Author: Jonathan Rivera
Date: December 22, 2023
Updated: September 2024
Audience: Everyone
Environmental details: Cloud
Summary
When running test executions and during other similar work, users are seemingly getting logged out randomly due to an expired session.
The error pop-up says:
"Got an invalid reply from a server that may be due to an expired session. You will be logged out."
Solution
Do not clear the browser cache and/or cookies.
This behavior can be easily replicated with the following steps, though this is not specific to test runs.
- Start a test run
- Do some routine work in the Execute Test window
- Clear browser cache (can be any browser window)
- Continue to work - Notice that it will still appear that you are still logged in.
- Please make sure to save your work or click on another page within the main Connect window.
- You will then see this message and be logged out:
Cause
If you clear your browser cache and cookies while using Connect, the session will end, resulting in a loss of work.
When this happens, it is not immediately apparent in the Execute Test window that you have been logged out. It will seem like you are working normally in this window until you save your work or click into a different window in Connect.
Prevention
Please don't clear the browser cache while using Connect.
Additional Information/Metadata
- Application performance logging
- View a system health report
- Logout
- Unresponsive
- Content disappearing
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