Pick List Field Not Populating After ReqIF Import in Jama Connect Interchange™

Helen Khoshnaw
Helen Khoshnaw
  • Updated
  • Jama Connect Interchange™ version 1.35
  • JCI Module: ReqIF

 

Summary

This article explains how to troubleshoot a ReqIF import where a pick list field imports as blank or does not appear to map correctly.

Symptoms

  • A field that is configured as a single-select or multi-select pick list in Jama Connect® does not populate after a ReqIF import.
  • The field appears mapped in the import configuration, but imported items show blank values for that field.

Common causes

  • Pick list (enumeration) values were not mapped (or not available) for the pick list field during import mapping.
  • Import configuration was not set up as expected for the specification’s container (Set vs Component), which can affect which item types/fields are applied during import.

 

Resolution

  1. In the ReqIF import mapping, map/populate the pick list values (enumerations), not just the field.
  2. During import, select the correct Container option in the Jama Connect Container drop-down (per your spec structure).
  3. Re-run the import and verify the field now populates after completion.

Additional Resources

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