Author: Sam Yerramalla
Date: October 29 2025
Audience: Jama Connect® Administrators
Environmental Details: Jama Connect®
Summary
This article addresses a scenario where the Delete Field button is disabled when editing an Item Type in Jama Connect®. It explains common causes such as field usage in existing items, locked system fields, or insufficient permissions. The article outlines steps to enable delete button to safely remove or replace fields without needing to recreate the entire Item Type.
Solution
By default, the Allow deletion of fields and data from item types option is turned off and can be managed through the Organization Admin Details tab.
Jama Connect® administrators will see the Delete Field button disabled, with a tooltip explaining the reason.
To enable this feature, under your Jama Organization Administratione screen, enable the field deletion option as shown below.
Once enabled, you should now be able to delete the fields as needed.
Cause
In Jama Connect® 9.24 software release a new setting is introduced allowing Jama Administators to enable or disable this feature. With this change, organization administrators now have control over whether fields in an item type should be disabled/enabled for deletion.
In the past, Jama Connect® Administrators could remove fields without fully understanding the potential impact on other teams or historical records. This update was designed to provide stronger oversight and protect important data from accidental loss.
Prevention
Remember that once it is enabled, any Jama Connect® administrator can delete any field data. Best practice is to enable this future momentarily and perform the required field deletion and disable the feature again to prevent accidental data loss.
Additional Information / Metadata /Resources
- Version 9.24 - Release Notes
- Peer-to-Peer Support Forum
- Delete or Update an Item Type's Field Without Losing Data
- Best Practice for Changing a Field Type
- Best Practice for Deleting Sample Data and/or Item Types
Feedback:
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