Errors Upgrading to v9.22.1 using the kURL Installer

Chris
Chris
  • Updated

Author: Chris Breaux

Date: June 2, 2025

Audience: Jama Connect® Administrators

Environmental details: Self-Hosted KOTS

Summary

Before upgrading to v9.22. x of Jama Connect, we must first upgrade all the back-end dependencies, which are managed through the Replicated KOTS platform. 
Version 9.22.1 — Self-hosted
This may precipitate a 'step-upgrade' of Kubernetes to get to the current version. However, installation errors can be encountered during this process.

[upgrade] Running cluster health checks
[upgrade/health] FATAL: [preflight] Some fatal errors occurred:
[ERROR CreateJob]: Job "upgrade-health-check-77lfx" in the namespace "kube-system" did not complete in 15s: no condition of type Complete
[preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...`
...
An error occurred on line 9131

Solution

The primary solution is to re-run the kURL installation script.

curl -sSL https://k8s.kurl.sh/jama-k8s-standardkots | sudo bash

If that is unsuccessful, you can further attempt a 'manual' upgrade with the following:

sudo kubeadm upgrade apply 1.31.7 --ignore-preflight-errors=all --kubeconfig /etc/kubernetes/admin.conf

Following this manual upgrade, you'll want to re-run the kURL installer once more and ensure everything comes up as expected.

Note: If kubectl If commands appear to hang or return no response, the Kubernetes API server may not be ready yet. Wait approximately 5 minutes before trying kubectl again or re-running the kURL installer if needed.

Cause

Depending on which version of Jama Connect (and its associated KOTS installer) you're running, there may be multiple steps of upgrading Kubernetes versions required. The failure we're seeing here is related to the availability of the kube api server when making the 'health' check. 
The likely cause of the 'delay' in availability is due to the resources on the application server. (These Kubernetes upgrades can be resource-intensive.) If your server only has the minimum required specifications (8 CPUs, 32GB RAM), then you are more likely to encounter this issue.

Prevention

The best ways to prevent this issue are:
1. Staying 'up-to-date' with new Jama Connect releases (to avoid 'step-upgrades' when running the KOTS installer)
("Follow" the Release Schedule for Jama Connect®

2. Increasing the resources on your application server from 'minimum' to 'recommended' values
(Jama Connect® v9.22.x User Guide)

Please feel free to leave feedback in the comments below.

 

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