Author: Chris Breaux
Date: 2025-05-14
Audience: Everyone
Environmental details: Cloud and Self-Hosted
Summary
You may encounter a situation where some field value is visible in the 'folder view' but not present in the actual 'item view.' Here is an example:
Solution
Try editing the field in question. You'll likely notice there are some additional 'styling' rules applied if you inspect the 'source'. Go ahead and remove the styling rules and save the item.
Cause
There is a difference in 'permissiveness' between our REST API and our UI when modifying rich text field values. If you were to try to add the same 'styling' rules via the UI, the ckditor would 'scrub' most of the applied values. However, fields modified via the REST API would 'allow' them.
Essentially, the styling rules are pushing the field value 'outside' of the normal range. Once the styling is removed, the value should become visible in the item view.
Prevention
Pay special attention to the field values you are creating/modifying via the REST API and ensure they do not contain any unnecessary styling rules.
e.g.
"<div style=\"-webkit-text-stroke-width:0px; background-color:transparent; box-sizing:border-box; color:#afafaf; font-family:Arial,Helvetica,sans-serif; font-size:13.33px; font-style:normal; font-variant:normal; font-weight:400; left:10px; letter-spacing:normal; margin-bottom:0px; margin-left:0px; margin-right:0px; margin-top:0px; orphans:2; padding-bottom:0px; padding-left:0px; padding-right:0px; padding-top:0px; position:absolute; text-align:left; text-decoration:none; text-indent:0px; text-transform:none; top:0px; white-space:normal; width:117px; word-break:break-all; word-spacing:0px\">Hello world.</div>"
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