MS SQL Server - SAML and OAuth pods are unable to connect to database

Riya Ray
Riya Ray
  • Updated

Author: Riya Ray

Date: November 2024

Audience: Everyone

Environmental details: Jama Connect and MS SQL Server (Database). 

Summary

When using MS SQL Server as the database server for Jama Connect, sometimes there have been issues getting the OAuth and SAML databases to connect, especially if multiple instances of SQL Server exist. 

Solution

To fix/ resolve this problem, the Jama Connect KOTS Admin console must be updated with the correct instance name.

  • Navigate to the Jama KOTS Admin console --> "Config"
  • Navigate to "Advanced Database Settings" --> "Database Connection Parameters"
  • Specify the Instance Name. See the screenshot below for example:

Cause 

MS SQL Server allows for the installation of multiple instances on the same server. However, when running KOTS, you should mention which instance of SQL Server is used by Jama Connect.

Prevention

When setting up/ configuring your Jama KOTS Admin console, update the Instance name if multiple instances of MS SQL Server are running on the same database server. 

Additional Information/Metadata

  • Troubleshooting
  • MS SQL Server configuration

 

 

 

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