KOTS - License signature is not valid: "endpoint" field has changed

Chris
Chris
  • Updated

Author: Chris Breaux

Date: March 26, 2024

Audience: Agents and Admins

Environmental details: Self-Hosted KOTS

Summary

This error is encountered when attempting to upload a license file during an installation.

Solution

Inspect the license.yaml In a text editor, the 'endpoint' value is used precisely. Currently, this should be endpoint: https://replicated.app

Cause

Some cybersecurity programs can 'read' and alter this license file. Here is an example of what it looked like when changed by one of these programs installed in the client's environment.

apiVersion: kots.io/v1beta1
kind: License
metadata:
name: k8customer-0017000000immqbaau-nonprod
spec:
appSlug: jama-k8s
channelID: 1kUIR8rwKEGe7rk5U7bhiDbd4dQ
channelName: StandardKOTS
customerName: k8customer-0017000000imMqBAAU-nonprod
endpoint: https://urldefense.com/v3/__https://replicated.app__;!!FIHMVlGrYVGa5kwGHCY!XhaT95oTkBaBUyOdqCVDJRE69Q17IKHYHFGY96CSUgynLUaadhUGIQUq_LLx5DAT9kswh01pO1qyjy1tB_bplsTD7vb-$

 

Prevention

Review the license.yaml for alterations or run a diff between the clients' license and one obtained from the Replicated vendor portal.

 

Please feel free to leave feedback in the comments below.

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