Pre-flight checklists experiencing database connection failures

Sravya Bandari
Sravya Bandari
  • Updated

Author: Sravya Bandari

Updated: June 2024

Audience: Everyone

Environment: Self-Hosted, Replicated - KOTS

Summary

This guide outlines the necessary steps to troubleshoot a pre-flight checklist failure for database connections before deploying on the replicated admin console.


Solution

  • Double-check to ensure the correct database details are entered into the admin console.
  • Verify the database setup, ensuring connectivity between the cluster and the database server.
  • For MySQL
    • kubectl run -i --tty --rm mysqlclient --image=mysql:8 --restart=Never -- bin/bash
      (This will place you within a new terminal window connected to the MySQL pod. Use the following command to establish a connection to the database server)
    • mysql --host=<mysql-hostname> --user=<username> --password=<password>
  • For MSSQL
    • kubectl run -i --tty --rm mssqlclient --image=mcr.microsoft.com/mssql-tools:latest --restart=Never -- bin/bash
      (This will place you within a new terminal window connected to the MSSQL Tools pod. Use the following command to establish a connection to the database server)
    • sqlcmd -S <mssql-hostname> -U <username> -P <password>
  • Also, could you please verify the connectivity of the specified username and credentials using the commands provided below?
    • mysql -u <<jamausername>> -p "defined password"
      mysql -u <<oauthusername>> -p "defined password"
      mysql -u <<samlusername>> -p "defined password"
  • Update the usernames and credentials as needed.

Cause

Entering incorrect database names, usernames, and passwords on the configuration page can lead to this issue.

 

Feedback: Please leave feedback in the comments below.

 

Related to

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.