LDAP is working, but LDAPS cannot connect

Jason Ritz
Jason Ritz
  • Updated

Author: Jason Ritz 

Date: December 7th, 2023

Audience: Everyone

Environmental details: Self-Hosted

Summary: 

LDAP is set up and working, but when switching to LDAPS, the connection to the LDAP server fails.

Solution:

  1. Add the LDAPS server certificate to the "Trusted Certificates" Field in the Replicated admin console.
  2. Restart/Redeploy the Jama Connect application.

 

Replicated Admin Console for KOTS installs 

Screenshot 2024-12-05 at 11.40.31 AM.png

 

Replicated Admin Console for Docker installs 

image001.png

You can append the LDAPS certificate to any existing trusted certificates if they are PEM formatted.

Cause:

The LDAPS certificate needs to be added to the Java keystore so the application knows to trust the connection to the LDAPS server. 

Feedback: Please leave feedback in the comments below.

 

Related to

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.