Author: Jason Ritz
Date: December 6th, 2023
Audience: Everyone
Environmental details: Self-hosted
Summary:
After running for some time, indexing fails. We can see the following message in the logs:
There was an error while indexing a chunk. It's been bisected down to a single problematic object:
Solution:
Add the following line to the advanced startup settings in the admin console and restart/redeploy the application.
reindexBrokenItemThreshold=100000000
Cause:
This error occurs when the number of items Elasticsearch can't parse exceeds the threshold of broken items.
Elasticsearch cannot parse items that cannot be searched, such as images and zip file attachments.
Feedback: Please leave feedback in the comments below.
Related to
- Authentication
- Relationships
- Administration
- Testing
- REST API and extensibility
- Reports
- Microsoft Word
- Microsoft Excel
- Installation
- Migration
- Coverage and traceability
- Traditional
- Jama Connect Interchange™
- Customer-Validated Cloud
- Security
- Diagram/Graph Editor
- Jama Software® Subscriptions Maintenance and Support Service Agreement
- Jama Connect®
- Supported
- Index
- Fails
- Error
- Item Configuration
- Deployment Migration
- Integrations
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