Author: Jason Ritz
Date Published: 2023-12-06
Last Updated: September 2025
Audience: Everyone
Environment: Self-hosted, Replicated – KOTS
Summary
After running for some time, indexing fails. We can see the following message in the logs:
There was an error while indexing a chunk. It's been bisected down to a single problematic object:Solution
Add the following line to the advanced startup settings in the admin console and restart/redeploy the application.
jamasearch.multithreadindex.chunksize=1000
jamasearch.reindexBrokenItemThreshold=10000000
jamasearch.multithreadindex.poolsize=10
If the issue is causing errors on startup, after adding the above config do the following.
Run
kubectl delete sts/core sts/activemq sts/hazelcast sts/elasticsearch pvc/volume-elasticsearch-0
- Redeploy from the admin console
- Initiate a full reindex from the root menu
Cause
This error occurs when the number of items Elasticsearch can't parse exceeds the threshold of broken items.
Elasticsearch cannot parse items that cannot be searched, such as images and zip file attachments.
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