Author: Sravya Bandari
Date: 29 September 2025
Last Updated: January 2026
Audience: Everyone
Environment: Self-hosted, Replicated - KOTS
Summary
This article outlines the steps to resolve an issue where scheduled jobs are missing from the Scheduled Jobs section in the root menu. This issue may occur after an upgrade or refresh of the Jama Connect® instance.

Solution
Note: The steps below require scheduled application downtime. Please ensure proper planning to minimize impact.
Root-re-index the Jama Connect® Application
From the Root Menu, perform an index of the application.
2. Verify if Jobs Appear
If scheduled jobs still do not appear, please go ahead with the following steps .
3. Run CLI Command on the Application Server
Log in to the Application Server CLI and run the following command:
kubectl delete sts core hazelcast activemq Cause
4. Redeploy via KOTS Console
Access the Jama KOTS console and redeploy the current version of Jama.
Cause
This situation may occur due to one of the following reasons:
A full re-index is still pending after the upgrade.
The ActiveMQ directory has become full.
Additional Information/Metadata
Always perform an index after each upgrade step.
Confirm the index completes correctly by reviewing
contour.log.
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