Failed License Upload During KOTS Install

Daniel Sardina
Daniel Sardina
  • Updated

Author: Daniel Sardina

Date: March 28, 2025

Audience: Everyone

Environmental details: Self Hosted, Replicated - KOTS

Issue 1: Error During Manual License Sync

When installing KOTS for a manual license sync, the following error can present itself

- Deploying Admin Console
- Waiting for Admin Console to be ready ✓
- Waiting for for installation to complete ✗
Error: failed to validate installation: failed to get latest license: failed to get license
from api: failed to execute get request: Get "https://replaced.app/license/jama-k8s": dial 
tcp: lookup replicated.app on 10.96.0.10:53: server misbehaving

Solution

Restart the kube-system core dns deployment

Check deployments across all namespaces:

kubectl get deployment -A


Restart the CoreDNS deployment

kubectl -n kube-system rollout restart deployment coredns

Cause

Issues with the CoreDNS deployment that can stem from the initial installation
 

Issue 2: Error When Manually Uploading a New KOTS License

Additionally, the following error can arise when attempting to manually upload a new KOTS license

• Checking for license update ✓
  • Deploying application
  • Waiting for Admin Console to be ready ✓
  • Waiting for installation to complete ✗
Error: failed to validate installation: failed to create online app: failed to pull: failed to fetch upstream: download upstream failed: failed to download replicated app: unexpected result from get request: 404

Solution

Reattempt the installation without the license or config parameters

kubectl kots install jama-k8s/standardkots --app-version-label=<desired app version>


Provide the license when prompted via the GUI.
Once you have access to the admin console, use the CLI to set and deploy your saved configuration file.

kubectl kots set config jama-k8s -n default --config-file /path/to/your/config.yaml --deploy

Cause

There can be a 'mismatch' between the 'desired app version' in the installation command and the 'actual' version available to your license. Contact Jama Support and check if your license has been 'pinned' to a specific version

Additional Information/Metadata

Troubleshooting Areas:

  • KOTS
  • DNS
  • Licensing
  • Redeployment

Related Resources:

Please feel free to leave feedback in the comments below.

 

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