Failed License Upload During KOTS Install

Daniel Sardina
Daniel Sardina
  • Updated

Author: Daniel Sardina

Date: March 28th 2025

Audience: Everyone

Environmental details: Self Hosted KOTS

Summary

When installing KOTS for a manual license sync, the following error can present itself

- Deploying Admin Console
- Waiting for Admin Console to be ready ✓
- Waiting for for installation to complete ✗
Error: failed to validate installation: failed to get latest license: failed to get license
from api: failed to execute get request: Get "https://replaced.app/license/jama-k8s": dial
tcp: lookup replicated.app on 10.96.0.10:53: server misbehaving

Solution

Restart the kube-system core dns deployment

Check deployments across all namespaces:

kubectl get deployment -A


Restart the CoreDNS deployment

kubectl -n kube-system rollout restart deployment coredns

Cause

Issues with the CoreDNS deployment that can stem from the initial installation

Additional Information/Metadata

  • Troubleshooting
  • KOTS
  • DNS
  • Licensing
  • Redeployment

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