Deleted Items are Visible in the UI

Jonathan Rivera
Jonathan Rivera
  • Updated

Author: Jonathan Rivera

Date: December 6, 2023

Audience:  Everyone

Environmental details: Self-hosted and Cloud

Summary: 

After deleting items, the items are still visible in the UI. Users may encounter some of the following situations:

  • Users cannot select an item from the Explorer Tree or within search or filter results, and are prompted with "This item has been deleted"
  • Users cannot select an item from the Explorer Tree or within search or filter results, and are prompted with "You don't have permission to perform this action"
  • The hierarchy sequence of the Explorer Tree is inconsistent with the List View
  • An item cannot be located in the Explorer Tree even though it can be seen in the List View
  • Batch deleted items remain in the Explorer Tree or show up in filter results

Solution:

  1. Perform a project cleanup as described here: 

Cause:

This is known to happen when creating a lot of items and deleting them, especially when other work is occurring at the same time. This is particularly prevalent when utilizing the API to do this work rapidly.

 

Prevention:

There is no a surefire way to prevent this, but we typically recommend to users to slow down the API work and perform checks along the way.

 

Additional Information/Metadata:

  • API
  • Deleting items

Feedback: Please leave feedback in the comments below.

 

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