Author: Alexander Cerrato
Updated: January 2025
Audience: Everyone
Environmental details: Self-hosted and cloud customers
Summary
While editing a test cycle, the browser tab is closed, causing the test cycle to be Locked.
Solution
A user account with a creator license must log in and edit the cycle details, make any necessary changes, and click on "Save" in the editor modal window.
1. Login with a user account with a creator's license.
2. While in test runs, view to the right of the test cycle, click on the dropdown menu.
3. Select the "Edit details" option.
4. If necessary, change any fields in the "Edit cycle details" modal window and click the save button at the bottom right.
Cause
The cycle is locked while editing its details to reserve editing privileges exclusively for the current user account. This ensures that only one user account can edit the test cycle at a time. When the browser tab is closed, the reservation is kept, and the locked state is not changed back to the unlocked state.
Prevention
Do not close the browser tab or window while editing the cycle.
Related Articles, Work orders, Zendesk tickets, Defects, etc.
Additional Information/Metadata
- Test cycle
- Test runs
- Locked status
- Browser functions
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