How to unlock a test cycle after browser tab being closed during editing

Alexander Cerrato
Alexander Cerrato
  • Updated

Author: Alexander Cerrato

Updated: October 2024

Audience: Everyone

Environmental details: Self-hosted and cloud customers

Summary

While editing a test cycle, the browser tab is closed, causing the test cycle to be Locked. 

Solution

A user account with a creator license will need to log in and edit the cycle details, perform any change if needed and click on "Save" in the editor modal window.

1. Log in with a user account with a creator's licenses.
2. While in test runs view to the right of the test cycle click on dropdown menu.
3. Select the "Edit details" option.
 
4. Change any fields in the "Edit cycle details" modal window if needed and click on the save button on the bottom right.


Cause

The cycle is locked while editing its details to reserve editing privileges exclusively for the current user account. This ensures that only one user account can edit the test cycle at a time. When the browser tab is closed, the reservation is kept, and the locked state is not changed back to the unlocked state.

Prevention

Do not close the browser tab or window while editing the cycle.

Related Articles, Work orders, Zendesk tickets, Defects, etc.

Additional Information/Metadata

  • Test cycle
  • Test runs
  • Locked status
  • Browser functions

 

Please feel free to leave feedback in the comments below.

 

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