Scheduled Jobs not running after Upgrading Jama Connect®

Kellen Fields
Kellen Fields
  • Updated

Author: Kellen Fields

Updated: June 2024

Audience: Everyone

Environmental details: Self-hosted Replicated - Traditional/Native channels

Summary

After performing an upgrade of Jama Connect, no scheduled jobs are running and none appear in the 'Scheduled Jobs' section of the root menu.
scheduled job.png

Solution

First, perform an index of the Jama Connect Application from the Root Menu.

  1. If the jobs still do not appear, continue with these steps. 
  2.  Clear cache - Login to UI as root.  Select Cache statistics.  Then select Clear all cache.
  3. Stop Jama - From the App server, run:  replicatedctl app stop --attach
  4. Remove /data/activeMQData folder.  -  From the App server, run: sudo rm -rf  /data/activeMQData
  5. Start Jama  - From the App server, run: replicatedctl app start 

Cause

This can happen if a full re-index still needs to be completed after the upgrade or if the ActiveMQ directory becomes full during that process.

Prevention

Perform an index after each upgrade step and make sure it completes correctly via the contour.log

 

 

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