Scheduled Jobs not running after Upgrade

Kellen Fields
Kellen Fields
  • Updated

Author: Kellen F.

Date: April 20, 2023

Audience: Everyone

Environmental details: Native Self-hosted

Summary: 

After performing an upgrade of Jama Connect, no scheduled jobs are running and none appear in the 'Scheduled Jobs' section of the root menu.
scheduled job.png

Solution:

  1. First, perform an index of the Jama Connect Application from the Root Menu
  2. If the jobs still do not appear continue with these steps. 
  3.  Clear cache - Login to UI as root.  Select Cache statistics.  Then select Clear all cache.
  4. Stop Jama - From the App server, run:  replicatedctl app stop --attach
  5. Remove /data/activeMQData folder.  -  From the App server run: sudo rm -rf  /data/activeMQData
  6. Start Jama  - From the App server, run: replicatedctl app start 

Cause:

This can happen if a full re-index is not completed after the upgrade, or if the ActiveMQ directory because full during that process

Prevention: Index after each upgrade step and make sure it completes correctly via the contour.log

 

 

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