Supported Software for Jama Connect® Self-Hosted 9.0.x

Carly Rossi
Carly Rossi
  • Updated

Server Components (KOTS)

Jama Connect self-hosted does not support high availability configurations. We recommend using snapshotting via your VM or taking nightly database backups in order to manually restore the application. We do not support making changes to Replicated outside of the replicated admin console web-UI.
 

Required System Specifications

See the following pages in Jama Connect User Guide to determine data size thresholds and scale adjustments to your environments accordingly:

 

Operating Systems

Jama Connect can be installed on any Linux distribution supported by Docker CE.

We regression-test against the following distros:

  • Red Hat 8.4, and 8.6

    • RHEL 8.x requires Containerd
  • Ubuntu 20.04, and Ubuntu 22.04

    • To use Ubuntu 22.04, you must update the memory or Elasticsearch fails.

      • From the KOTS Admin Console, adjust the memory settings so that Maximum Memory is 6G and Maximum Memory for Container is 8G

*We have ended support for CentOS with this Spring release. 

 

Database Servers

The database must be hosted on a server separate from the Jama Connect application. This server can host other databases, but we do not support other applications running on the same server as the database.

  • MySQL 8*

  • Microsoft SQL 2017, 2019, and 2022.

    • We do not support the use of the Azure database, as this is not tested. 

We do not support custom configurations of Jama Connect databases. Customizations such as query optimization and additional indexes that are not shipped with Jama Connect will not be supported. We do not expect any difference in customers’ database configuration, setting, indexes, triggers and etc. from what we regression test.


*We have ended support for MySQL 5.7 in order to provide extensive performance improvements brought about by rearchitecting areas of Jama Connect.

 

Browsers

Note that browser zoom is supported only at 100%. Use of browser extensions/add-ons or the enablement of Compatibility View is not supported while using Jama Connect. To prevent session issues, the application should be used in a single browser window. 

  • Edge Chromium

  • Firefox**

  • Google Chrome**

  • Safari**

**We will support versions released over the past 12 months.

 

Supported Word Processor and Spreadsheet Programs for Exports and Reports

  • Office 365 for Mac

  • Office 365 for Windows

 

MathType Equations Editor

Supported Versions: 7.7.1.6472 and 7.6.1.6408

 

Authentication

  • Crowd 5.0.2

  • LDAP

  • SAML

  • Auth0 (cloud-only)

See Authentication Options for Self-Hosted and Cloud Users (LDAP, AD, Crowd, SSO, SAML) for more information. 

 

Related to

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.