The application server fails to start after the database restarts.

Riya Ray
Riya Ray
  • Updated

Author: Riya Ray, Jason De Paola

Updated: June 2024

Audience: Everyone

Environment: Self-hosted, Replicated - KOTS

Summary

If the database server is turned off or restarted for any reason (planned or unexpected), the App server may not come up. In this case, we must execute the KOTS shutdown and startup scripts because the application may not have recovered from the database switch event. 

Solution

  1. Ensure your database server is up and running.
  2. On the Jama application server, run the below commands:
sudo /opt/ekco/shutdown.sh
sudo /opt/ekco/startup.sh

It may take some time for all the pods to come up. To monitor the pods, you can use the following command:

watch kubectl get pods
(Ctl-c to exit the watch)

Cause

Because of the improper shutdown of the database server, the application session may have also terminated abruptly. 

Prevention

Ensure the database server is running before starting/ deploying the Jama KOTS App Server.

 

Feedback: Please leave feedback in the comments below.

 

Related to

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.