Author: Jonathan Rivera
Date: July 28, 2023
Audience: Customers, and/or Agents and Admins
Environmental details:
Problem/Summary:
Replicated and Docker are on mismatched versions and/or not supported on the desired version of Connect.
Solution:
- Export the current Replicated settings. This will take out the guesswork of trying to reconfigure the Admin Console with prior settings, and you can use this config file to quickly re-import settings after Replicated is reinstalled.
Run this command on the application server:replicatedctl app-config export --hidden > replicated.config
- Fully uninstall Replicated by running the following commands on the application server:
systemctl stop replicated replicated-ui replicated-operator
service replicated stop
service replicated-ui stop
service replicated-operator stop
docker stop replicated-premkit
docker stop replicated-statsd
docker rm -f replicated replicated-ui replicated-operator replicated-premkit replicated-statsd retraced-api retraced-processor retraced-cron retraced-nsqd retraced-postgres
docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs sudo docker rmi -f
docker images | grep "registry\.replicated\.com/library/retraced" | awk '{print $3}' | xargs sudo docker rmi -f
yum remove -y replicated replicated-ui replicated-operator
rm -rf /var/lib/replicated* /etc/replicated* /etc/init/replicated* /etc/default/replicated* /etc/systemd/system/replicated* /etc/sysconfig/replicated* /etc/systemd/system/multi-user.target.wants/replicated* /run/replicated - Uninstall Docker. For this step, we refer customers to the Docker documentation to find steps relevant to their system. Typically, we expect self-hosted customers to be familiar enough with Docker to perform this step.
- Verify Docker is no longer installed by running this command on the application server.
docker version
- Reinstall Replicated by running the following command on the application server. This will also install the correct version of Docker.
Note: Make sure to replace <REPLICATED_VERSION> with the desired version. For example, 2.53.2.
curl -sSL "https://get.replicated.com/docker?replicated_tag=<REPLICATED_VERSION>&replicated_ui_tag=<REPLICATED_VERSION>&replicated_operator_tag=<REPLICATED_VERSION>" | sudo bash -s no-auto
- Check that Docker is on the desired version by running this command on the application server.
docker version
- Import the previously exported Replicated settings.
replicatedctl app-config import < replicated.config
- Navigate to the Admin Console and start Jama Connect
Cause:
This is typically the result of missing a step during the installation process, such as upgrading Connect without first running the curl command to upgrade Replicated. We have also seen mismatched Docker versions occur as the result of upgrades to Docker being done outside of the Replicated curl process.
Resolution:
By following the steps outlined above, you can reinstall Replicated and Docker to achieve the correct versions and align with supported software.
Prevention:
Follow our documentation when upgrading Connect. Customers should avoid upgrading Docker beyond supported versions.
Related Articles, Work orders, Zendesk tickets, Defects, etc.
- https://docs.docker.com/engine/install/
- Jama Connect User Guide | Install Replicated Admin Console
- Supported Software, Environments and System Requirements
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