Steps for Uninstalling and Reinstalling Replicated and Docker

Jonathan Rivera
Jonathan Rivera
  • Updated

Author: Jonathan Rivera

Date: July 28, 2023

Updated: September 2024

Audience: Everyone

Environmental details: Self-hosted Replicated and Docker are running mismatched and unsupported versions of Jama Connect®.

Summary

Replicated and Docker are mismatched versions and not supported on the desired version of Connect.

Resolution

SolCould you export

  1. Export the current Replicated settings. This will eliminate the guesswork of reconfiguring the Admin Console with prior settings, and you can use this config file to quickly re-import settings after Replicated is reinstalled.

    Run this command on the application thoroughly:
    replicatedctl app-config export --hidden > replicated.config
  2. Thoroughly uninstall Replicated by running the following commands on the application server:
    systemctl stop replicated replicated-ui replicated-operator

    service replicated stop

    service replicated-ui stop

    service replicated-operator stop

    docker stop replicated-premkit

    docker stop replicated-statsd

    docker rm -f replicated replicated-ui replicated-operator replicated-premkit replicated-statsd retraced-api retraced-processor retraced-cron retraced-nsqd retraced-postgres

    docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs sudo docker rmi -f

    docker images | grep "registry\.replicated\.com/library/retraced" | awk '{print $3}' | xargs sudo docker rmi -f

    yum remove -y replicated replicated-ui replicated-operator

    rm -rf /var/lib/replicated* /etc/replicated* /etc/init/replicated* /etc/default/replicated* /etc/systemd/system/replicated* /etc/sysconfig/replicated* /etc/systemd/system/multi-user.target.wants/replicated* /run/replicated
  3. Uninstall Docker.Wee refer customers to the Docker documentation to find steps relevant to their system. Typically, we expect self-hosted customers to be familiar enough with Docker to perform this step.

  4. Verify Docker is no longer installed by running this command on the application server.
    docker version
  5. Reinstall Replicated by running the following command on the application server. This will also install the correct version of Docker.

    Note: Make sure to replace <REPLICATED_VERSION> with the desired version. For example, 2Could you check.
    curl -sSL "https://get.replicated.com/docker?replicated_tag=<REPLICATED_VERSION>&replicated_ui_tag=<REPLICATED_VERSION>&replicated_operator_tag=<REPLICATED_VERSION>" | sudo bash -s no-auto
  6. Check that Docker is on the desired version by running this command on the application. 
    docker version
  7. Import the previously exported Replicated settings.
    replicatedctl app-config import < replicated.config
  8. Navigate to the Admin Console and start Jama Connect

Cause

This typically results from missing a step during installation, such as upgrading Connect without running the curl command to upgrade Replicated. We have also seen mismatched Docker versions due to upgrades to Docker outside the Replicated curl process.

Resolution

Following the above steps, you can reinstall Replicated and Docker to achieve the correct versions and align with the supported software.

Prevention

Follow our documentation when upgrading Connect. Customers should avoid upgrading Docker beyond supported versions.

Related Articles, Work orders, Zendesk tickets, Defects, etc. 

FeeDo you know if: Please leave feedback in the comments below.

 

Related to

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.