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Welcome to Jama Connect

Jama Connect is a centralized web application that helps you manage the development of new prod-
ucts. It manages all aspects of product development, including requirements, reviews, and testing.
Jama Connect also records test results and manages risk while maintaining regulatory compliance.

As a new user or trial user, read through this section to learn how Jama Connect can change the way
you work and can enhance your product development process. We want to answer all your "What do I
need to get started?" questions.

This information isn’t linear — feel free to scan through and jump to the different areas that are most
interesting to you.

The right tool at the right time

 

This guide contains information about a self-hosted release of Jama Connect. If you're a system
administrator new to Jama Software you can skip straight to the system administrator section [489].
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Get started

To start using Jama Connect, you need your user account credentials.

• Trial account — Sign up for a free trial at https://www.jamasoftware.com/platform/jama-connect/trial/
• New user account — Your administrator has your account username and password

As a new user of Jama Connect, this is the place to start: log in and get familiar with the different areas
of the workspace.

To log in to Jama Connect:

1. In a supported web browser, enter the URL provided by your administrator.
2. Type your username and password, then click Log in.

Header — Includes the main sections (Stream, Projects, Reviews, Risk, Admin) of the Jama
Connect interface.
Home — Shows links to your most relevant content like bookmarks, recent views, open views,
stream comments, and actions.

Quick tips

• You're allowed 10 login attempts within five minutes before you're locked out for 30 minutes. To
unlock your account before then, follow the forgotten password procedure.

• To manage your account, select your name in the top right navigation to open the My Profile window.
• To log out of the application, click Log Out in the top right corner. If you don't log out, the system logs

you out after two hours.
• Bookmark projects, containers, sets, and folders so they appear under Bookmarks and Recently

viewed sections. Having it appear in both places allows you to keep track of recently viewed items
even if you remove the bookmark.
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Exploring the Jama Connect workspace
The Jama Connect workspace is where you set up and manage your projects, create test plans,
communicate with your team, track relationships, and more.

You can also view these short videos to learn the Jama Connect basics: how to navigate the system,
add and edit information, build in traceability, send information for review, and collaborate with your
project team.

The workspace is divided into five panes that you can expand, collapse, and resize.

1. Explore and manage projects — Select the tabs at the top of the left panel to expand these
views: Explorer, Filters, Releases, Baselines, and Test Plans.

2. View item details — View the details for specific items. Content from Components, Sets, Folders,
Filters, and individual items are displayed in this pane.

3. Create trace relationships — Add relationships between items for traceability or add items to a
change request. Open this section from the Relationships tab and close it when it's not needed.

4. Manage item information — Manage information associated with comments, relationships, at-
tachments, versions, and activities.

5. Use keywords to navigate the workspace — Navigate to items grouped by keywords.

Jama Connect is highly configurable, so you can customize the workflow to work best for you. For
example, focus on creating requirements from the Explorer Tree, view details about a test case, or
explore relationships. Depending on the task or goal, you might interact with one area or all areas of the
workspace.

Navigation
These links can help you find your way around Jama Connect:

• Explorer Tree [50]
• Toolbar [51]
• Side toolbar [60]
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Views
You can choose how you view your selected items in the center panel. Each view is suited to a different
type of work.

• Single Item View [59] — Displays the information about one item in the center panel.
• List View [54] — Shows data from multiple items in a table with a different field in each column so

you can sort, select, and compare items at a glance.
• Reading View [55] — Shows both text and images for a group of items so you can read through

selected items like a document.
• Document View [55] — Provides a streamlined authoring and editing experience. Like other author-

ing tools, you can create, edit, and read items all in one view — no need to switch views for each
function.

• Trace View [58] — Shows related upstream and downstream items, missing relationships, and item
details in context of their relationship.

• Compare View [61] — Shows side-by-side content so you can compare differences between item
versions.

Project approach and tree structure
Jama Connect is made up of projects and uses a tree approach, which allows users to easily organize
content and view the content of each project.

What is a project?
Think of a project as a virtual container or “workspace” of information. Each project relates to a product
you are creating or a software application you are developing.

Why have a project?
Projects allow you to organize content and apply permission schemas. For example, a user might be
able to create and edit requirements in Project A, but you might not want them to see content in Project
B.

Projects are created by the Jama Connect admins at your organization, who also control corresponding
permissions for each project.

At a high level, each Jama Connect environment can contain multiple projects. Typically, a single
project in Jama Connect relates to a single product or a single version of a system that you are building.

Monitoring your project
Within a Jama Connect project, you can track releases/phases, baselines, test plans, and results. As a
project or organization admin, you can also create a project dashboard [410] to track the data your team
wants to monitor for quality and progress. For more information, see Working with dashboards [408].

Jama Connect User Guide

12



How do I access my project?
To open a single project, select Projects in the header. If you’re already in a project, click Change
project.

Advantages of projects and tree structure
Jama Connect projects and the Explorer Tree are highly configurable, which allows your organization to
adapt the solution to fit your own unique hierarchy and development process.

We also have several templates to get your team started. This allows your organization to:

• Standardize methodology across different teams
• Decrease context switching when working across multiple projects
• Enable reuse of shared requirements

Organizing your content
Each project has its own Explorer Tree, which displays project items in a hierarchical structure. Think of
the tree like your filing cabinet.
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Within the Explorer Tree you have access to several tools to organize your content:

• Component — A structural container used to organize a project into more manageable pieces.
For example, if your project represented an automobile, typical components in your Jama Connect
project might be: “Vehicle Airbag System” or “Emergency Braking System.” Below these components
in the Explorer Tree are all requirements and test sets that make up the subsystems for a car.

• Set — A container that defines groups of items of a single item type. Sets can exist at the top of a
project tree or nested under the components.
For example, in our “Emergency Braking System” component we might have a set of “System
Requirements” and a separate set of “Verification Tests.”  Typically, requirements documents (Product
Requirements, Functional Requirement specifications) translate in Jama Connect as a set.

• Folder — A way to organize items within a set.
• Items — The granular types of content in Jama Connect.

For example, a single requirement is an item. A single test case is an item. You can configure
multiple item types in Jama Connect.

Learn more about projects and Explorer Tree

• Projects at a high level [634]
• Configure Explorer Tree settings [47]

Item-based product development
Jama Connect is a product development platform that is database driven.

Why do we use items instead of documents? Several reasons:

• Version control — Track changes and feedback at an individual item level, whether the item is a
requirement, a risk, a test, or even project documentation.

• Data integrity — Quickly search, filter, and create dashboards to view progress based on item
attributes. Documents don’t allow for this functionality and often have data integrity issues.

• Time savings — Save time by not having to manually maintain IDs and trace links in a document. In
Jama Connect, traceability is a by-product of the way you work.

• Review efficiency — Focus on smaller, more iterative item reviews. Users no longer have to wait for
entire documents to be submitted before they can provide feedback. Get to market quicker!

• Auditing quality — With a few clicks, identify items that are missing coverage throughout the
product development process. Coverage is the extent to which items are validated by another item.

The shift from a document-based approach to item-based is key to the value of Jama Connect. Your
team's methodology directly influences how you set up and configure your Jama Connect environment
with different item types.

The following diagram illustrates how to shift from a document-based approach to an item-based
approach using Jama Connect.  

• Identify the documents and content that need to live in Jama Connect.
• Determine the item types that exist in those documents. For example, item types might be system

requirements, use cases, or test cases. Item types must have defined relationships in Jama Connect,
which you can specify with a relationship rule.

• Configure a project structure, then build your content. You can import existing documentation or
author directly in Jama Connect.
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The following diagram is a typical relationship model in Jama Connect that adheres to a Systems Engi-
neering Methodology (SEM). In it, a box represents a single item type and lines represent relationships.

Your team's development methodology comes into play here, for example classic vs. agile methodolo-
gy. While some teams use only one method, many teams use a combination.

Each method might use different terms. For example:

Classic Systems Engineering Agile Methodology

• System Requirement
• System Architecture
• High-Level Requirement
• Low-Level Requirement

• Strategic Themes
• Epics
• User Stories

Traceability from Requirements to Test
Traceability shows the relationship between items that depend upon and define each other. You can
travel upstream or downstream to get more context and trace product definition from high-level require-
ments all the way through to final tests.

Relationships in Jama Connect are established between discrete items. For example, Stakeholder
Requirement A is related to System Requirement X.

Benefits of establishing relationships
Why are relationships important in Jama Connect?

• Allocation — Understand which systems and subsystems implement the requirements.
• Traceability — Break down high-level requirements into more detailed specifications.
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• Verification — Improve implementation and quality by linking requirements to tests and their results.
• Impact analysis — When requirements change, identify and understand the ripple effect to lower-

level requirements and testing.

Relationship rules are applied to projects to drive compliance to your organization’s model and method-
ology. Setting up relationship rules for your item types is critical because it enforces the methodology
your organization wants to use in Jama Connect.

Jama Connect uses the terms “upstream” and “downstream” to describe relationship direction. When
upstream items change, their downstream items are flagged as “suspect” so that you can review any
impact the change might have.

How to establish a relationship

1. Navigate to a single item in your project such as a user need or a requirement.
2. Click Add related and select the item type you want to add.

Jama Connect opens a new window where you configure the item relationship.
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3. Click Save and Close.

The original item (Requirement) and the new item (Verification) are now linked with a trace relationship.

View and add relationships

• To view relationships, click the Relationships widget in right corner of the item.
• To add more relationships, click Relate Items.

To learn more about adding relationships, see Relationships [309]

What's next
Once you establish relationships, the Trace View in Jama Connect is a great way to view a live trace
matrix [316]. You can also filter and extract views of your traceability.

Trace view:
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Tracking changes in your project
Throughout product development, being able to track changes is critical, along with details and context
that led to the change, specific version differences, and stakeholders involved with and affected by the
changes. Jama Connect gives you the ability to capture all of these details.

Jama Connect has two effective ways to track changes:

• Versions — Capture changes at an item level. For example, a single requirement might have
multiple versions as well as associated change comments.

• Baselines — Capture a point-in-time snapshot of a group of items. Create a baseline to preserve a
version of an entire Jama Connect project or set of approved items.

Version changes
A new version is created each time you make changes to an item. In the bottom panel of the interface,
you can compare versions or make a past version current.

Changes to a single item
In the following screenshot, you can see how Jama Connect compares differences between multiple
versions of an item. The example engineering requirement has two versions. In the bottom panel, you
can also see who made the change, any change details, and any change comments. Get the complete
context of change from just this one screen!
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Version Compare view
This next screenshot shows the differences between two versions of a requirement. Individual field
differences are shown and highlighted in red (removed content) and green (added content), making it
easy to see what might have changed.

Changes to several items in a baseline
This screenshot shows a baseline in Jama Connect, which is a snapshot of several items.

Jama Connect provides users with the ability to identify and assess these changes between different
baselines from the baseline Document View compare feature, baseline Comparison Summary, and
default reports.

How reviews work
Ever feel like work is harder than it should be? Multiple revisions of a document get emailed around;
conflicting or out-of-sequence feedback on shared documents; time-consuming and costly review meet-
ings. Sound familiar?
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Jama Connect alleviates these pain points with its review features.

• Everyone is automatically included in the latest revision.
• Reviewers can simultaneously log their feedback and approvals.
• All feedback is associated with a specific revision of the document.
• Easily filter and view only the items that need additional review or feedback.

Reviews are critical to improving requirements and test quality and in increasing the shared understand-
ing among the teams that are engineering and implementing the requirements. Most item types in Jama
Connect can be sent to a review.

Review roles: who does what?

• Moderator — (Content owner) Starts the review and facilitates the discussion.
• Reviewer — Contributes to the discussion.
• Approver — Signs off and approves items in review.

Who can start a review?
Users with a Creator license and necessary permissions to author and edit in the project can start and
moderate a review.

What's involved in a review?
Here’s what a typical workflow looks like.
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1 Define what gets reviewed Before starting a review, determine which set or folder of items you want to send for
review. You can select an entire document or particular sections only, which allows for a
more agile and iterative review. A review can be started from a location, filter, release,
baseline, or test plan.

2 Start the review If leveraging Jama Connect workflow functionality, set the status of items to “Review:”
right-click on the Explorer Tree location and select Send for review. If starting from a
filter, release, baseline or test plan, right-click the name and select Send for review. Jama
Connect loads the review setup wizard, where you can configure the review deadline and
invite Reviewers and Approvers.

3 Monitor progress When the review is initialized, Reviewers and Approvers receive an email invitation to
participate. They work concurrently, adding comments and marking items “Approved” or
“Rejected.” As moderator, you can track participant progress and respond to comments.

4 Incorporate changes As moderator, you edit and incorporate feedback from the participants. You are then
prompted to publish a new revision of the review.

5 Close the review Reviews close when the review deadline is reached or when the moderator closes the
review manually. You can close the review for feedback, finalize the approval review, or
mark the review as finalized.

Reviews can always be reopened to publish new revisions and review what has changed.

Best practices

• Facilitate a review before a Requirement is moved to “Approved” or “Rejected” status.
• Focus on small, iterative reviews with fewer than 200 requirements per review. A large requirements

document can be difficult to consume.
• It’s OK to have lots of review revisions; approvers are always included in the latest revision.
• Offer guidance on the type of feedback you need.

Create a review
You can create a review for any group of items in a project. And you can start a review from several
places in the Jama Connect interface.

Regardless of where you begin, the process is the same through an easy-to-follow wizard.
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1. Select Reviews, then select Start a review.

The wizard opens to the Definition page.
2. Follow the prompts in the wizard to define your review. The pages of the review are:

3. Click Initiate review.

Learn more about reviews
For details about how to create and use reviews, explore these topics in the User Guide:

• Review moderator [165]
• Compare versions [202]
• Filter or search the review workspace [195]
• Organize and find review comments [193]
• Review Education Resources from Community site
• Review Center FAQ from Community site

Exporting documents from Jama Connect
While Jama Connect alleviates many pain points around managing documents, you might still need to
create documents to share with your customers, quality teams, or auditors.

The basics
With Jama Connect, you can easily create documents using our standard export to Word and Excel or
by creating your own custom office templates.

You can export the items that appear in your Jama Connect view with these export options:
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Beyond the basics with Office templates
If you need more than what the default Office templates provide, you can customize a template to suit
your project. For details about how to create a custom Office template:

• Exports [344] (User Guide)
• Word Template Guide (Community)

Advanced reporting
If you require more control over the report output than Word templates provide, you can use an
advanced reporting tool like BIRT or Velocity.

Here are some common scenarios for using an advanced reporting tool:

• Ordering of documents — Word templates always arrange your included items in the same order
that they appeared in Jama Connect when you generated the export. If you need like items to stay
together or certain item types to always be displayed before other types, you need to use a custom
export.

• Style formatting — Although Word templates support basic text formatting like bullets and fonts,
text size and color, they don’t support page formatting options like section breaks or custom page
numbering. BIRT and Velocity exports provide a broader level of control than Word.

• Multiple levels of relationships — Default Word templates can export relationships one level
upstream or one level downstream. BIRT and Velocity can follow relationships and tree structure
through multiple levels.

• Conditional logic — BIRT and Velocity both allow more control over when and where to display
information. For example, an advanced reporting engine lets you display an item’s status, but only if it
were created more than 30 days ago and has an upstream relationship to a feature.

For more detailed information about advanced reporting:

• Introduction to Advanced Reporting (Community)

There are inherent differences between the UI and export size. To align points and pixels (WIRIS font to
be same size as font size), you must manually configure the size to account for approximately 33% of
the difference.

Dashboards
You can configure your projects to show key metrics so you can quickly see what needs attention.  Typi-
cally, dashboards are used to:

• Monitor progress — For example, status of Requirements or Execution Results of a Test Cycle.
• Audit progress — For example, show the count of items that are missing a critical data point or

process step.

To access the dashboard, select the project name in the Explorer Tree.
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As an administrator with organization or project permissions, you can customize dashboards per project
(not per user).

Customizations include:

Filter results Displays the results of an existing filter.

Assigned to me Displays a list of items "assigned to" the current user.

Bar chart Displays the results of an existing filter as a bar chart.

Recent activity Displays a line graph of recent activity over a period of time.

Pie chart Displays a pie chart for a filter and field that the user selects.

Activity stream Displays the current activity stream of the project. View all current activity including comments, edits
made, new items created, and assignment changes.

Project summary Displays a summary of the entire project, including total number of items in the project, number of days
until next release, and number of days until project completion.

Rich text Displays user-defined text, images, diagrams, and equations.

Recently viewed Displays the last 15 items viewed by the current user.

Relationship diagram Displays the relationship rules applied to the project.

Exporting equations and alignment guidelines
Organization admins can save MathType and ChemType equations in PNG and SVG formats. For the
best web, exporting, and print experience, use PNG format with quality 300 dpi.

When the equation format is changed, existing equations keep their current format until edited. Depend-
ing on the format, the exported image might produce different results. Here's what to expect when
equations are exported and surrounded by text in PNG and SVG formats:

• PNG format — Recommended for the best web and printing experience. The bottom of the primary
equation line always aligns with the bottom of the surrounding text. The outermost fraction bar always
aligns with the middle of the surrounding text line.

• SVG format — Produces the most varied export results because SVG doesn't handle embedded
fonts well, which can rearrange certain characters when exported to Word. There is no height infor-
mation, so equations might have different alignment with surrounding text depending on the overall
dimensions.

Testing
Do you need to validate and verify your product? Or maybe you need to create a report that shows the
connection between regulations, requirements, and tests?

Then look no further: use Jama Connect test capabilities to guide your teams through the testing
process, so you can validate and verify your products and systems.
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Let's define our terms

Test cases Items that contain the tests needed to validate or verify product features or systems. They contain the
essential information about your tests, and can be organized by project, library, or ad hoc.

Test plans Documents that describe the strategy and objective of the test.

Test groups A collection of test plans that allows teams to organize test cases within a test plan.

Test runs Item used to record results for a test case you ran against your product.

Test cycles A series of test runs consisting of groups of test cases, that are ready for execution. In a test plan, you
can add a test cycle to help manage and execute test runs.

Defects Errors that are logged from test runs and traced to upstream test cases and requirements through the
relationship configuration.

What's involved in testing?
Here's a typical workflow:

1 Create test cases for your
project

Create test cases that meet the needs of a particular project or multiple projects
across your organization.Test cases describe the specific tests you plan to use and
their steps. Relate test cases to the requirement you’re testing.

2 Create a test plan to test
requirements

Create a test plan that gives an overview of how you want to test requirements.

3 Organize test cases in
groups

Associate the cases you want to use into that plan using groups to organize them.

4 Move groups into cycles Get ready for testing, by moving those groups into cycles where you can see a list
of all the tests you want to run.

5 Execute test runs and log
defects

Execute the test runs and log defects as needed.

6 Get overall test case sta-
tus

Status of resulting test runs roll up to calculate the overall test case status.

7 Generate report showing
results

You can then generate a report showing results, such as the Test Plan Summary
Report or the Test Plan Detail Report.
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Learn more about testing

• Test cases [361]
• Test plans [371]
• Test groups [380]
• Test cycles [383]
• Test runs [390]
• Defect item type [613]

All about baselines
A baseline in Jama Connect is a snapshot of your project at a point in time. The current version of each
selected item — and their relationships — are forever associated with that baseline.

Why are baselines important?
A baseline captures the relationship between your selected project components, as well as their state.
For example, Draft, Reviewed, and Approved.

A project in Jama Connect can have many baselines. You can use baselines as the basis for an export
or as a reference for a historical milestone. By creating a baseline at each project milestone, you can
view the status of your project at key points in the lifecycle. For example:

• At gate reviews
• Before a reorganization
• Before an import of requirements

Where to create the baseline

• In the Jama Connect Project, navigate to the Baselines tab and click Add > Baseline.

• From the Explorer tree, right-click on a component, set, folder, or item, and select Add baseline.
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Create a baseline
Are you ready to send an item for review? Or maybe you need to capture a snapshot of the current set
of requirements. Perhaps your project has reached a milestone like testing or approval.

Create a baseline to secure a snapshot of one or several items in your project.

1. Select the Baseline tab from the left panel tabs of your project.
2. From the Add drop-down menu, select Baseline.
3. Select the criteria that you want to include in your baseline, using the three tabs in the pop-up

window:
• Item selection — A copy of the project where you are working. Select your entire project, a

single set, multiple sets, a single item, or multiples items.
• Releases — If you created a release, baseline one or multiple items.
• Filters — Baseline any advanced filters you created.

4. Click Create. The Add Baseline window appears with a pre-populated name.
5. (Optional) Rename the baseline or add a description.
6. Click Save.

Your baseline is now created and is highlighted under the source where you created it.
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Organize your baseline tree: the basics
Working with baselines is dynamic and intuitive: reorganize, rename, and restructure your tree however
you want. Let’s create a folder or two, then we can arrange them.

Note: You must be a project admin or organization admin to do this.

1. From the Add drop-down menu, select Folder.
2. In the window that opens, type the name of the folder.
3. Click Save.

The new folder is saved at the top of your baseline tree.

Quick tips
• To add a folder to an existing folder, right-click on a folder and select Add Folder.
• To move a folder or a source, drag it to a location in your baseline tree.

Learn more about baselines
For detailed information about baselines, explore more topics in the User Guide:

• Baseline sources [277]
• Baseline organization [280]
• Baseline activity [291]
• Add electronic signatures to a baseline [260]

Reuse and synchronization
Reuse in Jama Connect is much more than a copy/paste mechanism. It’s a full suite of features that
allows for complex capabilities like:

• Maintaining a library of common requirements
• Branching a project to create a variant product
• Comparing differences between a local version of a requirement and its source library version

Reuse and synchronization methods detect variance and highlight the impact of that variance across
releases and projects. These methods are useful whether your product keeps the same requirements
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as a previous version; if it integrates and improves on original requirements; or if you include custom
requirements for each product.

To save time and effort for your teams:

• Reuse common product requirements across projects.
• Sync reused items to help determine and track variance across projects.

When you apply reuse and synchronization methods within your requirements management configura-
tion infrastructure, you maximize your requirements resource management. You can modify and evolve
existing work quickly while maintaining your requirements lineage.

Library approach

• A library project houses a collection of requirements maintained by a librarian or curator (permis-
sions-based).

• The curator of a library can pull differences back into the library when needed.
• Project members can pull and push updates between the project and the library.
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Branching approach

• Projects are branched by project duplication.
• Synchronization is enabled during project duplication and differences are monitored between contain-

ers and items.
• Jama Connect recommends creating a project baseline just after duplication. A baseline captures the

state of the project at the time of duplication and is used for baseline comparisons.

Administration
Administration in Jama Connect applies primarily to controlling the product development process and
users’ access to the data.

Product development process
There is no “one size fits all” process for developing products or applications. Each industry starts with a
template modeled after best practices, but every company can tailor the process to fit its needs.

Here is an example process used to develop a medical device.

In this example:

• Boxes indicate an artifact/document (generically defined as item types in Jama Connect).
• Lines indicate relationships that enforce traceability between the items.
• Item types indicate items with configurable fields to record specific details about each requirement, in-

cluding details like ID, Name, and Description, as well as values for capturing data (workflow status,
validation method), similar to columns in a spreadsheet.
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User management
A primary role for administration in any enterprise system is the assignment of licenses and managing
access to data. Jama Connect includes several options for administrators to fine-tune read/write/review
access to fit their company’s needs.

Learn more about user management

• Licensing [583]
• Managing users [573]

Manage item types
By default, a trial user account is set up with permissions of an organization admin, which gives you
access to the ADMIN module in the top-level navigation. If you don’t see this, ask your administrator to
update your permissions.

Edit an existing item type

1. Select Admin > Organization, then select Item Types.
2. Find the item type you want and click Edit in that row.
3. Adjust the details that your project users are able to see when they work with items.

• Display, Display plural — The name used to identify the item type, for example, System
Requirement.

• Type key —The part of the ID that helps users quickly determine the item type of an item. For
example, the default type key for System Requirement is SREQ, so when a user sees an item
with the ID of QR-SREQ-34, they can know at-a-glance that the item is a System Requirement
for that project.

• Use as — Specific functions or permissions for item types configured as a test case or defect.
• Image — An icon to help users quickly differentiate items.
• Widgets — A graphic that shows additional data for the item. The most common widgets are

Versions, Links, Attachments, Relationships, Activities, and Tags.
4. Click Save.

Add a field
Chances are that the fields available in your selected item type are just what you need for your process.
But if you want to add details specific to your organization, you can do that too.

1. Select Admin > Organization, then select Item types.
2. Select Fields from the row of the item type.
3. Click Add Field from the fields’ header for the item type.
4. Click Custom Fields, then select the type of field you want to add.
5. Enter the name you want users to see in Field Label.

The Unique Field Name is pre-populated with a suggestion. This name is used for reporting or
accessing from REST API [489].

6. Depending on the field type you select, additional options might be required. If prompted, configure
them now.

7. Click Save.
8. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Configure pick lists
A common field to configure on an item type is a pick list. Pick lists can be reused, and the list you want,
like Priority, might already exist. You can adjust the language or values to fit your needs.
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If you need a new list, you can create it before you add the new field to an item type.

1. Select Admin > Organization, then select Pick lists.
2. Find the pick list you want and click Values in that row.
3. Add a new value or edit an existing value:

• New — Click the + icon and enter the value.
• Existing — Select the row and click the pencil icon.

4. Click Save.
5. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Managing relationship rules
Relationships are an important part of ensuring compliance and quality. Many industries base their
processes around the V-Model and need relationships to enforce the traceability through the stages.

Creating the correct relationships can be challenging for users, so Jama Connect gives admins the
ability to configure rules that help guide users in making the correct connections.

In the previous process example for a medical device, the item type User Need can have two down-
stream relationships, System Requirement and Validation.

To configure these relationships, you use the Relationships option from the left panel.

Upstream refers to the higher-level item type that is affected by the lower level (downstream) item, often
through an activity like testing or decomposition.

Add a new relationship rule
Creating a relationship establishes a directional link between two items.

1. Select Admin > Organization, then select Relationships.
2. Find the relationship ruleset you want.
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3. Scroll to the bottom of the list of rules and select Add relationship.
4. Configure the relationships:

1. Select the Upstream Type.
2. Select the Downstream Type.

Relationship types describe why the relationship between the two items exists. View the pick
list above the rulesets on the Relationships page.

3. Click Yes or No to configure if the relationship is used for coverage.
If you select For Coverage, Jama Connect notifies users if this relationship doesn’t exist.

4. Click Save.

Managing workflow
Workflow is an important part of ensuring compliance and quality.

Workflow in Jama Connect is highly configurable. In general, workflow is set up on an item type with
a pick list of available statuses. This process guides a user though specific steps, making sure that
only users with correct permissions can make the workflow transitions (using the Transition Permissions
features), then locks items from further updates when needed. For example, when an item is moved
from Draft to Approved, it is locked so no changes can be made while it is in the Approved state.

Workflow transitions and versioning
Jama Connect captures item versions for any item field change. By default, this applies to an item's
Status field. For example, when the item transitions from Draft to Review, version one of an item
generates version two. However, you might want an item to transition between status values without
generating a new version of the item. For example, to ensure that the item version marked Approved
by review participants is the same version when the item Status field is transitioned to Approved. To
accomplish this result, select Do not version on status change so the item doesn't generate a version
when the status is transitioned.

Add a new transition to a workflow
The best way to understand workflows is to start with a workflow that's included in your collection of
data.

1. Select Admin > Organization, then select Workflow.
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2. Find the item type you want and click Config in that row.
3. In the Workflow Configuration section, use the item type and picklist field options to set up and

manage the transitions between status types.
The Current Status column shows all values for the selected picklist field; the New Status column is
the option you want for the transition from that state. For example, a requirement that is a Draft can
be Approved or Rejected.

4. Under Versioning, select an option:
• Version on status — Updates the version of the item when its status is transitioned. For

example, if the item is version one, after you transition the status it becomes version 2.
• Do not version on status change — The item's version isn't updated when its status is

transitioned. If the item is viewed in a baseline, the baseline displays the current status rather
than the status at the time of the baseline.

5. (Optional) To add a transition state, click + and configure:
• If users are notified of the change
• If the item is locked when it transitions to the new state
• Any restrictions on who can make the update

6. (Optional) Click - to remove a transition state.
7. Click Save settings.

REST API and extensibility
Jama Connect offers a powerful REST API that allows your team to integrate and extend the capabili-
ties of Jama Connect.

Typical use cases include:

• Integrating test results from automated test scripts
• Extracting specific data for analysis in Business Intelligence tools
• Automating manual batch tasks

You can see REST API swagger documentation at <your Jama URL>/api-docs/

Jama Connect User Guide

34



Interested in learning how to work with the Jama Connect REST API? The following resources can help
you get started.

• API Cookbook provides recipes for users and partners creating integrations using the Jama Connect
REST API: https://dev.jamasoftware.com/cookbook/

• Jama Connect REST API documentation provides information about the specifics of our API:
https://rest.jamasoftware.com/

REST API terms

ID Description

Project ID Project IDs are unique to Jama Connect. Your administrator sets the default project and set keys.

Example: <project key> - <set key> # <SBX-REQ-1 or SBX-TEST-3>

Global ID Global IDs reference where a requirement or test was reused globally across Jama Connect
projects. The Global ID isn’t unique because several copies of an item might be connected that
share the same Global ID.

Example: GID-1234
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ID Description

API ID API IDs are the database identifier for an item and is used by developers when interacting with
Jama Connect from the REST API.

In List View, you can locate the API ID as a column or in the browser URL for the item you’re
viewing.

Example: 21374

Where to find the API ID
Find Project API ID in the URL:

Find Filter API ID, navigate to the filter in Jama Connect, and look at the URL:

Find Item API IDs:

Find API IDs in List View:

Jama Connect top tasks
Want to learn more about the Jama Connect tasks that are of highest interest to our users? Based on
research and feedback, we created a table with links to these top areas. A top task is a frequently used
feature.
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Top task Helpful links

Create detailed requirements Add an item [69]

Create new items

Trace requirements Traceability from requirements to test [15]

Jama Connect for modern requirements management

Extract information from documents into Jama Connect Import items [99]

Import from Microsoft Word [100]

Import from Microsoft Excel [109]

Import from IBM DOORS [126]

Audit for quality and completeness Item-based product development [14]

Export test cases to Microsoft Excel [364]

Test [360]

Advanced filters [142]

Dashboard [412]

Collaborate with your colleagues Collaborating with your team [228]

Reviews in Jama Connect [162]

Staying connected with the Stream [236]

Electronic signatures [257]

Roles for review workflow [162]

Videos and top resources
These videos can help you get acquainted with Jama Connect and access additional information and
resources.

• Get started with Jama Connect
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• Jama Connect Basics
• Jama Community Top Resources
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Setting up your work environment

You can change the settings for your profile and workspace to suit your needs and your project work.

My Profile window

• Add a photo
• Add contact information
• Change your password
• Control subscriptions (email notifications)
• Manage settings for reviews

Workspace

• Customize the Explorer Tree
• View content
• Configure fields

Managing your profile
Your profile window is where you change your password and user details, view locked items, and
manage your review subscriptions.

To open the My Profile window, select your name in header.

Your profile window includes a row of tabs and a row of options and commands.

Tabs

Select this... To..

My Details Change your name, username, contact information, or license type.

My Subscriptions Configure your notifications and item subscriptions [41].

My Locked Items View your locked items [43].

Review Center Configure your review subscriptions [42].
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Options and commands

Select... To...

Show "learn more" page at login Enable the resources page to be displayed when you log in.

Edit Avatar Replace the photo that is displayed for your user account.

Change Password Reset your password [40] (if not using SSO).

Set API Credentials Create credentials for API [40].

Edit Settings Change the details of your user account.

Reset your password
You can change your password from the My Profile window or from the login screen.

An organization or system admin can also reset user passwords [583].

NOTE
This feature is disabled if your organization uses LDAP or Crowd authentication.

To rest your password:

1. Select your name in the header to open the My Profile window.
2. Select Change Password at the top of the window.

3. Enter and confirm your new password. To display tips about required characters, hover over the
center of the window.

4. Click Close.

Set API credentials
To integrate applications and scripts through the Jama Connect REST API [489], you must first gener-
ate API credentials. We currently use OAuth 2.0 authentication to generate pairs of client IDs and
secrets.

Important considerations

• API credentials are only used for safe authentication. User access and privileges set by your Jama
Connect admin are still enforced.

• For full instructions about using API credentials, see the developer notes on authentication.
• You can maintain a maximum of 20 API credentials. Remove any you don't need.

To set your API credentials:

1. Select your name in the header to open the My Profile window.
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2. Select Set API Credentials at the top of the window.
3. Add a required name for this set of credentials with an optional description that helps you identify

its use, such as Test Automation Integration.
4. Click Create API Credentials. Jama Connect generates a new Client ID and Client Secret pair.

5. Copy the Client ID and Client Secret into Jama Connect. The Client Secret is only visible after you
click Create API Credentials. If you skip this step, you must recreate the Client Secret.

6. (Optional) Remove any credentials you don't need by clicking the X next to the name.
7. Click Close.

Your API credentials are now available for you to use.

Configure email notifications and subscriptions
To stay up to date on changes, you can subscribe to email notifications [228]. First though, you must
configure your profile to be able to receive these notifications.

If you have notifications that others subscribed you to, you can’t unsubscribe, but you can mute them if
your organization admin has enabled this functionality.

To configure email notifications and subscriptions:

1. Select your name in the header to open the My Profile window.
2. Select My Subscriptions, then select the subscriptions you want to see:
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• Me — Subscriptions you created
• Others — Subscriptions created for you by others

3. Define how often you want to receive notifications using the drop-down menu at the bottom of the
window.
The system automatically checks for new notifications every 5 minutes.
• Immediate — Receive an email as soon as the activity occurs.
• Daily — Receive a batch of notifications in one email per day.
• Weekly — Receive a batch of notifications in one email per week.
• Mute All Notifications — Silence all item subscription emails.

NOTE
Muting notifications affects only email concerning your item subscriptions.

4. Click Close.

Configure your review settings
To keep up to date with review comments, you can subscribe to notifications for that review [209]. First,
though, you must configure your profile to be able to receive these notifications.

1. Select your name in the header to open the My Profile window.
2. Select the Review Center tab.
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3. Select the options you want for review settings:
• Email me updates to items I’ve subscribed to
• Automatically subscribe to items I’ve commented on

4. Click Close.

Using and managing locked items
As a user, you can view your locked items across all projects. You can also unlock any items that you
previously locked.

Items that were locked are listed in your profile window under the tab My Locked Items.

The list includes the item name and the date the item was locked.

TIP
If an item was locked by another user, you can see who locked it by viewing the item In
List View or Single Item View. Hover over the item's Edit button.

The tab, System Locked Items, and the option, Show All Locked Items, are visible only to organiza-
tion and project admins.

Organization admins and project admins can unlock items that were locked by any user. They can also
view system-locked items and unlock them according to their permissions.

Action Organization admin Project admin

Unlock items locked by another user [554] X Only in projects where they are admins

 View and unlock system-locked items [555] Across all projects Only in projects where they are admins

Enable category management for locked items [216] X
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NOTE
Organization and project admins can't use the batch update workflow to unlock sys-
tem-locked items.

View and unlock items across projects
You can view and unlock all the items you previously locked from your profile window.

1. Select your name in the header to open the My Profile window.
2. Select the My Locked Items tab to view a list of items you locked.

3. Select the item you want to unlock, then click the Unlock icon in the top right corner of the window.

NOTE
The option Show All Locked Items is only visible to organization admins. Users
don't see this option.

4. (Optional) Configure which fields are visible: open the item in List View, click the gear icon, then
select Locked, Last Locked By, and Last Locked.

The new columns and results appear in the list of locked items on the My Locked Items tab.
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Lock or unlock items in List View
You can view and unlock items you previously locked by viewing them in List View. When you have
multiple items to lock or unlock, you can use the batch edit option in List View.

1. In List View, select the items you want to unlock.
2. Click the Batch edit icon.

3. In the Batch edit window, enable Locked Status, then select an option:
• Unlock all items
• Lock all items

4. Click Next, comment and notify users as needed, then click Commit.
5. (Optional) Configure which fields are visible: open the item in List View, click the gear icon, then

select Locked, Last Locked By, and Last Locked.
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The new columns and results appear in the list of locked items on the My Locked Items tab.

Adding and deleting bookmarks
Bookmarks are handy links to content that you view frequently and are displayed at the top of your
homepage. You can bookmark projects, components, folders, sets, filters, risk analyses, and Trace
Views.

Bookmarks always appear at the top of the homepage and are sorted by the page most recently
viewed.

To add a bookmark, use one of these methods:

• Bookmark recently viewed content on the homepage — When you view a folder, set, component,
or project, it appears on your homepage in the Recently viewed list. Select the empty bookmark icon
for the content you want to bookmark. The bookmark icon changes to a solid icon and the content
appears under the Bookmarks and Recently viewed sections.

• Bookmark Trace Views — When viewing a Trace View that you want to bookmark, you first save
the Trace View [303], then select the bookmark icon at the top of the page. Trace View is now
bookmarked on your homepage.

• Use your browser's bookmarks or favorites feature — Follow the conventions of your browser to
bookmark any view in Jama Connect.

To remove a bookmark:

• On the homepage, select the solid bookmark icon in the bookmarks list. The content you remove
appears at the top of the section.

Customizing your workspace
You can change the look and behavior of your workspace to suit how you work.

Explorer Tree
Customize the Explorer Tree to display the information that's most useful to you.

Fields
Configure which fields are visible in List View, Trace View, and Projects Reading View.
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Customize the Explorer Tree
The Explorer Tree organizes the sets, components, folders and items in your project hierarchy. You can
configure the Explorer Tree settings so that it displays only information that's useful to you.

1. Select the gear icon at the top of the Explorer Tree to open the Explorer Settings window.

2. In the My settings tab, select the changes you want:

• Use my own settings — Overrides the default Explorer Tree settings with your personal set-
tings.

• Use default settings — Returns the Explorer Tree to the default settings. An organization or
project admin can configure default Explorer Tree settings [647].

• Show item IDs — Displays the unique ID [648] (as in PROJ-REQ-25) before each item.
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• Display global ID — Displays the global ID (as in GID-8845) before each item. This can be
helpful if the item is copied and synchronized.

• Show only folders / hide items — Hides items from view in the Explorer Tree. Components,
set, and folders are still displayed. This can improve performance when your project has a large
number of items.

• Show outline numbering — Displays a number scheme of order and depth in the Explorer
Tree. Root level items have numbers like 1, 2, or 3. Child items contain the parent item number
as well as its own number, like  1.1, 1.2,  or 1.1.5.

• Show relationships in Explorer Tree — Displays downstream relationships of items in the
Explorer Tree. Select the green downstream arrow to open the related items in List View.

IMPORTANT
Be careful not to relate an item back to itself, which can create an infinite loop
that causes the Explorer Tree to expand.

3. Click Apply.
4. When you're satisfied with changes, click Close.

Configure fields
Choose which fields are visible for each item as it appears in Projects Reading View, List View, or Trace
View.

Important considerations

• You can configure your Compare View for synchronized items [340] or your List View for base-
lines [291].

To configure fields:

1. Click the gear icon (show/hide fields) in the toolbar [51].
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In Trace View you can configure fields for each level independently.

2. In the drop-down list, select the fields you want to see.

NOTE
Reading View remembers user selections for a particular location, so they appear
across sessions.

3. Click Close.

The list that is displayed shows your changes.

Jama Connect User Guide

49



Introducing the Jama Connect interface
The Jama Connect interface is where you work with and manage your projects. It is made up of several
distinct areas, each with its own purpose.

The information in Get started [10] introduces you to the interface. This chapter takes a more detailed
look with descriptions of toolbars and panes in the interface. It also includes instructions for customizing
the Explorer Tree and configuring how you view your projects.

Explorer Tree
The Explorer Tree organizes the sets, components, folders, and items in your project hierarchy. You can
configure the Explorer Tree settings so that it displays only information that's useful to you.

How it works
You can drag and drop items between the Explorer Tree and List View [54] to move items [83]
and organize your project. You can also configure settings [47] so that the Explorer Tree displays
information that's most useful to you.

Jama Connect arranges content by component, set, and folder. Select one to view its content.
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For more information about how to use the Explorer Tree:

• Find an item in the Explorer Tree [152]
• Filter the Explorer Tree [147]
• Move items in the Explorer Tree [83]

Quick tips

• When working with a large number of items — more than 250 items per folder — work with them in
List View instead of the Explorer Tree.

• To move multiple items, you can multi-select in the List View and drag them to their new location in
the Explorer Tree.

Tools for viewing and controlling content
With Jama Connect, you can look at and control your content according to the type of work you need to
do.

• Toolbar [51] — Provides different methods to control and view your content.
• List View [54] — Shows data from multiple items in a table with a different field in each column.
• Reading View [55] — Shows text and images for a group of items so you can read through selected

items like a document.
• Document View [55] — Provides the ability to create, edit, and read items all in one view.
• Trace View [58] — Shows related upstream and downstream items, missing relationships, and item

details in context of their relationship.

You can also customize fields [48] that control how you view your projects.

Toolbar
The toolbar is located in the center of the workspace. The tools allow you ways to control and view your
content.
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Toolbar options vary slightly depending on your location in the application.

Select... To...

View details See the details of a component, set, folder, or a project overview.

List View Show data from multiple items in a table with a different field in each column.

You can sort, select, and compare items at a glance.

For more information, see List View [54].

Reading View Show text and images for a group of items, which allows you to read through selected items like a
document.

For more information, see Reading View [55].

Document View Create, edit, and read items all in one view — no need to switch views for each function.

For more information, see Document View [55].

Filter items Open the filter panel and filter the items you want to see.

A filter limits the group of items or comments by content, like author, keyword, date, or coverage.

Row height In List View, manually adjust the height of the rows.

If you select Extended, rows are formatted to wrap text.

Gear icon (show/hide
fields)

Configure which fields appear for each item in Reading View, List View, or Trace View.

For more information, see Configure fields [48].

Refresh Refresh the list of results and recent changes from other users.
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Select... To...

Add Add items, folders, sets, and components.

Trace View Show related upstream and downstream items, missing relationships, and item details in context of
their relationship.

For more information, see Trace View [58].

Export Export your data to Word, Excel, PDF, or use one of the Office Templates.

Batch edit Update picklist fields and tags for multiple items at a time.

Reuse Reuse [322] when your projects contain items that are the same or similar.

Convert to Change an existing item or items from one type to another.

Batch transition Select multiple items of the same item type and transition them to a different workflow status.

Send for review Send specific items for review.

Note: The maximum number of items you can Send for review is 500.

Relate to existing Relate two existing items of the same item type.
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List View
In List View, you can configure which fields appear as table columns. The table is dynamic — you can
sort, select, drag and drop, and reorder columns.

Important considerations

• To reorganize columns, select the column header and drag it to the new location.
• To choose which fields you see in the table, you can configure fields.
• Use the interactive links (breadcrumb navigation) to find your way around and view the location of

your project hierarchy.

• To sort items, select the column header.

View information about an item.

Move [83] items in a project.

View locked items [43].

View how many relationships an item has, as well as whether those relationships meet the project's relationship rules.
For more information, see Relationship Status Indicator [308].

View and add comments [242].

View and add connected users [256].

View related items (the relationship between two items). For more information, see Add a relationship from Single Item
View [309].
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Reading View
Reading View shows text and images for a group of items so you can read through selected items like a
document.

You can use Reading View in both Projects and Reviews. Click Reading View on the toolbar at the top
of the center panel.

From Projects > Reading View you can:

• View images
• Select individual or multiple items
• Open items
• View hierarchy with numbering
• Drag items to the Explorer Tree to reorder (as long as the item type allows it)
• Add comments and view connected users
• Configure fields [48]
• View related items
• Export hierarchical content from an advanced filter [148]

Document View
Document View provides a streamlined authoring and editing experience. Like other authoring tools,
you can create, edit, and read items all in one view — no need to switch views for each function. Use
the edit feature to quickly edit items without changing views or manually tracking your place in the
document.
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With Document View, you can:

1. Leverage all the functionality and toolbar actions of Reading View: filter items, configure items,
Reuse, Batch Transition, Send for Review, Edit, and more.

2. Add or insert content from a single screen.
3. Double-click on an item to open quick edit mode, with the option to expand to full edit mode.

4. Select the item action menu (horizontal ellipsis icon) to expand the Widgets drop-down menu, then
select Relationships to open the Relationships panel. From here, you can:
• View existing relationships
• Add, update, and remove relationships
• Clear suspect links
• Filter relationship settings
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5. Insert new items without losing your place in the document.
6. Add comments and lock items. Select an item's speech bubble icon to open the Comments panel,

so you can view comments and items at the same time. From the Comments panel, you can:
• Read and reply to existing comments
• Add, like, mute, and filter comments
• @mention a person or group
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Trace View
Trace View shows related upstream and downstream items. It also shows item details in context of their
relationship, as well as any missing coverage (downstream relationship).

1. Filter item types in Trace View [306].
2. Configure each level to display or hide fields [48].
3. Find any gaps in coverage.
4. Export the content [305].
5. Add related items directly from this view with the Add menu option in the toolbar.
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6. Establish relationships between existing items.

You can also display fields for various item types. For example, you can display the Test Case Status
for verification and verification testing. If a test case item is visible in Trace View, you can navigate
downstream to see any test runs generated from the test cases.

Understanding the Trace View interface
In the Source section, Trace View displays the items that were visible in the List View, Reading View, or
Single Item View from the time the Trace View was initiated.

1. The source.
2. Direct downstream items.
3. Blue arrows = Travel upstream (left arrow) or downstream (right arrow).
4. Top of each level column = Number of item types on the entire level.

NOTE
The item count is a unique count. If the same item is downstream of multiple items
in the source column, it appears multiple times in the "1 level down" column, but it's
counted only once.

Single Item View
In Single Item View, you can view specific details about an item. For example, an item's ID, Name,
Description, and Status. This view always shows all the fields the item type is configured to include by
your admin.

You can also edit the item [72] and use widgets [676] to access different areas of Jama Connect.
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Here's a high-level overview of some of the features Single Item View offers:

1. Top right toolbar [51]
2. Projects workflow [230]
3. Side toolbar [60]
4. Global ID [320]
5. View previous versions of an item [266]
6. Breadcrumb navigation (formerly called "Find me") helps you find your way around and indicates

the location in your project hierarchy.

Side toolbar
The side toolbar appears on the right side in Single Item View. The widgets give you access to different
features of Jama Connect. Widgets can be configured by an organization administrator configured by
an organization admin [611].

Select... To...

Relationship Status Indi-
cator

Open the bottom panel where you can see the required relationships for this item and whether the
item follows the project's relationship rules. Suspect relationships [315] are also flagged.

Connected users Open a window that displays the users directly associated with the item as well as indirectly
associated with related or traced items. The number displayed is the number of connected users.
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Select... To...

Review comments Open and close the bottom panel of review comments [193] related to this item. The number
displayed is the total number of comments for this item.

Comments Open and close the bottom panel of comments [242] related to this item. The number displayed is
the total number of comments for this item.

Activities Open and close the bottom panel display of activities [241] related to this item.

Versions Open and close the bottom panel of item versions [263]. The number displayed is the total number
of versions for this item.

Synchronized items Open and close the bottom panel of synchronized items [154].

Child items Open and close the bottom panel with a list view of child items [72]. Appears only if the selected
items has child items.

Items to be changed Open and close the bottom panel with a list of change requests [268] that might affect this item.

Compare View
Compare View shows side-by-side content so you can compare differences between different item
versions.

To open compare view, select the Version widget in the side toolbar.
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Compare View is used in these areas of Jama Connect:

• Compare versions of reviews [202]
• Compare synchronized items [336]
• Compare item versions [265]

Learn more
You can access information about Jama Connect with these features.

• Select Projects > Learn more to see a list of resources about Jama Connect.
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• You can see which version of Jama Connect you're using at the bottom of the page or from the login
page if you're using the default authentication.

• Click Help in the top right corner to open the Jama Connect User Guide in a new tab.

• View a glossary [678] of Jama Connect terms in the User Guide.
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Creating content

Content in Jama Connect is structured using an item-based approach rather than a document-based
approach. Items are the major building blocks for your content and Jama Connect includes several item
types.  

Item type: Containers

Components • Structural container
• Organize projects into manageable pieces

Sets • Structural container
• Access rights can be configured
• Items of the same type can be grouped
• Contain folders, test items, child items

Folders • Structural container
• Organize items
• Manage hierarchy in the Explorer Tree
• Contain text items or items of the same type

Item type: Items

Item • Individual building block of a project
• Comprised of customizable fields

Organizations typically create items as requirements, features, use cases, test cases, defects, or other
information types that define the scope of a project or product.

To create content in Jama Connect, you can import existing content from another platform, or you can
author directly in the application.

A typical process for creating content might include these tasks:

TIP
Before populating Jama Connect with your data, discuss with others in your organiza-
tion which elements of the application you want to use and how you want to use
them. Involving team members early in the process can help avoid rework later.
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Containers
Containers help organize your content in Jama Connect. Types of containers include components [65],
sets [66], and folders [67].

Item type: Containers

Components • Structural container
• Organize projects into manageable pieces

Sets • Structural container
• Access rights can be configured
• Items of the same type can be grouped
• Contain folders, test items, child items

Folders • Structural container
• Organize items
• Manage hierarchy in the Explorer Tree
• Contain text items or items of the same type

NOTE
A source folder [277] is a specific type of folder that refers to baselines. It is the only
container type that is not an item.

Add a component
A component is a structural container item used to organize a project into more manageable pieces. 

For example, you might define each piece of your product with a different component.

• Components can only be located or moved to the root of the Explorer Tree or inside another compo-
nent.

• Components might contain sets of various item types, text items, and sub-components. Each compo-
nent can have different access rights.

NOTE
Text items can appear anywhere in this structure.

To add a component:

1. Open the Add Item window using one of these methods:
• Wherever you want to add a component or sub-component in the Explorer Tree, right-click on

the project name.
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• Select Add > Component at the top of the left panel in the project where you want to add the
component.

2. In the Add Item window:
a. Write a name and description for the component.
b. (Optional) Select Notify to select users or groups you want to notify about the creation of this

component.
c. (Optional) To add more components, select Add another.
d. (Optional) Use the Select Location window to choose where to put the new folder.

This option appears only if you created a folder from the Add drop-down menu.
Invalid locations are disabled.

3. Click Save and Close.

Add a set
A set is a structural container item with configurable access rights, used to group items of the same
type. It can also contain folders, text items, child text items, and child items of the same type.

A set contains items of the same type. You can move or copy between sets of the same item type.

Item types for a set are configured by an organization administrator [608].

To add a set:

1. Open the Add Item window using one of these methods:
• Wherever you want to add a set in the Explorer Tree, right-click on the project name and select

Add > New item > Set of..., then select the item type from the list.
• From the top of the left panel, select Add > Set of..., then select the item type from the list.

2. In the Add Item window:
a. Edit the set key, name, and description of the set.
b. (Optional) Select Notify to select users or groups you want to notify about the creation of this

set.
c. (Optional) Select Add Another, then select the location for the new set.
d. (Optional) Use the Select Location window to choose where to put the new set.
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This option appears only if you created the set from the Add drop-down menu.
Invalid locations are disabled.

3. Click Save and Close.

Add a folder
A folder is a container item you can use to organize items and manage hierarchy in the Explorer Tree.

Folders are a structural item type that contain other items, not an array of different item types. Folders
can contain only text items and the same item type as the folder itself. Folders can be located or moved
inside a set of the same item type, or inside another folder. You can't place a folder inside a component
of mixed item types.

An item can be moved between folders and sets of the same item type using drag and drop within the
Explorer Tree or from List View. Folders can be dragged to other sets of the same item type or into
other folders also in the same item type.

To add a folder:

1. Open the Add Item window using one of these methods:
• Wherever you want to add a folder in the Explorer Tree, right-click on the set name and select

Add > New item > Folder.

• Select Add > Folder at the top of the left panel in the project where you want to add the folder.
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2. In the Add Item window:
a. Write a name and description for the folder.
b. (Optional) Select Notify to select users or groups you want to notify about the creation of this

folder.
c. (Optional) To add more folders, select Add another.
d. (Optional) Use the Select Location window to choose where to put the new folder.

This option appears only if you created a folder from the Add drop-down menu.
Invalid locations are disabled.

3. Click Save and Close.

Items
Items are the building blocks of Jama Connect. Projects are made up of items and items are made up
of fields. Items can be containers [65] or documents.

Item type: Containers

Components • Structural container
• Organize projects into manageable pieces

Sets • Structural container
• Access rights can be configured
• Items of the same type can be grouped
• Contain folders, test items, child items

Folders • Structural container
• Organize items
• Manage hierarchy in the Explorer Tree
• Contain text items or items of the same type

Item type: Items

Item • Individual building block of a project
• Comprised of customizable fields

All items have a global ID [320], a unique ID [648], and an item type that's determined by an organiza-
tion administrator [608].

Use text items to:
• Manage context data — Create introductory paragraphs when the data isn’t traced as part of the

relationship model.
• Contain information — Create figures or graphs to provide detail for data in adjacent items.
• Store content — Save content that is required in exports, such as boilerplate text that must be

included, but isn’t part of the core project data.
• Maintain change logs — For change logs you manually maintain, use text items as part of a

document export.
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NOTE
Baselines, source folders, risks, risk analyses, reviews, and test groups aren't items,
so they don’t have an item type and a global or unique ID.

Several places in Jama Connect allow you to see a quick preview of an item without opening it in the
center panel. For example, right-click on an item in the Explorer Tree and select Preview item.

Container items

Select View details next to a container's title to:

• Display container's detailed information.
• Open container's attachments [89].
• Edit the name or description of the container itself.

TIP
To receive email notifications when a container changes, subscribe yourself [229] or
others [229] to the container.

Add an item
Even if you import data from another application or sync data from another tool, you can also add a new
item to your project as needed.

You can an add an item to a project from several places in Jama Connect. The list of displayed items
includes only item types that are valid for the selected location.

Important considerations

• Before adding a new item, make sure your project includes an item set [66] for that item type, unless
it is a text item.

• You can't add items in filters or in lists of mixed item types.

To add an item to your project:

1. Open the Add item window using one of these methods.
• Right-click the project name — In the Explorer Tree (or wherever in that project you want to

add an item), right-click the project name, select Add > New item, then select an item type from
the list that appears.

• Add drop-down list — In the project where you want to add the item, select Add at the top of
the left panel, then select the item type from the list that appears.
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• Toolbar — From the toolbar above Single Item View,  List View, or Reading View, select Add,
then choose the item type from the list that appears.

In List View, if the list contains items of a single item type and no items are selected, you can add
an item of the same type, a text item, or a set to the bottom of the list.
If an item is selected, use one of these options.
• Insert new to insert a new item below the selected item.
• Add Item Type as child to add an item as a child item of the selected item.
• Add related to add a related item to the selected item. If a relationship rule [157] was applied

to that project, only item types that meet the rules are available for that selection. 
• Quick add add items in a set of the same item type.

2. Select the location where you want to add the new item in the window that opens (invalid locations
are disabled), then click Select & Close.

3. In the Add Item window:
a. Fill in the fields for the selected item type.
b. (Optional) Select Notify to add a notification comment and select users or groups to notify

about the creation of this item.
Comments are included in the version notes for the item [263] and are displayed in the
stream [241].
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TIP
To add a version comment when you save the item, see Version Comments.

4. Select Save or Save and Close.
5. Select Commit.

Quick-add an item
The Quick-add option lets you add multiple items at a time to a set of the same item type.

You can add up to 50 items at once.

Important considerations

• The Name field is required.
• The Description field is required or read-only based on how the item type is configured.
• To add required fields, edit the item after you create it.

To quick-add an item:

1. In your project, select Add > Quick add.
If you don’t see the Quick add option, then the item you’re adding doesn’t match the item type in
that set.

2. Enter the required name for the item (255 characters maximum) and an optional description (500
characters maximum).

3. Click Add Row to include additional rows as needed, for a maximum of 50 rows (items). Include a
name and optional description for each added item.
Use the tab key to move across the table.
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4. Click Save.
The new items appear in the Explorer Tree.

5. To add required fields to a new item, select the item to open and edit it.

Add a child item
Create a child item when you need an item that falls hierarchically below a parent item of the same item
type.

Important considerations

• If a parent item includes a child item, the parent item can't be converted to a text item.
• A parent item can include a child item that is a text item.
• Relationships and attribute values of a parent item aren't inherited by child items.

To add a child item:

1. Right-click on an item and select Add > New item > Sub Component.

2. In the Add item window, fill in the fields for the selected item type.
3. (Optional) Select Notify to add a notification comment and select users or groups to notify about

the creation of this item.
Comments are included in the version notes for the item and are displayed in the stream.

4. Select Save or Save and Close.
5. Select Commit.

Edit an item
You can edit a saved item any time you need to add or change its information.

Jama Connect User Guide

72



Single Item View automatically displays items in a read-only format.

Important considerations

• You must have create/edit permissions to edit an item.
• A field must be enabled for read/write permissions.
• If a field is disabled for editing, it might have been configured to be read-only [595] by an organization

admin, locked by another user, or locked through a workflow.

To edit an item:

1. Select the field you want to edit, using one of these methods:
• Double-click on the field
• Hover over the field and select the pencil icon to make it editable.

• Select Edit from the toolbar.

2. Edit the item field, as needed.
3. When you're done editing, select an option:

• Save & done.
• To save and add another item of the same type, select the arrow on the middle button, then

select Save & add another.
• To save and notify other Jama Connect users, select the arrow on the middle button, then select

Save & notify.

TIP
To add a version comment when you save the item, see Version Comments.

4. Select Save Changes to complete the edit and create a new version of the item.

A confirmation message confirms that the item was successfully changed.
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Edit an item in List View
You can edit an item to make needed changes, for example to picklists, fields, and tags. In List View
you can update multiple items of the same type. You can make changes in one item, then press Enter
to move to the next row.

TIP
If you need to make the same changes across multiple items, use batch update [74]. 

To edit an item in List View:

1. Double-click the field you want to edit in projects List View.

2. To undo any unsaved changes, press Escape or select Cancel below the selected item.
3. Select Save or press Enter to save the change and move to the next item in the list.

Batch-edit multiple items
You can update picklists, fields, and tags for multiple items at one time.

Important considerations

• You can't batch-edit rich text fields. Instead, use a Jama Connect to Excel round trip [122].
• You can't batch-edit test runs using this method. Instead, use the Test runs window to batch edit test

runs [404].

To batch-edit multiple items:

1. Select items that you want to edit using one of these methods:
• In List View, select the items that you want to edit, then select Batch edit.
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• (Review moderator only) Select the items you want to edit in the item progress [206] tab of
review statistics, then select Batch edit.

2. In the window, make your changes, then select Next. 
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3. (Optional) Select users or groups and send a notification.

4. Select Commit.

Add, edit, or delete links
You can add a link to an item using two methods.

• Associate a link with an item.
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• Embed a link in a rich text field in an item.

If the Links widget was enabled by an organization administrator [611], you can store a link or URL in
Jama Connect, then assign the link to individual items across projects.

Important considerations
URLs that are prefixed with "http://" are treated as unique links. URLs without the prefix are added to
the end of the Jama Connect URL, which might be helpful if you placed files on the server and you want
to link them without uploading them as attachments.

For example:

• http://www.creativecommons.org — Opens a new browser window with the URL https://creative-
commons.org/

• screenshots/login.html — Opens a new browser window with the URL http://localhost:8080/con-
tour/screenshots/login.html

To add, edit, or delete a link:

1. To add a link, in Single Item View, select Add link, then fill in the fields and select Save.  

2. To edit or delete a link, select Edit or Delete from the link's row.

Locking an item
A lock makes an item read-only, so that it can't be edited or deleted. An item can be manually
locked [77] or automatically locked [234] by the system.

What can you do with a locked item?

• Reuse [322] and create relationships from a locked item.
• View and unlock locked items [43].
• Find out who locked an item.

What can't you do with a locked item?

• Edit, delete, or synchronize locked items.

Who can unlock a Jama Connect item?
An organization admin or project admin can unlock system-locked items [555], but only an organization
admin can unlock items manually locked by another user [554].

Locked items Who can unlock?

Manually locked by other users Organization admin

Locked by system or workflow • Project admin
• Organization admin
• Creator user with workflow transition permissions (only for projects the user administers)

Manually lock and unlock items from the toolbar
To prevent others from making changes while you're working on an item, you can manually lock that
item.

Jama Connect User Guide

77

https://creativecommons.org/
https://creativecommons.org/


When you configure List View to show locked items, a gold lock appears next to items that are manually
locked.

TIP
If you need to access an item locked by another user, contact that user or your
organization administrator to unlock it.

To manually lock and unlock items:

1. To lock an item manually — In Single Item View, select Lock item from the toolbar.

2. To unlock an item — (Organization or project admins only) In Single Item View, select unlock
item [43] from the toolbar.

Converting items to another item type
In Jama Connect you can change an existing item or items from one type to another. When you
convert an item to another type, these attributes remain intact: short name, description, relationships,
versions, activities, comments, and tags.

To convert an item, folder, set, or component, you can use:

• Drag and drop [79]
• Context actions menu [80]

Important considerations

• A field is converted only if its name or data type is identical in the current and new item types.
• A lookup field is converted only if it refers to the same pick list (and has has the same name and data

type) in the current and new item types.
• Converting an item breaks the sync if you reused that item.
• If converting an item puts the item out of compliance with the relationship rules, the issue is reflec-

ted in the relationship diagram.
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• When you convert a set, all items in that set are converted to a different item type.
• You can't "undo" an item conversion [82] but you can convert the item back to the original item type.

Use the same procedure you used to convert items.

You can convert from... To... Notes

Component set

text item

Set within the original component convert to folders in the newly created set.

Set component

set

folder

text item

For components, the original set must be empty and at the top level of the hierar-
chy.

The original set must be empty.

Folder item

folder

Item item

text item*

folder**

Text item component

set

item

* An item that include child items can't be converted to a text item.

** A child item can't be converted to a folder unless the parent is converted first. When converting to a
folder, items lose widget functionality and custom field values.

Convert items using drag and drop
When you need to change the item type for all items in a set, use the drag and drop method.

Important considerations

• Before converting items, read about how conversions work in Jama Connect [78].
• When you drag and drop a text item into a folder of your required type, the text item is moved to that

location, but it isn’t converted.
• You can’t use bulk conversion for text items. You must convert them one at a time.
• When converting an item to a folder, select Recursively convert all items with Children to Folders

in the Review Item Conversion window. Parent items at every level beneath the item being converted
are converted to a folder.

To convert an item or set to another item type with drag and drop:

1. From List View or the Explorer Tree, select the items and drag them into the set where you want to
move them.

2. Review the information in the Review Item Conversion window.
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3. Click Next to view each page of the Review Item Conversion window.
4. If converting an item to a folder, select Recursively convert all items with Children to Folders.

Parent items at every level beneath the item being converted are converted to a folder.

NOTE
This option appears only when you select a folder to be converted.

5. Select Convert.
If the item can belong in its current location (such as a text item), it remains there. However, sets
can't contain mixed item types, so the item might need to be moved.

6. If prompted to move an item, select the new location for that item, then click Select and Close.
7. To see changes, select Versions in the side toolbar [60] of Single Item View [59] to open the item's

version tab.

Convert items in List View or Explorer Tree
You can use the drop-down menu in List View or the Explorer Tree to convert items or sets.

Before converting items, read about how conversions work in Jama Connect [78].

1. In List View or the Explorer Tree, select the items you want to convert, select Convert to, then
select an item type from the list that appears.
• List View — Select the checkbox for the item or set.
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• Explorer Tree — Right-click on an item or set.

The Review Item Conversion window highlights in white the fields that are copied into the new
item type.
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2. Click Next to view each page of the Review Item Conversion window.
3. If converting an item to a folder, select Recursively convert all items with Children to Folders.

Parent items at every level beneath the item being converted are converted to a folder.
This option appears only when you select a folder to be converted.

4. Select Convert.
If the item can belong in its current location (such as a text item), it remains there. However, sets
can't contain mixed item types, so the item might need to be moved.

5. If prompted to move an item, select the new location for that item, then click Select & Close.

NOTE
If you select multiple items in List View, you must also specify a location, even
if it's the items' original location. Doing this ensures that the items end up in the
correct place.

6. To see the changes, select Versions in the side toolbar [60] of Single Item View [59] to open the
item's version tab.

Convert items back to original type
You can't undo an item conversion, but you can convert your items back to their original type. When
changing back, the item receives new identifiers.  

• Use the same procedure you used to convert your items to convert the same items back to the
original type.

• Any fields that don't convert in the new conversion direction are lost. To determine if fields were
lost, select Versions in the side toolbar of Single Item View to open the bottom panel and select
Compare.

• Any fields that were lost must be manually replaced by an organization administrator [595].
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Moving items
Within a project, you can move items using the Explorer Tree [83] or List View [83]. Once items are
moved, you can undo the move or find the items in the stream [153]. 

Rules for moving items

Item type Rule

Component Can have child components and can be moved to the root of the Explorer Tree.

Set Can be moved inside a component or to the root of the Explorer Tree. Sets can't have child sets.

Folder Can be moved to a set that's the same item type as the set where the folder was created, or to another folder.

Item Can have child items of the same item type and be moved to a set of the same item type or to a folder.

Text item Can be moved anywhere in the Explorer Tree.

General You must have write-access to both an item and its new location. When components, sets, or folders are moved,
all items within them are also moved.

Move items in Explorer Tree
Items must meet valid item location rules [83] before then can be moved.

You can also move items between projects [83]. 

Visual indicators tell you if a move is allowed or provides guidance for moving an item.

• Green indicator — Moves that are allowed.
• Red indicator —Moves that aren't allowed.
• Dotted blue line — Guide for moving an item between other items.

To move items in the Explorer Tree:

1. Select the item you want to move in the Explorer Tree. 
2. Drag and drop the item to the new location.

Move items in List View
Items must meet valid item location rules [83] before they can be moved.

Quick tips

• If you select the tab at the top of the Explorer Tree and drag items from List View to the release, you
can change the release on one item or multiple items.

• You can move items between projects [83].

To move items in List View:

1. In List View, select the items you want to move. 
2. Drag and drop the items to the chosen location. 

Move items between projects
You can move an item or set of items, along with all associated conversations, versions, and attach-
ments to a different project. This is useful when a project has grown too large and performance has
started to degrade.

Important considerations — Review this list before you move items between projects

• A move can't be undone. Users can move items back to the original project but IDs are changed.
• You can only move components and sets between projects. If you're trying to move a folder of items

or individual items from a component or set, you must first create a new component/set, then move
those items to the new component/set.
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• Document key IDs are changed when an item is moved. The new ID is based on rules set up in the
destination project.

• When an item is moved, all associated stream collaboration, activities, and versions are moved to the
new project. Attachments, tags, and releases are copied to the new project.

• If you delete the source project, images inserted in a rich text field that are copied in other projects
are also deleted because they are referenced and aren’t copied from the original project. To keep
images intact in the duplicated project, we recommend archiving the source project.

• Original attachments, tags, and releases still exist in the source project, including links, images, and
diagrams within rich text fields.

• Test runs can't be moved. Test cases can be moved without impacting test runs.
• Items contained in a review aren't shown in future versions of a review after they are moved.
• The document ID in old baselines reflect the new ID.
• If any moved item is associated with an integration sync, integrations such as the JIH can't be

running while a move is being performed.
• Performance might be impacted at the time of the move if other resource-intensive processes are

being done at the same time.

TIP
If you delete the source project, images inserted in a rich text field that are copied in
other projects are also deleted because they are referenced and aren’t copied from
the original project. To keep images intact in the duplicated project, we recommend
archiving the source project.

To move items between projects:

1. Make sure that:
• You have write permissions in the source and destination project.
• The items to be moved must be unlocked.
• All other move operations are completed.  You can't make two moves at the same time.

2. In the source project, right-click on the set or component of items you want to move, then select
Move item.

3. In the Move items to... window, select the destination project and select Move. 
4. Review details and select Confirm.

During the move you can go to the destination project by selecting Go to project or stay in the
same project by selecting Done.
A pop-up window shows progress of the move. If any item fails to move, the entire move fails.

Once the move is complete, you can find recently moved items [153] from the Activity Stream.

Duplicate an item
You might want to copy an item to use it as a template for a new project or a new requirement.

You can duplicate items in Jama Connect using these methods.

• Duplicate items — Create a copy of the item's name, description, test steps (if applicable), and the
ability to choose to include tags, attachments, and links. You can duplicate items that are locked.

• Reuse items — Creates a copy of an item, but with more options. With this method you can reuse
multiple items, reuse items with children, duplicate more of the item's content, or duplicate an item
from another project. For more information, see Reuse items [323].

Jama Connect User Guide

84



NOTE
You must have read/write permissions to duplicate an item.

To duplicate an item:

1. Right-click on the item you want to copy and select Duplicate item from the menu.
2. In the Duplicate item window, indicate whether you want to duplicate tags, attachments, or links.
3. Press Enter or select Duplicate.

NOTE
According to the item type, selected preferences are saved across sessions. How-
ever, clearing your browser data restores default options. When specific attributes
(as in links) aren't enabled for an item type, the option doesn't appear in the
pop-up window.

The item you duplicated opens in Single Item View of the duplicated item.

Delete an item
When you delete items, they aren't physically deleted. They are marked as inactive and are no longer
visible to users or reports. If needed, they can be re-activated through the database.

Anyone with read/write permissions for an item can delete it, unless an organization administrator has
made the option unavailable [605].

Important considerations

• You can delete an item only if it is unlocked.
• Deleted items show up in the activity stream. The activity entry is also the only method of restoring a

deleted item [85] for those with delete permissions.
• In most cases, nothing is deleted from the Jama Connect database. Even if you delete another user,

item, or something else in the system, a record is maintained and the deleted object is merely de-ac-
tivated on the front end. However, you can permanently delete the selected project and everything
under it from the database.

To delete an item:

1. To delete in Single Item View [59], choose an item and select Delete.
2. To delete in List View [54], Reading View [55], or Document View [55], choose one or more items

and select Delete.
3. To delete in the Explorer Tree, right-click on an item and select Delete.

Restore a deleted item
If you have permission to delete an item, you can also restore it. When you restore a deleted item, it
retains all comments, versions, and relationships associated with the item.

NOTE
You must have project admin permissions to restore items deleted by someone else.
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To restore a deleted item:

1. Select the project name at the top of the left panel to open the dashboard, then open the Activity
Stream widget [412] to view recent activities. 

2. In the search field at the top of the Activity Stream widget, type delete to display all recently
deleted items.

3. Find the item you want to restore and select Restore.

If the set for the restored item was removed, a component with a temporary set is created. The item can
then be moved to any set of the same item type.

Tags
Tags are labels that you can attach to items. They can help you find items with something in common.

NOTE
These tags are different than hashtags [243] that you apply to comments in the stream.

Tags are displayed in the bottom of the left panel in a section that can be hidden.

• Search for tags [138] using the "tag:" prefix.
• You can edit tags in List View.

• Tags can be displayed in a Cloud View:
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In either view, select the tag to view its associated items.

Add and delete tags
Add and delete tags as your project evolves, if you created a tag by accident, or to keep items
organized.

The tags widget must be enabled by an organization administrator [608]. Otherwise, the option to add a
tag isn't available in the UI.

1. To add a tag to an item:
a. In Single Item View, select Add tag.

b. Enter the tag name in the available field, then press Enter.
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2. To delete a tag from an item, select the X in the tag.

Jama Connect User Guide

88



Attachments
Attachments are external files such as images, documents, and spreadsheets that can be attached to
an item.

A project administrator can manage attachments [651] for a project. 

Important considerations

• You must have create/edit permissions to access attachments.
• File size limit is 4 GB.
• These default file types are allowed: APK, AVI, BMP, CSV, DOC, DOCM, DOCX, DOT, DOTX, DWG,

GIF, GZ, JAMA, JPEG, LOG, MD, MOV, MP3, MP4, MPEG, ODG, ODP, ODS, ODT, PAGES, PDF,
PGP, PNG, PPT, PPTM, PPTX, RAR, RTF, TGZ, TIF, TIFF, TRA, TXT, VCS, VSD, VSDX, VSS, WAR,
WAV, WMA, WMV, WPS, XCF, XLS, XLSB, XLSM, XLSX, XLT, XPS, ZIP, ZIPX.

• Self-hosted environment — The system admin can update this list directly [512].

Add, edit, and delete attachments
An attachment is an external file such as an image, document, or spreadsheet that can be added to an
item. You can add, edit, or delete attachments as needed.
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NOTE
You must have create/edit permissions to access attachments.

1. To add an attachment:
a. In Single Item View, select Add attachment.

• To upload new items, select the Upload tab in the Add File Attachment window, then select
Choose file to select the file you want to attach and upload.
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• To attach files that are already uploaded to Jama Connect, select the Existing tab in the
Add File Attachment window, then select the file you want to attach. Select Show all to see
all the files that are already attached to an item.

b. Select Attach to Item.
The file is now shown in Single Item View as an attachment.

c. To download the attachment, select the attachment name or the down arrow icon.
2. To delete an attachment, select Remove from item (trash icon).
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3. To edit what is attached to an item, select Edit (three dots icon) to open the Edit File Attachment
window.

You can then:

• Reload the attachment.
• Update the name and description.
• Upload a different attachment, which overwrites the existing one. To add a new attachment, start

from step 1.
4. Select Save and Close.

Using the rich text editor
When the rich text editor is enabled [595] by your organization admin, you can format text in individual
fields and embed other data like images and tables.

With rich text fields you can use text formatting, hyperlinks [94], images [93], tables [94], spellcheck-
er (English), templates [97], diagrams, graphs [95], and equations [96]. 

NOTE
The equation editor requires additional licensing. Contact your Jama Software account
manager for more information.

If a field is enabled with rich text, you see the rich text menu, which provides rich text controls.
These controls are like text editing options in many software applications. You can also use keyboard
shortcuts [673] with the rich text editor.

Important considerations

• Many third-party reporting tools can't display rich text (HTML) properly.
• Integrations with third-party applications might not be able to accept rich text (HTML) data.
• Each rich text section can have its own style, making it difficult to control the overall look and feel of

your report.
• As needed, you can disable the rich text editor [595].
• Whenever a rich text item is saved, Jama Connect deletes certain text (usually code like JavaScript)

that might be a security risk. This doesn't affect most data.
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Rich text toolbar and buttons

1. Text style and size
2. Cut, copy, and paste — Paste action inserts selected text as plain text.
3. Field view — Insert document templates [97] (must be configured [616] by organization admin),

view source code, and fullscreen mode.
4. Format text
5. Subscript, superscript
6. Text alignment
7. List formatting
8. Edit text
9. Insert links
10. Special tools — Add diagrams [95], images [93], tables [94], special characters.
11. Accessibility checker
12. Equations editor — Math Editor, Chemistry Editor.

The spellchecker automatically underlines misspelled words in red. Cmd+right-click on the word to
view spelling suggestions.

Insert image to rich text fields
The rich text editor lets you add an image to an item field. The editor provides multiple methods for
adding an image.

A system admin can manage file types [512] for self-hosted customers.

To insert an image:

1. Add an image using one of these rich text methods:
• Toolbar option: Add image

TIP
Provide the full path to the image file to comply with third-party converters for
PDF and Word. If you move Jama Connect to a new server or modify the server
name, edit your image files to match the path or name change.

• Copy and paste (not available with Internet Explorer 10)
• Drag and drop
• Browse the server (select Add image from the server)

2. (Optional) Resize or move the image as needed.
A system admin or organization admin can define a maximum height and width setting for an
inserted image.

3. If an inserted image is too large to be displayed, select Expand to view the image in full size.
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Insert a link in rich text fields
Direct links to attachment files can be helpful to reviewers. You can link from a rich text field directly to
other sets, items, and attachments in Jama Connect, or to an external link.

1. Select the Link icon in the Rich Text toolbar.

2. In the Enter URL or Choose Item window, do one of the following:
• Enter the URL for an external link.
• Select tabs to choose your link from recently viewed locations, the Explorer Tree, releases,

search results, or attachments, then under the Attachments tab, upload a file directly from your
desktop.

3. Click Select to place your link in the rich text field. The link doesn't work until you save changes to
your item.

4. To break a link, select the Break link icon in the toolbar.

Add and edit tables with rich text editor
You can add a table to an individual field using the tools section of the rich text editor [92]. You can also
edit the table.
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TIP
Although you can import tables from other documents, they can be difficult to work with
once imported, and they don’t export cleanly. Instead, create tables manually in Jama
Connect.

1. To add a table, select the Table icon in the Tools section of the rich text editor.

2. To format a table, right-click any table cell, then select the preferred action.

3. To resize a table, select its borders.
4. To add space above or below a table, hover your mouse near the space, then select the blue

button that appears on the right.

Insert rich text diagrams
Diagrams can be anything from basic shapes to more complex modeling and business process flows.
Once saved, a diagram is an editable image within the rich-text field.

Important considerations

• You can't copy and paste between the diagram editor and other applications.
• You can’t import images from other diagramming tools.

To insert rich text diagrams:

1. Select Diagram in the Rich Text toolbar to open the Graph Editor window. If you highlight an
existing diagram before selecting the button, it appears in the window for editing.

2. In the Graph Editor window, create new shapes by dragging from the menu on the left and
dropping to the canvas. 
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3. To add shapes, icons, tables, or text, or to use the search function, use options in the left pane. For
more information, see MXGraph Editor.

4. To format style text and arrangement, use the options on the right.
5. When finished, select Save and Close to insert your image into the field.

Insert equations in rich text fields
With this editor, you can create complex equations and edit them in Jama Connect. These are con-
verted into images for safe storage and export, but are always editable when you have a MathType
license.

Important considerations
Your organization determines the total number of floating licenses, which are available on a first-come/
first-served basis. If a license is available, you can use it by opening the Equation Editor. To release the
license, close the Equation Editor. If a license isn’t available, try again in a few minutes or contact your
admin for help.

NOTE
The MathType Equations Editor requires a separate license. Contact your Jama Con-
nect administrator or sales representative to inquire about purchasing this license.

For self-hosted customers with a license, the system administrator can enable the
equations editor [504].

To insert equations in rich text fields:
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1. To add a new equation or formula, open the appropriate editor by clicking its icon (Math Editor or
Chemistry Editor), then select the equation or formula you need.

2. To edit an existing equation or formula in your item, use one of these methods:
• Highlight the equation/formula, then select the appropriate icon for the editor you need.
• Double-click on the equation/formula to open the appropriate editor.

For more information about how to create mathematical equations or chemistry formulas, see the
MathType User Guide.

Insert templates to rich text editor
Templates are pre-written text or documents that can be inserted into the rich text editor to help
uniformly format items like test cases or use cases.

IMPORTANT
This feature must be configured by an organization admin [616] before you can use it.

1. To open the Content Templates window, select the Templates icon in the Rich Text toolbar.

2. Select a template from the list (for example, Basic Use Case, Document Style Use Case, Basic
Test Case, and Agile Story Card) and continue editing the item.
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3. Select Replace actual contents to delete content currently in the field.
4. Click Save & done.

Run Accessibility Checker
The Accessibility Checker is a plugin that analyzes content created in the rich text editor. It lets you
know if the content meets standards for people with impaired visual, cognitive, or motor skills.

1. Select the Accessibility Checker icon from the Rich Text toolbar.

The plugin inspects output HTML code to identify common accessibility problems and offers a
"quick fix" solution.
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2. Use the arrows at the top of the pop-up window to scroll through issues found by the Accessibility
Checker.

3. For each identified issue, do one of the following:
• Enter the suggested changes and select Quick fix to apply the changes.
• Select Ignore.

4. If the Accessibility Checker finds no issues, you see a confirmation message. Select OK to close
the message.

Importing content into Jama Connect
Content in Jama Connect is structured using an item-based approach. Items in Jama Connect can be
containers (components, sets, folders) or instances of a particular type of item, such as a requirement
or test case.

One way to populate Jama Connect with content is to import existing items (such as requirements or
test cases) from other applications.

The most common applications for importing items into Jama Connect are:

Microsoft
Word

• Determine hierarchy of imported items with Word heading styles (Heading 1, Heading 2...).
• Retain formatting like bulleted lists, numbered lists, and text formatting.
• Import Word tables as rich text field content or use tables to identify and import discrete items into Jama

Connect.

Excel • Map columns directly to fields.
• Determine hierarchy of imported items with cell coloring or indentation.
• Import via one-way import [118] or round-trip import/export [122].

IBM Doors • Import objects found within Modules.
• Map object attributes directly to fields within Jama Connect.
• Maintain relationships during import with active IBM DOORS data.

The Data Import Wizard guides you through the process of importing items into Jama Connect. It
recognizes file types like .doc, .docx, .xls, .xlsx, and .csv and displays options accordingly.

You might need to prepare your source file for a successful import. For example, if your Word file has
requirements in tables, you might need to ensure that all tables use consistent headings in the first row
so that the wizard can identify each table for import.
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TIP
Before populating Jama Connect with your data, discuss with others on your team to
make sure all needed information has a “home” (field) in Jama Connect. Involving team
members in this process can avoid rework of having to import again for data that was
not initially taken into account.

Importing items from a Word file
You can add items to Jama Connect from a Word file. You might, for example, have a Word document
with various types of requirements (customer, system, or software requirements) or with test cases.

TIP
If you are familiar with how to prepare a Word file for import, go to Import a Word
file [105].

When using a Word document to import items into Jama Connect, you can use these features to control
how things are imported.

• Headings and styles — From the document’s Styles list, you can use default heading styles to
determine hierarchy (nesting) of imported items in Jama Connect.Headings are always imported as
items, not as folders. However, the hierarchy can be converted to folders once imported to Jama
Connect. Apply the Normal style to item descriptions.

• Tables — Tables in a Word document can be imported directly into Jama Connect rich text fields as
tables. Word tables can also be used to create discrete items in Jama Connect. If a table has a first
row header and one row per requirement, the content is read as one item per row. If a table has two
columns where the first column contains headings (for example, “Requirement Text”) and the second
column contains data (for example, “The system shall…”), the content is read as individual items for
each table that conforms to a repeated structure.

• Import/Ignore Sections — Use designated keywords in your Word document to define which sec-
tions to import and which to ignore. This is useful for large documents when not all content is relevant
to import.

• Field mapping — Define how Word elements map to Jama Connect item fields. This process varies
slightly, depending on whether you use headers or tables to identify items.

Jama Connect User Guide

100



NOTE
Many Word styles are imported, but not all are converted exactly. The import wizard
can’t import a table of contents. Images are included as part of the import. OLE
components, such as embedded Visio diagrams, are imported as PNG images.

Setting hierarchy with heading styles
When importing items from a Word document, you must prepare the document so that the import is
successful. An important step in this preparation is to set the hierarchy, how items are nested in Jama
Connect.

To set the hierarchy, use Word heading styles. Each heading represents a new item in Jama Connect.
The heading text is imported into the item’s Name field and any paragraph text, tables, or images are
imported into the Description field.

NOTE
In your Word document, all headings are imported as items, never as folders. How-
ever, the item hierarchy can be converted to folders after import using the Convert
function.

The hierarchy of imported items is determined by which heading level you apply to the item name. A
nested heading in Word is treated as a child item in Jama Connect, with a maximum of seven levels.

For example, in this diagram, Item A uses Heading 1 and is imported as a parent item. Item B uses
Heading 2 and is imported as a child of Item A, and Item C uses Heading 3 and is imported as a child
of Item B.

When you open the imported item in Single Item View, the Name field is populated with the text of the
Word heading, and the Description field is populated with the text of the Normal style paragraph.
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NOTE
For the Description and rich text fields, formatting for bullets, bold, italic, and underlin-
ing are retained when imported. Numbered lists are imported as bullets. When a list
contains multiple levels, Jama Connect continues to use bullets. However, each set is
indented to indicate the original level.

How tables are imported from Word
When importing items from a Word document, the Data Import Wizard lets you choose how tables are
imported.

Each table is an individual item

Select this option when your Word document includes a separate table for each item you want to
import. The wizard prompts you to complete field mappings with this option.

In this example, the document heading (System Requirements) is imported to Jama Connect as a
parent item and each table is imported as a separate child item.

The table for each item must have at least two columns: column 1 is the field name (for example,
Name) and column 2 is the field value (for example, Three digit display).
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TIP
If your Word file includes multiple tables, make sure that all tables use the same
wording for the field name in the header (first) row. For example, if one table uses ID
for the field name, all tables must use ID, as in this example.

Each table row is an individual item

Select this option when your Word document includes tables where the first row is the heading row and
each subsequent row constitutes a discrete item. The wizard prompts you to complete field mappings
with this option.

The cells with field names must be the top row of the table. Each subsequent row represents a separate
item, and a row’s cells define the field values.  If you have multiple tables in your document, each table
must have the same heading values to be recognized by the import tool.

This is an example document after importing into the set called System Requirements.
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Descriptions might include tables

Select this default option when the document you're importing has no tables or the content of a table
applies only to the item description.

You don't need to map fields when you select this option.

Here is an example document and the results after you import.

Prepare your Word file for import
Before you import a Word file, make sure it is formatted for a successful import. For example, confirm
that you use default headings and that your tables are formatted properly.

You might also need to define the document scope by tagging sections of content to include and
exclude. Requirement documents are often large and might contain sections or items that need to be
imported to different sets, different folders, or not at all.

1. Open the Word file you intend to import to Jama Connect.
2. Set hierarchy with heading styles [101] (how items are nested in Jama Connect).
3. If your file includes tables, make sure they are formatted according to how tables are imported from

Word [102].
4. (Optional) If you don’t want to import the entire file, add keywords to sections you want to import

and ignore.
Use start/stop keywords that are simple, one-word, and all caps with no formatting. Keywords must
not be actual words that might appear in the content. Commonly used start/stop keywords are
IMPORTSECTION and IGNORESECTION.
a. Insert the keyword IMPORTSECTION before and after each section you want to import.
b. Insert the keyword IGNORESECTION before and after each section you want to exclude from

the import.
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5. Save and close the Word file.

Import a Word file
Once you have exported data from DOORS, you can import it to Jama Connect using the Data Import
Wizard in Jama Connect.

1. Open the Data Import Wizard: In the Explorer Tree, right-click an item where you want to import
new items, then select Import. Your file will be imported below the selected item.
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The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.

a. Click Choose File and select the Word file you want to import.
If the file type isn’t recognized, the import doesn't continue.

b. (Optional) If you previously saved your field mappings for importing a Word file, click the
Select a saved field mapping field and choose that file.
This is useful if you are importing multiple documents with the same field mapping.

c. (Optional) In the Encoding section, select the character set encoding to use during the import.
For most imports you can use the default, UTF-8, which is used by the Jama Connect data-
base.

3. Complete the Choose Field Mappings for Import page, then click Next.
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a. Document Scope Options — If you tagged your Word file to import and ignore some sec-
tions, select the checkboxes and enter the name of each keyword (for example, INCLUDE-
SECTION and IMPORTSECTION).

b. Field Mapping
• Max length of Name field — Select this and enter a maximum number of characters for the

name. Default is 255 but this option lets you further limit the name length.
• Default Value — Use this option (when available) if you want a field value to be used

by default. Then, all items created during import include the default value you enter. For
example, you can set the status to Draft for all imported items.

4. Complete the How to Handle Tables page, then click Next.
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a. Choose a Table Import Style — Select this option if your item description includes tables:
• Descriptions may include tables — Select this option if your file uses headings for hierar-

chy, but the content includes some tables.
• Each table is an individual item — Select this option if your file uses tables and includes a

separate table for each item. Must complete Table Field Mapping.
• Each table row is an individual item — Select this option if your file uses tables and the

tables use a separate row for each item. Must complete Table Field Mapping.
b. Table Field Mapping — Complete this section if importing table content as individual items

(option 2 or 3 above). From your Word tables, copy the heading values into the Identifier field
for each Jama Field mapping. For some Jama Fields, you can set a default value (for example,
setting status to Draft), which populates the field if the mapping has no value.

5. Verify First Item in Import File — Review the mapping of the first item found in the document
you're importing. If the mapping is correct, select Submit to import the target document.

Jama Connect User Guide

108



a. (Optional) Select Import another file to restart the wizard.
b. (Optional) To reuse the field mapping settings, select Save this as new document mapping.

NOTE
Field mappings are project-specific and can be used by any user in the
project where the mappings are saved.

c. Click Submit.
6. Click Close.

A message appears in the Data Import Wizard to confirm that the import was successful.

Importing from Excel
You can use the Excel Import Wizard to import data into Jama Connect from a Microsoft Excel docu-
ment. This process is called a one-way Excel import. You can also export existing data from Jama
Connect to an Excel template, then update the data in Excel as needed, and import it back into Jama
Connect. This called an Excel round-trip.

To ensure a successful import, your Excel worksheet must be created and formatted for the specific
type of data (items, test cases, item relationships) that you want to import.

For items and test cases, your worksheet indicates item hierarchy — how items are nested — as
folders, parent items, or child items. You can use color or indentation to define hierarchy.

When importing items, your worksheet can include only one item type. If you need to import more than
one item type, you must create a separate worksheet for each item type and import each worksheet
separately.
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TIP
If you are familiar with how to prepare an Excel file for import, go to the tasks Import
items [118], Export/import via Jama Connect-to-Excel round trip [122], and Import
relationships [125].

Recognized file types

Jama Connect imports data from Excel files with these extensions: .xlsx, .xls, and .csv.

NOTE
An import from a file with a .csv extension doesn't create folders or hierarchy. On-
ly .xlsx and .xls files create folders and hierarchy.

Preparing a worksheet to import items
Before importing items from your Excel worksheet, make sure it contains all the necessary elements for
a successful import.

• One item type per worksheet. If you have more than one item type to import, create a separate
worksheet for each type.

• Header row [111]with field names

• Valid pick list options [111]
If importing into a Jama Connect pick list field, make sure the values in your Excel worksheet exactly
match the available values in the Jama Connect field.

• Date format
When including dates in text-formatted cells, always format dates like this:
mm/dd/yyyy hh:mm:ss Z (example: -0800, +1000, +0700) where Z is the time zone difference from
GMT.

• Roundtrip
If importing to update existing items in Jama Connect, you must use a spreadsheet generated from
Jama Connect when you select the Excel Export for Roundtrip option.
Create a baseline [275] before a round-trip export/import process, in case you need to restore old
data.

TIP
To import test cases or requirements, see Preparing a worksheet to import test ca-
ses [115] or Preparing a worksheet to import relationships [117].
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Defining header row in Excel
Including a header row in your worksheet helps to easily map columns in the worksheet to fields in
Jama Connect. Typically, the Header row is the first row in your worksheet, but it doesn’t have to be.

The header row includes fields listed horizontally, with values for those fields defined in subsequent
rows.

Your worksheet can contain only one header row. If you don't use column headers, the import automati-
cally numbers the columns sequentially from left to right, starting with 1.

We recommend that you always include Name and Description fields. You can add optional fields like
Status or Priority.

If you don’t include a Name field, the worksheet must still contain a column to be mapped to the Jama
Connect Name field. Every item and folder in Jama Connect must have a value in the Name field. If
your requirements were previously managed in an Excel worksheet without this field, you can create a
new column for Name values or designate an existing column, such as a legacy ID value, for the Name.

If other fields for the imported item type are required (based on Admin configurations), you can add
them to your worksheet or plan to set a default value during the import.

IMPORTANT
An organization administrator can add or delete fields [595] for an item type in Jama
Connect. However, the Name field is a system field and can't be disabled.

Defining pick lists in Excel
When your worksheet includes a column for a pick list in Jama Connect, for example Priority or Status,
the values you define must match the list of available values in Jama Connect. Otherwise, the imported
item shows a blank entry for that field value.

In this example worksheet, Requirement 1 lists Fun as a Priority value, which doesn’t match the values
in Jama Connect (High, Medium, Low). After importing this item, the List Item View shows a blank
entry for Priority.
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TIP
Before importing your worksheet, identify the columns in Excel that will be mapped to
pick list fields in Jama Connect. Use the Excel Filter functionality to identify the values
found in that column in Excel. If the values found in Excel do not have an exact match
in the Jama Connect pick list, you must correct errors before importing. Otherwise, the
value will be blank.

Setting hierarchy with color in Excel
When you import items from an Excel worksheet, you can use cell color to determine hierarchy of
imported items. This method allows only one tier of hierarchy and doesn't differentiate between colors.

In your Excel worksheet, you can select the cell you want to use as a parent container and use a color
to indicate hierarchy.

When you import the document, the Data Import Wizard prompts you to select the column that will
determine hierarchy. In this example, Name column is selected.

Jama Connect User Guide

112



The resulting import shows the colored cells as parent containers.

Setting hierarchy with indentation in Excel
When you import from an Excel worksheet, you can use indentation to determine hierarchy of imported
items.

In your Excel worksheet, you decide which cells you want to be parent items, then indent the cells
below the parent items.

Using indentation for hierarchy allows multiple levels of hierarchy (for example, folders containing sub-
folders and subfolders containing items). This is an advantage over using highlighted cells for hierarchy.
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When you import the document, the Data Import Wizard prompts you to select the column that will
determine hierarchy. In this example, Description column is selected.

The resulting import shows the indented cells as child items:
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Preparing a worksheet to import test cases
To import test cases and their steps, you use the Excel import to Jama Connect option. You can use
a one-way import to import a test case from an Excel worksheet or, if you need to update existing test
cases, you can use a round-trip process.

Required header fields

To successfully import test cases and their test steps, your Excel worksheet must contain one header
row with these four columns (field names): Test Case Name, Action, Expected Results, and Notes.

One-way import for test cases

Quickly bring legacy test cases into Jama Connect. This example worksheet imports two test cases:
"Test Wheel" and "Test Brakes." Each row with the repeated test case name is imported as a new test
step.
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When importing the Excel file, follow the instructions for any one-way import [118]. The Data Import
Wizard prompts you to select the worksheet, plus the number of the header row.

NOTE
To import items or requirements, see Preparing a worksheet to import items [110] or
Preparing a worksheet to import relationships [117].

Round-trip for test cases

When you need to update a test case already in Jama Connect, you can use a round-trip [122] process.
First you export a test case from Jama Connect, which generates an Excel file populated with the
required fields. Next you update any fields that need changes, then re-import the data back to Jama
Connect.

Because of the relationship between test cases and test runs, you can't update the test case sta-
tus [368] in a round-trip import/export. The test case status field is calculated from all test runs derived
from that test case.Test case status.

Add and delete a test step in Excel
You might need to add a new step to your test case or delete an existing step.

1. Add a test step — Copy an existing row (step), then right-click on the row where you want to insert
the copy and select Insert Copied Cells. Edit the fields in the copied row to reflect the information
needed for the new step.
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IMPORTANT
Always use Insert Copied Cells instead of Paste. The Paste command replaces
the row instead of adding a new row, and subsequent steps are removed on
import.

2. Remove a step — Right-click on the row (step) you want to remove, then select Delete.
Re-numbering of steps takes effect on import.

3. Save the file.

Preparing a worksheet to import relationships
Relationships are imported to Jama Connect from an CSV file, using a relationship import plugin [557].
You can’t import relationships with the Excel Import Wizard.

A properly formatted CSV file, when opened in Excel, consists of two columns:

• Column A — Parent or upstream item references
• Column B — Child or downstream item references

As needed, you can import multiple relationships to a single item or many relationships to many items.
To accomplish this, you create duplicate cell combinations for those items. In this example, CP-REQ-10
has three relationships, each in its own row.

NOTE
To import items or test cases, see Preparing a worksheet to import items [110] or
Preparing a worksheet to import test cases [115].
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Import items or test cases from Excel
Importing items or test cases from Excel to Jama Connect is called a one-way import. The process is
handled by the Data Import Wizard, which guides you through the steps. The wizard recognizes .xls
and .xlsx file types.

IMPORTANT
You can create new items with a one-way import. If you need to update existing items
or create new items in an existing set between items, use an Excel round trip [122].

1. Open the Data Import Wizard: In the Explorer Tree, right-click the set or folder where you want to
import new items, then select Import. Your file will be imported below the selected item.

The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.
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a. Click Choose File and select the Excel file you want to import. If the file type isn’t recognized,
the import doesn't continue.

b. (Optional) Encoding — Select UTF8.
3. Complete the Choose Field Mappings for Import page, then click Next.
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Excel Options — If your file has more than one worksheet, select the one you want to import, then
enter the number for the header row. If a header row doesn't exist, select row 0, which populates
the Mapping section with the Excel default column names.
• Round trip/Update Options — For one-way import, leave these options unselected.
• Field Mapping — Select the appropriate column from the worksheet for each field in Jama

Connect where you want to import data. Select a mapping for Name and any required fields, as
determined by the Admin configuration for the item type. Fields not required for the import don’t
need to be mapped.

4. On the Additional options page, indicate whether your worksheet uses cell color or indentation for
hierarchy, then click Next.
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5. If the fields were mapped successfully, you see a preview of your import. Click Submit to import all
items.
The Final Import Summary page confirms the total number of items imported.
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6. (Optional) Import another worksheet or save the current mappings to use for future uploads.

NOTE
Field mappings are project-specific and can be used by any user in the project
where the mappings are saved.

7. Click Close.

Export/import via Jama Connect-to-Excel round-trip 
With a round trip, you can batch edit multiple items or test cases in Jama Connect, as well as create
new items or test steps to be imported.

The round-trip process involves these steps:

1. Export the items you want to edit from Jama Connect to an Excel worksheet.
2. Make your changes in the worksheet (add items or steps, delete steps, change field values).
3. Import the edited worksheet back into Jama Connect.

Round trip requires you to re-import Excel documents created by Jama Connect using an Excel
template. When the system identifies items that originated in Jama Connect, it updates your items
according to the conflict rule set at the time of the import.

Excel has a cell character limitation and, during the export, truncates rich text fields that exceed the
limit. A truncated rich text field can impact the data that’s imported to Jama Connect using round-trip.

To import or export via Jama Connect-to-Excel round-trip:

1. Export a folder, filter, or set of items to Excel:
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a. In List View, select the columns that you want to export to Excel.
Only the columns shown in List View are exported, so be sure to display all columns you need
to include.

b. Select Export > View all export options.

c. In the window that opens, select Excel Export for Roundtrip from the menu on the left, then
select Run.

NOTE
Excel limits the number of characters that a cell can contain. If a Jama Connect
field (rich text field) exceeds the limit, Excel truncates the text when it's exported.
As a result, the Jama Connect is updated with the truncated data if imported via
round-trip.
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2. Open the newly downloaded Excel report and save it to a place where it can be edited.

Columns A–E are hidden. They contain fields that Jama Connect requires to update existing items.
3. Edit the exported Excel document with required changes, then save it.

a. Edit the fields you need to update. In this example, the names of three test cases are changed.

If a field is based on a pick list in Jama Connect (for example, Priority), the pick list values are
exported as well. This ensures that valid data is entered before re-importing to Jama Connect.

b. As needed, create new items or test steps that you want added to Jama Connect. After import,
added items appear at the bottom of the set or folder where you import to.
• You can add only one item type for the selected set or folder.
• Leave the ID and Global ID fields blank. These values are assigned to new items during

import
• Leave Assigned field blank.
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4. Import the edited Excel file. The process is the same as for the one-way import except for the
Choose Field Mappings for Import page:

a. Excel Options — If your file has more than one worksheet, select the one you want to import.
Select the number of the row in your worksheet that contains the headers. By default, the
Excel for Roundtrip export uses row 2 as the header row.
If a header row doesn't exist, select row 0, which populates the Mapping section with the Excel
default column names.

b. Round trip/Update Options — Select the checkbox for Update Items to update Jama Con-
nect items that were modified in the round-trip Excel worksheet.
Select an option for Conflict Resolution: Excel wins or Do Not Update. Conflicts might
occur when a field in Jama Connect has changed values since the round-trip export was
generated.

c. Field Mapping — Select the appropriate column from the worksheet for each field in Jama
Connect where you want to import data. Select a mapping for Name and any required fields,
as determined by the Admin configuration for the item type. Fields not required for the import
don’t need to be mapped.

Import relationships from Excel
Relationships are imported to Jama Connect from a CSV file. The file consists of two columns.

Important considerations
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• A relationship import plugin must be configured [557] and enabled.
• A CSV file must include correct parent and child field values and must have the .csv extension.
• Import relationships in small batches no larger than 250 at a time.
• Check that your parameters are written correctly and reference the right API ID or field. For more

information, see Configure import relationships plugin [557].

To import relationships:

1. From the Jama Connect header, select Project > Import > Custom Import.
2. In the window that opens, configure these settings:

• Select a destination — Select the location in your project for the Import Relationships Plugin.
Destination is required, but it doesn't affect the import.

• Select custom importer — Select the Import Relationships Plugin created by your organiza-
tion admin.

• Field delimiter — Select Comma.
• Optional Encoding — Select UTF8.
• Select file to import — Click Choose File, then navigate to the CSV file with the required

relationships.

3. Select your Excel file and click Import.

Give Jama Connect time to process the relationships. If you're importing more than 100 relationships,
the update isn't instantaneous.

When the import is complete, you see a notification at the top of your screen: "Success: X items
imported."

Importing from IBM DOORS
You can import active IBM DOORS data, such as requirements, test cases, and project information to
Jama Connect. You can also maintain relationships during the import process.

Here are the steps for a successful import:

1. Ensure you meet Jama Connect [127] and DOORS [127] prerequisites.
2. Export HTML zip file from DOORS [129].
3. Import to Jama Connect [130].
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DOORS export prerequisites
Before exporting data from IBM DOORS, verify these prerequisites for a successful export.

Mapping

• The Object Identifier column in IBM DOORS is typically mapped to the Name field in Jama Connect.
• If you're importing hierarchy, the DOORS standard Object Heading and Text (or Main) column must

be mapped to the Description field in Jama Connect. This is the only column that exports hierarchy
information to HTML for Jama Connect imports.

Links

If you're importing links (trace relationships) across multiple modules in DOORS:

• The modules must be open when you export. A DOORS export includes only the modules that are
shown in your view, so make sure no filters are selected because they limit the number of items
exported.

• Each module must have a unique prefix so that the Object Identifier is unique. DOORS doesn't
enforce this requirement, so make sure you confirm that each module has a unique prefix before you
export.

• The Object Identifier column must be visible in the DOORS module view (not Object Number or
Absolute Number). The Object Identifier is a combination of the Module Prefix and the Absolute
Number (as in SYS32). If the Object Identifier has only integer values, the Module Prefix is most
likely empty.

Jama Connect prerequisites for DOORS import
Before importing data from DOORS to Jama Connect, verify these prerequisites for a successful import.

Links

Relationships between items aren't created until both items are imported.

• To import relationships (or trace links), you must create a custom field in Jama Connect [595] for each
item type you're importing.

• Each custom field must contain a unique identifier, which aids in importing relationships from DOORS
to Jama Connect.

Create custom fields in Jama Connect
To import relationships (or trace links), you must first create a new custom field in Jama Connect for
each item type you're importing. Each field must contain a unique identifier.

TIP
When importing many custom fields from DOORS, create a common custom item type
that contains all the custom fields. Use this item type only for the initial import, then
later convert sets to a standardized set of item types. That way, every imported item
includes legacy DOORS information in its version history. To view this information,
compare versions [265].

1. In Jama Connect, select Admin > Organization > Item types.
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2. Find the item type you're using for the DOORS import, then select Add field.

3. In the Add Field window, complete these options, then click Save.
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• Select a Field Type — Select Custom Fields, then select Text Field from the drop-down menu.
• Field label — Enter a name for the field (for example, "DOORS ID").
• Unique Field Name — Enter "SYS_DOORS_ID." This is case-sensitive and must exactly match

the above image.
• Select Read Only.
This item type can now accept relationships (trace links) imported from DOORS.

IMPORTANT
The SYS_DOOR_ID field must be created for all the item types you are relating.

Export data from DOORS
Before you can import data from IBM DOORS to Jama Connect, you must export it to an HTML .zip file.
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1. On your local system, create the export target folder in the local drive/directory.
2. Open a DOORS module that you want to export and make sure there are no active filters.
3. Select File > Export > HTML.
4. Select Layout > Table.
5. Select Export > Current.
6. Select Links to import links as relationships and create the necessary field in Jama Connect [127].
7. Select a folder or location where you want to store your DOORS files.
8. Browse to the target folder and select Export.

9. Without making changes, create a .zip file to the target folder that contains the exported HTML
content.

IMPORTANT
Changing or moving the exported files before compressing them can create unreli-
able results.

Images in the item description are imported. Comments, attachments, and item history aren't imported.

Import DOORS files to Jama Connect
Once you have exported data from DOORS, you can import it to Jama Connect using the Data Import
Wizard in Jama Connect.

The import process creates:

• Sets or folders in an existing set. DOORS Attributes map to fields in Jama Connect.
• Relationships between items only after both items are imported.

The Data Import Wizard guides you through the import steps.

1. Open the Data Import Wizard: In the Explorer Tree, right-click an item where you want to import
new items, then select Import. Your file will be imported below the selected item.
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The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.
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• Click Choose File and select the DOORS file you want to import.
If the file type isn’t recognized, the import doesn't continue.

• (Optional) Select a saved field mapping — Select previously created import configurations that
were saved in the project for the same file type. This is helpful if you need to import multiple
documents with the same field-mapping layout.

• Optional Encoding — Select UTF8.
3. Complete the Choose Field Mappings for Import page, then click Next.
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• Field Mapping — Select a mapping for the Name field (this is usually the DOORS Object
Identifier attribute). You can assign a default value for other Jama Connect fields and select
which DOORS attributes you want to map to each.

IMPORTANT
The Description field is usually mapped to the Main attribute in DOORS. Bullets
and other symbols are exported from DOORS as images, not as formatting. If
you're mapping a field that contains images or formatting, the corresponding im-
port field must be configured as a rich text field, otherwise these images don't
appear.

You can't select a mapping for Step action, Step expected results or Step notes.

4. Select the options you want for hierarchy and relationships, then click Next.
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• Preserve hierarchy — Select to keep the DOORS hierarchy when importing. If left unselected,
the resulting items are at the same level.

• Use item/sub-item structure — Select if you want all parent items to keep the item type of their
children. If left unselected, all parent items become folders.

IMPORTANT
All items converted to folders lose their relationships (links). If you're importing
relationships, use the item or child-item structure.

• Create relationships from DOORS links — Select to migrate Trace Links from DOORS to
relationships in Jama Connect.
If you see the following error, check that you successfully completed all Jama Connect prerequi-
sites [127] before import.

• Relationship type — Select the type of relationship you want to create. If left unselected, this
value is set to your organization's default value.

• DOORS ID column — Select the name of the column from your export that contains the
DOORS Object Identifier, which is used as the identifier when creating relationships. It must
match between item types.
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• 'From' (OUT) link direction in DOORS maps to — Set OUT=upstream or OUT=downstream.
DOORS and Jama Connect use different terminology for relationship direction. The selection
depends on how relationships are used in DOORS. Check the HTML file or run a test import to
verify that this works as expected.

IMPORTANT
Because relationships are created based on the DOORS Object Identifier, import-
ing items twice creates multiple relationships.

5. If the fields were mapped successfully, you see a preview of your import. Verify that it looks correct,
then click Submit to import all items.

The Final Import Summary page confirms the total number of items imported.
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• (Optional) Import another DOORS Module.
• (Optional) If you plan on importing the same item type (objects) with the same mappings multiple

times, you can save your mapping changes as a new document mapping here.
6. Click Close.
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Find content

The content you want to find might be anywhere in your project. For example, you might want to look at
the requirements or test plans.

Jama Connect gives you many ways to directly access the items you need:

• Search [137] — Look through an index of your item type fields, as well as text within a Word
document, a PDF document, or text attachments, to bring up a list of items.
Use the search bar in the header to help you find the topic you're looking for.

• Filter [140] — Limit the results of a search by content such as author, keyword, date, or coverage.
You can also filter stream comments, review comments, reviews, review items, Trace View items, and
project items. To open the filter panel, select Filter items at the top of the center panel in List View or
Reading View.

• Advanced filters [142] — Save a set of rules or conditions for later use and share that filter with other
users.

• Quick find [148] — If you don't remember where to find something in the application, use the quick
find [148] topic in this guide.

Full text search
Jama Connect uses an index of the database fields for its search function. It also searches in text files,
Word files, and PDF files to find the items you're looking for.

You can search item IDs, descriptions, attachments, and field values. Search for an item's unique ID
(not global ID) and it opens.

Important considerations

• The application doesn't support searches for null values, including checkboxes that haven't been
selected.

• Files larger than 25 MB aren't indexed, so their content isn't searchable.
• These file types are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF.
• These file types are not indexable: XLSX, XLS, XML, HTML, HTM.

Ways you can search
For a simple search you can enter a word or a phrase in the search field. For an advanced search you
can use wildcards, Boolean operators, and more.

• Single term — Enter a single word to find items. For example, Test returns items with the terms
test, pretest, tests, tested, and tester.

• Phrase — Enter a group of words surrounded by double quotes. For example, “primary test"
returns only items that contain the words primary test.

• Single character wildcard — Enter a single character wildcard (?) with a single term (not a phrase).
For example, te?t returns items that contain test, tent, and text.

• Multi-character wildcard — Enter a multi-character wildcard (*) with a single term (not a phrase).
For example, syn*ize returns items containing the terms synchronize and synthesize.

IMPORTANT
To avoid a syntax error when you search, don't begin a search with an open or close
parenthesis followed by text or by itself.

• Boolean operators — Boolean operators in ALL CAPS to combine phrases or terms.
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• OR (||) is the default Boolean operator when you enter two terms or phrases. For example,
primary test OR sample returns items that contain either primary test OR sample.

• AND returns items where both terms and phrases exist. For example, primary test AND
sample returns documents that contain both primary test and sample.

• + returns items that must contain the term or phrase immediately following the +. For example,
+primary test returns items that must contain primary and might contain test.

• NOT (-) excludes items that contain the word or phrase after NOT. The application doesn't allow
null searches, so you must enter something before the word NOT to get any results. For example,
primary test NOT sample returns items that contain primary test but not sample.

• Parentheses — Use parentheses to group clauses and form sub-queries. For example, (tests OR
samples) AND maps returns results that contain tests and maps OR samples and maps.

• Prefix — Use the prefix tag: to indicate the tag field in your query. For example, tag: require-
ment management AND tag:security.

• Field name — Use field names followed by a colon to search for information in specific fields. If
a field name contains spaces, replace the space with an underscore character (_). For example,
user_status:new returns items with a User status field that contains new.

A note about special characters
A few special characters are automatically excluded (escaped) from full text search, so that they can be
searched for as plain text.

The auto-escaped characters are: \ ^ [ ] { } ~ /

If you used \ to manually exclude special characters, you can achieve the same results by using double
quotations. For example, if you previously searched using \*abc to treat the * character as text, you can
now use “*abc” instead.

NOTE
Special character search only works with newly created items. To use with older items,
re-index the items you want to use in the search.

Search for content
When you need to search across all projects or within a current project, you can enter a query in the
search field.

NOTE
This search method is for a simple search. For more complex searches, use advanced
filters [142].

For projects or sets to appear in your search results, you must have read permissions for them.

To search for content:

1. In the header next to the Search field, select where you want to search using the drop-down menu.
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• Project — Within the current project.
• All — Across all projects in your organization.

2. Enter your query in the search field and press Enter.
A wildcard is automatically added to the end of your search term. For example, if you search for
term the wildcard returns the results term, terminal, terminus, termites, etc.

3. (Optional) Select Include wildcard results to add a wildcard to the front of your search term.
For example, if you search for term and select this option, results return docuterm, postterm,
syncterm, etc.

4. (Optional) Select Filter items to refine your search. For details, see Filter items for targeted
results [140].

The results appear in List View.
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Filter items for targeted results
Using a filter is an easy way to refine your search results. To limit and focus your text search, you can
filter content by author, date, or coverage.

Filters can't be saved. If you want to reuse a specific filter, use the advanced filters [142].

1. In Projects, select Filter items to open the Filter by panel.

2. Define how you want to filter your results. Filters are cumulative and the options you select are
displayed at the top of the screen.
• Keyword — Enter a term in the Keyword field.
• Item Type — Templates for sets used within each project. For example, you can filter by System

Requirement, Set, Folder, or more.
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• Author — The person who created or last modified the item.
• Direct Coverage — Parameters for upstream, downstream, missing, and suspect relation-

ships [307].
• Last Modified — Time stamp of when the item was last modified.

The search results appear in List View.
3. When you're done, select Hide filters to close the panel.
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All filters that were applied to the item are preserved and visible at the top of the page.

Advanced filters
With the Advanced filters feature you can save a filter (a set of rules or conditions) for later use, as well
as share it with other users.

This feature lets you add advanced filters [143], edit advanced filters [143], bookmark them, filter the
Explorer Tree [147], and send items for review [166].

Rules and conditions

• Each rule is matched to a specific item type or to all item types that have a specified conditions.
• A condition describes specific attributes of an item such as fields, tags, relationships, location, key-

word, or if the item has children.
• Each rule can contain any number of conditions.
• A rule can be set to return items that follow any one of the conditions, all of the conditions, or none of

the conditions.

Finding advanced filters
In the left panel next to the Explorer Tree tab, select Filters to display a list of existing filters.

TIP
To find out the author of a filter, hover over the filter name.
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IMPORTANT
You can delete a shared filter even if you’re not the creator. Before you do however,
make sure the filter isn’t shared. When you delete a shared filter, it's deleted for
everyone.

Add or edit advanced filters
For best search results and quality performance, make your filters as specific as possible to return only
the results you need.

If you run a filter against all your Jama Connect projects, the results you get might be too broad to be
helpful and performance can be affected by such a large data set.

NOTE
Only organization admins can edit filters that they didn't create. Depending on your
permissions, you might not be able to edit filters that were created by other users. To
view their details, right-click on the filter name under the Filters tab and select View
criteria.

1. Select the Filters tab in the Explorer Tree.
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2. Select Add filter to open the New filter window.

3. Enter a name for the filter and select an option to indicate the project scope:
• This project only — Queries data from the project the user is viewing at the time. The filter

appears only when using this project.
• Current project — Queries data from the project the user is viewing at the time. But the filter is

also available for use in other projects.
• All projects — Pulls data from every project in the organization that the user has permissions to

view. Using this option, you can see items from other projects that match the filter criteria.
4. (Optional) Select Make public to make the filter available to anyone with access to the project.
5. Define your filter with available conditions, which depend on the selected item type.

• Add rule creates a new rule. A filter can contain any number of rules. 
• + adds a condition.
• – removes a condition.
• Add condition group (blue button) adds a condition group, which depends on the selected item

type.
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• this filter... opens the Embedded Filter window, where you can add a sub-filter to your relation-
ship condition.

For example, you can create a filter to identify change requests with downstream relationships
and a sub-filter to limit downstream items to the relationship item type.

• Limit to items updated within options limit the filter to items updated within a certain time
frame.

• Sort order for results by options define how results are sorted on output.
6. Select Preview <number> Results... in the bottom left corner of the New filter window. Results

appear in the same window.

Results example:
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7. (Optional) Click View in List to see the filter items in List View.
8. When finished creating and editing your filter, click Save.

Duplicate advanced filters
To save time when creating advanced filters, you can duplicate an existing filter, then edit it for another
search. This is especially useful with complex criteria.

1. View your saved filters by selecting the Filters tab in the Explorer Tree.

2. Right-click on the filter you want to copy and select Duplicate Filter.
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3. In the window that opens, enter a name for the copy and edit the filter settings [143] as needed.

4. Click Save.

Filter the Explorer Tree
The Explorer Tree can contain a lot of items, which can be difficult or time-consuming to find what you
need. To quickly locate multiple items, apply an existing filter.

1. View your saved filters by selecting the Filters tab in the Explorer Tree. 
2. Right-click on the filter you want to use and select Apply filter to Explorer.
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The filter results are shown in the Explorer Tree. Items in the hierarchy that don't apply are shown in
lighter text.

Export from advanced filters
You can use advanced filters to export data directly to Word, Excel, or PDF.

If you view your filter results in Reading View, the hierarchy container items are visible. These items
offer visual context and are included in your export. However, you can't select or change the items from
this view.

1. Create the advanced filter [142] that gathers the items you want to export. 
2. Select Export and choose the output type.

The file opens in a new tab.

Quick find
Use this handy table to quickly find the Jama Connect feature you need.

NOTE
When viewing Jama Connect on a small screen, icons are displayed as image-only,
without the text.
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To find... Where Select...

Baselines Explorer Tree Baselines tab

Dashboard • Upper left corner of the screen
• Explorer Tree

Project name

Homepage Top header from anywhere in Ja-
ma Connect

House icon

Impact Analysis Single Item View Single Item View > Impact analysis

Image-only version:
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To find... Where Select...

Item versions Single Item View (side toolbar) Versions widget

Relationships Single Item View (side toolbar) Relationships widget

Relationship Sta-
tus Indicator

• Side toolbar
• In a column in List View (when

configured)

Relationships widget

• Top number -- Represents the number of upstream items rela-
ted to this item.

• Bottom number -- Represents the number of downstream
items.

Relationship
rules

Single Item View Relationships widget > Relate items in the bottom panel >
Show relationship diagram at the top of the right panel

For more information, see Find relationship rules [157].
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To find... Where Select...

Releases Top of the left panel Releases

Review status Header Reviews

• Grid -- Displays review status at the bottom of each card.

• Table -- Displays review status in the Review status column.

Risk analyses Header Risk

Suspect links • List View
• Single Item View
• Advanced filters
• Explorer Tree

You can find suspect links from several places in Jama Connect.

For more information, see Find suspect links [158].

Test cases • Explorer Tree
• Projects > List View
• Projects > Trace View

You can find test cases from several places in Jama Connect.

For more information, see Find test cases [160].

Test plans Explorer Tree Test Plans tab > <plan>

Trace View Projects Trace View button

Jama Connect User Guide

151



To find... Where Select...

Traceability Ma-
trix

Projects > Project > Traceability Trace Matrix

Find an item in the Explorer Tree
If you navigated to an item from search results, filter results, or tags, you can quickly locate an item in
the Explorer Tree.

NOTE
If a component, set, or folder contains over 250 items, some items aren't visible in the
Explorer Tree.

Use one of these methods to find an item in the Explorer Tree:

• From the Single Item View toolbar, use interactive links to find a location in your project hierarchy.

• From the Explorer Tree, view the highlighted item you want to find.
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Find moved items
If you don't know where to look for items that were moved, you can use the Activity Stream to find and
access recently moved items. This is also an easy way to move all items back to the previous location
(or to another location) after a move is made.

To find moved items:

1. Open the Activity stream [237] and enter moved in the search field.

2. Select View Moved Items to see the files that were moved.

The results appear in List View.
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3. (Optional) Hover your mouse over the location to see the file path.

Find synchronized items
With reuse and synchronization, you can duplicate supporting information and continuously keep it in
sync. Supporting information includes any item, container of items, or a project.

Only an organization admin can configure reuse and synchronize [556].

Use one of these methods to identify synchronized items or find reused items:

• Explorer Tree — In the Explorer Tree, a blue dot indicates that an item was synchronized.

• List View — Select an item in List View, then select Reuse to open the Reuse item(s) window.

• Reading View — Select an item in Reading View, then select Reuse to open the Reuse item(s)
window.

• Document View — Select an item in Document View, then select Reuse to open the Reuse item(s)
window.

• Project drop-down menu — An organization or project admin can select Project > Sync items to
open the Sync items window, or Project >Manage all projects to duplicate (and optionally synchron-
ize) projects [637]. 

• Manage all projects — An organization or project admin can select Project > Manage all projects
to duplicate (and optionally synchronize) projects [637]. 

• Stream — Reuse and synchronization of items adds activity entries to the stream [252] for all items
created or modified during the process.

• Synced items window — Right-click on any item in the Explorer Tree, then select View synched
items to open the Sync Items window. There you can select any item or container on the left to see
which other items have the same global ID.
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• Bottom panel — Open an item in Single Item View, then on the right toolbar, select Synchronized
items to open the bottom panel, which displays all items currently synchronized with this item.

Find advanced filters
Once advanced filters are created and saved, you can view them in a list and find out which user
created each one.

1. From the project with the existing filters you want to view, select Filters.
2. Hover your cursor over the filter name to see who created the filter.

IMPORTANT
You can delete a filter when you no longer need it. Before you do however, make sure
the filter isn’t shared. When a shared filter is deleted, even if you're not the creator, it's
deleted for everyone.

Find review status
Quickly find a review status using one of these methods.

In some cases, the review status value in Grid View is different than in Table View. For example, In
Progress (Table View) vs X days left (Grid View).

• Select Grid to see the review status at the bottom of each card.
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• Select Table to display review status in the Review status column.

Find relationships
You can view and filter [314] related items filter related items in Single Item View, in either a table or a
visual layout.

1. In Single Item View, click Relationships in the side toolbar, which opens the bottom panel and
displays related items in a table.
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2. To see a different perspective with links to more rapid actions, you can click Visual Layout in the
bottom panel.

Find relationship rules
Relationship rules are set up by an organization admin [571], but can be viewed by all users in two
places.

1. In Single Item View — Select the Relationships widgets, select Relate items in the bottom
panel, then select Show relationship diagram at the top of the right panel. The relationship
diagram for this project appears in a pop-up window.
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2. From the dashboard [408] — When you select your project in the Explorer Tree, the dashboard tab
displays the relationship diagram.

Find suspect links
You can use several methods to find and clear suspect links [315].

1. To view and clear suspect links [315] for a project, select Project > Suspect links.

2. To view and clear suspect links [315] for an item, open an item in Single Item View [59] and select
Relationships in the side toolbar to open the bottom panel.
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The Suspect column reports if an item is suspect due to upstream changes.

3. In List View or Single Item View, view suspect links in the Relationship Status Indicator [308].
4. Find suspect links using advanced filters [142].

Find the Trace Matrix
The Trace Matrix is a visual representation of relationships between the items in a project.

To access the Trace Matrix:

1. Select Projects in the header.
2. Select Project > Traceability > Trace Matrix.
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The Trace Matrix window opens, which provides a visual representation of relationships between
the items in a project.
For example, you can select a set of requirements and see which have related test cases.

Find test cases
Use one of these methods to find test cases.

1. Use the Explorer Tree [47].
2. Select Projects > Trace View [58] . Test cases appear in relationship to items they test, along with

associated test runs.
3. Select Projects > List View [54] and filter by item type name.
4. Select Test Plans > Test Cases. Test cases appear in the test cases section of the plan.
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Find test plans
A test plan is an item that documents the overall strategy for validating or verifying that a product or
system meets its design specifications and requirements.

Although test plans are items, they aren't visible in the Explorer Tree. They are visible on the Test Plans
tab.

1. At the top of the Explorer Tree, select the Test Plans tab

2. Select the plan you want to use to view details [374] of that plan.
3. View and comment on test plans in review [376], as needed.

TIP
Although test plans don't appear in the Explorer Tree, you can reveal them with an
advanced filter [142].
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Reviews in Jama Connect

Reviews play a key role in successful product development. They help ensure that a new project meets
stakeholder, market, and compliance requirements.

Jama Connect uses an iterative and collaborative approach for reviewing requirements and other
artifacts in real-time, which improves stakeholder alignment, reduces review cycles, and eases the path
to compliance.

Your organization administrator configures review center settings [632] to meet the needs of your
organization.

Review features include a wizard that streamlines review setup and electronic signatures for coordina-
ted approval and signoff.

Roles for review workflow
Your role determines which tasks you perform in a review.

Moderator — Create, manage, finalize, and close a review. Only moderators can comment on a review
that has been Closed for feedback.

Approver — Provide feedback and approve or reject the item during the review.

Reviewer — Provide feedback.

Review Administrator — See and manage all reviews.

Role Responsibilities and actions

Moderator • Initiate a review.
• Add and manage review participants.
• Modify a review.
• Edit an item to incorporate feedback.
• Close and reopen a review.
• Publish a revised review.
• Finalize a review.
• Archive a review.
• Delete a review.
• Recover an archived review.
• Transition items based on item workflow.
• Remove items.

Reviewer* • Contribute feedback.
• Finish a review as a reviewer.

Approver • Contribute feedback.
• Approve or reject review items.
• Delegate approval.
• Finish the review as an approver.
• Add electronic signatures to a review.

Review administrator • View a list of all reviews.
• Perform administration tasks for all reviews, whether or not they were invited to participate.
• Archive and unarchive a review.
• Recover a deleted review.
• Configure review comments.

All • Find and view review items.
• Compare versions.
• Monitor progress.
• Vote on items.
• Subscribe to items on the page.

* Moderators and approvers can also perform all reviewer actions.
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Review lifecycle — Who does what during a review
Action Moderator Reviewer Approver Review Ad-

min

Initiate a review [166] X

Invite participants [171] X X

Add and manage review participants [173] X

Modify a review [174] X

Delegate approval [190] X

Participate as a reviewer [184] X X X

Find and view review items [195] X X X X

Contribute feedback [185] X X X

Finish the review as a reviewer [187] X X

Finish the review as an approver [188] X

Electronically sign the review [189] X

Incorporate review feedback [175] X

Close a review [177] X

Mark a review as completed and update workflow status [183] X

Compare versions [202] X X X X

Monitor progress [205] X X X X

Vote on items [209] X X X X

Subscribe to items on the page [209] X X X X

View list of all reviews [164] X

Perform administration tasks for all reviews [192] X

Archive a review [179] X X

Recover an archived review [180] X X

Recover a deleted review [192] X

Configure review comments [193] X

Remove or recover items in a review [181] X

Workflow status for reviews
The review status field shows the current workflow stage (status) of a review. This field changes as a
result of other operations, like closing and archiving a review.

In Grid and Table View, you can quickly find a review status.

In some cases, the review status value in Grid View is different than in Table View. For example, In
Progress (Table View) vs X days left (Grid View).

Grid View Table View

Jama Connect User Guide

163



Status Definition Grid
View

List
View

In progress Default status when moderator initiates a review [166] . Status can be changed to
“In progress” when the moderator restores a deleted review or marks the review
status as "In progress [155]."

No Yes

Completed Status displayed when a moderator selects Close for feedback or a deadline
date is met.

Yes Yes

Review final-
ized

Status when a moderator marks a review as finalized. Yes No

Archived Status when a moderator archives a review [179], or when a review administrator
recovers a deleted review or sets the status to "Archived."

Yes Yes

Deleted Status when a moderator or review administrator deletes a review [179]. No Yes

Review Center dashboard views
Access reviews from the top navigation by selecting Reviews in the header.

From the header, you have two options:

My reviews All reviews where you are assigned as a reviewer [184], approver [187], or moderator [165].

All reviews Reviews that haven't yet been archived.

What you see in the dashboard

What is displayed in the dashboard depends on your role, whether you’ve been invited to a review, and
the options you select.
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Review administrators — See all reviews.

Users — See only public reviews until they are invited to a review (depends on how your organization
administrator and moderator have set public review permissions).

Filter by — Filter reviews by review status or by your role in the review.

Include/Hide archived reviews — See reviews that have been archived or remove them from your
results.

The indicator for a public review depends on your view:

Grid View Table View

Moderator tasks
Certain tasks can only be performed by a moderator. Moderators can also be reviewers or approvers, in
which case they can perform all tasks for those roles as well as moderator tasks.

• Initiate a review [166]
• Add and manage participants [173]
• Modify a review [174]
• Incorporate feedback for review items [175]
• Close an "in progress" review for feedback [177]
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• Finalize a review [179]
• Publish a revised review [178]
• Archive a review [179]
• Delete a review [179]
• Recover an archived review [180]
• Remove or recover items in a review [181]
• Transition a Peer review to an Approval review [182]
• Close and finalize Approval review [183]

Initiate a review
You can create reviews for any item or group of items that you can access. By default, you are the
moderator for any reviews you create.

You can start a review from several places in the interface. Whichever method you use, a wizard opens
and guides you through the process.

Method/location Action

Reviews Select Reviews in the top navigation, then select Start a review.

Test plan Select Test runs > Cycle > Send for review to send a cycle of test runs to review.

Note: To send an entire test plan for review, select Test Plans, right-click on the test plan, and select
Send for review.

Projects > Single
Item View

Select the item you want to review, then select Send for review.

Projects > List View Select the items you want to review, then select Send for review.

Explorer Tree Right-click on an item and select Send for review.

Filters tab — Right-click on the filter that points to the items you want to review, then select Send for
review.

Releases tab — Right-click on the filter that points to the release you want to review, then select Send
for review.

Baselines tab — Right-click on the source that includes the baselined items you want to review, then
select Send for review (reviews the items in their current state, not their baselined state). If all items
from an existing source were deleted, you can't select Send for review from the baseline tree.

TIP
When you initiate a review, a baseline of the selected reviews is automatically gener-
ated [292]. You can find this baseline [292] under the Baselines tab or you can find a
link under the Versions tab of any item in this review.

To start a review:

1. Select the items you want to review using one of the methods described in the previous table.
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2. Definition [167] — Define your review.
3. Settings [169] — Configure the settings for your review.
4. Participants [171] — Configure who you want to review your items.
5. Invitation [172] — Complete the invitation email.

Definition
When you initiate a review [166], the first step is to define the review.

1. If you selected items before initiating the review, the system suggests a name, or select a name for
the review.

2. Set a deadline for the review, or the deadline defaults to one week from today.

NOTE
If you're using Windows, be sure that "Adjust for daylight saving time automatical-
ly" is enabled in "Date and time" settings in Windows, so that the time zone is
displayed correctly when initiating a review.

3. If you selected items before initiating the review, the Project field shows the name of the source
project. Otherwise, select the Project that contains the items for this review.

4. If you selected items before initiating the review, this field isn't editable. Otherwise, select the items
that you want to review.
You can select whole containers or expand the containers to select individual items. You can also
use the Releases or Filters tab to select a release or filter to send to review. You can't select items
from multiple tabs. Use the Select button to indicate your choice is complete.
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5. Select Include item attachments to add item attachments to the review.

When the review is created, you see attachments for the item in each section of the review (if they
exist). Select the attachment link to open the latest version of the attachment.

6. Select Include related items to see options for making upstream and downstream items visible in
the review (as long as such items exist).
You see each item type that's related either upstream or downstream, along with a count of the
number of related items.
Select Show filters to filter those relationships by relationship type.
Select the related items you want to include in the review.
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7. Select Next.

Settings
When you initiate a review [166], the second step is to choose the review settings. This image shows
the default settings. Additional settings are available only if they are configured by an organization or
process administrator.
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You see the Review template option if it's enabled in Review center by an organization admin.

1. Select electronic signature settings.
If you select Require electronic signatures from approvers, all approvers must sign the review
in order to approve it. Select Enable signature group for approvers if you want your review sig-
natures to have a particular signer role. Find out more about how electronic signatures work [257].

2. Select permission settings.
Allow for review comments to also appear in the single item view within a project:
Administrators must first enable this option in the Review Center Settings for this option to
appear.
Make public: This option makes the review visible beyond those invited to participate. An organi-
zation administrator determines whether public reviews [632] can be seen by anyone with access
to reviews, or only by those with permission to ALL items in a review.
Let approvers add reviewers and approvers: Select to allow approvers to add others to the
review.
Let approvers delegate their review to others: Select to allow delegation of the approver role. If
an approver is assigned a signer role, and they delegate their approver role, the signer role is also
delegated.

3. Select optional settings.
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Enable time tracking: Check this box to track the amount of time each reviewer spends within the
review. The clock that tracks the time is visible to all participants in review statistics [205].
Notify me when a participant finishes a review: Check this box to send notification emails [228]
to the moderator when a reviewer marks a review complete or when a participant requests a new
version.
Enable voting: Check this box so participants can provide input on priority or other issues the
moderator needs to resolve. Read more about voting [209]. If you select this box, you are asked to
designate the number of votes per user and a label for what the vote means.

4. Select Next.

Participants
When you initiate a review [166], the third step is to choose review participants.

IMPORTANT
Inviting anyone to a review gives them read access to the entire content of the review,
even if they don't have permission to the underlying items. 

1. Using the left column, select participants for this review.
Use the tabs at the top of the column to select from users on the project team, or from outside
the project team.
You can select individuals or groups. Search by name or email using the field at the top of the list. If
you select a group, you can add all users or select individual users from the group.
Select the Invite user by email tab to invite users from outside of Jama Connect. Those users
receive an email invitation with a link to the review. When they select the link, they are given a
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reviewer license (as long as there are floating reviewer licenses available) and are asked to set up
an account. They can only access the review you invite them to.

IMPORTANT
An organization administrator can disable this function or can restrict the domains
for which outside review invitations are allowed. [632]

2. Selected participants appear in the right panel. Select a review role for each participant (approv-
er [187] or reviewer [184]).
If you enabled signer roles [169], you can also assign a signer role to each approver.
Signer roles are based on groups. If you select a group name, then select All users, the signer role
for those users defaults to the group name.

3. Select Next.

Invitation
When you initiate a review [166], the final step is to complete the invitation.

1. You see a draft of the email that's sent to participants. At the top, it shows the total number of
participants who receive the email and their roles.
Fields for the email subject and message are the only two fields you can modify in this panel.
The email also shows the review role and signer role as determined in the participants pan-
el [171]. For reviews that have participants with different reviewer roles, light gray text shows
information that might vary for each participant.
The signature meaning is the same for all reviews and defaults to "I approve this review" and
can't be modified.
The email includes a link to the review and the deadline.

2. Select Initiate review to receive a confirmation that your email was sent.
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Add and manage review participants
As a moderator, you can add or remove moderators from your review.

Important considerations

• If you remove yourself from a review, you no longer have access to that review. All added and
existing moderators receive email notifications for changes to the list of moderators during the review.

• Moderators can be added to a review regardless of their access rights to the items in the review.
However, when a new revision for the review is published, it includes only items that moderators
have write access to. This can have unexpected consequences for reviews sent from filters, such as
missing or extra items in the new revision.

To add and manage review participants:

1. In a review, select Add moderators.

If you are viewing multiple reviews in the Table View, select Update moderators for this review.

The Update Moderators window opens.
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2. Add moderators from your team (Project Team tab) or from outside your team/Jama Connect
(Outside Project Team tab).

3. To remove a moderator, select the X next to the name in the Review Moderators panel.
4. (Optional) Add a comment about the changes you made.
5. To finish, select Update Moderators.

Modifying an "In progress" review
You might want to change the content that's included in a review, the due date, or the participants. You
can also close a review so that feedback is no longer allowed.

Only a moderator [165] or a review administrator [192] can change a review.

You can change a review from different locations and views in Jama Connect:

• In a review, use the Manage review drop-down menu.

• In Reviews > Table View, use the Actions column.
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The icons in the Actions column are:
Edit — Open the wizard where you change the deadline, invite new reviewers, or change an approv-
er’s status (role).
Reopen — Open a review that was closed.
Delete — Remove a review permanently (only a review administrator can recover a deleted review).
Update moderators  — Add to or remove moderators from your review.
Archive  — Remove the review from the list that appears to users.

Modifying a "Closed" review
A review closes automatically on the end date and time or it can be closed manually by the modera-
tor. When a review is closed, reviewers can no longer add comments.

Important considerations

• As the moderator, you might want to reopen a closed review to allow more feedback, archive the
review, or publish a new version.

• Only a moderator or a review administrator can edit a review.
• When viewing a closed review, you see a blue status bar at the top of the review, which notifies

participants if a review is closed.

Use these buttons to do the following with a closed review:

• Archive — Remove a review from the primary list of reviews.
• Recover — Recover a review that was archived or deleted. No item updates are published.

Incorporate review feedback
A moderator can incorporate feedback by editing an item directly from the review.

1. From the header, select Reviews, then open the item using one of these menus:

Triangle drop-down menu Menu next to item's name

You can also select the name of the item you want to edit to open it, then select Edit item from the
menu on the right. 

2. In the window that opens, make the changes you need.
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3. (Optional) Select Notify to designate people or groups you want to inform about this change, then
choose the people to be informed.

Your changes are saved in the project, but not in the review.
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Any time an update is made to an item that's in review, a blue status bar appears at the top of the
review. The review remains unchanged until the moderator publishes a new version.

4. Select Commit.
5. To update change in the review click Publish new revision.
6. In the window that opens, select one:

• Publish — Update the review for all participants.
• Modify review — Make further changes to the review itself in the wizard.

Participants receive an email notifying them about the new revision.

Close an "In progress" review
A review closes automatically when its deadline is reached. A moderator might want to close a review
manually before the deadline if, for example, all reviewers already provided feedback.

Once a review is closed, a moderator can recover it by changing the status back to In progress.

1. To close a review manually that you are currently viewing, select Manage review > Close for
feedback.

The closed review now displays the message “This review is closed” in the blue status bar.
2. To reopen a closed review, select Recover.
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The blue status bar no longer appears when the review is reopened.

Publish a revised review
When changes are made to the original review items, you can publish a new version of the review that
includes the changes.

1. Open a review that includes changes. The text in highlighted in blue indicates the number of
pending updates.

2. Select Publish new revision to include these changes in the review.

3. In the Publish new revision window, select an option:

• Publish — Publish the revision immediately (available only when a new version of an item is
created).

• Modify review — Change more options for the review in the wizard.

A confirmation message confirms that the revision was successfully published.
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Finalize a review
When you’re satisfied that your review is complete — that all items have been reviewed and approved
and that all comments have been resolved — the next step is to finalize the review. 

Important considerations

• When you finalize the review, the review workflow tool automatically updates the status of the review
items. For example, at the end of a review, a moderator can trigger the status of reviewed items to
change from "In review" to "Approved." 

• If workflow is assigned to an item type in your Approval review [633], the item will transition. If you
don't use a template, the review is marked as finalized.

• When you reopen a finalized review, items are transitioned to their previous review status.

To finalize a review:

1. In the review, select Manage review > Mark review as finalized.

2. In the window that opens, select Finalize review.

This action automatically triggers Review Status Workflow, which updates the status of the review.

Delete a review
You can delete a review, but not if it includes electronic signatures. However, if an entire project is
deleted, all reviews in that project are also deleted, even if they include electronic signatures.

Once a review is deleted, only a review administrator can recover it.

1. From the header in the review, select Delete review (trash icon).

2. When prompted to confirm, select Yes.

Now, when a user selects Reviews, the review that you just deleted is no longer listed with other
reviews.

Archive a review
When a review is archived, it's no longer visible in the list that’s displayed when users select Reviews in
the header.

Reviews can only be archived by moderators and review administrator, and only if their status is
“Closed.”

As the moderator, you can control which reviews are visible to your participants:

• Select Filter by > Include archived reviews.
• Select Filter by > Hide archived reviews.

To archive a review:
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1. From the header, select Reviews > Table. 
2. In the Actions column of the review you want to archive, select the folder icon to archive the

review, then confirm when prompted.

Recover an archived review
A moderator or review administrator can recover a review that was archived [179].

Important considerations

• When an archived review is recovered, the participant roles and contributions are unchanged. For
example, if an approver signed and approved a review before it was archived or deleted, it remains
the same after the review is recovered.

• If items were edited after a review was archived or deleted, they don't appear in the recovered review
until the moderator publishes a revised review.

• You can recover an archived review from the review’s Actions column or from its blue status bar.

1. To recover an archived review from the Actions column:
a. From the header, select Reviews > Table.
b. In the row with the review you want to recover, select the Reopen icon from the Actions

column.

c. In the window that opens under Select review status, use the drop-down menu to select "In
progress,"  select a new end date and time, then select Save.
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2. To recover an archived review from the review’s blue status bar:
a. Open a review that was archived.
b. From the header, select Recover.

Remove or recover items in a review
A moderator can remove or recover items in a review, and can perform either of these actions without
altering the source in the project.

Important considerations

• When you pair these actions with the Approval workflow, those items remain in their original state and
aren’t updated when the review is finalized.

To remove items from a review:

1. In the review with the item you want to remove, select the triangle drop-down menu, then select
Remove next to the item.

The "Tagged for removal" label appears.
2. Click Publish new revision to remove the item from the review.
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3. In the Publish new revision window, click Publish.
A label appears with the version the item was removed in.
Anyone who has access to the review can see items that were removed.

To recover items in a review:

1. From the triangle drop-down menu, select Recover to recover the item you removed.

The "Tagged for recovery" label appears.
2. Click Publish new revision to recover the item in the review.

Transition a Peer review to an Approval review
When reviewers are done looking over a Peer review, the moderator can transition a review to an
Approval review.

Important considerations

• Both templates must be enabled [633] by an organization administrator.
• When an item is tagged for removal or recovery, and you want to transition to an Approval review,

those items are automatically updated.

To transition a Peer review to an Approval review:

1. In the review, select Manage review > Transition to Approval.

Jama Connect User Guide

182



The Transition to approval review wizard opens.
2. On the Definition page, make your changes, then click Next.

3. On the Settings page, confirm you’re using the approval template, then click Next.

4. On the Participants page, make your changes, then click Next.
5. On the Invitation page, update the subject and message as needed, then click Transition review.

A revision is created and an email notification is sent to reviewers.

Close and finalize an Approval review
After the review is approved, the moderator closes and transitions items to their approved state. You
don’t need a Peer review to finalize an Approval review.

Workflow must be enabled [33] in Admin > Organization for the items in the review, or the option to
Close and transition items won't appear when you finalize a review.
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Example with workflow disabled

To close and finalize an Approval review:

1. In the review, select Manage review > Finalize approval review.
Wizard opens. You can change the name, deadline, and participants.

2. View the review overview and workflow transitions, then click Finalize review.

The review is now closed.

Reviewer tasks
• Contribute feedback [185]
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• Finish a review as a reviewer [187]

Reviewers can also perform tasks that are available to all review roles.

For example:

• Find and view review items [195]
• Compare versions [202]
• Vote on items [209]
• Subscribe to items on the page [209]

For details, see Tasks for all review roles [195].

Contribute feedback
Once a review is created, all participants can read through the items, make comments, and ask
questions.

Important considerations

• By default, you see only comments made in a specific version. For example, comments made in
version 2 only appear in that version.

• Once a review is closed, reviewers can no longer comment.

To contribute feedback:

1. From the review, open the Comment window using one of these methods:
• Select the Comments icon next to the item.
• Select the text you want to comment on.

2. Type your comment.
3. (Optional) Apply a category to your comment to help participants understand and track key feed-

back.
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Category Outline color Meaning

Comment / Speech bubble Yellow Open

Green Acknowledged by Moderator

Question mark Yellow Open

Green Answered by Moderator

Pencil / Proposed change Yellow Open

Green Accepted by Moderator

Red Rejected by Moderator

Exclamation / Issue Yellow Open

Green Resolved by Moderator

4. Select Submit feedback to save the comment.

Additional ways to collaborate with your team

• Use the like icon when you agree with a comment and want to track how team members vote on a
decision.
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Finish a review as a reviewer
When you complete your work as a reviewer, the next step is to “finish” the review. This action lets the
moderator know you're done with your work (if notifications were set up) and updates the overall review
progress in review statistics [206].

If the review is closed before you finish the review, the blue status bar includes a message: “This review
is closed.”

To finish a review as a reviewer:

1. From the review, select Complete review on the toolbar. 

2. In the review summary window, add any final comments, select Finish.

3. If you need to make more comments after finishing the review, select Reopen review from the
toolbar, as long as the moderator hasn’t yet closed the review.

Approver tasks
• Approve or reject review items [188]
• Finish a review as an approver [188]
• Add electronic signature to a review [189]
• Add reviewers [191]
• Delegate approval [190]
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IMPORTANT
After delegating approval, you are no longer an approver, but you remain a reviewer
for the current review. If you delegate approval, all new approvers receive an email
notification.

Approve or reject review items
During a review, you can view items and their comments, approve or reject individual items, and
approve or reject an entire review.

If you don't see a checkmark or X, you don't have Approver status. Contact your Moderator if you need
Approver status.

1. To mark an individual item, select an icon next to its name:
• Checkmark = Item is approved
• X = Item is rejected

2. To mark all items on the page, use the Batch item actions drop-down menu:
• Mark entire page approved
• Mark entire page rejected

3. If your review contains more than one page of items, repeat this action for each page.

When you're done, the blue status bar includes the message “You’ve marked all items in the review.”
You can then finish the review as an approver and electronically sign the review.

Finish a review as an approver

1. When you're finished with a review, select Complete review from the toolbar.

2. In the Review finished window, you can mark any remaining items "Approved" and add a final
comment. These comments are visible under Reviews > Feedback in the top-right menu, or in an
email sent to the moderator if email notifications are enabled for this review. If this review requires
an electronic signature [189], you can also add that here.
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3. Select Request new revision or Approve (or Approve and sign if you're using an electronic
signature).

NOTE
If you change your mind and want to reopen your review after finishing a review as
an approver, you can select  Reopen review to re-open it, as long as the moderator
hasn't closed the review. If you're using an electronic signature [257], opening a review
revokes it.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.

1. In the Review finished window, enter your username and password as your electronic signature.
If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.
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Delegate approval
Assign approval to another team member if you're away when a review needs to be approved or
someone else is a better fit.

1. In the review, select Delegate approval from the toolbar.

2. In the Request reviewer delegation window, select a delegate.
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3. Click Delegate approval.
A confirmation message appears.

4. Click Yes to confirm.

An email is sent to the new approver notifying them of the request.

Add reviewers
Approvers can add reviewers to an open review at any time.

1. In the review, select Add participants.

2. In the window, select the review participants you want to add.
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3. Click Add participants.

An email is sent to the reviewers notifying them of the request.

Review administrator tasks
• Recover a deleted review [192]
• Configure review comments to appear in projects [193]
• Recover an archived review [180]
• Modify a review [174]
• Make a review public [169]

Quick tips

• Permissions for a review admin must be assigned by an organization admin.
• As a review admin, you can access a review's content when the review is public; when you are also a

reviewer, approver, or moderator in the review; or when you add yourself to the review.

Recover a deleted review
Only a review administrator can recover a review that was deleted.

When a deleted review is recovered, the participant roles and contributions are unchanged. For exam-
ple, if an approver signed and approved a review before it was deleted, it remains the same after the
review is recovered.

If items were edited after a review was deleted, they don't appear in the recovered review until the
moderator publishes a revised review.

To recover a deleted review:
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1. From the header, select Reviews > Table.
2. From the FILTER BY... drop-down menu, select Deleted.

3. In the row with the review you want to recover, select the Recover icon in the Actions column.

4. In the Recover review window, select the new end date for the review.

5. Click Save.

The table is refreshed and the review is now open.

Configure review comments to appear in projects
Comments made during reviews can provide valuable context, whether you're reviewing a requirement,
lower-level feature, or test item. A record of those comments offers enhanced traceability, so you can
make informed decisions over the course of the item's lifecycle.

The review moderator can allow comments from a review to appear in the project view for that item.
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When enabled, the Review comments widget appears in Single Item View. Select it to see the review
comments for that item.

This option needs to be enabled in two places for it to take effect. The organization admin must enable
it in the Review Center Settings and the moderator must enable it when creating a review.

For the administrator:

1. Select Admin > Organization > Review center.
2. Under Permission settings, select Allow for review comments to also appear..., then click Save

settings.
This option is now available and visible to review moderators when they create reviews.

For the review moderator:

• When creating a review, select Allow for review comments to also appear in the single item view
within a project.
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Once enabled, comments are grouped by review and sorted with the latest comments at the top.

Quick tips

• Why aren't comments appearing? For review comments to be visible within a project, this setting
must be enabled for each review.

• How do I see comments from older reviews? For reviews created without this setting, you can go
back and change this setting to include review comments.

• View More — Appears if there are more comments from that review that haven't loaded.
• Load More — Provides comments from older reviews that haven't loaded, including comments that

might have occurred since the page loaded.

Tasks for all participant roles
• Find and filter items in a review [195]
• Highlighting review comments [198]
• Compare versions [202]
• Show related items in a review [203]
• View participant progress [205]
• View item progress [206]
• View review activity [207]
• Filter review comments [208]
• Subscribe to a review [209]
• Export reviews [209]
• Voting [209]

Find and filter items in a review
All user roles can search for and filter specific items in a review.
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You can navigate to different areas of the review workspace without losing your filter or search selec-
tion. For example, if you make a filter selection and go to another view, your filter selection is saved
when you navigate back to the review.

Find items in a review

• Enter text in the Search field, then expand the Search by item types drop-down menu to filter your
search.

• Select the item type, then enter text in the Search field.

When you select an item from the search results or table of contents, the item is selected and outlined
in blue. In the Find items panel, you can refine your search based on the filtered results.
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• From the drop-down menu in the left panel of the review, select View in tree to open the Find item
panel and view the item in the review hierarchy. You can also resize the panel as need.

Filter items in a review
Use filtering to view items and comments that need your attention.

All review participants can filter items to find comments by status, version, author, or activity.
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All review participants can filter items to find comments by status, version, author, and activity.

All review participants can filter review items by Activity, Comments by status, Comments by ver-
sion, and Comments by author. Selecting and applying filters in a specific category is additive and
applies ADD statements to each selection. If you apply filters that span multiple filter categories, it
becomes an OR statement.

Highlighting review comments
You can organize and find comments based on their status: Open, Resolved, or Rejected. Comments of
each status type are highlighted by a different color (highlighting is turned on by default).

For example, a comment highlighted in yellow lets review participants know that it’s open, while a
comment highlighted in red indicates that a proposed change was rejected.

By default, the review version that you’re looking at shows only highlighted comments that are open,
resolved, or rejected.

When two highlighted comments overlap, that text is highlighted in light blue.
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You can only reject comments that propose a change.

Moderators resolve an open comment: select it, (optional) type a response and click Reply, then click
Resolve.

Jama Connect User Guide

199



The comment box and highlighted text changes to a resolved status (green).

Apply @mention to review comments
Use the @mention feature to direct comments to a subject matter expert. This is useful when you have
several reviewers and need to direct a question to a specific reviewer.

Important considerations

• Comments that include @mention are highlighted by color, based on whether you or another review
is tagged. Light yellow = comment for you. Light blue = comment for another reviewer.
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• Only users participating in the review appear in the list of possible reviewers who can be tagged with
@mention. You can modify the review [174] to add participants.

• Anyone who is participating in the review can @mention other participants.

To use the @mention feature:

1. In a review, select the comment icon and type @ followed by the name of the reviewer.
Repeat for each reviewer you want to mention.
Only the names of the people you included when you created the review [166] appear in the list.

2. Type your message, then click Comment.

3. (Optional) To display only items where you are mentioned, select Filter items > My mentions.
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An email notifies the tagged review participant with the review name, items, and comment.

Compare versions
Whenever a published review has more than one version, you can compare two versions.

Important considerations

• If you want to make other fields visible in the review, an organization administrator can configure item
type views [617] for Reading View or Single Item View to show those fields.

• Typically, item fields contain fewer than 10,000 characters (2,000 words). When you compare review
versions, the applications might skip fields with lengthy content.

• The date and version a comment was added appears in the comment.

To compare versions:

1. From the review with the versions you want to compare, click Compare.

2. Select the versions drop-down menu near the review title to select the version you want to compare
to the current review.
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Changes are displayed inline. Deleted text is red and highlighted. Added text is green and under-
lined.

The "compare view" displays inline changes for most field types. If the field can't be compared, you
see the message: Not available for reviews.

Show related items in a review
Including related items in a review gives reviewers context and helps them understand the coverage of
items in a review. Related items are visible only if the moderator selected the option Include related
items when the review was created.  
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If you don't have permissions to view a related item, you see an item type icon and the text This item is
outside the scope of this review.

To view items directly related to a review item:

1. In the review, select Show related items.

Initially, up to five upstream and downstream items are displayed.
2. To view additional related items, select Load More Downstream Items.
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3. Select a related item to see more details.

View participant progress
As a review progresses, you can view statistics about the participants' progress. This information is
unique to the current version of the review.

In separate tabs, you can see item progress [206] for this version, or review activity [207] across
versions.

1. From the review with stats you want to view, select Stats.

2. Under the Participant progress tab, you can see a panel with participant details and links to email
participants.
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Next to that, bar charts show overall progress for the review for approvers and reviewers who
have finished the review. For approvers the chart shows how many items they marked approved or
rejected. For other reviewers it shows how many items are marked read. Reviewers' time spent.
Below that, each participant is listed with their review role, signer role, signature information,
comment count, time spent shown in hours:minutes, and a progress bar showing their completion
level.

NOTE
Time is logged if a tab with the review is left open by a reviewer.

View item progress
As a review progresses, you can view statistics about the progress of the items in review. This informa-
tion is unique to the current version of the review.

In separate tabs, you can see participant progress [205] for this version and review activity [207] across
versions.

• From the review with the items you want to view, select Stats.

Under the Item progress tab, you see an overview with the total number of items in the review, their
item types, the start and end dates for this version of the review, the current approval status for all
items (if this review uses approvers), and a summary of open comments in the review.
Below that, is a table showing item fields along with the number of votes, as well as the number of
participants who marked the item approved, rejected, or reviewed.
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For reviews with multiple approvers, the item approval status count increases when all approvers
approve the item. However, it only takes one approver to reject an item for the rejected count to
increase. Items that aren't marked as approved or rejected are considered not reviewed. Items that
aren't marked as approved or rejected are considered not reviewed.
If you're a moderator, you see the preset filters to filter the list by item type, folder, or set. You can
use Views to configure which fields are visible in the table. You can use Actions to batch update
items [74].

View review activity
You can see all activities for a review across versions, including when reviews were opened, closed,
when new versions were published or when signatures were added. This can be useful for collecting
electronic signature [257] information for FDA 21 CFR Part 11 compliance.

You can also see item progress [206] and participant progress [205] for each version of the review.

1. From the review with activities you want to view, select Stats.

2. In the page that opens, select the Review activity tab.
The table shows activity for all versions since the review was created.
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Filter review comments
You can view and filter comments for all the items in a review to find only the comments you want to
see. 

1. From the review, select Feedback to see all the comments for the review, with a filter panel on the
left. 
You can read and reply to comments here.

2. (Optional) You can also use the filters in the filter panel to search for comments by category or
keyword. Available categories are:

All Every comment from the review.

Open Comments the moderator hasn't acknowledged or responded to

Mine Your comments

Review Comments sent to participants about the review by email

Important Comments flagged as important by a moderator

Questions Comments that are questions to be answered

Proposed changes Comments that suggest changes

Issues Comments that raise issues
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Subscribe to a review
If you're a review participant, you can stay up-to-date on review comments with email notifications in
reviews where you're a participant.

To receive notifications, you must first configure your review subscriptions [42] in your profile. You can
also configure your profile so that you automatically follow an item when you comment on it.

1. Open the review with the items you want to subscribe.
2. Select Subscribe > Subscribe to the items on this page.

IMPORTANT
Some reviews contain multiple pages of items. To subscribe to all the items in a
large review, you must subscribe to items on multiple pages.

Export reviews
You can export reviews as a Word document or a PDF by selecting Export anywhere in Reviews.

You have two export options:

• Export activity review — Includes all review activities [207] across versions (for example, when the
review was created, versioned, closed, marked as finalized) along with the date, name, and role of
the person responsible.

• Export version review — Includes an overview of the review, a list of participants with their review
role, signer role, signature meaning and status, as well as the content of the review and the com-
ments.

To download an export to your desktop:

1. In the review you want to export, select Export in the top right toolbar.
2. Select the type of export and format.

3. In the window that opens, choose how you'd like to open the file, then click OK.

The file opens in a new tab.

Voting
With voting, your team can prioritize items or rank them based on a topic proposed by the moderator.
Each participant has a certain number of votes. Participants can give multiple votes to a single item.

Moderators can enable voting in the settings [169] when they initiate a review.

Jama Connect User Guide

209



You can apply votes as a participant using one of these methods:

• Select the up arrow to add a vote or the down arrow to subtract votes. The box on the left displays
the number of votes you used on that item. You also see how many votes you have left to use.

• Participants can also apply votes while viewing an item's detail.
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Categories

In Jama Connect, the Categories feature allows you to organize and view cross-project items based on
classifications. Examples of classifications include configurations, allocations, releases, and features.

You can use the Categories feature to assign cross-project items like requirements, test cases, and
use cases to customer-defined groupings. According to your project needs, you can assign a single
category or multiple categories.

The Categories feature is disabled by default. The organization admin must enable it before the option
appears in Jama Connect. Once the feature is enabled, users with read/write permissions can make
edits. For more information, see Enable categories [215].

TIP
If you prefer to hide the Categories tab for a project, go to the Page layout settings
(gear icon > Change layout).

Your role determines your interactions when you use the Categories feature.

Role Responsibilities and actions

User with read permissions • View categorized items in the Category tree.
• See a list of cross-project items.
• View Category Path.
• View Category Path ID.

User with read/write permissions • Organize your requirements across projects.
• Apply a category to items from Single Item View, List View, or Reading View.
• View categorized items in the Category tree.
• See a list of cross-project items.
• View Category Path.
• View Category Path ID.

Organization admin • Control and manage the Category admin tree:
• Add, move, copy, and merge categories.
• Edit and delete categories.

• See category details like description and when it was created.
• View Category Path.
• View Category Path ID.
• View Category ID.
• Clean up categories.

Changes to the Categories admin tree affect any allocated items in your projects.

Managing categories in projects (users)
The interface for the Categories feature consists of multiple parts and depends on your view: List View,
Reading View, or Single Item View.
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1. Categories tab in the Explorer Tree — Select it to open the Categories UI.
2. Category tree — Select a category to view specific details about a category like the Category

Path. You can also expand the tree to see how your organization admin organized the hierarchy for
the categories they created.

3. Category Path and list of variations column — Displays the category variation paths and Cate-
gory Path IDs.

4. Applied column — Displays the version history, which allows you to see which version the item
was at when the category was applied. When you view an older version, you can see which
categories were applied or unapplied.

5. Manage categories button — Select it to open the Manage categories window where you can
apply and unapply categories.

Apply or unapply categories
When the Categories feature is enabled by the organization admin, you can apply categories to items or
unapply them as needed.

Important considerations

• You must have read/write permissions to use the Categories feature.
• You can select a maximum of 50 items at a time.
• Organization admins can allow users to manage categories on system-locked and user-locked items.

When enabled, users with read/write access can manage categories on locked items. For more
information, see Enable category management for locked items [216].

• Managing access will have an impact on cross-project use of categories. When a user is working with
a cross-project list in Reading View and they click Manage categories, the displayed categories are
limited to Global categories and categories that intersect with the selected projects.

• When you view an older version, you can see which categories were applied or unapplied.
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To apply and unapply categories:

1. Select the items where you want to apply or unapply categories.
2. Open the Manage Categories page depending on your view.

• List View or Reading View — Select the Manage categories button from the header.

• Single Item View — Select the Manage categories button from the Category Path table.

On the Manage Categories page that opens:
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• Categories column lists available categories to apply to selected items.
• Applied categories column lists categories already applied to the selected items.

3. From the Categories column, select the categories you want to apply: double-click a single cate-
gory or select multiple categories and use the arrows to move them to the Applied categories
column.

The selected categories are highlighted in yellow until you save your changes.
The bottom of the page lists the number of categories that will be applied and the number of items
that will be impacted.

4. To unapply a category, select it in the Applied categories column: double-click a single category
or select multiple categories and use the arrows to move them to the Categories column.
The selected categories are highlighted in yellow until you save your changes.

5. Click Save to apply your changes.

Controlling the Categories feature (organization admins)
The Categories feature allows users to organize and view items in a cross-project hierarchy. It allows
users to see how items and components can build a final product.

The Categories feature is disabled by default. As the organization admin, you must enable it for the
option to appear in Jama Connect and be available to users.
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When this feature is enabled, organization admins can interact with:

1. Categories admin tree
• Create a hierarchy that is specific to your company's workflow.
• Add, move, copy, and merge categories.

2. Selected category path option
• View category details like description and when it was created.
• Remove category.

3. Variations of selected category option
• Edit and delete a category.
• View category paths, associated variation path, and category IDs.

Example Category ID: CAT-123

Category ID encompasses all variations of a category

Example variation path ID: PATH-123

Variation path ID is specific to each path

4. Clean up categories option
• Perform a manual update to applied categories on current and historical items.

When enabled, users with read/write permissions can interact with:

1. Categories tab in the Explorer Tree
2. Categories table in Single Item View
3. Manage categories button in Single Item View, Reading View, and List View

Enable the Categories feature
You must enable the Categories feature before users with read/write permissions can apply categories
to items. By default, this feature is disabled.

To enable Categories:
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1. From the Jama Connect header, select Admin > Categories.
2. Next to Enable categories, select On.

The Categories option is now visible in Jama Connect and available to users.

Enable category management for locked items
Organization admins can allow users to manage categories on system-locked and user-locked items.

Important considerations

• This option is disabled by default.
• When enabled, users with read/write permissions can manage categories on locked items.
• When you enable or disable this option, a message appears in the Admin Activity stream.

To enable category management for locked items:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. Select Allow category management for locked items.

The ability to manage locked items is now available to users.

Add a new category
Create a hierarchy or a list of categories that users can apply to organize project requirements.

To add a new category:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. In the Categories admin tree, click Add.
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3. In the Add category window, enter a name, then click Add.

Your new category appears in alphabetical order in the tree and is immediately visible in all Jama
Connect projects.

Edit category properties
You can change the name of an existing category.

When you edit a variation of a category, all variations are changed and add an optional description.

To edit category properties:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. In the Category admin tree, select the category that you want to edit.
3. Click Variations of selected category, then select the pencil button.
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4. In the Edit category window, enter a new name or description, then click Save.

The change appears in the Category admin tree and is immediately visible in all Jama Connect
projects.

Remove a category variation
To disassociate requirements related to a category or to update the hierarchy, you can remove a
category variation.

Removing a category variation removes only that single variation. For example, if you have two varia-
tions of a category called “Transmission,” you can remove the variation that is no longer needed, and
the other variation remains unchanged. To remove all variations of a category, see Delete a category.

Important considerations

• Categories that no longer belong to a variation are deleted.
• Nested categories are removed.
• Nested categories that are orphaned are deleted.
• Organization admins must delete a category with only one variation. When you delete the only

variation of a category, the Category ID is deleted along with the remaining Category Path ID.
• All items, including locked items, are updated to reflect the category changes made by the organiza-

tion admin.

To remove a category variation:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. From the Category admin tree, select the variation you want to remove.
3. Click Selected category path, then select the minus icon.

4. When prompted to confirm, click Yes.
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The selected category is removed. Nested categories are removed and descendant categories that are
orphaned are deleted. All items associated with these categories are updated.

Delete a category
When you delete a category, all variations of that category are also deleted.

For example, if you have two variations of a category called "Transmission," and you delete either
variation, both variations are deleted from the Category admin tree along with the associated Category
ID.

To remove only one variation of a category, see Remove a category variation.

Important considerations

• Deleting a category affects all variations of a category and can have a widespread impact on
your category hierarchy.

• Nested categories are deleted.
• Nested categories that are orphaned are deleted.
• Categories that no longer belong to any other variation are deleted.
• All items, including locked items, are updated to reflect the category changes made by the organiza-

tion admin.

To delete a category:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. In the Category admin tree, select the variation that you want to delete.
3. Click Variations of selected category, then select the trash icon (Delete category variations).

4. When prompted to confirm, click Yes.

The selected category and all variations are deleted. Nested categories are removed and descendant
categories that are orphaned are deleted. All items associated with these categories are updated.

Organize the Category admin tree
You can organize the Category admin tree to reflect how your items are structured. After completing a
move, copy, or merge, items with those applied categories are updated to reflect the new hierarchy.

Important considerations

• When you drag a category to an existing category, it is nested under the category you selected. A
new variation is created. Items with those categories are updated to reflect the new hierarchy.
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• Copying a category duplicates it and its nested categories to the area you selected in the Category
admin tree. New variations and Category Path IDs are created. Items with those categories are
updated to reflect the new hierarchy.

• Merging two categories, from the move or copy actions, duplicates the selected categories and its
nested categories to the area you selected in the Category admin tree. New variations and Category
path IDs are created. Items with those categories are updated to reflect the new hierarchy.

To organize the Category admin tree:

1. From the Jama Connect header, select Admin > Organization > Categories.

2. From the Category admin tree, select the category you want to update, then do one of the follow-
ing:

• Move — Drag and drop it to the new location in the Category admin tree, then select Move
category.
If a duplicate category exists in the location you selected, you have the option to merge them.

• Copy — Drag and drop it to the new location in the Category admin tree, then select Copy
category.
If a duplicate category exists in the location you selected, you have the option to merge them.

• Merge — Click Yes, then select Move and merge category or Copy and merge category.
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3. Click Save.

All items associated with these categories are updated.

Managing category access to projects
Organization admins can configure a category’s visibility to hide or show one, many, or all projects.

Important considerations

• When an item is deleted and restored, associated categories are not restored.
• If a project is archived and restored later, associated categories are not restored.

Category access types

Unassigned access: Not visible in projects.

Project access: Visible in one or more projects.

Global access: Visible in all organization projects.

As projects are added to the organization, visibility is applied automatically.

Unassigned categories — Unassigned categories are not visible in any of the organization's projects.
This includes project views, List View, Reading View, Single Item View, tree views, and the Manage
categories window. When new categories are added, users don't have access by default, so that the or-
ganization admin can configure new categories without disrupting existing work or revealing categories
to the entire organization.

Project access — Project access categories can only be seen and used in specific projects set by the
organization admin. The organization admin manages access and makes any necessary changes.

Global access — Global access gives all projects the visibility to a category. Select Global access to
enable or disable this option at any time. When enabled, all active organization projects can see that
category. The Manage access option is disabled because all projects are set to Visible.

NOTE
If the user disables Global access, the category is converted to a Project access
category and the visible projects are still accessible. The user can choose to manage
access and make any necessary changes.
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Add Categories field to items in review
For the Categories field to appear in Review Center Reading View and Review Center Single Item
View, organization admins must add it to an existing item type.

1. Select Admin > Organization, then select Item types.

2. In the Item types section, click Views in the Action column for the item type you want.

3. In the View window that opens, select Review Center Single Item View from the drop-down
menu.
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4. Drag Categories from the Hidden fields column to the Visible fields column, then click Save.
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5. From the drop-down menu, select Review Center Reading View.
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6. Drag Categories from the Hidden fields column to the Visible fields column, then click Save.
7. Click Close.

The Categories table now appears when users are in a review.
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Configure access to projects
Access to a project can only be managed on one non-global category at a time. Organization admins
can hide or display any projects that are active in the organization.

Important considerations

• You can only edit access to projects on top-level parent categories. All child categories inherit the
top-level (parent) access to projects. This action also affects all move, copy, and merge actions.

• Organization admins can’t edit category access when categories are applied to items in the project
they are trying to remove. Applied categories must be unapplied from all items in the selected
projects before category access can be hidden. This action also affects all move, copy, and merge
actions.

To configure access to projects:

1. From the Jama Connect header, select Admin > Organization > Categories.
2. In the Categories admin tree, select the Project category you want to update, then click Manage

access.

The Manage access window opens.
3. From the Hidden projects column, select the projects you want to be visible: double-click a single

project or select multiple projects and use the arrows to move them to the Visible projects column.
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The selected categories are highlighted in yellow until you save your changes.
The bottom of the page lists the number of projects that will be hidden or visible and the number of
categories that will be impacted.

4. From the Visible projects column, select the projects you want to hide: double-click a single
project or select multiple projects and use the arrows to move them to the Hidden projects
column.
The selected categories are highlighted in yellow until you save your changes.
The bottom of the page lists the number of projects that will be hidden or visible and the number of
categories that will be impacted.

5. Click Save to apply your changes.
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Collaborating with your team

For companies to turn today’s research into tomorrow’s products, teams must stay connected and
synchronized. Jama Connect equips teams to track decisions and ensure quality of the product they set
out to build.

Jama Connect links globally distributed team members and facilitates collaboration in the product
development lifecycle. It allows you to provide and capture feedback, decision making, and approval for
requirements and all product aspects under review.

Jama Connect enables efficient sharing of data, documents, files, information, and knowledge within
and across teams in your organization.

Use these features to work with your team, document conversations, and track decisions.

• Reviews [162] — A method to help teams, stakeholders, and customers discuss, evaluate, revise,
and approve items in the development process. For details, see Reviews in Jama Connect [162].

• Workflows [230] — An automated set of transitions, from one status to another, over the course of
an item's lifespan.

• Notifications [228] — Optional emails sent to groups or individuals to alert you when changes to
items are made.

• Stream [236] — A collection of the most recent comments and activities in the project.
• Electronic signatures [257] — A method for getting approval on electronic documents or forms.

Email notifications and subscriptions
Users can configure email and notification settings in their profile [41] to stay up to date with activity in
their projects.

IMPORTANT
To receive notifications in Jama Connect, your SMTP must be enabled by your system
admin.

You can sign up for notifications to be sent to you automatically from several places in Jama Connect.

Notifications from... Sent to you...

Review [166] When you're invited to participate

When someone replies to your comments in a review

Workflow [653] When status of an item changes

Stream [246] When you're mentioned in the stream

System Health Report [556] With updates on license usage

Your Jama Connect administrators control what you can do with subscriptions. For example:

• Organization administrators — Can allow users to subscribe others and to mute subscriptions.
• Project organization administrators — Can unsubscribe groups or individuals from any of their

subscriptions.

As a user, you can:
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• Set up notifications for a single item in a project or for an entire project.
• Configure email notifications and subscriptions.

Subscribe to emails for yourself
You can subscribe to a single item, to multiple items, or to an entire project.

1. To subscribe to a single item, select the item in Single Item View, then select Subscribe.

2. To subscribe to multiple items:
a. Open the items in Project > List View.
b. Select each item you want to subscribe to.
c. Select Subscribe.

A confirmation message appears below the toolbar.

Subscribe other users to email notifications
You must be a system, organization, or project administrator to subscribe others to all items at a project
level.

1. To subscribe others to a single item, select the item in Single Item View, then select Subscribe >
Subscribe others.

2. To subscribe others to multiple items:
a. Open the items in Projects > List View.
b. Select each item you want to subscribe to.
c. Select Subscribe > Subscribe others.
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d. In the Subscribe others to all items window, select the groups or users that you want to
subscribe to this item.

e. Click OK.

Workflow
A workflow is a set of transitions from one status to another, over the course of an item's lifespan. 

All workflows must be set up by an organization or process administrator before they can be used.

Workflow can be used in these scenarios:

• Project items [230] — Creates a common pathway for items to follow.
• Review items [633] — Allows organizations to configure items to transition to a specific workflow state

following the review process.

Using workflow in Projects
You can set up a workflow for Project items, so that users at your organization can move items in your
project along a similar path as they progress. 

Workflow in Projects allows you to:

• Update status for an item or group of items. Items must be the same type and in the same workflow
state.

• Transition items from one status to the next, either for a single item or as a batch transition for a
group of items.

If workflow is configured by an organization [653] or process admin, use the drop-down menu in Single
Item View to move the status of an item along the workflow and activate any related actions or
notifications.
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Use workflow to batch transition items
With batch transitions, you can select multiple items of the same item type and transition them to a
different workflow status.

IMPORTANT
All items that you transition must be in the same state. For example, you might batch
transition all "In Progress" items to a "Complete" status, but you can't select both "In
Progress" and "Proposed" items for batch transition.

To use workflow to batch transition items:

1. Select the project, folder, or set that contains the items you want to transition and view them in List
View. Select the items you want to transition, then select Actions > Batch transition. 

2. In the Batch Transition Workflow window, confirm your item selection, choose the status, add a
comment, then click Commit.
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Your comment appears in the version history of the item and as an activity in the stream.
A batch transition is the only way to add a version or notification comment.

3. The status change is shown for each item you transitioned. 

Use workflow to batch transition items in reviews
With batch transitions, you can select multiple items of the same item type and transition them to a
different workflow status.
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IMPORTANT
The items you select for transition must be the same item type and workflow state.

To use workflow to batch transition items in reviews:

1. When you're in a review, select Stats > Item progress.

2. Scroll to the bottom of the page and select items of the same item type and workflow state that
are to be transitioned. You can select multiple items by using Shift or Ctrl keys. Select Actions >
Batch transition workflow.

NOTE
You can also batch update non-workflow fields, but you can't batch delete from
here.
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3. In the Batch transition workflow window, select the set of items you want to update and the
intended workflow transition, then click Commit. 

If the workflow doesn't have another transition state to select, you don't have permission or the item
is locked. A pop-up window displays a warning that you can't proceed.

Lock items in a workflow
Locking items in a workflow can help avoid unwanted changes. For example, a project administrator
might want to leave items unlocked while in "draft" status, but lock them when they reach "approved"
status.

NOTE
You must have organization or project admin permissions to configure workflow.

Important considerations

• Items can also be automatically locked by the workflow [230]. These items show a gray lock after
their name and a blue lock in List View. 

• System-locked items unlock when transitioned through the workflow or by an organization or project
administrator.
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To add an automatic lock to the workflow:

1. Select Admin > Project > Workflow.
2. For the item you want to lock, select Override.
3. In the Lock? column, select the lock icon to include (or remove) an automatic lock in the workflow.

4. Click Save settings.
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Stream — Staying connected
The stream is where you can see the most recent comments and activities of your Jama Connect
project.

The stream is built on three basic activities:

• Connect
• Communicate
• Collaborate

Working with the stream
With everyone having the most up-to-date information through the stream, stakeholders stay informed
and aligned.

You can:

• Include stakeholders in a conversation [244] by name or email.
• Keep up to date on the latest activities [241] for a project or item.
• Clarify conversations by using actions [248] like questions, decisions, or issues.
• Include whiteboards, prototypes, or other images [247].
• Filter the stream [250] to include only comments or activities that refer to a specific project, item, or

person.
• View the stream across projects [255], at an item level [252], or at a project level [254].

Types of streams
Jama Connect includes streams for specific types of collaboration and activity.

Global Stream [237] — At this level, you see a collection of the most recent comments and activities.
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Project and Item Activity Stream [237] — At this level, you see comments and activities for the entire
project.

Item Collaboration Stream [238] — At this level, you can see comments and connected users related
to a specific item.

Baseline Activity Stream [240] — At this level, you can monitor activity, quickly find a baseline ID, or
see if a signature is revoked.

Review Activity (Stats) [240] — At this level, you can see all activities for a review across versions,
including when reviews were opened, closed, when new versions were published, or when signatures
were added.

Admin Activity Stream  [549]— At this level, you see an audit trail of updates made by organization
and project administrators.

Global stream
At this level, you see a collection of the most recent comments and activities.

How to access
From the header, select Stream.

What you can do
See the most recent comments related to an item.

Project activity stream
At this level, you see comments and activities for the entire project.
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How to access

• Select the project name to open the Activity Stream.
• If you don’t see the Activity Stream, click Add widget. In the window, select Activity stream, then click

Add. You must have Project Admin permissions to do this.

What you can do

• See comments and activities for the entire project.
• See changes to items — Adding, editing, or deleting content from item fields, commenting on an item;

using features like releases, baselines, or reviews that impact the item.
• Find out when a review is opened, revised, closed, reopened; when signatures are added or revoked.
• View items that are reused and synchronized and reuse details that appear in the activity stream.

Users with read permission can view details about reused items and can select a link to view newly
copied and synchronized items.

• From a project, select the Collaboration Stream View icon to see information only for that project.

Item collaboration stream
At this level, you can see comments and connected users related to a specific item.

Here's an example of what the stream looks like in List View and Reading View:

How to access
There are several ways to view the stream at the item level.

• In Project > List View, select the speech bubble icon.
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• In Project > Reading View, select the speech bubble icon.

• In Project > Single Item View, select the speech bubble icon.

What you can do
• See comments and connected users related to a specific item.
• See changes to items — Adding, editing, or deleting content from item fields, commenting on an item;

using features like releases, baselines, or reviews that impact the item.
• View items that are reused and synchronized and reuse details that appear in the activity stream.

Users with read permission can view details about reused items and can select a link to view newly
copied and synchronized items.
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Baseline activity stream
At this level, you can monitor activity, quickly find a baseline ID, or see if a signature is revoked.

How to access
Select the Baselines tab, baseline name, and View details (which changes to View items) to open the
Activity stream.

What you can do

• Monitor activity, quickly find a baseline ID, or see if a signature is revoked.
• View changes to baselines — Adding (manually or automatically with a review), editing, or deleting*

baselines or sources. Visible to users with read-only permission. Baseline activity streams.
*Deleting requires admin permissions. Baselines with e-signatures can’t be deleted.

Review activity (stats)
At this level, you can see all activities for a review across versions, including when reviews were
opened, closed, when new versions were published, or when signatures were added.
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How to access

• In the review, select Stats to open the activity page.

What you can do

• See all activities for a review across versions, including when reviews are opened, closed, when new
versions were published, or when signatures were added.

• Find out when a review is opened, revised, closed, reopened; when signatures are added or revoked.
• See when items are sent for review.
• See all activity for a single review across revisions in the Review activity tab.

Activity stream
Activities are the recorded changes made to an item, including editing, commenting on, relating to other
items, deleting, and restoring.

You can view activities at an item level [252] or a project level [254]. You can also view activities specific
to different parts of Jama Connect, such as reviews [207] and baselines [291].

These are the types of activities that appear in the stream.
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Activity type Definition Visible in...

Changes to items Adding, editing, or deleting content from item fields; comment-
ing on an item; using features like releases, baselines, or re-
views that impact the item.

Project activity stream

Item activity stream

Changes to baselines Adding (manually [282] or automatically with a review [287]),
editing, or deleting* baselines or sources. Visible to users with
read-only permission. Baseline activity stream [291] shows all
activity for a baseline.

Baseline activity stream

Project activity stream

Reused and synchronized
items

When items are reused and synchronized [320], details of re-
use appear in the activity stream. Users with read permission
can view details about reused items and can select a link
to  view newly copied and synchronized items. 

Project activity stream

Item activity stream

Comments Comments related to an item or project. Review comments
aren't included in activity stream.

Collaboration stream

Reviews When review is opened, revised, closed, reopened; when sig-
natures are added or revoked.

Project activity stream

Review activity (stats)

When items are sent for review, see all activity for a single
review across revisions in the review activity [207] tab.

Review activity (stats)

* Deleting requires admin permission. Baselines with e-signatures can’t be deleted.

Comments
Comments are user-created messages that you can see in the stream or in reviews.

Comments are visible:

• At an item level [252]
• At a project level [254]
• In reviews [185]
• Across projects [255]

You can add and delete a comment as well as restore comments that you deleted. You can also add a
hashtag (#) to a comment for filtering or add a reference to a specific person, project, or group. 

Add, delete, or restore a comment
All comments made in Jama Connect are displayed in the stream. You can see any comment you have
permissions to view.

Important considerations

• You can add comments, delete comments that you made, and restore comments that you deleted.
• You can also restore comment threads or replies that you deleted, but only if they were associated

with an item. You can't restore deleted comments that aren't associated with an item. 
• When the discussion gets long, Jama Connect shows only the most recent comments. Select View

all replies to expand the thread and show all comments. Select Hide replies to collapse the thread.

1. To add a comment to the stream, an item, or a project:
a. Open the stream at an item level [252], project level [254], or across projects [255].
b. Enter your comment:

• New comment — In the Stream comment box.
• Replying to a comment — In the reply box below the comment.
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c. (Optional) As needed, you can refer to a particular person, group, project or item [244], request
or resolve an action [248], upload an image [247], or add a hashtag [243].

d. Select Comment.
2. To delete a comment:

a. Select Delete below the comment.
b. When prompted, click Yes.

3. To restore a deleted comment:
a. In Single Item View, select the Activities widget to open the bottom panel.

b. In the deleted comment, select Restore.

c. When prompted, click Yes.
The comment is restored and appears in the My Settings section.

Add a comment hashtag
By adding a hashtag to your comments, you can quickly filter the stream by selecting the hashtag itself.

Important considerations

• Tags begin with the # character and are lowercase letters with no spaces.
• Comment tags are different from item tags. Comment tags are added to comments and can be used

to filter the stream, but item tags are added to an individual item and can be used to search or group
items.

To add a comment hashtag:

1. In the Stream comment box, type # followed by the tag. For example, #alert or #review.

2. Click Comment.
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The comment appears in the stream thread.

Use @mention to add a reference
To increase the efficiency and usability of your comments, you can refer to specific items, projects,
people, or groups with @mention.

Anyone you include in a comment receives an email notification [246].

1. Open a list of names (items, projects, people, groups) using one of these methods:
• In the comment field of the Stream window, type @ followed by the first few letters of the name.

• Below the comment field of the Stream window, select @.

2. Scroll through the list to select the name you want to include in your comment.

The name that you included appears as a bold link in your comment.

Add someone from outside Jama Connect
You can add a commenter who is not part of Jama Connect. They get a temporary license [583] that
allows them to view the comment threads to which they were invited. They can also see descriptions of
referenced items in the thread. 

Once you send the invitation, the person can optionally set up a user login and password, which is then
available in the @mention drop-down list. The license expires after 30 days —and the user is locked
out of Jama Connect — unless it is changed to a permanent one. They can still be @mentioned in
stream if the license has expired, but they can no longer access the conversation or items.

NOTE
An administrator can grant invited users permission [664] to view additional project
data.
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To give stream access to someone outside of Jama Connect:

1. In the comment field of the Stream window, type @ followed by the user's email address to trigger
an invitation, then select the blue Invite bar that appears.

2. In the Invite User window that opens, enter the full email address and click Invite.

3. Type your note and click Comment. 

The person you invited now automatically receives stream emails [246].

View referenced projects and items
When a project or item is referenced with @mention, you can view it in its activity stream.

1. To view a reference to a:
• Project — Open the project's activity stream.
• Item — Open the item's activity stream in Single Item View.

2. (Optional) In the activity stream, select Description to see details about the referenced project or
item.
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3. (Optional) Select View additional references to see more than the first displayed reference.

Email notifications for the stream
Jama Connect includes several types of email notifications, including ones initiated in the stream. This
information applies only to stream email notifications.

Adding participants
When you comment on an item or project in the activity stream, you can add people to a comment by
using @mention. This includes people who aren't current Jama Connect users.

When you receive stream notifications
Initial email — When your name is added to a comment in the stream.

Update email — When anyone replies to a comment thread where your name was added.

New comments — If you subscribed to the item.

Quick tips
• If you are in multiple groups that are mentioned in a comment, they receive only one email for each

comment or reply.
• When participants receive an email because they're mentioned in the stream, they can comment di-

rectly to the thread by replying to that email.  A copy of the comment is emailed to everyone on the
thread.

• Email updates contain links to see the entire comment thread in Jama Connect.

NOTE
Replying to a thread by email works for comment threads in the stream, but not for
comments in reviews.
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• To stop receiving email notifications for a comment thread where you’re mentioned, go to that thread
in the stream and select Mute.  Do this for each thread that mentions you.

NOTE
Once you mute notifications for a thread, you only receive future emails if you're
specifically mentioned in a comment or if you're a member of a group that's also
referenced.

Upload images to the stream
You can include useful photos (meeting notes, white board drawings, or prototypes) in the stream by
uploading images.

To upload images to the stream:

1. In the Stream window, select the Image button.

2. Select the image file you want to upload, then select Open.
The image appears in the stream comment field.

3. (Optional) To resize the image, hover over the bottom right-hand corner of the image, grab the
handle and drag the corner to the required size.

4. (Optional) To move the image in the comment, hover over the top left-hand corner of the image and
grab the handle. Drag the image to the correct location in the comment.
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5. Select Comment.

The image you uploaded now appears in the stream.

Request or resolve an action
Actions can highlight important conversations in the stream by identifying a comment as one of three
types: decision, question, or issue.

Actions also help clarify your request to someone you include in your comment. You can also filter by
actions [250] to see what questions, issues, or decisions need attention.

To request or resolve an action:

1. To initiate a request, choose from the Actions menu or type a ! in the comment box and choose an
action from the menu that appears.

When a comment contains a request action, the left edge of the comment is outlined in yellow and
a blue button invites other users to resolve the action (Answer question, Make decision, Resolve
issue).
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2. To respond to a request, choose from the Actions menu: Decision, Answer, or Resolution.

Tips and more

• Resolved actions are displayed in green.

• Open actions are displayed with a yellow border.

Jama Connect User Guide

249



• Use the like icon when you agree with a comment and want to track how team members vote on a
decision.

• Select the number next to the like icon to see who agreed.

Filter the stream
Filters let you see only comments that matter to you. When you create a filter, it remains active only if
the session is active.

If you want to reuse a filter, you can save it. You can also bookmark a filter in your browser to view later.

NOTE
You can create custom filters [252] at an item level to filter comments or activities in the
stream.

To filter the stream:

1. Open a Stream window and select the Filter comments field.
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2. Enter one of the following and select from the displayed menu to create a filter:

# Displays a menu of hashtags.

@ Displays a menu of users.

! Displays a menu of actions.

Keyword Displays a menu of frequently used names for people, groups, projects, or other content types.

3. Select an option from one of the menus or press Enter if you entered a new keyword.
4. (Optional) To filter by actions, select the Quick filters menu. These filters are additive so you can

filter on multiple actions.

The filters you choose appear below the comment field. The stream is refreshed with each filter you
add or delete.

5. (Optional) To save a filter, select the bookmark button and enter a name for the filter, then select
Save.

6. To set a quick filter from a comment, select people, projects, items, or other boldfaced references in
the comment. These filters aren't additive.

7. (Optional) To share a filter with another Jama Connect user, copy the URL of your filtered results
and send it through email.
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View collaboration stream at an item level
You can view the stream [236] comments and activity for an item, for example, to see all "Open"
(unresolved) questions about that item. A speech bubble icon includes a number that indicates how
many comments were recorded for that item.

NOTE
The side toolbar is only visible if it is configured by the organization administrator [611].

To view collaboration stream at an item level:

1. Select an item’s speech bubble icon using one of these methods:
Projects > Reading View

Projects > List View
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Projects > Document View

Single Item View > Side toolbar

2. In the window that opens, select the silhouette icon to view comments, add comments, or view
connected users.

To view comment and activity stream:

1. In Single Item View, select the Activities button on the side toolbar to see the history of an item.
The number on the button indicates the item's activity.

2. The bottom panel displays the stream and all activities (such as edits, reviews, relationships) and
comments for this item. From here you can add a comment, search the stream with a keyword,
refresh the display, or hide the panel.
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3. Use the three buttons in the top left corner of the stream to:
• Display active comments
• Display all activities
• Apply a custom filter to activities

4. Select the settings (gear) icon in the top right corner to open the Activity Filter Settings window.
5. Keep the default settings or customize keywords, activity type, date range, or item type, then select

Apply. Your custom filters are saved across items.

View collaboration stream at a project level
You can view the stream [236] at a project level, you see comments [242] and activities [241] for the
entire project in the project dashboard.

Important considerations

• Any comments you enter at this level automatically refer to the selected project.
• If the stream doesn't already appear on your project dashboard, a project or organization admin can

add it.

Open the project dashboard using one of these methods:
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• Explorer Tree — Select the main project level in the Explorer Tree or select the name of the project
just above the Explorer Tree.

• Stream — Select Stream (comment bubble) in the upper right navigation.

View global stream across projects
View the stream across projects when you want to do a search or filter projects. For example, if you
want to see open questions that are assigned to you for all projects.

To view the stream across projects, use one of these methods:

• Select Stream from the top navigation. This displays all comments from all projects, starting with the
most recent.

• Select View All Stream Activity from the home page to see all comments across projects.
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View connected users
A connected user is a creator, editor, or someone who has commented, subscribed, or been @men-
tioned on an item.

View connected users to see who is connected to items. For example, if you're changing a requirement
and want to see who might be impacted by a change.

To view connected users:

1. Open the Connected users window using one of these methods:
• Single Item View — Select the connected users icon.

• List View — Select the user icon.

2. Select Show indirectly connected users to view users who are interested in items related to this
one.
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3. (Optional) To toggle the related users on or off, select the circle icons at the top of the list.

You can now view the list of connected users and make comments in the stream.

Electronic signatures
An electronic signature is a way for project participants to virtually approve reviews, baselines, and
electronic documents like test plans and requirements.

Review moderators can require a signature for a review and add a signer role. All review signatures
carry the Signature meaning: "I approve the content of this review."

Electronic signatures consist of a username and password. They are captured with a time and date
stamp and an audit trail. Each signature is tied to the individual user, as well as to a baseline or review
where the signature was added.

Electronic signatures, time stamps, signer roles, and signature meaning are all visible in review activi-
ty [207].

Things to know

• For easy identification, a baseline with an electronic signature includes a blue dot and white exclama-
tion mark in the baseline tree.

• As the moderator, you can add a signer role or a reason for signing to a review signature [189], but
not to a baseline signature.
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• Signatures are enabled by default, but can be disabled by a system administrator.
• Electronic signatures depend on the authentication system your organization is using. Authentication

properties can be configured by a system administrator.
• You can't delete a review with an electronic signature, or a baseline created from a review with an

electronic signature.
• You can revoke your signature if it was signed in error or something needed to change. Select

Revoke to cancel your signature. Only the user who signed the baseline can remove their signature.
When revoking a signature, you can leave a reason for revoking, which appears in the activity stream
as a comment.

• As an approver, you can reopen a review that you signed, but this revokes your signature.
• To see a review that was signed, look in the participant progress [205] or review activity [207] tab.
• Self-hosted customers can't edit a baseline that is signed.

NOTE
You can't delete a review with an electronic signature, or a baseline created from a
review with an electronic signature.

Electronic signatures depend on the authentication system your organization is using.
Authentication properties can be configured by a system administrator.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.

1. In the Review finished window, enter your username and password as your electronic signature.
If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.
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Add signer role
As a moderator, you can enable the signer role for other approvers. This allows them to associate their
role with their signature. Signer roles are created from user group names.

If your moderator is inviting a user from outside of Jama Connect, they must log in and register before
you can assign them to a group. After your organization or project admin adds them to a group, the
moderator can edit the review to give them a signer role.

1. Initiate a review [166].
2. Make sure electronic signatures and signer roles are enabled in settings [169].
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3. To invite participants [173], select the user, then use the Signer role drop-down menu to assign a
signer role.

• If the user belongs to multiple groups, you can choose their role as signer from multiple options.
• If they don't belong to any groups, their role is "Not assigned."
• To add a signer role, create a user group [574] with a name that indicates the role you want to

represent (for example, QA, Business Analysts, Security). Be sure the person you want to assign
the role to belongs to that group.

• If you select a group in the participants panel, select Add all users. The signer role defaults to
the name of that group.

4. Click Initiate review.

Approvers assigned a signer role are notified of their role in their email invitation [172].

TIP
After a review is signed, anyone with permission to a review can view signer roles that
were used for a signature under review activity [207].

Sign a baseline electronically
If your business process dictates that signatures must be applied to collections of data such as base-
lines, electronic signatures can be associated directly with a specific baseline. Signatures can also be
captured and associated with a baseline if signatures are collected during a review.
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1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then click View
details.

2. Select Add signature.

3. In the Electronic signature window, enter your username, password, and any optional comments,
then click Save. Username and password must match that of the logged in user.
If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.
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Managing your content

Content in Jama Connect uses an item-based approach, where items are the major building blocks for
your content. Managing your content includes planning, organizing, and tracking progress and impact.

• Item versions [263] — Each time you change an item, a new version is created. You can compare
versions [265] and make a past version current [264].

• Change requests [268] — Change requests are items that call for a change to a product or system.
• Releases [272] — A release is a group of items that are developed together and mapped to a specific

completion date.
• Baselines [275] — A baseline in Jama Connect is a snapshot of your project at a point in time.
• Coverage and Traceability [302] — Coverage is the extent to which items are validated by another

item. Traceability shows the relationship between items that depend upon and define each other.
• Reuse and synchronization [320] — With reuse [322] you can duplicate supporting information for

any item, container of items, or even a project. With synchronization [329] you keep items continu-
ously in sync.

• Exports [344] — Select the data you want to export directly to Word [346] or Excel [347].

Item versions
A new version of an item is created each time you change a field value for that item.

When you view item versions, these details are visible:

• Baselines and reviews that include the specific version of that item.
• Automatically generated change details.
• User comments applied by the person who made the changes.
• Date when the item was changed.
• Name of the person who made the changes.

NOTE
To add a version comment when you save the item, see Version Comments.

To view an item's versions, click the Versions widget in the side toolbar, which opens the bottom panel.
There you can compare versions [265] or make a past version current [264].
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The current version number appears next to the item name. From the Version drop-down menu, select
the version of the item you want to view.

Change the current item version
When you make a past item current, the system creates a new version with field values identical to the
version you chose. This preserves a past version if you need to revert to it.

Important considerations

• Past versions of a test cycle can't be made current.
• Pick list values that existed when the previous version of the item was active are restored, even if a

value was removed.
• For items that were converted from one type to another, you can't use the Make Current option to

revert to the previous item type.

To change the current version:

1. In Single Item View, click the Versions widget to open the bottom panel [59].
2. In the row with the version that you want, click Make Current.
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3. In the Restore version window, click Confirm.

The screen is refreshed and a note appears in the column User comment and transitions.

Compare versions of an item
You can compare different versions of an item to track changes.

1. Click the Versions widget to open the bottom panel in Single Item View [59].
2. Select the two versions you want to compare, using the buttons in the From and To columns, then

click Compare.

In the Version Compare window:
• Selected From version is on the left.
• Selected To version is on the right.
• Changes are displayed inline.
• Deleted text is red and highlighted.
• Added text is green and underlined.
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TIP
Select Hide Details to see a side-by-side view of the versions without the colored
inline changes. Jama Connect highlights the entire field where the versions differ.

View previous versions of an item
In Single Item View, you can view differences between items that have more than one version. View the
history of an item to quickly identify changes and track progress.

Important considerations

• You can only edit the current version of an item.
• The Relationships widget is the only available widget.
• When you view an older version, you can see which categories were applied or unapplied.

To view a previous version of an item:

1. From the Explorer Tree, select the item you want to view.
The item opens in Single Item View.
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2. From the Version drop-down menu, select the version of the item you want to view.

The screen displays the information for the version you selected.
3. Select the Relationships widget to view all relationships for the version you are viewing.

Suspect information doesn't appear in the relationship table.
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Change requests
Change requests are items that call for a change to a product or system. 

When an item type is activated as a change request [608], you can add new change requests and
associate them with other items [268]. 

With change requests you can:

• Use Associate item(s) [268] to associate the change request with those items directly impacted by the
request.

• Use Impact Analysis [271] to determine if and how your change requests affect other items.
• Send a change request to review [166] to gather feedback from stakeholders and determine if the

change request is approved or rejected.

Add a change request and associate items
When an item needs to be altered, you can add a change request, which helps track the requested
change.

As the author of a change request, you can capture the details of the requested change, manage the
status of the change request, add and update the associated items, and close the change request as
item updates are made.

NOTE
The change request must be an available item type for your project. Available item
types are managed by the project admin.
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1. To create a new set of Change Requests in your project:
a. Right-click on the project and select New item > Set of... > Change Requests.
b. In the Add Item window, enter a name for the set, for example, Change Requests.
c. Click Save and Close.

2. Add a new item [69] to that set.
3. Select the item, then open the bottom panel by clicking the bell widget (Items to be changed) from

the side toolbar. This widget only appears when configured by an organization admin [611].

4. Click Associate Items in the bottom panel, select the items that apply to this change request, then
click Associate.

IMPORTANT
Change request items can't be associated with other change request items.
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The associated items appear in the bottom panel with links to those items. Each item includes the
starting version (when the change request was introduced) and the ending version, which fulfills the
change request.
When you view other items that were associated with this change request, you see the same
widget in the right toolbar of their Single Item View, as well as any change requests they're
associated with in the bottom panel.
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Edit a change request association
Edit change request associations to indicate which version is the starting or ending version of a change
request.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Double-click in the row with the item you want to update. 
3. In the window that opens, change values for Starting Version, Ending Version, and Note as

needed.

4. Click Save.

Run Impact Analysis on a change request
Before implementing a change request, you can determine its impact on related downstream items.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Select the item you want to know more about, then select Actions > Impact Analysis.

The Impact Analysis is displayed as a highlighted table, listing all items directly associated with
the change request. Also, any items that are downstream from directly associated items are shown
with their degree of separation from that item.

Jama Connect provides the visibility of the potential impact of a change request. The impact is then
used to analyze the requested change to determine if any impacted items need to be updated.
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Delete change request associations
If you included an item in a change request and later determine that the item isn’t impacted by the
change, you can remove or “disassociate” the item from the change request.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Select the row with the item you want to update, then select Edit > Remove Association.

The screen is refreshed, and the associated item is removed.

Close a change request
A change request records the current version of each associated item, which is the starting version.
Closing a change request records the end version of each item being changed.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Select the change request you want to close, then select Actions > Close Change Request.

3. When prompted, click Yes to confirm.

Releases
A release is a group of items that are developed together and mapped to a specific completion date.

To see all the releases listed for this project, select Releases at the top of the left panel. Select a
specific release to see the items assigned to it.

Jama Connect User Guide

272



If you include items in a release, you are assigning them to that release. If the release field [273]
is visible, you can use Reading View or List View to see the name of the release where an item is
assigned.

Assigning an item to a release
When you assign an item to a release, the item appears under the Releases tab, and the action is
noted in the version history.

IMPORTANT
Admins only — You can only use the system predefined Release field to show items in
the Releases tab. If you use a custom Release field to designate an item to a release,
that item doesn’t appear in the Releases tab.

Before you can assign items to a release, a project or organization admin must first create the release.
Once the release is created, you can assign an item to that release in several ways:

• Locate the release field [273] (if it is visible [617]) in Single Item View or List View and select the
release name you want from the drop-down menu.

• In the List View or Reading View of your project, select the items you want to add to the release.
Select the Releases tab at the top of the left panel and drag the items into the release.

• Use batch update [74].
• Use round-trip import and export [122].

Release field
The release field is a predefined field [594] with a picklist that contains all the releases created in a
particular project.

IMPORTANT
You can only use the system predefined Release field to show items in the Releases
tab. If you use a custom Release field to designate an item to a release, that item
doesn’t appear in the Releases tab.

If you don't see a Release field in the item type you are using, an organization admin can edit the fields
for that item type [595]and make it visible [617].

A project admin must also configure pick list values [600] for each release. 

Customize the Release settings
You can determine what you'd like to see under the Releases tab for your project, whether it is the
default settings or your personal settings.

1. Select Projects > Project, then select the Releases tab. 
2. Click the Configure release explorer (gear) icon.
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3. In the Release Explorer Settings window, determine what you want to see on the Releases tab:
• Select Use my own settings or Use default settings.
• Select the item types, types of IDs, archived releases, and relationships that you want to see.
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4. Click Apply.

Baselines
A baseline in Jama Connect is a snapshot of your project, or a select collection of items (for example, a
set or folder of items), at a point in time.
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The version of selected items — and their relationships — are forever associated with that baseline.

Important considerations

• When you add a relationship to a baseline, the version doesn't change.
• Relationships do not change if you replace it with a baseline.

For example, if you have two relationships at the time of baseline version one, make a change to
version two, add a relationship to version three and replace it with a baseline, you still have three
relationships.

• If you click Replace with baseline, all item fields are set back to their values at the time of the
baseline. For more information, see Replace baseline with current [296].

• When you select an item with previous versions in the baseline, the historical view of that item opens
in Single Item View. Hover over a link to see the available versions for an item. Selecting an item’s
link from a baseline will route you to the baselined version — Historical or current. You can also
select the gear icon (Show/Hide) to open the drop-down menu, then select Current version and Ver-
sion to display those columns.

• Organization and project admins can unlock locked baselines from the baseline header. This option
only appears when a baseline is locked and you have admin permissions.

What you need to create a baseline
Versioning must first be enabled to create a baseline. Once versioning is enabled [660], a baseline is
created:

• Automatically [292] when someone initiates or revises a review
• Manually [282] by anyone with read/write permissions

Why are baselines important?
Baselines allow you to capture the state of your content in alignment with key points in your product de-
velopment lifecycle, such as at key approval gates or when generating documents from Jama Connect.
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Having the baseline allows you to compare items as they change over time and, potentially, revert to a
previous state.

What can I do with a baseline?

• Locate an existing baseline [287]
• Create a baseline manually [282]
• Compare baselines [289]
• Use Compare with current to see baseline changes [291]
• View baseline activity [291]
• Replace current items with baseline [296]

Categories feature and baselines
When enabled by an organization admin, historical versions of categories are visible in the baseline.
They can’t be configured. To show or hide the Categories feature, click the gear icon.

The categories that were applied to the baselined items appear in List View.

What is a baseline source?
A baseline source is a container that holds all the baselines for a specific group of items.

You can add a baseline from a project, set, folder, filter, release, or individual items. Adding a baseline
creates the source automatically. The source is created in the tree and contains the new baseline. A
source can't exist without a baseline.
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If a source already exists when a new baseline is created for the same set of items, the baseline is
added to that source. Otherwise, a new source is created and added to the top of the tree.

Key to the baseline tree

• Green database icon — Source
• White box wrapped in gray — Baseline
• Individual Items — Default source name when multiple items are selected at the time the baseline is

created.
• B1-04/27/2020 — Example of a default baseline name (baseline number and date it was created).

Baseline name is editable as needed.

Quick tips

• You can create a new baseline from an existing source.
• Deleting a baseline source deletes all the baselines it contains.

Compare baselines in Baseline source List View
A baseline source is generated when you create a baseline or review. To see all baselines associated
with that source in List View, select the baseline source.

An in-app comparison summary provides a high-level overview of baseline changes and lets you run
the baseline comparison report. This feature displays detailed information about the baseline, such as
the number of items, Baseline ID, Baseline signatures, Baseline status, and Baseline type.

To compare baselines:

1. Select the Baselines tab in the Explorer Tree, then select the baseline source with the baselines
you want to compare.
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2. In List View, select the two baselines you want to compare, then click Compare.

The Compare baselines window opens.
3. Review the Baselines comparison summary, then click Export detailed report.

A pop-up message notifies you when the report is ready.
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4. In the message, select View reports history page.
5. From the Reports history page, select the report, then click Download.
6. From the Downloads section of your browser, select the report to open it.

Benefits of organizing your baseline tree
Organize your baseline tree to reflect how your organization works.

Project and organization admins can reorganize the baseline tree by dragging and dropping sources
and folders.

Organizing baseline sources and folders

• Use drag and drop to move baseline sources from one location to another, from the root level to a
folder, and between folders.

• Baseline folders can be created at the root level or added to a folder. Use drag and drop to reorder
baseline folders.

• If you hover over an icon or name in the baseline tree, hover text describes the contents of the item.

• Editing a source name creates an event in the project activity stream. In the activity stream, select the
baseline source ID to open the baseline tree and view the highlight.

Searching and identifying baselines, baseline folders, and baseline sources

• When you type a name in the search field, the results are highlighted so you can find them easily.
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• When you clear the search field, the results from the previous search are expanded and highlighted
in the baseline tree.

• When you create a folder or baseline, it is highlighted in the baseline tree.
• If you accessed the baseline from a link or if the Explorer Tree hierarchy is collapsed, select Find me

to locate the baseline in the baseline tree.
• When you toggle Show IDs to On, the baseline IDs are displayed in the baseline tree. When the IDs

are visible, you can search for them using the baseline search box.

• When you select the baseline ID in the activity stream, the source is expanded and the baseline is
highlighted. Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a
signature is revoked.
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• A link is added in the baseline header when a baseline is created from a review or a new revision of a
review. Use the link to navigate to a specific review quickly.

Creating and renaming baselines and baseline folders
Once a baseline is created, the collection of items in the baseline can't be changed. You can, however,
change the baseline name and description.

Users with a creator license and permissions for project or organization admin can create, edit, and
delete an empty baseline folder.

Anyone with read/write permissions can edit, delete, or restore a baseline that they created. However,
you must have project or organization admin permissions to edit, delete, or restore baselines created by
others.

Create a baseline folder using one of these methods:

• Add drop-down menu, select Folder.
• Right-click on the folder, then select Add Folder.

Create a baseline manually
Create a baseline when you want to capture a snapshot of where items are at in that moment.

NOTE
You must have a creator license and read/write permissions to manually create a
baseline.

Important considerations

• Baselines are created automatically [292] whenever anyone creates a review.
• Project versioning must be enabled [660] to be able to create a baseline.

Jama Connect User Guide

282



• All upstream and downstream relationship information from items included in the baseline scope is
also included in the baseline snapshot, even if those upstream or downstream items aren't part of the
baseline scope. This functionality is limited to relationship direction, item name, and item ID.

To create a baseline manually:

1. In the Explorer Tree, select the Baselines tab in the project where you want to create the baseline.
2. Add a baseline using one of these methods:

• If the item already has a source, right-click on the source and select Add baseline.

• If you want to create a baseline from the Project Explorer Tree, right-click on a set, component,
folder, or item.
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• If you need to choose items, select Add > Baseline from the top.

NOTE
If the items from an existing source were deleted, you can't add a new baseline
from that source.

• If you want to create a baseline from a filter, select the Filters tab, right-click on the filter, and
select Add baseline.
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3. In the window that opens, click a tab (Item selection, Releases, Filters) and select containers or
individual items in that tab. You can select containers or individual items, but you can select from
only one tab.

4. Click Create.
5. (Optional) Change the default name for the baseline and add a description.
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You can update the pick list and rich text as needed. When the baseline pick list is updated, the
activity is captured in the baseline and project activity streams.

6. Click Save to create the baseline.

The new baseline is added to the tree, either under an existing source or at the top of the tree.
Baselines are always listed in the order they were created.

Edit a baseline
Once a baseline is created, the item content can't be changed. You can, however, change the baseline
name, description, and baseline status.

Important considerations

• Anyone with read/write permissions can edit, delete, or restore a baseline that they created.
• You must have project or organization admin permissions to edit, delete, or restore baselines created

by others.
• You must be an organization or project admin to edit a signed baseline.

To edit a baseline:

1. Select the Baselines tab in the Explorer Tree, then select the baseline you want to edit.
2. Edit the baseline using one of these methods:

• Right-click on the baseline and select Edit.

• In the upper right corner of the main panel, click Edit.
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3. In the window, enter your changes and click Save & done.

Your changes appear in the Explorer Tree.

Locate an existing baseline
When anyone creates or publishes a revision of a review, a baseline is automatically generated.
Knowing where to look for an existing baseline can be helpful when you want to compare changes in a
review that has multiple versions.

You can find a baseline for a specific project from the Explorer Tree or Single Item View.

Explorer Tree
Use the Explorer Tree to quickly find a baseline.

1. Select the Baselines tab of the project you want to look at.
2. Type the baseline name in the search field. The results are highlighted so you can find them easily.
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3. Expand the source to see all the baselines from the same source, then select the one you want. If
a baseline was created from a review, it is preceded by the word "Review" in the name.

4. Select the baseline to view its contents.

Single Item View
Use the Versions information in Single Item View to see which versions of that item are associated with
specific baselines and reviews.

1. Open the item in Single Item View [59].
2. Select the Versions widget on the side toolbar [60].

The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.
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3. The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.

Compare baselines
When a baseline has more than one version, you can compare two versions in baseline Document
View using the baseline in-app Compare option.

Important considerations

• Document View must be enabled. If the setting has been disabled, organization admins can enable it
from Admin > Details.

• Use this feature while viewing an older version of a baseline. If viewing the most current version, the
baseline in-app Compare option doesn’t appear.

• When comparing baselines, the categories table isn’t available.
• Baselines that were created before Jama Connect 9.6 now display an icon to indicate that the new

fields aren't available. This icon appears in List View, Document View, in-app comparison summary,
and the Preview panel.

To compare baselines:

1. Select the Baselines tab in the Explorer Tree, then select the baseline with the version you want to
compare.

2. Select Document View, then click Compare.
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3. From the drop-down menu, select the version to compare with the baseline you are viewing.

Changes are displayed inline with versions indicated by color:
Red = Edited or deleted text/data from an older version
Green = Edited or added text/data from a new version

4. To compare relationships between two versions of a baseline, select Show related items.
Changes are displayed inline with versions indicated by color:
Red = Edited or deleted text/data from an older version
Green = Edited or added text/data from a new version

5. Click X to return to baselines Document View.
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Use Compare with current to see baseline changes
The Compare with current option allows you to compare baselines and see if an item changed since
the last baseline, and what those changes were.

You can use any of these methods to compare baselines:

• Select the Baselines tab in the Explorer Tree, then select the baseline you want to view.
• In List View, select the gear icon (Show/Hide) to open the drop-down menu, then select Current

version and Version to display those columns.
• To preview an item, select the row, then select Preview item.

A panel displays the information for the version you selected.
From the Version drop-down menu, select most current or baselined to view the full details.

• To compare a baselined item with the current version side-by-side, select the row for that item, then
select Compare with current in the top right.

• View baseline reports to show changes over time:
• Baseline Comparison [417] compares two baselines.
• Baseline Compared to Current [416] compares the items and relationships from a baselined ver-

sion to the current version.

View baseline activity
Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a signature is
revoked.
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1. Select the Baselines tab, then select the name of the baseline that you want to view.
2. Select View details.

The baseline activity stream is visible at the bottom of the center panel.

Locate review baselines
When anyone creates or revises a review, a baseline is automatically generated so that you can
compare changes between reviews.

You can find automatically generated review baselines in two ways:

• Select Baselines in the Explorer Tree of your project.
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Baselines that were automatically generated for reviews are displayed with the word "Review" pre-
ceding the name of the review.

• If you know the items that were included in the baseline (or the review that created it):

1. Open the item in Single Item View [59].
2. Select Versions in the side toolbar [60].

The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.

3. Select the link for the review or its corresponding baseline. The link is enabled only if you were
invited to the review.
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Sign a baseline electronically
If your business process dictates that signatures must be applied to collections of data such as base-
lines, electronic signatures can be associated directly with a specific baseline. Signatures can also be
captured and associated with a baseline if signatures are collected during a review.

1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then click View
details.

2. Select Add signature.

3. In the Electronic signature window, enter your username, password, and any optional comments,
then click Save. Username and password must match that of the logged in user.
If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.
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Deleting sources and baselines
Delete a source or baseline if it was created by mistake or you no longer need it.

Important considerations

• Deleting a source deletes all the baselines it contains.
• The option to delete a baseline or source that contains a baseline is only enabled for baselines

that are not yet electronically signed. However, deleting a project [640] deletes all project content,
including baselines and signatures.

NOTE
You must have project or organization admin permissions to delete sources and base-
lines.

To delete a source:

• Right-click on the source you want to delete, then select Delete source and baselines.
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To delete a baseline:

Delete a baseline from the project using one of these methods.

• Select the baseline, then click Delete (trash icon) in the top right.
• Right-click on the baseline name, then click Delete.

Quick tips

• Undo — If you change your mind after deleting a source or baseline, you can select Undo in the
success notice.

• Restore — You can restore a deleted baseline or source by finding the deletion activity [241] in
the projects activity stream and selecting Restore. If you deleted a source that contains multiple
baselines, you can restore individual baselines or the source and all its baselines. When you restore
a baseline or source, this event appears in the baseline activity stream.

• Limitations — You can't edit or delete a baseline that is electronically signed. You also can't delete a
source if it contains an electronically signed baseline.

Replace current items with a baselined version
When you replace current items with a baselined version, a new version of the item is created and
content is replaced with the baseline content. No versions are lost.

Important considerations

• Items that were deleted are restored to the version when the baseline was created.
• Relationships that were deleted aren't restored.
• You can restore a prior version of an individual item from the versions tab in Single Item View [263].
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NOTE
You must have project or organization admin permissions to do this. 

To replace current items with a baselined version:

1. Select the baseline you want to revert to in the Baselines tab of the Explorer Tree [287].
2. Click Replace with baseline.

3. In the confirmation message, click Replace.

A pop-up message displays the number of items that were updated.

Reuse baselined items
You can reuse baselined items in the same project or in a different project. Reusable items include
folders, sets, components, text items, and a single item baseline.

NOTE
You can’t reuse baselines created from a filter, a release, individual items, a project, a
test plan, a test run, or a test cycle.

To reuse baselined items:

1. Select a baseline using one of these methods:
• Baseline tree — Select the baseline that you want to reuse, right-click to open the context

menu, then select Reuse baseline.
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• Baseline List View — Select the baseline you want to reuse, then click Reuse.

• Baseline Document View — Select the baseline you want to reuse, then click Reuse.

The Reuse baseline window opens with the reused baseline highlighted. You can also select a
different baseline.
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2. In the Select reuse options pane, select an option:
• Sync items and share global ID — Gives the source item and the destination item the same

global ID. With the same global ID. Changes to one item flags the relationship between the
source and destination.

• Create a baseline in destination upon reuse — Creates a baseline source and a child base-
line in the destination project after reuse is successful.

• Include categories — Includes categories with the reused items in the destination project.
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NOTE
The category isn’t reused if it is deleted from the destination project, or the organi-
zation admin reorders or removes the category path.

3. In the Select a target destination pane, select a valid location for the reused content. For example,
when reusing a System Requirement, the target location must include a set of System Require-
ments.
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4. Depending on the options you selected, click Reuse and sync or Reuse.
5. In the confirmation window, select an option:

• Yes
• Preview
• Cancel

6. In the Reuse complete window, select an option:
• View items — Shows a list of all newly reused items. If the destination is in a different project, a

new browser tab opens and displays a list of items.
• Reuse again — Reuses the same source items in a different location.
• Finished — Closes the window.
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Coverage and traceability
Coverage is the extent to which items are validated by another item. Typically, a requirement is consid-
ered “covered” only if it has corresponding test cases against it and test engineers assigned to it.

Traceability refers to the established connections made between various levels of requirements, risk
analysis, designs, and verification. Trace is the item-to-item relationship made to indicate a connection
between items, whether for indicating the abstraction of requirement to more detailed levels, mitigation
of risk, fulfillment of a requirement by a design, or verification of a requirement. The creation of trace
establishes the traceability of information which can be analyzed to assess change impact, determine
coverage, and identify gaps.

In industries with rapid change and innovation such as medical device development and automotive
manufacturing, an unidentified coverage gap can be risky to end users and costly to remediate. Track-
ing of coverage with end-to-end traceability helps eliminate these blind spots and ensure quality.

By relating items [309] according to a set of relationship rules [571], you can assess the impact that
changes can have on other items. When you view items in Trace View [58] or use options to analyze
item relationships, you can determine if you have the coverage you need.

Trace View
Trace View shows related upstream and downstream items. It also shows item details in context of their
relationship, as well as any missing coverage (downstream relationship).

1. Filter item types in Trace View [306].
2. Configure each level to display or hide fields [48].
3. Find any gaps in coverage.
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4. Export the content [305].
5. Add related items directly from this view with the Add menu option in the toolbar.
6. Establish relationships between existing items.

You can also display fields for various item types. For example, you can display the Test Case Status
for verification and verification testing. If a test case item is visible in Trace View, you can navigate
downstream to see any test runs generated from the test cases.

Understanding the Trace View interface
In the Source section, Trace View displays the items that were visible in the List View, Reading View, or
Single Item View from the time the Trace View was initiated.

1. The source.
2. Direct downstream items.
3. Blue arrows = Travel upstream (left arrow) or downstream (right arrow).
4. Top of each level column = Number of item types on the entire level.

NOTE
The item count is a unique count. If the same item is downstream of multiple items
in the source column, it appears multiple times in the "1 level down" column, but it's
counted only once.

Save, copy, and bookmark a Trace View
Saving a Trace View lets you bookmark it to be able to quickly find it or share it. You can copy a saved
Trace View, then rename and edit it to use as a a new Trace View.

1. Select the Trace View [58] that you want to save, then click Save.
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The Name field is now editable.
2. Edit the name as needed, then select the checkmark (Save) next to the field.

3. (Optional) Bookmark the Trace View by selecting the bookmark icon.

4. (Optional) To see a list of saved Trace Views, click the arrow next to the name.
Bookmarked views appear at the top of the list.
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Bookmarked Trace Views are visible from your homepage; use the URL to share this Trace View with
other users.

Export a Trace View
When you export from a Trace View, the result contains all data from the currently visible columns on
your screen to the Source column. This means that if you are two levels downstream from the source,
the export contains all the levels between the sources and the second level down. All displayed fields
are also exported.

IMPORTANT
You can export a maximum of six levels from Trace View. If you try to export a view
with more than six levels, the Export button is grayed out.

1. From the Explorer Tree or an advanced filter, select the items you want to export, then click Trace
view.

2. Navigate to the furthest level upstream or downstream that you want to export, then click Export to
generate a CSV file.
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3. Click OK to open the CSV file.

Filter items in Trace View
In Trace View, you can filter items by item type fo refine your results.

1. In Trace View [58], select the items you want to filter.
2. If the column you want to filter includes more than one item type, click Filter items at the top of the

column.

3. In the window that opens, select the item types you want to see.
The number next to each type is the total count of unique items of that type.
After the filter runs, a message reports how many levels and item types were filtered.

4. (Optional) Select X to remove all filters and refresh the screen.
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5. (Optional) Select Save the Trace View [303] or Export the Trace View [305] with filters in place.

Relationships
Relationships link items together. When items are linked, you can assess the impact an item or group of
items can have on other items.

Traceability is defined by relationships. When one item changes, you can check related items to make
sure they are still accurate and verify that requirements are written.

Relationships can be upstream or downstream from an item. With appropriate permissions [307], you
can relate items within the same project or between multiple projects. Find and view relationships [156]
in Single Item View.

You can also add relationships from:

• Single Item View [309]
• List View, Reading View, or Trace View [311] (by adding a new related item)
• Trace matrix [311]

Relationships and access permissions
Your ability to interact with relationships depends on your access permissions for each of the related
items. Read more about permissions [583]. 

Permissions for
current item...

Permissions
for related

item...

You can...

Read/Write Read only • View trace relationships.
• View ID and name of related item.
• Modify relationships.
• Create new relationships.
• Navigate to related item and clear suspect links.

Read only or
Read/Write

No permission • View trace relationships, but not modify or create new relationships.
• See ID and name, but not navigate to related item.

Read only Read/Write • View trace relationships.
• Modify relationships.
• Create new relationships.
• Navigate to related items and clear suspect links.

Read/Write Read/Write • Create, modify, and delete relationships.
• Navigate to related items and clear suspect links.
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Permissions for
current item...

Permissions
for related

item...

You can...

Read only Read only • View trace relationships.
• Navigate to related items, but not create or modify relationships between the two

items.

Relationship Status Indicator
The Relationship Status Indicator shows an item’s relationship count. The indicator shows red if the
item is missing an upstream or downstream relationship, is suspect, or is causing a suspect relation-
ship.

The Relationship Status Indicator is visible in the Relationship widget of the side toolbar [60], as well
as in a column in List View (when configured [48]). 

Relationships widget

Top number — Number of upstream items related to this item.

Bottom number — Number of downstream items.

Red — Item not in compliance with relationship rules.

Gray — Item in compliance with relationship rules.

List View
When you hover over an icon (exclamation mark, question mark, up arrow, down arrow), you see how
the item violates the relationship rule applied to the project.

An item might violate relationship rules in one of these situations:

• Orphan Item — Item is missing a required upstream relationship. Adding a related upstream item
resolves the error.

• Missing Downstream — Item is missing a required downstream relationship. Adding a related
downstream item resolves this error.

• Suspect — Suspect Item means one or more upstream items have changed. Causing Suspect
means a change has caused a suspect relationship with all downstream items. When you've properly
assessed the change, clearing the suspect links resolves the error.

Jama Connect User Guide

308



If relationship rules haven't been applied to the project, an error appears only if the link is suspect.

Add a relationship from Single Item View
Creating a relationship establishes a directional link between two items. The related items can exist in
the same project or in different projects.

Important considerations

• You must have permissions to a linked related item to be able to preview, open, or edit it. Otherwise,
you can only see the related item’s name, project, and relationship attributes.

• If relationship rules [571] were applied to the project, only items that meet the rule's criteria appear
in the right panel. Likewise, you can only create a relationship with item types that meet the applied
relationship rule. To display the rules associated with this project, click Show relationship diagram
at the top of the right panel.

To add a relationship:

1. While viewing an item in Single Item View, click Relationships in the side toolbar, then click Relate
Items in the bottom panel that opens.
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2. In the side panel that opens, select the items you want to relate to the item you're viewing, using
one of these methods:
• Double-click on the items you want.
• Select the items you want and click Relate.
A relationship is added to the selected item in the direction defined by the rules. It is then immedi-
ately visible in the bottom panel. If the new relationship isn't defined in the rules, you are prompted
to define the relationship direction and type.
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Add a relationship from the Trace Matrix
Creating a relationship establishes a directional link between two items. The related items can exist in
the same project or in different projects.

1. Select Projects in the header, then select Project > Traceability > Trace Matrix.

2. In the header row of the Trace Matrix window, use the drop-down lists to select two item types you
want to compare, select the number of items you want to see for each type, then click View Matrix.

3. Double-click in any cell where you want to add or edit a relationship. 
4. In the Add/Edit Relationship window, make the needed changes, then click Update.

Add a new related item
You can add a new item and relate it to one or more items at the same time.

1. View the items to be related in List View [54], Trace View [58], or Reading View [55].
2. Select the items where you want to add related items. All selected items must be the same item

type.
3. From the side toolbar, select Add > Add related. From the drop-down menu, select the item type

for the upstream or downstream items you want to add. The drop-down menu lists only item types
allowed by relationship rules.
When a rule is applied, it dictates the direction and relationship type for the item you want to relate.

4. If a rule is not applied — In the Relationship settings window, select the direction and relationship
type for the item you want to relate, then click Create relationship.
• Direction — Upstream or downstream.
• Relationship Type — Must be configured by an organization administrator [568].

Common examples include: related to, dependent on, derived from, validated by, verified by, or
mitigated by.

Jama Connect User Guide

311



5. In the Add Item window, enter a name, description, and other details as needed, then click Save. 
6. In the Select Location window, choose where to save this item, then click Select & Close.

Locations that aren't permitted appear in light gray. You might need to expand folders, sets, or
components to find the location you want.

7. If you selected Notify in the Add Item window, enter the comment, select groups or users to notify,
then click Commit.
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A pop-up window appears with this message: "Success <item name> has been updated/created."

Allow locked items to be related
As part of your workflow, you can relate two existing locked items. This functionality must be configured
first by an organization admin.

1. Select Admin > Organization, then select Relationships.

2. In the Relationship Options section, click Edit.
3. Select Allow relationship changes between two locked items.
4. Click Save.

You can now relate two locked items.
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Filter relationships
You can filter items to display only items that are related to a single item. For example, you might want
to view only the test cases related to a requirement. The filter is stored until the end of your session, so
as you move from item to item, the filter remains in effect.

1. In Single Item View, select Relationships in the side toolbar. 
2. In the bottom panel that opens, select Filter.

3. In the Relationships filter settings window, choose your own settings or keep the defaults, then click
Apply.
The filtered results appear in the bottom panel.

4. To release the filter and see all related items again, click Filter Applied-Click To Restore De-
faults.

Relate to an existing item
Many times, the items you want to relate have already been added to Jama Connect. You can relate
items that exist.

Recently viewed items is the default view, but you can also use the Explorer Tree, Releases,
or Search tab to find the items you want to relate.

To relate an existing item:

1. View the items to be related in List View [54], Trace View [58], or Reading View [55].
2. Select the items you want to relate. All selected items must be the same item type.
3. Select Relate to existing.

4. In the side panel that opens, select the items that you want related, then click Relate. 
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A relationship is added to the selected item in the direction defined by the relationship rule. It is then
immediately visible in the bottom panel of the relationships view. If you establish a relationship that is
not defined by a relationship rule, you are prompted to select a type.

Clear suspect links
Suspect links appear on an item when changes were made to upstream items, meaning the item might
no longer be correct or complete. For example, if a requirement changes, the downstream verification
might no longer correctly verify the requirement as-is. The change to the requirement causes a suspect
relationship to the verification item.

Only updates to certain fields trigger suspect links. These fields are determined by the organization
admin, who configures item types [595].

Suspect links also cause the relationship status indicator to be red when you view items in List View or
Single Item View.

If you determine that a suspect link has no impact or if you make the necessary changes, you can
manually clear the suspect link.

To clear suspect links:

1. Open all suspect links for the project or for a single item [158].
2. Select Clear (one link) or Clear All (all visible items).
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Trace Matrix
The Trace Matrix is a visual representation of relationships between the items in a project.

It helps you determine the impact when a change occurs and lets you quickly see relationships for two
groups of items.

For example, you can select a set of requirements and see which have related test cases.
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Along with determining the impact of a change, you can add a relationship from the Trace Matrix.

IMPORTANT
The Trace Matrix doesn't enforce relationship rules.

Impact Analysis
Impact Analysis shows you a complete picture of all upstream and downstream related items that might
be affected by changes. You can run an impact analysis on an item or on a change request.

With traceability, you can see how a change might impact a selected item before you make the change.

For example, if you're about to change a requirement, you can run an impact analysis to see the degree
to which the change might impact other requirements and verifications.

To run Impact Analysis on an item:

• In the top toolbar of Single Item View, select Impact Analysis.

To run Impact Analysis on a change request:

• In the side toolbar of a change request, select Items to change (bell widget) to open the bottom
panel, then select Actions > Impact Analysis.
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Coverage Explorer
The Coverage Explorer is a tool to view downstream relationships (or the lack of them) from a selected
collection of items like a set, folder, or filter. Coverage Explorer provides needed coverage.

You can create and save coverage views and export them to an Excel document [319]. 

To open the Coverage Explorer, select Projects in the header, then select Project > Traceability >
Coverage Explorer.
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The Coverage Explorer opens. From this window, you can add a new coverage view and look at
existing views.

Create and export views in the Coverage Explorer
Coverage Explorer enables you to analyze the relationships established across items in your project
and identify gaps. For example, you can use Coverage Explorer to identify if any requirements lack
verifications, or to ensure your requirements trace to “passed” verifications.

A view can contain a maximum of 500 items per level. You can bookmark a view to highlight and
prioritize it. Only the view's creator can rename or delete it.

1. Select Projects in the header, then select Project > Traceability > Coverage Explorer.

2. Select Add Coverage View to open the Select Items window.

3. Select the items you want to analyze for coverage.
To change your view, use the tabs at the top: Recently Viewed, Explorer, Filters, and Releases.
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4. With the items selected that you want to analyze, click Select to close the window.
5. (Optional) To hide, show, or reorder fields for that level, click the gear icon at the top of the

Coverage Explorer.
6. (Optional) To add a new level of downstream relationships, click the green plus button.

You can add only one item type per level. However, if you add a downstream level and leave the
item type blank, Coverage Explorer displays all items regardless of type if type isn't selected.

7. Click Save.
You can deselect the star by clicking on it.

8. (Optional) Click Export to generate an Excel document.

Reuse and synchronization
With reuse [322] you can copy items and containers of items such as components, sets, and folders,
along with any supporting information. With synchronization [329] you can maintain a connection be-
tween reused items and containers, monitoring them for differences and updating any that are out of
sync.

Supporting information that can be duplicated [84] includes:

• Entire item
• Item fields
• Item widget relationships, tags, attachments
• Child items

When items are synchronized, they receive a Global ID that they share regardless of their location in
the system. You can synchronize the items that you reuse, or connect existing items so that they share
a Global ID and can be synchronized.

To keep track of synchronized items, you use the Sync Items window, where you can compare
items [336] and decide how to update synchronized items.

You can see which items are synchronized in the Explorer Tree. A blue dot on the item’s icon indicates
that the item is synchronized.
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Important considerations

• Only an organization admin can configure reuse and synchronize [556] options.
• Reuse and synchronization can require significant memory, especially if your organization has a large

Jama Connect database and has heavy reuse or synchronization use.
• While the links to attachments are synchronized, the content in the attachment is not.
• Reusing and synchronizing items adds activity entries to the stream [252] for all items created or

modified during the process.

Global ID
A Global ID is an identifier of synchronized items. While every item has its own unique ID [648], which is
also the project ID, synchronized items share a Global ID.

Items that share this Global ID are considered cloned artifacts, despite being in different areas of Jama
Connect.

Global IDs have two parts:

• Global ID prefix — The Global ID (for example, GID-) is the same across the organization. An
organization admin can change the Global ID prefix [550].

• Global ID counter — The Global ID counter is a number that increases for each new Global ID.
It can only be reset or reduced by an organization admin. If a user tries to set the counter value
below the Last Used Global ID Counter, Jama Connect shows an error message notifying the user to
choose a greater value.

When items are synchronized, they are assigned the same Global ID. When an item is removed from
this group through Break sync [332], a new Global ID is assigned.

Reuse and synchronization considerations
Reusing and synchronizing hundreds of items can affect system performance, causing it to feel slower
than usual for users and decreasing performance for other processes such as exporting.

If you try to reuse and synchronize hundreds of items, a warning appears if performance is likely to be
impacted.

If you still want to reuse and synchronized hundreds of items, consider running the reuse and synchro-
nization options in smaller batches or start the process during off hours when demand for resources is
less.

Use cases for reuse and synchronization
Typical scenarios for reuse and synchronize include:
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• Duplicate — Make a copy of items, containers, sets, or folders for reuse. Synchronization is optional
but can be enabled between duplicated items.

• Library — Create a library to establish system-wide standards in your organization for all business
units to follow. These standards might include common business practices, rules, glossaries, or
non-functional requirements that teams must reference but can’t modify. This information can be
created and managed in one place and reused in projects where applicable.

TIP
If you're using a library to push changes to many projects, you can synchronize
items to push changes from your “library” project to all other project items that share
the same global ID. To do this, you must have write access on all projects included in
the sync.

• Shared requirements — Large projects typically adhere to a common set of requirements, but
often each requirement also has information specific to and managed by a project. For example,
a requirement name and description can be shared across multiple projects, but release values,
priorities, assignments, and relationships are managed by each project.

• Branching — You can split a set of artifacts  into several branches so that each branch can be
modified at the same time.
This can be useful when you want a snapshot of items at a point in time, but still allow the items to be
modified at the same time. In this case, reuse results in the versioning of an entire document made
up of multiple items, rather than a version of only a single requirement.

• Release management — Similar to branching, reuse and synchronization let you use items across
multiple releases in parallel. Typically, in this scenario, projects in Jama Connect represent a release.

• Project template — You can set up a project as a template that you reuse and synchronize. A tem-
plate lets you ramp up new projects quickly or establish standard practices on content organization.
You can also push updates to all projects that used the template.

Reuse
If your projects contain items that are often the same or slightly different, reusing items helps you work
more efficiently. You can reuse items over multiple projects and synchronize them, as needed.

Reuse for users
Selecting items to reuse can be helpful if you are creating several copies, but want the original “source”
item to maintain a connection with its copied items.

For example, you might have a set of requirements from a library project in Jama Connect and need to
reuse it in several other projects. You copy the set to Project 1 and Project 2. When viewing the copied
requirements in Project 2, users might see an upstream relationship to the “source” requirements in the
library. Adding or not adding this relationship has no impact on how items are compared or synced.

You can only reuse items in sets of the same item type. For example, if you have two requirement sets
in a project created from the same item type, you can duplicate and move items between these sets.
Child items can also be reused, but they must be the same item type as the parent item. 

TIP
If you have several items that are reused regularly, put them in a central project
so future changes to items can be maintained from a central location. For instance,
during reuse, relationships can automatically be created that are inconsistent with the
relationship rules of a specific project.
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Reuse administration
Reuse is best managed by a dedicated reuse admin. An organization admin can assign reuse admin
permissions [589].

Reuse admins are the only ones who can:

• Edit and delete Compare Views of synchronized items.
• Manage (add, edit, delete) reuse rules under Advanced options.

Reuse an item
You can reuse individual or multiple items or containers of items such as components, sets, and folders.
Items can be reused in the same project or in a different project.

TIP
To quickly make a copy of an item in the same project, use the Duplicate items [84]
option.

1. Select items for reuse with one of these methods:
• Explorer Tree — Select the item or container that you want to reuse, right-click to open the

context menu, and select Reuse items.
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• List View — Select the items you want to reuse, then click Reuse.

• Reading View — Select the items you want to reuse, then click Reuse.
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• Document View — Select the items you want to reuse, then click Reuse.

2. In the Reuse Items window, select the source items you need.

3. On the Basic tab, select the options you want.
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• Sync items and share global ID — Gives the source item and the destination item the same
global ID. With the same global ID, changes to one item flag the relationship between them as
out of sync.

• Append a prefix to the names of the copied items — If items are being reused but not
synchronized, you can append a prefix to the new item to differentiate between two copies of the
same items. Enter the prefix you want to use in the field.

• Add a relationship from the original item —Creates a relationship between the original item
and the new item.

• Include all tags, attachments, and links — Duplicates all tags, attached files, and URL links
associated with the items. If an existing item is overwritten and this option is selected, all tags, at-
tachments, and links are updated to match (removes any tags, attachments, or links that existed
in the destination but not in the source item). If this option isn't selected and you overwrite an
existing item, any tags, attachments, and links are cleared in the destination item.

• Include categories — Includes categories with the reused items in the destination project.
The category isn’t reused if it's deleted from the destination project, or the organization admin
reorders or removes the category path.

• Don't include relationships outside of the source selection — Copies only the source item.
Relationships within the source item aren't copied. For example, if the source item has a com-
ponent that contains Features, Requirements, and Test Cases, relationships between those
selected items are copied when the component is reused.
However, those relationships aren't copied if any source items have relationships to items
outside the source component, such as a relationship between a requirement in the source
component and a use case in another component that is not reused in this action.
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• Include relationships from the source selection — Copies the items and relationships con-
tained within the source. For items within the source that have relationships outside the source,
the copies of these items have relationship created to those same related items outside the
source.

• Include related items and mirror relationships — Copies the items and relationships con-
tained within the source. Any items outside the source that are directly related to items within the
source are also copied.

IMPORTANT
If you change the hierarchy of the source component, those changes aren't made
in the destination component.

4. Select a target destination for the item.

• Reuse source project hierarchy in destination project — Reuses the project structure that
contains the reused items. For example, if a folder is selected for reuse, the set that contains the
folder is also reused.

• Manually select location(s) for reused items(s) — Select a specific location to place the
reused content. The target location must contain a valid location to house the reused items. For
example, if you select this option when reusing a System Requirement, the target location must
have a set of System Requirements.

5. Click Reuse and sync at the bottom of the window. If you reuse something that has already been
reused, you are prompted to select Overwrite Items or Skip Items.

6. In the Reuse Complete window that shows a summary of what was reused, select one:
• View Results — Shows a list of all newly reused items.
• Reuse again — Reuses the same source items in a different location.
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• Finished — Closes the window.

Add and edit reuse rules
As the reuse admin, you can create reuse rules and edit existing reuse rules.

Any field left unchecked uses its default values.

IMPORTANT
You must be a reuse administrator [322] to perform these tasks.

1. Select items for reuse from the Explorer Tree or List View, then click Reuse.

2. In the Reuse Items window that opens, under Reuse Options, click the Advanced tab.

3. Add a rule or edit an existing rule:
• Existing rule — Click edit next to a rule name.
• New rule — Click Add Rule, select Add item type rule, then select an item type from the

drop-down list.
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• Define how to handle upstream and downstream items that are related to this item type: select
the green Related button. You can add multiple rules for each item type and each rule can
include a maximum of 16 levels.

• To remove a level or rule, select the red Delete (minus) button.
4. Configure the reuse options that you want to apply to these rules:

• Sync items and share Global ID — Gives the source item and the destination item the same
Global ID so that changes to one item flag the relationship between them as out of sync.

• Append a prefix to the names of the copied items — For items reused but not synchronized,
adds a prefix to the new item to differentiate it from the original. Enter a prefix in the field.

• Add a relationship from the original item — Creates a relationship between the original item
and the new item.

5. At the bottom of the window under Fields to Copy, click Configure next to each item type you want
to configure to limit the fields and widgets to be copied.

6. On the Fields tab, define whether all fields or specific fields are copied.

IMPORTANT
Release fields can't be reused and synced between projects because they are
unique to each project.

7. On the Widgets tab, define whether to copy tags, attachments, and links.
8. Click Done to save your changes and close the window.

Synchronization
Synchronization checks for differences between reused items and containers. When differences exist,
users can update the corresponding information for those items or containers.

Synchronized items are only visible if you have read permissions to both items. You must have write
permissions to edit, synchronize [333], reuse [323], or duplicate items.

 If you change the hierarchy of a source component, those changes aren't synchronized in the destina-
tion component.

When you convert a synchronized item to a different item type, such as converting a Requirement to a
Feature Request, the item loses its synchronization and receives a new Global ID.
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NOTE
Synchronization changes don't trigger suspect links [315]. Synchronizing doesn’t re-
move deleted items. For example, if an item is deleted from the original component,
you can't choose Sync All to delete that item from the new component.

Synchronization updates are allowed only on projects where you have read/write permissions. You can
pull data from projects where you have read-only permissions, but you can't push data to items in those
projects.

When you add a new item to a synced container, Jama Connect indicates that the item is out-of-sync.
Syncing the containers results in the creation of that item in the synced container.

You can synchronize items using any of these methods:

• When you connect items from Single Item View [335]
• In the Sync Options window (when syncing multiple items) [333]
• When you reuse items [323]
• When an organization or project admin duplicates projects [637]

NOTE
If items with the same Global ID are not allowed in the same project, Jama Connect
doesn’t allow you to reuse in the same project with sync enabled.

Sync options window
When viewed from Compare View, the Sync Options window is divided into top and bottom section,
which correspond to the left and right columns in Compare View, respectively. The functionality is the
same for each section.

Jama Connect User Guide

330



When you select the Basic tab in the top right corner, you can view and select these options:

Basic options

Handle relationships • Don't synchronize relationships.
• Include relationships from the source selection
• Include related items and mirror relationships

Options as needed • Synchronize all tags, attachments, and links.
When synchronizing related items that don't exist in the destination project, all fields, tags, attach-
ments, and links are reused. Fields that aren't applicable to the destination project are set to defaults.
Only links to attachments are synchronized, not the attachments themselves.

• Add a relationship from the original item

Default destination
uses the specified tar-
get destination

• Reused items are placed in the destination project based on the hierarchy of the source project.
• If a matching location isn't found, the system automatically creates components, sets, and folders in

the destination project as needed.

When you select the Advanced tab in the top right corner, you can view and select these options:

Advanced options

Display and mod-
ify existing reuse
rules or add new
ones

• Reuse rules shown are filtered by item type.
• Deselect Only show applicable to display all reuse rules.
• Select Add rule to add a new rule to the items selected in this view.

Select a destina-
tion

• Select Manually select location(s) for reused item(s) to select a specific destination for your synced
items.

• Select Synchronize to sync all fields specified in the reuse rules in the Sync Options window. This also
removes all attachments, tags, links, and relationships if selected.
When synchronizing related items that don't exist in the destination project, all fields, tags, attachments,
and links follow the sync option that's applied to the view (fields that aren't applicable to the destination
project are set to defaults).

Select Synchronize to sync items based on the selected Sync Options setting.

When synchronizing related items that don't exist in the destination project, all fields, tags, attachments,
and links follow the sync option that's applied to the view.
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Break synchronization
When you break the synchronization, the connection is removed between items and other relationships
built on this connection. The removed item receives a new Global ID. Further synchronizations for that
original Global ID don't affect the item with the broken connection.

1. Access the Number of Synchronized Items panel using one of these methods:
• Open the Sync Items window by selecting an item in the Explorer Tree, right-clicking and select-

ing View synced items.

• In Single Item View of the item whose synchronization you want to break, open the bottom panel
by opening an item in Single Item View, then clicking the Synchronized items widget.

2. In the window that opens, select an item and click Break Sync.
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3. In the Sync Items window, break the synchronization for one item or all listed items:
• One item — To remove the sync from a specific item and assign a new Global ID, click Break

Sync in the same row as the item.
• All listed items — To break the synchronization between all listed items and assign a new

Global ID to each item, click Break Sync at the top of the window.

4. When prompted to confirm, click Yes.

A message confirms that the item is no longer synchronized.

Synchronize items from Synced Items window
Synchronization checks for differences between reused items and containers. When differences exist,
you can update the corresponding information for those items or containers.

1. Open the Sync Items window: In the Explorer Tree, right-click the item, component, or set you want
to sync, then click View synced items.
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2. Click Sync All to open the window for all displayed items or use the up or down arrow to sync
changes to or from the displayed items.

3. Click Compare to open the Compare View, then use one of these synch methods:
• One item — Use the right or left arrow for each item to sync it in a particular direction.
• Multiple items — Select multiple items (highlighted in blue) with the Ctrl+Shift keys, then use

the arrows at the top of the Sync All column to synchronize all items in one direction.
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IMPORTANT
When you synchronize an item, a new version of that item is created. If the sync
was done by mistake, it can’t be undone but you can make the prior version
current. This applies to field updates only, not to relationships created or new
items created.

4. (Optional) The Batch Sync window displays the selected number of items to update, with Selected
Items chosen by default. If needed, select All Items.

5. Click Batch Sync to complete the update.
• Sync items — Only fields that are enabled as synchronized fields [611] are updated. Child items

are added to the destination if they exist in the source only. 
• Sync a container — The container and all children are synced unless you created advanced

reuse rules [328] that specify otherwise.

Connect items from Single Item View
If you want items to share a Global ID, you can connect them to keep them in sync.

1. Open the bottom panel in Single Item View [59].
2. In the bottom panel, select Connect Items.

3. In the panel that opens, select the item you want to connect to, then click Connect.
To help you find the item, you can use the Recently Viewed, Search, Explorer, or Releases tabs.
You can also click Preview to open a window with details about an item.
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The newly connected item now appears in the bottom panel with the same Global ID. This change also
appears as an activity in the Stream [236].

Compare synchronized items
You can compare synchronized items to see what has changed.

1. Open the Sync Items window: In the Explorer Tree, right-click on the item, component, or set you
want to sync, then click View synced items.
The selected item or component is displayed with a sync status that lets you know whether that
item is in sync or out of sync.
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2. If the item is out of sync, select it to open a Detailed Comparison View of those differences.
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3. To view the differences at an item level, select Compare.

A list of all synchronized items in that component is displayed.
4. To filter items within a component, use the links at the top. Use your mouse to scroll left or right so

you can compare fields.
5. Click Configure View to configure which fields are displayed [340]. Yellow highlights indicate

synchronized items with content that doesn't match.
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NOTE
If an organization admin didn't enable a field to be synced [611], it's never high-
lighted in yellow, and it can't be synced.

6. (Optional) Select Save Diff View.

7. For more information that helps determine whether to sync something, select Detailed compare
view for the items you want to compare.
The Detailed Compare View window lists changes, with old text red and highlighted and new text
green and underlined.

8. To synchronize the data, select the green arrow or the pencil icon to manually edit the content of
the fields.
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9. Click Save when you're done.

Configure Compare View for synchronized items
Configuring the Compare View window allows you to customize which fields you see, as well as
relationships, widgets, and item types.

1. In the Explorer Tree, right-click on the item, component, or set you want to sync, then click View
synced items.
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2. In the Sync Items window that opens, click Configure View in the top right corner.

3. From the drop-down menu at the top of the Configure View window, select the item type you want
to configure.

4. On the Fields tab, move the fields you want from the Hidden Fields column to the Visible Fields
column, and move those you don’t want to the Hidden Fields column. You can double-click, drag,
or use the arrows.
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5. On the Relationships tab, select whether and how to view relationships in the Compare View
window.
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6. On the Widgets tab, select the widgets you want to see in the Compare View window.
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7. (Optional) To save the changes you made in this window, click save a Compare View [336].
Otherwise, the changes don't persist when you close this window.

8. Select Apply to save your changes.

The window is refreshed and your changes are saved.

Exports
With Jama Connect, you can create documents using the standard export to Word and Excel or by
creating your own custom Office Templates [349]. For example, you might need to create documents to
share with your customers, quality teams, or auditors.

Exporting without a template
To export data directly to Word [346] or Excel [347] in List View or Reading View, you can do so without
a template, using advanced filters [142] or the Explorer Tree.

Exporting with a template
Using templates to export data speeds your work and improves consistency. With Excel templates,
you can easily create and share your customized analysis with others in your organization. With Word
templates, you can create standardized documents that are automatically populated with your data.

To export to a specific template, you select Export > View all export options, then download an
existing template [352]. You can modify a template as needed.
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Customizing your output
If you have information you want to include or exclude from your export, you can select which fields you
want. In List View, select the gear icon to modify the fields that appear in your document.

Export template parameter
By default, extra line breaks are removed to improve the published document. This might cause
consecutive tables to be combined.

To restore a template to previous export results, self-hosted customers can apply a new parameter to
the report parameter field in the template.
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Setting Definition Parameter

Default Removes extra line breaks. Consecutive tables are combined. cleanEmptyParagraphs=true

Custom Keeps extra line breaks. Consecutive tables are separate. cleanEmptyParagraphs=false

Uploading custom Velocity reports
Your system or organization admin can upload custom Velocity exports [565] that are displayed in the
Export window.

Export to Word from Reading View
You can export a set of items as a Microsoft Word document. If you want to show your content in
context, you can include hierarchy in the export.

The default Word export is a boilerplate that was created with Office Templates and can be modified to
meet your needs.

1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. Choose Reading View.
3. Select Export > Export to Word.

Depending on how you selected your data, your exported content appears as follows:

Method Results

Explorer Tree The selected container becomes the title page for the export.

Advanced filter with-
in single project

Reading View includes the container hierarchy above the filtered items, up to the top of the
project. Container items that show hierarchy have a grayed-out (disabled) checkbox, while the
rest of the items can be selected. Hierarchical containers are exported with the content items.

Cross-project filter Reading View doesn't display numbering. The export is a listing of items without hierarchical
information.

Export to Word from List View
When you export items from List View, all items appear in list form.
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TIP
Word for Mac is known to have some issues with exporting certain formats and tables.
If you experience issues, eliminate special formatting or tables within tables.

1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. In List View, select Export > Export to Word.

The export displays a table of contents, followed by each item, its name, and a list of its field names and
values.

Export to Excel
If you need to provide data to external stakeholders who don’t have access to Jama Connect, you can
export to Microsoft Excel. You can also use round trip to work offline or share data in a format that can
be used to update existing data.

IMPORTANT
Don't use field names in Jama Connect that start with the equal symbol (=). When
Excel encounters a field value that starts with =, the cell is interpreted as a formula. For
example, if the name of an item in Jama Connect is =1338-1, Excel interprets it as a
formula and the value is displayed as 1337.

You can export selected items to an Excel template in two ways:

• Default boilerplate template
• Office Templates, which can be customized

NOTE
Excel doesn't support rich text. Jama Connect removes formatting when it exports to
Excel.

To export data to Excel:

1. Select the items you want to export using the Explorer Tree or an advanced filter.
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2. In List View, select the gear icon (Show/Hide) to open the drop-down menu.
3. Select the fields that you want to include in the Excel output.
4. Deselect (hide) the fields that you don't want to include.
5. In the toolbar, select Export.
6. From the drop-down list, select an option:

• For default template — To use the default boilerplate, select Export to Excel. Your results
appear immediately.

• For Office Templates — To customize your template, select View all export options, select an
Excel export option, then click Run.

• Export to Excel default — Generates an export that includes the fields that appear in List
View (one column per field). Not intended for importing data updates to existing items in Jama
Connect. Instead, use Excel Export for Roundtrip [122].

• Excel Export for Roundtrip —Includes all available fields. You can edit the resulting spread-
sheet and import the changes back into Jama Connect.

A confirmation message appears with a link to the report.

All fields that you plan to update using round trip must be included in the export, including rich text
fields like Description. Rich text is output in raw HTML format, so the content can be preserved if
re-imported.

Export to PDF from Reading View
You can export a set of items as a PDF using the PDF reports included with Jama Connect. If you
want to show your content in context, you can include hierarchy in these exports. The default export is
created with Office templates and can be modified as needed.

NOTE
For information about creating custom PDF reports and how to make existing reports
PDF compatible, go to the Jama Software Community site and search for Velocity
reports or see Export Velocity reports to Excel [434].

1. Select the items you want to export using the Explorer Tree or an advanced filter.
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2. In Reading View, select Export > Export to PDF.

Depending on how you selected your data, your exported content appears as follows:

Method Results

Explorer Tree The selected container becomes the title page for the export.

Advanced filter with-
in single project

Reading View includes the container hierarchy above the filtered items, up to the top of the
project. Container items that show hierarchy have a grayed-out (disabled) checkbox, while the
rest of the items can be selected. Hierarchical containers are exported with the content items.

Cross-project filter Reading View doesn't display numbering. The export is a listing of items without hierarchical
information.

Export to PDF from List View
When you export items from List View, all items appear in list form.

1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. In List View, select Export > Export to PDF.

The export displays a table of contents, followed by each item, its name, and a list of its field names and
values.

Office Templates
Microsoft Office Templates are Word documents and Excel spreadsheets that allow you to add format-
ting to your exported data.

Office Templates are best for simple exporting with Word and Excel using data that you select in the
Explorer Tree or with an advanced filter [142].

To open the Office Templates window, select Export > View all export options.
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The Office Templates window shows several default templates that come with Jama Connect. You can
download an existing template [352] and use it as is or modify it, or create your own template in Word
and upload it [353]. Select the bookmark next to a template to move it to the top of the list.

Your system or organization admin can upload custom Velocity exports [565] that are displayed in the
Export window.

TIP
All Items Details Export [356] and the Coverage Report [357] are made with Velocity
and can't be downloaded and modified with Microsoft Word.

Each Office Template consists of three sections:

• Cover page — Contains general information about the export, and the data it references. Some
fields typically included in this area are:
<<reportName>> - shows the Report Name entered in the Office Templates window 
<<reportDescription>> - shows the Report Description entered in the Office Templates window 
<<contextType>> - shows the type of content being used (e.g. release, component, filter, folder, item 
etc) 
<<contextName>> - immediate context for the data being used (e.g. container name, like "Requirements") 
<<userName>> - name of the user generating the report 
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<<projectName>> - name of the project 
<<projectManager>> - project administrator 
<<organizationName>> - name of the organization 
<<contextPath>> - hierarchical path from the content to the project level

• Table of contents — Automatically generated using Word's heading hierarchy. You can delete this
by editing the template and removing this section.

• Items and fields — Contains the items and their respective fields from the selected data set. This
section can be modified.

TIP
For a list of fields available for export in your current project, download the Field
Reference Guide [358]. 

If you need to roll up field data or do something more complex than a simple export of
formatted data from Jama Connect, read about reports [414] or custom reports [433].

Export data with Office templates
Using data that you select in the Explorer Tree or with an advanced filter, Office Templates can be
leveraged for simple exporting with Word or Excel.

1. In List View or Single Item View, select Export > View all export options.

2. In the window that opens, select the export you want from the template list on the left.
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3. Select the format for your export and enter any additional information required for some templates.
4. (Optional) Select Email me the report to receive a link to the export when it's finished. Links are

stored for 7 days before they're automatically deleted.
5. Click Run.

A confirmation message appears with a link to the report.

Download an existing export template
You can download an existing Office Template to use as is or modify it as a a new template.

1. In List View, Reading View, or Single Item View, select Export > View all export options.

2. In the window that opens, right-click on the template you want to download, then select Download
Template.
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The template is downloaded to your computer.
3. Modify the template in Word as needed and upload it as a new template [353].

Upload an export template for a report
Any user with read/write permissions can upload and export a custom template.

For self-hosted customers, an organization or system admin can upload templates in multiple projects.

To upload an export template for a report:

1. Save the template you want to upload to your desktop computer [352].
2. Select Export > View all export options to open the All export options window.

3. In the window that opens, click Upload a Template.
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4. Select Choose File and select the template you want to upload.

5. Enter a name and description for the report.
To make the template name and description visible in your export, include these field tags:

Report Name «reportName»

Report Description «reportDescription»
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For a list of other available field tags you can include in your templates for the current project,
generate the Word Template Reference Guide [358].

6. Under Share with, select how you want this export template to be available, then click Save
Report.

• Organization — Available to users in any project. Export templates that are shared with
the organization are visible in the left column of the Office Templates window with the label
All Projects.

• Project — Available to other users in this project only.
7. Click Run.
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A confirmation message appears with a link to the report.

Create an All Item Details export
The All Item Details export displays all item details for the selected project. It was designed in Velocity
for output in Microsoft Word and HTML.

This export is useful for sharing details of a set of requirements or another group of artifacts with others
outside of Jama Connect.

1. Select the data you want to export using the Explorer Tree or an advanced filter.
2. Select Export > View all export options.

3. In the window that opens, select All Item Details, select a format, and choose the parameters you
need (Include relationships, Include tags).
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4. (Optional) Select Email me the report to receive a link to the export when it's finished. Links are
stored for 7 days before they're automatically deleted.

5. Click Run.

A confirmation message appears with a link to the report.

Create a Coverage Report
The Coverage Report displays downstream relationships to the selected set in HTML, Microsoft Word,
or Microsoft Excel. It provides a summary and detailed information on the traceability coverage for the
selected items.

1. Select the data you want to export using the Explorer Tree or an advanced filter.
2. Select Export > View all export options.

3. In the window that opens, select Coverage Report.
4. Select a format and choose the parameters you need (Missing coverage only, Downstream item

location). If you select no parameters, your report looks like the following image. For a report with
a more specific set of relationships, select one or both parameter options.
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5. (Optional) Select Email me the report to receive a link to the export when it's finished. Links are
stored for 7 days before they're automatically deleted.

6. Click Run.

A confirmation message appears with a link to the report.

Generate the Word Template Reference Guide
The Word Template Reference Guide is helpful when you're creating or editing templates. It provides a
dynamic reference of all field tags that you can use to expose information in your export templates.

This guide is unique to each project in Jama Connect. Downloading the guide provides an up-to-date
list of all available field tags for items in the currently selected Jama Connect project.

When creating a new template, you can copy and paste from this reference guide. If any fields change
in your project, download a new guide to see how the changes affect export templates.

1. In List View or Single Item View, select Export > View all export options.

2. In the window that opens, click Upload a Template, then click Generate Word Template Refer-
ence Guide.
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3. (Optional) Select Email me the report to receive a link to the export when it's finished. Links are
stored for 7 days before they're automatically deleted.

4. Click Run.

A confirmation message appears with a link to the report.

Embed custom fonts in exports
You can embed custom fonts into Word or PDF exports.

IMPORTANT
The custom font you use in the template must be in the TrueType Font format (TTF).

1. Download the template [352] for the existing export that you want to publish with a custom font.
2. Convert that template to DOCX format by selecting File > Save As > Word Document (.docx) in

Microsoft Word.
3. Select all of the text in the document and apply your custom font.
4. Enable embedded fonts in the document.
5. Upload the template [353] to an existing or new export in Jama Connect.
6. Export the document [351] in Word or PDF format.
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Managing tests with Jama Connect

Using tests in Jama Connect helps validate the quality of your product and verify that the product meets
its requirements. When you run a test, the generated report shows connections between regulations,
requirements, and test results.

Terms
Test case — A description of the specific tests you need to run in order to validate or verify product
features or systems.

Test plan — An item that documents the overall strategy for validating or verifying that a product or
system meets its design specifications and requirements. It also serves as a means of organizing test
cases from the project or another project. Test runs are generated for the test cases included in the test
plan.

Test group — A way to organize and optionally assign test cases in a test plan. The order of test
groups and test cases with each group determines how the test runs appear in the test cycle.

Test cycle — A group of test cases converted into a series of test runs that are ready for execution.

Test run — An item used to record results for a test case you ran against your product. Test runs are
traced directly to the test case where they were generated, and the results for each run determine the
Test Case Status for the related test case

Testing workflow

A typical workflow for testing looks like this:

1. Create test cases [361] and relate them directly to the requirements that the test cases verify. A
test case describes the specific tests you plan to use and their steps [365].

2. Create a test plan [371] that gives an overview of how you want to test requirements.
3. Associate the necessary test cases with the test plan and organize them into groups [380].
4. Get ready for testing by adding a cycle [383] in the test plan. When building a cycle, you must

select from the groups in the plan. When you save and create a cycle, you see test runs for all test
cases and the selected groups are also created.

5. Execute the test runs and log defects [395] as needed.

Resulting test run statuses roll up to calculate the overall test case status [368]. You can then gener-
ate a report showing results, such as the Test Plan Summary Report [429] or the Test Plan Detail
Report [427].

IMPORTANT
You must have at least a Test Runner license to be able to add and edit defects
and items, create test plans and runs, and manage relationships and attachments.
However, test runners can only affect items that are used as defects [362]. More
extensive permissions require a different license [583].
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Test cases
Test cases are items that define how a requirement is verified. Test cases (also referred to as valida-
tions or verifications) are directly related to the requirements they are meant to verify. This ensures
proper coverage and establishes a trace from requirements to the results of testing (verification).

Test cases are created in the same way any item is created and organized in the Jama Connect struc-
ture. Jama Connect sample frameworks typically provide a default test case item, but your organization
can configure its own test case item type with terminology and fields relevant to your process.

Like most other items in Jama Connect, test cases can be reused across projects. They can be
organized directly within a project or within a library of test cases, where they can be reused.

After creation, organization, review, and approval, test cases are added to one or more test plans in
Jama Connect, where test runs are generated for the test cases. During a test run, results are captured
for test cases. Jama Connect automatically establishes a trace from test cases to test runs and displays
this relationship in Trace View.

Import test cases
You can import multiple test cases and their corresponding test steps from a spreadsheet.

• You can use a one-way import [118] to quickly bring legacy test cases into Jama Connect.

• You can use a round-trip import [122] so you can work with content outside of Jama Connect and
bring changes back in safely. 

TIP
Use Excel for test case imports. Although you can use Microsoft Word, you can only
map the Name and Description fields, not the individual steps.

Important considerations

• Each row with the same test case name is imported as a new test step for that case.
• Test cases and steps can be edited with a round-trip import. For more information, see Edit test cases

using round-trip [361].

To import test cases:

1. Make sure your spreadsheet includes columns for Test case name and Description. If importing
steps, also include a column for Action, Expected results, and Notes.

2. Add columns to represent additional fields as part of the import. This is consistent with how other
imports to Excel work.

Edit test cases using round-trip
You can edit multiple test cases and their corresponding test steps using round-trip.

You can't use a round-trip [122] to edit the test case status [368] because that field is automatically
calculated from test run statuses.

1. Export a round-trip Excel file [122] and include the Steps field.
2. To add a test step in Excel, copy a preexisting row and insert it where you want it. Change the

content of the cells as needed to create the new step. The steps are renumbered on import.
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3. To remove a step in Excel, delete a row anywhere in the sequence of steps. The steps are
renumbered on import.

4. Import test cases [361].

Special use of item types for test
Any item type can be set up by an organization admin [613] to work in ways that are specific to a test.

For example, the item must be set as a Test Case or Defect to operate within a test.

• Test case — Items used as a test case have test steps [365] and test case status [368] fields, as well
as work in test plans for users with a Creator license.

• Defect — Items you use as defects work in testing for users with a Test Runner license [585] or a
Creator license.

View and edit test case details
Test cases are created in the Explorer Tree for a project and edited like any other item [72]. You can
open test cases from the Explorer Tree, Reading View, List View, or find them using search or a filter.

1. To view test cases in groups — In Single Item View, select the test case ID to open and edit it.
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2. To view test cases from test runs:
a. In Single Item View, select the Test case widget to open the bottom panel and view details

about the test case.

b. Select the test case ID to open and edit it.
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Export test cases to Microsoft Excel
You can export test cases to Excel for audit purposes when the documents need to be saved in a
formal repository.

The content that appears in the final output depends on the items you select. For example, if you select
Name and Modified by, those are the only fields that appear in the output.

NOTE
For test cases, you can also export to a Microsoft Word document [346] or create an
export with Office Templates [349].

You can export test cases with or without steps. When including steps:

• Each step is assigned its own row in Excel output.
• Each step row includes the same non-step data for that case. The repeated data impacts the item

count in the spreadsheet.

To export test cases:

1. From the Explorer Tree, select the set or folder for the test cases that you want to export. If the test
cases are in multiple locations, you must use a filter to select them.

2. Select List View.
3. Select the gear icon to open a drop-down menu and select what you want to include in the Excel

spreadsheet.
4. In the toolbar, select Export > Export to Excel.

The results of your export depend on whether or not you included steps.

With steps
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When you export the Steps field from Jama Connect, all Step columns are included in the export: Step
#, Step Action, Step Expected Results, and Step Notes.

Without steps

Test steps
Test steps are distinct actions used to run a test.

When running a test, you can indicate the success or failure of each step. The Test Steps field is
available in any item whose item type is used as a test case.

A test step consists of these fields, which are authored in the test case:

• Action
• Expected Result
• Notes

Add and edit test steps
For complex test cases, you can add tests steps as needed, as well as edit existing steps.

Important considerations

• When you use a carriage return in test case steps, the displayed text is wrapped. Enable Rich Text
Editor for line breaks to be displayed in steps.

• Test steps are plain text by default. Once an organization admin enables rich text in test steps [598],
you can edit these steps with rich text. To do so, you select the pencil icon or double-click on the
Steps field. Selecting Edit in the toolbar allows only plain text or html edits.

TIP
To add and edit test steps using your key commands, see Keyboard shortcuts [673].

To add and edit test steps:

1. View details of the test case [362] where you want to add steps.
2. Select Edit in the toolbar (for plan text or html edits only), the pencil icon next to the field (for rich

text), or double-click in the field to make it editable, then in the steps field, click Add Step.
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3. Enter text in these fields as needed: Action, Expected Result, and Notes. Use the rich text
editor [367] to format text or to add images in the steps.

4. Use the action buttons in the far right column to reorder, duplicate, insert, or delete a step. If you
need to use the same step multiple times in a test case, you can triple-click the row number to
highlight the entire step, then copy and paste as needed.
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5. Click Save to include the test steps in the test case.

Add images to test steps
To provide more detail in a test step, you can add an image.

Test steps are plain text by default. An organization admin can enable rich text for basic formatting and
embedded images [598].

IMPORTANT
You must save a new test case before you can add an image to the test step field.

To add an image to test steps:

1. Select Edit in the toolbar (for plain text or html edits only), the pencil icon next to the field (for rich
text or html edits), or double-click in the field to make it editable.

2. Place your cursor in the cell where you want to add the image, then click the add image or file icon
and select the image from your browser or server.

Large images are resized automatically to fit the width of the cell. When you save the test case,
click Expand to view the image in full size.
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Test case status
Test case status is a system-managed field that is automatically calculated based on the status of
associated test runs.

Important considerations

• An organization admin can choose to hide the test case status field [599] on any item being used as
a test case. It is possible to have the test case status visible for one test case item type and not for
another.

• Test case status is a system-managed field that is automatically calculated and can't be updated
manually.

By default, this status is calculated using all available test runs associated with the test case, including
runs that aren't scheduled. An organization admin can disable this option [605] so that unexecuted runs
aren't included in the calculation.

The status is calculated by one of these methods:

• If the test case is used in only one active test plan, the test case status the case status reflects the
most recent associated run status.

• If the test case is used in multiple active test plans, the test case status reflects the most urgent run
status based on the following hierarchy, regardless of when it ran.

If a test case is used in multiple plans and it picks up the status of a plan that's no longer relevant, you
can archive that plan [378]. Doing so removes that plan's test run statuses from the test case status
calculation.

You can also use archiving to trigger a recalculation of all test cases in a plan. When a user archives
and then unarchives the test plan, the status for all test cases in that plan is recalculated. This can
be useful if you want to recalculate the test case status after changing the admin setting to include
unexecuted test runs [605], which isn't retroactive.

Add a Test Run Results column
The Test Run Results column displays the status of all downstream test runs. You can add this column
to test cases in reviews, List View, Reading View, and Trace View.

1. To add a column in List View or Reading View:
a. From the gear icon, select Test Run Results.
b. Hover over the color bar to view the status for each test run.
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2. To add a column in Trace View:
a. From the gear icon, select Test Run Results.

b. Hover over the color bar to view the status for each test run.

3. (Organization admins only) To add a column in reviews:
a. Select Admin > Organization, then select Item types.
b. On the Item types page, select Test Case > Edit.

Your admin might use a different name for Test Case, like Verification. To confirm the item
type, look at the Use as section in the Edit Item Type window.
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c. Click Save.
d. Select Test Case > Views and enable the Test Run Results field for Reading View and Single

Item View.
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In a review with Test Case items, the results rollup bar now appears.
e. To view the status for each test run, hover over the color bar.

Test plans
A test plan is an item that documents the overall strategy for validating or verifying that a product or
system meets its design specifications and requirements. 

Working with test plans consists of these tasks:

• Add a test plan [372]
• Add test cases to a plan [373]
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• View test plan details [374]
• Edit a test plan [375]
• Send a test plan for review [376]
• Duplicate a test plan [377]
• Archive a test plan [378]
• Delete a test plan [379]

Add a test plan
You can add test cases to a plan, edit, duplicate, or delete the plan, send it out for review, and archive
the plan.

NOTE
You must have read/write permissions for the entire project to create a test plan. 

1. Select the Test Plans tab in the left panel.

2. Click Add test plan.
3. In the window that opens, enter the name and description of your new plan. An organization admin

can edit the default template [616] included in the test plan description.
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4. To create another test plan, select Add Another, then complete the options for that plan.
5. To let others know that you created this plan, select Notify. You can leave a comment and notify a

user or group by email.
6. Click Save and Close.

The new test plan appears at the top of the list in the Test plans table.

Add test cases to a plan
Once you create test cases, you can add them to a plan in groups. 

For example, you might group all the cases for a specific aspect of the product, for a test location, or for
a specific tester.

Because a test case can appear in a test plan only once, you can only add a test case to one group in a
test plan.

To add a test case to a plan:

1. In the left panel, select the Test Plans tab and the name of the plan where you want to add the
cases. 

2. In the toolbar of the center panel, select Test Cases for that plan.
The right panel shows the tree for your project.

NOTE
If you select a different project in the project selector drop-down menu, the right
panel displays the tree for the selected project.
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3. To add test cases to an existing group: Select any component, set, or folder of test cases, or an
individual test case from the plan's tree on the right, then drag it to an existing group.
You can also select the Releases, Filters, or Search tabs to find the test cases you want to add.

4. To create a new group based on the Explorer Tree hierarchy, drag the component, set, or folder
that contains test cases to the dashed line box at the top of the center pane. The hierarchy is used
to generate groups with test cases.
For example, if you drag and drop this set of test cases:

These three groups are created:

View test plan details
You can view the details of a test plan by opening it, then you can toggle between three views.

1. Select the Test Plans tab in the left panel.
2. Select the plan to open it.
3. In the center panel, toggle between these views:
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• Overview — Describes the testing goals and purpose and is displayed as a Single Item
View [59] of the test plan. An organization admin can configure which fields are displayed for
this item type [595].

• Test Cases — Where you add groups of test cases to a plan.

• Test Runs — Where you add and perform a cycle of test runs.

Edit a test plan
Once you find the test plan you want to use, decide which way to edit the Overview section of the plan.

1. Select the Test Plans tab in the left panel.
2. Right-click on the plan you want to edit and select Edit to open the Edit item page.
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3. Make changes to the test plan Overview as needed.
4. Click Save.

Send a test plan for review
You can send a test plan for review to ensure that the content is correct and the expected test cases
were included.  You also gain a baseline of the test plan with its test cases for later comparison, if
needed.

Important considerations

• When you send test items for review, Single Item View and Reading View might not display all
relevant fields. To include the necessary fields, ask your organization admin to configure views [617]
for an item type.

• You can create an advanced filter [142] that contains any combination of test plans, cycles, cases,
and runs and send that to review.

To send a test plan for review:

1. Select the Test Plans tab in the left panel.
2. Right-click on the test plan you want to review and select Send for review.
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3. When the initiate review [166] page opens, complete the pages and click Initiate review.

Duplicate a test plan
To save time, you can create a copy of an existing plan to use as a template.

The copy contains:

• All details from the original
• All groups of test cases from the original

The copy doesn't contain:

• Test runs from the original
• Test cycles from the original

To duplicate a test plan:

1. Select the Test Plans tab in the left panel.
2. Right-click on the test plan you want to copy (active or archived) and select Duplicate.
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An active copy of the selected test plan is created.

Archive a test plan
The only way to archive a test run is to archive the associated test plan. When you archive a test plan,
the associated test runs no longer appear in the associated test case, and the test case status reverts
to "not scheduled."

1. Select the Test Plans tab in the left panel.
2. Right-click on the test plan that you want to archive and select Archive.

The archived test plans moves into a group at the bottom of the list of test plans.
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3. To make a test plan and its associated test runs active again, right-click on the test plan and
select Unarchive.

This action recalculates the test case status.

Delete a test plan
When you delete a test plan, you also delete all associated test cycles and test runs. This action also
changes the status of test cases associated with the deleted test runs.

IMPORTANT
If a plan has any associated test runs, archive the test plan [378] rather than deleting it.
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1. Select the Test Plans tab in the left panel.
2. View details [374] of the plan you want to delete. 
3. In the toolbar, click Delete (trash icon).

Test groups
A test group lets you organize and optionally assign similar tests in a test plan.

Test cases are added to a plan in groups. This organization makes it easier for others to understand
and run your test plan.

For example, you might want to include in the same group all the cases for a specific aspect of the
product, or group by test location or tester.

Add, edit, or delete a test groupadd test
Test cases are added to a plan [373] in groups, which makes it easier for others to understand and run
your test plan. For example, you might want to include in the same group all the cases for a specific
aspect of the product, or group by test location or by tester.

Along with the default test group, you can create a new group manually by clicking Add Test Group
or automatically generate test groups by dragging test containers to the center panel. These automatic
test groups inherit the name of the test case container. For example, test cases organize by folders in a
set generate test groups for each folder.

Workflow tip
Some organizations create a user as a placeholder for a particular team, such as "Software Team," and
assign groups to that team. While this method requires an active license, it allows members of the team
to see all the runs that are assigned to their team in a cycle. When you execute a run that was assigned
to another user, such as "Admit Test," you can reassign that run to yourself.
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To add, edit, or delete a test group:

1. Select the Test Plans tab in the left panel, then select the plan where you want to add a test group.
2. In the toolbar of the center panel, select Test Cases for the plan you want to see.
3. Click Add Test Group.

4. In the window that opens:
a. Enter the name for the group.
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b. Assign a person to run the tests in this group by clicking Search (magnifying glass icon), then
select the person's name, click Select User and click Save.
Any runs created from this group are automatically assigned to that person.

5. To edit an existing group:
a. Select the gear icon to open the Add/Edit Group of Test Cases window.

b. Make your changes and click Save.
6. To delete an existing group:

a. Select the Test Group you want to delete, then click X (Delete this test group).

b. Click Yes to confirm.
The test group is removed from the center panel.
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c. Select Test Runs and review existing Test Cycles to see if there are test runs linked to the
removed test group cases.

d. If test runs are unassigned and appear in the Not Run state, select Cycle > Edit cycle.
A wizard opens and guides you through the process [385]. The removed test group no longer
appears on the second page of the Edit Cycle wizard.

e. Save the Test Cycle to update and ensure the test runs were removed.

IMPORTANT
If the test runs were executed, then you must delete each test run from Single
Item View.

Test cycles
Test cycles convert groups of test cases into a series of test runs that are ready to be executed.

In a test plan, you must add a test cycle [383] to generate runs [395] and record results. You can also
send a test cycle for review [388].

You can't add a test case directly to a cycle; you must first include it in a group.

Test cycles can include all tests in the plan or a select number of groups defined in the plan. For cycles
generated after the first cycle, test cycles might also include or exclude test cases based on previous
run status within that plan.

Add a test cycle
Cycles are created from groups of test cases. Add a test cycle to combine test runs that you want to
execute together. 

1. Select the Test Plans tab in the left panel.
2. Select the plan to open it.
3. In the toolbar of the test plan, select Test Runs.

The screen displays the selected cycle and all associated test runs.
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4. To add a cycle, select Add cycle from the Cycle drop-down menu.
If this is the first cycle you're adding, you see a green button icon.

The Add test cycle wizard opens.
5. On the Test cycle details page, enter the name, start and end dates, and optional description, then

click Next.

6. On the Test cases page, make your selections:
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• Add by test group — Select All test groups in a plan or select individual test groups.
• All statuses — Select All statuses or select individual statuses.

7. Click Save.

The page is refreshed and displays the new test cycle.

Edit a test cycle
Cycles are created from the test plan's groups of test cases. From the Cycle drop-down menu, you
can edit just the details (name and description) or edit the cycle's full contents (details and any needed
tests).

Important considerations

• When you edit the contents of a test cycle, a text alert warns you about potential data loss. For each
group that is removed, you can hover over its caution icon to see the number of test runs to be
deleted. The total number is highlighted in yellow at the bottom of the screen.
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• If a group in the cycle contains an assigned test run or a test run with a status other than Not Run,
that run is not deleted when the group is removed. It must be manually removed from the test cycle.

To edit a test cycle:

1. In a test plan, select Test Runs, then select the cycle you want to edit.
The screen displays the selected cycle and its associated test runs.

2. To edit only the cycle's name and description, select Edit details from the Cycle drop-down menu.

a. In the page that opens, change the name and description as needed.
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b. Click Save.
3. To edit the cycle's name, description, and contents, select Edit cycle from the Cycle drop-down

menu.

The Edit test cycle wizard opens.
a. Enter the name, start and end dates, and optional description, then click Next.

b. Make your selections under Add by Test Group:
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• Add by test group — Select All test groups in plan or select individual test groups.
• Add by test run status — Select All statuses or select individual statuses.

c. Click Save.

A pop-up message confirms that the changes were successful.

Send a test cycle for review
A wizard guides you through the process of sending a test cycle out for review.

NOTE
When you send test cycles and runs for review, some relevant fields might not appear
in a review's Single Item View or Reading View. If this occurs, an organization admin
can configure views [617] for an item type to include the necessary fields.

To send a cycle for review:

1. In a test plan, select Test Runs, then select the cycle you want to send for review.
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2. Select Send For Review from the Cycle drop-down menu.

3. When the initiate review [166] page opens, complete the pages and click Initiate review.

When you send a cycle to a review, the review content includes the cycle details and all runs in the
cycle.
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Test runs
A test run is an item that records results for a test case against your product.

A test run item type is created as a singular instance of a test case. The core information (name,
description, and steps) is copied from the test case into the test run when the test run is generated.

If a test case changes after a test run is created, the test run must be manually updated to reflect the
newer version of its test case.

Test runs are executed in test cycles, where test runners indicate a result of passed, failed, blocked, or
passed with errors. These test run statuses roll up to a single status in the parent test case.

Example of a test run:
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Find and manage test runs
By selecting Test Runs in the toolbar, you can manage all the runs in the cycles for a test plan.

Important considerations

• The test cycle displays a clickable ID for each test run. Clicking the ID navigates to the test run in
Single Item View.

• Select the column header to sort columns. Return them to their original order by selecting Restore
order. For older data, a project reindex [661] might be required to properly restore the order.

• The order of the Test Group column is based on the hierarchy of groups. The names themselves
can't be sorted in List View.

To find and manage test runs:

1. For the plan you're using, select Test Runs in the toolbar.

Test runs are displayed in a configurable List View in the center panel.
2. To make fields visible, select Views > Configure view in the toolbar.

3. To see the test case associated with this run, right-click on a test run and select Open test case.
4. To assign a user to a test run, select Assign test run.
5. To filter the List View for test runs assigned only to you, select Show only assigned to me in the

upper left toolbar.
6. To export the visible test runs as a standard Word, Excel, or custom format document (Office

Templates), select Export.

View test run details
You can view specific details about a test run, such as connected users, comments, and associated test
cases.
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1. In the test plan, select Test Runs from the toolbar to display test runs in List View. 

2. Select the ID of a test run to view its details in Single Item View.

3. From the toolbar on the right, you can:
• View and add relationships, comments, and connected users.
• Check the activity and version history for the test run.
• Open the associated test case.
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Configure test run view
You can configure how your system displays test runs, which columns are visible when you view test
runs.

1. Select a test plan, then select Test Runs from the toolbar.
2. From the Views drop-down menu, select Configure view.

3. In the window that opens, double-click on the field name, drag and drop, or use the arrows to move
the field names between the Hidden fields column and Visible fields column.
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4. Select Restore organization defaults if you want to return to the default settings. An organization
admin can configure the default view settings for test run item types [617].

5. Select Save as default for Test Runs if you want to use this configuration for all test runs that you
view in Jama Connect. Otherwise, your settings are applied only during this session and return to
default settings when you log in again.

6. Click Apply.

Assign test runs
A test run must be assigned to an individual. It can be assigned in advance or when a user executes a
run.

Assigning users in advance allows them to easily identify which test runs they are responsible for
executing. It also ensures that no test runs are missed because they weren't assigned.

1. In the test plan, select Test Runs.

Jama Connect User Guide

394



2. Select the test runs you want to assign. Press Ctrl or Shift to select more than one.

3. From the Actions drop-down menu, select Assign Test Runs.

4. In the Assign Test Runs window, select the name of the user you want to assign, then click Select
User.

5. Click OK.

The page is refreshed and the user you assigned to the test run appears in the Assigned to column.

Execute a test run
When a user executes a test run, results like Pass/Fail are captured for that run. The run displays
details for conducting the run, including the description and steps defined in the associated test case.

IMPORTANT
When you select Pause, the results (Pass/Fail) aren't automatically saved. You must
click Save and Done to save the recorded results or "actual results" values.
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1. In the test plan, choose the run you want to execute using one of these methods:
• Select Execute this Test Run (blue arrow button) next to the run you want.

• Right-click on the run you want and select Execute Test Run.

The Execute Test window includes three tabs at the top: Test Execution, Test Run Details, and
Test Case.

NOTE
If you try to execute a test run that isn't assigned to you, you are prompted to
reassign it to yourself.

2. To execute multiple runs assigned to you, make sure they are assigned to you before opening the
Execute Test window, then select Open my next assigned test to continue to the next run.
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3. Select the Test Execution tab.
a. Click Start Test Run to start the duration timer.

Unless the field is configured to read-only, you can double-click on the duration field and
change the timer to reflect the actual testing time.

b. If you discover a defect while running a test, select Log a Defect to open the right panel, fill
in the information and click Save Defect. (A project admin can determine where these defects
are saved [660].) When you add a defect from the Test Execution window, it's automatically
related to that test run and test case where the test run was generated.
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c. Once you start the timer and begin the test, mark each step as passed, failed, or not applica-
ble*. You can add results for each step in the results field. If there are no steps, you can assign
an overall passed, failed, or not applicable status*.
* Not applicable status is only available when configured by an organization admin.

d. To include images in the Results column of the test steps, click Add Image. You can also
provide feedback for the test run as a whole using the Actual Results field, which is a rich text
field that can include formatted text, tables, images, and links.
The test run status [403] (in progress, passed, failed, blocked) is shown at the bottom of the
status column.
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e. (Optional) If any step failed but you want to conditionally pass the test run, select
Pass with errors. If the test run couldn’t be executed (steps couldn’t be performed), select
Mark as blocked.

4. Select the Test Run Details tab to view details about the run.

These items are visible:
• Test case that generated this test run — View the version number of the test case at the time

the test run was generated and the current version. Select the ID to open a new window that
displays the details of the derived item, such as the goal of the test case, preconditions, steps in
the case, and the duration of the test run.

• Upstream items related to this test run — Select the item ID to view detailed information about
the related items in a separate window.

5. Select the Test Case tab to view details about the test case that generated this test run.

6. Click Save and Close.
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Archive a test run
The only way to archive a test run is to archive the associated test plan.

When you archive a test plan, the associated test runs no longer appear in the associated test case,
and the test case status reverts to "not scheduled" or the appropriate value based on any existing
non-archived test runs.

1. Select the Test Plans tab in the left panel.
2. Right-click on the test plan that you want to archive and select Archive.

The archived test plan moves into a group at the bottom of the list of test plans.

3. To unarchive a test plan (make it active again), right-click on it and select Unarchive.
Along with the default test group, you can create a new group manually or by dragging test cases
to the center panel.
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Configure custom fields to appear during test execution
When custom fields are added to the Test Run item type, they appear in the Test Execution window
during testing. Similar to the Actual Results field, these custom fields can be filled in during test
execution.

Supported custom field types
Note: Other custom field types don't appear on the test run execution panel.

• Date
• Flag (Boolean)
• Integer
• Multi-select
• Picklist
• Text box (plain text)
• Text box (rich text)

You can use Editor Templates in custom rich text fields. To export the Editor Template information
for a Test Run item from Single Item View, select Export > View all export options > All Item
Details, then click Run.

• Text field
• URL

To configure custom fields:

1. Select Admin > Item Types > Test Runs, then select Add field.
2. In the Add field window, complete the form [595], then click Save.

On the next test run, the custom fields are available and can be edited.

Example: Add a custom test field to capture the serial number for a product being tested during that
test run's execution.
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Sync test runs with test cases
When you create a test run, the Name, Description, and Steps values are copied from the test case to
the test run.

Important considerations

• If you make a change to the test case after synchronization, the change isn't reflected in the test run. 
• Synced test runs are versioned and updated to reflect the changes from the test case. Any previous

progress, results, or statuses are saved in the test run version history. The previous results can be
restored with the Make Current action in the test run version history widget.

To sync test runs with a test case:

1. If a test case has changed since the test cycle was updated, look for an out of sync alert in the
second column of the test execution grid.
This alert also appears in the test run execution window next to the test run name.
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2. Select the test run you want to make current (press Shift to select multiple test runs), then select
Actions > Sync Test Runs to Test Cases.

The Sync test runs to latest case version window opens.

3. Select the run you previously chose or all out-of-sync runs, then click Next.
4. Click Commit to make the selected test runs current. 

Test run status
Test run status indicates the current state of a test run, and is used in calculating test case status.

You can also view a test run status summary per cycle. It is displayed next to the cycle name when you
select Test Runs in the toolbar.
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Possible states are: 

• Pass
• Fail
• Blocked  
• In progress 
• Not run
• Not applicable

For "Not applicable" to be an available status option, it must be configured by your organization
admin [626].

NOTE
If you need to reset the test run to a status of Not run, you can batch update test run
status [404] or deselect steps that were marked as pass or fail, and set the test run
duration to 0. This automatically resets the status to Not run.

Batch update test run status
As long as test runs aren't locked and you have write permissions, you can update the status of multiple
test runs at once.

You can only batch update test runs in the Test runs window. You can't use advanced filters to batch
update test runs. 

1. Select Test Runs in the toolbar. 
2. In the center panel, use the Ctrl or Shift keys to select the test runs you want to update.

3. Select Actions > Batch Update Test Run Status.
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4. Confirm the number of runs, then click Next.

5. Select the new status you want for the selected runs, then click Next.

6. Select the users or groups you want to notify, then click Commit.
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Using the Test Runs widget
The Test Runs widget on the test case item allows you to view all runs and their results from that test
case.

In Single Item View, the test runs widget appears on item types where the Use as setting is Test Case.

This widget shows all test runs associated with the test case. From the Test Runs widget, you can view
the test runs status and take action on the test runs:

• Batch assign
• Status updates
• Sync with a test case

The number indicates the number of active test runs.
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Analysis — Monitoring your project

Jama Connect includes tools that give you the big picture of your project and that help you gain insight
on different areas of your product development.

• Dashboard [412]
• Reports [414]
• Coverage and traceability tools [302] — Find out how mature the product development is. For exam-

ple, if 100% of requirements have a traced verification, development is in a mature and complete
state and can claim compliance.

• Exports [344] — Analyze data in tools like Excel. Jama Connect provides dashboards for a visual
at-a-glance display of your project. Users with organization admin or project admin permissions can
configure a project dashboard.

Working with dashboards
In Jama Connect, the dashboards feature allows you to track the data your team wants to monitor for
quality and progress.

You can select dashboard widgets [412] that display a project's key metrics, so you can see which parts
of your project need attention. Dashboards are customized per project, not per user.

Example dashboard widgets include:

• Pie chart — Shows all requirements by status. For example, 25% are in draft state, 75% are in
review state.

• Bar chart — Shows count of all requirements missing a downstream verification test.

Your role determines your interactions — and the options that are available — when you use the
dashboard feature. For example, a user with read/write permissions can view the dashboards created
by an organization or project admin, but they can't create, edit, or delete a dashboard. Work with your
admin to create a dashboard with the widgets that best support your team's needs.

Role Responsibilities and actions

User with read/write permissions • View the dashboards created by an admin.
• Choose your default dashboard.
• Download or view data from a chart.
• Switch dashboards.
• Print the contents of your dashboard.

Organization and project admins • Create, edit, and delete dashboards for users with read/write permissions.
• Choose your default dashboard.
• Download or view data from a chart.
• Switch dashboards.
• Print the contents of your dashboard.

Manage the dashboard (users)
When the dashboard feature is configured by an organization or project admin, you can use the
dashboard to give your team insight into the progress of each project. Dashboard changes are made at
the project level.

Important considerations

• Only organization and project admins can can create or modify dashboards.
• Dashboard names appear in alphabetical order.

To manage the dashboard:
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1. From the Explorer Tree, select your project name to open the project dashboard.

2. To download or view data from a chart, select an option from the drop-down menu.
The download options only appears in the Bar, Line, Pie, and Complex chart widgets.

• Download PNG — Downloads the widget image.
• Download CSV — Downloads the data from the chart.
• Download PDF — Downloads the widget image.
• View data table — Displays the data table/chart and the numerical information associated with

the data.
3. To view a different dashboard, select from the Switch drop-down menu.

TIP
To see the current dashboard when the project page loads, select Set as my
default dashboard.

4. To print the contents of your dashboard, select Print.

TIP
For best results, use a landscape page setup and enable printing of background
images in your browser settings.
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Configure the dashboard (admins)
The dashboard feature allows organization and project admins to customize a project dashboard so that
it displays the information needed by project members. Dashboard changes are made at the project
level.

Important considerations

• Only organization and project admins can create or modify dashboards.
• Each dashboard must have a unique name. Also, descriptive names can help you organize and

manage your dashboards.
• Widgets and dashboards are limited to a maximum of 20 each. The initial project dashboard is

allowed an unlimited number of widgets, but for optimal performance we recommend a maximum of
20 widgets. Subsequent dashboards are limited to 20 widgets.

• Projects must have at least one dashboard. You can have a maximum of 20 dashboards per project.
• The first dashboard created for a project is automatically set as the default dashboard for all users.

• If you delete the project default dashboard, you are prompted to select a new dashboard as the
default.

• Users can customize which dashboard first appears upon their login by viewing the dashboard of
their choice and selecting set as my default dashboard

• Dashboard names appear in alphabetical order.

To set up the dashboard:

1. From the Explorer Tree, select your project name to open the project dashboard.

2. To add a widget to your dashboard:
a. Select Add widget in the top right toolbar of the dashboard.

b. In the window that opens, select the dashboard widget options you want, then click Add.
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3. Select Layout in the toolbar, then choose how you want the windows to appear on the dashboard.

4. To create an additional dashboard, select Add dashboard in the toolbar.
a. In the window that opens, enter a unique name.
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b. Click Create.
The screen is refreshed and the new dashboard appears.

5. To edit the name of a dashboard, select Edit.
a. Enter a new name.
b. Click Save.

A pop-up message confirms that the new name was saved.
6. To view a different dashboard, select from the Switch drop-down menu.

7. To see the current dashboard when the project page loads, select Set as my default dashboard.

8. To download or view data from a chart, select an option from the drop-down menu.
The download options only appear in the Bar, Line, Pie, and Complex chart widgets.

• Download PNG — Downloads the widget image.
• Download CSV — Downloads the data from the chart.
• Download PDF — Downloads the widget image.
• View data table — Displays the data table/chart and the numerical information associated with

the data.
9. To print the contents of your dashboard, select Print.

TIP
For best results, use a landscape page setup and enable printing of background
images in your browser settings.

Dashboard widget options
You can customize a project dashboard to display the information needed by project members. Dash-
board changes are made at the project level.
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NOTE
To manage the dashboard [408], you must have organization admin or project admin
permissions.

The following widgets can be added to the dashboard.

Filter results Displays the results of an existing filter.

• Name the window.
• Select a filter and which columns to display.
• Select how many items to display.

Bar chart Displays the results of an existing filter as a bar chart.

• Configure the name, filter, field shown, and number of elements with the gear icon in the top right.
• Select individual bars in the bar chart to view those items in a new tab.

Pie chart Displays a pie chart for a filter and field that the user selects.

• Configure the filter and field with the gear icon button in the top right.
• Select the individual items in the pie chart to open those items in a new tab.

Project sum-
mary

Displays a summary of the entire project, including:

• Total number of items in the project.
• Number of days until next release.
• Number of days until project completion.
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Recently
viewed

Displays the last 15 items viewed by the current user.

• Select a recently viewed item to open it in a new tab.

Assigned to
me

Displays a list of items assigned to the current user.

• Select the gear icon in the top right to edit the settings.
• Name the window.
• Select a filter and which columns to display.
• Select how many items to display.

Recent activi-
ty

Displays a line graph of recent activity over a period of time.

• Configure the time period.
• Change the name with the gear icon in the top right.

Activity
stream

Displays the current activity stream of the project.

• View all current activity including comments, edits made, new items created, and assignment
changes.

• Use the filters at the top right to filter only comments, activities, or search for specific items.

Rich text Displays user-defined text, images, diagrams, and equations.

• Select the gear icon to insert text, pictures, and tables with the same rich text options as an item
description field [92].

Relationship
rules diagram

Displays the relationship rules [157] applied to the project.

Complex
chart

Displays a granular snapshot of data based on filter, field, and series selections.

• Select the gear icon to configure the filter, fields, and series.
• Select individual bar sections in the stacked bar chart to view those items in a new tab.

Reports
A report is a document that helps you analyze the current status and progress of your project. Reports
can include graphs, tabular data, metrics, and other roll-ups.

Important considerations

• Reports can refer to specific data within a project, to an entire project, or they can apply across
multiple projects.

• To access reports, select Projects > Reports in the upper-right header. From there, you can run a
report [415].

• Jama Connect includes default reports that were created with BIRT or Velocity. You can also create
custom reports.

• Your system or organization admin can upload custom Velocity exports [565] that are displayed in the
Export window.

Jama Connect includes these default reports

Report type Displays...

Baseline Compared to Current Side-by-side comparison of items and relationships in a baseline and their current versions.

Baseline Comparison Side-by-side comparison of items and relationships in two baselines.

Bidirectional Traceability Upstream and downstream relationships for a selected container of items.

Items in a Set Tabular list of items in a set.

Release Status Current state of the items within a release.

Task List with Estimates All item types and sums and totals their estimates if applicable.

Test Plan Detail Details of a test plan.

Test Plan Summary Summary of the test plan with graphs and charts, by cycle and build.

Trace Relationships Items with their downstream relationships.

User List List of all the active and inactive users associated with the organization.
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Report type Displays...

Review Center Stats Progress of a specific review.

Run a report
Reports can refer to specific data within a project, to an entire project, or they can apply across multiple
projects.

To generate a report:

1. From the Jama Connect header, select Reports > Run report.

Jama Connect lists all default reports and any custom reports [433] you have added. Bookmarked
reports appear at the top of the list.

2. (Optional) To add a report to your bookmarked reports, select its bookmark icon.
3. From the list of reports, select the one you want to run, then define the options for that report.

For details on defining the report options, see the task for running that specific report.
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4. Select Run Report.

Run a Baseline Compared to Current report
The Baseline Compared to Current report compares items and relationships in a baseline to their
current versions, displayed in side-by-side columns.

To run this report:

1. From the project with the baselines you want to compare, select Reports > Run report in the
upper-right corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select an option for this report:

• Baseline Compared to Current — Word format
• Baseline Compared to Current (PDF)

3. Define the report:
a. Select the format for the report (available formats are listed).
b. Navigate to and select the baseline you want to compare to the project’s current state.
c. (Optional) Include relationships and version comments.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Baseline Compared to Current shows a table that compares the baseline items and relationships side
by side.

Run a Baseline Comparison report
The Baseline Comparison report displays a side-by-side comparison of items and relationships in two
baselines.

This report compares two specific states of selected items at a certain point in time. For example, to see
what has changed between two baselines, you can compare the baseline that's created when you open
a review with the baseline of the completed review.

NOTE
When comparing baselines, the hierarchical order must be the same between the two
baselines. If items are reordered in the Explorer Tree from one baseline to the next, the
report shows incorrect or no results.

To run this report:

1. From the project with the baselines you want to compare, select Reports > Run report in the
upper-right corner of the header to open the Run Reports window.
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2. From the list of reports in the Run Reports window, select an option for this report:

• Baseline Comparison — Word format
• Baseline Comparison (PDF)

3. Define the report: 
a. Select the format of the report.
b. Navigate to and select the two baselines you want to compare.
c. (Optional) Include relationships and version comments.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.

Items added or deleted between the compared baselines are noted at the top of the report.
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Run a Bidirectional Traceability report
The Bidirectional Traceability report displays upstream and downstream relationships for a selected
container of items.

To run this report:

1. From the project with the relationships you want to include, select Reports > Run report in the
upper-right corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Bidirectional Traceability.
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3. Define the report:
a. Select a default format (HTML, PDF, WORD, or XLS).
b. Select the location of the items you want to include.

NOTE
You must choose a container of items to analyze for upstream and downstream
traceability. The report doesn't work on single items.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.

The report displays all items that have relationships from the selected location. Both downstream and
upstream relationships are displayed for each item. The report also indicates whether any related
artifacts are marked as suspect: T = True (suspect), F = False (not suspect).
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Run an Items in a Set report
The Items in a Set report displays a tabular list of items included in a set.

The report is displayed as a table that includes these columns: Header (hierarchy), ID, Name, and
Description.

To run this report:

1. From the project with the items you want to include, select Reports > Run report in the upper-right
corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Items in a Set.
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3. Define the report: 
a. Select the format of the report.
b. Select the location of the items you want to include.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Run a Release Status report
The Release Status report displays the current state of the items within a release.

It shows graphs of item status and priority, as well as a table with priority, status, estimate, and amount
remaining.

To run this report:

1. From the project with the items you want to include, select Reports > Run report in the upper-right
corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Release Status.

3. Define the report:
a. Select the format of the report. The default format is PDF.
b. Select the location of the items you want to include.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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NOTE
If you have data in the Estimate and Remaining fields, those numbers are totaled at
the bottom of the report.

Run a Review Center Stats report
The Review Center Stats report displays the progress of a specific review in a table that shows activity
per reviewer and per review item.

NOTE
You must be a reviewer, approver, or moderator of a review to run the report or to be
able to see the review listed in the menu. Public reviews aren't listed unless you're
specifically assigned to the review.

To run this report:

1. From the project with the review you want to include, select Reports > Run report in the upper-
right corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Review Center Stats Report.
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3. Define the report:
a. Select the format of the report (available formats are listed).
b. Select the review you want to use.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Run a Task List with Estimates report
The Task List with Estimates report displays all item types and totals their estimates if applicable.

To run this report:

1. From the project with the items you want to include, select Reports > Run report in the upper-right
corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Task List with Estimates.
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3. Define the report:
a. Select the format of the report (available formats are listed).
b. Select the location of the items you want to include.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.

Run a Test Plan Status Detail report
The Test Plan Status Detail report displays the details of a test plan.

To run this report:

1. From the project with the test plan you want to include, select Reports > Run report in the
upper-right corner of the header to open the Run Reports window.
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2. From the list of reports in the Run Reports window, select Test Plan Status Detail.

3. Define the report:
a. Select the format of the report (available formats are listed).
b. Select the test plan you want to use.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Run a Test Plan Status Summary report
The Test Plan Status Summary report displays a summary of the test plan with graphs and charts, by
cycle and build. 

To run this report:

1. From the project with the test plan you want to include, select Reports > Run report in the
upper-right corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select Test Plan Status Summary.
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3. Define the report:
a. Select the format of the report.
b. Select the test plan you want to use.

4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Run a User List report
The User List report displays a list of all the active and inactive users associated with the organization.

NOTE
When a floating creator license is unavailable, a new user logging in is granted a
floating reviewer license if one is available. If the only available license is for named
reviewers, the new user can't log in to Jama Connect.

The report includes: Username, full name, disabled (inactive) status, email, and license type.

License type key for User List Report

Creator (named) N

Creator (float) C

Test runner TR
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Stakeholder S

Temporary ET

Reviewer (named) NV

Reviewer (float) — legacy V

Reserved reviewer — legacy RV

Reserved collaborator — legacy R

Collaborator (float) — legacy FC

Inactive I

To run the report:

1. From the project with the data you want to include, select Reports > Run report in the upper-right
corner of the header to open the Run Reports window.

2. From the list of reports in the Run Reports window, select User List.

3. Define the report by selecting the format of the report.
4. (Optional) Select Email me the report to receive it by email.
5. Select Run Report.
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Custom reports
If your reporting needs go beyond built-in default reports [414], exports [344], and Office Tem-
plates [349] you can create custom reports.

Jama Software Consulting Services can help in creating:

• Reports with logic
• Reports with charts and graphs
• Reports with custom formatting

To get help, contact your account manager or Jama Software support at support@jamasoftware.com. 

View and download Reports history
From the the Reports history page, you can view and download reports. You can also see the status of
reports that are generated.

NOTE
Organization admins see all reports. Users see only reports they create.

To view and download reports:

1. From the Jama Connect header, select Reports > Reports history.

2. Select the report you want to view, then click Download.

A pop-up message notifies you that the download was initiated.
3. From the Downloads section of your browser, select the report to open it.
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Manage the Reports history page
From the Reports history page, you can sort columns, search, download, and delete multiple reports.
View the Context column to determine the origin of a report or export, such as a set or filter.

A non-context sensitive report can be run from anywhere and isn't associated with a set, folder, filter,
container, or baseline.

To manage the Reports history page:

1. From the Jama Connect header, select Reports > Reports history.

2. To search for a report — Enter your query in the search field.
The results appear in the table.

3. To download multiple reports — Select the reports you want to download, then select Down-
load.

4. To delete multiple reports — Select the reports you want to delete, then select Delete Selected
Reports (trash icon).

5. To sort columns — Select the up arrow icon and down arrow icon to reorganize the table.

Export Velocity reports to Excel
As a root user, you can configure settings that allow users to export a Velocity report to Excel in XLSX
format. This option lets users export directly to Excel rather than using the legacy XLS format.

Important considerations

• This option is available only for Velocity reports.
• You must configure this option for each report.

Jama Connect User Guide

434



To enable the Velocity report option:

1. Log in to Jama Connect as root user.
2. Select Reports > Add Report.
3. In the Add/Edit Report window, enter the following information:

• Report Name — Enter a name
• Report Type — Velocity
• Report Format — Microsoft Excel
• Excel Format — XSLX format

4. Click Save.

When a user runs a report, they can now see the Excel format type when they hover over the "Select a
format" icons.
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XLSX format example
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XLS format example

From the Jama Connect header, select Reports to view the Reports history section. You can see the
XLS and XLSX format options and if a report type is Velocity. For more information, see View and
download Reports history [433].

Risk
With Risk Management, your organization can use Jama Connect to organize and conduct a risk
analysis for your products.

The default starter templates are based on the FMEA and ISO 14971 standards and follow a common
risk management process. However, they can be adjusted to better meet your needs.

Your framework might not include Risk Management Analysis templates. For more information, contact
your Jama Software admin or consultant.
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Installing Jama Connect (KOTS)

Jama Connect is a Linux-based application that uses containerd to manage containers and depends on
Replicated KOTS software to "orchestrate" deploying applications. The process of installing Jama Con-
nect includes installing and configuring the software. These tasks deliver the components necessary to
run Jama Connect.

Components and what they do
Replicated KOTS — A container-based platform for easily deploying cloud native applications inside
customers' environments, providing greater security and control. The KOTS Admin Console is the
interface for installing and administering the Jama Connect application. See https://www.replicated.com/
for details.

Containerd — A container runtime that assists in the deployment, management, and operation of
containers that support Jama Connect KOTS. See https://containerd.io/ for details.

Jama Connect license — The license included in your Welcome email. You save the license to your
application server, then begin installing Jama Connect.

Jama Connect architecture

• Users access Jama Connect by browsing to the instance URL (https://jamainstanceurl.custom-
er.com/).
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• Administrators browse to the KOTS Admin Console using the same instance URL, but on port 8800
(https://jamainstanceurl.customer.com:8800/).

• Jama Connect and the license are updated via API calls for internet-enabled environments. Our
airgap option removes the need for remote API calls.

• Content that is added to your Jama Connect instance is stored in the database.
• Uploaded artifacts, such as attachments and report templates, are stored in a Persistent Volume

created by a Persistent Volume Claim (PVC) called tenantfs.

For more information about KOTS, see https://www.replicated.com/blog/announcing-kots/

Installation workflow (KOTS)
Whether your environment is internet-enabled or airgapped, the installation process consists of three
stages: planning, preparation, and installation.

Review the system and server requirements for your environment, then follow the instructions for each
stage.

For this component... Follow these instructions

MySQL Install and configure MySQL [445]

Microsoft SQL Install and configure Microsoft SQL Server [447]

Internet Install KOTS software (internet) [450]

Airgap Install KOTS software (airgap) [453]

Local Elasticsearch Included by default

Remote Elasticsearch Configure dedicated Elasticsearch nodes [464]

Planning your installation (KOTS)
Before you install the Admin Console and Jama Connect, make sure you have the following according
to your type of installation.

All instal-
lations

• The license file sent from Jama Software (included in the Welcome email)
• An application server with the necessary preparation [441] and sizing requirements [441]
• A database server with the necessary preparation [445]
• Supported [440] 64-bit Linux distribution with a kernel of:

• 4.x or greater (recommended)
• 3.10 (minimum)

Airgap in-
stallations

• URL to the airgap-safe portal (included in the Welcome email) for downloading the Jama Connect application file
• A unique password (included in the Welcome email) to access the airgap-safe portal
• PDF of this installation guide for the version of Jama Connect you are installing

IMPORTANT
If you lose the URL and password, contact Support to generate new ones.

Optional • TLS certificate and private key to secure the Admin Console and Jama Connect application
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System requirements and supported software (KOTS)
Make sure that your environment conforms to all requirements and recommendations before installing
Jama Connect software.

After reviewing the information on this page, see "Things to do before installation" in Jama Connect
9.6.x User Guide. 

IMPORTANT
To use Ubuntu 22.04, you must update the memory or Elasticsearch fails. From the
KOTS Admin Console, adjust the memory settings so that Maximum Memory is 6G
and Maximum Memory for Container is 8G.

Application server
Use the information in this table for the server that runs the Jama Connect application. For details on
sizing your application server to your environment, see "Resource sizing for application server" in Jama
Connect User Guide 9.6.x. 

Component

Minimum

• 8 CPU
• 32 GB RAM
• 200 GB storage per node
• Every node has the same storage space

Recommended

• 16 CPU
• 64 GB RAM
• 200 GB storage
• Every node has the same storage space

Operating system

• Recommended — Ubuntu 20.04 or Ubuntu 22.04
• Red Hat 8.6 or 8.8 — Supported only when the RHEL Container Tools are not installed.

Software installed with Jama Connect

• KOTS
• Containerd

Musts

• Dedicated server — Is running only Jama Connect
• Accessible by admin with permissions
• Uses only supported software and environments

Database server
Use the information in this table for the server that runs your database. For details on sizing your
database server to your environment, see "Resource sizing for database server" in the Jama Connect
9.6.x User Guide.

Component

Minimum

• 4–8 CPU
• 16–24 GB RAM

Recommended

• 8 CPU
• 24 GB RAM
• Dedicated volumes for data

Database software

• MySQL 8 (recommended)
• Microsoft SQL Server 2019 & 2022
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Component

Operating system

• Recommended — Ubuntu 20.04 or Ubuntu 22.04
• Red Hat 8.6 or 8.8

Musts

• Database is hosted on a server separate from the Jama Connect application.
• Database server can host other databases, but no other applications.
• Accessible by admin with permissions.
• Uses only supported software and environments.
• Databases must be able to accept a minimum of 300 concurrent connections.

Not supported

• Azure database
• MariaDB
• Custom configurations of Jama Connect databases (for example, query optimization and additional indexes that aren’t shipped

with Jama Connect)

Supported software
Make sure your environment uses only supported software.

Component

Browsers

• Edge Chromium
• Firefox*
• Google Chrome*
• Safari*

*Versions released over the past 12 months are sup-
ported.

Important

Browser zoom is supported only at 100%. Use of browser exten-
sions/add-ons or enabling Compatibility View is not supported while us-
ing Jama Connect.

Tip

To prevent session issues, use the application in a single browser win-
dow.

Word processor and spreadsheet programs

• Office 365 for Mac
• Office 365 for Windows

Office 365 is used for exports and reports.

Application server requirements (KOTS)
To install and run Jama Connect successfully, your application server must meet these requirements.

Requirement Notes

A dedicated application
server

Jama Connect is the only application running on the application server. External services can
affect stability of the application, for example by consuming memory resources.

Sufficient storage, CPU,
and memory for optimal per-
formance

To estimate the size of and required resources for your application server, see Resource sizing
for application server [441].

Accessible by an admin with
permissions

An admin must have proper permissions to maintain the application, perform upgrades, and
access the server for regular maintenance.

Uses compatible software
and environments

Verify that you're using supported software and environments [440] compatible with the most
recent self-hosted release.

Resource sizing for application server (KOTS)
For optimal performance, estimate your application server needs before you install Jama Connect.

Requirements

• Each node must have a minimum volume of 200 GB. Increase this size based on the size of the
assets that you plan to save in Jama Connect. We recommend that every node has the same storage
space.
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• KOTS must be up and running before you configure the application settings in the KOTS Admin
Console.

IMPORTANT
To avoid performance issues, use the recommended requirements for horizontal scal-
ing, rather than minimum requirements.

Use the following tables to help determine resources for the primary node of your application server.

Table 1. Minimum size (AWS instance sizing = m5.2xlarge)
CPU RAM CPU + memory settings CPU + memory setting with horizontal scaling jamacores

8 32 GB N/A jamacore application settings:

• Maximum CPU: 1000m
• Maximum memory: 2 G
• Maximum memory per container: 3 G
• Number of ingress nodes 2

Table 2. Recommended size (AWS instance size = m5.4xlarge)
CPU RAM CPU + memory settings CPU + memory setting with horizontal scaling jama-

cores

16 64 GB Supports:

• 1,250 users with a ramp-up time of 30 sec-
onds

Supports:

• 1,250 users with a ramp-up time of 10 seconds
• 2,500 users with a ramp-up time of 30 seconds

jamacore application settings:

• Maximum CPU: 12000m
• Maximum memory: 48 G
• Maximum memory for container: 60 G

jamacore application settings:

• Maximum CPU: 3000m
• Maximum memory: 12 G
• Maximum memory for container: 15 G
• Number of ingress nodes: 2

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

Diff Service settings:

• Maximum memory: 2 G

Diff Service settings:

• Maximum memory: 2 G

Use the following table to help determine resources for the secondary node of your application server.
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Table 3. Secondary nodes dedicated to Elasticsearch: Recommended size (AWS
instance size = m5.2xlarge)

CPU RAM CPU + memory settings

8 32 GB Supports:

• 2,500 users with a ramp-up time of 10 seconds

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

TIP
Once you're up and running, you can monitor usage and adjust your settings as
needed (see "Monitoring memory usage" and "Configure memory settings" in Jama
Connect User Guide 9.6.x).

Database server requirements (KOTS)
The database must be hosted on a server separate from the Jama Connect application. This server
can host other databases, but we don’t support running other applications on the same server as the
database.

Supported databases

• MySQL 8 (recommended)
• Microsoft SQL Server 2019 & 2022

What is not supported

• Azure database
• MariaDB
• Custom configurations of Jama Connect databases. Customizations such as query optimization and

additional indexes that aren’t shipped with Jama Connect aren’t supported.

Resource sizing for database server (KOTS)
For optimal performance, estimate your database server needs before you install Jama Connect.

Use the information in this table to determine resources needed for your database server.

Database server Small Medium Large Enterprise

Active items in system ≤ 600, 000 ≤ 2 million 2–4 million 4 million+

Active projects ≤ 100 ≤ 500 ≤ 1, 000 1,000+

Concurrent users ≤ 50 ≤ 500 ≤ 1, 000 1,000+

CPU 4 8 16 Contact Support

Total systems of RAM 16 GB 32 GB 64 GB Contact Support

If your usage approaches the Enterprise threshold, contact Support for customized recommendations
and advanced, multi-server setup.
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TIP
Once you're up and running, you can monitor usage and adjust your settings as
needed (see "Monitoring memory usage" and "Configure memory settings" in Jama
Connect User Guide 9.6.x).

Important considerations

• Total system RAM for your database server can vary if you're using memory intensive workflows such
as reuse, exporting, moving items, integrations, and batch updates. Database sizing is based on your
usage patterns and platform. You must have a minimum of 4–8 cores and 16–24 GB of memory.
Consult with your database admin when determining database size.

• The memory allocation allows for minimum headroom. If you need to run additional software for
monitoring and analysis, consider the system requirements for that software. Configure dynamic
memory settings as needed in the Admin Console. 

Things to do before installation (KOTS)
Whether your environment is internet-enabled or airgap, make sure that your application server and
database server are ready before installing Jama Connect.

• Review the Jama Connect Release Notes.
• Prepare your application server [444].
• Prepare your database server [445].
• Install and configure your database (MySQL [445] or SQL Server [447]).
• Configure custom memory settings for Elasticsearch [449].

Prepare your application server (KOTS)
Make sure your application server meets all requirements. See System requirements and supported
software [440].

For users and admins to properly access Jama Connect, specific ports must be accessible to inbound
traffic. Work with your network admin to make sure your network is configured properly.

1. Inbound rules and ports for nodes — Make sure the ports in the following table are accessible to
inbound traffic and the inbound rules are configured for each server in the KOTS cluster.

Protocol Port range Source* Inbound rule
applies to

node...

Description

HTTPS 443 Anywhere All Jama Connect port for SSL/TLS communication
(HTTPS), which is used to access Jama Connect. It
can be disabled or the port number can be reconfig-
ured.

HTTP 80 Anywhere All Jama Connect port for clear text communication
(HTTP), which is used to access Jama Connect. It
can be disabled or the port number can be reconfig-
ured.

TCP 8800 Anywhere All Allows admins to access the KOTS Admin Console,
which is used to configure, install, and upgrade Jama
Connect.

SSH 22 Anywhere All Allows admins to make remote connections to the
nodes using SSH.

TCP 6443 Anywhere

Any node

Primary Allows admins and KOTS nodes to access the Kuber-
netes API server.**
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Protocol Port range Source* Inbound rule
applies to

node...

Description

TCP 2379–2380 Any node Primary Allows the KOTS nodes to access the etcd server
client API.**

TCP 10250 Any node All Allows the KOTS nodes to access the Kubelet API
server.**

UDP 8472 Any node All Allows KOTS (Flannel) to create a virtual network that
connects the services running inside the cluster.**

* Anywhere means anyone or anything that must consume the resources in the environment.

** Can be disabled in single node clusters.

2. User IDs — Verify that the following User IDs are available and unused on the application server.
• User ID 91 — Used by Tomcat to read and write to directories inside jamacore pods.
• User IDs 480–499 — Used by the various services.

3. Time sync setting — To ensure accurate time on the application server, set up a cron job to
sync the time on a routine schedule (for example, every day or hour). Use this command to set up
the cron job:
ntpdate pool.ntp.org

Preparing your database server (KOTS)
The following information is needed when connecting the application server to the database server.

Information Requirements

Type/vendor Database must be one of the following:

• MySQL 8 (recommended) — Install and configure MySQL [445]
• Microsoft SQL Server 2019 & 2022 — Install and configure Microsoft SQL Server [447]

Database hostname Example: jama.companydb.com

Listening ports The application server must be allowed to communicate remotely with the database server over the
listening ports.

Default ports are:

• MySQL = 3306
• Microsoft SQL Server = 1433

Database schema
name

The database owner must be able to create one:

• A new database schema
• Tables inside an existing database schema of the given name

The database name must follow these rules:

• Start with a letter (a–z)
• Contain any number of characters: a–z, 0–9 or an underscore ("_")
• Letters must be lowercase

Username jamauser

Password

Connections The database must be able to accept a minimum of 300 concurrent connections.

SAML schema user-
name

samluser

OAuth database user-
name

oauthuser

The username and password for SAML and OAuth must match what's entered in the Microsoft SQL
Server upgrade preparation script. See Install and configure Microsoft SQL Server [447] for more
details.

Install and configure MySQL (KOTS)
MySQL is the recommended database server. Follow these steps to install and configure it.
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Important considerations

• You must have full database admin permissions to the server hosting the MySQL database.
• For the Jama Connect installation to succeed, you must first create two additional database schemas.
• If you need to upgrade the MySQL, see "Install and configure MySQL (upgrading traditional to

KOTS)" in Jama Connect User Guide 9.6.x.

Recommended settings and sample

The following recommended settings require 8 GB of memory allocated to MySQL Server for a typical
installation and 16 GB for an enterprise installation.

These settings can be added to your my.cnf file (Linux) or my.ini file (Windows).

Property Typical installation Enterprise installation

max_allowed_packet 1 GB 1 GB

tmp_table_size 2 GB 2 GB

max_heap_table_size 2 GB 2 GB

table_open_cache 512 512

innodb_buffer_pool_size 2 GB 12 GB

innodb_log_file_size 256 MB 256 GB

innodb_log_buffer_size 12 MB 12 MB

innodb_thread_concurrency 16 16

max_connections 151 351

wait_timeout 259200 259200

Here is a sample text config file at an enterprise level. You must add the following values for your
environment:

bind-address=0.0.0.0
key_buffer_size=16M
max_allowed_packet=1G
thread_stack=192K
thread_cache_size=8
tmp_table_size=2G
max_heap_table_size=2G
table_open_cache=512
innodb_buffer_pool_size=12G
innodb_log_file_size=256M
innodb_log_buffer_size=12M
innodb_thread_concurrency=16
max_connections=351
wait_timeout=259200

To install and configure MySQL:

1. Make sure that the InnoDB engine is enabled.
2. Download and install a supported version of MySQL [440].
3. On the MySQL database server, create an empty Jama Connect schema / database that uses

UTF8:

CREATE DATABASE jama character set utf8mb4;

4. On the MySQL database server, create two additional database schemas and a user ("jamauser")
with the ability to access, create, and update tables within the database:

CREATE DATABASE saml;
CREATE DATABASE oauth;
CREATE USER 'jamauser'@'%' IDENTIFIED BY 'password';
CREATE USER 'oauthuser'@'%' IDENTIFIED BY 'password';
CREATE USER 'samluser'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON jama.* TO 'jamauser'@'%';
GRANT ALL PRIVILEGES ON oauth.* TO 'oauthuser'@'%';
GRANT ALL PRIVILEGES ON saml.* TO 'samluser'@'%';
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5. Create a database schema for Quartz to support horizontal scaling in KOTS:
CREATE DATABASE quartz;      
CREATE USER 'quartzuser'@'%' IDENTIFIED BY 'password';            
GRANT ALL PRIVILEGES ON quartz.* TO 'quartzuser'@'%'

6. Restart the database server.

Install and configure Microsoft SQL Server (KOTS)
If you are using Microsoft SQL Server for your database, follow these steps to install and configure it.

Important considerations

• You must have full database admin permissions to the server hosting the SQL Server database.
• If you need to upgrade the Microsoft SQL Server, see "Install and configure Microsoft SQL Server

(upgrading traditional to KOTS)" in Jama Connect User Guide 9.6.x.

Before installing Jama Connect 8.62.x

• Install Microsoft SQL Server 2016–2019 for the database server.
• From the Microsoft SQL administrator section, go to Server Configuration > Collation, then set the

Database Engine to SQL_Latin1_General_CI_AI.
• Create an empty Jama Connect database and two additional database schemas for the installation to

succeed.
• Jama Connect requires that the MSSQL COMPATIBILITY_LEVEL value is 130 or greater.

To confirm the current value:
SELECT compatibility_level FROM sys.databases WHERE name = <DATABASENAME>;

To modify the value:
ALTER DATABASE <DATABASENAME> SET COMPATIBILITY_LEVEL = 130;

For more information, see https://learn.microsoft.com/en-us/sql/t-sql/statements/alter-database-trans-
act-sql-compatibility-level?view=sql-server-ver16

Organizations using Microsoft SQL Server must enter database users in Replicated. Without these
entries, the installation will fail.

The new schema must be created for a successful installation. Otherwise, the system continues to
attempt to connect to the databases and produces log failures. After you create the database schemas,
you must restart Jama Connect.

For more information, go to Supported software, environments, and system requirements and select
your version of Jama Connect.

Follow these steps for a first-time installation of Jama Connect:

1. Connect to the SQL Server using a SQL management application (such as SQL Server Manage-
ment Studio).

2. Replace the following values in the installation script: <JAMA_LOGIN_Psswd>, <SAML_LOG-
IN_Psswd> & <OAUTH_LOGIN_Psswd>.

3. Copy and store the passwords you create here. You will need them later to configure the Admin
Console settings.

4. In a new query window, run this SQL query script:
-- Fresh Install Preparation SCRIPT
/*
Jama Connect Preparation Commands for a fresh install. It is required to run
 these command / script on the Microsoft SQL Server BEFORE running the Jama 
Connect 8.62.x install
for ON-PREM installation using Microsoft SQL Server 2016 - 2019
DATE: 05/10/2021
NOTES:
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This script assumes this is a new Installation of JAMA Connect. DO NOT RUN 
THIS SCRIPT ON AN EXISTING JAMA INSTALLATION.
The script will create a new empty JAMA database, add 2 new schemas (empty) to 
the Jama Database, 2 new DB Logins and Database users to support the Multi-
Auth functionality released in Jama Connect 8.62.0.

INSTRUCTIONS:
This script must be run prior to Jama installation or installation may fail to 
complete.
Modify the <JamaUser_LOGIN_Psswd>, <SAML_LOGIN_Psswd> & <OAUTH_LOGIN_Psswd> 
values in the script below before Execution. 
Passwords must be enclosed in single quotes.
*/

USE master;
CREATE LOGIN jamauser with password = 'password';
CREATE LOGIN samluser with password = 'password';
CREATE LOGIN oauthuser with password = 'password';
GO

USE master;
CREATE DATABASE jama;
GO
ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK IMMEDIATE
GO
ALTER DATABASE jama CONVERT TO CHARACTER SET latin1 [COLLATE = 'latin1_general_CI_AI'];
GO

USE jama;
EXEC ('CREATE SCHEMA oauth');
EXEC ('CREATE SCHEMA saml');
GO

USE jama;
CREATE USER jamauser for LOGIN jamauser;
CREATE USER samluser for LOGIN samluser with DEFAULT_SCHEMA=saml;
CREATE USER oauthuser for LOGIN oauthuser with DEFAULT_SCHEMA=oauth;
GO

EXEC sp_addrolemember N'db_owner', jamauser;
EXEC sp_addrolemember N'db_owner', samluser;
EXEC sp_addrolemember N'db_owner', oauthuser;
GO

5. Create a database schema for Quartz to support horizontal scaling in KOTS:
USE master;      
CREATE LOGIN quartzuser with password = 'password';      
GO             

USE jama;      
EXEC ('CREATE SCHEMA quartz');      
GO             

USE jama;      
CREATE USER quartzuser for LOGIN quartzuser with DEFAULT_SCHEMA=quartz;      
GO             

EXEC sp_addrolemember N'db_owner', quartzuser;            
GO

6. Confirm that these actions were successful:
• Script completed — Check the Query Execution results for errors.
• Users created — Run the following SQL script in a new query window.

USE jama
SELECT * from master.sys.sql_logins
SELECT * from Jama.sys.sysusers

The results include jamauser, samluser, and oauthuser in the "Name" column of the result
panes.

• Users granted the DB_owner role — Run the following SQL script in a new query window.
USE jama
SELECT DP1.name AS DatabaseRoleName,
isnull (DP2.name, 'No members') AS DatabaseUserName
FROM sys.database_role_members AS DRM
RIGHT OUTER JOIN sys.database_principals AS DP1
ON DRM.role_principal_id = DP1.principal_id
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LEFT OUTER JOIN sys.database_principals AS DP2
ON DRM.member_principal_id = DP2.principal_id
WHERE DP1.type = 'R'
ORDER BY DP1.name;

The results show that db_owner role is granted to jamauser, samluser, and oauthuser.
7. Keep the database from locking users' accounts while they are logging in or working in Jama

Connect (you must have db_owner permissions):
ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK IMMEDIATE;

8. Make sure the flag was successfully enabled:
SELECT is_read_committed_snapshot_on FROM sys.databases WHERE name='jama';

If the returned value is 1, the flag is on.

Configure custom memory settings for Elasticsearch (KOTS)
To prepare for installing Jama Connect, you must first update the system that hosts the application. The
update consists of configuring memory settings for Elasticsearch.

Requirements

• The memory settings must be configured on each server in the KOTS cluster for Elasticsearch
to run on these servers. If you use the remote Elasticsearch setting, the memory settings can be
applied only to servers that are dedicated to Elasticsearch.

• You must have admin permissions to configure the memory settings for Elasticsearch.

To configure memory settings:

1. As an admin, open the /etc/sysctl.conf file, add the following line to the file, then save the file.
vm.max_map_count=262144

2. Reload the sysctl.conf file:
sudo sysctl -p

3. To confirm, type this command:
sudo sysctl -a | grep max_map_count

The system responds with:
vm.max_map_count=262144

Installing the software (KOTS)
KOTS is an open-source application for Kubernetes clusters that streamlines the process to remotely
install, manage, and update Jama Connect, all from the KOTS Admin Console or command-line inter-
face (CLI).

IMPORTANT
KOTS and Jama Connect must be installed on a new cluster that is created during
installation and dedicated to KOTS.

Whether your organization is internet-enabled or requires an airgap installation, follow these instructions
to download, install, and configure the software you need for your Jama Connect instance.

The software includes:

• KOTS Admin Console (Replicated)
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• Jama Connect

Jama Software sends a Welcome email that includes your Jama Connect license file.

The installation process consists of these tasks:

• Install KOTS and Jama Connect (internet [450] or airgap [453])
• Provision your Jama Connect dataset [457]
• Create a Replicated Snapshot [458]

Depending on your environment, the process can also include these tasks:

• Configure KOTS to save tenant assets in Amazon EFS [466]
• Enable horizontal scaling [462]
• Configure dedicated Elasticsearch nodes [464]
• Configure Federated Authentication for KOTS Admin Console [470]

Install Jama Connect and KOTS (internet)
The installation script and the installation wizard guide you through the process of installing the KOTS-
required software and Jama Connect, then configuring the KOTS Admin Console.

The license file is included in the Welcome email you received from Jama Software.

1. Open the Welcome email from Jama Connect, then save the attached license file on your local
system.

2. Run the command on the application server provisioned for Jama Connect:
curl -sSL https://k8s.kurl.sh/jama-k8s-standardkots | sudo bash app-version-label=<version label>

IMPORTANT
If you are deploying an older version of Jama Connect, you must include the
app-version-label argument with the installation command (for example, 8.79.6,
9.0.4). If the argument isn't included, the latest available application version is
assumed.

3. After the command runs, save the KOTS admin URL, password, and other configuration options for
future reference. This is the only time these credentials appear, so make sure you save them.

4. In a supported browser, enter the URL for Kotsadm, which was generated when you installed
KOTS.

5. Log in to the KOTS Admin Console using the password you just saved.
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6. Select the appropriate option:
• Have key/certificate — Click Choose file under Private key and Certificate, navigate to the files

and select them, then click Upload & Continue.
• No key/certificate — Select Self-Signed Cert.

7. Upload the license file that you saved on your local system.

8. Configure the settings for each group, as needed. Scroll down to see each group of settings.
• Database Settings — Select your database type (MySQL or Microsoft SQL Server), then use

the information from Preparing your database server [445] to complete the settings.
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• Host Name — Enter the base URL for Jama Connect. Ensure this domain name is routable on
your network.

• TLS Key Pair Source — (Optional) If you have a custom key and certificate for the host
name, select Custom TLS Configuration. In the TLS Configuration section, upload the key and
certificate.

• Assets Size — Enter the estimated size of the assets that you are planning to store in Jama
Connect.

• Elasticsearch Settings > Volume Size — Enter the amount of disk space that each Elastic-
search node is allowed to use.

• Tenant Manager Settings — Enable this setting for optimal performance. Disable this setting if
background operations are required before you provision the tenant (for example, when reusing
traditional Replicated or using remote Elasticsearch).
The Tenant Manager provisions, restores, upgrades, and sets licenses during application startup.

9. (Optional) From the Config tab in the KOTS Admin Console, follow the steps to configure KOTS to
save tenant assets in the Amazon EFS [466].

10. Scroll to the bottom of the page and click Continue.
The system performs the preflight checks.

11. From the Preflight checks screen, click Continue to open the KOTS Admin Console.
The process can take up to an hour. When the system is available, the status changes to Ready.
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12. Log in to Jama Connect as root using the hostname configured for Jama Connect.
13. Important: Once Jama Connect is installed, use these instructions to provision a Jama Connect

dataset [457].

IMPORTANT
You must provision a Jama Connect dataset [457] before you allow your users access
to Jama Connect. If you need the link to the dataset, contact your Customer Success
Manager.

Install Jama Connect and KOTS (airgap)
The installation script and the installation wizard guide you through the process of installing the KOTS-
required software and Jama Connect, then configuring the KOTS Admin Console.

The following is included in the Welcome email you received from Jama Software:

• License file
• URL to the airgap-safe portal for downloading the Jama Connect application file
• A unique password to access the airgap-safe portal

To install Jama Connect and KOTS:

1. Open the Welcome email from Jama Connect and save the attached license file to your local
system.

2. Log in to the download portal, then download the KOTS Admin Console Bundle and Jama
Connect App Bundle to your local system.
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3. To download the Kubernetes Installer for your channel and install it, run the following command on
the application server provisioned for Jama Connect.
export REPLICATED_APP=jama-k8s
export REPLICATED_CHANNEL=standardkots

curl -LS https://k8s.kurl.sh/bundle/$REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz \
-o $REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz

tar -zxvf $REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz

cat install.sh | sudo bash -s airgap

If your application server doesn't have internet access, you can download the Kubernetes Installer
from the airgap-safe portal and upload it to the application server.

4. After the command runs (which might take several minutes), save the KOTS admin URL, pass-
word, and other configuration options for future reference. This is the only time these credentials
appear, so make sure you save them.

5. In a supported browser, enter the URL for Kotsadm, which was generated when you installed
KOTS.

6. Log in to the KOTS Admin Console using the password you just saved.

Jama Connect User Guide

454



7. Select the appropriate option:
• Have key/certificate — Select Choose file under Private key and Certificate, navigate to the

files and select them, then click Upload & Continue.
• No key/certificate — Select Use Self-Signed Cert.

8. Upload the license file saved on your local system.
9. Upload your jama-k8s airgap bundle, then click Continue.

The Config tab in the KOTS Admin Console opens, where you can configure Jama Connect.
10. Configure the settings for each group, as needed. Scroll down to see each group of settings.

• Database Settings — Select your database type, then use information from Preparing your
database server [445] to complete the settings.

• Host Name — Enter the host name for the cluster.
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• TLS Key Pair Source — (Optional) If you have a custom key and certificate for the host
name, select Custom TLS Configuration. In the TLS Configuration section, upload the key and
certificate.

• Assets Size — Enter the estimated size of the assets that you are planning to store in Jama
Connect.

• Elasticsearch Settings > Volume Size — Enter the amount of disk space that each Elastic-
search node is allowed to use.

11. (Optional) From the Config tab in the KOTS Admin Console, follow the steps to configure KOTS to
save tenant assets in the Amazon EFS [466].

12. Scroll to the bottom of the page and click Save config.
The system performs the preflight checks.

13. From the Preflight checks screen, click Continue to open the KOTS Admin Console.
14. In the Application section of the dashboard, wait until the status changes to Ready.
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15. Log in to Jama Connect as root using the hostname configured for Jama Connect.
16. Important: Once Jama Connect is installed, use these instructions to provision a Jama Connect

dataset [457].

IMPORTANT
You must provision a Jama Connect dataset [457] before you allow your users access
to Jama Connect. If you need the link to the dataset, contact your Customer Success
Manager.

Provision your Jama Connect dataset (KOTS)
Although optional, we strongly recommend that you provision an industry dataset. It ensures that your
organization has a sample framework as you begin to use Jama Connect.

If you don’t provision an industry dataset in your installation, you don’t see sample data or an industry
framework when you log in and begin using Jama Connect. Otherwise, your use of Jama Connect isn’t
impacted.

Your purchase confirmation email includes the .jama license file and a link to the industry dataset. If you
don't have this link, contact your Customer Success Manager.

Requirements

• Jama Connect must be installed before you provision your dataset. Otherwise, the provisioning will
fail.

• If the /data/restore directory doesn't exist, you must manually create it.

To provision your dataset:
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1. Using the link that was included in your purchase confirmation email, download the .jama license
file for the industry dataset.

2. Copy the .jama file to a host system with a node within the KOTS cluster.
3. On the host system, copy the .jama file to the /data/restore directory: 

kubectl cp -c core <path to .jama archive> default/core-0:/data/restore/

4. Configure the permissions for the file to be read by all users:

chmod 644 /data/restore/<filename>.jama

5. Delete the tenant properties file:

kubectl exec --tty -c core pods/core-0 -- rm /home/contour/tenant_properties/tenant.properties

6. Remove the resources:

kubectl delete sts/core
kubectl delete job/tenant-manager 
kubectl delete pod/hazelcast-0

7. Drop the current database and create a new database, SQL Server [447] or MySQL [445], with the
same name. If you decide to create a database with a new name, update the database settings in
the config tab of the KOTS Admin Console.

8. From the KOTS Admin Console in the Restore Jama Backup section, enter the path to the backup
file, then click Save.

9. Select Go to updated version, then click Deploy.

In the Application section of the dashboard, the status changes to Ready. The provisioning of your
dataset is complete.

Create a Replicated Snapshot (KOTS)
Taking a full snapshot creates a backup of the KOTS Admin Console and application data. It can be
used for full Disaster Recovery by restoring over the same instance or in a new cluster. Tenant assets
are included in the snapshot. Elasticsearch data is included by default.

A Replicated Snapshot can be taken while Jama Connect is running without interruption.

Requirements

• Replicated Snapshots must be enabled for your Replicated customer license.
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• KOTS Admin Console 1.79 and later.
• Replicated Snapshots don't include your database. You must use a proprietary backup/restore sys-

tem for your type of database, MySQL or SQL Server.

Important considerations

• When restoring from a snapshot in a new cluster, you must reinstall KOTS.
• Recommended — Include Elasticsearch data in snapshots to avoid having to reindex your data after

performing a restore. However, if your snapshot is not recent, we recommend reindexing your data.
• Replicated Snapshots don't support IAM authentication against EFS. Saving Replicated Snapshots in

EFS requires that you use the default file system policy to allow all nodes in the cluster to mount the
EFS.

To create a Replicated snapshot:

1. Capture the KOTS installer.
2. (Recommended) Include Elasticsearch data in snapshots: From the KOTS Admin Console under

the Elasticsearch Settings section, select Include Elasticsearch in Replicated Snapshots.
3. Airgap only — Capture the IP address of the private registry, which is the IP address value in the

Cluster-IP column:

kubectl get service/registry -n kurl

4. Configure the storage destination:
a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. From the Destination drop-down menu, select a storage destination for your snapshots.

• For AWS S3 — The IAM role assigned to the underlaying servers or the user associated
with the credentials (access and secret key) must have the Policy template attached.
Use the following template to create a policy, replacing the <arn-S3> parameter with ARN of
the S3 bucket. For example: arn:aws:s3:::jama-snapshots.

{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Effect": "Allow",
            "Action": [
                "s3:PutObject",
                "s3:GetObject",
                "s3:AbortMultipartUpload",
                "s3:DeleteObject",
                "s3:ListMultipartUploadParts"
            ],
            "Resource": "<arn-s3>/*"
        },
        {
            "Effect": "Allow",
            "Action": "s3:ListBucket",
            "Resource": "<arn-s3>"
        }
    ]
}

• For NFS — If using EFS as an NFS server, the Server field = the DNS name of the EFS
and the Path field = a directory inside the EFS, writable by the user:group 1001:1001.

c. Click Update storage settings to save your preferences.
5. Schedule Full Snapshots:

a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. Select Enable automatic scheduled snapshots, then click Update schedule.

6. Create a Full Snapshot (follow the steps provided by Replicated).

Capture KOTS Installer (KOTS)
When you restore a snapshot in a new cluster, the version of KOTS and its add-ons must match those
of the original cluster. Capture each KOTS Installer that was used to create or update your clusters.
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Why capture the kurl URL?
A hashed kurl URL (for example, https://kurl.sh/c601b1e) points to a website where you can get the
installation script or Kubernetes airgap bundle. Both require you to install the same version of KOTS
and add-ons. You must capture this kurl URL because the Replicated Channel URL that was used to
install KOTS always pulls the latest KOTS installer that has been promoted. If you rerun the installer
from the channel to enable an advanced option or you create a cluster to restore a snapshot, you might
accidentally update the KOTS version and it's add-ons.

NOTE
Replicated Vendor maintains a history of every installer that has been promoted to a
channel. If for any reason the kurl URL captured in this procedure doesn't work, it can
be provided to Jama Software and we might be able to find a similar installer in our
KOTS Installer History.

To capture the KOTS Installer:

1. Use the following installer resource information to create a .yaml file named installer.yaml:
cat <<EOT >> installer.yaml
apiVersion: cluster.kurl.sh/v1beta1
kind: Installer
metadata:
  name: latest
EOT

2. Get all installer resources in your cluster, and copy down the name of the installer that you used to
download it:
kubectl get installers

3. Gather the installer details, replacing the <installer-name> parameter:
kubectl get installers <installer-name> -o yaml

4. From the results, copy the spec section and paste it at the end of the installer.yaml file that you
created.
The file looks similar to this example of a KOTS Installer:
apiVersion: cluster.kurl.sh/v1beta1
kind: Installer
metadata:
  name: latest
spec:
  certManager:
    version: 1.9.1
  containerd:
    version: 1.6.24
  contour:
    version: 1.25.2
  ekco:
    version: 0.28.3
  flannel:
    version: 0.22.3
  kotsadm:
    applicationSlug: jama-k8s/standardkots
    version: 1.103.3
  kubernetes:
    version: 1.27.6
  metricsServer:
    version: 0.6.4
  minio:
    version: 2023-09-30T07-02-29Z
  openebs:
    isLocalPVEnabled: true
    localPVStorageClassName: local
    version: 3.9.0
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  prometheus:
    version: 0.68.0-51.0.0
  registry:
    version: 2.8.3
  velero:
    version: 1.11.1

5. Send the installer.yaml file to the create installer API from Replicated to receive a hashed URL:

curl -X POST -H "Content-Type: text/yaml" --data-binary "@installer.yaml" \
https://kurl.sh/installer && echo ""

6. Save the kurl URL that is displayed. It looks similar to https://kurl.sh/c601b1e.

Restore KOTS Admin Console and Jama Connect from a Replicated Snap-
shot (KOTS)
When you set up a new application server for Jama Connect, you can restore the KOTS Admin Console
settings that you saved in a Replicated Snapshot.

Snapshots include the registry images and data for Jama Connect.

Requirements
If restoring to a new cluster, it must match these specifications and settings of the cluster where the
backup was taken:

• Number of nodes
• Inbound and outbound traffic rules
• Virtual memory settings for Elasticsearch
• Connectivity to external services and resources (for example, AWS EFS, AWS S3)

To restore from a snapshot:

1. Configure servers for a new cluster:
a. After the servers for the cluster are provisioned, install KOTS on one node using the captured

KOTS Installer. You must pass the same flags to the installation script that were passed to the
original cluster.
• Restoring an online cluster — Run the appropriate installation script that was generated

from the captured KOTS installer.
• Restoring an airgap cluster — Download the appropriate KOTS installer bundle, replacing

<ip> with the IP address of the private registry from the original cluster:

cat install.sh | sudo bash -s airgap kurl-registry-ip=<ip>

b. When the installer has finished, run the command displayed on the screen so the other servers
join the cluster. If required, label the nodes dedicated for Elasticsearch.

c. Install any add-ons that were manually installed in the cluster. For example, the EFS Driver.
2. Configure the storage destination: From the KOTS CLI, point the cluster to the storage destination

where the Replicated Snapshots were saved.

AWS S3 See configure-aws-s3.

Azure See configure-azure.

GCP See configure-gcp.

S3-Other See configure-other-s3.

NFS See configure-nfs. If the cluster uses EFS or NFS, also see Configuring an NFS Storage Destination.

Note: If using EFS as an NFS server, Server field = DNS name of the EFS and Path field = a directory inside
the EFS, writable by the user:group 1001:1001.

3. Locate the snapshot and restore it: From the KOTS CLI, run a backup ls and full restore.

backup ls

This can take a few minutes. If the snapshots don’t appear, rerun this command.
4. If you changed the host name for Jama Connect:
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a. Update the Host Name field in the KOTS Admin Console and deploy the change.
b. From your browser, log in to Jama Connect and change your URL.

5. View scheduled jobs to verify that the list isn't empty.
6. If the Elasticsearch data wasn't included in the snapshot or if the snapshot isn't recent, reindex all

search items.
7. Verify that you can locate your assets.

Enable horizontal scaling (KOTS)
To avoid performance issues, you can enable horizontal scaling and add more instances of Jama
Connect. For each KOTS node, configure each Jama Connect instance to use more CPU and memory.

Important considerations

• This task is optional.

Requirements

• Jama Connect must already be installed and running before enabling this option.
• If restoring your environment from a backup, restore it without horizontal scaling enabled.
• To use horizontal scaling, you must provide a new database schema and user.
• Once you increase the number of replicas for each instance role, don’t decrease the number.

IMPORTANT
To avoid performance issues, use the recommended requirements [441] for horizontal
scaling, rather than minimum requirements.

To enable horizontal scaling:

1. On the KOTS Admin Console, go to the Config tab.
2. Scroll to the Core Jama Application Settings section, and select Enable Horizontal Scaling.

Extra fields are displayed for setting horizontal scaling.
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3. Specify the number of nodes that you want per role (default is 1). For recommended values, see
Application server requirements [441].
• Minimum number of ingress nodes
• Minimum number of job nodes
• Minimum number of report nodes

4. Adjust the maximum memory and CPU for each node. For recommended values, see Application
server requirements [441].

5. Scroll down to the Database Settings section and specify the Quartz database schema informa-
tion.

You can use the following scripts as a base to create the schema for Quartz in your database. They
were created assuming that you already set up your database [445].
In the scripts, change the schema name, username, or user password to match what you specified
in the KOTS Admin Console.

MySQL: CREATE DATABASE quartz;
CREATE USER 'quartzuser'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON quartz.* TO 'quartzuser'@'%';

Microsoft SQL: USE master;
CREATE LOGIN quartzuser with password = 'password';
GO 

USE jama;
EXEC ('CREATE SCHEMA quartz');
GO 

USE jama;
CREATE USER quartzuser for LOGIN quartzuser with DEFAULT_SCHEMA=quartz;
GO 

EXEC sp_addrolemember N'db_owner', quartzuser;
GO

6. Click Save config.
7. Deploy the new version: Select the Version history tab and click Deploy in the row of your newly

configured version.
8. Verify the status of your application: Select the Dashboard tab and make sure the status is Ready.
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9. (Optional) Verify that the new pods are ready:
kubectl get pods -o wide

Configure dedicated Elasticsearch nodes (KOTS)
Your primary KOTS server (node) is referred to as a KOTS stack.  To run Elasticsearch, you must
add one or more secondary nodes where Elasticsearch will run, and configure the nodes to run
Elasticsearch.

Important considerations

• This task is optional .
• You must have a functioning primary KOTS server and a secondary server where Replicated

KOTS has not yet been installed. For secondary node specifications, see Application server require-
ments [441].

• This task is appropriate for a new node and an existing node.
• Contact Support to enable remote Elasticsearch for your Replicated license.

To configure your nodes:

1. Make sure communication is established between primary (KOTS stack) and secondary (where
Elasticsearch will run) KOTS nodes. For more information, see Prepare your application serv-
er [444].

2. On the secondary node, configure the memory settings for Elasticsearch [449].
echo "vm.max_map_count=262144" | sudo tee -a /etc/sysctl.conf
sudo sysctl -p

3. On the Admin Console of the primary node below Version history, click Check for updates to
synch the changes made to your license.

4. Select the Config tab and, if you see the following message, click Edit the latest config.

5. Scroll down to the Elasticsearch Settings section and follow the steps shown to add a dedicated
Elasticsearch node.
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6. Set the number of Elasticsearch nodes to match the number of dedicated KOTS nodes that you
configured.

7. Adjust the maximum memory and CPU that each Elasticsearch node can use based on the
specifications of each dedicated KOTS node set up for Elasticsearch. For more information, see
Application server requirements [441] and Resource sizing for application server [441].
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8. Click Save config.
9. Deploy the changes.
10. When the Elasticsearch cluster is up and running, reindex all items.

Configure KOTS to save tenant assets in Amazon EFS
When you configure KOTS to save tenant assets in Amazon EFS, the tenant assets are saved if a
cluster fails. EFS provides automatic backups of the tenant assets and EFS is automatically scaled as
you add and remove assets.

IMPORTANT
Complete this task before Jama Connect is deployed. Otherwise, if you want to move
your assets to EFS, you must first back up tenant assets to a TAR in KOTS [469].

Requirements

• A KOTS cluster must be up and running.
• You must be able to create and modify these AWS resources: IAM roles, IAM policies, security

groups, EC2 instances, and EFS file systems.
• The cluster must have internet access to download the EFS driver and associated containerd images.
• Ports 9909 and 9809 must be available for the EFS driver to function successfully.
• Create a new EFS dedicated to your KOTS stack because each Persistent Volume requires an EFS

point, and access points are limited. Currently, each EFS can have a maximum of 120 access points.
A dedicated EFS allows you to future-proof the cluster. The steps are provided below.
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NOTE
Make sure you copy the Amazon Resource Names (ARNs) for the IAM role that is
assigned to the EC2 instances included in the KOTS cluster.

To save tenant assets:

1. Create a new security group for the EFS that allows inbound access for the TCP protocol on the
NFS port (2049) from all EC2 instances that are included in the KOTS cluster.
a. Select a security group that is assigned to the EC2 instances as the source.
b. Confirm that the EC2 instances included in the KOTS cluster have a security group that allows

outbound access on the NFS port to the security group created in the previous step.
2. Create the Amazon EFS file system:

a. From the Amazon EFS Management Console, select Create file system.
b. In the Create file system page, click Customize.
c. On the File systems setting page, configure the following, then click Next:

• Name — Enter a name that allows you to easily identify the EFS.
• Availability and Durability — Regional.
• Automatic backups — Enable automatic backups during off hours to avoid backup incon-

sistencies.
• Performance mode — General Purpose.
• Throughput mode — Bursting.
• Encryption — Enable encryption of data at rest.

d. On the Network access page, configure the following, then click Next:
• Virtual Private Cloud (VPC) — Enter the name of the VPC where the KOTS cluster is

running.
• Mount targets — Verify that a mount target is created per Availability Zone, then assign the

security group you created earlier.
e. Using the template below, generate a file system policy for the EFS, replacing the <arn-clus-

ter-role> parameter with the ARN of the cluster role. Then, attach the policy to the EFS.
{
  "Version": "2012-10-17",
  "Statement": [
    {
      "Effect": "Deny",
      "Principal": {
        "AWS": "*"
      },
      "Action": "*",
      "Condition": {
        "Bool": {
          "aws:SecureTransport": "false"
        }
      }
    },
    {
      "Effect": "Allow",
      "Principal": {
        "AWS": "<arn-cluster-role>"
      },
      "Action": [
        "elasticfilesystem:ClientRootAccess",
        "elasticfilesystem:ClientWrite",
        "elasticfilesystem:ClientMount"
      ]
    }
  ]
}

f. On the Review and create page that opens, review the file system configuration groups, then
select Create to create your file system and return to the File systems page.
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3. Edit the cluster role:
a. Generate the ARN of the newly created EFS, replacing <region>, <account-id>, and <file-

system-id> parameters:
arn:aws:elasticfilesystem:<region>:<account-id>:file-system/<file-system-id>

b. Generate the ARN for the access points, replacing <region> and <account-id> parameters:
arn:aws:elasticfilesystem:<region>:<account-id>:access-point/*

IMPORTANT
The template must be used as is, with the policy targeting all access points.

c. Use the following template to create a new IAM policy, replacing the <arn-efs> with the
ARN generated in step 3a and replacing the <arn-access-points> parameters with the ARN
generated in step 3b. Then, attach the new policy to the cluster role.
{
  "Version": "2012-10-17",
  "Statement": [
    {
      "Effect": "Allow",
      "Action": [
        "ec2:DescribeAvailabilityZones"
      ],
      "Resource": "*"
    },
    {
      "Effect": "Allow",
      "Action": [
        "elasticfilesystem:DescribeAccessPoints",
        "elasticfilesystem:DescribeFileSystems",
        "elasticfilesystem:DescribeMountTargets"
      ],
      "Resource": "<arn-efs>"
    },
    {
      "Effect": "Allow",
      "Action": "elasticfilesystem:CreateAccessPoint",
      "Resource": "<arn-efs>",
      "Condition": {
        "StringLike": {
          "aws:RequestTag/efs.csi.aws.com/cluster": "true"
        }
      }
    },
    {
      "Effect": "Allow",
      "Action": "elasticfilesystem:DeleteAccessPoint",
      "Resource": "<arn-access-points>",
      "Condition": {
        "StringEquals": {
          "aws:ResourceTag/efs.csi.aws.com/cluster": "true"
        }
      }
    }
  ]
}

4. Install the AWS EFS driver version 1.3.8 in your cluster:
kubectl apply -k "github.com/kubernetes-sigs/aws-efs-csi-driver/deploy/kubernetes/\
overlays/stable/?ref=tags/v1.3.8"

The following containerd images are downloaded to your EFS driver: amazon/aws-efs-csi-
driver, public.ecr.aws/eks-distro/kubernetes-csi/node-driver-registrar, public.ecr.aws/eks-distro/ku-
bernetes-csi/livenessprobe.

5. Verify that the driver was successfully installed:
kubectl get daemonset.apps/efs-csi-node csidriver/efs.csi.aws.com deployments/\
efs-csi-controller -n kube-system
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6. Enable the EFS Storage Class.
a. Log in to the KOTS Admin Console, select the Config tab, then scroll to the AWS Resources

section.
b. Select Enable EFS Storage Class.
c. In the AWS EFS Storage Class section under File System ID, enter the ID of the newly created

EFS.
7. Remove existing PVC and assets.

IMPORTANT
If Jama Connect has been deployed and you want to move your assets to EFS,
you must first back up tenant assets to a TAR in KOTS [469].

a. From the primary node, delete the StatefulSets of the core pods:
kubectl delete sts/core sts/core-ingress sts/core-reports sts/core-jobs

b. Delete the PVC that contains the assets, so that a new PVC can be created that points to EFS:
kubectl delete pvc/tenantfs

8. Save assets in EFS.
a. From the KOTS Admin Console, scroll to the Storage section, then in the Assets Storage

Class field, enter the name assigned to the EFS Storage Class.
b. Save your changes and deploy Jama Connect.
c. (Optional) Once the core pods are running, restore tenant assets from a TAR in KOTS [470].

9. Run this command:
kubectl get pvc/tenantfs

The output displays storage class as the name assigned to the EFS storage class.

Back up tenant assets to a TAR file in KOTS
If Jama Connect was deployed to KOTS and you want to move your assets to EFS, you must first back
up tenant assets to a Tape Archive file (TAR) in KOTS.

IMPORTANT
You must have a core-0 pod running, unless you have horizontal scaling enabled for
jamacore, then a core-ingress-0 pod is running.

To back up tenant assets:

1. Set an environment variable with your tenant name [474]:
export TENANT_NAME=jama

2. Copy the assets from a core pod to an assets local directory in the KOTS node. To reduce the
backup size, exclude the tempreports.
kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/attachments assets/attachments

kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/avatars assets/avatars
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kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/diagrams assets/diagrams

kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/equations assets/equations

kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/reports assets/reports

kubectl cp -c core default/core-0:/home/contour/tenant/${TENANT_NAME}/tempreports assets/tempreports 

3. List the contents of the assets directory inside the core pod:

kubectl exec --tty -c core pods/core-0 -- ls -la /home/contour/tenant/${TENANT_NAME}/ 

4. Verify that the commands from step 2 included every folder and file displayed.
5. Create a TAR file from the local directory:

tar -zcvf assets.tar.gz assets/

6. Copy the TAR file from the node to a different system and review its content:

scp <user>@<ip-another-machine>:<destination-path> assets.tar.gz

You now have a backup file that includes all the assets.

Restore tenant assets from TAR in KOTS
Follow this process when you have an existing cluster and want to save your tenant assets on an
external storage device.

Requirements

• In EFS, the tenant assets must be backed up in a TAR file [469] and restored once EFS has been
configured.

• Make sure that you use our process to create the TAR file; the restore commands expect a TAR file
with a certain structure.

To restore tenant assets:

1. Set an environment variable with your tenant name [474]:

export TENANT_NAME=jama

2. Copy the TAR file from its current location to a master node:

scp assets.tar.gz <user>@<ip-master-node>:~/assets.tar.gz

3. Log in to the master node and extract the TAR file:

tar -xvzf assets.tar.gz

4. Copy the assets to a core pod:

cd assets
kubectl cp -c core . default/core-0:/home/contour/tenant/${TENANT_NAME}/
kubectl exec --tty -c core pods/core-0 -- chmod -R 755 /home/contour
kubectl exec --tty -c core pods/core-0 -- chown -R tomcat:tomcat /home/contour

5. Verify that the assets were copied:

kubectl exec --tty -c core pods/core-0 -- ls -la /home/contour/tenant/${TENANT_NAME}/
kubectl exec --tty -c core pods/core-0 -- du -shc /home/contour/tenant/${TENANT_NAME}/

Configure Federated Authentication for KOTS Admin Console
By default, you can log in to the KOTS Admin Console with a shared password. To improve security,
configure this feature so that KOTS admin authentication is managed by your Identity Provider.

Requirements

• You must have the KOTS software installed.
• Identity Service must be enabled by Jama Software Support for your Replicated license.
• You must have an Identity Provider that is compatible with OpenID.
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Important considerations

• When you enable identity provider access to the KOTS Admin Console, shared password authentica-
tion is disabled. To reset authentication and reenable shared password authentication:

kubectl kots identity-service enable-shared-password --namespace default 

To configure Federated Authentication:

1. Update the KOTS license if Support enabled Identity Service for your license. (See "Update the
KOTS license" in Jama Connect 9.6.x User Guide).

2. Connect KOTS Admin Console to the Identity Provider.
a. Log in to the KOTS Admin Console, then select the Access tab.
b. In the Configure Identity Provider section:

• Verify that the Admin Console URL matches the URL for your KOTS Admin Console.
• Connector name — Enter a name that works best for your team.
• Issuer — Enter the Issuer or OpenID Configuration URL from your IdP application.
• Client ID and Client secret — Enter the Client ID and Client Secret from your IdP applica-

tion.
c. Select the Access tab to expand the Advanced options menu, complete the following, then

click Save provider settings:
• Scopes — Enter the OpenID, profile, and email.
• Skip email verification — Enable or disable this option based on your organization's needs

and IdP support.
• Remaining fields — Use the default values.

d. Click Logout.
You are redirected to a new login screen, where you can log in to Jama Connect. If a "Failed to
attempt login" error appears, see Troubleshooting KOTS errors [471].

After installing Jama Connect (KOTS)
Whether your environment is internet-enabled or airgap, after you install Jama Connect you can contin-
ue to set up your Jama Connect environment.

Follow any post installation instructions that apply to your organization.

The setup tasks to configure your environment include:

• Add Organization Admin account
• Modify organization details
• Configure email/collaboration settings
• Configure user authentication
• Create XML backups (optional)
• Update the license for KOTS environments (optional)

If you have further questions about Jama Connect installation and setup, visit the Jama Support
Community or contact Support.

Troubleshooting your installation (KOTS)
If you run into problems with your KOTS installation, here are some resources that might help.

• Connection errors [472]
• Federated Authentication errors [472]
• Backup and restore errors [473]
• Installation errors [472]
• Generate a support bundle [473]
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Installation errors (KOTS)
If any errors occurred during installation, use this table to fix the issues.

Error message Solution

This webpage is not
available

Verify that the "Host Name" section of the settings was correctly entered to point to the application
server.

Not private or Not se-
cure

This might happen if you chose a self-signed certificate or uploaded an invalid certificate. Verify that
you correctly entered the Custom TLS configuration in the Host Name window.

If this happens only for other users and not the system administrator, and the Admin Console is using
a self-signed certificate, you might have already told your web browser to "Proceed ... (unsafe)" or
"Add exception," while other users haven't. Verify that you selected the setting you want for Reuse
admin console TLS configuration in the Host Name window.

Problem: Cannot create
database jama: Con-
nections could not be
acquired from the un-
derlying database!

Most likely, something is wrong with your Admin Console database settings (for example, bind-ad-
dress, DBO credentials), or the connection between the application server and the database server.
Double-check your database settings in the Admin Console.

Connection errors (KOTS)
The KOTS installation process includes using the kubectl command line tool. If you see an error
message that relates to kubectl, use the workaround tips for the issue.

Error message Reason Workaround

The connection to the server local-
host:8080 was refused - did you
specify the right host or port? error:
error loading config file "/etc/kuber-
netes/admin.conf": open /etc/kuber-
netes/admin.conf: permission denied

kubectl might not be configured
properly for the user and/or node
where you tried to use it.

• Wrong user — Switch to the user that instal-
led KOTS or to root (sudo su -), then rerun
the kubectl command.

• Wrong node — Switch to the server where
KOTS was installed initially or to a primary
node, then rerun the kubectl command.

kubectl can be configured for other users and no-
des but it requires some research. See Embed-
ded Cluster: How to get kubectl working for other
users.

Waited for 1.184446141s due to cli-
ent-side throttling, not priority and
fairness

When using kubectl with Ubuntu
18.04, you might see this warn-
ing message.

Log in to Jama Connect as the root user (sudo
su -).

Application status is not accurate This error usually occurs when
the cluster is restarted or if
a cluster was restored from a
snapshot. The Application status
in the KOTS Admin Console
might differ from what you see in
the UI when using kubectl.

Redeploy the latest license version from the Ver-
sion history tab in the KOTS Admin Console.

Federated Authentication errors (KOTS)
The "Failed to attempt login" error can occur when you log in to the KOTS Admin Console from a
browser for the first time. This error can occur if you didn't specify the host name and chose to upload
custom certificates, or you specified the host name but it wasn't retained by the KOTS Admin Console.

To resolve this issue:

If provided, the KOTS Admin Console uses the custom certificate. If none was provided, a new self-
signed certificate is generated with the host name you specified. The KOTS Admin Console retains the
host name.

1. Review the KOTS Admin pod logs:
a. Check the name for your KOTS Admin pod:

kubectl get pods -o wide

b. Check the logs for your KOTS Admin pod:
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kubectl logs -f pods/<kotsadm-pod-name>

Review the logs and confirm that the following error appears:
{
  "level": "error",
  "ts": "2022-08-25T18:36:03Z",
  "msg": "failed to get kotsadm oidc provider: failed to query provider \"https://<your-kots-
admin-hostname>:8800/dex\": Get \"https://<your-kots-admin-hostname>:8800/dex/.well-known/openid-
configuration\": x509: certificate is valid for kotsadm, kotsadm.default, kotsadm.default.svc, 
kotsadm.default.svc.cluster, kotsadm.default.svc.cluster.local, not <your-kots-admin-hostname>"
}

2. Restore the ability to configure the TLS certificates:
kubectl -n default annotate secret kotsadm-tls acceptAnonymousUploads=1 --overwrite

3. Restart the kurl-proxy pod:
kubectl delete pod $(kubectl get pod | grep kurl-proxy | awk '{print $1}')

4. Open the KOTS Admin Console with this link: http://<your-kots-admin-hostname>8800/tls
5. Choose one:

• Select Skip & continue if you don't want to provide custom certificates.
• Upload the files and select Upload & continue if you want to provide custom certificates.

Backup and restore errors (KOTS)
Replicated has documented the following scenarios.

Error message Reason Workaround

Error executing hook When a cluster is restarted, some pods might be in a Shut-
down state, meaning they were likely replaced by new pods.

Delete the pods that are in
a Shutdown state:

kubectl delete pods/<pod-name>

Connect is not reach-
able after a restore
even when pods are
ready

If you restored a cluster on a new server with a different host
name than the original, and updated the Host Name field in the
KOTS Admin Console and deployed it, the httpproxy resource for
nginx might not have been updated.

Delete the httproxy resource for
nginx and redeploy it:

kubectl delete httpproxy/nginx

Generate a support bundle (KOTS)
To troubleshoot and diagnose problems with application deployments, you can generate a support
bundle to collect and analyze data from your environment.

Jama Support uploads the support bundle to the Replicated vendor portal to view and interpret the
analysis, and can open a support request ticket if needed. Severity 1 issues are resolved three times
faster when submitted with support bundles.

1. For internet environments, generate a support bundle from the CLI:
a. Log in to the KOTS Admin Console, then select the Troubleshoot tab.
b. Scroll down to the Analyze Jama Connect for support section, then click If you’d prefer to get

a command to manually generate a support bundle.
A cURL command appears.

c. Copy the command.
d. From the CLI, run the command to generate a support bundle.

2. For airgap environments, generate a support bundle from the CLI:
a. Log in to the KOTS Admin Console, then select the Troubleshoot tab.
b. Scroll down to the Analyze Jama Connect for support section, then click If you’d prefer to get

a command to manually generate a support bundle.
A cURL command appears.

c. Remove the following code from the cURL command:
curl https://krew.sh/support-bundle | bash

Your command looks like this:
kubectl support-bundle secret/default/kotsadm-jama-k8s-supportbundle --redactors=configmap/\
default/kotsadm-redact-spec/redact-spec,configmap/default/kotsadm-jama-k8s-redact-spec/redact-spec
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d. Copy the command.
e. From the CLI, run the command to generate a support bundle.

KOTS FAQ

Question Answer

What is my tenant
name?

Your tenant name is the text you entered as the database name from the Config tab in the KOTS
Admin Console.

How can I find the
name of a node?

Run this command, then check the Name column:

kubectl get nodes -o wide

How do I shut down
my cluster?

Ideally, your cluster is always up and running. If all nodes require maintenance, shut down and perform
maintenance on one node at a time. The KOTS installer deploys EKCO, which is a utility tool to
perform maintenance operations on the cluster.

Run this command to prepare the node for a reboot:

sudo /opt/ekco/shutdown.sh

When the process is finished, shut down the node.

Does Jama Connect
support NFS?

If running Jama Connect in AWS, you can configure the application to save your tenant assets in EFS,
or configure KOTS to save Replicated Snapshots to an NFS server.
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Upgrading Jama Connect (KOTS)

Upgrading Jama Connect to 8.79.6, 9.0.4, or 9.6.x requires that you first update the Jama Connect
KOTS platform. The updated KOTS platform optimizes how data is stored in Jama Connect and how
KOTS resources communicate with one another.

IMPORTANT
Upgrading your current environment involves significant maintenance downtime and
requires that you have a recovery plan in case you need to revert to the original envi-
ronment. Instead, we recommend that you install a new Jama Connect environment
(referred to as a clean installation), then copy elements of your current environment to
the new environment.

Here are the supported upgrade scenarios:

• (Recommended) Clean installation of Jama Connect KOTS platform — This recommended
scenario requires that you install a clean Jama Connect KOTS instance on a new application server,
then copy data assets from your current environment to the new environment. The new instance must
point to a restored backup of your database.

• In-place upgrade of Jama Connect KOTS platform — This scenario requires upgrading your
current environment in place, which involves significant maintenance downtime and requires that you
have a recovery plan in case you need to revert to the original version. You must run a pre-upgrade
script before running the Kubernetes (kURL) installer.

Recommended upgrade paths
Use this table to determine the best upgrade path for your organization.

If your Jama Connect instance is running this version... Upgrade to one of these versions...

8.79.x 8.79.6

9.0.4

9.6.x

9.0.x 9.0.4

9.6.x

Perform a clean installation of Jama Connect
Whether your environment is internet-enabled or airgapped, we recommend that you install a new Jama
Connect environment (referred to as a clean installation) to support new versions of the Jama Connect
application.

The process includes using a new application server and a database instance that was restored from
a backup of your current production instance. Once the new environment is up and running, you must
copy elements of your current environment to the new environment (move from one KOTS environment
to another KOTS environment).

To perform a clean installation:

1. Install the KOTS software [438].
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2. Provision your tenant in Jama Connect KOTS:
a. From the KOTS Admin Console, select the Config tab.
b. Configure the settings for each group, as needed. Scroll down to see each group of settings.

IMPORTANT
Use the settings from your current environment as a guide when configuring
the new settings.

Make sure that the current Host name, Database name, Username, and
Password are configured correctly in the KOTS Admin Console. When you
install KOTS in a new environment, you must point to the newly installed
database host or the deployment fails.

• Database Settings — Select your database type (MySQL or Microsoft SQL Server), then
use the information from Preparing your database server [445] to complete the settings.

• Host Name — Enter the base URL for Jama Connect. Ensure this domain name is routable
on your network.

• TLS Key Pair Source — (Optional) If you have a custom key and certificate for the host
name, select Custom TLS Configuration. In the TLS Configuration section, upload the key
and certificate.

• Assets Size — Enter the estimated size of the assets based on the current data assets size
of your environment and its projected growth.

• Elasticsearch Settings > Volume Size — Enter the amount of disk space that each Elastic-
search node is allowed to use.

c. Scroll down to Tenant Manager Settings and deselect the Enabled checkbox to disable it.
Disabling the tenant manager allows you to pause provisioning while copying data assets from
the existing KOTS environment to the new KOTS environment.

d. Scroll to the bottom of the page and click Save config.
The preflight checks run.

e. From the Preflight checks screen, click Deploy to deploy the Jama Connect application and
services.
When the system is available, the status in the KOTS Admin Console changes to Ready.
The deployment process can take at least an hour.

f. From the application server CLI, verify that the Kubernetes pods were successfully created:
kubectl get pods

The status of the pods change to ready and running.
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g. When the pods are ready and running, copy the data assets from the original instance to an
accessible location on the new application server.
To gather these items from the original instance:
i. In the terminal of the application server, use the kubectl tool to create a bash session

inside the core pod.
kubectl exec -it core-0 -- /bin/bash

ii. From the bash prompt, change your directory.
cd /home/contour/tenant/jama
tar -zcvf assets.tar.gz avatars/ attachments/ diagrams/ reports/ equations/ tempreports/

iii. Exit the core pod bash prompt and use the kubectl tool to copy the TAR file to the local
application server.
exit
kubectl cp core-0:/home/contour/tenant/jama/assets.tar.gz ./assets.tar.gz

iv. Copy assets.tar.gz to the new application server.
h. On the application server, set the tenant name for the environment (the tenant name, usually

jama, is the name of the Jama Connect database schema):
export TENANT_NAME=<tenant_name>

i. On the application server:
i. Copy and extract the previously preserved data assets into the running core pod and

change the ownership permissions:
kubectl cp -c core /tmp/contour/assets.tar.gz \
default/core-0:/home/contour/tenant/${TENANT_NAME}/ 

kubectl exec --tty -c core pods/core-0 -- tar -xvzf \ 
/home/contour/tenant/${TENANT_NAME}/assets.tar.gz -C /home/contour/tenant/${TENANT_NAME}/ 

kubectl exec --tty -c core pods/core-0 -- chmod -R 755 /home/contour

kubectl exec --tty -c core pods/core-0 -- chown -R tomcat:tomcat /home/contour

ii. Delete the core stateful set to recreate the core pod:
kubectl delete sts/core

j. From the KOTS Admin Console, select the Config tab, enable the Tenant Manager Settings
that were previously disabled, then click Save config.

k. Remove entries from the Jama Connect database tenantstate table to prepare for a new
deployment:
DELETE FROM tenantstate;

l. After the preflight checks run successfully, deploy the new version of Jama Connect:
i. From the KOTS Admin Console, click Deploy next to the newly saved version of Jama

Connect.
ii. When the deployment is complete and all pods are running, log in to Jama Connect as

root using the host name configured for Jama Connect.
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iii. If upgrading with new servers:
• Configure SAML authentication in the new Jama Connect KOTS environment (see

"Configure SAML authentication" in Jama Connect User Guide 9.6.x).
• Update the base URL before performing a full reindex (see "Change URL" in Jama

Connect User Guide 9.6.x).
m. Perform a full reindex in Jama Connect to complete the deployment (see "Reindex all search

items" in Jama Connect User Guide 9.6.x).

Perform an in-place upgrade of Jama Connect
Upgrading Jama Connect to 8.79.6, 9.0.4, or 9.6.x requires that you first update the Jama Connect
KOTS platform. The updated KOTS platform optimizes how data is stored in Jama Connect and how
KOTS resources communicate with one another.

IMPORTANT
Upgrading your current environment involves significant maintenance downtime and
requires that you have a recovery plan in case you need to revert to the original envi-
ronment. Instead, we recommend that you install a new Jama Connect environment
(referred to as a clean installation), then copy elements of your current environment to
the new environment. See Perform a clean installation [475].

To perform an in-place upgrade, see the instructions for your environment:

• Update the Jama Connect platform (internet) [478]
• Update the Jama Connect platform (airgap) [480]

Update the Jama Connect KOTS platform (internet)
Before you can deploy Jama Connect 8.79.6, 9.0.4, and 9.6.x, you must first update the Jama Connect
KOTS platform (referred to as an in-place upgrade).

This method requires that you first run a pre-upgrade script, then run the Kubernetes (kURL) installer.
After you run the script and installer, new versions of Jama Connect can be deployed from the KOTS
Admin Console.

Upgrade from this Jama Connect version... To one of these versions...

8.79.x 8.79.6

9.0.4

9.6.x

9.0.x 9.0.4

9.6.x

Important considerations

• Make sure that the file system on your primary node/application server has enough free space to
support a data migration of the assets associated with your Jama Connect instance. Measure the
disk space occupied by the var/lib/longhorn directory (du /var/lib/longhorn) and confirm that the disk
has twice that amount available.

• Expect downtime. Upgrade during off hours to minimize the impact.
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• The Kubernetes (kURL) installer is interactive and prompts you to confirm some of the steps. De-
pending on the number of remote nodes in your environment, expect this part of the upgrade process
to take at least two hours.

• If you have dedicated Elasticsearch nodes, you are prompted to run separate installer commands on
the secondary nodes during the installation.

• Recommended — Run the install commands inside a terminal multiplexer session to keep the ses-
sion active in the event that the connection is dropped or the terminal is closed.

• If your Jama Connect deployment fails with a HorizontalPodAutoscaler error, you must manually up-
date the Kubernetes secret associated with the deployed Helm release and redeploy Jama Connect.
See Troubleshoot PersistentVolumeAccessMode errors if Jama Connect deployment fails [483].

To update the Jama Connect KOTS platform:

1. Back up your Jama Connect instance.
2. Download prepare-for-longhorn-to-openebs-upgrade.sh from GitHub.
3. On the primary node, run the shell script downloaded in step 2 as a user with adequate privileges:

bash prepare-for-longhorn-to-openebs-upgrade.sh

4. Run the kURL installer:

IMPORTANT
The kURL installer is interactive and prompts you to continue several times
throughout the upgrade process. Kubernetes is upgraded incrementally in steps
from version 1.23.17 to 1.27.6 and requires you to confirm several of the steps
before proceeding to the next version.

a. From the command line on the primary node/application server, enter the following command
to initiate the installation:
curl -sSL https://kurl.sh/jama-k8s-standardkots | sudo bash -s 

b. Prepare your instance for the new Jama Connect release. This command deletes targeted
KOTS resources, which is required before deploying the new version of Jama Connect.
kubectl delete sts/activemq sts/core sts/diff sts/elasticsearch sts/hazelcast sts/oauth \
sts/saml sts/search sts/nginx sts/core-ingress sts/core-reports sts/core-jobs \
jobs/tenant-manager pvc/volume-oauth-0 pvc/volume-saml-0

5. Upgrade Jama Connect [479].

Upgrade Jama Connect with KOTS (internet)
When a new version of Jama Connect is available, you can apply and deploy it from the KOTS Admin
Console.

IMPORTANT
If you are upgrading Jama Connect 8.79.6 or 9.0.4 to 9.6.x, you must run this com-
mand on the application server CLI before deploying Jama Connect:

kubectl delete sts/saml sts/oauth pvc/volume-oauth-0 pvc/volume-saml-0

To upgrade Jama Connect with KOTS:

1. From the KOTS Admin Console, select the Version history tab, then click Check for update.
2. When the preflight checks are complete, find your Jama Connect upgrade version, then click

Deploy.
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The new version is tagged as Currently deployed version.

Update the Jama Connect KOTS platform (airgap)
Before you can deploy Jama Connect 8.79.6, 9.0.4, and 9.6.x, you must first update the Jama Connect
KOTS platform (referred to as an in-place upgrade).

This method requires that you first run a pre-upgrade script, then run the kURL installer. After you run
the script and installer, new versions of Jama Connect can be deployed from the KOTS Admin Console.

See also: Updating Embedded Clusters.

Upgrade from this Jama Connect version... To one of these versions...

8.79.x 8.79.6

9.0.4

9.6.x

9.0.x 9.0.4

9.6.x

Important considerations

• Make sure that the file system on your primary node/application server has enough free space to
support a data migration of the assets associated with your Jama Connect instance. Measure the
disk space occupied by the var/lib/longhorn directory (du /var/lib/longhorn) and confirm that the disk
has twice that amount available.

• Expect downtime. Upgrade during off hours to minimize the impact.
• The Kubernetes (kURL) installer is interactive and prompts you to confirm some of the steps. De-

pending on the number of remote nodes in your environment, expect this part of the upgrade process
to take at least two hours.

• If you have dedicated Elasticsearch nodes, you are prompted to run separate installer commands on
the secondary nodes during the installation.

• Recommended — Run the install commands inside a terminal multiplexer session to keep the ses-
sion active in the event that the connection is dropped or the terminal is closed.

• If your Jama Connect deployment fails with a HorizontalPodAutoscaler error, you must manually up-
date the Kubernetes secret associated with the deployed Helm release and redeploy Jama Connect.
See Troubleshoot PersistentVolumeAccessMode errors if Jama Connect deployment fails [483].

To update the Jama Connect KOTS platform:

1. Log in to the airgap portal, select Embedded Cluster, then download the Embedded Kuber-
netes Installer files to your local system.
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2. From an internet-enabled system, download prepare-for-longhorn-to-openebs-upgrade.sh from
GitHub.

3. On the primary node, run the shell script downloaded in step 2 as a user with adequate privileges:

bash prepare-for-longhorn-to-openebs-upgrade.sh

4. Extract (untar) the kURL installer:

tar -xzvf jama-k8-standardkots.tar.gz

The following contents are extracted: kurl directory, install.sh, join.sh, tasks.sh, and upgrade.sh
scripts.

5. Run the kURL script to ensure all required images are available:

sudo bash tasks.sh load-images

6. Run the kURL installer:

IMPORTANT
The kURL installer is interactive and prompts you to continue several times
throughout the upgrade process. Kubernetes is upgraded incrementally in steps
from version 1.23.17 to 1.27.6 and requires you to confirm several of the steps
before proceeding to the next version.

a. From the command line on the primary node/application server, enter the following command
to initiate the installation:

Jama Connect User Guide

481

https://github.com/JamaSoftware/kots-preflights/blob/main/v2/scripts/prepare-for-longhorn-to-openebs-upgrade.sh


sudo bash install.sh airgap 

b. When the installation is complete, prepare your instance for the new Jama Connect release.
This command deletes targeted KOTS resources, which is required before deploying the new
version of Jama Connect.
kubectl delete sts/activemq sts/core sts/diff sts/elasticsearch sts/hazelcast sts/oauth \
sts/saml sts/search sts/nginx sts/core-ingress sts/core-reports sts/core-jobs \
jobs/tenant-manager pvc/volume-oauth-0 pvc/volume-saml-0

7. Upgrade Jama Connect [482].

Upgrade Jama Connect with KOTS (airgap)
When a new version of Jama Connect is available, you can apply and deploy it from the KOTS Admin
Console.

IMPORTANT
If you are upgrading Jama Connect 8.79.6 or 9.0.4 to 9.6.x, you must run this com-
mand on the application server CLI before deploying Jama Connect:

kubectl delete sts/saml sts/oauth pvc/volume-oauth-0 pvc/volume-saml-0

To upgrade Jama Connect with KOTS:

1. From the air-gap safe portal, download the new jama-k8s airgap bundle for embedded clusters.
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2. From the KOTS Admin Console, select the Version history tab:
You must complete this step if the new airgap bundle hasn't been uploaded yet.
a. Click Upload new version.
b. Select the new airgap bundle.
A new version is created, and the system performs the preflight checks.

3. When the preflight checks are complete, click Deploy.

The new version is tagged as Currently deployed version.

Troubleshooting your upgrade (KOTS)
If you run into problems with your KOTS upgrade, here are some resources that might help.

• Troubleshoot HorizontalPodAutoscaler errors if Jama Connect deployment fails [483]
• Troubleshoot PersistentVolumeAccessMode errors if Jama Connect deployment fails [485]
• Troubleshoot kURL installer errors if node connectivity tests fail [486]

Troubleshoot HorizontalPodAutoscaler errors if Jama Connect deployment
fails
In previous versions of Jama Connect with Kubernetes 1.27.6, the HorizontalPodAutoscaler resources
for horizontal scaling were deprecated. If your Jama Connect deployment fails with the following error,
you must manually update the Kubernetes secret associated with the deployed Helm release and
redeploy Jama Connect.
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IMPORTANT
This process applies only to environments with horizontal scaling enabled.

To modify the Kubernetes Helm release secret:

1. Retrieve the name of the secret associated with the latest deployed Helm release:
kubectl get secret -l owner=helm,status=deployed,name=application | awk '{print $1}' | grep -v NAME

2. Use the secret to save the latest deployed release details to a file:
kubectl get secret <secret-name> -o yaml > release.yaml

3. Create a backup of the file you created:
cp release.yaml release.bak

4. Decode and generate output of the release object (JSON) found in the file you created:
cat release.yaml | grep -oP '(?<=release: ).*' | base64 -d | base64 -d | gzip -d > release.data.decoded

5. Using an editor tool, edit the release object data by changing all occurrences that reference the
deprecated API version (autoscaling/v2beta1) with the new value (autoscaling/v2) found in the
manifest field.

6. Encode the modified release object:
cat release.data.decoded | gzip | base64 | base64

7. If the output contains line breaks, you must remove them before you can continue.
8. Using an editor tool, replace the JSON property value “data.release” in release.yaml with the newly

encoded release object value you just created.
9. Apply the release file:

kubectl apply -f release.yaml

10. Deploy Jama Connect.
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Troubleshoot PersistentVolumeAccessMode errors if Jama Connect deploy-
ment fails
If you configured Jama Connect to use a third-party storage class to save assets, you might get the
following deployment error.

To modify Assets PVC Access Mode:

1. From the Config tab in the KOTS Admin Console, set the Assets PVC Access Mode to ReadWri-
teMany.

2. Deploy Jama Connect.
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Troubleshoot kURL installer errors if node connectivity tests fail
When the kURL installer runs, internal tests confirm that all nodes can communicate with each other. If
these tests fail, the Linux "fs.inotify.max_user_instances" host setting must be updated.

The Linux "fs.inotify.max_user_instances" is a host setting that defines user limits on the number of
available inotify resources on the application server.

If the connectivity tests fail, these error messages are displayed:

For more information, see How to increase the inotify.max_user_watches and inotify.max_user instan-
ces syssctls on a Linux host.

To update the Linux host setting:

1. Check the current inotify user instance limit:
cat /proc/sys/fs/inotify/max_user_instances

2. To update the limits temporarily (the value is set to 65536 in this example):
sudo sysctl fs.inotify.max_user_instances=65536
sudo sysctl -p

3. To apply the changes permanently, add fs.inotify.max_user_instances=65536 to the file /etc/
sysctl.conf.
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Administration

Jama Connect administrators have special roles in working with your organization's content.

A role is a set of permissions granted to a user so that they can perform particular functions.

• System administrators [489] set up and install Jama Connect. They are able to access the server
settings and log in as the root user. Jama Connect manages system administration for hosted
customers. For self-hosted customers, this role holds the initial license and can't be assigned.

• Organization administrators [549] have the highest level of permissions in Jama Connect and can
configure settings for the organization. All Jama Software customers have at least one organization
administrator, and there might be multiple within a single organization. They must have a creator
license.

• Project administrators [643] have the necessary permissions to manage many aspects of a project
that those with create/edit permissions can't. They must have a creator license.

• Review administrators [192] have the necessary permissions to manage reviews. They must have a
creator or reviewer license.

• Reuse administrators [322] have the necessary permissions to create advanced reuse and synchroni-
zation rules. They must have a creator license.

• Process administrators [593] have the necessary permissions to configure content and connections in
Jama Connect. They must have a creator license.

• User administrators [573] have the necessary permissions to manage licenses, users, and groups.
They must have a creator license.

• Report administrators [433] have the necessary permissions to upload and manage reports and
exports. They must have a creator license.

Authentication methods
Jama Connect supports a wide range of authentication methods to keep your data safe and secure by
authenticating users. The default method, Basic authentication, verifies users with the login data that is
stored in the Jama Connect database.
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Supported combinations for self-hosted and cloud

• SAML for SSO and OAuth for REST
• Multi-mode for user authentication and OAuth for REST

For information about using the Jama Connect REST API with OAuth, see Set API credentials [40].

Supported third-party authentication methods

• SAML [516] — Open standard for transferring identity data between two parties: an identity provider
(IdP) and a service provider (SP).
Electronic signatures are enabled by default, but can be disabled by a system admin.
To set up SAML, your company must meet these requirements:
• Have a SAML 2.0-compliant Identity Provider (IdP).
• Identify a technical person, often an IT administrator, who can provide the URL of the Identity

Provider. Name this person before engaging with Jama Software and, for testing purposes, provide
them access to Jama Connect.

• If you're on a version of Jama Connect earlier than 8.62, you must follow instructions for that
release instead of the instructions here. Contact Support for help accessing the correct instructions
and with the process.

• LDAP [521] — Self-hosted option. Centralizes the management of user accounts. Jama Connect
includes a built-in integration of LDAP and Microsoft Active Directory.

• Crowd [526] — Self-hosted option from Atlassian. Manages users and groups within a single a
system. Jama Connect accepts user details from Crowd, then syncs them with authentication data in
the application.

Internal authentication methods

• Basic [515] — The default authentication for Jama Connect. Basic authentication uses a username
and password that’s stored in the Jama Connect application database.

• Basic + IdP [518] — The combination of Basic and SAML creates multi-mode authentication,
so you can separate your internal users from your external partners, vendors, and contractors.
Multi-mode authentication provides access for external users so they can be part of the requirement,
approval, and tracking process in Jama Connect.

NOTE
To use multi-mode authentication [518], you must be running Jama Connect 8.62 or
later.

As a self-hosted user, you can update or change the authentication type for an organization. To do this,
log in as root user and select System Properties > Authentication Properties.

SCIM provisioning for user management
System for Cross-domain Identify Management (SCIM) is a standard for automating the exchange of
user identity information between identity domains or IT systems. (source)

SCIM provides a predefined schema for common user attributes like name, username, first name,
last name, and email address. Attributes for organization-level groups are included to create and
delete groups and manage group membership. This schema allows your organization to automatically
provision users into your Jama Connect environment directly from your identity provider (IdP). It also
helps you manage users within the application.

New user creation is a one-way synchronization with SCIM from your IdP to Jama Connect. Adding a
new user in Jama Connect won't create a new user in your IdP.
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Supported identity providers
Jama Connect currently supports SCIM provisioning with the following IdPs:

• Okta Custom Application
• Microsoft Azure AD

For more information, see Jama Connect SCIM configuration with Okta.

Configure SCIM provisioning
Self-hosted customers — Contact Support to assist with enablement and ensure successful imple-
mentation.

NOTE
Before enabling SCIM provisioning, some data sanitization is required.

REST API
Jama Software REST API is an application program interface to assist developers in a clean, straight-
forward integration with the application.

A system administrator can enable REST API in system properties [512].

Get more information about REST API, features and documentation.

Supported image extensions and attachment types
Jama Connect only allows attaching file types that exist in the Allow List, which provides improved
security and prevents uploading harmful file types that aren’t blocked.

To prevent uploading file types that might be harmful, Jama Connect filters the file types that you can
upload as an attachment.

Uses this method to filter attachment types... Supported version

Allow List Cloud, Jama Connect 2015.2 and later

Block List Jama Connect 2015.1 and earlier

Supported Jama Connect attachment types
We collected this list based on the usage pattern of our current customers. Each type has been
screened for potential security risks.

APK, AVI, BMP, CSV, DOC, DOCM, DOCX, DOT, DOTX, DWG, GIF, GZ, JAMA, JPEG, JPG, MD,
MOV, MP3, MP4, MPEG, ODG, ODP, ODS, ODT, PAGES, PDF, PGP, PNG, PPT, PTM, PPTX, RAR,
RTF, TGZ, TIF, TIFF, TRA, TXT, VCS, VSD, VSDX, VSS, WAR, WAV, WMA, WMV, WPS, XCF, XLS,
XLSB, XLSM, XLSX, XLT, XPS, ZIP, ZIPX

System administrator (KOTS)
System administrators are in charge of the following tasks: 

• Logging in to the application server operating system and Jama Connect as root user
• Installing, updating, and maintaining the Jama Connect platform
• Setting up the database and application servers
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• Installing the admin console and Jama Connect
• Configure settings such as authentication and mail servers
• Regular maintenance such as updates and uploading custom reports

Ideally a system administrator has expertise in these areas of administration:

• Database
System administrators set up and administer the database including database sizing, resource alloca-
tion, recommended backups, and availability of the database engine.

• Linux
Jama Connect must be installed on a Linux based system. System administrators need to use
Command Line Interface (CLI) for basic navigation, file manipulation, permissions, and network
configuration when they are installing, upgrading, allocating resources, and maintaining availability
and security of the server. 

• Directory server
If you're not using Jama Connect native authentication, system administrators must perform setup
and administration or your organization's supported directory server [515].

• Mail server
If you're using these functions in Jama Connect, system administrators perform setup and administra-
tion of your organization's mail server.

System administration is necessary for customers who are self-hosting Jama Connect. For cloud cus-
tomers, Jama Software manages system administration. If you're interested in an implementation that
doesn't require system administration at your organization, contact your sales representative regarding
our cloud solution.

Configuring the Admin Console settings
Jama Connect uses Replicated KOTS technology to deliver all microservices to self-hosted customers.
Replicated software is a container orchestration tool that provides the interface, Admin Console, for
Jama Connect.

Replicated and Jama Connect are hosted on the same application server, running on different ports.

The Admin Console stores settings, such as SSL certificates and database connection information, that
Jama Connect uses to start and run correctly. Some of its functions include:

• Manage the run state of Jama Connect
• Perform upgrades
• Synchronize license renewals

Many of the settings for the Admin Console are configured during installation. However, you can make
changes to the settings whenever you need.

Application server overview
Your application server hosts the Jama Connect application, Kubernetes pods and accompanying
stateful sets, and the Admin Console (Replicated software). It also stores data such as attachments,
images, reports, and a micro-service cache.

Docker containers — A standalone executable package of software that includes code, runtime,
system tools, system libraries, and settings. See https://www.docker.com/resources/what-container for
details.

Replicated KOTS — A Kubernetes Off-The-Shelf (KOTS) platform for easily deploying cloud native ap-
plications inside customers' environments to provide greater security and control. The Admin Console
is the user interface for installing the Jama Connect application. See https://www.replicated.com/ for
details.
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• Jama Connect users access Jama Connect by browsing to the instance URL (https://jamainstan-
ceurl.customer.com/).

• System administrators access the Admin Console by browsing to the same instance URL, but on port
8800 (https://jamainstanceurl.customer.com:8800/).

• Replicated updates Jama Connect and the license via API calls for internet-enabled environments.
Our airgap option removes the need for remote API calls.

• Any content added to your Jama Connect instance is stored in the database. Uploaded artifacts are
saved inside a Kubernetes volume. To extract them, you must run kubectl commands.

Create a Replicated Snapshot (KOTS)
Taking a full snapshot creates a backup of the KOTS Admin Console and application data. It can be
used for full Disaster Recovery by restoring over the same instance or in a new cluster. Tenant assets
are included in the snapshot. Elasticsearch data is included by default.

A Replicated Snapshot can be taken while Jama Connect is running without interruption.

Requirements

• Replicated Snapshots must be enabled for your Replicated customer license.
• KOTS Admin Console 1.79 and later.
• Replicated Snapshots don't include your database. You must use a proprietary backup/restore sys-

tem for your type of database, MySQL or SQL Server.

Important considerations

• When restoring from a snapshot in a new cluster, you must reinstall KOTS.
• Recommended — Include Elasticsearch data in snapshots to avoid having to reindex your data after

performing a restore. However, if your snapshot is not recent, we recommend reindexing your data.
• Replicated Snapshots don't support IAM authentication against EFS. Saving Replicated Snapshots in

EFS requires that you use the default file system policy to allow all nodes in the cluster to mount the
EFS.

To create a Replicated snapshot:

1. Capture the KOTS installer.
2. (Recommended) Include Elasticsearch data in snapshots: From the KOTS Admin Console under

the Elasticsearch Settings section, select Include Elasticsearch in Replicated Snapshots.
3. Airgap only — Capture the IP address of the private registry, which is the IP address value in the

Cluster-IP column:
kubectl get service/registry -n kurl

4. Configure the storage destination:
a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. From the Destination drop-down menu, select a storage destination for your snapshots.

• For AWS S3 — The IAM role assigned to the underlaying servers or the user associated
with the credentials (access and secret key) must have the Policy template attached.
Use the following template to create a policy, replacing the <arn-S3> parameter with ARN of
the S3 bucket. For example: arn:aws:s3:::jama-snapshots.
{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Effect": "Allow",
            "Action": [
                "s3:PutObject",
                "s3:GetObject",
                "s3:AbortMultipartUpload",
                "s3:DeleteObject",
                "s3:ListMultipartUploadParts"
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            ],
            "Resource": "<arn-s3>/*"
        },
        {
            "Effect": "Allow",
            "Action": "s3:ListBucket",
            "Resource": "<arn-s3>"
        }
    ]
}

• For NFS — If using EFS as an NFS server, the Server field = the DNS name of the EFS
and the Path field = a directory inside the EFS, writable by the user:group 1001:1001.

c. Click Update storage settings to save your preferences.
5. Schedule Full Snapshots:

a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. Select Enable automatic scheduled snapshots, then click Update schedule.

6. Create a Full Snapshot (follow the steps provided by Replicated).

Restore KOTS Admin Console and Jama Connect from a Replicated Snap-
shot (KOTS)
When you set up a new application server for Jama Connect, you can restore the KOTS Admin Console
settings that you saved in a Replicated Snapshot.

Snapshots include the registry images and data for Jama Connect.

Requirements
If restoring to a new cluster, it must match these specifications and settings of the cluster where the
backup was taken:

• Number of nodes
• Inbound and outbound traffic rules
• Virtual memory settings for Elasticsearch
• Connectivity to external services and resources (for example, AWS EFS, AWS S3)

To restore from a snapshot:

1. Configure servers for a new cluster:
a. After the servers for the cluster are provisioned, install KOTS on one node using the captured

KOTS Installer. You must pass the same flags to the installation script that were passed to the
original cluster.
• Restoring an online cluster — Run the appropriate installation script that was generated

from the captured KOTS installer.
• Restoring an airgap cluster — Download the appropriate KOTS installer bundle, replacing

<ip> with the IP address of the private registry from the original cluster:

cat install.sh | sudo bash -s airgap kurl-registry-ip=<ip>

b. When the installer has finished, run the command displayed on the screen so the other servers
join the cluster. If required, label the nodes dedicated for Elasticsearch.

c. Install any add-ons that were manually installed in the cluster. For example, the EFS Driver.
2. Configure the storage destination: From the KOTS CLI, point the cluster to the storage destination

where the Replicated Snapshots were saved.

AWS S3 See configure-aws-s3.

Azure See configure-azure.

GCP See configure-gcp.

S3-Other See configure-other-s3.
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NFS See configure-nfs. If the cluster uses EFS or NFS, also see Configuring an NFS Storage Destination.

Note: If using EFS as an NFS server, Server field = DNS name of the EFS and Path field = a directory inside
the EFS, writable by the user:group 1001:1001.

3. Locate the snapshot and restore it: From the KOTS CLI, run a backup ls and full restore.
backup ls

This can take a few minutes. If the snapshots don’t appear, rerun this command.
4. If you changed the host name for Jama Connect:

a. Update the Host Name field in the KOTS Admin Console and deploy the change.
b. From your browser, log in to Jama Connect and change your URL [540].

5. View scheduled jobs [542] to verify that the list isn't empty.
6. If the Elasticsearch data wasn't included in the snapshot or if the snapshot isn't recent, reindex all

search items [543].
7. Verify that you can locate your assets.

Configure database settings
Database settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll to the Database Settings section of the page.

3. Select the type of database you're using, MySQL or Microsoft SQL, then complete or change the
database settings as needed.

4. (Optional) If you need to connect to your database through an SSL-encrypted connection, provide
additional connection string parameters. These parameters specify key/value pairs in the format
appropriate to your database.
• MySQL

useSSL=true&requireSSL=true

• SQL Server
ssl=require;appName=jama;bufferMinPackets
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More options are available for MySQL and SQL Server

5. Scroll to the bottom of the page and click Save config. A message confirms that your settings were
saved.

Configure web server settings
Web server settings can be configured as part of your initial installation of Jama Connect or any time
you need to make changes.

The web server configuration allows the use of SSL (TLS) or plain text connections.

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Web Server section of the page.
3. Enter the context path for Jama Connect, for example, https://<host_name>/. Don't use this config-

uration unless you need to specify a sub-path or sub-directory.
4. (Optional) Enter the context path.
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5. (Optional) Set the TLS and plain text port as needed.
6. Scroll to the bottom of the page and click Save config. A message confirms that your settings were

saved.

Configure host name
Your Host Name settings can be configured as part of your initial installation of Jama Connect or any
time you need to make changes.

If possible, choose a host name that's meaningful to users. Be sure the domain name matches your
TLS certificate. 

If you need to change this host name, you must also change the base URL [540]. 

To configure the host name:

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Host Name section of the page.

3. Enter or change the host name.
4. (Recommended) Select Reuse Admin Console TLS Configuration to use the same certificate

configured in the KOTS Admin Console.
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5. Scroll to the bottom of the page and click Save config. A message confirms that your settings were
saved.

Bypass browser TLS warning
A Transport Layer Security (TLS) or Secure Sockets Layer (SSL) certificate is required to establish a
link between the Admin Console (Replicated) and your browser.

When configuring the KOTS Admin Console for the first time, you see a TLS warning with an option to
bypass it with a self-signed certificate. If you have a trusted certificate, you can configure the certificate
at any time [497]. If you continue with the self-signed certificate, you see a warning every time you
access the Admin Console.

You can upload a TLS certificate and provide a private key if you have one. Private keys can't be
password-protected. The key and primary certificate must be in PEM format, that's a base64 encoded
x509 certificate.

To bypass browser TLS warning:

1. Open the KOTS Admin Console, then select Continue to setup.

2. Choose one:
• To upload now — Select Choose private key and Choose SSL certificate, then select Upload

& continue.
• To upload later — Select Choose SSL certificate.
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The KOTS Admin Console login page opens.

Configure TLS certificate
The settings for the TLS certificate can be configured as part of your initial installation of Jama Connect
or any time you need to make changes.
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You can provide custom private key and TLS certificates to secure the application, or you can reuse the
Admin Console certificate. You can also update your certificate [538] if it expires. 

The certificate ensures that Jama Connect trusts the issuer.

To configure the TLS certificate:

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Host Name section of the page.

3. Select Custom TLS Configuration to open the TLS Configuration section.
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4. To link Jama Connect to a service protected by a certificate (self-signed or issued by a local
authority):
• Private Key — Click Browse files for Private Key and select your private key.
• Certificate — Click Upload a file and select your self-signed certificate.

5. Scroll down to the Trusted Certificates section, and select Use trusted certificate file to upload
a PEM-formatted public certificate or multiples that are concatenated into a single file. These
certificates are added to the default Java trust store. You might need this functionality to connect
to your MySQL, SQL Server, LDAP, Crowd, IMAP, SMTP, or other internal servers from Jama
Connect.

Jama Connect User Guide

499



6. Scroll down to the bottom of the page and click Save config. A message confirms that your
settings were saved.

Configure memory settings
Memory settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

Use the advanced memory settings to change the memory allocation of containers that are running
Java processes.

NOTE
When changing memory settings, make sure you don't over-allocate the total memory
of the application server. Monitor usage [535] and make sure to leave enough memo-
ry for system processes to run smoothly. For information, see "Resource sizing for your
application server."

To configure memory settings:

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Core Jama Application Settings section of the page.

3. Select Show Memory and CPU Settings.
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4. Enter the default values. If you have performance issues, contact Support for help configuring
these values.

5. Scroll to the bottom of the page and click Save config. A message confirms that your settings were
saved.

Configure advanced startup settings
Startup settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

Enable Java Management Extensions (JMX) and set additional Java Virtual Machine JVM options
(JAVA_OPTS) for the following containers that are running Java processes:

• The jamacore application
• Search service
• Elasticsearch

IMPORTANT
Each of these containers already adds a number of their own JVM options that might
clash with additional JVM options configured here.
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Use JMX support in a secure environment, because JMX ports have no authentication on the JMX ports
when JMX is enabled.

To configure advanced startup settings:

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Startup Settings section of the page, and select Show advanced startup

settings.

3. Select Enable JMX remote for core Jama application.
4. Enter the JMX remote port number for the core Jama application.

Don't overlap JMX ports between containers and don't overlap other ports that are already in use
on the application server.

5. (Optional) Enter additional Java JVM options for Jama core, search service, and Elasticsearch.
6. Enter a Java RMI server hostname.

A single Java RMI server hostname can be given that works across all containers that have JMX
enabled. The host IP address is used by default. However, if the host IP address isn't accessible by
the JMX client for the configured JMX ports, the public hostname or the public host IP is set here. If
an SSH tunnel is used, set the hostname to "localhost."

7. (Optional) In the Add services configuration field, add services configuration specific to Jama
Connect, such as throttling.
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8. Scroll to the bottom of the page and click Save config. A message confirms that your settings were
saved.

TIP
Garbage collection logging (GC logging) is automatically enabled for containers that
are running Java processes. GC log files are available alongside other log files for the
respective container [543]. When you restart Jama Connect, previous GC log files are
packaged as a ZIP file. Typically, the default GC logging configuration is sufficient, but
it's possible to override GC logging parameters through the Additional JVM options
for Jama core field in Admin Console advanced startup settings.

Configure Search Service Settings
Search service settings can be configured as part of your initial installation of Jama Connect or any time
you need to make changes.

Configure index settings for Elasticsearch. Making changes to these settings requires re-indexing.

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the Search Service Settings section of the page.

3. Enter the default values.
4. Scroll to the bottom of the page and click Save config. A message confirms that your settings were

saved.
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Set a custom location for the MathType Equations Editor
Settings for the MathType Equations Editor can be configured as part of your initial installation of Jama
Connect or any time you need to make changes.

NOTE
The MathType Equations Editor requires a separate license. After your organization
has purchased the license, and the system administrator sets up a location for the
editor, users can access the editor in the Rich Text Editor [96] in Jama Connect.

Airgap or self-hosted instances of Jama Connect can add math and chemical equation options to the
rich text editor without making calls to an external server.

Before enabling the MathType Equations Editor, you must:

• Designate a server inside your environment that can listen for MathType calls and responses. Check
for the latest supported version on the Community.

• Acquire a MathType license from Jama Software.

To configure settings for MathType Editor:

1. In the header of the KOTS Admin Console, select Application > Config to open the settings page.
2. Scroll down to the WIRIS Connection Settings section of the page.

3. Select Use custom WIRIS connection to override default settings for communication with the
WIRIS cloud servers.
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4. Enter the following information for your designated MathType server:
• WIRIS Host (Required) — Enter the hostname of your MathType server. This must be accessible

from both the Jama Connect application server and the user's browser. Don't include the port or
protocol.

• WIRIS Path — Enter the context path followed by "render." Depending on how your server is set
up, it might look like this:

/editor/render

• WIRIS Port — The defaults are 80 for http and 443 for https. You can override these values by
entering a different port number.

• WIRIS Protocol — This is https or http. If you use https to link to Jama Connect, you must also
use https for WIRIS.

NOTE
Additional settings for proxy are available but haven't been fully tested. You
can use these settings if your Jama Connect instance needs to use a proxy to
connect to the MathType server. However, these settings don't change how your
browser connects to the MathType server.

5. Scroll to the bottom of the page and click Save config. A message confirms that your settings were
saved.

Setting up Jama Connect
Once you finish installing Jama Connect, continue with a few tasks for the initial setup of the applica-
tion.

When logged in as root, you can access the System Administration page. From there you can complete
the tasks for setting up and maintaining Jama Connect.
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Administrator tasks
System admins complete basic setup and maintenance tasks on the System Administration
page. Some of these tasks can also be completed by an organization admin.

Task System admin Organization admin

Modify organization details [511] X

Configure general properties [512] X

Configure authentication properties [515] X

Manage users [573] X X

Manage permissions [668] X X

Manage reports [414] X

Monitor license usage [585] X X

Create editor templates [616] X X

Create a backup [530] X

Reindex search [543] X

View log and profile [546] X

Clear cache [542] X

View scheduled jobs [542] X

View applied patches [542] X

Log in as root for the first time
As a system administrator, you are the root user with a unique set of permissions [583] that allow
you to access the System Administration page in Jama Connect.

The first time you log in as root, change the default password for the root user and edit any details in
the My Profile page, such as email address, phone number, or location.

To log in as root for the first time:

1. From the Jama Connect login page, enter the default credentials for root, then select Sign In.
• Username = root
• Password = password
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2. In the top right header, select root.

3. On the root user's My Profile page, select Change Password.

4. Enter the existing password, enter and confirm a new secure password, then select Save.
5. (Optional) Select Edit Settings to configure the root user email and any other details as needed.
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6. Select Save, then select Close

Assign a new user as organization admin
Only system and organization admins can assign roles or grant permissions to other users. If you con-
figure an organization admin right after you install Jama Connect, you can share the tasks of setting up
user accounts and permissions.

You must be have system admin permissions to complete this task.

1. Log in to Jama Connect as the root user [506] or as an organization admin.
2. Select Users > Add user.

Jama Connect User Guide

508



3. Select a user if LDAP is enabled [521]:
a. From the LDAP column that is added, select Add user from LDAP, enter the name of an

existing LDAP user in the search box, then press Enter.

TIP
You can add wildcards to a search but don’t add them at the beginning of a
search term. Wildcards at the beginning can result in slow performance. For
large directories, expect several minutes.

b. From the search results, choose a user, then select Add.

4. Select a user if LDAP isn’t enabled — Select Add user.
5. In the Create User page that opens, complete the information for a single user.

6. For License Type, select Creator.
7. Under Groups, select Organization Admin from the list.
8. Select Save.

Grant permissions to users
Permissions allow users access to create, read, and edit items. They are granted at different levels in
your environment.
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Types of permissions Level Notes

Roles [591] and access permissions Organization level Org-level permissions are passed on to lower levels.

Project admin permissions Project level

Access permissions Container level and above

TIP
Organization admin permissions can’t be overridden. In releases prior to Jama Con-
nect 8.62, there was the appearance that you could control an organization admin’s
access. However, that user could still see all projects and content, and if they wanted
they could give themselves access. The addition of User, Process, and Add project
roles decreases the need for a large group of organization admins. No updates or
overrides that you created in the past have been removed, so we recommend that you
remove them as your organization adopts these new admin roles.

You can create new permissions for a user or group as well as modify existing permissions.

To grant permissions to users:

1. Log in to Jama Connect as the root user [506] or as an organization admin.
2. Select Admin > Permissions.

3. In the Project Selector on the left, choose the level where you want to access permissions. 
• Organization (System)
• Individual project
• Container
The main page displays current permissions.

4. To change existing permissions for a user or group:
a. Select Modify in the row of the user or group you want to change, select the permissions you

want to include, and deselect what you don't want to include.
b. Select Remove in the row of the user or group where you want to delete permissions.

5. To add permissions for a user or group:
a. Select Add permissions in the top right.
b. In the Add permissions page that opens, select Add user or Add group.
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• Existing user or group — Select a user or group from the list on the left, then under
Permissions, select the role (access permissions) for that user or group.

• New user or group — Select New user or New group in the top right corner of the page.
Then under Permissions, select the role or access permissions for that user or group.

c. Select Save.

Edit organization details
As a system admin, you can change your organization’s information such as the name, descrip-
tion, or return email address.

1. Log in to Jama Connect as the root user [506].
2. Select Organizations > Edit.

3. Enter or change any of the following information:
• Organization name — Typically the name of your company or team. This name appears in the

application as well as in reports.
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• Description — Additional information about your company.
• Return email — Email notifications automatically sent by the application. Typically, the organiza-

tion administrator's email address is used or noreply@example.com.
• Base URL — The base URL is used to create URLs sent in email notifications and embed

images in exports.
• Rich text image max width (px) — Maximum pixel width setting that shrinks all images embed-

ded into rich text fields. Default 0 means no max width is applied.
• Rich text image max height (px) — Maximum pixel height setting that shrinks all images

embedded into rich text fields. Default 0 means no max height is applied.

NOTE
Images retain their aspect ratio when adjusted to fit the maximum setting of
height or width. The adjustment only happens during an upload or document
import. Images that already exist on the server are not adjusted. Compres-
sion is based on the width and height setting applied.

• Allow project admins to subscribe to others — Allows project administrators to subscribe
other users to items.

• Allow users to mute subscriptions — Allows users to turn off a subscription that was subscri-
bed to by another user.

• Allow non-administrators to delete items/containers — Allows a user to delete items even if
they don't have organization admin permissions. Default is On.

• Include unexecuted test run in status calculations (Not retroactive) — Jama Connect uses
all associated test runs to automatically calculate test case status.

NOTE
For test cases associated with a single plan, test case status reflects the status
of the test run with the most recent activity, which includes unexecuted tests (if
enabled). When the case is associated with multiple plans, the most urgent sta-
tus is chosen in this priority order: unexecuted, failed, blocked, scheduled,
passed.

Select this box to include unexecuted test runs in the calculation of test case status (default).
Uncheck this box to remove unexecuted test runs from the status priority order.
If you don't include unexecuted test runs and there are no executed test runs, the system defers
to including unexecuted test runs.

• Allow multiple items with the same Global ID in a single project — Allows items to be
reused multiple times within one project. Default is off.

Configure general properties
The general properties need to be configured for all Jama Connect installations. Properties include
configuring email and any messages you want to display on the login page.

1. Log in to Jama Connect as the root user [506].
2. Select the System properties tab in the Jama System Administration panel, then select Edit in the

top, right corner.
3. Change any of the following settings.

• Enable HTML Tag Security Cleaning — Prevents suspicious HTML tags from being added to
new and modified rich text fields and test steps. Doesn’t clean up data retroactively. Enabled by
default.

• SMTP Settings — Settings that affect notifications and subscriptions.
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SMTP Enabled Select Yes to use SMTP.

SMTP Host The domain address of your SMTP server.

SMTP Port The port for SMTP access.

SMTP User User account to access SMTP.

SMTP Password Password for the user account.

Authorization Required Select Yes if authorization is required for the SMTP server.

Use TLS? Select Yes if your mail server uses TLS. Jama Connect supports only Explicit (Opportunis-
tic) SSL/TLS connections for SMTP.

• System "From" address — Enter an address for the system to use when it sends notifications
or other system messages (for example, info@mycompany.com).

• Collaboration "From" address — IMAP must be supported to enable reply-to e-mails in the
stream [246]. The Collaboration "From" address must match the email address used for IMAP,
so replies to stream emails are sent to the same account that processes incoming mail (for
example, replyto@mycompany.com). To enable IMAP, see Configure Inbound email (IMAP) set-
tings [514].

• Allow Project Administrators to add groups — Select Yes for project administrators to add
groups [662]. Otherwise, only system and organization administrators can add groups.

• Allow Project Administrators to set project permissions — Select Yes for project administra-
tors to grant project permissions [664]. Otherwise, only system and organization administrators
can grant permissions.

• Allow access to REST API — Enables users to perform actions in Jama Connect from outside
the user interface.

• Attachment file extensions — List of file types (lowercase, separated by commas, periods,
spaces, or newline characters) that can be uploaded as an attachment.

NOTE
Files are rejected if the content of the file doesn’t match the file extension, or
if the MIME type is not understood by the system, even if the file type is listed
here. To allow files of an unknown type, set the option to a blank string.

File extensions must be lowercase even if the actual extension on the file is
uppercase. Learn more.

• Notice on login page — Displays a notice to users below the login page and in a yellow bar at
the base of the application page.
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NOTE
This login page might not be visible if you are using SSO or SAML logins.

• Maintenance mode — Logs out and locks out all users except the root user until this option
is disabled.

• Set header color — Helps to differentiate test or staging instances from the production instance
of Jama Connect.

• Set Batch Synchronous Index Limit — Select a limit that determines whether items in a batch
update are indexed synchronously or asynchronously. Synchronous indexing can add time to the
index process, so the default value is set to 1000. The added time depends on the number of
items and the complexity of fields for those items.
• Synchronous indexing — The number of items in a batch update is equal to or less then the

limit.
• Asynchronous indexing — The number of items in a batch update is greater than the limit.

4. Click Save.

Configure Inbound email (IMAP) settings
Before configuring IMAP, verify that your email server supports IMAP. Your server must support IMAP to
enable reply-to emails in the stream [236].

For more information, see Authenticate an IMAP, POP or SMTP connection using OAuth.

To configure IMAP:

1. Log in to Jama Connect as the root user [506].
2. Select System Properties > Inbound email (IMAP).
3. Click Edit, then select Is IMAP enabled.
4. Configure the following settings:
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Host Enter the IMAP server URL.

User account Enter a user account for someone with access to the folder where IMAP emails are saved.

Password Enter the password for the user account or the OAuth secret.

Port The port for IMAP connection, typically different from SMTP. Standard ports are Non-SSL:143,
SSL:993.

Is SASL XOAuth2 Ena-
bled

Select to enable OAuth authentication and token-based authorization for Microsoft based IMAP
connections.

Is SSL Enabled Select to enable SSL IMAP connections.

Is TLS Enabled Select to enable TLS IMAP connections.

OAuth Client ID Enter the client ID (Microsoft AAD Application ID).

OAuth scopes Enter the resource URLs defining the token authorization request.

OAuth authority Enter the URL of the authenticating authority or security token service.

Microsoft security token service example: https://login.microsoftonline.com/{microsoft_ten-
ant_id}

Incoming mail folder (Required) Enter the name of the mail folder to read collaboration replies from.

Error mail folder (Required) Enter the name of the mail folder to move unknown emails to. Unknown emails are
non-collaboration emails.

Is debugging enabled Select to enable debug level logging for failing IMAP connections. After enabling, check the
server logs and test the connection.

5. Click Save.

Configure Basic authentication
The default authentication method is Jama Connect Basic, which authenticates users by their username
and password that are stored in the Jama Connect database. Passwords are encrypted before they are
stored in the database.
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NOTE
You must be a system administrator to complete this task.

To configure the Basic authentication properties:

1. Log in to Jama Connect as the root user [506].
2. Select System Properties > Authentication Properties > Basic.

3. Configure the authentication properties for the method you are using.
• Enable basic authentication — Enabled by default. You must deselect this option to use LDAP

or Crowd.
• Enable "Forgot Password" functionality — Users who forget their password can request a

new password without notifying the system admin.
• Allow users to change their username — Users can change their username when they

manage their profile [39].
• Password requirements — Set the required password strength for all future passwords. New

user passwords must meet the required password strength to be saved. Changes to these
settings do not affect passwords already in the system.

4. Click Save.

Configure SAML authentication
To configure SAML authentication, you must first update the authentication properties.

Important considerations

• To connect multiple instances of Jama Connect to the SAML service, you must create unique meta-
data or applications for each instance through the identity provider. This is true for any combination
of production, sandboxes, or self-hosted instances. The entity ID is a unique value that allows the
service and identity provider to locate each other and send users to the correct Jama Connect
instance.

• We recommend testing an integration instance before using SAML on a production instance. For
example, disable a sandbox instance from SAML before connecting on a production instance.
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• Starting with Jama Connect 8.48, organizations that use SAML can use electronic signatures [257],
which are enabled by default. If your identity provider (IdP) can't process the re-authentication, you
can disable signatures.

• You can enable a different authentication method at any time. If you do, SAML is disabled.
• You can control the auto-provisioning of new SAML users in both single SAML and multi-mode. If

your users are set up in SAML but not yet added to your Jama user table, this option allows you to
control whether users can auto-provision in Jama Connect.
When this option is selected and properties are saved, your SAML users (SAML and multi-mode)
can’t sign in to Jama Connect until you add them to the Jama user table. A message tells them to
finish the authentication process with their administrator.
This option is selected by default after you upgrade to 8.62.

To configure SAML authentication:

1. Log in to Jama Connect as the root user [506].
2. Select System Properties > Authentication Properties > SAML.
3. Before you enter data, select Enable SAML, then click Save.

NOTE
The following selections for the Match on field configuration are beta features that
are under development: Username, Custom identifier (NameID), and Custom
identifier (Attribute). For now, use the default Email selection. If you're interes-
ted in beta testing the Username or Custom identifier selections, contact your
account manager.
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4. Contact your identity provider for the metadata URL or XML, then paste it in the appropriate field.
If a connection is established, the last three read-only fields are auto-populated with a URL.
• SP metadata URL — https://saml-or.jamacloud.com/saml/metadata/alias/defaultAlias
• ACS / single-sign-on URL — https://saml-or.jamacloud.com/saml/SSO/alias/defaultAlias
• SP entity ID / Audience restriction — https://saml-or.jamacloud.com/saml/metadata/alias/de-

faultAlias
If the connection doesn't work, you might need to adjust the information in the ACS binding, First
name attribute mapping, and Last name attribute mapping fields or contact support.

TIP
The mapping fields serve as the key that connects user identity between Jama
Connect and your identity provider. If name attribute mapping fields aren't speci-
fied, then a new user's full name defaults to their email address.

5. Click Save.

Once SAML is enabled, Jama Connect redirects all users to the identity provider's login page. The
Jama Connect login page is only accessible for system administrators if they log in as the root user with
this URL:

https://your-jama-url/casper/login.req

Configure multi-mode authentication
The combination of Jama Connect Basic and SAML authentication (Basic + IdP) provides extra securi-
ty by separating your internal users from external partners.
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To configure multi-mode authentication:

1. If you haven't entered the SAML metadata in the root menu, go to the SAML tab and enter it there.
• Contact your identity provider for the metadata URL or XML, then paste it in the appropriate field.

If a connection is established, the last three read-only fields are auto-populated with a URL.
• SP metadata URL — https://saml-or.jamacloud.com/saml/metadata/alias/defaultAlias
• ACS / single-sign-on URL — https://saml-or.jamacloud.com/saml/SSO/alias/defaultAlias
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• SP entity ID / Audience restriction — https://saml-or.jamacloud.com/saml/metadata/alias/de-
faultAlias
If the connection doesn't work, you might need to adjust the information in the ACS binding,
First name attribute mapping, and Last name attribute mapping fields or contact support.

TIP
The mapping fields are the key that connects user identity between Jama
Connect and your identity provider. If name attribute mapping fields aren't
specified, a new user's full name defaults to their email address.

2. Log in to Jama Connect as the root user [506].
3. Select System Properties > Authentication Properties > Basic + IdP.

4. Select Enable BOTH Basic authentication and SAML, then click Save.
The Basic + IdP tab transitions can now accept input. While the Basic and SAML tabs are now
read-only This type of input is the same on both tabs: Basic and SAML.

5. Complete the Basic and SAML sections in the Basic + IdP tab:
Basic — Fill out the the Basic Authentication section.
SAML — If you haven't entered the SAML metadata in the root menu, complete the following steps
in the SAML section of the Basic + IdP tab.

NOTE
The following selections for the Match on field configuration are beta features that
are under development: Username, Custom identifier (NameID), and Custom
identifier (Attribute). For now, use the default Email selection. If you're interes-
ted in beta testing the Username or Custom identifier selections, contact your
account manager.

6. Click Save.
7. Confirm the configuration was successful.

• Select the Users tab, then verify that the Authentication Type column appears in the table.
If you see the Authentication Type column, Basic + IdP authentication is now enabled.
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Configure LDAP authentication
LDAP (Lightweight Directory Access Protocol) is a tool for organizations to centralize the management
of user accounts. Jama Connect includes a built-in integration for LDAP and Microsoft Active Directory.

LDAP must be configured before it can be used in Jama Connect to authenticate users against your
LDAP server. 

To configure LDAP authentication:

1. Log in to Jama Connect as the root user [506].
2. Select System Properties > Authentication Properties > LDAP.

3. Configure the authentication properties for the method you are using.
• Enable LDAP — Select this to enable LDAP and disable the default Jama Connect authentica-

tion. Save the settings for changes to take effect.
• Enable Self Registration — Users can register themselves by logging in to Jama Connect using

their LDAP credentials. If successfully authenticated, they get a prompt to register for Jama Con-
nect. Without self-registration, users must be added manually by an organization administrator.
Once registered, users will be assigned a license type based the rules below. An organization or
project administrator must then assign permissions for that user.
• If there are available creator licenses, they are assigned a creator license.
• If there are no named creator licenses, users are assigned floating creator licenses (shared

among others).
• If there are no creator or floating creator licenses available, you can still create users, but

they are set to inactive. An organization administrator must manually assign the user an active
license when one becomes available.

• Default organization for self-registered user — Select the organization that self-registered
users are assigned by default. There should only be one option.

• Default user group for self-registered user — Select the default group to which a self-regis-
tered user should be assigned. Organization administrators will need to assign permissions to
self-registered users. 

4. You can configure multiple directories with LDAP authentication. To add a new provider, select Add
AD Provider or Add LDAP Provider, depending on the LDAP tool you use.  

5. In the window that opens, provide the server information used to connect to the Active Directory or
LDAP server, then click Next.
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• Name — Name of the connection that will appear in the Jama Connect interface.
• Description — Description of the connection that will appear in the Jama Connect interface.
• URL — The URL to the Active Directory or LDAP server.
• Bind DN — The reference to the account that Jama Connect will use to perform all actions

against the Active Directory or LDAP server. This field accepts the Distinguished Name of the
account ("cn=John Doe,ou=Users,dc=jamasoftware,dc=com").  
Some Active Directory servers support the use of Full Name ("John Doe") or Email ("jdoe@do-
main.com").

• Bind Password — The password of the Bind DN account.
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• Test Configuration — Select Test configuration to test for a successful connection to the
specified server and bind account information. If successful, a "Configuration Successful" mes-
sage will display in the window and the Base DN selection screen will expand.

• Select the Base DN — The Base DN is the directory where users in Active Directory or LDAP
exist that need to be added to Jama. Successfully tested configurations will load a radio button
selection list of all available Base DNs.

6. Specify the attributes in Active Directory and LDAP that automatically populates the Jama Connect
user attributes.

• Username — Enter the username of a sample user that exists in the specified Base DN.
• Username Attribute — Enter the attribute where the username value is stored (for example,

Active Directory commonly uses "samaccountname"). 
7. Select Next to validate that the provided username and username attribute exist. If successful, the

window expands to show a selection list of all available attributes for each of the Jama Connect
user attributes.
• Jama User Attributes — First Name, Last Name, Full Name, Email, Location, Phone, Title. 
• LDAP attribute — The selection drop-down shows all available directory attributes that are

connected to the provided username. Select the correct value in the selection list that matches
the Jama Connect user attribute.

8. Select Advanced setup if you know all the details of the connection and user attribute values. If
you choose this option, you must add the Full Name Attribute or errors will result.
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9. After saving the connection, select Synchronize Now to manually sync all existing users in Jama
Connect to LDAP. This updates user information with attributes from LDAP. 

Any Jama Connect users who are not registered in LDAP are deactivated. Users in LDAP that do not
already exist in Jama Connect aren't synchronized. New users must be added manually [508] with
existing LDAP credentials.

Troubleshooting LDAP errors
If any errors occurred during installation, use this table to troubleshoot the issues.
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Error message Reason

Unable to communicate with LDAP server; nested ex-
ception is javax.naming.CommunicationException: local-
host:389 [Root exception is java.net.ConnectException:
Connection refused: connect]

Can't connect to the server. Check the URL and make sure port
389 is open.

Operation failed; nested exception is javax.naming.Au-
thenticationException: [LDAP: error code 49 - Invalid Cre-
dentials]

The BindDn or password is incorrect.

Can't find user Indicates that the Base Dn, Bind Dn, and Bind Password can be
connected to accurately (a good connection to LDAP). Either the
Login Name Attribute was not filled in correctly or the Sample User
does not exist in the Base Dn indicated.

Can't authenticate user The sample user password is incorrect. However, this message
indicates a successful connection to LDAP and that the sample
user was found in the Base Dn.

Operation failed; nested exception is javax.naming.Partial-
ResultException: Unprocessed Continuation Reference(s);
remaining name

The cause is usually the base URL is incomplete (too broad).

Operation failed; nested exception is javax.naming.Serv-
iceUnavailableException: adunit:636; socket closed. Port
636 is for SSL.

Either SSL isn't supported by Spring LDAP or the certificate is
incorrect.

Solution: Try using ldap protocol. For example: ldaps://myserver.ex-
ample.com:636.

Make sure you entered the correct information for the type of LDAP you are configuring:

• Active Directory
URL: 'ldap://localhost:389'
Base Dn: 'ou=Users,dc=<domainname>,dc=com'
Bind Dn: 'cn=Admin,ou=Admin Users,dc=<domainname>,dc=com'
Bind Password: 'password'
Login Name Attribute: 'sAmAccountName'
Email Attribute: 'email'
User Name Attribute: 'displayName'
Sample User: 'admin'
Sample User Password: 'password'

• LDAP
URL: 'ldap://localhost:389'
Base Dn: 'ou=Users,dc=<domainname>,dc=com'
Bind Dn: 'cn=Admin,ou=Admin Users,dc=<domainname>,dc=com'
Bind Password: 'password'
Login Name Attribute: 'uid'
Email Attribute: 'mail'
User Name Attribute: 'cn'
Sample User: 'admin'
Sample User Password: 'password'

IMPORTANT
If you are using SSL, you must use the ldaps protocol. For example, ldaps://myserv-
er.example.com:636

The Base Dn and Bind Dn values won't accept a domain-only value. At least one additional level is
required, such as the 'ou=Users' shown in the example above.
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Take note of the "Can't find/authenticate user" errors. Errors often indicate a successful connection, but
the Sample User/Password are incorrect. 

IMPORTANT
The Sample User and Password fields are deleted every time the configuration window
is closed.

Configure Crowd authentication
Use Crowd to manage users and groups within a single system. Jama Connect can accept user details
from Crowd and sync them with authentication data in Jama Connect.

To configure Crowd authentication:

1. Log in to Crowd as an administrator.
2. Select Applications > Add Application, fill in the fields for a new application and select Next.

• Application type — Generic Application.
• Name — "jama" or any other unique name that identifies Jama Connect as the application.

NOTE
The name must match. For example, lower case "jama" in the above example.

• Description — (Optional) Provide a short description of the application.
• Password — Create a new password that Jama Connect uses to access Crowd.

3. Enter the URL and IP address for Jama Connect, then select Next.
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4. Select the directories that control access to Jama Connect, then select Next.

NOTE
These directories must exist prior to inclusion.

5. Select the particular groups in the Crowd Directory you want to have access to Jama Connect, or
choose "all users in the directory" if you want all users to have access, then select Next.

6. Review your configuration, then select Save.
7. Log in to Jama Connect as the root user [506].
8. Select System Properties > Authentication Properties and complete the following fields.
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• Enable Crowd — Select to enable or disable Crowd Connector. When disabled, the Jama
Connect database is used for users and passwords. 

• Crowd location — Enter the URL for the Crowd server.
• Crowd application name — Name of the application created in step 2 above.
• Crowd application password — Enter the password for Jama Connect that was created in

Crowd.
• Validation interval — The amount of times a user can access the application prior to re-authen-

ticating. The larger the number, the less communication with Crowd.
• Sync Crowd users and groups — Select this option to push Crowd Groups and Users into

Jama Connect at regular intervals. Make sure you understand how users and groups in Crowd
interact with Jama Connect [529] before you do this.
When syncing with Crowd, Jama Connect assigns licenses as follows:
• If there are available named creator licenses, users are assigned a named creator license.
• If there are no available creator licenses, users are assigned a float license.
• If there are no available creator or float licenses, the user is skipped and it appears in the log.
When Crowd is synced, Jama Connect runs through its list of users, adds new users, and
modifies existing users in the Jama Connect userbase. When that's complete, Jama Connect
runs through the list again to see if there are any existing users in the Jama Connect userbase
that need to be deactivated.
Since Jama Connect makes two passes at adding and deactivating users, you might need to
sync twice consecutively for it to work. For example, if you reach your license threshold, don't
use float licenses, try adding a new user and deactivating an existing user, or must sync twice
consecutively before the new user is given a named license.

IMPORTANT
You can also select Manual Sync at the bottom of the window to manually
synchronize all users and groups. Manual sync removes all Jama Connect
configured Users and Groups and insert Crowd users and groups.
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• Sync interval — Enter the timing interval you would like for Crowd to synchronize groups and
users with Jama Connect. This defaults to 30 minutes.

• Default Organization for User — Only required when multiple organizations are setup with
Jama Connect.

9. Click Save.
10. Select Test Connection to test if the configuration values are valid.

Users who are registered in Jama Connect, but not in Crowd, can't access Jama Connect. Other users
won't be able to add disabled users to reviews or notifications.

How users and groups work in Crowd
How users and groups function is impacted when you synchronize users and groups in Crowd connec-
tor [526].

The following actions change:

• All groups and users in Crowd that aren't in Jama Connect are added to Jama Connect. New
users are assigned the most licenses available. When no licenses are available, users are created
and Inactive.

• All groups in Jama Connect that aren't in Crowd are removed.
• All users that are in Jama Connect, but not in Crowd, are deactivated.
• Going forward, all user and organizational group management activities are performed in Crowd.
• Organization admins no longer create or edit users and organizational groups in Jama Connect

because they are automatically created from Crowd.

The following actions stay the same:

• Organization admins retain the ability to assign a license type [582] to users.
• Users can continue to upload avatar icons [39].
• Organization and project admins continue to manage project groups [662] within individual projects.

IMPORTANT
Project level project groups are only managed in Jama Connect and aren't visible in
Crowd.

• An organization or project admin continues to manage user and group permissions [589] in Jama
Connect.

Action in Crowd Result in Jama Connect

Group(s) added to “Jama” Application in
Crowd

Group created.

The name of the group is reused if it already exists.

Users added to the "Jama" group in Crowd Users added.

Attributes in Jama Connect are overwritten by values from Crowd if a user already
exists.

Group attributes modified Group attributes are modified.

User attributes modified User attributes are modified.

User added to group User is added to group.

User removed from group User is removed from group.

Group deleted Group is deleted.

User is deactivated User is deactivated.

User activated User is activated.

If the user doesn't exist, a new user is created. The new user is assigned the
highest available license. If a license isn't available, the user is inactive.
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Backing up and restoring your data
Backing up your data is an essential part of maintaining and securing your self-hosted environment.
With regular backups, you can easily restore settings and content when you update your application
server hardware or if you lose data.

NOTE
This information applies to self-hosted environments only.

You can back up and restore your data using several methods:

• Replicated snapshot — A function of Replicated software that creates a backup of the Admin Con-
sole environment. It includes all Admin Console settings, the Replicated database, Docker images,
and Docker container volumes.

• .jama or XML file — A method with built-in automation, recommended for migrations and refreshes.
A .jama file includes the database and /data directory. An XML file includes only the database.

• Native database backup — The proprietary backup/restore system for MySQL and SQL Server
databases. Recommended only if your database is extremely large.

• Backup of user data directories [543] — Where all physical artifacts [543] are stored.

IMPORTANT
Create a backup regularly: daily, weekly, or monthly. Include in your regular back-
up a Replicated snapshot (Admin Console environment) and a .jama or XML file back-
up (database and /data directory).

Create a Replicated Snapshot (KOTS)
Taking a full snapshot creates a backup of the KOTS Admin Console and application data. It can be
used for full Disaster Recovery by restoring over the same instance or in a new cluster. Tenant assets
are included in the snapshot. Elasticsearch data is included by default.

A Replicated Snapshot can be taken while Jama Connect is running without interruption.

Requirements

• Replicated Snapshots must be enabled for your Replicated customer license.
• KOTS Admin Console 1.79 and later.
• Replicated Snapshots don't include your database. You must use a proprietary backup/restore sys-

tem for your type of database, MySQL or SQL Server.

Important considerations

• When restoring from a snapshot in a new cluster, you must reinstall KOTS.
• Recommended — Include Elasticsearch data in snapshots to avoid having to reindex your data after

performing a restore. However, if your snapshot is not recent, we recommend reindexing your data.
• Replicated Snapshots don't support IAM authentication against EFS. Saving Replicated Snapshots in

EFS requires that you use the default file system policy to allow all nodes in the cluster to mount the
EFS.
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To create a Replicated snapshot:

1. Capture the KOTS installer.
2. (Recommended) Include Elasticsearch data in snapshots: From the KOTS Admin Console under

the Elasticsearch Settings section, select Include Elasticsearch in Replicated Snapshots.
3. Airgap only — Capture the IP address of the private registry, which is the IP address value in the

Cluster-IP column:
kubectl get service/registry -n kurl

4. Configure the storage destination:
a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. From the Destination drop-down menu, select a storage destination for your snapshots.

• For AWS S3 — The IAM role assigned to the underlaying servers or the user associated
with the credentials (access and secret key) must have the Policy template attached.
Use the following template to create a policy, replacing the <arn-S3> parameter with ARN of
the S3 bucket. For example: arn:aws:s3:::jama-snapshots.
{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Effect": "Allow",
            "Action": [
                "s3:PutObject",
                "s3:GetObject",
                "s3:AbortMultipartUpload",
                "s3:DeleteObject",
                "s3:ListMultipartUploadParts"
            ],
            "Resource": "<arn-s3>/*"
        },
        {
            "Effect": "Allow",
            "Action": "s3:ListBucket",
            "Resource": "<arn-s3>"
        }
    ]
}

• For NFS — If using EFS as an NFS server, the Server field = the DNS name of the EFS
and the Path field = a directory inside the EFS, writable by the user:group 1001:1001.

c. Click Update storage settings to save your preferences.
5. Schedule Full Snapshots:

a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. Select Enable automatic scheduled snapshots, then click Update schedule.

6. Create a Full Snapshot (follow the steps provided by Replicated).

Restore KOTS Admin Console and Jama Connect from a Replicated Snap-
shot (KOTS)
When you set up a new application server for Jama Connect, you can restore the KOTS Admin Console
settings that you saved in a Replicated Snapshot.

Snapshots include the registry images and data for Jama Connect.

Requirements
If restoring to a new cluster, it must match these specifications and settings of the cluster where the
backup was taken:

• Number of nodes
• Inbound and outbound traffic rules
• Virtual memory settings for Elasticsearch
• Connectivity to external services and resources (for example, AWS EFS, AWS S3)

To restore from a snapshot:
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1. Configure servers for a new cluster:
a. After the servers for the cluster are provisioned, install KOTS on one node using the captured

KOTS Installer. You must pass the same flags to the installation script that were passed to the
original cluster.
• Restoring an online cluster — Run the appropriate installation script that was generated

from the captured KOTS installer.
• Restoring an airgap cluster — Download the appropriate KOTS installer bundle, replacing

<ip> with the IP address of the private registry from the original cluster:

cat install.sh | sudo bash -s airgap kurl-registry-ip=<ip>

b. When the installer has finished, run the command displayed on the screen so the other servers
join the cluster. If required, label the nodes dedicated for Elasticsearch.

c. Install any add-ons that were manually installed in the cluster. For example, the EFS Driver.
2. Configure the storage destination: From the KOTS CLI, point the cluster to the storage destination

where the Replicated Snapshots were saved.

AWS S3 See configure-aws-s3.

Azure See configure-azure.

GCP See configure-gcp.

S3-Other See configure-other-s3.

NFS See configure-nfs. If the cluster uses EFS or NFS, also see Configuring an NFS Storage Destination.

Note: If using EFS as an NFS server, Server field = DNS name of the EFS and Path field = a directory inside
the EFS, writable by the user:group 1001:1001.

3. Locate the snapshot and restore it: From the KOTS CLI, run a backup ls and full restore.

backup ls

This can take a few minutes. If the snapshots don’t appear, rerun this command.
4. If you changed the host name for Jama Connect:

a. Update the Host Name field in the KOTS Admin Console and deploy the change.
b. From your browser, log in to Jama Connect and change your URL [540].

5. View scheduled jobs [542] to verify that the list isn't empty.
6. If the Elasticsearch data wasn't included in the snapshot or if the snapshot isn't recent, reindex all

search items [543].
7. Verify that you can locate your assets.

Back up to .jama or XML
We recommend backing up to a .jama or XML file for migrations and refreshes because this method
has built-in automation. You can avoid manual changes which can impact the integrity of the data.

A .jama file backup includes the database and /data directory. An XML file backup includes only the
database.

Important considerations

• If SAML is enabled, disable it before backing up your data. After you restore your instance of Jama
Connect, you must re-enable SAML.

• Backups must be done manually; they can't be scheduled automatically.
• Make sure you have enough available disk space [535].
• Make sure Jama Connect is in maintenance mode [512] before you create a backup.
• If you are using a version of Jama Connect prior to version 8, generate backups during a mainte-

nance window and inform users, including API users, not to use the application.
• Regardless of what version you are using, all integrations must be disabled.

To back up to a .jama or XML file:

Jama Connect User Guide

532

https://docs.replicated.com/reference/kots-cli-velero-configure-aws-s3
https://docs.replicated.com/reference/kots-cli-velero-configure-azure
https://docs.replicated.com/reference/kots-cli-velero-configure-gcp
https://docs.replicated.com/reference/kots-cli-velero-configure-other-s3
https://docs.replicated.com/reference/kots-cli-velero-configure-nfs
https://docs.replicated.com/enterprise/snapshots-configuring-nfs
https://docs.replicated.com/reference/kots-cli-backup-ls
https://docs.replicated.com/reference/kots-cli-restore-index


1. Log in to Jama Connect as the root user [506].
2. Select the Backup tab to see the backup options.

3. Choose a backup method (listed here in recommended order).

Method Scenario Select...

Save .jama file to the application server. Migrating between versions later than 8.0. Save .jama File to
server

Save XML file to the application server. • Migrating between different types of databa-
ses

• Migrating version earlier than 8.0

Save XML File to
Server

Download XML database backup to your
workstation.

• If you can't access the application server
• For smaller databases

Download XML

Download document type definition (DTD)
to your workstation.

If all other methods fail Download DTD

The backup process is complete.

Restore to a new server from .jama or XML
When you set up a new server, you can install Jama Connect and restore data using the .jama or XML
file backup you created. See Back up to .jama or XML file [532].

IMPORTANT
If you use SAML in your environment, it was disabled before you created the .jama or
XML backup. When you install Jama Connect on a new server, it will be running Basic
authentication. You must re-enable SAML to use that authentication method.

To restore a new server from .jama or XML:

1. Log in to Jama Connect as the root user [506] on the new server.
2. Install Jama Connect:

a. In the header of the KOTS Admin Console, select Application > Config to open the settings
page.

b. Scroll down to the Database Settings section of the page, then select select the database you
are using: MySQL or SQL Server.
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c. Under Restore Jama Backup, enter the file path for the backup you created, (for exam-
ple, /data/restore/your_backup.xml). Select Check conditions to make sure the path to your
backup file meets the conditions listed onscreen.

IMPORTANT
You must have an empty database for the restore process to complete.

3. For non-.jama file backups: Move existing data folders to the new application server.
4. Save and restart Jama Connect.
5. Log in to Jama Connect as the root user [506]
6. If your new application server has a different URL than the old one, update the base URL to reflect

the change.
7. To sync your indexes with the database, index all items.

Jama Connect User Guide

534



Backing up MySQL or SQL Server database
If your MySQL or SQL Server database is extremely large, use the native backup method that comes
with your database. Doing so avoids possible data corruption.

Follow instructions for whichever system you are using, MySQL or SQL Server.

IMPORTANT
If you are migrating from one type of SQL server to another, for example SQL Server to
MySQL, use the .jama or XML file backup [532].

Maintaining your Jama Connect environment
A system administrator is responsible for keeping the system up and running and at peak performance.

Maintaining your environment consists of ongoing tasks that are done regularly and important tasks that
are done infrequently.

Ongoing/regular tasks Infrequent but important tasks

• Monitor memory usage [535]
• Maintaining your Jama Connect database [536]
• Back up your data [530]
• View scheduled jobs [542]
• Clear cache [542]
• Remove old Docker images [541]
• View applied patches [542]
• Reset Admin Console password [537]
• Deactivate and reactivate users [536]

• Update the license [537]
• Update the certificate [538]
• Update the application's IP address [539]
• Change [540] or fix URL [540]
• Delete an organization [541]
• Reindex all items [543]

Monitoring memory usage
Make sure you have allocated an appropriate amount of memory for your organization's usage. Check
and adjust usage regularly to keep your environment running for best performance.

Several factors affect the amount of memory that Jama Connect requires, including:

• Size of your dataset
• Number of concurrent users
• Users' common workflows

If any of the pods’ memory consumption is close to the maximum available memory, you can adjust
those values. These containers in order require the most memory:

• jamacore
• elasticsearch
• searchservice

Make sure that you don't over-allocate the total memory of the application server. Also, leave approx-
imately 5 GB of available memory (headroom) for system processes. For help in estimating your
application server size, use the tables in Resource sizing for your application server.

Use one of these methods to monitor usage, then adjust your memory settings [500] as needed.

• Log in to Jama Connect as the root user.
• Select the License management tab to view usage by license type.
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• Use the Admin Console monitoring graphs.
• Use any Java application monitoring tool that supports JMS.
• Use JavaMelody, which comes preconfigured with the Jama Connect application. To access Java-

Melody, log in to Jama Connect as the root user [506] and navigate to [your.jama.url]/javamelody.

Maintaining your Jama Connect database
Follow these recommendations to maintain your Jama Connect database, which includes having a data
backup plan and ensuring the appropriate memory is allocated to the database server.

1. Create a data backup plan — Back up your database server at least daily and implement backup
strategies as needed.

2. Allocate appropriate memory to the database server — Have your Database Administrator
monitor memory usage and allocate memory in advance to prevent running out of memory.

3. Configure system variables and server properties based on usage — For details, see the
documentation for MySQL or SQL Server.

4. Check or analyze databases and tables every 6 months — We recommend that you review or
analyze your databases at least every 6 months, or after you write, change, or delete a substantial
amount of data. Pay extra attention to table or index size because Jama Connect is a write-heavy
application. If a table has grown out of size or the index is too large, it might need to be rebuilt.
Use these resources to determine if an index or table must be rebuilt:
• Leverage MySQL and SQL Server statistic gathering to detect the need to repair or analyze

databases or tables.
• Run mysqlcheck to check, repair, optimize, or analyze tables in MySQL. For details, see mysql-

check — A Table Maintenance Program.
• Use the Maintenance Plan Wizard tool to manage backups, data integrity checks, and statistic

gathering in SQL Server. For details, see Use the Maintenance Plan Wizard.

Deactivate and reactivate users
Users can’t be deleted from Jama Connect, but you can deactivate users if they are no longer active
members of the team. When you deactivate a user, their account becomes inactive and their named
license is freed up for another user. You can also reactivate the user as needed.

IMPORTANT
You must have organization or system administrator permissions to deactivate and
reactivate a user.

To deactivate and reactivate users:

1. Log in to Jama Connect as the root user [506].
2. Select the Users tab.
3. To deactivate a user, select Deactivate in the Action column next to the user you want to deacti-

vate.
Deactivated users disappear from the list.

4. To reactivate a deactivated user:
a. Select View inactive users to view all users, then select Activate in the Action column next to

the user you want to reactivate.
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b. In the User license type window, select a license type and select Save.

Reset Admin Console password
You can reset the password for the Admin Console if, for example, the administrator forgot it.

1. To remove the current password, run this command on the application server:
replicated auth reset

2. To change your password:
a. From the KOTS Admin Console, select the circle ellipsis icon, then click Change password.

b. Update the password information, then click Change Password.

The new password takes effect immediately.

Update the license
When you renew your license or change the number of available seats, you must update your license.
You receive a single key for your organization, called a license key, which specifies the type and
number of licenses you have.
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TIP
Schedule a license update during a maintenance window because the process in-
volves an interruption to the Jama Connect application.

To sync your license:

1. Open the KOTS Admin Console: https://<your hostname>:8800.
2. In the KOTS Admin Console, select the Applications tab, click License, then make the following

changes:
• Internet installation — Click Sync license.
• Airgap installation — Click Upload license, then select the latest license.
The KOTS Admin Console checks for updates to your license and creates a new version.

3. Select Version history and deploy the new version with your license changes.
4. Log in to Jama Connect, then select License Management to verify that the license updates were

successful.

Update the certificate
If a certificate expires, it becomes invalid and must be replaced.

1. In the header of the KOTS Admin Console, select the gear icon > Console Settings.
2. Under TLS Key & Cert, select the location of the SSL private key and certificate.

• If the SSL key and certificate are on the application server, select Server path, then enter the file
locations.

• If the SSL key and certificate are on the computer you use to access the Admin Console, select
Upload files to upload the key and certificate files, then select Choose file for SSL Private Key
and SSL Certificate.

3. Scroll to the bottom of the page and select Save config. A message confirms that your settings
were saved.
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Update the IP address for the application server
If you need to update the IP address or hostname of your application server, you must also edit the
Replicated configuration files to reflect this change.

If you previously used an IP address, continue using an IP address. If you previously used a hostname,
continue using a hostname.

NOTE
If you are using DNS and the hostname for this server isn't changing (just the underly-
ing IP), you don't need to edit any files.

1. Make the IP/hostname changes in your network and on the server.
2. Stop the Jama Connect services.
3. Stop Replicated (KOTS Admin Console):

• CentOS, RHEL 7+, and Fedora
sudo systemctl stop replicated replicated-ui replicated-operator

• Debian, Ubuntu, and thers
sudo service replicated stop
sudo service replicated-ui stop
sudo service replicated-operator stop

4. Edit the Replicated configuration files to replace all occurrences of the old IP address or hostname
with the new IP address or hostname.
• Fedora/CentOS/RHEL

/etc/sysconfig/replicated and /etc/sysconfig/replicated-operator
• Debian/Ubuntu

/etc/default/replicated and /etc/default/replicated-operator
• Others

Contact support at support@jamasoftware.com if you can't locate the Replicated configuration
files.

5. If you have a firewall in place or use a proxy and configured no_proxy settings in Docker, update
these settings with the new IP address.

6. Restart Docker.
• Fedora/CentOS/RHEL 7+

sudo systemctl restart docker

• Debian/Ubuntu and Others
sudo service docker restart

7. Start the Replicated service (KOTS Admin Console).
• Fedora/CentOS/RHEL 7+

sudo systemctl start replicated replicated-ui replicated-operator

• Debian/Ubuntu and Others
sudo service replicated start
sudo service replicated-ui start
sudo service replicated-operator start

8. Once the Replicated containers are up, navigate to https://{new_ip_address}:8800, then enter the
new IP address or hostname under Settings > Hostname.

9. Log in to Jama Connect as the root user [506].
10. Change the URL [540] to reflect the new IP address.
11. Run Fix URL references [540] to change any existing references in the text of items that were

already created.
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Change URL
The Base URL is the first part of all web addresses that Jama Connect installations use, beginning
with http and ending with a slash (/).

You might want to change your Base URL if a company changes its name or if you need to create a test
instance.

To change your Base URL:

1. Log in to Jama Connect as the root user [506].
2. Select the Organizations tab.
3. Select Change URL from the Action column.

4. Enter the new URL in the New Base URL text box.
5. Select Change URL.
6. Update all URL references [540] in the application to the new value. 

If this step isn't completed, the application still contains old URL references, which can result in
unpredictable behavior such as images not being displayed in exports.

7. If you're using SAML authentication, disable and re-enable SAML settings to update the base URL
in our SAML services.

The new URL is updated and active.

Update URL references after changing URL
The option Fix URL References updates all URL references in the application to reflect a new URL.
After you change a URL [540], always run this function.

IMPORTANT
The Fix URL References option doesn’t modify items in archived projects. It also
doesn’t change the URL used to connect the application server to your database serv-
er; that URL is stored in your database.properties file. The Base URL (baseurl field) is
only updated in the database organization table by the Change URL [540] option.

Use the Fix URL References option if:

• You notice images are not being displayed in exports.
• A login prompt appears after URL redirection.
• An error message is displayed when you run exports.

To update all URL references in the application:

1. Log in to Jama Connect as the root user [506].
2. Select Organizations > Fix URL References.
3. Select Fix URL References from the Action column.
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4. Enter the new URL in the text box, To this URL.
5. Select Fix URL References.
6. When prompted, select Yes to finish.

Delete an organization
Deleting an organization is an activity that is done only when more than one organization exists.

NOTE
Before version 4.3, users had the option to add multiple organizations. However, this
option was removed in the spring of 2014. As of release 8.10, if you have multiple
organizations, delete all but your production organization.

Overall system performance might be affected during the delete process depending on the size of the
organization to be deleted. Schedule the deletion during off-peak hours.

Deleting an organization completely removes all data about the organization including projects, set-
tings, and users. Deleted organizations can’t be recovered. If you need to preserve the non-production
organizations, contact your account representative.

To delete an organization:

1. Back up your data [532].
2. Log in to Jama Connect as the root user [506].
3. Enable maintenance mode [512] under the System properties tab. If maintenance mode isn't

enabled, the option to delete organizations isn't available.
4. Under the Organizations tab, select the Delete action in the row of the organization to be deleted.
5. When prompted, select Yes to confirm you are deleting the organization.

Remove old Docker images
Old Docker images from previous versions of Jama Connect use up storage space and might cause
indexing to fail. To avoid this, periodically remove old Docker images from your system to keep it
running smoothly.

You also want to remove dangling volumes, which are volumes associated with a container that no
longer exists. Jama Connect creates new containers and volumes when you restart the application.
These volumes can fill up your disk space.

IMPORTANT
Make sure Jama Connect is running so that only images not in use are deleted. These
commands clean only images and volumes loaded with the Docker storage driver
in use. Files that were written with other storage drivers remain on the volume until
separate commands are run for that storage driver.
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Use these commands to clean up your volumes:

1. Identify how much space is being used on your server:

sudo docker system df

2. List out all Docker images on your server:

sudo docker images

Images are displayed on the screen, listed by their ID in the IMAGE ID column.

3. Remove an image by its ID:

sudo docker rmi IMAGE_ID

4. Remove any dangling volumes from the Docker data root directory:

docker volume rm $(docker volume ls -qf dangling=true)

5. Identify the volumes being removed:

docker volume ls -qf dangling=true

NOTE
When you run the commands above to remove an image that is currently in use, you
will get an error. For self-hosted customers with internet access, any missing images
download again when you restart Jama Connect. For airgap customers, you'll need to
manually load the images.

View scheduled jobs
Some jobs can impact performance. When you view scheduled jobs, you can identify which jobs are
currently running, when jobs are scheduled to run, and how much memory they require. Knowing this
information helps you prepare for any performance hit.

1. Log in to Jama Connect as the root user [506].
2. In the Jama System Administration panel, select Scheduled jobs to view jobs, their group, class,

and firing time.

View applied patches
You might need to check which patches have been installed on your application server. For exam-
ple, you can see if any patches were missed, or you might need to let support know about your
current environment.

1. Log in to Jama Connect as the root user [506].
2. In the Jama System Administration panel, select Applied Patches to view the unique ID, run date,

and status.

Clear cache
If you notice latency or slow performance of Jama Connect, you can free up disk space and memory by
clearing the cache.

1. Log in to Jama Connect as the root user [506].
2. In the Jama System Administration panel, select Cache statistics.
3. Clear items from the cache:
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• All items — Select Clear all cache to clear all cache items from the cache.
• Specific item — Select Clear Cache on a specific cache item to clear it from the cache.

Reindex all search items
Search indexes get out of sync with the database due to large batch updates, API updates, or database
updates. During a full index, all search indexes are rewritten to the current values in the database.

NOTE
You must have system administrator permissions to complete this task while logged in
as root. While organization admins and project admins can index project items [661],
they can't index all search items.

Important considerations

• Files over 25 MB aren't indexed, so their content isn't searchable.
• Filetypes that can be indexed: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF.
• Filetypes that can't be indexed: XLSX, XLS, XML, HTML, HTM.
• During the index process, the application automatically enters maintenance mode [512]. Users can’t

log in during this time and users who are already logged in receive a message about the mainte-
nance.

To sync your search indexes:

1. Notify users before initiating an index.
2. Disable all integrations including legacy connectors and the Jama/Tasktop Integration Hub.

DWR, SOAP, and REST API calls are automatically blocked during the reindex.

NOTE
The system admin doesn't have access to disable integrations. Work with an
organization admin or integrations admin [641] to disable those services.

3. Log in to Jama Connect as the root user [506].
4. Select the Index/Search tab and select Index items.

The system displays a count of items in the application and the estimated time to complete the
index.

5. Select Yes to continue.

You see an alert when indexing is complete and maintenance mode is automatically disabled.

Folder locations
You can use an exported filesystem, such as NFS, for mounting the following directories, provided the
path remains the same. 

The following two directories are on the application server:

• /data
Stores physical artifacts, like attachments, reports, avatars, diagrams, and metrics. Exported file
systems, like NFS, are supported for use with the /data directory.

• /logs
Contains all log files of the Jama Connect components such as the following:
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• /logs/tomcat
Apache Tomcat log files, logs all activities [241] in the application

• /logs/tomcat/contour
Core Jama Connect log files

• /logs/elasticsearch
Elasticsearch log files

• /logs/search
Search service log files

• /logs/nginx
Nginx log files (note that currently only error logging is provided for Nginx)

NOTE
You cannot change the location where log files are written to, however, you can
change the appenders and logging levels for different components of the Jama Con-
nect application. The core Jama Connect application log configuration can be updated
in:

/data/log4jconfig/log4j.properties

The log configuration for Elasticsearch and search service can also be found in 

/data/config

Changes to these configuration files persist when you restart Jama Connect and are
applied in a few seconds.

IMPORTANT
Replicated snapshots are stored in the following location by default: 

/var/lib/replicated/snapshots

However, if you change the path to include /data it will be easier to include these
snapshots in your regular backups of Jama Connect data at /data/directory, as such:

/var/lib/replicated/data/snapshots

Note that /snapshots should have three times the space allocated as the rest of /data.

Upgrading from Jama Connect traditional to KOTS
Jama Connect is a Linux-based application that runs on Docker containers and uses Replicated
software to "orchestrate" deploying applications. The current version of Jama Connect uses Replica-
ted KOTS, while older versions use traditional Replicated software. The process of upgrading Jama
Connect from traditional to KOTS includes planning, preparing your environment, and installing the
software.

Upgrade scenarios
Upgrade with new servers (recommended) — This recommended scenario uses new application and
database servers to support your KOTS Replicated environment. It requires you to:

• Copy targeted data from the existing application server into the new environment.
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• Restore a backup of your current database to the new database server.

While this scenario results in the temporary overhead of supporting two separate environments, it
comes with less risk of unwanted downtime.

Upgrade with existing servers — This scenario reuses the current application and database servers
from your traditional Replicated environment. This scenario:

• Requires you to uninstall elements of the traditional Replicated platform before you can install the
KOTS Replicated platform. 

• Can cause significant maintenance downtime. Make sure to inform your users of this maintenance
window. Also have an emergency plan in place to revert back to the traditional Replicated environ-
ment if necessary.

Before you upgrade

• Contact your Customer Success Manager to request a KOTS internet or airgap license.
• Choose the upgrade scenario that works best for your organization. Whichever scenario you choose,

expect production downtime while the new instance is configured. Best to upgrade during off hours.
• Follow the instructions in the planning [684] and preparing [691] sections to ensure a successful

upgrade.

Components and what they do
Replicated KOTS — A container-based platform for easily deploying cloud native applications inside
customers' environments, providing greater security and control. The KOTS Admin Console is the
interface for installing, configuring, and administering the KOTS deployment of the Jama Connect
application and required services. See https://www.replicated.com/ for details.

Docker containers — A standalone executable package of software that includes code, runtime,
system tools, system libraries, and settings. See https://www.docker.com/resources/what-container/ for
details.

Jama Connect KOTS license — Contact your Customer Success Manager to request a KOTS license.
Save the license file to a location you can access easily; you will need it when installing Jama Connect.

For more information about KOTS, see https://www.replicated.com/blog/announcing-kots/

NOTE
Replicated KOTS is the only supported platform for Jama Connect 9.0 and later. To up-
grade Jama Connect traditional to KOTS, see Upgrade from Jama Connect traditional
to KOTS workflow [684].

Troubleshooting

NOTE
This information applies to self-hosted environments only.
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You can avoid troubleshooting by following regular maintenance practices [535], but if you run into
problems here are some resources that might help:

• For issues with installation, log in to Jama Connect as the root user [506], and select the System Info
tab to see a quick overview of your installation.

• View log and profile [546] 
• Clear cache [542]
• View scheduled jobs [542]
• Index all items [543]
• Remove old Docker images [541]
• Reconnect to the Wiris server [548]

Thread dump
A thread dump is a snapshot of the state of your Jama Connect processes at a point in time.

Jama Support might request a thread dump for troubleshooting performance issues.

Any time you generate a support bundle, the bundle includes three thread dumps taken at 5-second
intervals.

TIP
Take multiple thread dumps over an interval of time. A single thread dump on its own
doesn’t provide complete information about an issue.

You can create a thread dump from the command line or the from the Logging Configuration window.

Manually (command line) Logging configuration window [546]
jamacli jamacore-thread-dump Select Logging > Configuration

NOTE
You can create thread dumps only for containers that are the core Jama Connect
application.

View and configure logging
Log files record information from the application and can help with troubleshooting. Information is
captured in the contour.log file.

Entries in the log file are noted by the [jama.AccessLog] package and include this information:

• Date of request
• Server processing time to handle the request
• The user who submitted the request
• The organization ID of the user who submitted the request
• The user session ID of the user who made the request
• The server address that the request was made to
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Enabling the profiler logging enhances logging in Jama Connect. However, profiler logging might
require additional resources to generate this content. For best performance, use the profiler for trou-
bleshooting purposes.

The profiler prints out the following information:

• The user who submitted the call
• The organization the user belongs to
• The java thread ID of the call
• A stack trace of the call that includes processing time and memory usage of each trace

To view the log and configure logging:

1. Log in to Jama Connect as the root user [506].
2. Select Logging > Log Viewer to view the log. As needed, select Refresh at the top right to refresh

the log.
3. Select Logging > Configuration.

TIP
By default all logging levels are set to info and will reset to that default when the
application is restarted. 

To permanently change the logging level and appenders, edit the file:

/data/config/log4j.properties

The log configuration for Elasticsearch and search service can also be found in:

 /data/config

You cannot change the location to where log files are written. Changes to these
configuration files are applied within a few seconds and are persisted across
restarts the application.
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4. To change the logging level from the default setting of Info, select Edit.

5. To log additional content for every log entry in the contour.log file, scroll to the bottom of the page
and select Enable profiler under Profiling.

Profiling is indicated in the log file as the [jama.Profiler] package.
Here is a sample log entry:
2011-04-28 09:37:19,865 INFO [org.directwebremoting.impl.DefaultRemoter] - Exec: 
projectSvc.getExtTreeNodeForProject()
2011-04-28 09:37:19,869 INFO [jama.Profiler] - user:admin org:2 thread:96 start:2011-04-28 09:37:19,866
[3ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.Jama.dwr.impl.DwrProjectServiceImpl.getExtTreeNodeForProject
[3ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.contour.service.impl.ProjectServiceImpl.getExtTreeNodeForProject
[2ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.contour.service.impl.DocumentTypeServiceImpl.getAvailableDocumentTypesForProject

6. To capture information for all user requests and all locked-out users in Jama Connect, select
Access log, then select Enable access logging.
Information is captured in the contour.log file. Here is a sample log entry:
2014-08-29 16:24:59,370 INFO http-bio-8080-exec-17 [jama.AccessLog] - [3 ms] PRBDIJN9 1 - 
083BBE5B1E8C481033DA7AFBBEF023A5 160 http://localhost:8080/contour/

7. To capture a one-time dump of the current running java threads being executed, select Dump
threads information under Thread dump.
Information is captured in contour-threaddump.log.
This information is useful for identifying long running processes. If Jama Connect seems to hang,
run a thread dump and send the log file to .

Reconnect to the Wiris server (self-hosted only)
If your connection to the Wiris server is interrupted, you can fix the issue by modifying the Wiris
settings, restarting your system, then returning the settings to their original values.
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1. Modify the Wiris settings:
a. In the Admin Console, select Settings > WIRIS Connection Settings.
b. Select Use custom Wiris connection.
c. Make the following changes:

• Wiris Host — Add “xx” to the end of the string
• Wiris Path — Add “xx” to the end of the string
• Wiris Port – Change to 44311

d. Select Save and restart your system.
2. Test the connection. Use Jama Connect in a field that calls the Wiris MathType Editor:

a. In Jama Connect, select Projects, and select the item you want to modify.
b. From the Add drop-down menu, select New item > Text.
c. In the Add item window, select the Math Editor icon.
d. Add an equation using the equation editor. As expected, this action fails.

3. In the KOTS Admin Console, reset the modified Wiris setting to the original values.
4. Select Save and restart your system.
5. Test the connection. Use Jama Connect in a field that calls the Wiris MathType Editor:

a. In Jama Connect, select the item you want to modify.
b. From the Add drop-down menu, select New item > Text.
c. In the Add item window, select the Math Editor icon.
d. Add an equation using the equation editor. This action now succeeds

Organization administrator
The organization admin controls all aspects of configuring Jama Connect, including its users [573],
groups, content [550], collaborations [627], and integrations [641]. It is a role that can be assigned
to an individual or a group.

Most organization admin tasks are accessed under Admin in the top-level navigation. This heading is
only visible to users with organization admin privileges.

When you edit configurations on the organization admin pages, many changes require you to sign
out before they take effect. By default, Jama Connect creates a group called Organization Admin and
assigns it Administrator and Manage project rights to the organization.

Monitoring changes with the Admin Activity stream
The Admin Activity stream provides an audit trail of updates made by organization and project admins.

To open the Activity stream panel, select Admin, then click the Activity stream button on the right side
of the panel.

Search for activities by entering the search term, like the name of a pick list or the user who performed
the action.
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Managing content
There are many areas of the application that require organization admin permissions to set up and
maintain content for the broader group of users.

Some common tasks for managing content on an admin level include:

• Change Global ID
• Configure baseline status
• Unlock items locked by another user
• Configure reuse and synchronization

Change Global ID
A Global ID is a unique identifier of items that are connected through synchronization. While every item
has its own unique ID [648], two items that are synchronized can share a Global ID.

You can change or add a prefix, as well as an optional item type key, in front of the Global ID assigned
to items.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Details, then click Edit.  

Jama Connect User Guide

550



2. Select whether to allow multiple items with the same Global ID in a single project.
• Yes — One item can be synchronized with other items in the same project.
• No — (Default) Items can only be synchronized to items in other projects.

3. To change the prefix for your Global ID, click Edit next to Global ID prefix.

4. In the window that opens, enter a new value for the prefix and select the options you need.
• Change only future prefixes — Change the Global ID Prefix and click Update. No current IDs

are affected. Future IDs include the new prefix.
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• Change ALL prefixes (past and future) — Select Apply prefix to existing items, then click
Update. All existing prefixes are changed if they match the old prefix, and new IDs contain the
new prefix. If the past Global IDs didn't have a prefix, the new prefix is appended to those IDs.

• Include item type in the global ID — Enter a new prefix value and select Include Item Type
Key, then click Update .

5. To change the value for the Global ID next counter, click Edit next to Global ID next counter.
6. Set the counter that assigns Global IDs, then click Update. If you set the counter to a value that's

being used, the counter uses the next available ID as its starting point when the next item is
assigned.

Your changes appear on the Organization Details page.

Configure baselines status
Once you create a baseline-specific pick list, you can enable the baseline status to be able to select the
pick list. The baselines status pick list can’t be edited after you configure it.

From Admin > Pick lists, you can edit the pick list that's in use but you can't delete it. You can,
however, disable the pick list when you no longer need it.

NOTE
You must have organization admin permissions to complete this task.

To enable and configure the baselines status:

1. Create a dedicated pick list that is used only for baselines.
2. Select Admin > Details, then next to the Baselines status option, click Configure.
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3. In the Configure baselines status window that opens, select Enable baselines status pick list,
then choose the baseline pick list you created.

4. Click Save.
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Once the pick list is enabled, users can apply this option when editing a baseline. The pick list values
appear in the Baselines List View and View details headers.

Unlock items locked by another user
You must have organization and project admin permissions to unlock items that are locked by another
user.

NOTE
Project admins can only batch unlock items from List View and Single Item View.

To unlock items that others have locked as an organization admin:

1. Select the link with your name in the header to open the My profile window. This button is disabled
if you selected Admin in the header.

2. Select the My locked items tab and select Show All Locked Items.

3. Locate and select the item in the list you want to unlock. then click Unlock.

To unlock items that others have locked as a project or organization admin:

From List View

1. Select the item you want to unlock, then click Batch edit.
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2. In the Batch update window, select Locked Status > Unlock all items, then click Next.
3. (Optional) Add a comment and notify users.
4. Click Commit.

From Single Item View

• Select the item you want to unlock, then click the Unlock item icon.

TIP
If you are an organization or project admin, you can also access the system-locked
items tab to unlock system-locked items [555].

Unlock system-locked items
Anyone can view the list of system-locked items, regardless of permissions. However, only an organiza-
tion or project admin can unlock items that are system-locked.

• Organization admins can unlock all system-locked items.
• Project admins can unlock only system-locked items where they have admin permissions to those

items.

To unlock system-locked items:

1. Select your name in the header to open the My Profile window.
2. Select System Locked Items to see all items that were automatically locked [234] (blue lock).
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3. Select the items you want to unlock, then click the Unlock icon in the top right corner of the
window.

Configuring reuse and synchronization
You must have write permissions [589] to modify items through synchronization. Items with a user
lock [554] or system lock [555] can't be modified through synchronization.

NOTE
You must have organization admin [549] permissions to complete this task.

As an organization admin you can:

• Grant permissions to a reuse admin [589]
• Configure global ID [550]
• Sync or remove Compare Views [336]
• Enable synchronization of widgets [611]

View a system health report
The system health report is an optional feature that notifies you of areas in the application that can
affect performance and user experience.

Important considerations

• Projects that are too large, reports that contain too many items, and syncing too many items at a time
are just a few of the things that can slow Jama Connect down and cause problems. This report can
be emailed to designated users weekly.

• We recommend that reviews contain fewer than 250 items. This threshhold is in place to mitigate any
performance issues that could come from a review with an excessive amount of items.

NOTE
You must have organization admin permissions to view the system health report.

To view a system health report:
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1. To view the report, select Admin > Organization, then select System health report.
2. Select Add or change recipients to specify who receives the report.

3. To set a threshold for each of the areas (Projects, Reviews, Reports, and Test Plans), click Edit the
threshold.

Plugins
Plugins provide tools that help speed up the process for setting up Jama Connect.

NOTE
You must be an organization admin to complete this task.

You can install two plugins:

• User import plugin [562]
• Import relationship plugin [557]

Configure the Import Relationships Plugin
The Import Relationships Plugin helps you batch create relationships between existing items in the
application.

NOTE
You must have organization admin permissions to complete this task.
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Important considerations

• Before you use the Import Relationships Plugin in Jama Connect, you must first create a direct
relationship between the items you plan to link. Otherwise, the linking might fail. For example, when
you link use case item types to test case item types, you must first define a relationship rule for that
project. For more information, see Set up relationship rules [622].

• For information on how to use the Import Relationships Plugin, see the Relationship Plugin Tutorial

To configure the plugin:

1. Select Admin > Organization, then select Plugins > Add plugin entry.

2. In the Add plugin entry window that opens, enter the following information and click Save.

• Name — Enter a name you visible to users. For example, Import Relationships.
• Enabled — Make the plugin available to users.
• Class (case sensitive) — Enter the name of the object defined in the source code.  

For a single project enter:

com.jamasoftware.contour.plugin.jama.ImportRelationships

For cross-project imports enter:

com.jamasoftware.contour.plugin.jama.ImportRelationshipsCrossProject

• Type — Import
• Parameters — Set relationship parameters [559]
• Plugin notes — Add any notes you have here. This isn't visible to end users.

3. When the information is correct, click Save. 
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TIP
For a sample entry of a cross-project import, see Set relationship parame-
ters [559].

Setting relationship parameters
Depending on whether you want to import relationships in a single project or multiple projects, there are
four or six parameters to define.

NOTE
You must have organization admin permissions to set relationship parameters.

Cross-project import sample entry
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These parameters are used when configuring the Import Relationships Plugin [557]:

• parentType: Defines which item type to use for the parent (upstream) relationship.
• childType: Defines which item type to use for the child (downstream) relationship.
• parentField: Defines which field to use to find the the parent (upstream) item.
• childField: Defines which field to use to find the child (downstream) item.
• parentProjectId: Defines the project that contains the parent (upstream) item. Only for the cross

project plugin.
• childProjectId: Defines the project that contains the child (downstream) item. Only for the cross

project plugin.

Parameters can be written in any order, as long as they follow correct formatting. Each parameter is
case sensitive and requires a semicolon at the end.

Gathering parentType and childType values
To specify the item Types, you need the API IDs of the item Types to be related. You can find the API ID
under Admin > Item Types.
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For example, if you wanted to create relationships for upstream Requirements to downstream Use
Cases, you join the item Type with the corresponding API-ID:

parentType=24;

childType=25;

Gathering parentField and childField values
The CSV file used for import needs to contain an identifying field for each item, such as the Name or
Global ID. To specify which field in the parent and child item will be used for this identification, use
the system Field value. You can see which fields are available to use under Admin > Item Types >
[Highlight the item type to be used] > Edit.

For example, if you wanted to use the ID (also known as the Unique ID) for your parentField and
childField, your parameters need to join the field type with the field value:

parentField=documentKey;

childField=documentKey;
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Gathering parentProjectId and childProjectId values
To specify which projects the parent and child items are associated with, you need the API-IDs of both
projects. You can get the project API-ID under Admin > Project > [select the project to be used] >
API-ID.

For example, if you wanted to import relationships between a parent project with API-ID 20258 and a
child project with API-ID 31548, your parameters need to join the item with the corresponding project
API-ID:

parentProjectId=20258;

childProjectId=31548;

Configure the User Import Plugin
With the User Import Plugin, you can add multiple users at once by importing a spreadsheet. Imports
don't delete users from Jama Connect.

NOTE
You must have organization admin permissions to complete this task.

Important considerations
If the import fails it might be because:

• A user that already exists was set to add (rather than update).
• A user that doesn't exist was set to update (rather than add).
• One or more of the records is incorrect.
• A required field was missing.

To configure the plugin:
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1. Select Admin > Organization, then select Plugins > Add plugin entry.

2. In the Add plugin entry window that opens, enter the following information and click Save.

• Name — User Import
• Enabled —Make the plugin available to users
• Class (case-sensitive) — Enter the name of the object defined in the source code: 

com.jamasoftware.contour.plugin.jama.UserImportPlugin

• Type — Event or Import
• Parameters — Leave this field blank
• Plugin Notes — Add any notes you have here. This isn't visible to the end user.

3. Create a CSV document with no header row that contains the following values in columns A
through K:
• Username — If LDAP or CROWD is enabled, the username must match what is listed in the

directory.
• First name
• Last name
• Email
• Password
• Title
• Location
• Phone number
• License type — Values must be one of the following:

Jama Connect User Guide

563



Value Meaning

N Named creator

C Float creator

FC Float collaborator

S Stakeholder

R Reserved collaborator

V Float reviewer

RV Reserved reviewer

NV Named reviewer

TR Test runner

• Add/Update — Values must be one of the following:

Value Meaning

Add Add as a new user

Update Update an existing user

• Company
• Groups — If a user belongs to multiple groups you can add them in columns L and up.
For example:

4. Select Project > Import > Custom import.

5. In the Custom Import window that opens, enter the following information:
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• Select a destination — This is a required field. Your selection doesn't affect the outcome.
• Select Custom Importer — User Import
• Field Delimiter — Comma
• Optional Encoding — UTF8
• Select file to import — Choose the CSV file you created in step 3, that contains the list of users

to be imported.
6. Click Import.

Each user that's added with the user import plugin receives a welcome email with the Jama Connect
URL.

Upload custom reports or exports
You can upload reports [414] or exports [344] so that other users can access them.

Self-hosted — For BIRT and Velocity reports, only self-hosted customers with system, organization, or
report admin permissions can complete this task.

Important considerations

• If uploading a Velocity or Office Template export that uses preselected (context-sensitive) data in the
main project view, the exports appear under Exports > View all export options.

• If uploading Velocity reports that pull data at a project or cross-project level, the exports appear under
Reports in the Jama Connect header. For more information, read about Jama Connect and Velocity
here.

• Report criteria is unique to each report. Before uploading a report or export, check with the person
who created it about the best settings to use.

• For templates with Microsoft Word or HTML formats, you can also export to PDF. For Velocity
and HTML templates, PDF export results might vary. For more information, see Quick Start: HTML
Templates for Velocity PDF Reports.

• For Office Templates, any user with a creator license can add a custom export [353], which appears
under Export > View all export options.
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To upload custom reports or exports:

1. To add or edit a report:
• (Self-hosted only) For BIRT reports, log in as root user [506] and select Reports.
• For Velocity or Office template reports, select Admin > Reports. 

2. Click Add report in the top right corner.
3. In the Add/Edit Report window that opens, define the report. Available options depend on the type

of report you choose.

• Report Name — Enter a name so that others can identify the custom report or export template.
• Report Type — Select BIRT, Velocity , or MS Office Template.
• Report Formats — Select HTML, PDF, Microsoft Word, or Microsoft Excel.
• Excel Format — Select XLS format (legacy) or XLSX format.
• Data Access — Select Limit data availability or Allow all data to be reported on regardless

of user permission.
• Restrict to Group — Select whether and how to limit access (by user permissions or user

group) to run custom reports.
• Report File Name — Click Browse and select the report or export template to upload. BIRT

reports have file extension .rptdesign and Velocity reports have file extension .vm.
• Description — Enter an optional description to define the output.
• Scope — Define whether the report or export template is available to all users (Organization) or

only to users in a particular project (Project). Default for Jama Connect reports is System.
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• Organization — Select the organization from the drop-down menu.
• Visible to Users — Select Visible to Users if you want other users to see the report.
• Context Sensitive — Select Context Sensitive if you have an export that uses preselected

(context-sensitive) data in the main project view.
This export appears in the window that opens when users select Exports > View all export
options.

• Class name and path — Enter the class name and path for custom plug-ins for BIRT or
Velocity reports. Otherwise, leave blank.

4. In the Criteria section, click + to add report criteria.

a. From the Select Parameter Type drop-down menu, select the type of data you want to
include.
• Release — Select the project release parameters as needed.
• Location — Select a location for each parameter.
• Baseline Parameter — Select one baseline for each baseline parameter.
• String Parameter — Enter the string parameter.
• Date Parameter — Enter the date.
• Boolean — Select True or False. The value is sent to the reporting engine.
• Test Plan — Select a test plan from the list of test plans in the selected project. Jama

Connect passes the database ID to the report.
• Review — Select a review from the list of reviews in the selected project. Jama Connect

passes the ID to the report.
b. Under Display, enter the label you want users to see when publishing the report and exporting

from Jama Connect.
c. Under Name, enter a unique case-sensitive name that is passed to the report or export

template.
When you publish a report or export Jama Connect content, these parameters are displayed in
alphabetical order by the name field, not in the order shown in the report setup screen.

IMPORTANT
If you change the Name criteria, you must also change the reference to the criteria
in your report or export template. Otherwise, the report or export template fails.

5. Click Save to upload the report or export template and save your changes.

The report or export is saved and appears in the Reports table.

Managing relationships
As an organization admin you can use several tasks to manage relationships.

• Edit relationship widget [611] in an item type
• Set the relationship types [568]
• Configure the Import Relationships Plugin [557]
• Set up relationship rules [571] at an organizational level
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Configure relationships
Before setting up relationships (traceability) between your artifacts, you need to set up the types and
options available to users.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Relationships > Edit.

2. To change the relationship options from No to Yes, select each option:
• Show Status in Relationship Grid?
• Show Note in Relationship Grid?
• Allow relationship changes between two locked items?
Note and Status columns are added to the table in the bottom panel. The Note and Status fields
are only editable when the relationship type is set to Show Note and Show Status.

3. Configure relationship types:
a. In the Relationships widget of an item, double-click on a relationship to edit its type, direction,

status, and note.
b. Use the toolbar at the top of this panel to edit, add, or delete types.
c. Include a description to specify how and when this type is used.

4. Set up relationship rules [571].

Set relationship types
One part of the initial traceability setup is configuring the available relationship types.

NOTE
You must have organization admin permissions to set relationship types.

1. Select Admin > Organization, then select Relationships.
2. Under Relationship Types, use the icons to add, edit (pencil), delete (X) or reorder (arrows)

relationship types.
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3. When adding a new relationship type, enter a display name and description. The description is only
visible in this edit window.

4. (Optional) Select Show Note and Show Status to allow users who create a new relationship using
this relationship type to enter a note and a status for that relationship.
Status and notes are visible any time you reopen the Add/edit relationship window. Also, when
notes and status are enabled under Relationship Options...

... you see them in the bottom panel of Single Item View when Relationships is selected.
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You can also filter by status or note in an impact analysis [317].

5. If you delete a relationship type, choose a replacement type for affected relationships.
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Set up relationship rules
Relationship rules help maintain the project structure by preventing problems with relationships [307].
The rules help users know when relationships are required and in which directions.

NOTE
You must have organization admin permissions to complete this task.

When relationship rules are set up, the Relationship Status Indicator [308] alerts users to easily see
when their relationships don't match the relationship rules. 

Rule sets are created at the organization level, and can then be applied to one or more projects.

To set up relationship rules:

1. Decide with your team which relationships to include, the relationship types, and whether
the rules are exclusive and included in coverage calculations for the project.

2. Select Admin > Organization > Relationships and scroll down to the section labeled Relation-
ship Rule Configuration to see any previously created rule sets.
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3. Scroll to the bottom and select Add rule set.
a. Select New Rule Set and edit the name to describe your set.

b. Add a rule by selecting the item type for Upstream, Downstream, and Relationship type
from the drop-down menus. Select For coverage if you want this relationship included for
coverage.

NOTE
Configure the same rule set across projects that share relationships. If you
relate items across projects with different rule sets, the source project's rule
set is applied.

c. Click Save.
As the rule is saved, it is added to the diagram, indicating the relationship.

d. (Optional) Click Add another relationship to include another relationship for this rule set.
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As rules are created, the diagram is updated to show the relationships. Solid lines between
items indicate a coverage (required) relationship. Dashed lines indicate relationships that
aren't for coverage.

TIP
Once you've set relationship rules for a project, you can also view the rela-
tionship rules diagram in Single Item View or on the dashboard [157].

4. To delete a rule, select the X at the end of the rule's row. To delete an entire rule set, select the X at
the top right of the rule set. After editing or deleting a rule, the rule set diagram is updated with any
changes made.

5. Click Add project to apply the rule set to one or more projects. If a rule set is applied to a project
with existing items, nothing changes in that project, even if the existing relationships break the
new rules. Only future relationships are required to conform with the rule set. 

IMPORTANT
A project can have only one rule set. If a rule set has already been applied to a
project and you try to apply another, the application removes the first rule set from
the project and applies the second one.

6. (Optional) Select Allow any item type not mentioned in this rule set... to allow users to cre-
ate relationships outside the rule set you applied to the project.

Rules are between item types. If you don't define a rule for a particular item type, that item type can
have a relationship with anything (or nothing if the user chooses), even if the rule set is exclusive.

Managing users and groups
Organization admins and user admins can can set up user access for your organization.

• Add user groups [574]
• Add users [576] and assign them to one or more groups
• Edit user details [582]
• Edit user subscriptions [582]
• Reset user password [583]
• Open projects and assign users and groups access rights [664]

You can also assign this task to a project administrator.

Jama Connect User Guide

573



User groups
User groups are an efficient way to manage notifications, permissions, access, and actions for multiple
users at a time.

A user can be assigned to multiple groups.

Groups allow you to efficiently accomplish many tasks:

• Grant access permissions [589]
• Grant role permissions [591]
• Initiate a review [166]
• Subscribe users to items [229]
• Notify users of changes [228]
• Send workflow notifications [653]
• Grant access to projects workflow [615]
• Add signer roles to reviews [259]

Types of groups
Jama Connect includes two types of groups:

• Organization group — These groups have no project context and are available to all projects in the
organization when adding permissions.

• Project group — These groups are created in the context of a project and are available to that
specific project when adding permissions.

Jama Connect comes with several predefined organization groups and project groups. For example, the
group Organization Admin is a default group that has organization and project rights.

Group names
You can create and name groups based on users' roles, permissions, or position. For example, you can
name groups by:

• Internal structure — Job title, work group
• Access permission — Read only, read/write
• Roles — Reuse admin, review admin, project admin

NOTE
If you use signer roles [259] for electronic signatures [257], signer roles for electronic
signatures, the group name is used as the signer role.

Actions for each admin type
The type of admin you are determines your ability to manage groups:

• Organization admin — Add, delete, and edit user groups available to all projects.
• System admin — Add groups.
• Project admin — Add groups at a project level.
• User admin — Manage members of a group where you are also a member.

Add a user group
With user groups, you can efficiently manage notifications, permissions, access, and actions for multiple
users at a time. A user can be assigned to multiple groups.
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IMPORTANT
If this is a new installation of Jama Connect, create user groups before adding individu-
al users.

Important considerations

• Organization admins and system admins can add user groups that are available to all projects.
• Only organization admins can delete user groups or make changes to an existing group's members,

details, or subscriptions.
• Project admins can add groups at a project level [662].
• User admins can manage members of a group only where they are also a member. This restriction

ensures they don't unintentionally provide or remove access to unknown or existing projects

To add a user group:

1. Select Admin > Organization > User groups, then select Add group.

NOTE
A user's membership in project groups determines which groups are available for
signer roles.

2. In the Add group window that opens, enter a name and description for the group, and select
members from the left column. Large lists are searchable.
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Selected users appear in the right column.
3. Click Save.

The new group appears in the list of user groups. Now, a review moderator can edit a review and give a
user a signer role [259].

Add a user
When you add one user to Jama Connect, you define the username and license type, assigne the user
to groups, and optionally generate an email with the account information.

If you install and configure the user import plugin [562], you can add multiple users at the same time.

If this is a new installation of Jama Connect, add user groups [574] before adding users.

NOTE
You must have organization admin or system admin permissions to complete this task.

To add a single user:

1. Select Admin > Organization, then select Users to display a list of active users.
If you don't see the user you're looking for, select View inactive users.

2. If LDAP is enabled [521], you can select Add user from LDAP and search for an existing LDAP
user in the search box.  Jama Connect searches LDAP against the configured "Login Name
Attribute" and the "User Name Attribute." You can add wildcards to a search, but if you add them at
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the beginning of a search term, they can result in slow performance. For large directories, expect
several minutes.

3. From the toolbar, select Add user.

4. In the Add user window that opens, fill in the required fields, then select Save.

• Username — Enter a unique name, as in an email address (recommended).
• License type — Consider the number of licenses purchased [583] and the expected us-

age [585] by the user when assigning license types.
• User groups — Select the appropriate groups for this user.
• Send user welcome email — (Optional) Send an email to the user with username, password,

and URL to log in to the system.

Configure the User Import Plugin
With the User Import Plugin, you can add multiple users at once by importing a spreadsheet. Imports
don't delete users from Jama Connect.

NOTE
You must have organization admin permissions to complete this task.

Important considerations
If the import fails it might be because:

• A user that already exists was set to add (rather than update).
• A user that doesn't exist was set to update (rather than add).
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• One or more of the records is incorrect.
• A required field was missing.

To configure the plugin:

1. Select Admin > Organization, then select Plugins > Add plugin entry.

2. In the Add plugin entry window that opens, enter the following information and click Save.

• Name — User Import
• Enabled —Make the plugin available to users
• Class (case-sensitive) — Enter the name of the object defined in the source code: 

com.jamasoftware.contour.plugin.jama.UserImportPlugin

• Type — Event or Import
• Parameters — Leave this field blank
• Plugin Notes — Add any notes you have here. This isn't visible to the end user.

3. Create a CSV document with no header row that contains the following values in columns A
through K:
• Username — If LDAP or CROWD is enabled, the username must match what is listed in the

directory.
• First name
• Last name
• Email
• Password
• Title
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• Location
• Phone number
• License type — Values must be one of the following:

Value Meaning

N Named creator

C Float creator

FC Float collaborator

S Stakeholder

R Reserved collaborator

V Float reviewer

RV Reserved reviewer

NV Named reviewer

TR Test runner

• Add/Update — Values must be one of the following:

Value Meaning

Add Add as a new user

Update Update an existing user

• Company
• Groups — If a user belongs to multiple groups you can add them in columns L and up.
For example:

4. Select Project > Import > Custom import.

5. In the Custom Import window that opens, enter the following information:
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• Select a destination — This is a required field. Your selection doesn't affect the outcome.
• Select Custom Importer — User Import
• Field Delimiter — Comma
• Optional Encoding — UTF8
• Select file to import — Choose the CSV file you created in step 3, that contains the list of users

to be imported.
6. Click Import.

Each user that's added with the user import plugin receives a welcome email with the Jama Connect
URL.

Add users to multi-mode authentication
Multi-mode authentication allows you to add a new Basic user, so you can differentiate between IdP
and Basic users.

NOTE
You must have organization admin permissions to complete this task.

Important considerations

• Authentication methods must match to use electronic signatures in baselines and reviews. An organi-
zation admin can change authentication methods.

• Users can't use the same email between the two different authentication types.

To add users to multi-mode authentication:

1. Select Admin > Organization, then select Users to display a list of active users.
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2. Select Add user.

3. In the Add user window that opens, select the authentication type you want for this user:
• Basic authentication — Select Use basic authentication for this user.
• IdP authentication — Deselect Use basic authentication for this user.

4. Click Save.

Jama Connect runs a check to see which authentication method was used. Initially, the Authentication
Type for the user you added is blank. When they log in for the first time, the column is populated with
Basic or IdP.

You can also verify the Authentication Type from Admin > Organization > Users.
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Edit user details
Depending on your organization's type of authentication, you can edit basic details for Jama Connect
users.

NOTE
You must have organization or user admin permissions to complete this task.

1. Select Admin > Organization, then select Users to display a list of active users. If you can't find
them, select View Inactive Users.

2. Select Edit in the Action column of the user you want to edit.

3. In the Edit User window that opens, make changes to the user's details as needed.
4. Click Save.

Edit user subscriptions
Users can subscribe to and control their own email notifications. However, if a user's subscriptions were
added by someone other than the user, only an admin can make changes.

Organization admins can unsubscribe a user; project admins can only mute a user's subscriptions.

NOTE
You must have organization or project admin permissions to complete this task. 

To edit a user's subscriptions:
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1. Select Admin > Organization, then select Users.
2. Select Subscriptions in a user row to open the Edit subscriptions window.

3. Select a user from the left column to display their current subscriptions in the right column.  
• To remove a single subscription, click Unsubscribe in the Action column.
• To remove multiple subscriptions for a user, select the subscriptions in the Notifications column,

then click Unsubscribe selected in the top right corner.
4. To edit a group subscription, select Admin > Organization > User groups > Subscriptions.

Reset user password
If your organizations is using Jama Connect with basic authentication, you can update users' pass-
words as needed.

NOTE
You must have system, organization, or user admin permissions to complete this task.

1. Select Admin > Organization, then select Users to view a list of users. If you can't find the user
you want, select View Inactive Users.

2. Select Password in the Action column for the user needing a new password.
3. In the Edit password window that opens, enter and confirm a password that meets the default

authentication requirements.

License types and permissions
Organization admins and user admins assign license types to users. They can also view the current
license [587] assigned to users, as well as assign users license types [582].

The type of license limits the possible permissions and roles that can be granted to a user. License
types include creator, stakeholder, test runner, and reviewer.

Regardless of the assigned license type, each user has a unique login consisting of username and
password.

Creator and reviewer licenses can be named licenses or float licenses; test runner licenses and stake-
holder licenses are named only.

Types of licenses

License type Definition Named li-
cense

Float license

Creator Gives full read and edit rights and full access to reviews to active
users who daily manage items and projects.

X X

Test runner Gives basic permissions to read and review, as well as the ability
to create test plans and defects, to execute test runs, and to add
attachments to test runs during execution.

X
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License type Definition Named li-
cense

Float license

Stakeholder Gives read-only privileges to those who need visibility into a project,
but don’t need editing rights. Stakeholders can view items, provide
comments, and act as reviewers.

X

Reviewer Grants permission to participate in reviews, act as approver, moder-
ator, or review admin, and to respond to comments in the stream.
Reviewers can't initiate reviews or access items in the core project.

X X

Temporary A 30-day full creator license automatically granted to a non-licensed
individual, invited by email to a review or to comment in the stream.
The only default permissions are for the discussion thread or review
to which they were invited.

X X

Collaborator
(Legacy)

A legacy license; gives read-only privileges to users needing visibility
into a project, but not editing rights. They can view items, provide
comments, participate in (but not create) reviews, execute test runs,
and log defects.

X X

Permissions by license type
The type of license assigned to you defines your permissions, which in turn determine your ability to
create and edit items and to access items as read-only.

With a creator license and read-only permissions to a project, you can:

• Execute test runs
• Log defects from the test run execution window

* Permissions that are included with each license type.
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Configure Jama Connect for test runner license
Users with a test runner license can manage attachments and relationships, and edit only certain items
for tests such as test plans, cycles, groups, runs, and item types used as defects [362]. User with a test
runner license don't have permissions to manage attachments and relationships, or to edit items in the
rest of the project.

NOTE
You must have organization or user admin permissions to configure Jama Connect for
the test runner license type.

1. Configure item types to be used as a defect [613].
2. Assign access permissions [589].

Batch update license types
Occasionally, you might want to update many users at once. For example, several users might be
assigned a temporary license that's about to expire and you need to assign creator licenses.

If you select more users than the available number the selected license type, that license type isn't
available when batch updating.

NOTE
You must have organization or user admin permissions to complete this task.

1. Select Admin > Organization, then select Users.
2. Sort the users by license type by selecting the field name header at the top of the user grid.
3. Select the users you want to update. Use Shift or Cmd-click to select multiple users.
4. Right-click or Ctrl-click and select Batch Update User(s).

5. In the window that opens, select the license type, then click Commit.

Monitor license usage

NOTE
You must have system, organization, or user admin permissions to complete this task.

1. Select Admin > Organization, then select License.
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The center panel displays the daily usage by license type for a particular time period, as well as
detail of current usage.

2. Use the menus in the header to select the type of license and the time period you want displayed.
You can view stats from the last 7, 30, or 90 days, including the number of licenses being used on
a daily basis, the number of days where you reached your maximum threshold, and if any users
were downgraded in license type or denied access due to a lack of license availability.

3. Click on one of the chart lines to see an hourly breakdown of license usage throughout that day.
From the hourly view, select a specific hour of the day to see a minute-by-minute breakdown.

NOTE
This chart shows a live look at license usage at the time the page is loaded or
refreshed. The data is stored in UTC time, however the chart display converts the
data to match the user’s time zone by applying the appropriate offset.

Daily

Hourly

Minute-by-minute

Scroll down to see all of your license information such as license type, expiration date, how
many licenses are owned, as well as any integrations the organization has purchased. For more
information, see View license [587].

4. To adjust the threshold, select Threshold (gear icon), make your changes, then click Save.
5. (Optional) Select Notify me when this threshold is met and enter an email address to send

notifications when usage surpasses a specified threshold. 
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6. (Optional) To download your license data usage to Excel, click Export, select the destination for
the exported file, then click OK.

View license
View details about your license, such as the type and its expiration date.

NOTE
You must have system, organization, or user admin permissions to view the licenses. 

• To view your current license information, select Admin > Organization, then select License.
A CSV export is available for analyzing license usage trends within Excel. The exported data repre-
sents a UTC time zone.
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For organizations with floating licenses, information about float license usage is available above the
table (more information is available here [585]).
The table provides details about the license, such as the type and expiration date. Counts are also
provided by specific user license type, as shown in this example:
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Grant permissions
Permissions control how users experience Jama Connect. They allow users to access, modify, and
delete items or to perform other specific tasks. They also restrict actions that users can perform or
content users can see.

NOTE
You must be an organization or user admin to grant most permissions.

System admins grant limited permissions.
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Important considerations

• Project admins [664] grant only project-level permissions. Project admins can access users outside
of their project to give access when the option Allow project administrators access to all users
and organization groups is enabled.

• Before assigning permissions, consider setting up groups [574] to make this task more efficient.
• Permissions are inherited from higher levels in the organization structure. For example, if you assign

a group access at the organization level, all projects, components, and sets within the organization
inherit the permissions.

• When a group or user's Inherited column contains the value "true" and is highlighted in green, that
user or group has received its permissions from a higher level.

• Certain permissions are allowed with each license type [583]. You might need to assign the correct
license type [582] to change permissions. Also, be aware of how permissions work with related
items [307].

• If a user is part of multiple user groups with conflicting permissions, the user is granted the highest
permissions that are set.

• While items within sets fall under the permission rules of the set, attachments to those items don't.
Attachments can still be accessed by outside users who have access permission to the project
while adding attachments [89] or inserting rich text links [94].

To grant permissions:

1. Select Admin > Organization, then select Permissions.

2. In Project Selector on the left, select the level where you want to access permissions.organization,
an individual project, or container, depending on the level you want to grant permissions. 
• Organization (System)
• Individual project
• Container
The main page displays the current permissions.

TIP
Permissions set at the organizational level are passed on to lower levels, but
might be overridden for individual projects, components, or sets. For simplicity, set
permissions at the highest acceptable level.

Organization admins can also grant project permissions in the configure project
window [664].

3. To edit current user or group permissions, select Modify or Override.
4. To add a new user or group, select Add permissions in the top right corner of the window.
5. In the Assign permissions window that opens, select the groups or users you want to add.

Jama Connect User Guide

590



You can also add a new group or user by selecting Add user or Add group in the top right corner
of the window, then select the role or access permissions [666] you want to add from the bottom
of the window.

NOTE
Roles [591] and access permissions can be granted at an organizational level.
Project administrator permissions can be granted at a project level. Access per-
missions can be granted at a container level and greater. 

6. Click Save.
7. To completely remove access to a project, component, or set, select Remove at the level that

access was granted by unselecting all permissions.

IMPORTANT
Remove functions differently at lower levels in the hierarchy. If the user's or
group's permissions were previously overridden at that level, the Inherited col-
umn reads "false," and selecting Remove reverts the permissions to the original
inherited permissions. If the user's or group's permissions weren't previously over-
ridden, the Inherited column reads "false," and selecting Remove completely
removes the group or user from a project or set. If the group or user's permissions
are inherited, the Inherited column reads "true" and permissions can only be
removed at the higher level where they were assigned.

Roles
A role is a set of permissions that allows a user to perform specific functions. Each permission type
defines the functions it allows.

An admin grants permissions by role [669] to an individual or to a group.
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NOTE
Permission roles are different from other types of roles such as review roles [162] and
Signer roles [259].

Types of roles

Role Definition

System admin [489] 

(self-hosted only)

Handles installation, setup, and configuration of Jama Connect, and has no access to projects.
System admin is a special user that isn’t a role for other users. It doesn't require a license and
logs in to the system with the username "root."

Organization admin [549] Controls all aspects of configuring Jama Connect, its users, and its groups.

User admin [573] Manages licenses, users, and groups; can see all users and organization groups in the system.

Process admin [593] Configures content and connections within Jama Connect; controls item types, pick lists, relation-
ship rules, Review Center, and workflow; delegates these responsibilities to appropriate users
and groups.

Project admin [643] Focuses on permissions, project groups, and workflow customization.

Add Project Allows a user to create a new project or duplicate an existing project where that user is project
admin.

Review admin [192] Has access to a review's content when the review is public. A review admin is also a reviewer,
approver, or moderator in the review. Permissions must be assigned by an organization admin.

Reuse admin [322] Manages reuse. Requires read access to the synchronized items they are working with, and write
permissions to edit, synchronize, reuse, or duplicate those items.

Report admin [565]

(self-hosted only)

Allows the report developer to upload and manage BIRT, Velocity, and Word templates. Reports
are assigned to specific projects where the report admin has project management rights.

User admin limitations

• Can set permissions only for groups/users on projects where they are project admin.
• Can manage organization group membership only for groups where they are a member.
• Can't make changes or additions to users or groups that have been assigned to organization or

process admins except for activation/deactivation and license management.
• Can manage only members of a group where they are also a member. This restriction ensures they

don't unintentionally provide or remove access to unknown or existing projects.

IMPORTANT
Users must have the license type [583] that allows for the permissions granted with
each role.

Deactivate and reactivate users
Users can't be deleted from Jama Connect but they can be deactivated. When you deactivate a user,
the user becomes inactive and frees up named assigned licenses associated with that user.

IMPORTANT
You must have organization or user admin permissions to deactivate a user.
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1. Select Admin > Organization, then select Users. 
2. In the Action column for the user you want to deactivate, select Deactivate.

Deactivated users disappear from the list until you select View inactive users.
3. To reactivate a user, select Activate, then select a license type in the User license type window

and click Save.

Managing process
Jama Connect can be configured to align your processes and artifacts to suit your unique organization
needs. You can control fields, picklists, relationships, templates, and workflow.

These settings tend to evolve over time as teams mature and new groups are brought into Jama
Connect. The admin role delegates these responsibilities to the appropriate users and groups.

• Item types [607]
• Fields [593]
• Set up editor templates [616]
• Configure views [617]
• Manage relationships [618]
• Manage tests [626]

Fields
A field holds a basic unit of data in an item type.

Fields contain values. In List View, each column represents a different field. Individual users can
configure which fields they see. For more information, see Configure Compare View for synchronized
items [340] and Configure fields [48].

An organization admin can add new fields to an item type [595] and configure the behavior for those
fields.

Jama Connect includes these types of fields:

Field type Description Created by...

Predefined fields Fields that are indexed and can be searched without using the
database field name.

Organization admin

Custom fields Fields that are similar to predefined fields, or can be multi-
select fields, URL fields, calculated, rollup, and item of type
fields.

Organization admin

System fields Fields that are necessary for system functionality and can't be
removed from an item. For example, Name, test steps [365],
test case status [368], and review status [155].

Automatically generated

TIP
Predefined fields are similar to custom fields. If you plan on doing a lot of reporting with
your data, predefined fields simplify the document type's underlying schema and make
it easier to use those fields in reporting.
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Predefined fields
An organization admin can add predefined fields [593]. They are indexed and can be searched without
using the database field name.

If you frequently use reporting with your data, predefined fields simplify the document type's underlying
schema and make is easier to use those fields in reporting.

When adding fields [595], you must select the database location where the lookup value is stored from
predefined fields. This selection doesn't affect users. However, custom report writers must know the
mapping of the fields to the database.

These are the predefined fields you can choose:

Type Details

Text Rich text can be enabled in text fields.

Dates Each field (date1 through date5) limits the user entry to a valid date and provides a pop-up calendar
picker.

Integer The fields originalEstimate, remainingEstimate, and timeSpent allow only whole number positive
numerals.

Flag Flag fields are displayed as checkboxes. By default, all flags are marked as No (false).

String Includes the predefined fields Short Name, ID, and string1 through string15.

Pick list In the Add field window, fields such as status, priority, and lookup 1–10 prompt you for a has been
pick list. If that option isn’t available, you select a non-pick list type from the drop-down list. Once a
predefined field is used for a pick list, it's no longer available in the list. If additional fields are needed,
use custom fields.

Release Each pick list is populated by the list of releases created within each project. Some item types are
configured with a release field by default. If the release field is removed from the item type, it becomes
available in the predefined field list.

User Item types with a user field include a pop-up list of users. Only one user can be selected from the list.

Custom fields
Organization admins can add custom fields that are unique to their organization. Custom fields can be
similar to predefined fields, or they can be multi-select, URL, calculated, rollup, and item of type fields.

To find a field, search using the field name because they aren't indexed.

You can add a custom field [595] of these types:

Type Details

Item of Type Create a new pick list field that is populated by a list of existing items in the current project that are the
specified item type. In this manner, users can reference items of another type. Only one item can be
selected in an Item of Type pick list.

Flag Flag fields are displayed as checkboxes to those working with the item type. By default, all flags are
labeled No (false).

Integer Allows only whole number positive numerals.

Release Each pick list is populated by the list of releases created within each project. Some item types are
configured with a release field by default. If the release field is removed from the item type, it's available
in the predefined field list.

Pick List A set of specific values that can be entered in a field.

Float Use float fields to accurately capture numeric values. The float field follows IEEE 754. These fields can
be positive or negative.

Multi-select pick list Allows the user to select multiple values in a pick list.

URL Similar to a regular text box, a URL field performs some minor validation of text entered in the field to
check that it’s a URL and displays the text as a link when submitted.

Text field Holds plain text strings with no line breaks. If line breaks are required, use the Text box field.

Text box Holds more data than a typical Text field in plain text or rich text, Can include line breaks and have a
template applied to it.

Jama Connect User Guide

594



Type Details

Rollup Shows progress on downstream items without having to open each downstream item. You can opt to
open a filter with any downstream items included in the rollup calculation. Progress on the downstream
item is tracked by a pick list (often a Status pick list).

Indicate the downstream item type, the pick list field on that downstream item type, and the pick list
value that shows that progress is complete.

Calculated fields* Allows admins to configure automated calculations using addition, multiplication, average, Weighted
Shortest Job First (Scaled Agile prioritization model), and simple logic (2D lookup matrix). You can add
calculated field results to the List View and use them for sorting and filtering.

You must select the following options:

• Calculation type — Average, Multiply, Sum, Weighted Shortest Job First, or Lookup matrix.
• Calculation source — This item or Related item(s).
• Related item type
• Relationship direction — Upstream or Downstream.
• Fields upon which to base the calculation — Displays pick list, multi-select, integer, other calcu-

lated fields from the same item, number of upstream or downstream relationships, and number of
comments fields.
• Pick list field — Value used in the calculation.
• Multi-select field — Value used is the sum of the value of each selected item.
• Calculated field — Result is used in the calculation. Once a calculated field is chosen as an input for

a calculated field, it can't be used as an input in additional calculated fields.
• Number of decimals to display — Up to 4.
• Whether to require all values to be present before the calculation is performed — If you don’t

select this option, the calculation is performed each time a value is entered into one of the selected
fields.

* American or British-style decimals must be used in the fields where the calculations are derived.
Otherwise, errors occur. If a calculation is based on a related item, the calculated field isn’t update until
the item containing the calculated field is edited.

Add, edit, or delete fields
When editing an item type [608], you can add, change, or delete fields.

NOTE
You must have organization admin permissions to complete this task.

Important considerations

• When you toggle a field between rich text and text, the text doesn't retroactively change data that was
previously entered in that field. Each type is saved in a different format (HTML vs plain text). A large
scale data translation isn’t supported — data might have accumulated over years and with potentially
millions of records, so the update might break compliance rules, version history, integrations, or
review comments.

• Things to know before you delete a field:
• Once a field is deleted, all values related to that field are deleted from the database and can’t be

recovered.
• If the field was used to relate synced items, such as JIRA KEY, proxy, a duplicate item is created if

you try to create the sync again.
• If the field is mapped in an integration, it is no longer updated and might cause errors in your

integration tool.
• If a filter used the field, update the filter before removing the field to avoid inaccurate filter results.
• If the deleted field raised suspect links, relationships are affected. Because the field no longer

exists, users can’t see the changes that created the suspect link.
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• If you try to restore a previous version of an item that still contains the deleted field, the field's
contents aren’t restored. Even if you recreate the field before the version rollback, data isn’t
restored.

• If you still want to delete a custom field, consider exporting a copy of the field values via a report or
the API.

To add, edit, or delete a field:

1. Select Admin > Organization > Item types. 
A list of existing fields is displayed with information about each field.

2. Select a row to highlight it in blue, then select an action icon in the top toolbar.

Action icons include:
• Pencil — Edit a field
• Green arrows — Re-order fields
• Red X — Delete a field
• Green Add field — Open the Add field window

3. If you selected Add or Edit, select Predefined Fields or Custom Fields, then use the drop-down
list to select a field type.
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Both field types can be used in the same item type. (This section does not appear when editing
fields).

IMPORTANT
You can only use the system predefined Release field to show items in the Relea-
ses tab. If you use a custom Release field to designate an item to a release, that
item doesn't appear in the Releases tab. 

4. Complete these options to define or edit the field type:
• Field label — The field name that users see. The application automatically uses this value

as the unique field name in the database, which can’t be changed. Avoid leading with an
underscore; some unique field names might conflict with Elasticsearch fields (such as _source or
_ID) and prevent proper functioning.

• Infotip — (Optional) Visible to users when they hover over this field label.
• Unique Field Name — The name of the field in the database, which the application uses

automatically.
• Read Only — Prevents users from editing the field.
• Allow API overwrite — Fields that are configured to be read-only have the option to be editable

via the REST API. System fields like modifiedDate or rollup don't allow the option to overwrite.
• Is Required — Required fields are string, text or date fields that are configured so that the user

must enter data into the field before saving an item.
• Use to Trigger Suspect — Suspect links [315] is triggered when specific fields update in an

item. This option lets you determine which field changes flag an item as suspect.
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• Synchronize — When items are synchronized to other items, a change in a field with this check-
box flags this item as out of sync in the synced items window and in Single Item View [154].

• Text Components — (Custom Fields > Text Box only) Choose whether you want rich-text
capabilities.

• Pick list, Multi-select, Calculated fields — If a field requires lookup or a pick list for input, add
the pick list or lookup matrix.

5. Click Save.

By default, new fields are added to the bottom of the item type fields list, but you can reorder using the
green arrows.

Enable test case item
If testers need more formatting options when they edit their test cases, specifically for steps, a WYSI-
WYG editor that is similar to the one used in most item Description fields is available.

NOTE
You must have organization admin permissions to complete this task.

Important considerations

• When you disable rich text, no data is lost, but images and rich text are replaced with HTML tags.
Users don’t see any existing steps break and the content is still rendered. The user must decide
which formatting tags to remove.

• The application doesn’t automatically strip tags, and renders correct HTML tags in steps with or
without the rich text mode enabled.

• To hide the test case status from view, see Hide test case status field [599].

To enable test case item:

1. Select Admin > Organization, then select Item types.
2. Select the item type you want to use, which is a Test Case [362] type.
3. In the right panel, select the Steps field, then select the Edit pencil icon.

4. In the Edit field window that opens, select Allow Rich Text to enable the feature.
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5. Click Save.

Hide test case status field
Test case status is a system-managed field that can't be deleted, however it can be hidden from view.

1. Select Admin > Organization, then select Item types.
2. Select the item type that you want to use, which is a Test Case [362] type.
3. In the right panel, select the Test Case Status field, then select the Edit pencil icon.

4. In the Edit field window that opens, select Hide test case status to enable the feature.
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5. Click Save.

The test case status field for the item type you selected is now hidden from view.

Pick lists
Pick lists are a set of specific values that you can enter into a field. This feature ensures that all users
enter field content correctly. Pick lists are also useful when you create lookup matrices and calculated
fields.

Each pick list must be assigned a name. An optional description defines how the pick list is used.

Each option in a pick list can be assigned the following:

• Order — The arrangement of options in a field pull-down list.
• Display — The words users see when they select pick list options.
• Infotip — (Optional) Custom text that provides context for that value and is visible when a user

hovers over this field label.
• Description — Explanation of an option's meaning. For example, a display of High might be descri-

bed as "over 5000 items," "625-750 degrees," or "at least 72 miles."
• Pick list type — Standard type pick lists can be used for pick list, multi-select, calculated, or status

fields. Only Lookup matrix type pick lists can be used to configure lookup matrices.
• Value — The addition of a numerical value or weight to each option, which is useful in creating

calculated fields.
• Color — A means to visually distinguish pick list options at a glance, visible in different views across

the application. For example the test case status [368] field colors are green (passing), red (failing),
and orange (blocked).

• Default status — The status value that appears by default. A pick list can have only one default
status.

Manage pick list values
A pick list can have multiple values, which can be organized, color-coded, and set as a default.

A value can include an optional infotip, which is custom text that provides additional context for that
value.

NOTE
You must have organization admin permissions to change pick list values.
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Important considerations

• Changing a pick list value — Might affect other fields if the value is included in a calculated field.
• Archiving a pick list value — Removes the option from a selectable option, but preserves the

historical selection of the value. Archived pick lists can't be unarchived.
• Deleting a pick list value — Removes the selected value from all items in the system. Each item is

versioned and updated with the replacement value. Previous versions retain the deleted value. The
deleted value is no longer available for filtering. Each pick list must retain at least one value and that
value can't be deleted. Deleting a value from a lookup matrix type pick list might require updating any
dependent lookup matrices.

• Selecting a pick list type — Use the default or standard pick list types unless the pick list is
intended for configuring a lookup matrix.

To manage pick list values:

1. Select Admin > Organization > Pick lists, then select the pick list row you want to modify.

2. In the table, select the item row you want to modify, then select the icon for one of the following
actions.

• Plus icon (add item) — Enter the name and optional characteristics like infotip, description,
value, and color.

• Pencil icon (edit item) — Make your changes.
• Box icon (archive item) — If you  archive an item, the value's row is removed from view. This

action can't be undone and is only visible on versions of items before it was archived.
• X icon (remove item) — Select a replacement value, then click Delete.

The value is saved to items in the system where the deleted value is selected.
3. Click Save.

The table is updated to reflect your changes.
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Add a lookup matrix
A lookup matrix serves as a source for logic-based calculations in lookup matrix type calculated fields.

To add a logic-based calculated field to an item, you must first add the lookup matrix and give it a name.
Adding an optional description defines how the lookup matrix is used in calculated fields.

To configure a lookup matrix, you must select a pick list for the matrix columns, rows, and results.

1. Create pick lists [600] for the calculation inputs (matrix rows and matrix columns) and the calcula-
tion results (matrix values).
a. Select Lookup matrix as the pick list type.

b. (Optional) To change the table color from default gray, select a row in the Pick list values table,
click Edit values, and select a color.

2. Select Admin > Organization > Lookup matrices.
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3. Click Add lookup matrix.

4. Enter a name and optional description for the lookup matrix.
5. Configure the lookup matrix settings:

a. Under Matrix Configurations, use the drop-down selectors to configure the matrix columns,
rows, and values/result.

b. Click Generate matrix, then select matrix values for each matrix cell according to the logic-
based calculation outcomes you need.
For example, when you select Low for the P-total field and Minor for the Severity field, the
calculated field for Risk Score returns the result Acceptable in yellow.
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6. Click Save & done.
7. Select from an existing item type or add a new item type, then click Add field.
8. Confirm that the calculation input fields were added to the item: make sure the pick lists match the

configuration pick lists used for the calculation lookup matrix source you want.
9. In the Add field window that opens, select Lookup matrix as the calculation type.

Select from an existing lookup matrix as the calculation source, then select from available fields as
calculation inputs.
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10. Click Save.

Configure organization detail
Early in the setup process, configure the details for your organization, including organization name and
description, base URL, how subscriptions are handled, and more.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Details.
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2. Configure these details for your company:
• Organization name — The name of your company or team. Each instance of Jama Connect

can have only one organization. The organization name is also used for reports.
• Description — An explanation and additional information about your company.
• Return email — A return address for email notifications. Typically the organization admin's email

address is used or noreply@example.com.
• Base URL — When email notifications include links to items, the link is created from the base

URL for your Jama Connect installation. For example, http://localhost:8080/contour. Attachments
(images etc) depend on this setting being accurate.

• Rich text image max width (px) — Maximum pixel width setting that shrinks all images embed-
ded into rich text fields. Default is 0, no maximum width is applied.

• Rich text image max height (px) — Maximum pixel height setting that shrinks all images
embedded into rich text fields. Default is 0, no maximum height is applied.

IMPORTANT
Images retain their ratio when adjusted to fit the maximum setting for height
or width. The adjustment only happens during an upload or document import.
Images that already exist on the server aren't adjusted. Compression occurs
based on the width and height settings.

• Allow users to subscribe others — Users can subscribe other users to items.
• Allow users to mute subscriptions — Users can turn off a subscription that another user

subscribed them to.
• Allow non-administrators to delete items/containers — Users who have create/edit permis-

sions can delete items. When disabled, only organization admins can delete items.
• Allow project administrators access to all users and organization groups — Project admins

can see all projects' users and groups. When disabled, project admins can see only their own
project's groups and users.

Jama Connect User Guide

606



• Include unexecuted test runs in status calculations (not retroactive) — (Default) Jama
Connect includes all associated test runs to automatically calculate test case status. When
deselected, unexecuted test runs are not included unless there are no executed test runs.

NOTE
For test cases associated with a single plan, test case status reflects the status
of the test run with the most recent activity, which includes unexecuted tests
if this option is enabled. When the case is associated with multiple plans, the
most urgent status is chosen, in this priority order: unexecuted, failed, blocked,
scheduled, passed.

Deselect this box to remove unexecuted test runs from that priority order.

• Allow multiple items with the same global ID in a single project
• Java Date Time Format — Formats include month/day/year (default), year/month/day, and day/

month/year.
• Change global ID [550] — Change or add a prefix or an optional item type key in front of the

global ID assigned to items.
• Configure the baselines status for pick lists — After you create a baseline-specific pick list,

you can enable the baseline status to select the pick list. The baselines status pick list can’t be
edited after you configure it.
Once you create a baseline-specific pick list, you can enable the baseline status to be able to
select the pick list. The baselines status pick list can’t be edited after you configure [552] it.

• MathType and ChemType editor format — For the best results, use PNG format with quality
300 dpi. When the equation format is changed, existing equations keep their current format until
they are edited.

Item types
Item types are the templates for sets used within each project.

While sets are unique to each project, item types can be used in projects [646] across the entire
organization. Item types can't be customized for individual projects.

Each item type can be configured [608] to best fit your organization and methodology. The fewer item
types that your organization creates, the easier it is to manage items.
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Additionally, every item type is automatically assigned an API ID for reporting purposes, which can't be
specified or changed.

Add and edit item types
You can create a new item type, add or delete fields [595] in an existing item type, or change the item
type details. Once an item type is created, users can add it to their project.

NOTE
You must have organization admin permissions to add and edit item types.

Important considerations

• Changes to an item type affect that item type in all projects. Item types can't be customized for
individual projects.

• Jama Connect comes with a core set of item types that can't be deleted. When you select Admin >
Organization > Item types, core item types don't include a Delete option.

• You can see a list of core item type fields in Admin > Organization > Item Types > Core > Views
> Projects List View - Mixed Item Types. Custom fields can't be selected for visibility in mixed item
type views.

• Before a new item type can be used in a project, it must be added to that project by a project or
organization admin.
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TIP
The fewer item types that your organization creates, the easier it is to manage items
and to report on the sets based on those item types.

To add or edit an item type:

1. Select Admin > Organization, then select Item types.
2. To add a new item type, click Add item type. To edit an existing item type, click Edit for the item

type you want to modify. 

3. In the Add item type window that opens, select or modify the following options:
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• Display — (Required) Name for a single item of this item type.
• Display plural — (Required) Name for multiple items of this item type.
• Description — Explanation for how this item type is used or how it is distinguished from other

item types.
• Type key — (Required) The default ID Prefix that is shown when creating a set using the item

type. It can be overwritten.
• Use as — Option if you are using this item type for special use for test [362]. (If you're using the

REST API to create an item type, it refers to this as a Category).
• Widgets — Small embedded applications that add functionality to item types. Read more about

widgets [676] or how to enable or disable them [611].
• Image — (Required) The icon displayed for this item types. Icons are used as the set icon, the

list view icon, and the icon at the upper-left of the item view.
• Library icon and Custom icon — (Required) The icon for the item type you're editing. Icons are

used for set (container), List View, and in the upper left corner in Single Item View.
Admins can use default icons or upload their own custom 16x16 pixel icon. Custom icons can’t
be reused and must be uploaded for each item type.
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NOTE
A custom icon must be deleted by an admin to revert to a library icon.

• API ID — A reference ID that is automatically assigned to an item type for API reporting
purposes. You can see this ID by selecting Admin > Item types, but it cannot be specified or
changed.

4. Click Save.

IMPORTANT
You can delete an item type but you are prompted to delete any existing items of that
type before you delete it. To delete, select the item type you want to delete and click
Delete.

Enable or disable item widgets
Widgets are small embedded applications that add functionality to item types.

NOTE
You must have organization admin permissions to complete this task.

Available widgets include:

• Activities [241]
• Attachments [89]
• Change request  [268]
• Relationships [307]
• Synchronized items [329]
• Tags [86]
• Versions [263]

To enable or disable widgets:

1. Select Admin > Organization, then select Item types.
2. Click Edit in the row of the item type where you want to enable or disable widgets.
3. To enable a widget, select the widget's name [676] in the Inactive widgets column to move it to

the Active widgets column.
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Each widget in the Active widgets column has a synchronize toggle button next to its name (gray
= disabled; black = enabled).

NOTE
Adding the relationship widget automatically also adds the Relationship Status
Indicator [308]. They can’t be used separately.

4. To indicate that a widget can be synchronized, click its synchronize toggle button

NOTE
If you disable synchronization for a specific widget, when an item of that type is
synchronized, that widget isn't included in synchronization, nor is that widget taken
into account when sync status is calculated.

5. To disable a widget, click the X next to the widget's name in the Active widgets column.
6. Click Save.
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Use a different item type as a test case or defect
You can use any item type as a defect or a test case. When you select test case, test steps and test
case status are added to that item type.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization > Item types.
2. Click Edit in the row of the item type you want to change to a test case.
3. In the Add/Edit item type window that opens, select the pull-down menu next to the Use as field

and select one of the options: Test case or Defect.

4. Click Save. 
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Enable test case item
If testers need more formatting options when they edit their test cases, specifically for steps, a WYSI-
WYG editor that is similar to the one used in most item Description fields is available.

NOTE
You must have organization admin permissions to complete this task.

Important considerations

• When you disable rich text, no data is lost, but images and rich text are replaced with HTML tags.
Users don’t see any existing steps break and the content is still rendered. The user must decide
which formatting tags to remove.

• The application doesn’t automatically strip tags, and renders correct HTML tags in steps with or
without the rich text mode enabled.

• To hide the test case status from view, see Hide test case status field [599].

To enable test case item:

1. Select Admin > Organization, then select Item types.
2. Select the item type you want to use, which is a Test Case [362] type.
3. In the right panel, select the Steps field, then select the Edit pencil icon.

4. In the Edit field window that opens, select Allow Rich Text to enable the feature.
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5. Click Save.

Change a set key
You can edit a set ID or renumber items in a set at any time.

NOTE
You must have organization or project admin permissions to complete this task.

1. Select Projects, right-click on the set you want to modify, then select Change set key.

2. In the Confirm Set Key Change window that opens, enter the new set key, which must be 1–16
characters long, consisting of only letters, numbers, and underscores.

3. Select Regenerate Item IDs to reset the counter to 1 and to apply new numbering to all existing
items.

IMPORTANT
Don't select Regenerate Item IDs if you want to restart numbering on newly
created items. Leave existing items as they are.

Configure workflow
Workflows aren't project-specific. When you configure a workflow, it applies to the item type across
projects.

NOTE
You must have organization or process admin permissions to complete this task.

Important considerations

• If the organization admin selects Allow project managers to override workflows on a project, the
project admin for each project can set up the workflows.

• If you disable a workflow, Jama Connect stores your settings for later use.
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• An organization admin can disable a workflow from the Workflow Administration section.
• Selecting these Workflow options, Enable workflow for this organization and Allow project man-

agers to override workflows on a project might impact system performance.
• Workflow applies to all projects using the selected item type and can't be disabled at a project level.

To configure workflow:

1. Select Admin > Organization, then select Workflow.

2. Select options to enable workflow for all projects using this item type:
• Enable workflow for this organization.
• (Optional) Allow project managers to override workflows on a project.

3. Under Workflow Administration:
• To start a new workflow, click Add/Edit.
• To edit a workflow, click Config in the Action column.

From here, a project admin can continue to set up the project workflow [653].

Set up editor templates
Editor templates can be applied to any rich text field and must be configured before use.

NOTE
You must have system or organization admin permissions to complete this task.

1. Select Admin > Organization, then select Editor templates.
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• To create new template with a rich text editor, click Add editor template and give it a name and
description.

• To edit an existing template, select a template, then click Edit.

2. Create or edit the template as you want it to appear in other items.
3. Click Save.

The template is now available to other users [97]. 

Configure views
You can configure the default fields in Projects List View, Projects Reading View, Reviews Single Item
View, and Reviews Reading View.

You can also configure views in Projects that contain mixed item types, such as views created from a
tag, filter, or component, by selecting Projects List View with mixed item types.

NOTE
You must have organization admin permissions in order to configure default views.

Configuring fields for a view [48] overrides the default and becomes the standard order of visible fields
for that user, in all similar views, for that item type.

1. Select Admin > Organization, then select Item types > Views.

2. In the Project List View window that opens, select the view you want to configure.

Jama Connect User Guide

617



3. Double-click a field name or use the arrows to move fields between the Hidden and Visible
columns. Select and drag field names up or down to reorder them.

4. Click Save.

NOTE
You can only select core item type fields when you configure List View for mixed item
types. For a list of core item type fields, see Admin > Item types > Core > Views.

Managing relationships
As an organization admin you can use several tasks to manage relationships.

• Edit relationship widget [611] in an item type
• Set the relationship types [568]
• Configure the Import Relationships Plugin [557]
• Set up relationship rules [571] at an organizational level

Configure relationships
Before setting up relationships (traceability) between your artifacts, you need to set up the types and
options available to users.
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NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Relationships > Edit.

2. To change the relationship options from No to Yes, select each option:
• Show Status in Relationship Grid?
• Show Note in Relationship Grid?
• Allow relationship changes between two locked items?
Note and Status columns are added to the table in the bottom panel. The Note and Status fields
are only editable when the relationship type is set to Show Note and Show Status.

3. Configure relationship types:
a. In the Relationships widget of an item, double-click on a relationship to edit its type, direction,

status, and note.
b. Use the toolbar at the top of this panel to edit, add, or delete types.
c. Include a description to specify how and when this type is used.

4. Set up relationship rules [571].

Set relationship types
One part of the initial traceability setup is configuring the available relationship types.

NOTE
You must have organization admin permissions to set relationship types.

1. Select Admin > Organization, then select Relationships.
2. Under Relationship Types, use the icons to add, edit (pencil), delete (X) or reorder (arrows)

relationship types.
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3. When adding a new relationship type, enter a display name and description. The description is only
visible in this edit window.

4. (Optional) Select Show Note and Show Status to allow users who create a new relationship using
this relationship type to enter a note and a status for that relationship.
Status and notes are visible any time you reopen the Add/edit relationship window. Also, when
notes and status are enabled under Relationship Options...

... you see them in the bottom panel of Single Item View when Relationships is selected.
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You can also filter by status or note in an impact analysis [317].

5. If you delete a relationship type, choose a replacement type for affected relationships.
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Set up relationship rules
Relationship rules help maintain the project structure by preventing problems with relationships [307].
The rules help users know when relationships are required and in which directions.

NOTE
You must have organization admin permissions to complete this task.

When relationship rules are set up, the Relationship Status Indicator [308] alerts users to easily see
when their relationships don't match the relationship rules. 

Rule sets are created at the organization level, and can then be applied to one or more projects.

To set up relationship rules:

1. Decide with your team which relationships to include, the relationship types, and whether
the rules are exclusive and included in coverage calculations for the project.

2. Select Admin > Organization > Relationships and scroll down to the section labeled Relation-
ship Rule Configuration to see any previously created rule sets.
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3. Scroll to the bottom and select Add rule set.
a. Select New Rule Set and edit the name to describe your set.

b. Add a rule by selecting the item type for Upstream, Downstream, and Relationship type
from the drop-down menus. Select For coverage if you want this relationship included for
coverage.

NOTE
Configure the same rule set across projects that share relationships. If you
relate items across projects with different rule sets, the source project's rule
set is applied.

c. Click Save.
As the rule is saved, it is added to the diagram, indicating the relationship.

d. (Optional) Click Add another relationship to include another relationship for this rule set.
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As rules are created, the diagram is updated to show the relationships. Solid lines between
items indicate a coverage (required) relationship. Dashed lines indicate relationships that
aren't for coverage.

TIP
Once you've set relationship rules for a project, you can also view the rela-
tionship rules diagram in Single Item View or on the dashboard [157].

4. To delete a rule, select the X at the end of the rule's row. To delete an entire rule set, select the X at
the top right of the rule set. After editing or deleting a rule, the rule set diagram is updated with any
changes made.

5. Click Add project to apply the rule set to one or more projects. If a rule set is applied to a project
with existing items, nothing changes in that project, even if the existing relationships break the
new rules. Only future relationships are required to conform with the rule set. 

IMPORTANT
A project can have only one rule set. If a rule set has already been applied to a
project and you try to apply another, the application removes the first rule set from
the project and applies the second one.

6. (Optional) Select Allow any item type not mentioned in this rule set... to allow users to cre-
ate relationships outside the rule set you applied to the project.

Rules are between item types. If you don't define a rule for a particular item type, that item type can
have a relationship with anything (or nothing if the user chooses), even if the rule set is exclusive.

Configure the Import Relationships Plugin
The Import Relationships Plugin helps you batch create relationships between existing items in the
application.

NOTE
You must have organization admin permissions to complete this task.
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Important considerations

• Before you use the Import Relationships Plugin in Jama Connect, you must first create a direct
relationship between the items you plan to link. Otherwise, the linking might fail. For example, when
you link use case item types to test case item types, you must first define a relationship rule for that
project. For more information, see Set up relationship rules [622].

• For information on how to use the Import Relationships Plugin, see the Relationship Plugin Tutorial

To configure the plugin:

1. Select Admin > Organization, then select Plugins > Add plugin entry.

2. In the Add plugin entry window that opens, enter the following information and click Save.

• Name — Enter a name you visible to users. For example, Import Relationships.
• Enabled — Make the plugin available to users.
• Class (case sensitive) — Enter the name of the object defined in the source code.  

For a single project enter:

com.jamasoftware.contour.plugin.jama.ImportRelationships

For cross-project imports enter:

com.jamasoftware.contour.plugin.jama.ImportRelationshipsCrossProject

• Type — Import
• Parameters — Set relationship parameters [559]
• Plugin notes — Add any notes you have here. This isn't visible to end users.

3. When the information is correct, click Save. 
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TIP
For a sample entry of a cross-project import, see Set relationship parame-
ters [559].

Managing tests
As an organization admin you can do the following to manage tests:

• Include unexecuted test runs in status calculations [605]
• Enable rich text in test steps [598]
• Use an item type as a test case or defect [613]

Test run item
A test run is a system item and can't be deleted. It serves as the record of a test being executed.

When a test case is associated with a test cycle, a test run is automatically created in that cycle. An
automatic association is created between that test run and its originating test case, test cycle, test
group, and test plan. These associations contextualize the test run.

A test run’s name, description, and steps are the same as its originating test case at the time the run
was created.
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Status — Available statuses
Passed and Failed are required statuses that can't be changed or disabled. "Not applicable" is an
optional status that can be enabled when certain test steps and/or tests might not be applicable to all
testing scenarios. Not applicable status in a step or test run is excluded from any result calculation.

Status — Default behavior for completing steps out of order
Select one of the three options for how the system might behave when a tester skips a test step and
does not assign it a status:

• Assign “Passed” to all skipped steps
• Do not assign status to any skipped steps
• Allow tester to select status for skipped step (for example, ignore, pass, fail)

Managing collaboration
Collaboration includes emails [228], electronic signatures [257], the stream [236], reviews [162], and
workflows [230].

Configure organization detail
Early in the setup process, configure the details for your organization, including organization name and
description, base URL, how subscriptions are handled, and more.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Details.
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2. Configure these details for your company:
• Organization name — The name of your company or team. Each instance of Jama Connect

can have only one organization. The organization name is also used for reports.
• Description — An explanation and additional information about your company.
• Return email — A return address for email notifications. Typically the organization admin's email

address is used or noreply@example.com.
• Base URL — When email notifications include links to items, the link is created from the base

URL for your Jama Connect installation. For example, http://localhost:8080/contour. Attachments
(images etc) depend on this setting being accurate.

• Rich text image max width (px) — Maximum pixel width setting that shrinks all images embed-
ded into rich text fields. Default is 0, no maximum width is applied.

• Rich text image max height (px) — Maximum pixel height setting that shrinks all images
embedded into rich text fields. Default is 0, no maximum height is applied.

IMPORTANT
Images retain their ratio when adjusted to fit the maximum setting for height
or width. The adjustment only happens during an upload or document import.
Images that already exist on the server aren't adjusted. Compression occurs
based on the width and height settings.

• Allow users to subscribe others — Users can subscribe other users to items.
• Allow users to mute subscriptions — Users can turn off a subscription that another user

subscribed them to.
• Allow non-administrators to delete items/containers — Users who have create/edit permis-

sions can delete items. When disabled, only organization admins can delete items.
• Allow project administrators access to all users and organization groups — Project admins

can see all projects' users and groups. When disabled, project admins can see only their own
project's groups and users.
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• Include unexecuted test runs in status calculations (not retroactive) — (Default) Jama
Connect includes all associated test runs to automatically calculate test case status. When
deselected, unexecuted test runs are not included unless there are no executed test runs.

NOTE
For test cases associated with a single plan, test case status reflects the status
of the test run with the most recent activity, which includes unexecuted tests
if this option is enabled. When the case is associated with multiple plans, the
most urgent status is chosen, in this priority order: unexecuted, failed, blocked,
scheduled, passed.

Deselect this box to remove unexecuted test runs from that priority order.

• Allow multiple items with the same global ID in a single project
• Java Date Time Format — Formats include month/day/year (default), year/month/day, and day/

month/year.
• Change global ID [550] — Change or add a prefix or an optional item type key in front of the

global ID assigned to items.
• Configure the baselines status for pick lists — After you create a baseline-specific pick list,

you can enable the baseline status to select the pick list. The baselines status pick list can’t be
edited after you configure it.
Once you create a baseline-specific pick list, you can enable the baseline status to be able to
select the pick list. The baselines status pick list can’t be edited after you configure [552] it.

• MathType and ChemType editor format — For the best results, use PNG format with quality
300 dpi. When the equation format is changed, existing equations keep their current format until
they are edited.

Edit user subscriptions
Users can subscribe to and control their own email notifications. However, if a user's subscriptions were
added by someone other than the user, only an admin can make changes.

Organization admins can unsubscribe a user; project admins can only mute a user's subscriptions.
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NOTE
You must have organization or project admin permissions to complete this task. 

To edit a user's subscriptions:

1. Select Admin > Organization, then select Users.
2. Select Subscriptions in a user row to open the Edit subscriptions window.

3. Select a user from the left column to display their current subscriptions in the right column.  
• To remove a single subscription, click Unsubscribe in the Action column.
• To remove multiple subscriptions for a user, select the subscriptions in the Notifications column,

then click Unsubscribe selected in the top right corner.
4. To edit a group subscription, select Admin > Organization > User groups > Subscriptions.

Manage stream comments
Decide whether you want to use Jama Connect for collaboration within and across projects and items.
The stream is the method for sharing comments on items and making and closing decisions.

NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Stream.
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NOTE
Separate domains with a comma and don't add a space between the comma and
next domain.

2. Configure these settings as needed:
• Disable Stream and project comments — Turns off the stream.
• Enable new comments in global Stream — Displays comments when you access the stream

from the header.
• Allow users to invite new users to Jama Connect by email — Gives users the ability to add

users outside of Jama Software with @mention.
Those who accept invitations automatically receive a temporary license [583] but only have rights
to view the discussion threads to which they have been invited. Organization administrators can
give them more rights, but will need to change the license type to a permanent one before
their 30 day license expires. An organization has unlimited temporary licenses, which have
full creator permissions.

• Only allow email addresses with these domains — Restricts invitations to email addresses
within a specific domain. Separate multiple domain entries with a comma.

• Comment update frequency — Controls how often the stream is updated with new comments.
3. Click Save settings.

Managing reviews
As an organization admin, you can manage many aspects of a review, including permissions, access,
licenses, and more.

Users with reviewer, test runner, collaborator, and stakeholder licenses can participate in reviews but
can't create reviews. When a user is invited to participate in a review, they automatically get a reviewer
license. Reviewer licenses don't automatically grant read- or write-access to project data.

To manage reviews, you can:

• Grant permissions to a review admin [589]
• Assign reviewer licenses [582]
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• Configure access to reviews [632]
• Configure item workflow for Approval Reviews [633]
• Determine which default fields are visible in reviews [617]
• Manage permissions by license type [583]

Configure review access
You might want to configure access to a review for certain members of your team to see the review. If
your company follows specific processes, you can tailor the review access accordingly.

Important considerations

• You must be an organization admin to configure review settings.
• Reviews created before Jama Connect 8.61.x with the setting Reviews can be public disabled and

later enabled, those reviews become public.
• Reviews created after Jama Connect 8.61.x with the setting Reviews can be public disabled and

later enabled, those reviews remain private.
• For information about license types and reviewer roles, see Permission by license types [583].

To configure access to reviews:

1. Select Admin > Organization, then select Review center.
2. Select the options you want and click Save settings. 

• Disable reviews — Blocks access to reviews.
• Reviews can be public — (Default) Allows reviews to be viewed (read-only) by users with

review access to public reviews. Select who can see public reviews.
• Anyone with access to reviews — Lets anyone, regardless of project permissions, to see all

items in the review.
• Only those with permission to ALL items in the review — Lets users see a public review if

they have access to all items in the review.
• Enable review moderators to invite users outside their project — Lets review moderators

give reviewers access to specific items in a project.
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• Allow approvers to add other reviewers and approvers — (Default) Lets approvers include
other users and assign them roles as reviewer or approver.

• Allow approvers to delegate their approval — (Default) Lets approvers appoint a reviewer to
approve and sign for them.

• Allow review moderators to invite new users to Jama by email — Lets moderators include
non Jama Connect users. When they accept, they are automatically granted a reviewer license.
• Only allow email addresses with these email domains — Limits invitees to users with email

domains you enter here. Leave it blank to allow any domain.

Item workflow for Approval Reviews
When you integrate Approval Reviews with your item workflow, you ensure that reviews are consistent
and up to date. When enabled by an organization admin, moderators can use templates for Approval
and Peer reviews.

NOTE
You must be an organization admin to configure the item workflow for Approval Re-
views.

This overview describes the process for using item workflow with review templates.

1. Organization admin — From Admin > Organization > Review center:
1. Select Enable Approval review template. Approval reviews are required to integrate the

workflow for your review process
2. (Optional) Select Enable Peer review template. Peer reviews can be transition to Approval

reviews.
3. Click Save settings.

2. Organization admin — From Admin > Organization > Workflow:
1. Select Enable a workflow transition to be enabled by a finalized Approval review.
2. Configure the workflow transition status, notifications, lock state, and permissions that apply to

the new approval review transition.
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3. Moderator — Create a review, then select the Peer review template in the review wizard.
4.  Moderator — View a Peer review and transition it to an Approval review.
5. Moderator — When the Approval review is done, select Finalize Approval review.
6. Moderator — After viewing the review overview and workflow transitions, select Finalize re-

view to confirm the transition.

Types of review templates
The review templates are optional. You can use none, one, or both types. You don’t need a Peer review
template to finalize an Approval review.

NOTE
Review templates are disabled by default. You must enable the Approval and Peer
review templates to use them.

• Approval review template — Use when you want to collect signatures and need a review signed off.
If workflow is enabled, you can batch update items [74] to an approved state.

• Peer review template — Use when you have a review with ongoing itera-
tions and when changes to items are always in the “ready for approval” state.

Organizing projects
A project is a way of organizing your data in Jama Connect and is made up of items, filters, base-
lines, releases, reports and tests.

As an organization admin you can complete the project-level tasks of a project admin or you can grant
project admin permissions [643] to a user who manages a particular project and its users.

Some tasks, such as the following, are related to projects and must be done by the organization admin:

• Add a project [635] (available for project admins with Add Project role)
• Duplicate a project [637] (available for project admins with Add Project role)
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• Archive a project [639]
• Grant project permissions [664] (if disabled for project admins)
• Add or delete groups [574] (if disabled for project admins)
• Set up projects workflow [653]
• Set up relationship rules [571]

Add a project
If your organization has many projects or products, you can create a folder called "Product Line" with
projects for major releases. You can also create a project to hold a library of common requirements or
documents that you can reuse [322].

NOTE
You must be an organization or project admin with the Add Project role to complete this
task.

1. Select Admin > Project, then select Add project.

2. (Optional) Add a folder to organize your projects.
3. Set up relationship rules for the project [571]. Only one rule set can be applied to each project.
4. Set up project's workflow [653] as needed.

Edit project details
Update the name, key contributors, and other high-level details for a project.

NOTE
You must have project or organization admin permissions to edit project details.

1. Select Admin > Project, then select Details > Edit.
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2. Make your changes, then click Save.
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NOTE
The Project Summary widget on the project dashboard uses the End date in the
Project Details window to calculate the number of days until the project is complete.

Change a project key
When you update a project key, the ID for all items in the project is regenerated.

NOTE
You must have project or organization admin permissions to change a project key.

1. Select Admin > Project, navigate to the project with key you want to change, then select Details >
Change project key.

2. Enter the new project key (1–16 characters, consisting of letters, numbers, and underscores).
3. Click Submit.  

Once the project key is updated, the Unique ID [648] of all items within that project are updated to
contain the new key.

Duplicate a project
You can duplicate a project to reuse its requirements, permission settings, tags, and attachments, or to
start a new project from a template.

When you duplicate a project, its test plans, test cycles, and test runs are not copied to the target
project.

NOTE
You must be an organization or project admin with the Add Project role to duplicate
projects.

1. Select Admin > Project, then select the project you want to duplicate.
2. Select Actions > Duplicate Project.
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3. Select the items you want to copy and whether to synchronize them.

• Project Settings — Settings in the Admin > Project area. For example, visible item types,
relationship rule, and Explorer Tree maximum count.

• Project Permissions — Project-level permissions that were applied are carried over to the
copied project.

• Existing Relationships — Relationships between items in the project are copied to the new
project.

• Public Filters — Public filters created by users or project admins are copied to the new project.
• Tags — Tags created by users are copied to the new project.
• Releases — Release values in the Releases tab are copied to the new project, which also

maintains the release values in the standard “Release” field on items.
• Project Groups — Project-level groups are copied to the new project.
• Workflow — Workflow customizations (notifications, lock settings, transition permissions) are

copied to the new project.
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• URL Links and Attachments — Hyperlinks and attachments to items, using the links/attach-
ments widget, are copied to the new project.

• Synchronize Duplicated Project — All copied items receive a new project ID but maintain the
same Global ID as the original project. This allows teams to compare differences between the
source project and copied project. Common use cases are for parallel development of variant
products or branches of a products release.

• Create Relationships — All copied items include a trace relationship to the original item. You
can set the direction and relationship type.

4. Click Duplicate Project.

A message appears confirming the project was successfully duplicated.

Archive a project
You can archive a project to clean up your workspace or to hide it from most users' view.

When you archive a project, it remains in the database but is hidden from immediate view from most
users. Organization admins still see the archived project in the project tree with "(ARCHIVED)" in the
title.

NOTE
You must have organization admin permissions to complete this task.

Important considerations

• Archived projects and their content don't appear in filters or search results. When a project is ar-
chived, all releases associated with the project are archived.

• Project groups aren't deleted when a project is archived. If a project is no longer needed, delete it
before it is archived.

• Select Actions > Unarchive to unarchive a project.
• When you archive a project, related items from external projects no longer appear. If you unarchive

the project, those related items reappear.

To archive a project:

1. Select Admin > Project, then select the project you want to archive.

2. Select Actions > Archive project.
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3. When prompted, click Yes.

Delete a project
When a project is no longer needed, you can delete it, which completely removes the project and all its
data from the database.

NOTE
You must have organization admin permissions to delete a project.

Important considerations

• Project folders must be empty before they can be deleted.
• Once a project is deleted, there's no way to restore the project. When a project is deleted, all the

data in that project is deleted. However, this doesn't automatically free up space in the database. A
database admin must manually compress the database.

• To clean up your workspace or to remove a project from view, archive the project rather than delete it.
• Projects can be stored in empty folders.

To delete a project:

1. Select Admin > Project, then select the project you want to delete.

2. Select Actions > Delete Project.

Jama Connect User Guide

640



3. Review the list of items, confirm the deletion, then click Delete Project.

The project is deleted in the background, so you can continue working. You receive an email when the
deletion is finished.

NOTE
The project isn’t removed immediately. A daily task runs at midnight UTC to perma-
nently remove data from the database. Once the project is permanently removed from
the database, you can remove item types associated with that project.

Integrations
To best support product development teams, Jama Software offers a number of integration platforms for
customers to connect to other application lifecycle management (ALM) software.

Jama Software currently offers OpsHub Integration Manager (OIM) and Tasktop Integration Hub (TIH),
which provide the necessary platform to manage the integration. These integrations hubs manage
information between Jama Connect and your third-party applications in a bi-directional manner.

These solutions can be managed in self-hosted environments. or, in the case of the OIM, hosted by
OpsHub in their cloud.

For more information:

• Integrations — Visit the Community
• Purchasing a solution — Contact <sales@jamasoftware.com>
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Integrate OSLC Model Connector with Jama Connect
Open Services for Lifecycle Collaboration (OSLC) is an open-source set of specifications that enables
and simplifies tool integration in software development.

NOTE
You must have organization admin permissions to enable the OSLC Model Connector
and give access to users in your organization.

Integrating OSLC provides traceability between Jama Connect and OSLC domains, applications, and
organizations. The partnership between the Smartfacts Model-Based Systems Engineering (MBSE)
platform and Jama Connect helps product development teams increase their level of collaboration and
communication.

The result of this collaboration is the OSLC Model Connector, which provides:

• Complete traceability for requirements throughout the product development lifecycle
• Clear visibility into MBSE design artifacts in real-time
• Ability to link requirements to various modeling tools

For more information, see Jama Connect OSLC Model Connector Datasheet.

IMPORTANT
Contact your Jama Software account manager to set up access to the OSLC Model
Connector and to MID Smartfacts.

To set up and use the OSLC Model Connector:

1. Enable OSLC Model Connector.
a. Log in to Jama Connect, then select Admin > Organization > OSLC.
b. Select Enable OSLC > Save settings.
A pop-up message confirms that OSLC was successfully enabled.

2. Grant OSLC Model Connector permissions.
a. Select Admin > Organization > Permissions.
b. In the row for the user or group you want to provide access, select Modify.
c. In the Edit permissions window, select OSLC, then click Save.
A checkmark is displayed in the OSLC column for that user or group. The OSLC permission
automatically inherits the permissions that are set for those users or groups.

3. Configure specific item types for OSLC Model Connector.
a. Select Admin > Organization > Item types.
b. In the row for the item type you want to configure, click Edit.
c. In the Inactive widgets column of Widgets table, select OSLC Artifacts.

OSLC Artifacts move to the Active widgets column.
d. Click Save.
A checkmark is displayed in the OSLC column for that user or group. The OSLC permission
automatically inherits the permissions that are set for those users or groups.
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To use the OSLC Model Connector with Jama Connect:

1. Open your project and right-click on the item where you want to add a new item.
2. Click Add > New item > <item type>.
3. In the Add item window, enter a name for the item, then click Save and Close.

The OSLC Artifacts widget appears in Single Item View.
4. In the OSLC Artifacts widget, select + to add links to OSLC Artifacts that you configured in

Smartfacts.
You now see links in the OSLC Artifacts widget.

5. Select a link.

A panel slides out to display the artifact.

Example of the OSLC Artifacts Widget in Jama Connect

Project administrator
A project administrator is a role that can be provided for all projects or on a specific project with a focus
on permissions, project groups, and workflow customization.

Select Admin > Project to configure your projects.
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As administrator, all your projects are available from the Project tab. The last project you viewed is
selected by default.

As a project administrator you can:

• Manage project releases [650]
• Configure project item types [646]
• Manage project users [662]
• Manage project groups [662]
• Manage project permissions [664]
• Manage project attachments [651]
• Manage project tags [652]
• Perform a project cleanup [660]
• Index project data [661]

Monitoring changes with the Admin Activity stream (project admin)
The Admin Activity stream provides an audit trail of updates made by project administrators.

To open the Activity stream panel:

1. Select Admin > Project, then select the project you want to view.
2. Select the Activity stream button on the right side of the panel.

The Activity stream opens. You can search for activities by entering a search term.

The Project admin Activity stream includes the following actions:

Tab Available information

Settings Changes in version items; maximum number of items displayed in the Explorer Tree; where to
save test run defects.

Item Types Item types that transition from visible to hidden and from hidden to visible.

Release List What was added, edited, deleted, archived, and unarchived in a project release.

Project Permissions Modifications to inherited permissions; added and removed permissions at the project level.
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Workflow Overriden items and who overrode them; removed and configured workflows per item type in a
project.

Attachments Attachments added from the Attachments tab of the Project admin panel.

Tag Management What was added, deleted, and edited to a tag in a project.

Index When a project level index was initiated.

Clean up When project cleanup and project baselines cleanup are initiated.

Manage projects
As project administrator you have permissions to modify, set up, and organize various aspects of the
project and content. You can also manage users [662] that participate in the project.

You can also choose to manage the project dashboard [408], although that doesn't require project
administrator permissions.

Edit project details
Update the name, key contributors, and other high-level details for a project.

NOTE
You must have project or organization admin permissions to edit project details.

1. Select Admin > Project, then select Details > Edit.

2. Make your changes, then click Save.
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NOTE
The Project Summary widget on the project dashboard uses the End date in the
Project Details window to calculate the number of days until the project is complete.

Configure project item types
A hidden item type prevents users from creating new items or sets of that type. Sets or items that are
created under a visible item type, and are then hidden, are still functional in Jama Connect.

Important considerations

• By default, a moved item type places itself at the end of the list. Drag and drop item types to reorder
them.

• An organization admin can also configure views [617] for all projects, and an individual user can
configure fields [48] for their personal settings.

IMPORTANT
You must have organization or project admin permissions to configure project item
types.
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To hide item types from a particular project:

1. Select Admin > Project, then select Item Types. 

2. Double-click on any item type to move it between the Hidden item types and Visible item types
columns.

3. Click Apply to save your changes.

Configure default Explorer Tree settings

IMPORTANT
You must have organization or project administrator permissions to configure default
Explorer Tree settings.

1. Select the gear icon at the top of the Explorer Tree.

2. Select the Default settings tab, then select the default settings.
• Show item IDs

This displays the unique ID [648] (as in PROJ-REQ-25) before each item.
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• Display global ID
This displays the global ID (as in GID-8845) before each item. This can be helpful if the item is
copied and synchronized.

• Show only folders / hide items
This hides items from view in the Explorer Tree. Components, sets, and folders are still dis-
played. This can improve performance when your project has a large number of items.

• Show outline numbering
This displays a number scheme of order and depth in the Explorer Tree. Root level items have
numbers like 1, 2, or 3. Child items contain the parent item number as well as its own number,
like 1.1, 1.2,  or 1.1.5.

• Show relationships in Explorer Tree
This displays downstream relationships of items in the Explorer Tree. Select the green down-
stream arrow to open the related items in List View.

CAUTION
If you relate items back to themselves, you might create an infinite loop that
causes the Explorer Tree to expand. To avoid this, don't relate items in a way
that creates an infinite loop.

3. Select Apply and Close to give other users the option to select these default settings. 

Project key
The project key is a unique identifier, automatically created with each project, that makes up the first
part of each item's Unique ID. 

Project or organization administrators can change a project key. [637]

Unique ID
Unique IDs, or item IDs, identify an item with a project key, set key and a set counter. Unique IDs
remain the same even if item name or content is changed. They can't be edited or duplicated.

• Project key
A project key identifies which project an item belongs to. Project keys must be unique to each
project, and must be 1–16 characters long, consisting of letters, numbers, or underscores. A project
or organization administrator can change the project key [637], but that doesn't reset the numbering
of items. 

• Set key
A set key identifies item sets for each project. You can use the same set key across sets or projects.
Project or organization administrators can change a set key [615] to better meet your organization's
needs.
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• Set counter
The set counter is a number automatically added to the item. Unlike the Global ID counter, you can
reset the set counter when you change the set key. 

NOTE
It's possible to use the set key across multiple sets of the same item type. However,
keep in mind that the set counter is shared across all items using the same set key.

Change a project key
When you update a project key, the ID for all items in the project is regenerated.

NOTE
You must have project or organization admin permissions to change a project key.

1. Select Admin > Project, navigate to the project with key you want to change, then select Details >
Change project key.

2. Enter the new project key (1–16 characters, consisting of letters, numbers, and underscores).
3. Click Submit.  

Once the project key is updated, the Unique ID [648] of all items within that project are updated to
contain the new key.

Change a set key
You can edit a set ID or renumber items in a set at any time.

NOTE
You must have organization or project admin permissions to complete this task.

1. Select Projects, right-click on the set you want to modify, then select Change set key.
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2. In the Confirm Set Key Change window that opens, enter the new set key, which must be 1–16
characters long, consisting of only letters, numbers, and underscores.

3. Select Regenerate Item IDs to reset the counter to 1 and to apply new numbering to all existing
items.

IMPORTANT
Don't select Regenerate Item IDs if you want to restart numbering on newly
created items. Leave existing items as they are.

Manage releases
A release is a group of items that are developed together and mapped to a specific completion date.
Users can view releases and use them to assign items to a release.

NOTE
You must have project or organization administrator permissions to manage releases.

Project and organization administrators can set up and manage releases that others use. The releases
in the release list are used to populate the pick list for the Release field on an item. Releases are
automatically sorted by release date in the release list and in pick lists.

1. Select Admin > Project, then select Release List.

2. Select the option you need:
• Add a release

Select the green Add release button in the toolbar to open the Add/edit release window. Add
the name, description, release date, then select Save. 
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TIP
You can also add a release from the Releases tab at the top of the left panel.

• Edit a release
Select Edit in the Action column for the release you want to edit. This opens the Add/edit
release window where you can edit the name, description and release date and select Save. 

• Delete a release
Select Delete in the Action column for the release you want to delete. Select Yes to confirm.
Releases can't be deleted if any items are assigned to them. To remove all assigned items,
select the Releases tab and move all assigned items from that release to another release.

• Archive a release
Select Archive in the Action column for the release you want to archive. Select Yes to confirm.
You can view archived releases by selecting View archived releases in the toolbar where you
can select Unarchive.
Archived releases don't appear in filters or search results, but items assigned to any archived
release do. The Release field for these items is populated and has "(Archived)" appended to the
release's version field.

NOTE
Administrators can also configure default release settings [273] that show how
releases are displayed.

Manage attachments

NOTE
You must have project or organization administrator permissions to manage attach-
ments.

1. Select Admin > Project, then select Attachments.
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2. From the toolbar, you can add, edit, or delete attachments.

3. In the Add/Edit File Attachment window, add or edit information about that attachment. Select the
History bar at the bottom of the window to pull up a version history for that attachment to compare
versions.

4. Select Upload and Save.

From Single Item View, any user can now add that attachment [89].

Manage tags
From the Tag Management tab, you can view, edit, and create tags.

NOTE
You must have project or organization administrator permissions to manage tags.

• Select Admin > Project, then select Tag Management to add, edit, or delete tags.

From Single Item View, any user can add that tag [87].
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Manage workflows

NOTE
You must have project or organization administrator permissions to manage workflows.

1. To manage workflows as a project administrator, select Admin > Project.

2. Select the Workflow tab, then select Override for the workflow you want to edit.

3. In the Workflow Configuration section, set up a project workflow [653], then click Save.

Set up projects workflow

NOTE
You must have project or organization administrator permissions to set up projects
workflow. 

1. To manage workflows as a project administrator, select Admin > Project.
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2. Select the Workflow tab, then select Override for the workflow you want to edit.
If the organization administrator has configured it [615], select Override to make changes to any
workflow.

You are prompted to confirm the changes.
3. In the Workflow Configuration section, select the following options for the workflow you're creating.

• Enable workflow for this organization
• Allow project managers to override workflows on a project

Important: If you don't enable this option, performance might be impacted and it could trigger a
long transaction if the organization has over 10 workflows.

• Workflow for Item Type
• What picklist field should workflow apply to
• Version items on workflow status change
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NOTE
You can only associate one pick list field per item type. The field you associate
must be a pick list field; multi-select lists don't work.

4. In the first row of the Current Status table, specify an initial state for the item when it's created. This
is the default status of the item, and it overwrites the default field status if one is set.

5. In the following rows, specify the workflow, who is allowed to make those transitions, and the
actions that occur when an item changes status. For example, like locking the item or sending an
email.

TIP
Use the pull-down to move the current status to a new status and trigger related
actions or notifications.

6. Edit the Action text to make messaging more useful or clear.
7. Use the green plus button or the red minus button to add or remove transitions in your workflow.
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8. Select the lock icon to lock or unlock the item when it reaches a certain status (like "draft,"
"approved" or "complete"). 

NOTE
This lock is a "system lock" that's slightly different from a user lock. A user lock
can still be edited by the user who locked it and easily unlocked by the same user
or an admin. If an item is in a system lock, no one can edit the item. Admins can
still unlock the item, but we recommend using transitions to move an item to a
state where it can edited again.

9. Select the link in the Transition permissions column to choose who can make these transitions. 
10. Select the link in the notifications column to send an email notification when a user transitions

the status of an item. 

If you send a notification, a message appears where you can document the transition and reason
for changing the status.

11. Click Save.

Configure workflow
Workflows aren't project-specific. When you configure a workflow, it applies to the item type across
projects.

NOTE
You must have organization or process admin permissions to complete this task.

Important considerations

• If the organization admin selects Allow project managers to override workflows on a project, the
project admin for each project can set up the workflows.

• If you disable a workflow, Jama Connect stores your settings for later use.
• An organization admin can disable a workflow from the Workflow Administration section.
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• Selecting these Workflow options, Enable workflow for this organization and Allow project man-
agers to override workflows on a project might impact system performance.

• Workflow applies to all projects using the selected item type and can't be disabled at a project level.

To configure workflow:

1. Select Admin > Organization, then select Workflow.

2. Select options to enable workflow for all projects using this item type:
• Enable workflow for this organization.
• (Optional) Allow project managers to override workflows on a project.

3. Under Workflow Administration:
• To start a new workflow, click Add/Edit.
• To edit a workflow, click Config in the Action column.

From here, a project admin can continue to set up the project workflow [653].

Lock items in a workflow
Locking items in a workflow can help avoid unwanted changes. For example, a project administrator
might want to leave items unlocked while in "draft" status, but lock them when they reach "approved"
status.

NOTE
You must have organization or project admin permissions to configure workflow.
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Important considerations

• Items can also be automatically locked by the workflow [230]. These items show a gray lock after
their name and a blue lock in List View. 

• System-locked items unlock when transitioned through the workflow or by an organization or project
administrator.

To add an automatic lock to the workflow:

1. Select Admin > Project > Workflow.
2. For the item you want to lock, select Override.
3. In the Lock? column, select the lock icon to include (or remove) an automatic lock in the workflow.
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4. Click Save settings.

Unlock system-locked items
Anyone can view the list of system-locked items, regardless of permissions. However, only an organiza-
tion or project admin can unlock items that are system-locked.

• Organization admins can unlock all system-locked items.
• Project admins can unlock only system-locked items where they have admin permissions to those

items.

To unlock system-locked items:

1. Select your name in the header to open the My Profile window.
2. Select System Locked Items to see all items that were automatically locked [234] (blue lock).
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3. Select the items you want to unlock, then click the Unlock icon in the top right corner of the
window.

Configure project settings

IMPORTANT
You must be a project or organization administrator to complete this task.

1. Select Admin > Project > Settings, then select Edit.

2. On the Settings page, you can make the following changes:
• Version items

Turns automatic versioning on and off when using the Save and close option. You might want to
turn versioning off while initially creating and organizing the project.

• Max items displayed in Explorer Tree
Sets the maximum number of items that are displayed per container (project, component, set, or
folders) when using the Explorer Tree. After an import there might be thousands of items so this
can be configured to improve performance when working with large data sets.

• Save test run defects here
Defects that are recorded in the Test execution window are automatically sent to this location
in the project. The Defect item types must be a Visible item type for them to appear. For more
information, see Configure project item types [646].

Project and baseline cleanup
Project cleanup can be used to remedy issues that occur from inconsistent references or inactive items.

For example, users might experience inconsistencies between the Explorer Tree, List View, filter re-
sults, or see these messages:

Jama Connect User Guide

660



• "This item was deleted."
• "You don't have permission to perform this action."

Project cleanup recalculates sort orders and compares them with the database to solve these problems.
It doesn't require re-indexing or downtime.

TIP
Perform a cleanup at a time of low usage.

• Select Admin > Project > Clean Up, then select Clean up project or Clean up project baselines.

A confirmation message appears when the process is finished.
Self-hosted customers can ask a system administrator to verify the results in the log.

Index project items
Sometimes project indexes get out of sync due to field configuration changes, large batch updates, API
updates, and various other functions.

Index project data if you see data that's incorrect or doesn't exist. For example, failed batch updates, or
an item that shows a value in a field, but a search for that field value doesn't return the item.

NOTE
You must have project or organization administration permissions to index project
items. 

• As a project administrator, select Project > Index and click Index items.
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If this doesn't resolve the problem, the system administrator can try doing a full index of items [543].

TIP
Large files over 25 MB aren't indexed and therefore, their content isn't searchable.
The following filetypes are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF. The
following filetypes aren't indexable: XLSX, XLS, XML, HTML, HTM.

View project users
From the Users tab, you can view information about each user, such as email, license type, login
information, and user status.

NOTE
You must have project or organization administrator permissions to do this.

1. Select Admin > Project, then select Users.

2. (Optional) select Subscriptions to unsubscribe notifications for individuals or groups.

TIP
Individual users can manage their own subscriptions in their profile [41].

Manage project groups
As a project administrator, you can manage groups of users that already have access to a project.
These groups are valuable when fine tuning permissions or creating email lists.
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NOTE
You must have project administrator permissions to manage groups at a project
level. You must have organization administrator permissions to add, delete or edit
groups [574] at an organizational level.

1. Select Admin > Project, then select Groups. 

2. Select Add Group in the top right toolbar.
3. In the window that opens, give the group a name and description, then select users for the group

and select Save.
4. For project level groups, you can edit the group name, description, or members, as well as editing

a group's subscriptions. You can also delete the group. Use the buttons in the Actions column of
the group you want to edit. 

NOTE
A system administrator can disable or enable the project administrator's ability to add
groups [512].

Jama Connect User Guide

663



Edit user subscriptions
Users can subscribe to and control their own email notifications. However, if a user's subscriptions were
added by someone other than the user, only an admin can make changes.

Organization admins can unsubscribe a user; project admins can only mute a user's subscriptions.

NOTE
You must have organization or project admin permissions to complete this task. 

To edit a user's subscriptions:

1. Select Admin > Organization, then select Users.
2. Select Subscriptions in a user row to open the Edit subscriptions window.

3. Select a user from the left column to display their current subscriptions in the right column.  
• To remove a single subscription, click Unsubscribe in the Action column.
• To remove multiple subscriptions for a user, select the subscriptions in the Notifications column,

then click Unsubscribe selected in the top right corner.
4. To edit a group subscription, select Admin > Organization > User groups > Subscriptions.

Grant project permissions

NOTE
You must have at least project administrator permissions to complete this task. An or-
ganization administrator [589] or system administrator [509] can also grant permissions
at an organization or project level. A system administrator can enable or disable the
project administrator's ability to grant project permissions [512].

1. Select Project > Project Permissions.
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2. Select the project, component, set or item for which you want grant permissions in the project
selector on the left. From here, you can use the toolbar to:  
• Select Add permissions to add a new user or group.
• Select Modify in the row of a user or group you want to edit.
• Select Remove in the row of any user or group for which you want to delete permissions.
• Select Override to override the inherited permissions for this user or group.

TIP
When a row contains the value True in the Inherited column and is highlighted
in green, this means the group or individual has received its permissions from a
higher level. Select Override in the Actions column to change these inherited
permissions.

3. In the Add/Edit access window, you can grant the set of permissions that come with the role of
project administrator, or you can grant access permissions for the selected item, set, component.
Select Save.

4. Alternatively, select Remove to take away all permissions from the user or group for that project,
set, or folder.
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Reference

Jama Connect provides several tools and topics that help you use the application and quickly find
answers, whether you're a new or experienced user.

• Glossary of terms [678]
• Quick find [148]
• Best practices and guardrails [672]
• Application performance testing [674]
• Keyboard shortcuts [673]
• Permissions by license type [583]
• Get help [676]

Permissions
Permissions allow users to do things such as access, modify, and delete items, as well as to perform
other specific tasks. Permissions control how users experience Jama Connect by restricting actions
they can perform and the content they can see.

What determines permissions?

• License type [583] assigned to a user
• Roles [669] (permission sets) granted to a user
• Access permissions [671] granted to a user for specific projects or containers

Who grants permissions?

• System administrator [509]
• Organization administrator [589]
• Project administrator [664]

License types and permissions
Organization admins and user admins assign license types to users. They can also view the current
license [587] assigned to users, as well as assign users license types [582].

The type of license limits the possible permissions and roles that can be granted to a user. License
types include creator, stakeholder, test runner, and reviewer.

Regardless of the assigned license type, each user has a unique login consisting of username and
password.

Creator and reviewer licenses can be named licenses or float licenses; test runner licenses and stake-
holder licenses are named only.

Types of licenses

License type Definition Named li-
cense

Float license

Creator Gives full read and edit rights and full access to reviews to active
users who daily manage items and projects.

X X

Test runner Gives basic permissions to read and review, as well as the ability
to create test plans and defects, to execute test runs, and to add
attachments to test runs during execution.

X
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License type Definition Named li-
cense

Float license

Stakeholder Gives read-only privileges to those who need visibility into a project,
but don’t need editing rights. Stakeholders can view items, provide
comments, and act as reviewers.

X

Reviewer Grants permission to participate in reviews, act as approver, moder-
ator, or review admin, and to respond to comments in the stream.
Reviewers can't initiate reviews or access items in the core project.

X X

Temporary A 30-day full creator license automatically granted to a non-licensed
individual, invited by email to a review or to comment in the stream.
The only default permissions are for the discussion thread or review
to which they were invited.

X X

Collaborator
(Legacy)

A legacy license; gives read-only privileges to users needing visibility
into a project, but not editing rights. They can view items, provide
comments, participate in (but not create) reviews, execute test runs,
and log defects.

X X

Permissions by license type
The type of license assigned to you defines your permissions, which in turn determine your ability to
create and edit items and to access items as read-only.

With a creator license and read-only permissions to a project, you can:

• Execute test runs
• Log defects from the test run execution window

* Permissions that are included with each license type.
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Roles
A role is a set of permissions that allows a user to perform specific functions. Each permission type
defines the functions it allows.

An admin grants permissions by role [669] to an individual or to a group.

NOTE
Permission roles are different from other types of roles such as review roles [162] and
Signer roles [259].

Types of roles

Role Definition

System admin [489] 

(self-hosted only)

Handles installation, setup, and configuration of Jama Connect, and has no access to projects.
System admin is a special user that isn’t a role for other users. It doesn't require a license and
logs in to the system with the username "root."

Organization admin [549] Controls all aspects of configuring Jama Connect, its users, and its groups.

User admin [573] Manages licenses, users, and groups; can see all users and organization groups in the system.

Process admin [593] Configures content and connections within Jama Connect; controls item types, pick lists, relation-
ship rules, Review Center, and workflow; delegates these responsibilities to appropriate users
and groups.

Project admin [643] Focuses on permissions, project groups, and workflow customization.

Add Project Allows a user to create a new project or duplicate an existing project where that user is project
admin.

Review admin [192] Has access to a review's content when the review is public. A review admin is also a reviewer,
approver, or moderator in the review. Permissions must be assigned by an organization admin.

Reuse admin [322] Manages reuse. Requires read access to the synchronized items they are working with, and write
permissions to edit, synchronize, reuse, or duplicate those items.

Report admin [565]

(self-hosted only)

Allows the report developer to upload and manage BIRT, Velocity, and Word templates. Reports
are assigned to specific projects where the report admin has project management rights.

User admin limitations

• Can set permissions only for groups/users on projects where they are project admin.
• Can manage organization group membership only for groups where they are a member.
• Can't make changes or additions to users or groups that have been assigned to organization or

process admins except for activation/deactivation and license management.
• Can manage only members of a group where they are also a member. This restriction ensures they

don't unintentionally provide or remove access to unknown or existing projects.

IMPORTANT
Users must have the license type [583] that allows for the permissions granted with
each role.
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Permissions granted by role
A set of permissions is included with the user's license type [583]. Users can also be as-
signed roles [591] that grant additional permissions.

The role of system admin only applies to self-hosted customers.

For role-related permissions to work, users must have the required license type.

Roles and permissions
Permissions and roles control how users experience Jama Connect. They restrict users' actions or the
content users can see.
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Roles provide access to the administrative features of Jama Connect. Roles are assigned by adminis-
trators to individual users or to groups.

Permissions control read and write access to your project. You can be granted permission to an entire
project, to a project’s folders, or to a collection of items in a project. Permissions are assigned to
individual users or to groups.

Permissions are inherited from higher levels in the organization structure and can be set at different
levels:

• Organization
• Folder
• Project

Once permissions are set on a project, they can be adjusted based on the organization of the project
Explorer Tree.

NOTE
To be able to access the project, admins must set the permissions before adjusting a
set or component.

Best practices for admins

• Set permissions at the highest level possible. This helps you track existing permissions for a user or
group when many one-off changes are made.

• Use groups instead of individual users. Using groups reduces the volume of entries and ensures
consistent setup of users who require similar access.

Permission questions and scenarios

Question I want to provide general user management to my IT group, but how do I restrict access to sensitive projects and
project groups?

Answer Assign the user admin role. This role is limited to viewing and administering project-level permissions on projects
only where they are a project admin.

They can still create users, deactivate existing users, manage their participation in organization groups, and config-
ure licenses.

Question Can a user admin grant themselves or others the process role or organization admin role? Can they change their
own permissions?
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Answer No, only an organization admin can set the org and process roles.

A user admin must be a project admin to adjust permissions to a project. If they remove their own project admin role,
they no longer have access to that project’s permissions.

Question Why aren’t there any options to override permissions on certain users or groups?

Answer This restriction controls visibility and access across projects that might belong to different divisions or contains
sensitive information that you don’t want exposed to all users.

If you want your user admin (user or group) to have access to all projects and project groups, assign the project
admin role at the organization level.

Question Why can’t my user admin see all groups where a user is assigned?

Answer By default, user admins can’t access all projects. The user must be a project admin to access the groups for that
project.

Question Why can’t my user admin manage the membership in an organization group?

Answer User admins can only provide access to projects they can access. To access a project, they must be a member of
that project's organization group.

When they aren't a member of the organization group, the project isn't visible to them, so they can't provide access.

Question Why am I getting “no permissions” error when I try to add a user to a group?

Answer The group might have permission to access projects that you don’t.

Question Why can’t my process admin see all projects when assigning relationship rules?

Answer A project might contain sensitive information, so access is restricted. The list of projects shows only projects where
the process admin is also a project admin.

If you want your process admin (user or group) to have access to all projects and project groups, assign the project
admin role at the organization level.

Question Is there a way to limit the item types that a process admin is able to see?

Answer Not at this time. This is a future option under consideration.

Question I just made a user an organization admin. Why can’t the user access certain projects?

Answer The option to override an organization admin’s access is no longer available. To avoid confusion, remove any
overrides on organization admin users/groups that you made in the past.

Question Does the process admin have access to all projects and users?

Answer Process admins only have access to the projects where they are a project admin.

They do have access to users and organization groups for assigned workflow transitions.

Question The @mention feature isn’t working for my users, regardless of project permissions on the Stream page.

Answer The top-level option to create comments has a new configuration that disables this option by default. Context-free
comments (not made from a project or item) created confusion and exposed users and groups to all system users.

The @mention from the Stream page is now limited to include only users and groups that align with the commen-
ter’s project permissions. This change tightens security and eliminates accidental exposure of users or groups.

Question As a project admin, why can’t I add users to my project if they are in the same system?

Answer Your organization has configured the settings for Jama Connect to restrict project admins’ visibility of users and
groups to only their project’s permissions.

If you want your project admins to have access to all users and groups, your organization admin can configure the
setting on the Organization Detail page.

Question I’ve given a user with read/write permissions access to a set in my project, but they still can’t see the project.

Answer Permissions must first be set on the project. Once the user has read or read/write permissions to the project, they
can access the set. You can provide or remove permissions to other sets or components in the project to modify
access.

Question I removed a user’s access to a component. Why can they still see it?

Answer Users receive the highest level of rights assigned to them. If a user is part of a group that has permissions to a
component, you can make one of the following changes:

• Change that group’s permissions to exclude the component.
• Remove the user from the group so the individual entry is now the highest level of rights assigned.

Access permissions
With access permissions, a user can create, read, and edit items.
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Levels of access permissions

• Read/Write — A user with these access permissions can read write edit and delete
• Read-only — A user with these permissions can read, but not create or edit items.

How permissions are granted

• Organization admin — Grant access permissions at an organizational level [589].
• Project admin — Grant access permissions at a project level [664]. 

Relationships and access permissions
Your ability to interact with relationships depends on your access permissions for each of the related
items. Read more about permissions [583]. 

Permissions for
current item...

Permissions
for related

item...

You can...

Read/Write Read only • View trace relationships.
• View ID and name of related item.
• Modify relationships.
• Create new relationships.
• Navigate to related item and clear suspect links.

Read only or
Read/Write

No permission • View trace relationships, but not modify or create new relationships.
• See ID and name, but not navigate to related item.

Read only Read/Write • View trace relationships.
• Modify relationships.
• Create new relationships.
• Navigate to related items and clear suspect links.

Read/Write Read/Write • Create, modify, and delete relationships.
• Navigate to related items and clear suspect links.

Read only Read only • View trace relationships.
• Navigate to related items, but not create or modify relationships between the two

items.

Best practices and guardrails
Best practices and guardrails provide proven guidance that helps you get the most out of your experi-
ence with the Jama Connect application.

Change/use
this...

For this result...

Explorer Tree
settings

When your project has a large number of items, you can improve performance by changing the Explorer Tree
settings to only show folders and components [47].

Filters Filters that run against all projects find and display results for all items in your Jama Connect application.
Filters like these can return large data sets and degrade performance. To assure quality performance, make
filters more specific to return only the results you need.

Items and at-
tachments

When working with more than 1,000 items per folder, hide items in the Explorer Tree [47] and work with them
in List View [54] in the center panel. To move multiple items, multi-select in List View and drag them to their
new location in the Explorer Tree.

Files larger than 25 MB aren't indexed so their content isn't searchable.

• Indexed file types: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF
• Non-indexed file types: XLSX, XLS, XML, HTML, HTM

Item field con-
tent

Keep the content of item fields to fewer than 10,000 characters (2,000 words). When you compare review
versions, the applications might skip fields with lengthy content.

Reuse and synchronization of hundreds of items can affect system performance, causing it to feel slower than
usual for users and decrease performance for other processes such as exporting.
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Change/use
this...

For this result...

Reuse and
synchroniza-
tion

If you try to reuse and synchronize a very large number of items, a warning appears if it’s likely to impact
performance.

If you still want to do this, consider reusing items in smaller batches or starting a large reuse and synchronize
process during off hours when there is less competition for resources.

Review items We recommend that reviews contain fewer than 250 items. This threshhold is in place to mitigate any
performance issues that could come from a review with an excessive amount of items.

Keyboard shortcuts
Use the following shortcuts to navigate throughout the Jama Connect application.

NOTE
In general, Mac users can substitute the Cmd key for the Ctrl key and the Option key
for the Alt key. Depending on your keyboard, you might also have to press the Fn key.

Table 4. General navigation
Key command Function

Esc Close an open window. 

Tab Navigate from field to field in List View or Single Item View.

Enter Selects a highlighted button or open a selected item.

Arrow keys Scroll through items, tags, releases, baselines, or test plans in the left panel.

Table 5. Inline editing in List View
Key command Function

Esc Cancel unsaved changes.

Tab Move cursor between editable fields.

Enter Save changes and move to the next item in the list.

Table 6. Rich text accessibility
Key command Function

Alt + 0 Open window with accessibility instructions.

Alt + F10 Enter the toolbar or the tab list of the open window.

Ctrl + right-click (Windows)

control + command + click (Mac)

Access native browser spellcheck menu.

Tab Move to the right between groups of toolbar buttons.

Shift + tab Move to the left between groups of toolbar buttons.

Right arrow Move to the next button to the right.

Left arrow Move to the next button to the left.

Enter Activate a selected button or menu option.

Table 7. Rich text navigation
Key command Function

Home Jump to the beginning of the line.

Ctrl + Home Jump to the beginning of the document.
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Key command Function

End Jump to the end of the line.

Ctrl + End Jump to the end of the document.

PgDn Scroll down the document by the length of the editing area.

PgUp Scroll up the document by the length of the editing area.

Ctrl + L Open the link window.

Table 8. Rich text writing and formatting
Key command Function

Shift  + Enter Add a line break.

Ctrl + Z Undo the last change.

Ctrl + Y Redo the last change.

Ctrl + C Copy a text fragment to the clipboard.

Ctrl + V, Shift + Insert Paste a text fragment from the clipboard.

Ctrl + X, Shift +  Del Cut a text fragment to the clipboard.

Ctrl + B Apply or remove bold formatting. 

Ctrl + I Apply or remove italic formatting. 

Ctrl + U Apply or remove underline.

Ctrl + A Select all field contents.

Shift + Arrow Select text letter by letter.

Ctrl + Shift + Arrow Select text word by word.

Shift + End Select a text fragment from the cursor to the end of the line.

Shift + Home Select a text fragment from the beginning of the line to the cursor.

Ctrl + Shift + End Select a text fragment from the cursor to the end of the document.

Ctrl + Shift + Home Select a text fragment from the beginning of the document to the cursor.

Shift + PgDn Select a text fragment of approximately the length of the editing area, starting from the cursor and
going down.

Shift + PgUp Select a text fragment of approximately the length of the editing area, starting from the cursor and
going up.

Table 9. Review navigation
Key command Function

Tab Move from one highlighted comment to another.

Table 10. Test case authoring
Key command Function

Tab + Shift Move cursor between editable fields and row actions.

Esc Move focus from cell to row, row to table.

arrow-up and arrow-down When focus is placed on row, navigate up and down through table rows.

When focus is placed in cell, navigate through lines of text.

Enter When focus is placed in cell, enter a line return when rich text is enabled.

When focus is placed on row action, the action is performed.

When focus is placed on Add step, add a new step and move cursor to the first cell of new row.

Application performance testing
Jama Software runs daily performance testing of Jama Connect. The frequency depends on your
environment.
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Self-hosted performance test results
Self-hosted environment — Daily performance testing

These performance test results indicate a large self-hosted environment with 1,250 concurrent users.

• All requests were serviced during the testing period of 90 minutes with no un-intentional errors.
• 82% of requests were serviced in under 1 second.
• Longer running operations (like bulk updates and copies) were serviced within tolerances.

• Performance tests consider different user personas commonly found in our customer base, with the
most common and active users being Staff Engineers and Testers (Creators [666]).

• The total of unique, concurrent users spread across the personas was 1,250.
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• This graph shows the distribution of serviced requests during the test with response times expressed
in milliseconds (ms).

• 79% of requests were serviced in under 305ms with 99.5% of requests serviced in the consumer web
target of under 3 seconds.

Get help 
Do you have a question that's not covered in the Jama Connect User Guide?

Visit our Support Community where you can find answers, start discussions, share ideas, and access
developer documentation.

As part of your contract, your organization can get additional help from our support staff. Your organiza-
tion's named support contact can submit tickets directly to our support staff.

If you have a large team to train quickly, need to integrate Jama Connect with other tools, or want to go
beyond the basics, Jama Software offers training courses and other professional services to help you
be more successful.

• Education and Tutorials
• How-To Videos and other Resources
• Business Services

Let us know how we can help you.

Widgets
A widget is small embedded application that adds functionality to the dashboard or to item types.

This table includes all widget types, their definitions, and how they are used.

Widget Definition

Activities* Lists all the changes users made to an item: adding, relating, editing, deleting, and restoring.

Activities are listed in chronological order.

Users can search their activity history and filter on activity types.

Attachments* Shows external files attached to an item: images, documents, and spreadsheets.

If your organization has a document management system, link from a Jama Connect item to the file in
your document management system, rather than duplicating files in Jama Connect.
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Widget Definition

Change Request* Indicates that the item is linked to one or more change requests.

Example: If the icon includes a number, the item is linked to that many change requests and is automati-
cally added if the item is linked to a change request.

Comments Indicates that a user made comments on the item.

Generally used for day-to-day collaboration with colleagues and tracking questions, decisions, and issues
about items.  These comments are only visible to users with permission to see the Jama Connect project.
Comments from reviews are separate and not included here.

Enabled by default.

Connected Users Shows a creator, editor, or someone who has commented, subscribed, or is @mentioned in an item. Also
shows users on upstream or downstream traced items.

Enabled by default.

Items to be
changed

Indicates when a user links to requirements, tests, and other items that require a change.

Visible only on item types where the Change Request widget is enabled.

Links* Adds links to an item by associating a link with that item or embedding a link in a rich text field within the
item.

Hyperlinks can also be added in any rich text field.

Relationships* Shows items that are related for traceability.

Example: A requirement might be linked to upstream customer needs multiple downstream test cases.

Review comments Shows comments for reviews where this option is enabled.

Risk* Shows the link from requirements, mitigations, or verifications to a particular risk.

Sub items Shows the number of items directly under a currently viewed item in the Explorer Tree.

Example: The "System" component has five sub items:
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Widget Definition

Synchronized
Items*

Monitors differences between reused items and containers.

The number of items that an item is synchronized with is displayed in the blue circle.

Example: If a source item version changes, all reused items are flagged as "out of sync" so you can
compare differences.

Tags* Labels items so you can find similar items quickly.

Any user with create and edit permissions can add a new tag.

Users with project admin permissions can edit or delete existing tags.

Test Runs Shows the results from a Test Plan and Test Cycle.

Jama Connect allows one Test Case to many Test Run results.

The number indicates the number of active Test Runs.

Visible only on item types where the "Use as" setting is Test Case:

Versions* Shows the number of versions.

A new version is created each time you change an item. You can compare versions or revert to a past
item.

* Widget is only visible on item types where an organization admin has enabled [611] it.

Recommended
At minimum, enable these widgets:

• Activities
• Relationships
• Synchronized items
• Versions

Glossary
Term Definition

actions A tag that identifies a comment in a stream conversation as one of three types: decision, question, or issue.

approver A role in the review process with the ability to approve or reject an item for correctness or completeness.

attachment External files such as images, documents, and spreadsheets that can be attached to an item.

baseline A fixed reference point that captures the state of selected items and their relationships within a project at a
specific point in time.

Baseline Com-
pared to Current
Report

A report that displays a side-by-side comparison of items and relationships in a baseline and their current
versions.

Baseline Com-
parison Report

A report that displays a side-by-side comparison of items and relationships in two baselines.

baseline ID A unique ID assigned to each baseline. Baseline IDs are automatically generated and numbered sequen-
tially in the order they were created. They can't be edited or duplicated.

batch transitions A workflow feature that allows you to select multiple items of the same item type and transition them to a
different workflow status.

Jama Connect User Guide

678



Term Definition

Bidirectional
Traceability Re-
port

A report that displays upstream and downstream relationships for a selected container of items.

bookmarks Links to content you view frequently at the top of your homepage.

bottom panel A panel that slides in from the bottom of the center panel to give more detail on items such as relation-
ships, the activity stream, version history, and merged items.

change request A formal proposal that identifies changes to items in a specific product or system.

child item An item that falls hierarchically below a parent item of the same item type.

collaborator li-
cense

A named or floating license that gives read-only privileges to users needing visibility into a project, but
not editing rights. These users can view items, provide comments, participate in (but not create) reviews,
execute test runs, and log defects.

comments User-created messages found in the stream or in reviews.

Compare View A side-by-side view of content that helps you compare differences between versions of an item.

component A structural container used to organize a project into more manageable pieces.

container A Jama Connect unit for organizing document items. Containers include three types: components, sets,
and folders.

contributor In risk analysis, a role in that can open, view, and edit any analysis where the user is invited. Contributors
must have a creator license in Jama Connect.

coverage The extent to which items are validated by another item.

Coverage Explor-
er

A tool to view or export a set of items, including related items that provide needed coverage.

creator license A named or floating license that gives full read and edit rights, and full access to reviews, for those who are
active users managing items and projects on a daily basis.

dashboard A visual display of Jama Connect data. It can be configured to show key metrics about your project, to
highlight which areas might need attention.

dashboard widg-
et

A small embedded application that compiles and displays data from a single project or filter.

downstream A way to identify a relationship between items. If one item is downstream from another, it might be
impacted by that item.

electronic signa-
tures

A digital process that indicates a user’s acceptance of a document, item, or process. In Jama Connect,
electronic signatures are used to approve a review or baselines.

Explorer Tree A method of structurally and visually organizing the sets, components, folders, and items in your project
hierarchy.

export An action that extracts data from Jama Connect to a Word or Excel document.

field A fixed location in a unit of data such as a record or computer instruction that has a specific purpose and
usually a fixed size.

filter A method to display subset of items, users, or reviews from a larger collection. These are available as
simple or advanced filters.

folder A type of container used to organize your work. Jama Connect uses item folders, baseline folders, and
project folders.

global ID A unique identifier of items connected through synchronization.

homepage The start page that is displayed when Jama Connect first opens. It can show links to your most relevant
content, like bookmarks, recent views, open reviews, and stream comments or actions.

Impact Analysis In requirements management, a method to show the implications of a proposed change to all upstream and
downstream related items.

Import An action that incorporates data into Jama Connect from an external source such as Microsoft Word,
Excel, and IBM doors.

Import Relation-
ships Plugin

A tool that helps you batch-create links between existing items in the application.

index A list of information about each item that ensures proper display, sorting, filtering, and searching of data.

item The building blocks of Jama Connect. Projects are made up of items. Items are made up of fields. Items
can be containers (sets, folders, components or parent items) or documents (features, requirements, test
cases, tasks, defects).

item counter A tool that automatically assigns numbers to items as part of their ID.

item ID Unique identifiers for each item that, unlike a Global IDs, can't be duplicated.

Items in a Set Re-
port

A report that displays a tabular list of items in a set.
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Term Definition

item types The templates for sets used within each project.

item widget A graphical element of the UI that adds functionality to an item type, for example, adding links, attach-
ments, relationships, and tags.

left panel The area of the UI where you can find and organize your data. It contains the Explorer Tree, advanced
filters, releases, baselines, tests, and tags.

license The document that gives permission to an organization to install and run the Jama Connect application.

license type The possible permissions and roles that can be granted to a user (for example, creator, stakeholder, test
runner, and reviewer).

List View A way of viewing data from multiple items in a table with a different field in each column so you can sort,
select, and compare items at a glance.

lock A method to make items read-only. Locks can be set automatically or manually.

moderator A user who creates and manages a review. Moderators must have a creator license type.

notifications Optional emails sent to groups or individuals alert you when certain changes are made.

Office Templates Word documents and Excel spreadsheets that allow you to add formatting to your exports.

organization A representation of the entire group of users who have access to your instance of Jama Connect as well as
all the projects, items, and data.

organization ad-
min

A role with administrative control of the Jama Connect application. An organization might have one or more
organization administrators.

permissions A way of allowing users the ability to access, modify, and delete items or perform other specific tasks.

pick lists A set of defined values that can be entered into a field.

project A way of organizing your data in Jama Connect. A project is made up of items, filters, baselines, releases,
reports, and tests.

project admin A role that has the necessary permissions to manage a particular project.

project key A unique identifier, automatically created with each project, which makes up the first part of each item's
Unique ID.

project workflow A well-defined sequence of the tasks and activities required to complete a specific project. In Jama
Connect, you set up a workflow in Projects, so that users can move project items along a similar path as
they progress.

Reading View A way of displaying text and images for a particular group of items so you can read through selected items
like a document.

relationship A way of linking items together that can help you assess the impact an item or group of items can have on
other items.

Relationship Sta-
tus Indicator

A tool that shows the number of  relationships an item has, as well as whether those relationships meet the
project's relationship rules.

release A group of items that are developed together and mapped to a specific completion date.

Release Status
Report

A report that displays the current state of the items within a particular release.

Replicated snap-
shot

A backup of the Admin Console settings, Docker containers, and the Jama Connect license.

report A document that helps you analyze the current status and progress in your work. Reports can include
graphs, tabular data, metrics, and other roll-ups.

required fields String, text, or date fields that are configured so that the user must enter data into the field before saving an
item.

REST API An application program interface to assist developers in a clean, straightforward integration with the appli-
cation.

reuse The duplication of an item within a project or to a different project where it can be modified without affecting
the original item.

reuse admin A role with the permissions needed to manage reuse.

review A process that helps teams, stakeholders, and customers collaborate in Jama Connect discuss, review,
revise and approve information.

review admin A role with the permissions needed to manage reviews.

Review Center
Stats Report

A report that displays the progress of a specific review.

reviewer A role that participates in a review to provide feedback.

reviewer license A named or floating license that grants permission to participate in reviews, act as approvers, moderators,
or review administrators, and respond to comments in the stream. A reviewer license doesn't allow users to
initiate reviews or access items in the core project.
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Term Definition

Reviews work-
flow

A tool for moderators to update the status of reviewed items. When configured, the reviews workflow
automatically updates field values for review items of the same type and review status.

right panel A panel that slides out to provide more specific information about the data you selected.

risk control
measures

The procedures or requirements implemented to reduce risk levels.

risk control op-
tions

The means by which a risk is reduced.

risk control veri-
fication

Confirmation that specified requirements were fulfilled.

risk ID A unique ID assigned to each row in an analysis. They are automatically generated across all analyses and
are numbered sequentially in the order they were created.

risk management The systematic application of management policies, procedures and practices to the tasks of analyzing,
evaluating, controlling, and monitoring risk. (ISO 14971)

search A function or process of finding letters, words, files, or other data in an index of all database fields, as well
as text within Word, PDF, or text attachments, to display a list of resulting items.

signature mean-
ing

A system setting that states the meaning of the electronic signature. It's required for FDA 21 CFR Part 11
compliance. In Jama Connect, it defaults to "I approve this review" and can't be modified. The signature
meaning is visible in review invitations.

signer role A role for an approver in the review process. Approval is provided with an electronic signature. Signer roles
are created from user group names.

role A set of permissions granted to a user so that they can perform a particular job.

set A structural container with configurable access rights, used to group items of the same type. It can also
contain folders, text Items, child text items and child items of the same type.

set key The key that identifies item sets within your project. The key doesn’t have to be unique across sets or
projects.

sequence of
events

The events that lead to a hazardous situation.

severity The measure of the possible consequences of a hazard.

stakeholder li-
cense

A named license that gives read-only privileges to those who need visibility into a project, but don’t need
editing rights. Stakeholders can view items, provide comments, and act as reviewers.

Single Item View A way to display the information about one item in the center panel.

stream A collection of the most recent comments and activities (adds, deletes, or edits).

suspect links Suspect links on an item mean it might no longer be correct or complete, because changes were made to
items upstream.

synchronization A method for monitoring for differences between reused items and containers. When differences exist,
users can update the data for those items or containers.

system admin A role that handles the overall installation, setup, and configuration of Jama Connect. The system admin
doesn't have access to projects, doesn’t require a special license, and is the only user who can log in to the
system as "root user."

system fields Automatically created fields such as name,  test steps, test case status, and review status, which provide
system functionality and can't be disabled or deleted.

system health re-
port

An optional feature that notifies administrators of areas of the application that can affect performance and
user experience.

tags Labels that you can attach to items to help identify items that have something in common.

Task List with Es-
timates Report

A report that displays all item types and sums their estimates if applicable.

temporary li-
cense

A 30-day full creator license, automatically granted to a non-licensed individual whose email address is
used to invite them to a review or to comment in the stream. It has no default permissions except for the
discussion thread or review to which they were invited, although an organization administrator can add
permissions.

test case Items that contain the tests needed to validate or verify product features or systems.

test case status An automatically calculated status that indicates the state of the last edited test run associated with that
test case.

test cycle Groups of test cases converted into a series of test runs that are ready for execution.

test group A way to combine and label similar tests in a test plan.

test plan An item that documents the overall strategy for validating or verifying that a product or system meets its
design specifications and requirements.
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Term Definition

Test Plan Detail
Report

A report that displays the details of a test plan.

test run An item used to record results for a test case you ran against your product.

test runner li-
cense

A named license that includes basic permissions to read and review, as well as the additional ability to
create test plans and defects, and execute test runs.

test run status An indicator of the current state of a test run, which is used in calculating test case status.

test steps Distinct steps used to run a test.

text item A specific and unique type of item that lives outside the boundary of other item types and doesn’t function
as a full feature. Unlike other item types, text items can be used as part of a mixed item set.

thread dumps A snapshot of the state of your application instances' processes at a point in time.

toolbar The part of the UI that is located at the top of the center panel. From there you can switch views, filter
items, configure fields, and export your data.

traceability A method for showing the relationship between items that depend upon and define each other. You can
always travel upstream or downstream to get more context and trace product definition from high level
requirements all the way through final tests.

trace matrix A visual representation of relationships within a project.

Trace Relation-
ships Report

A report that displays items with their downstream relationships.

Trace View A way of displaying related upstream and downstream items, missing relationships, and item details in
context of their relationship.

trial license A 30-day license granted to new users who sign up for a trial of Jama Connect on jamasoftware.com.

upstream A way to identify a relationship between items. If one item is upstream from another, it might impact that
item.

unique ID An ID that identifies an item with a project key, set key, and a set counter. A unique ID (also called item ID)
remains the same even if the item name or content is changed. It can't be edited or duplicated.

user A basic role associated with a unique Jama Connect login. Each user has their own license type, groups,
and permissions.

user group A way to manage notifications, permissions, access, and actions for multiple users at a time.

User Import Plu-
gin

A tool that allows organization admins to add multiple users at once by importing a spreadsheet.

User List Report A report that displays a list of all the active and inactive users associated with the organization.

version One of a sequence of copies of an item, each incorporating new modifications. There are versions of
reviews and versions of items.

viewer A role that can read, but not edit, a risk analysis.

widgets Small embedded applications that add functionality to the dashboard or item types.

workflow An automated set of transitions from one status to another, over the course of an item's lifespan.

Jama Connect Interchange (JCI)
Jama Connect Interchange™ is an integration platform that seamlessly integrates Jama Connect with
other best of breed tools like Atlassian Jira and Microsoft Excel.

Unlike other integration tools in the marketplace, JCI is built, supported, and continually enhanced by
dedicated teams at Jama Software. This means JCI is deeply integrated with Jama Connect configura-
tions and workflows, providing you with a smart and seamless sync while you continue to work in your
tool of choice.

JCI supports both cloud-based and self-hosted instances of Jama Connect.

To access the JCI library of resources, including release notes and a dedicated user guide, visit the JCI
sub-community on the Jama Software Community site. To learn about the key benefits and common
use case, see the Jama Connect Interchange Datasheet and Jama Connect Interchange User Guide.

To find out whether JCI would be a good fit for your organization, contact your Customer Success
Manager.
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Upgrading from Jama Connect traditional to KOTS

Jama Connect is a Linux-based application that runs on Docker containers and uses Replicated
software to "orchestrate" deploying applications. The current version of Jama Connect uses Replica-
ted KOTS, while older versions use traditional Replicated software. The process of upgrading Jama
Connect from traditional to KOTS includes planning, preparing your environment, and installing the
software.

Upgrade scenarios
Upgrade with new servers (recommended) — This recommended scenario uses new application and
database servers to support your KOTS Replicated environment. It requires you to:

• Copy targeted data from the existing application server into the new environment.
• Restore a backup of your current database to the new database server.

While this scenario results in the temporary overhead of supporting two separate environments, it
comes with less risk of unwanted downtime.

Upgrade with existing servers — This scenario reuses the current application and database servers
from your traditional Replicated environment. This scenario:

• Requires you to uninstall elements of the traditional Replicated platform before you can install the
KOTS Replicated platform. 

• Can cause significant maintenance downtime. Make sure to inform your users of this maintenance
window. Also have an emergency plan in place to revert back to the traditional Replicated environ-
ment if necessary.

Before you upgrade

• Contact your Customer Success Manager to request a KOTS internet or airgap license.
• Choose the upgrade scenario that works best for your organization. Whichever scenario you choose,

expect production downtime while the new instance is configured. Best to upgrade during off hours.
• Follow the instructions in the planning [684] and preparing [691] sections to ensure a successful

upgrade.

Components and what they do
Replicated KOTS — A container-based platform for easily deploying cloud native applications inside
customers' environments, providing greater security and control. The KOTS Admin Console is the
interface for installing, configuring, and administering the KOTS deployment of the Jama Connect
application and required services. See https://www.replicated.com/ for details.

Docker containers — A standalone executable package of software that includes code, runtime,
system tools, system libraries, and settings. See https://www.docker.com/resources/what-container/ for
details.

Jama Connect KOTS license — Contact your Customer Success Manager to request a KOTS license.
Save the license file to a location you can access easily; you will need it when installing Jama Connect.

For more information about KOTS, see https://www.replicated.com/blog/announcing-kots/
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NOTE
Replicated KOTS is the only supported platform for Jama Connect 9.0 and later. To up-
grade Jama Connect traditional to KOTS, see Upgrade from Jama Connect traditional
to KOTS workflow [684].

Workflow for upgrading from traditional to KOTS
Whether your environment is internet-enabled or airgapped, the upgrade process consists of three
stages: planning, preparation, and installation.

Review the system and server requirements for your environment, then follow the instructions for each
stage.

For this component... Follow these instructions

MySQL Install and configure MySQL

Microsoft SQL Install and configure Microsoft SQL Server

Internet Install KOTS software (internet)

Airgap Install KOTS software (airgap)

Local Elasticsearch Included by default

Remote Elasticsearch Configure dedicated Elasticsearch nodes

Planning your upgrade to KOTS
Before you upgrade from traditional to KOTS, make sure you have everything you need according to
your type of installation.

Important considerations

• We recommend that you use a new application server and database server. Once the KOTS Replica-
ted environment is installed successfully, the traditional Replicated environment can be removed.

• If you plan to reuse the existing application server and database server when upgrading:
• Make sure you pay careful attention to resource sizing. System requirements for the KOTS Repli-

cated platform are different from the traditional Replicated platform.
• This scenario requires that you uninstall the traditional Replicated platform, resulting in potential

unwanted downtime.
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What you need

All envi-
ronments

• The KOTS license file (submit a request to your Customer Success Manager).
• Run the KOTS preflight installation checks to ensure servers and settings are configured correctly.
• Record the size of existing data assets and database for application and database server requirements and re-

source sizing. To check the current assets size, run the following command from the application server command
line:
sudo du -shc /data/contour/*

• Record the existing settings from your traditional Replicated Admin Console. You can find the settings in the sup-
port bundle (under /daemon/replicated/app-config.json). These settings are used to configure Jama Connect after
the upgrade to Jama Connect KOTS.

• An application server with the necessary preparation and sizing requirements [689].
• A database server with the necessary preparation.
• Supported [687] 64-bit Linux distribution with a kernel of:

• 4.x or greater (recommended)
• 3.10 (minimum)

Airgap
environ-
ment

• The KOTS airgap license file (submit a request to your Customer Success Manager).
• PDF of this installation guide for the version of Jama Connect you are installing.

IMPORTANT
If you lose the URL and password, contact Support to generate new ones.

Optional • TLS certificate and private key to secure the Admin Console and Jama Connect application.

Run the KOTS preflight installation checks
Whether your environment is internet-enabled or airgapped, run the KOTS preflight installation checks
to ensure your system is ready for upgrade.

Important considerations

• The preflight checks verify that all server requirements are met to help avoid installation and upgrade
issues. When the results display green checkmarks for each test, you can begin the installation
process.

• If you are performing an in-place upgrade to 8.79.6, 9.0.4, or 9.6.x, the warning and failure messages
displayed during preflight are expected and can be ignored.
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To run preflight checks for internet-enabled environments:

1. Run the command on your application server:
curl -s https://raw.githubusercontent.com/JamaSoftware/kots-preflights/main/v2/non-airgap/\
application-server.sh | sudo bash

2. Run the command on your database server:
curl -s https://raw.githubusercontent.com/JamaSoftware/kots-preflights/main/v2/non-airgap/\
database-server.sh | sudo bash

3. Press S to save the file, then review the results.
4. Submit an Installation Service Request Form (guided for Self-Hosted) and include your preflight

check results to help our technical services team support your installation needs. Include any
questions or concerns about the results in the ticket.

To run preflight checks for airgapped environments:

1. From an internet-enabled server
a. Download the preflight script files for the application server:

curl https://raw.githubusercontent.com/JamaSoftware/kots-preflights/\
main/v2/airgap/linux/airgap-host-preflight_linux.tar.gz --output airgap-host-preflight_linux.tar.gz

curl https://raw.githubusercontent.com/JamaSoftware/kots-preflights/\
main/v2/airgap/linux/airgap-application-server_linux.sh --output airgap-application-server_linux.sh
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b. Download the preflight script files for the database server:
curl https://raw.githubusercontent.com/JamaSoftware/kots-preflights/\
main/v2/airgap/linux/airgap-database-preflight_linux.tar.gz --output airgap-database-
preflight_linux.tar.gz

curl https://raw.githubusercontent.com/JamaSoftware/kots-preflights/\
main/v2/airgap/linux/\
airgap-database-server_linux.sh --output airgap-database-server_linux.sh

2. From your application server
a. Save both application server script files to a directory on the airgapped application server that

will host your KOTS installation, then configure the file permissions for the shell script:
chmod +x <path to the files>/airgap-application-server_linux.sh

b. Run the preflight installation check:
sudo bash <path to the files>/airgap-application-server_linux.sh

c. Press S to save the file, then review the results.
3. From your database server

a. Save both database server script files to a directory on the airgapped Jama Connect database
server, then configure the file permissions for the shell script:
chmod +x <path to the files>/airgap-database-server_linux.sh

b. Run the preflight installation check:
sudo bash <path to the files>/airgap-database-server_linux.sh

c. Press S to save the file, then review the results.
4. Submit an Installation Service Request Form (guided for Self-Hosted) and include your preflight

check results to help our technical services team support your installation needs. Include any
questions or concerns about the results in the ticket.

System requirements and supported software (KOTS)
Make sure that your environment conforms to all requirements and recommendations before installing
Jama Connect software.

After reviewing the information on this page, see Things to do before installation.

IMPORTANT
To use Ubuntu 22.04, you must update the memory or Elasticsearch fails. From the
KOTS Admin Console, adjust the memory settings so that Maximum Memory is 6G
and Maximum Memory for Container is 8G.

Application server
Use the information in this table for the server that runs the Jama Connect application. For details on
sizing your application server to your environment, see Resource sizing for application server.

Component

Minimum

• 8 CPU
• 32 GB RAM
• 200 GB storage per node
• Every node has the same storage space

Recommended

• 16 CPU
• 64 GB RAM
• 200 GB storage
• Every node has the same storage space

Operating system

• Recommended — Ubuntu 20.04 or Ubuntu 22.04
• Red Hat 8.6 or 8.8 — Supported only when the RHEL Container Tools are not installed.
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Component

Software installed with Jama Connect

• KOTS
• Containerd

Musts

• Dedicated server — Is running only Jama Connect
• Accessible by admin with permissions
• Uses only supported software and environments

Database server
Use the information in this table for the server that runs your database. For details on sizing your
database server to your environment, see Resource sizing for database server.

Component

Minimum

• 4–8 CPU
• 16–24 GB RAM

Recommended

• 8 CPU
• 24 GB RAM
• Dedicated volumes for data

Database software

• MySQL 8 (recommended)
• Microsoft SQL Server 2019 & 2022

Operating system

• Recommended — Ubuntu 20.04 or Ubuntu 22.04
• Red Hat 8.6 or 8.8

Musts

• Database is hosted on a server separate from the Jama Connect application.
• Database server can host other databases, but no other applications.
• Accessible by admin with permissions.
• Uses only supported software and environments.
• Databases must be able to accept a minimum of 300 concurrent connections.

Not supported

• Azure database
• MariaDB
• Custom configurations of Jama Connect databases (for example, query optimization and additional indexes that aren’t shipped

with Jama Connect)

Supported software
Make sure your environment uses only supported software.

Component

Browsers

• Edge Chromium
• Firefox*
• Google Chrome*
• Safari*

*Versions released over the past 12 months are sup-
ported.

Important

Browser zoom is supported only at 100%. Use of browser exten-
sions/add-ons or enabling Compatibility View is not supported while us-
ing Jama Connect.

Tip

To prevent session issues, use the application in a single browser win-
dow.

Word processor and spreadsheet programs

• Office 365 for Mac
• Office 365 for Windows

Office 365 is used for exports and reports.
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Application server requirements (upgrading traditional to KOTS)
To install and run Jama Connect successfully, your application server must meet these requirements.

Requirement Notes

A dedicated application
server

Jama Connect is the only application running on the application server. External services can
affect stability of the application, for example by consuming memory resources.

Sufficient storage, CPU,
and memory for optimal per-
formance

To estimate the size of and required resources for your application server, see Resource sizing
for application server [689].

Accessible by an admin with
permissions

An admin must have proper permissions to maintain the application, perform upgrades, and
access the server for regular maintenance.

Uses compatible software
and environments

Verify that you're using supported software and environments [689] compatible with the most
recent self-hosted release.

Resource sizing for application server (upgrading traditional to KOTS)
For optimal performance, estimate your application server needs before you install Jama Connect.

Requirements

• Each node must have a minimum volume of 200 GB. Increase this size based on the size of the
assets that you plan to save in Jama Connect. We recommend that every node has the same storage
space.

• KOTS must be up and running before you configure the application settings in the KOTS Admin
Console.

IMPORTANT
To avoid performance issues, use the recommended requirements for horizontal scal-
ing, rather than minimum requirements.

Use the following tables to help determine resources for the primary node of your application server.

Minimum size (AWS instance sizing = m5.2xlarge)

CPU RAM CPU + memory settings CPU + memory setting with horizontal scaling jamacores

8 32 GB N/A jamacore application settings:

• Maximum CPU: 1000m
• Maximum memory: 2 G
• Maximum memory per container: 3 G
• Number of ingress nodes 2

Recommended size (AWS instance size = m5.4xlarge)

CPU RAM CPU + memory settings CPU + memory setting with horizontal scaling jama-
cores

16 64 GB Supports:

• 1,250 users with a ramp-up time of 30 sec-
onds

Supports:

• 1,250 users with a ramp-up time of 10 seconds
• 2,500 users with a ramp-up time of 30 seconds
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CPU RAM CPU + memory settings CPU + memory setting with horizontal scaling jama-
cores

jamacore application settings:

• Maximum CPU: 12000m
• Maximum memory: 48 G
• Maximum memory for container: 60 G

jamacore application settings:

• Maximum CPU: 3000m
• Maximum memory: 12 G
• Maximum memory for container: 15 G
• Number of ingress nodes: 2

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

Diff Service settings:

• Maximum memory: 2 G

Diff Service settings:

• Maximum memory: 2 G

Use the following table to help determine resources for the secondary node of your application server.

Secondary nodes dedicated to Elasticsearch: Recommended size (AWS instance size = m5.2xlarge)

CPU RAM CPU + memory settings

8 32 GB Supports:

• 2,500 users with a ramp-up time of 10 seconds

Elasticsearch settings:

• Maximum CPU: 8000m
• Maximum memory: 8 G
• Maximum memory for container: 10 G

TIP
Once you're up and running, you can monitor usage and adjust your settings as
needed.

Database server requirements (upgrading traditional to KOTS)
The database must be hosted on a server separate from the Jama Connect application. This server
can host other databases, but we don’t support running other applications on the same server as the
database.

Supported databases

• MySQL 8 (recommended)
• Microsoft SQL Server 2019 & 2022

What is not supported

• Azure database
• MariaDB
• Custom configurations of Jama Connect databases. Customizations such as query optimization and

additional indexes that aren’t shipped with Jama Connect aren’t supported.

Resource sizing for database server (upgrading traditional to KOTS)
For optimal performance, estimate your database server needs before you install Jama Connect.
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Use the information in this table to determine resources needed for your database server.

Database server Small Medium Large Enterprise

Active items in system ≤ 600, 000 ≤ 2 million 2–4 million 4 million+

Active projects ≤ 100 ≤ 500 ≤ 1, 000 1,000+

Concurrent users ≤ 50 ≤ 500 ≤ 1, 000 1,000+

CPU 4 8 16 Contact Support

Total systems of RAM 16 GB 32 GB 64 GB Contact Support

If your usage approaches the Enterprise threshold, contact Support for customized recommendations
and advanced, multi-server setup.

TIP
Once you're up and running, you can monitor usage and adjust your settings as
needed.

Important considerations

• Total system RAM for your database server can vary if you're using memory intensive workflows such
as reuse, exporting, move items, integrations, and batch updates. Database sizing is based on your
usage patterns and platform. You must have a minimum of 4–8 cores and 16–24 GB of memory.
Consult with your database admin when determining database size.

• The memory allocation allows for minimum headroom. If you need to run additional software for
monitoring and analysis, consider the system requirements for that software. Configure dynamic
memory settings as needed in the Admin Console. 

Things to do before upgrading from traditional to KOTS
Whether your environment is internet-enabled or airgap, make sure that your application server and
database server are ready before upgrading Jama Connect from traditional to KOTS.

Important considerations and requirements

• If using the existing application server and database server, you must back up the Jama Connect
database and all project assets before proceeding with the upgrade.

• Recommended — Back up or create a snapshot of all relevant application servers in case you need
to revert to the traditional Replicated environment.

• Record existing Admin Console settings before you uninstall the traditional Replicated platform ele-
ments. These settings are used when configuring new settings for the KOTS environment.

Perform these tasks before you upgrade to KOTS

• Preserve data assets
• Prepare your application server
• Prepare your new or existing database server
• Install and configure your database (MySQL or SQL Server)
• Restore database backups from traditional Replicated to KOTS
• Configure custom memory settings for Elasticsearch

Preserve data assets
You must preserve project data assets from the traditional Replicated environment before beginning the
upgrade and before uninstalling the traditional Replicated Docker containers.
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NOTE
These assets are used when you provision your tenant.

To preserve data assets:

1. Create a backup of your tenant and OAuth databases. If you are installing KOTS in an environment
with a new database server, you must restore the backups to the new server.

2. Save the backup file to a location you can access easily. You need access to this file when
provisioning the tenant in the new KOTS Replicated environment.

3. Preserve the data assets and save them to an accessible location:

cd /data/contour
tar -zcvf assets.tar.gz avatars/ attachments/ diagrams/ reports/ equations/ tempreports/

Prepare your application server (upgrading traditional to KOTS)
Make sure your application server meets all requirements. See System requirements and supported
software [440].

For users and admins to properly access Jama Connect, specific ports must be accessible to inbound
traffic. Work with your network admin to make sure your network is configured properly.

Prepare an existing application server

IMPORTANT
These steps apply only if you are upgrading with an existing server.

You must remove Replicated services and all Docker packages before you upgrade to
KOTS.

You must preserve the existing data assets before you uninstall the traditional Replica-
ted Docker containers.

1. Record the existing settings of your Admin Console.
2. Stop the Replicated services.

Ubuntu/Debian sudo service replicated stop
sudo service replicated-ui stop
sudo service replicated-operator stop
sudo docker stop replicated-premkit
sudo docker stop replicated-statsd

RHEL/Fedora systemctl stop replicated replicated-ui replicated-operator
service replicated stop
service replicated-ui stop
service replicated-operator stop
docker stop replicated-premkit
docker stop replicated-statsd

3. Stop and remove remaining containerd containers:

docker stop $(docker ps -aq)
docker rm $(docker ps -aq)

4. Run the command for your operating system to remove traditional Replicated platform elements.
Removing these items does not remove data or assets associated with provisioned tenants.
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IMPORTANT
Jama Connect is offline during this process. Make sure to inform your users of this
maintenance downtime.

Ubuntu/Debi-
an

docker rm -f replicated replicated-ui replicated-operator replicated-premkit replicated-statsd retraced-api \
retraced-processor retraced-cron retraced-nsqd retraced-postgres
docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs sudo docker rmi -f
docker images | grep "registry\.replicated\.com/library/retraced" | awk '{print $3}' | xargs sudo docker rmi -f
apt-get remove -y replicated replicated-ui replicated-operator
apt-get purge -y replicated replicated-ui replicated-operator
rm -rf /var/lib/replicated* /etc/replicated* /etc/init/replicated* /etc/init.d/replicated* \
/etc/default/replicated* 
/var/log/upstart/replicated* /etc/systemd/system/replicated*

RHEL/Fedora docker rm -f replicated replicated-ui replicated-operator replicated-premkit replicated-statsd retraced-api \
retraced-processor retraced-cron retraced-nsqd retraced-postgres
docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs sudo docker rmi -f
docker images | grep "registry\.replicated\.com/library/retraced" | awk '{print $3}' | xargs sudo docker rmi -f
yum remove -y replicated replicated-ui replicated-operator
rm -rf /var/lib/replicated* /etc/replicated* /etc/init/replicated* /etc/default/replicated* \
/etc/systemd/system/replicated* /etc/sysconfig/replicated* \
/etc/systemd/system/multi-user.target.wants/replicated* /run/replicated*

5. Stop and remove any remaining Docker resources, including containers, images, and volumes.
This affects all containers on the system, not only those associated with Jama Connect and
Replicated.

docker kill $(docker ps -q)
docker rmi -f $(docker images| awk '{print $3}')
docker volume rm $(docker volume ls -qf dangling=true)
docker system prune -a -f

6. Remove remaining Docker packages to prepare for the KOTS installer.

Ubuntu/Debian #dpkg, purge and remove
dpkg -l | grep -i docker
sudo apt-get purge -y docker-engine docker docker.io docker-ce docker-ce-cli docker-compose-plugin
sudo apt-get autoremove -y --purge docker-engine docker docker.io docker-ce docker-compose-plugin

#remove remaining docker files
sudo rm -rf /var/lib/docker /etc/docker
sudo rm /etc/apparmor.d/docker
sudo groupdel docker
sudo rm -rf /var/run/docker.sock

RHEL/Fedora sudo yum remove docker-ce docker-ce-cli docker-scan-plugin docker-ce-rootless-extras containerd.io
sudo yum remove docker \
              docker-client \
              docker-client-latest \
              docker-common \
              docker-latest \
              docker-latest-logrotate \
              docker-logrotate \
              docker-engine

7. After removing Docker from the server, you must reboot the server before proceeding with the
upgrade.

Prepare all application servers (existing and new)

1. Inbound rules and ports for nodes — Make sure the ports in the following table are accessible to
inbound traffic and the inbound rules are configured for each server in the KOTS cluster.

Protocol Port range Source* Inbound rule
applies to

node...

Description

HTTPS 443 Anywhere All Jama Connect port for SSL/TLS communication
(HTTPS), which is used to access Jama Connect. It
can be disabled or the port number can be reconfig-
ured.

HTTP 80 Anywhere All Jama Connect port for clear text communication
(HTTP), which is used to access Jama Connect. It
can be disabled or the port number can be reconfig-
ured.

TCP 8800 Anywhere All Allows admins to access the KOTS Admin Console,
which is used to configure, install, and upgrade Jama
Connect.
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Protocol Port range Source* Inbound rule
applies to

node...

Description

SSH 22 Anywhere All Allows admins to make remote connections to the
nodes using SSH.

TCP 6443 Anywhere

Any node

Primary Allows admins and KOTS nodes to access the Kuber-
netes API server.**

TCP 2379–2380 Any node Primary Allows the KOTS nodes to access the etcd server
client API.**

TCP 10250 Any node All Allows the KOTS nodes to access the Kubelet API
server.**

UDP 8472 Any node All Allows KOTS (Flannel) to create a virtual network that
connects the services running inside the cluster.**

* Anywhere means anyone or anything that must consume the resources in the environment.

** Can be disabled in single node clusters.

2. User IDs — Verify that the following User IDs are available and unused on the application server.
• User ID 91 — Used by Tomcat to read and write to directories inside jamacore pods.
• User IDs 480–499 — Used by the various services.

3. Time sync setting — To ensure accurate time on the application server, set up a cron job to
sync the time on a routine schedule (for example, every day or hour). Use this command to set up
the cron job:
ntpdate pool.ntp.org

Your application server is now ready for the upgrade to KOTS.

Preparing your new or existing database server (upgrading traditional to
KOTS)
The following information is needed when connecting the application server to the database server.

Information Requirements

Type/vendor Database must be one of the following:

• MySQL 8 (recommended)
• Microsoft SQL Server 2019 & 2022

Database hostname Example: jama.companydb.com

Listening ports The application server must be allowed to communicate remotely with the database server over the
listening ports.

Default ports are:

• MySQL = 3306
• Microsoft SQL Server = 1433

Database schema name The database owner must be able to create one:

• A new database schema
• Tables inside an existing database schema of the given name

The database name must follow these rules:

• Start with a letter (a–z)
• Contain any number of characters: a–z, 0–9 or an underscore ("_")
• Letters must be lowercase

Username jamauser

Password

Connections The database must be able to accept a minimum of 300 concurrent connections.

SAML schema user-
name

samluser

OAuth database user-
name

oauthuser
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The username and password for SAML and OAuth must match what's entered in the Microsoft SQL
Server upgrade preparation script. See Install and configure Microsoft SQL Server [696] for more
details.

Install and configure MySQL (upgrading traditional to KOTS)
MySQL is the recommended database server. Follow these steps to install and configure the server.

Important considerations

• You must have full database admin permissions to the server hosting the MySQL database.
• For the Jama Connect installation to succeed, you must first create two additional database schemas.

Recommended settings and sample
The following recommended settings require 8 GB of memory allocated to MySQL Server for a typical
installation and 16 GB for an enterprise installation.

These settings can be added to your my.cnf file (Linux) or my.ini file (Windows).

Property Typical installation Enterprise installation

max_allowed_packet 1 GB 1 GB

tmp_table_size 2 GB 2 GB

max_heap_table_size 2 GB 2 GB

table_open_cache 512 512

innodb_buffer_pool_size 2 GB 12 GB

innodb_log_file_size 256 MB 256 GB

innodb_log_buffer_size 12 MB 12 MB

innodb_thread_concurrency 16 16

max_connections 151 351

wait_timeout 259200 259200

Here is a sample text config file at an enterprise level. You must add the following values for your
environment:

bind-address=0.0.0.0
key_buffer_size=16M
max_allowed_packet=1G
thread_stack=192K
thread_cache_size=8
tmp_table_size=2G
max_heap_table_size=2G
table_open_cache=512
innodb_buffer_pool_size=12G
innodb_log_file_size=256M
innodb_log_buffer_size=12M
innodb_thread_concurrency=16
max_connections=351
wait_timeout=259200

IMPORTANT
The following steps apply only if you are creating a new database instance to support
the KOTS upgrade.

To install and configure MySQL:
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1. Make sure that the InnoDB engine is enabled.
2. Download and install a supported version of MySQL [440].
3. On the MySQL database server, create an empty Jama Connect schema / database that uses

UTF8:
CREATE DATABASE jama character set utf8mb4;

4. On the MySQL database server, create two additional database schemas and a user ("jamauser")
with the ability to access, create, and update tables within the database:
CREATE DATABASE saml;
CREATE DATABASE oauth;
CREATE USER 'jamauser'@'%' IDENTIFIED BY 'password';
CREATE USER 'oauthuser'@'%' IDENTIFIED BY 'password';
CREATE USER 'samluser'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON jama.* TO 'jamauser'@'%';
GRANT ALL PRIVILEGES ON oauth.* TO 'oauthuser'@'%';
GRANT ALL PRIVILEGES ON saml.* TO 'samluser'@'%';

5. Create a database schema for Quartz to support horizontal scaling in KOTS:
CREATE DATABASE quartz;      
CREATE USER 'quartzuser'@'%' IDENTIFIED BY 'password';            
GRANT ALL PRIVILEGES ON quartz.* TO 'quartzuser'@'%'

6. Restart the database server.

Follow the instructions to Restore backup data from traditional Replicated to KOTS [698].

Install and configure Microsoft SQL Server (upgrading traditional to KOTS)
If you are using Microsoft SQL Server for your database, follow these steps to install and configure it.

Important considerations

• You must have full database admin permissions to the server hosting the SQL Server database.

IMPORTANT
The following steps apply only if you are creating a new database instance to support
the KOTS upgrade.

To install and configure SQL Server:

1. Connect to the SQL Server using a SQL management application (such as SQL Server Manage-
ment Studio).

2. Replace the following values in the installation script: <JAMA_LOGIN_Psswd>, <SAML_LOG-
IN_Psswd> & <OAUTH_LOGIN_Psswd>.

3. Copy and store the passwords you create here. You will need them later to configure the Admin
Console settings.

4. In a new query window, run this SQL query script:
-- Fresh Install Preparation SCRIPT
/*

INSTRUCTIONS:
This script must be run prior to Jama installation or installation might fail to 
complete.
Modify login passwords as needed. 
Passwords must be enclosed in single quotes.
*/

USE master;
CREATE LOGIN jamauser with password = 'password';
CREATE LOGIN samluser with password = 'password';
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CREATE LOGIN oauthuser with password = 'password';
GO

USE master;
CREATE DATABASE jama;
GO
ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK IMMEDIATE
GO

USE jama;
EXEC ('CREATE SCHEMA oauth');
EXEC ('CREATE SCHEMA saml');
GO

USE jama;
CREATE USER jamauser for LOGIN jamauser;
CREATE USER samluser for LOGIN samluser with DEFAULT_SCHEMA=saml;
CREATE USER oauthuser for LOGIN oauthuser with DEFAULT_SCHEMA=oauth;
GO

EXEC sp_addrolemember N'db_owner', jamauser;
EXEC sp_addrolemember N'db_owner', samluser;
EXEC sp_addrolemember N'db_owner', oauthuser;
GO

5. Create a database schema for Quartz to support horizontal scaling in KOTS:
USE master;      
CREATE LOGIN quartzuser with password = 'password';      
GO             

USE jama;      
EXEC ('CREATE SCHEMA quartz');      
GO             

USE jama;      
CREATE USER quartzuser for LOGIN quartzuser with DEFAULT_SCHEMA=quartz;      
GO             

EXEC sp_addrolemember N'db_owner', quartzuser;            
GO

6. Confirm that these actions were successful:
• Script completed — Check the Query Execution results for errors.
• Users created — Run the following SQL script in a new query window.

USE jama
SELECT * from master.sys.sql_logins
SELECT * from Jama.sys.sysusers

The results include jamauser, samluser, and oauthuser in the "Name" column of the result
panes.

• Users granted the DB_owner role — Run the following SQL script in a new query window.
USE jama
SELECT DP1.name AS DatabaseRoleName,
isnull (DP2.name, 'No members') AS DatabaseUserName
FROM sys.database_role_members AS DRM
RIGHT OUTER JOIN sys.database_principals AS DP1
ON DRM.role_principal_id = DP1.principal_id
LEFT OUTER JOIN sys.database_principals AS DP2
ON DRM.member_principal_id = DP2.principal_id
WHERE DP1.type = 'R'
ORDER BY DP1.name;

The results show that db_owner role is granted to jamauser, samluser, and oauthuser.
7. Keep the database from locking users' accounts while they are logging in or working in Jama

Connect (you must have db_owner permissions):
ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK IMMEDIATE;

8. Make sure the flag was successfully enabled:
SELECT is_read_committed_snapshot_on FROM sys.databases WHERE name='jama';

If the returned value is 1, the flag is on.

Follow the instructions to Restore backup data from traditional Replicated to KOTS [698].
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Restore database backups from traditional Replicated to KOTS
After you install and configure your MySQL or Microsoft SQL database server, you must restore
backups of the tenant and OAuth databases from the existing traditional Replicated database instance
to the new KOTS database instance.

IMPORTANT
If you use SAML authentication in your traditional Replicated environment, it must be
configured in the new KOTS environment, rather than restoring from a backup.

Restore the database, using instructions for MySQL or SQL Server:

1. Restore the tenant database from a native backup to the new environment.
2. Restore the OAuth database from a native backup to the new environment.

Configure custom memory settings for Elasticsearch (upgrading traditional
to KOTS)
To prepare for installing Jama Connect, you must first update the system that hosts the application. The
update consists of configuring memory settings for Elasticsearch.

Requirements

• The memory settings must be configured on each server in the KOTS cluster for Elasticsearch
to run on these servers. If you use the remote Elasticsearch setting, the memory settings can be
applied only to servers that are dedicated to Elasticsearch.

• You must have admin permissions to configure the memory settings for Elasticsearch.

To configure memory settings:

1. As an admin, open the /etc/sysctl.conf file, add the following line to the file, then save the file.

vm.max_map_count=262144

2. Reload the sysctl.conf file:

sudo sysctl -p

3. To confirm, type this command:

sudo sysctl -a | grep max_map_count

The system responds with:

vm.max_map_count=262144

Upgrading the Replicated platform from traditional to KOTS
Whether your organization is internet-enabled or requires an airgap installation, follow these instructions
to download, install, and configure the software you need for your Jama Connect instance.

IMPORTANT
KOTS and Jama Connect must be installed on a new cluster that is created during
installation and dedicated to KOTS.
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The software includes:

• KOTS Admin Console (Replicated)
• Jama Connect
• Jama Connect KOTS license file (contact your Customer Success Manager to request a KOTS

internet or airgap license)

The upgrade process consists of these tasks:

• Install KOTS and Jama Connect (internet [699] or airgap [701])
• Provision your tenant in Jama Connect KOTS
• Create a Replicated Snapshot

Depending on your environment, the process can also include these tasks:

• Configure KOTS to save tenant assets in Amazon EFS
• Enable horizontal scaling
• Configure dedicated Elasticsearch nodes
• Configure Federated Authentication for KOTS Admin Console

Install the Jama Connect Replicated KOTS platform (internet)
The installation script and the installation wizard guide you through the process of installing the KOTS-
required software and Jama Connect, then configuring the KOTS Admin Console.

1. Contact your Customer Success Manager to request a KOTS internet license, then save the
license file on your local system.

2. Run the command on the application server provisioned for Jama Connect:
curl -sSL https://k8s.kurl.sh/jama-k8s-standardkots | sudo bash

The installation process can take up to an hour to complete.
3. After the command runs, save the KOTS admin URL, password, and other configuration options for

future reference. This is the only time these credentials appear, so make sure you save them.

4. In a supported browser, enter the URL for Kotsadm, which was generated when you installed
KOTS.

5. Log in to the KOTS Admin Console using the password you just saved.
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6. Select the appropriate option:
• Have key/certificate — Click Choose file under Private key and Certificate, navigate to the files

and select them, then click Upload & Continue.
• No key/certificate — Select Self-Signed Cert.

You can configure the SSL/TLS certificates in the KOTS Admin Console after the deployment as
needed.

7. Upload the license file that you saved on your local system.

The Config tab in the KOTS Admin Console opens, where you can configure and provision Jama
Connect.
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Install the Jama Connect Replicated KOTS platform (airgap)
The installation script and the installation wizard guide you through the process of installing the KOTS-
required software and Jama Connect, then configuring the KOTS Admin Console.

1. Contact your Customer Success Manager to request a KOTS airgap license, then save the license
file on your local system.

2. Log in to the airgap portal, select Embedded Cluster, then download the jama-k8s Airgap Bun-
dle and Embedded Kubernetes Installer files to your local system.

3. To download the Kubernetes Installer for your channel and install it, run the following command on
the application server provisioned for Jama Connect.

export REPLICATED_APP=jama-k8s
export REPLICATED_CHANNEL=standardkots

curl -LS https://k8s.kurl.sh/bundle/$REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz \
-o $REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz

tar -zxvf $REPLICATED_APP-$REPLICATED_CHANNEL.tar.gz

cat install.sh | sudo bash -s airgap

If your application server doesn't have internet access, you can download the Kubernetes Installer
from the airgap-safe portal and upload it to the application server.

4. After the command runs (which might take several minutes), save the KOTS admin URL, pass-
word, and other configuration options for future reference. This is the only time these credentials
appear, so make sure you save them.
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5. In a supported browser, enter the URL for Kotsadm, which was generated when you installed
KOTS.

6. Log in to the KOTS Admin Console using the password you just saved.

7. Select the appropriate option:
• Have key/certificate — Select Choose file under Private key and Certificate, navigate to the

files and select them, then click Upload & Continue.
• No key/certificate — Select Use Self-Signed Cert.

You can configure the SSL/TLS certificates in the KOTS Admin Console after the deployment as
needed.

8. Upload the license file saved on your local system.
9. Upload your jama-k8s airgap bundle, then click Continue.
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The Config tab in the KOTS Admin Console opens, where you can configure and provision Jama
Connect.

Provision your tenant in Jama Connect KOTS (upgrading traditional to
KOTS)
After upgrading the KOTS Replicated environment, you must provision the existing tenant in the new
environment.

IMPORTANT
The KOTS Admin Console doesn't support formulas. Instead, use literal values.

To provision your tenant in KOTS:

1. From the KOTS Admin Console, select the Config tab.
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2. Configure the settings for each group, as needed. Scroll down to see each group of settings.

IMPORTANT
Make sure that the current Host name, Database name, Username, and Password
are configured correctly in the KOTS Admin Console. If you installed KOTS in
a new environment, you must point to the newly installed database host or the
deployment fails.

• Database Settings — Select your database type (MySQL or Microsoft SQL Server), then use
the information from Preparing your database server to complete the settings.

• Host Name — Enter the name of the database server (for existing resources, enter current
name; for new resources, enter the new name).

• TLS Key Pair Source — (Optional) If you have a custom key and certificate for the host
name, select Custom TLS Configuration. In the TLS Configuration section, upload the key and
certificate.

• Assets Size — Enter the estimated size of the assets based on the current data assets size of
your environment and its projected growth.

• Elasticsearch Settings > Volume Size — Enter the amount of disk space that each Elastic-
search node is allowed to use.

3. (Optional) From the Config tab in the KOTS Admin Console, follow the steps to configure KOTS to
save tenant assets in the Amazon EFS.

4. Scroll down to Tenant Manager Settings and deselect the checkbox to disable it.
Disabling the Tenant Manager prevents Jama Connect from completing tenant provisioning, which
allows you to copy data assets and tenant.properties from the traditional replicated environment to
the KOTS environment.
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5. Scroll to the bottom of the page and click Save config.
The Preflight checks run.

6. From the Preflight checks screen, click Continue to deploy the Jama Connect application and
services.
When the system is available, the status in the KOTS Admin Console changes to Ready.
The deployment process can take up to an hour.
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When the preflight checks are complete, Jama Connect creates the Kubernetes pods, which
contain the Jama Connect application and related services.

7. From the application server CLI, verify that the Kubernetes pods were successfully created:
kubectl get pods

Application server CLI example:

8. When the pods are ready and running, copy the data assets, which you preserved in an earlier
task, to an accessible location on the application server.

9. On the application server, set the tenant name for the environment (the tenant name, usually jama,
and can be found in the tenant.properties file is the name of the Jama Connect database schema):
export TENANT_NAME=<tenant_name>

10. On the application server:
a. Copy and extract the previously preserved data assets into the running core pod and change

the ownership permissions:
kubectl cp -c core /tmp/contour/assets.tar.gz default/core-0:/home/contour/tenant/${TENANT_NAME}/
kubectl exec --tty -c core pods/core-0 -- tar -xvzf /home/contour/tenant/${TENANT_NAME}/\
assets.tar.gz -C /home/contour/tenant/${TENANT_NAME}/
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kubectl exec --tty -c core pods/core-0 -- chmod -R 755 /home/contour

kubectl exec --tty -c core pods/core-0 -- chown -R tomcat:tomcat /home/contour

b. Delete the core stateful set to recreate the core pod:

kubectl delete sts/core

11. From the KOTS Admin Console, select the Config tab, enable the Tenant Manager Settings, then
click Save config.

12. Remove entries from the Jama Connect database tenantstate table to prepare for a new deploy-
ment:

DELETE FROM tenantstate;

13. To deploy the new version of Jama Connect:
a. From the KOTS Admin Console, click Deploy next to the newly saved version of Jama

Connect.
b. When the deployment is complete and all pods are running, log in to Jama Connect as root

using the hostname configured for Jama Connect.
c. If upgrading with new servers:

• SAML authentication must be configured in the new KOTS Jama Connect environment.
• Update the base URL before performing a full reindex.

d. Perform a full reindex in Jama Connect to complete the deployment.

Create a Replicated Snapshot (KOTS)
Taking a full snapshot creates a backup of the KOTS Admin Console and application data. It can be
used for full Disaster Recovery by restoring over the same instance or in a new cluster. Tenant assets
are included in the snapshot. Elasticsearch data is included by default.

A Replicated Snapshot can be taken while Jama Connect is running without interruption.

Requirements

• Replicated Snapshots must be enabled for your Replicated customer license.
• KOTS Admin Console 1.79 and later.
• Replicated Snapshots don't include your database. You must use a proprietary backup/restore sys-

tem for your type of database, MySQL or SQL Server.

Important considerations

• When restoring from a snapshot in a new cluster, you must reinstall KOTS.
• Recommended — Include Elasticsearch data in snapshots to avoid having to reindex your data after

performing a restore. However, if your snapshot is not recent, we recommend reindexing your data.
• Replicated Snapshots don't support IAM authentication against EFS. Saving Replicated Snapshots in

EFS requires that you use the default file system policy to allow all nodes in the cluster to mount the
EFS.

To create a Replicated snapshot:

1. Capture the KOTS installer.
2. (Recommended) Include Elasticsearch data in snapshots: From the KOTS Admin Console under

the Elasticsearch Settings section, select Include Elasticsearch in Replicated Snapshots.
3. Airgap only — Capture the IP address of the private registry, which is the IP address value in the

Cluster-IP column:

kubectl get service/registry -n kurl

4. Configure the storage destination:
a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. From the Destination drop-down menu, select a storage destination for your snapshots.
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• For AWS S3 — The IAM role assigned to the underlaying servers or the user associated
with the credentials (access and secret key) must have the Policy template attached.
Use the following template to create a policy, replacing the <arn-S3> parameter with ARN of
the S3 bucket. For example: arn:aws:s3:::jama-snapshots.
{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Effect": "Allow",
            "Action": [
                "s3:PutObject",
                "s3:GetObject",
                "s3:AbortMultipartUpload",
                "s3:DeleteObject",
                "s3:ListMultipartUploadParts"
            ],
            "Resource": "<arn-s3>/*"
        },
        {
            "Effect": "Allow",
            "Action": "s3:ListBucket",
            "Resource": "<arn-s3>"
        }
    ]
}

• For NFS — If using EFS as an NFS server, the Server field = the DNS name of the EFS
and the Path field = a directory inside the EFS, writable by the user:group 1001:1001.

c. Click Update storage settings to save your preferences.
5. Schedule Full Snapshots:

a. In the KOTS Admin Console, select Snapshots > Settings & Schedule.
b. Select Enable automatic scheduled snapshots, then click Update schedule.

6. Create a Full Snapshot (follow the steps provided by Replicated).

After upgrading Jama Connect traditional to KOTS
Whether your environment is internet-enabled or airgap, after upgrading from Jama Connect traditional
to KOTS you can continue to set up your Jama Connect environment.

Follow any post upgrade instructions that apply to your organization:

• Add Organization Admin account
• Modify organization details
• Configure email/collaboration settings
• Configure user authentication
• Create XML backups (optional)
• Update the license for KOTS environments (optional)

If you have further questions about Jama Connect installation and setup, visit the Jama Support
Community or contact Support.
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