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Welcome to Jama Connect

Jama Connect is a centralized web application that helps you manage the development of new technol-
ogy products. It manages all aspects of product requirements. Jama Connect also records test results
and manages risk while maintaining regulatory compliance.

As a new user or trial user, read through this section to learn how Jama Connect can change the way
you work and can enhance your product development process. We want to answer all your "What do |
need to get started?" questions.

This information isn’t linear — feel free to scan through and jump to the different areas that are most
interesting to you.

The right tool at the right time

This guide contains information about a self-hosted release of Jama Connect. If you're a system
administrator new to Jama Software you can skip straight to the system administrator section [471].
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Get started

To start using Jama Connect, you need your user account credentials.

» Trial account

Sign up for a free trial at https://www.jamasoftware.com/platform/jama-connect/trial/
* New user account

Your administrator has your account username and password.

As a new user of Jama Connect, this is the place to start: log in and get familiar with the different areas
of the workspace.

To log in to Jama Connect:

1. In a supported web browser, enter the URL provided by your administrator.

2. Type your username and password, then select Log in.
Header — Includes the main sections of the Jama Connect interface.
Homepage — Shows links to your most relevant content like bookmarks, recent views, open views,
stream comments, and actions.

Tips and more

* You're allowed 10 login attempts within five minutes before you're locked out for 30 minutes. To
unlock your account before then, follow the forgotten password procedure.

» To manage your account, select your name in the top right navigation to open the My Profile window.

+ To log out of the application, select Log Out in the top right header. If you don't log out, the default
timeout is two hours.

» Bookmark projects, containers, sets, and folders so they appear under Bookmarks and Recently
viewed sections. Having it appear in both places allows you to keep track of recently viewed items
even if you remove the bookmark.


https://www.jamasoftware.com/platform/jama-connect/trial/
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Exploring the Jama Connect workspace

The Jama Connect workspace is where you set up and manage your projects, create test plans,
communicate with your team, track relationships, and more.

You can also view these short videos to learn the Jama Connect basics: how to navigate the system,
add and edit information, build in traceability, send information for review, and collaborate with your
project team.

The workspace is divided into five panes that you can expand, collapse, and resize.

1. Explore and manage projects — Select the tabs at the top of the left panel to expand these views:

Explorer, Filters, Releases, Baselines, and Test Plans.

2. View item details — View the details for specific items. Content from Components, Sets, Folders,
Filters, and individual items are located in this pane.

3. Create trace relationships — Add relationships for traceability or items within a change request.
Open this section from the Relationships tab and close when it's not needed.

4. Manage item information — Manage information associated with comments, relationships, attach-

ments, versions, and activities.
5. Use keywords to navigate the workspace — Use the tags cloud to navigate to items grouped by
keywords.

Jama Connect is highly configurable, so you can customize the workflow that works best for you. For
example, focus on creating requirements from the Explorer Tree, view details about a test case, or

explore relationships. Depending on the task or goal, you might interact with one area or all areas of the

workspace.
Navigation

These links can help you find your way around Jama Connect:

10
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» Explorer Tree [45]
* Toolbar [48]
+ Side toolbar [56]

Views

You can choose how you view your selected items in the center panel. Each view is suited to different
types of work.

+ Single Item View [55] — Displays the information about one item in the center panel.

» List View [51] — Shows data from multiple items in a table with a different field in each column so
you can sort, select, and compare items at a glance.

* Reading View [52] — Shows both text and images for a particular group of items so you can read
through selected items like a document.

* Trace View [52] — Shows related upstream and downstream items, missing relationships, and item
details in context of their relationship.

+ Compare View [57] — Shows side by side content so you can compare differences between
different item versions.

Project approach and tree structure

Jama Connect is made up of projects and uses a tree approach, which allows users to easily organize
content and view the content of each project.

What is a project?

Think of a project as a virtual container or “workspace” of information. Each project relates to a product
you are creating or a software application you are developing.

Why have a project?

Projects allow you to organize content and apply permission schemas. For example, a user might be
able to create and edit requirements in Project A, but might not be able to see content in Project B.

Projects are created by the Jama Connect admins at your organization, who also control corresponding
permissions for each project.

At a high-level, each Jama Connect environment can contain multiple projects. Typically, a single
project in Jama Connect relates to a single product or a single version of a system that you are building.

Monitoring your project

Within a Jama Connect project, you can track releases/phases, baselines, test plans, and results. You
can also create a project dashboard to track the data your team wants to monitor for quality and
progress.

11
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How do | access my project?

To open a single project, click Projects in the header. If you're already in a project, select Change
project to switch to a different project.

Advantages of projects and tree structure

Jama Connect projects and the Explorer Tree are highly configurable, which allows your organization to
adapt the solution to fit your own unique hierarchy and development process.

We also have several templates to get your team started. This allows your organization to:

» Standardize methodology across different teams
» Decrease context switching when working across multiple projects
» Enable reuse of shared requirements

Organizing your content

Each project has its own Explorer Tree, which displays project items in a hierarchical structure. Think of
the tree like your filing cabinet.

12
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Within the Explorer Tree you have access to several tools to organize your content:

+ Component — A structural container used to organize a project into more manageable pieces.
For example, if our project represented an automobile, typical components in our Jama Connect
project might be: “Vehicle Airbag System” or “Emergency Braking System.” Underneath these compo-
nents are all the requirements and test sets that make up these subsystems for a car.

» Set — A container that defines groups of items of a single item type. Sets can exist at the top of
projects or beneath the components.
For example, in our “Emergency Braking System” component we might have a set of “System
Requirements” and a separate set of “Verification Tests.” Typically documents such as a Product
Requirement document or Functional Requirement specification translates in Jama Connect as a set.

* Folder — A way to organize items within a set.

* Items — The granular types of content in Jama Connect.
For example, a single Requirement is an item. A single Test Case is an item. You can configure
multiple item types in Jama Connect.

Learn more about projects and Explorer Tree

* Projects at a high level [625]
» Configure Explorer Tree settings [47]

Item-based product development
Jama Connect is a database-driven, item-based product development platform.

Why do we use items instead of documents? Several reasons:

» Version control — Track changes and feedback at an individual item level, whether the item is a
requirement, a risk, a test, or even project documentation.

+ Data integrity — Quickly search, filter, and create dashboards to view progress based on item
attributes. Documents don’t allow for this and often have data integrity issues.

» Time savings — Save time by not having to manually maintain IDs and trace links in a document. In
Jama Connect, traceability is a by-product of the way you work.

» Review efficiency — Focus on smaller, more iterative item reviews. Users no longer have to wait for
entire documents to be submitted before they can provide feedback. Get to market quicker!

» Auditing quality — With a few clicks, identify items that are missing coverage throughout the
product development process.

The shift from a document-based approach to an item-based approach is key to enabling the value of
Jama Connect. Your team's methodology directly influences how you set up and configure your Jama
Connect environment with different item types.

The diagram below illustrates how to shift from a document-based approach to an item-based approach
using Jama Connect.

+ Identify the documents and content that need to live in Jama Connect.

+ Determine the item types that exist in those documents. For example, item types could be System
Requirements, Use Cases, or Test Cases. ltem types must have defined relationships in Jama
Connect, which you can specify using a relationship rule.

» Configure a project structure, then import your existing documentation or start authoring in Jama
Connect.

With an item-based and data driven workflow, you can configure a project structure, then begin author-

ing in Jama Connect. You can either import existing content or author directly in the application. You
only need to export documents as needed.

13
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The following diagram* is a typical relationship model in Jama Connect that adheres to a Systems
Engineering Methodology (SEM).

* Box = single item type. Lines = relationships

Your team's development methodology comes into play here, for example classic vs. agile methodolo-
gy. While some teams use only one method, many teams use a combination.

Each method might use different terms. For example:

Classical Systems Engineering System Requirement
System Architecture
High-Level Requirement

Low-Level Requirement

Agile Strategic Themes
Epics

User Stories

Traceability from Requirements to Test

Traceability shows the relationship between items that depend upon and define each other. You can
always travel upstream or downstream to get more context and trace product definition from high level
requirements all the way through final tests.

Relationships in Jama Connect are established between discrete items. For example, Stakeholder
Requirement A is related to System Requirement X.

14
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Benefits of establishing relationships
Why are relationships important in Jama Connect?

* Allocation — Understand which systems and subsystems implement the requirements.

* Traceability — Break down high-level requirements into more detailed specifications.

» Verification — Prove implementation and quality by linking requirements to tests and their results.

» Impact analysis — When requirements change, identify and understand the ripple effect to lower-
level requirements and testing.

Relationship rules are applied to projects to drive compliance to your organization’s model and method-
ology. Setting up relationship rules for your item types is critical because it enforces the methodology
your organization wants to use in Jama Connect.

Jama Connect uses the terms “upstream” and “downstream” to describe relationship direction. When
upstream items change, their downstream items are flagged as “suspect” so that you can review any
impact the change might have.

How to establish a relationship:

15
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1. Navigate to a single item in your project such as a user need or a requirement.

Click Add related and select the item type you want to add.

Jama Connect opens a new window where you configure the item relationship.

3. Click Save and Close.
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The original item (Requirement) and the new item (Verification) are now linked with a trace relationship.

View and add relationships

» To view relationships, click the “Relationships widget in right corner of the item.
» To add more relationships, click Relate items.
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To learn more about adding relationships, see: Relationships [260]

What's next

Once you have established relationships, the Trace view in Jama Connect is a great way to view a live
trace matrix [272]. You can also filter and extract views of your traceability.

Trace view:

Tracking changes in your project

Being able to track changes is critical throughout product development, including details and context
that led to the change, specific version differences, and stakeholders involved with the changes. Jama
Connect gives you the ability to capture all of these details.

Jama Connect has two effective ways to track changes:
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» Versions — Capture change at an “item” level. For example, a single requirement might have
multiple versions as well as associated change comments.

+ Baselines — Capture a point-in-time snapshot of a group of items. For example, if you want to
preserve a version of an entire Jama Connect project or “set” of approved items, you can create a
baseline.

Version changes

A new version is created each time you make changes to an item. In the bottom panel, you can
compare versions or make a past version current.

Changes to a single item

In the following screenshot, you can see how Jama Connect compares differences between multiple
versions of an item. This engineering requirement has two versions. In the bottom panel, you can also
see who made the change, any change details, and, if added, any change comments. Get the complete
context of change from just this one screen!

Version Compare view

This next screenshot shows the differences between two versions of a requirement. Individual field
differences are shown and highlighted* in red and green, making it easy to see what might have
changed.
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* Red = content that was removed. Green = new content added.
Changes to several items in a baseline

This next screenshot shows a baseline in Jama Connect, which is a snapshot of several items.

Baselines can also change over time as new requirements are added, removed, or updated. Jama
Connect provides users with the ability to track these changes between different baselines through
out-of-the-box reports.

How reviews work

Ever feel like work is harder than it should be? Multiple revisions of a document get emailed around;
conflicting or out-of-sequence feedback on shared documents; expensive time-consuming review meet-
ings: sound familiar?
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Jama Connect alleviates these pain points with its review features.

» Everyone is automatically placed in the latest revision.

* Reviewers can simultaneously log their feedback and approvals.

+ All feedback is in sequence with document revisions.

* It's easy to filter and view only the items that need additional review or feedback.

Reviews are critical to improving requirements and test quality and in increasing the shared understand-
ing among the teams who are engineering and implementing the requirements. Most item types in
Jama Connect can be sent to a review.

Review roles: who does what?

* Moderator — Content Owner. Starts the review and facilitates the discussion.
» Reviewer — Contributes to the discussion.
» Approver — Signs off and approves items that are in review.

Who can start a review?

Users with Creator license and permissions to author and edit in the project can start and moderate a
review.

What's involved in a review?

Here’s what a typical workflow looks like.
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1 Define what gets reviewed Before starting a review, determine which set or folder of items you want to send for
review. A review doesn’t need to be for an entire document. It can be for particular
sections only, which allows for a more agile and iterative review. In addition to location, a
review can be started from a filter, release, baseline, or test plan.

2 Start the review If leveraging Jama Connect workflow functionality, make sure the status of items is

set to “Review:” right-click on the location in the Explorer Tree and click Send for re-

view. If you're starting from a filter, release, baseline or test plan, right-click the Filter/Re-
lease/Baseline/Test Plan name and click Send for review. Jama Connect loads the review
setup wizard, where you can configure the review deadline and invite Reviewers and
Approvers.

3 Monitor progress the review is initialized, Reviewers and Approvers receive an email invitation to participate.
They work concurrently, adding comments and marking items as “Approved” or “Rejected.”
As a moderator, you can track participant progress and respond to comments.

4 Incorporate changes As the moderator, you incorporate edits based on feedback from the participants. After
incorporating changes, you are prompted to publish a new revision of the review.

5 Close the review Reviews close when the review deadline is reached or when the Moderator closes the
review manually (Finish > Close for feedback, Finish > Finalize approval review, or
Finish > Mark review as finalized).

Reviews can always be reopened to publish new revisions and review what has changed.
Best practices

+ Facilitate a review before Requirement is moved to “Approved” or “Rejected” status.

» Focus on small, iterative reviews with fewer than 200 requirements per review. A large requirements
doc can be hard to consume.

It's OK to have lots of review revisions; approvers are always placed into the “latest” revision.
 Offer guidance on the type of feedback you need.

Create a review

You can create a review for any group of items in a project. And you can start a review from several
places in the Jama Connect interface.

Regardless of where you begin, the process is the same through an easy-to-follow wizard.
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Let’s start from Reviews in the top navigation.

1. Select Reviews, then select Start a review.

The wizard opens to the Definitions page.
2. Follow the prompts in the wizard to define your review:

Definition Settings Participants Invitation
3. Click Initiate review.
Learn more about reviews
For details about how to create and use reviews, explore these topics in the User Guide:

* Review moderator [152]

» Compare versions [187]

+ Filter or search the review workspace [180]

* Organize and find review comments [178]

* Review Education Resources from Community site
* Review Center FAQ from Community site

Exporting documents from Jama Connect

While Jama Connect alleviates many of the pain points around managing documents, you might still
need to create documents to share with your customers, quality teams, or auditors.

The basics

With Jama Connect, you can easily create documents using our standard export to Word and Excel or
by creating your own custom office templates.

The items that appear in your Jama Connect view are exported:
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Beyond the basics with Office templates

If you need more than what the default Office templates provide, you can customize a template to suit
your project. For details about how to create a custom Office template:

» Exports [298] (User Guide)
» Word Template Guide (Community)

Advanced reporting

If you require more control over the report output than Word templates provide, you can use an
advanced reporting tool like BIRT or Velocity.

Here are some common scenarios for using an advanced reporting tool:

» Ordering of documents — Word templates always arrange your included items in the same order
that they appeared in Jama Connect when you generated the export. If you need like items to stay
together or certain item types to always be displayed before other types, you need to use a custom
export.

+ Style formatting — Although Word templates support basic text formatting like bullets and text
decoration, they don’t support control for page formatting options like section breaks or custom page
numbering. BIRT and Velocity exports provide a broader level of control than Word.

* Multiple levels of relationships — Default Word templates can export relationships one level up-
stream or one level downstream. BIRT and Velocity both allow more access to follow relationships
and tree structure through multiple levels.

» Conditional logic — BIRT and Velocity both allow more control over when and where to display
information. If you want to display an item’s status, but only if it were created more than 30 days ago
and has an upstream relationship to a Feature, you need to use an advanced reporting engine.

For more detailed information about advanced reporting:
* Introduction to Advanced Reporting (Community)
Dashboards

You can configure your projects to show key metrics to quickly see what needs attention. Typically,
dashboards are used to:

* Monitor progress (for example, status of Requirements or Execution Results of a Test Cycle)
+ Audit progress (for example, show the count of items that are missing a critical data point or process
step)

To access the dashboard, select the project name in the Explorer Tree.
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As an administrator with organization or project permissions, you can customize dashboards per project

(not per user).

Customizations include:

Filter results

Displays the results of an existing filter.

Assigned to me

Displays a list of items "assigned to" the current user.

Bar chart

Displays the results of an existing filter as a bar chart.

Recent activity

Displays a line graph of recent activity over a period of time.

Pie chart

Displays a pie chart for a filter and field that the user selects.

Activity stream

Displays the current activity stream of the project. View all current activity including comments, edits
made, new items created, and assignment changes.

Project summary

Displays a summary of the entire project, including total number of items in the project, number of days
until next release, and number of days until project completion.

Rich text

Displays user defined text, images, diagrams, and equations.

Recently viewed

Displays the last 15 items viewed by the current user.

Relationship diagram

Displays the relationship rules applied to the project.

Testing

Do you need to validate and verify your product? Or maybe you need to create a report that shows the
connection between regulations, requirements, and tests?

Then look no further: use Jama Connect test capabilities to guide your teams through the testing
process, so you can validate and verify your products and systems.

Let's define our terms

Test cases Iltems that contain the tests needed to validate or verify product features or systems. They contain the
essential information about your tests, and can be organized by project, library, or ad hoc.
Test plans Document that describe the strategy and objective of the test.

Test groups

Allows teams to organize test cases within a test plan.

Test runs Item used to record results for a test case you ran against your product.

Test cycles A series of test runs consisting of groups of test cases, that are ready for execution. In a test plan, you
can add a test cycle to help manage and execute test runs.

Defects Testing errors that are logged from test runs and traced to upstream test cases and requirements

through the relationship configuration.

What's involved in testing?

Here's a typical workflow:
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1 Create test cases for your Create test cases that meet the needs of a particular project or multiple projects
project across your organization.Test cases describe the specific tests you plan to use and
their steps. Relate test cases to the requirement you're testing.
2 Create a test plan to test Create a test plan that gives an overview of how you want to test requirements.
requirements
3 Organize test cases in Associate the cases you want to use into that plan using groups to organize them.
groups
4 Move groups into cycles Get ready for testing, by moving those groups into cycles where you can see a list
of all the tests you want to run.
5 Execute test runs and log Execute the test runs and log defects as needed.
defects
6 Get overall test case sta- Resulting test run statuses roll up to calculate the overall test case status.
tus
7 Generate report showing You can then generate a report showing results, such as the Test Plan Summary
results Reporter or the Test Plan Detail Report.

Learn more about testing

» Test cases [316]

» Test plans [326]

» Test groups [329]

+ Test cycles [337]

* Test runs [340]

» Defect item type [594]

All about baselines

A baseline in Jama Connect is a snapshot of your project at a point in time. The current version of each
selected item — and their relationships — are forever associated with that baseline.

Why are baselines important?

25




Jama Connect User Guide

A baseline captures the relationship of your selected project components to each other, as well as their
state — for example: draft, reviewed, approved.

A project in Jama Connect can have many baselines. Use baselines as the basis for an export or as a
reference for a historical milestone. By creating a baseline at each project milestone, you can view the
status of your project at those key points in the lifecycle. For example:

+ At gate reviews
» Before a reorganization
» Before an import of requirements

Where to create the baseline

In the Jama Connect Project, navigate to the Baselines tab and click Add > Baseline.

Create a baseline (snapshot)

Are you ready to send an item for review? Or maybe you need to capture the current set of require-
ments. Perhaps your project has reached a milestone like testing or approval.

Create a baseline to secure a snapshot of one or several items in your project.

1. Select the Baseline tab from the left panel tabs of your project.
2. From the Add drop-down menu, select Baseline.
3. Select the criteria that you want to include in your baseline, using the three tabs in the pop-up
window:
+ Item selection — A copy of the project where you are working. Select your entire project, a
single set, multiple sets, a single item, or multiples items.
* Releases — If you created a release, baseline one or multiple items.
 Filters — Baseline any advanced filters you created.
4. Click Create. The Add Baseline window appears with a pre-populated name.
(Optional) Rename the baseline or add a description.
6. Click Save.

o

Your baseline is now created and is highlighted under the source where you created it.
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Organize your baseline tree: the basics

Working with baselines is dynamic and intuitive: reorganize, rename, and restructure your tree however
you want. Let’s create a folder or two, then we can arrange them.

Note: You must be a project admin or organization admin to do this.

1. From the Add drop-down menu, select Folder.
2. In the window that opens, type the name of the folder.
3. Click Save.

The new folder is saved at the top of your baseline tree.
Quick tips

» To add a folder to an existing folder, right-click on a folder and select Add Folder.
» To move a folder or a source, drag it to a location in your baseline tree.

Learn more about baselines
For detailed information about baselines, explore more topics in the User Guide:

* Baseline sources [239]

* Baseline organization [240]

» Baseline activity [248]

» Add electronic signatures to a baseline [228]

Reuse and synchronization

Reuse in Jama Connect is much more than a copy/paste mechanism. It’s a full suite of features that
allows for complex capabilities like:

» Maintaining a library of common requirements
* Branching a project to create a variant product
» Comparing differences between a local version of a requirement and its source library version

Reuse and Sync methods are useful for detecting variance and putting a spotlight on the impact
analysis across releases and projects. And these methods are useful whether your product keeps the
same requirements as a previous version; if it integrates and improves on original requirements; or if
you include custom requirements for each product.
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To save time and effort for your teams:

* Reuse common product requirements between projects.
» Sync across those reused items to help determine and track variance across projects.

When you use Reuse and Sync within your requirements management configuration infrastructure, you
maximize your requirements resource management. You can modify and evolve existing work quickly
while maintaining your requirement lineage.

Library approach

» Alibrary project houses a collection of requirements maintained by a “librarian” or “curator” (permis-
sions-based).

» The curator of a library can pull differences back into the library when needed.
* Project members can pull and push updates between the project and the library.

Branching approach
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* Projects are branched by project duplication.

» Synchronization is enabled during project duplication and differences are monitored between contain-
ers/items.

» Jama Connect project baselines are created just after duplication. This captures the state of the
project at the time of duplication and is used for baseline comparisons.

Administration

Administration in Jama Connect is primarily used to control the product development process and
users’ access to the data.

Product development process

There is no “one size fits all” process for developing products or applications. Each industry starts with a
template modeled after best practices, but every company can tailor the process to fit their needs.

Here is an example process* used to develop a medical device.

* Boxes = an artifact/document (generically defined as item types in Jama Connect).
Lines = relationships that enforce traceability between the items.

Item types = items with configurable fields to record specific details about each requirement, including
details like ID, Name, and Description. Also include values for capturing data like workflow status and
validation method, similar to columns in spreadsheet.

User management
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A primary role for administration in any enterprise system is the assignment of licenses and managing
access to data. Jama Connect includes several options to give administrators the ability to fine-tune
read/write/review access to fit their company’s needs.

Learn more about user management

* Licensing [578]
* Managing users [568]

Manage item types

By default, a trial user account is set up with permissions of an organization administrator, which
gives you access to the ADMIN module in the top-level navigation. If you don’t see this, ask your
administrator to update your permissions.

Edit an existing item type

1. Select Admin > Organization, then select Item Types.
2. Find the item type you want and select Edit in that row.
3. Adjust the details that your project users can see when working with items.

» Display, Display plural — The name used to identify the item type, for example, System Re-
quirement.

+ Type key —The part of the ID that helps users quickly determine the item type of an item. For
example, the default type key for System Requirement is SREQ, so when a user sees an item
with the ID of QR-SREQ-34, they can know at-a-glance that the item is a System Requirement for
that project.

» Use as — Specific functions or permissions for item types configured as a test case or defect.

» Image — An icon to help users quickly differentiate items.

* Widgets — A graphic that shows additional data for the item. The most common widgets are
Versions, Links, Attachments, Relationships, Activities, and Tags.

4. Click Save.

Add a field

Chances are that the fields available in your selected item type are just what you need for your process.
But if you want to add details specific to your organization, you can do that too.

Select Admin > Organization, then select Item types.

Select Fields from the row of the item type.

Select Add Field from the fields’ header for the item type.

Select Custom Fields, then select the type of field you want to add.

Enter the name you want users to see in Field Label.

The Unique Field Name is pre-populated with a suggestion. This name is used for reporting or
accessing from REST API.

6. Depending on the field type you select, additional options might be required. If prompted, configure
them now.

7. Click Save.
8. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Al i

Configure pick lists

A common field to configure on an item type is a pick list. Pick lists can be reused, and the list you want,
like Priority, might already exist. You can adjust the language or values to fit your needs.
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If you need a new list, you can create it before you add the new field to an item type.

1. Select Admin > Organization, then select Pick lists.
2. Find the pick list you want and select Values in that row.
3. Add a new value or edit an existing value:
* New — Select the + icon and enter the value.
» Existing — Select the row and click the pencil icon.
4. Click Save.
5. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Managing relationship rules

Relationships are an important part of ensuring compliance and quality. Many industries base their
processes around the V-Model and need relationships to enforce the traceability through the stages.

Creating the correct relationships can be challenging for users, so Jama Connect gives administrators
the ability to configure rules that help guide users in making the correct connections.

In the previous process example for a medical device, the item type User Need can have two down-
stream relationships: System Requirement and Validation.

To configure these relationships, you use the Relationships option from the left panel.

Upstream refers to the higher-level item type that is affected by the lower level (downstream) item, often
through an activity like testing or decomposition.

Add a new relationship rule
Creating a relationship establishes a directional link between two items.

1. Select Admin > Organization, then select Relationships.
2. Find the relationship ruleset you want.
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3. Scroll to the bottom of the list of rules and select Add relationship.
4. Configure the relationships:
a. Select the Upstream Type.
b. Select the Downstream Type.
Relationship types describe why the relationship between the two items exists. View the pick list
above the rulesets on the Relationships page.
c. Select Yes or No to configure if the relationship is used for coverage.
Note: If you select For Coverage, Jama Connect notifies users if this relationship doesn’t exist.
d. Click Save.

Managing workflow
Similar to relationships, workflow is an important part of ensuring compliance and quality.

Workflow in Jama Connect is highly configurable. In general, workflow is set up on an item type with
a pick list of available statuses. This process guides a user though specific steps, making sure that
only users with correct permissions can make the transitions (by utilizing the Transition Permissions
features), then locking items from further updates when needed.

For example, when an item is moved from Draft to Approved, it is locked so no changes can be made
while it is in the Approved state.

Add a new transition to a workflow

The best way to understand workflows is to start with a workflow that's included in your collection of
data.

1. Select Admin > Organization, then select Workflow.

2. Find the item type you want and select Config in that row.

3. In the Workflow Configuration section, use the item type and picklist field options to set up and
manage the transitions between statuses.
The Current Status column shows all values for the selected picklist field; the New Status column is
the option you want for the transition from that state. For example, a requirement that is a Draft can
be Approved or Rejected.
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4. (Optional) To add a transition state, select + and configure:
+ If users are notified of the change
+ If the item is locked when it transitions to the new state
» Any restrictions on who can make the update

5. (Optional) Select - to remove a transition state.

6. Click Save settings.

REST API and extensibility

Jama Connect offers a powerful REST API that allows your team to integrate and extend the out-of-box
capabilities of Jama Connect.

Typical use cases include:

* Integrating test results from automated test scripts
» Extracting specific data for analysis in Business Intelligence tools
» Automating batch manual tasks

You can see REST API swagger documentation at <your Jama URL>/api-docs/
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Interested in learning how to work with the Jama Connect REST API? The following resources can help
you get started.

» API Cookbook provides recipes for users and partners creating integrations using the Jama Connect
REST API: https://dev.jamasoftware.com/cookbook/

» Jama Connect REST API documentation provides information about the specifics of our API: https://
rest.jamasoftware.com/

ID Description

Project ID Project IDs are unique to Jama Connect. Your administrator sets the default project and set keys.

Example: <project key> - <set key> # <SBX-REQ-1 or SBX-TEST-3>

Global ID Global IDs are used to reference where a requirement or test was reused globally across Jama
Connect projects. The Global ID isn’t unique because several copies of items might be connected
that share the same Global ID.

Example: GID-1234

API ID API IDs are the database identifier for an item and is used by developers when interacting with
Jama Connect from the REST API.

In List View, you can locate the API ID as a column or in the browser URL for the item you're
viewing in Jama Connect.

Example: 21374

Find Project API ID in URL:

Find Filter API ID, navigate to the filter in Jama Connect and look at URL:

Find Item API IDs:
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Find API IDs in List View:

Jama Connect top tasks

Want to learn more about the Jama Connect tasks that are of highest interest to our users? Based on
research and feedback, we created a table with links to the top areas our users want to know about.
A top task is a common feature that’s frequently leveraged by our users.
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Top task Helpful links

Create detailed requirements Add an item [66]

Create new items

Trace requirements to verifications and tests Traceability from requirements to test [14]

Jama Connect for modern requirements management

Extract information into Jama Connect from documents Import items [94]
Import from Microsoft Word [95]
Import from Microsoft Excel [104]

Import from IBM DOORS [121]

Audit for quality and completeness Item-based product development [13]
Export test cases to Microsoft Excel [324]
Test [316]

Advanced filters [135]

Dashboard [353]

Collaborate with your colleagues Collaborating with your team [196]
Reviews in Jama Connect [149]
Staying connected with the Stream [203]

Electronic signatures [225]

Roles for review workflow [149]

Videos and top resources

Use these videos to get acquainted with Jama Connect and to access additional information and
resources.

» Get started with Jama Connect
« Jama Connect Basics
+ Jama Community Top Resources
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Setting up your work environment

You can change the settings for your profile and workspace to suit your needs and your project work.
My Profile page

» Add a photo

+ Add contact information

» Change your password

» Control subscriptions (email notifications)
+ Manage settings for reviews

Workspace

» Customize the Explorer Tree
» View a group of content
» Configure fields

Editing and managing your profile
Your profile is where you change your password, view locked items, and manage subscriptions.

To manage your profile, select your name in the top right navigation to open the My Profile window.

To do this... Select...
Edit your user details Edit settings
Replace your default user picture Edit avatar
Reset your password [37] and you're not using SSO Change password
Set API credentials [38] Set API credentials
Configure your item subscriptions [39] My subscriptions
View your locked items [41] My locked items
View and unlock system-locked items [549] System locked items
Configure your review subscriptions [40] Review Center

Reset your password
You can change your password from your My Profile window or reset it from the login screen.

An organization or system administrator can also reset user passwords [578].

NOTE

If your organization is using LDAP or Crowd authentication, this feature is disabled.

1. Select your name in the header to open the My Profile window.
2. Select Change Password from the options at the top of the window.
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3. Enter and confirm your new password.
Passwords must meet the strength requirements set by the system administrator [501]. To display
tips about which characters are required for password strength, hover over the center of the
window.

4. Select Close.

Set API credentials

To integrate applications and scripts through the Jama Connect REST API [471], you must first gener-
ate API credentials. We currently use OAuth 2.0 authentication to generate pairs of client IDs and
secrets. This method is often preferred by users and IT security groups over more basic methods that
directly take usernames and passwords.

Important considerations

» To use the APl in a self-hosted environment, you need basic authentication for scripts and integra-
tions.

» API credentials like these are only used for safe authentication. User access and privileges set by
your Jama Connect administrator are still enforced.

+ For full instructions on how to use API credentials after you generate them, see the developer notes
on authentication.

* You can make a maximum of 20 API credentials; remove the ones you don't need. To do this, select
Set API credentials from the My Profile window.

To set your API credentials:

1. Select your name in the header to open the My Profile window.

2. Select Set API Credentials at the top right of the window.

3. Add a name (required) to help remember why you made these credentials and a short description
(optional) that's easy to understand, like Test Automation Integration.

4. Select Create API Credentials. Jama Connect generates a new Client ID and Client Secret pair
for you to use.
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5. Copy the Client ID and Client Secret right away.

o IMPORTANT
The Client Secret is displayed only once, right after you create it. Copy the Client
ID and Client Secret into your application before you continue. If you don't copy
them now, you must create a new Client ID and Client ID.

Configure email notifications and subscriptions
You can subscribe to email notifications [196] to stay up to date on item changes. To receive email
notifications, you must configure your profile to receive them.

You can only unsubscribe to notifications that you created for yourself. If you have notifications that
others subscribed you to, you can’t unsubscribe, but you can mute them.

NOTE

Muting notifications can be disabled by an organization administrator [618].
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Select your name in the header to open the My Profile window.

Select My Subscriptions, then select the tab with the subscriptions you want to see:
* Me — Subscriptions you created

+ Others — Subscriptions that others created for you

Show Items Subscribed by Me (1) | Others (1) g Unsubscribe selected

Show Items Subscribed by Me (1) Others (1) o Mute selected

Define how often you want to receive notifications: use the drop-down menu at the bottom of the
window.

Default is to check for new notifications every 5 minutes.

» Daily — Receive a batch of notifications in a single daily email.

+ Weekly — Receive a batch of natifications in a single weekly email.

* Mute All Notifications — Silence all item subscription emails.

NOTE

Muting notifications only affects email subscriptions for items and not other types
of email notifications [196].

Configure my review settings
You can subscribe to a review [193] to keep up to date with comments on items in the review.

1.

Select your name in the header to open the My Profile window, then click Review Center.
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2. Configure your settings:

» Enable email updates from Reviews.

» Automatically follow items you commented on.
3. Select Close.

View and unlock locked items
You don't need administrator permissions to unlock items that you locked.

Organization admins can... Unlock other users' items [547]

View and unlock system-locked items [549] across projects in Jama Connect

Project admins can... Unlock other users' items [547]

View and unlock system-locked items in projects where they are admins

TIP
@ In Single Item View, you can see who locked an item when you hover over the Edit
button.

Organization and project admins can't unlock system-locked items using the batch
update workflow.

To view locked items across projects:

1. Select your name in the header to open the My Profile window.
2. Click My Locked Items to view a list of locked items.

3. Select the item you want to unlock, then select Unlock in the top right corner of the window.
Note: Organization admins can select Show All Locked Items.

4. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,
Last Locked By, and Last Locked.
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= K T E~ @~ £ Bitems

<) Restore defaults Al Selected (15)
Itemn Type Last Activity Date
v Last Locked v Last Locked By
v Locked Max
Min Modified By
Modified Date Name

To unlock your items across projects:

1. Select your name in the header to open the My Profile window.
2. Click My Locked Items to view a list of locked items.

3. Select the item you want to unlock, then select Unlock in the top right corner of the window.
4. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,
Locked By, and Last Locked.

To lock or unlock items in List View:

1. In List View, select the items you want to unlock.
2. Select Batch edit.

3. Inthe Batch update window, enable Locked Status, then select one of the following:
* Unlock all items
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* Lock all items

4. Click Next, comment and notify users as needed, then select Commit.

5. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,
Locked By, and Last Locked.

= B T E~ @~ £ Bitems

<) Restore defaults All Selected (15)
Itemn Type Last Activity Date
v Last Locked v Last Locked By
v Locked Max
Min Modified By
Modified Date MName

The new columns and results appear in the table.

Adding and deleting bookmarks

Bookmarks are links to content you view frequently and are displayed at the top of your homepage.
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NOTE

You can use your browser's bookmarks or favorites feature to bookmark any view in
Jama Connect.

Bookmarks remain at the top of the homepage, sorted by most recently viewed. Projects, components,
folders, sets, filters, risk analyses, and Trace Views can be bookmarked for future reference.

You can add bookmarks in two different ways:

+ Bookmark recently viewed content on the homepage — When you view a particular folder, set,
component, or project it will appear in the Recently viewed list on your homepage. Select the empty
bookmark icon for the content you want to bookmark. The bookmark icon changes to a solid icon and
the content appears under the Bookmarks and Recently viewed sections.

+ Bookmark Trace Views — When viewing a Trace View that you want to bookmark, you first save
the Trace View [256], then select the bookmark icon at the top of the page. Trace View is now
bookmarked on your homepage.

To remove a bookmark, select the solid bookmark icon in the bookmarks list on the homepage. The
content you remove appears at the top of the section.

NOTE

You can also bookmark risk analyses [416]. These are visible for organizations with
risk management licensing, and appear when you select Risk in the header.

Learn more
Here are some ways to learn more about the application:

» Select Projects > Learn more to see a list of in-depth resources about Jama Connect.
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* You can see which version of Jama Connect you're using at the bottom of the page or from the login
page if you're using the default authentication.

» View a glossary [668] of Jama Connect specific terms.

» Look for Learn more or the question mark icon throughout the application. You can also select Help
in the top right corner to open the Jama Connect User Guide in a new tab.

Getting familiar with the Jama Connect interface

The Jama Connect interface is where you work with and manage your projects. It is made up of several
distinct areas, each with its own purpose.

The information in Get started introduces you to the interface. This chapter takes a more detailed look
with descriptions of toolbars and panes in the interface. It also includes instructions for customizing the
Explorer Tree and configuring how you view your projects.

Explorer Tree
The Explorer Tree organizes the sets, components, folders, and items in your project.

How it works

You can drag and drop items between the Explorer Tree and List View [51] to move items [79]
and organize your project. You can also configure settings [47] so that the Explorer Tree displays
information that's most useful to you.
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Jama Connect arranges content by component, set, and folder. Select one to view its content.

For more information about how to use the Explorer Tree:

* Find an item in the Explorer Tree [147]
+ Filter the Explorer Tree [139]
* Move items in the Explorer Tree [79]

Tips and more

* When working with a large number of items — more than 250 items per folder — work with them in
List View instead of the Explorer Tree.

» To move multiple items, you can multi-select in the List View and drag them to their new location in
the Explorer Tree.
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Customize the Explorer Tree
The Explorer Tree organizes the sets, components, folders and items in your project hierarchy. You can
configure the Explorer Tree settings so that it displays only information that's useful to you.

1. Select the gear icon at the top of the Explorer Tree to open the Explorer Settings window.

2. Inthe My Settings tab, select the changes you want:

+ Use my own settings — Overrides the default Explorer Tree settings with your personal set-
tings.

» Use default settings — Returns the Explorer Tree to the default settings. An organization or
project administrator can configure default Explorer Tree settings [636].

+ Show item IDs — Displays the unique ID [637] (as in PROJ-REQ-25) before each item.
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3.

+ Display global ID — Displays the global ID (as in GID-8845) before each item. This can be
helpful if the item is copied and synchronized.

+ Show only folders / hide items — Hides items from view in the Explorer Tree. Components,
set, and folders are still displayed. This can improve performance when your project has a large
number of items.

» Show outline numbering — Displays a number scheme of order and depth in the Explorer
Tree. Root level items have numbers like 1, 2 or 3. Child items contain the parent item number
as well as its own number, like 1.1, 1.2 or 1.1.5.

+ Show relationships in Explorer Tree — Displays downstream relationships of items in the
Explorer Tree. Select the green downstream arrow to open the related items in List View.

A CAUTION
Be careful not to relate an item back to itself. You can create an infinite loop that
causes the Explorer Tree to expand. To avoid this, don't relate items in a way
that creates an infinite loop.

Select Apply. When you're satisfied with changes, select Close.

Tools for viewing and controlling content

With Jama Connect, you can look at and control your content according to the type of work you need to
do.

Toolbar [48] — Provides different methods to control and view your content.

List View [51] — Shows data from multiple items in a table with a different field in each column.
Reading View [52] — Shows text and images for a group of items so you can read through selected
items like a document.

Trace View [52] — Shows related upstream and downstream items, missing relationships, and item
details in context of their relationship.

You can also customize fields [54] that control how you view your projects.

Toolbar

The toolbar is located in the center of the workspace. The tools allow you ways to control and view your
content.
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Toolbar options vary slightly depending on your location in the application.

Select... To...
View details See the details of a component, set, folder, or a project overview.
List View Show data from multiple items in a table with a different field in each column.
You can sort, select, and compare items at a glance.
- For more information, see List View [51].
Reading View Show text and images for a group of items, which allows you to read through selected items like a
document.
. For more information, see Reading View [52].
Filter items Open the filter panel and filter the items you want to see.
A filter limits the group of items or comments by content, like author, keyword, date, or coverage.
Row height In List View, manually adjust the height of the rows.
daiaia If you select Extended, rows are formatted to wrap text.
Row height

| @~ O Tiems

: 1= Condensed I
1=

Medium

= Extended

Gear icon (show/hide
fields)

= B Y 1E- [&~| & 20017 selected

O Restore efaults Al Selected (14)

' # of Attachments

v/ #of Comments

/i of Downstream. v #oflinks

Configure which fields appear for each item in Reading View, List View, or Trace View.

For more information, see Configure fields [54].

Refresh

]
s

Refresh the list of results and recent changes from other users.
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Select...

To...

Add items, folders, sets, and components.

Trace View

" Trace view

Show related upstream and downstream items, missing relationships, and item details in context of
their relationship.

For more information, see Trace View [52].

Export

Export your data to Word, Excel, PDF, or use one of the Office Templates.

Batch edit

Batch edit

xl
=

Update picklist fields and tags for multiple items at a time.

Reuse

Reuse

(L]

Reuse [279] when your projects contain items that are the same or similar.

Convert to

Convert to

¥ -

Change an existing item or items from one type to another.

Batch transition

Batch transition
a5 9

£
L]

Select multiple items of the same item type and transition them to a different workflow status.

Send for review

Send for review
-+ T ]

8
1

Send specific items for review.

Note: The maximum number of items you can Send for review is 500.

Relate to existing

Relate to existing
4 o @&

Relate two existing items of the same item type.
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List View

In List View, you can configure which fields appear as table columns. The table is dynamic — you can
sort, select, drag and drop, and reorder columns.

Tips and more

+ If your organization has a risk management license, you can also configure this view [54] to see
risks in List View [423].

» To reorganize columns, select the column header and drag it to the new location.

» To choose which fields you see in the table, you can configure fields [54].

+ Use the interactive links (breadcrumb navigation) to find your way around and view the location of
your project hierarchy.

» To sort items, select the column header.

View information about an item.

QL-BR-3

Move [79] items in a project.

View locked items [41].

View how many relationships an item has, as well as whether those relationships meet the project's relationship rules.
For more information, see Relationship Status Indicator [269].

View and add comments [210].

i'i°"H°H

View and add connected users [224].

View related items (the relationship between two items). For more information, see Add a relationship from Single ltem
View [260].
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Reading View

Reading View shows text and images for a group of items so you can read through selected items like a
document.

You can use Reading View in both Projects and Reviews. Click Reading View on the toolbar at the top
of the center panel.

From Projects > Reading View you can:

+ View images

» Select individual or multiple items

* Open items

* View hierarchy with numbering

» Drag items to the Explorer Tree to reorder (as long as item type allows it)
» Add comments and view connected users

» Configure fields [54]

» View related items

» Export hierarchical content from an advanced filter [140]

+ If your organization has a risk management license, you can also configure this view [54] to see
risks in Reading View [423]

Trace View

Trace view shows related upstream and downstream items, missing relationships, and item details in
context of their relationship.
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When you select Trace View, the items you selected in List View are displayed in the Source column.
Related items downstream from the source are displayed to the right. ltems upstream from the source
are displayed to the left. Use the blue arrow buttons on either side of the screen to travel up or
downstream.

The top of each level column shows a count of the item types found on the entire level.

@ NOTE
The item count is a unique count. If the same item is downstream of multiple items
in the source column, it appears multiple times in the "1 level down" column, but it's
counted only once.

Select an item in the source column to highlight its specific upstream and downstream relationships.
You can select multiple items using the checkboxes. Selections remain highlighted as you navigate.
Select X to clear your selections.

Select Set columns at the top of each trace level to turn fields on or off [54] for items in that level.
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Use Trace View to find missing coverage and use the Add menu in the toolbar to add items directly from
this view.

You can also filter Trace View [258] or use Trace View to save a view [256] or export the content [257].

You can also use the Trace View to see validation and verification testing results. If a test case is visible
in Trace View, you also see the related test runs. No manual creation of relationships is required; Trace
View infers the relationship between test cases and runs and once a test cycle is created.

If your organization has a risk management license, you can also configure this view [54] to see risks
in Trace View. [423]

Configure fields
Choose which fields you see for each item in Projects Reading View, List View, or Trace View.

Tips and more

» All users see the Risk field as an option. However, risk analyses function only if you purchased
additional licensing.

* You can also configure your Compare View for synchronized items [296] or your List View for
baselines [247].

1. Select the gear icon (show/hide fields) in the toolbar [48].

= B T S~ |@~| 2 2o0f17 selected

“) Restore defaults Al Selected (14)
v i of Attachments v # of Comments
v # of Downstream. .. v # of Links

In Trace View you can configure fields for each level independently.
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2. In the drop-down list, select the fields you want to see. Reading View remembers user selections
for a particular location so they appear across sessions.
3. Close the window.

The table displays your changes.

Single Item View

In Single Item View, you can view specific details about an item. For example, an item's ID, Name,
Description, and Status. This view always shows all the fields the item type is configured to include by
your admin.

You can also edit the item [70] and use widgets [56] to access different areas of Jama Connect.
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Here's a high-level overview of some of the features Single Item View offers:

Side toolbar [56]
Global ID [278]

A

Top right toolbar [48]
Projects workflow [198]

Breadcrumb navigation (formerly called "Find me") helps you find your way around and indicates

the location in your project hierarchy.

Side toolbar

The Side toolbar appears on the right side in Single Item View. The widgets are buttons that give
you access to different features of Jama Connect. Widgets can be configured by an organization
administrator configured by an organization administrator [593].

Select...

To...

Relationship Status Indi-
cator

i o

. e

Open the bottom panel where you can see the required relationships for this item and whether the
item follows the project's relationship rules. Suspect relationships [270] are also flagged.

Connected users

”
(2

Opens a window that displays the users directly associated with the item as well as indirectly
associated with related or traced items. The number displayed is the number of connected users.
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Select...

To...

Review comments

E

Opens and closes the bottom panel of review comments [178] related to this item. The number
displayed is the total number of comments for this item.

Comments

0
o

Opens and closes the bottom panel of comments [210] related to this item. The number displayed
is the total number of comments for this item.

Activities

A
[ 34

Opens and closes the bottom panel display of activities [209] related to this item.

Versions

V|
(3]

Opens and closes the bottom panel of item versions [230]. The number displayed is the total
number of versions for this item.

Synchronized items

Opens and closes the bottom panel of synchronized items [288].

Child items Opens and closes the bottom panel with a list view of child items [69]. Appears only if the
selected items has child items.

(1]

Items to be changed

Y

Opens and closes the bottom panel with a list of change requests [232] that might affect this item.

Compare View

Compare View shows side-by-side content so you can compare differences between different item
versions.

To open compare view, select the Version widget in the side toolbar.
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Compare View is used in these areas of Jama Connect:

* Compare versions of reviews [187]
» Compare synchronized items [293]
» Compare item versions [231]
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Creating content

Content in Jama Connect is structured using an item-based approach rather than a document-based
approach. Items are the major building blocks for your content and Jama Connect includes several item
types.

Item type: Containers

Components * Structural container
» Organize projects into manageable pieces
Sets + Structural container

ﬂ * Access rights can be configured
Iltems of the same type can be grouped
Contain folders, test items, child items

s Folders Structural container

+ Organize items

» Manage hierarchy in the Explorer Tree
» Contain text items or items of the same type

Item type: Items

ltem Individual building block of a project

» Comprised of customizable fields

Organizations typically create items as requirements, features, use cases, test cases, defects, or other
information types that define the scope of a project or product.

To create content in Jama Connect, you can import existing content from another platform, or you can
author directly in the application.

A typical process for creating content might include these tasks:

TIP

@ Before populating Jama Connect with your data, discuss with others in your organiza-
tion which elements of the application you want to use and how you want to use
them. Involving team members early in the process can help avoid rework later.
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Containers

Containers help organize your content in Jama Connect. Types of containers include components [60],
sets [61], and folders [63].

Item type: Containers

Components  Structural container

|_IE| « Organize projects into manageable pieces
Sets « Structural container

? « Access rights can be configured

* Items of the same type can be grouped
« Contain folders, test items, child items

Folders « Structural container

« Organize items

« Manage hierarchy in the Explorer Tree

« Contain text items or items of the same type

NOTE

A source folder [239] is a specific type of folder that refers to baselines. It is the only
container type that is not an item.

Add a component
A component is a structural container item used to organize a project into more manageable pieces.

For example, you might define each piece of your product with a different component.

» Components can only be located or moved to the root of the Explorer Tree or inside another compo-
nent.

+ Components might contain sets of various item types, text items, and sub-components. Each compo-
nent can have different access rights.

NOTE

Text items can appear anywhere in this structure.

To add a component:

1. Open the Add Item window using one of these methods:

* Wherever you want to add a component or sub-component in the Explorer Tree, right-click on
the project name.
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+ Select Add > Component at the top of the left panel in the project where you want to add the
component.

2. Inthe Add ltem window:
a. Write a name and description for the component.
b. (Optional) Select Notify to select users or groups you want to notify about the creation of this
component.
c. (Optional) To add more components, select Add another.
d. (Optional) Use the Select Location window to choose where to put the new folder.
This option appears only if you created a folder from the Add drop-down menu.
Invalid locations are disabled.
3. Click Save and Close.

Add a set

A set is a structural container item with configurable access rights, used to group items of the same
type. It can also contain folders, text items, child text items, and child items of the same type.

A set contains items of the same type. You can move or copy between sets of the same item type.
Item types for a set are configured by an organization administrator [589].
To add a set:

1. Open the Add Item window using one of these methods:
+ Wherever you want to add a set in the Explorer Tree, right-click on the project name and select
Add > New item > Set of..., then select the item type from the list.
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* From the top of the left panel, select Add > Set of..., then select the item type from the list.
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2. In the Add Item window:

a.
b.

Edit the set key, name, and description of the set.

(Optional) Select Notify to select users or groups you want to notify about the creation of this
set.

(Optional) Select Add Another to add more components, then select the location for the new
set.

(Optional) Use the Select Location window to choose where to put the new set.

This option appears only if you created the set from the Add drop-down menu.

Invalid locations are disabled.

3. Click Save and Close.

Add a folder

A folder is a container item you can use to organize items and manage hierarchy in the Explorer Tree.

Folders are a structural item type that contain other items, not an array of different item types. Folders
can contain only text items and the same item type as the folder itself. Folders can be located or moved
inside a set of the same item type, or inside another folder. You can't place a folder inside a component
of mixed item types.

An item can be moved between folders and sets of the same item type using drag and drop within the
Explorer Tree or from List View. Folders can be dragged to other sets of the same item type or into
other folders also in the same item type.

To add a folder:

1. Open the Add Item window using one of these methods:
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* Wherever you want to add a folder in the Explorer Tree, right-click on the set name and select
Add > New item > Folder.

+ Select Add > Folder at the top of the left panel in the project where you want to add the folder.

In the Add Item window:

a. Write a name and description for the folder.

b. (Optional) Select Notify to select users or groups you want to notify about the creation of this
folder.

c. (Optional) To add more folders, select Add another.

d. (Optional) Use the Select Location window to choose where to put the new folder.
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This option appears only if you created a folder from the Add drop-down menu.
Invalid locations are disabled.
3. Click Save and Close.

Items

Items are the building blocks of Jama Connect. Projects are made up of items and items are made up
of fields. Iltems can be containers [60] or documents.

Item type: Containers

7 Components « Structural container
i_|;| « Organize projects into manageable pieces
Sets « Structural container
'ﬁ' « Access rights can be configured

* ltems of the same type can be grouped
« Contain folders, test items, child items

Folders « Structural container

< Organize items

« Manage hierarchy in the Explorer Tree

« Contain text items or items of the same type

Item type: Items

Iltem Individual building block of a project

« Comprised of customizable fields

All items have a global ID [278], a unique ID [637], and an item type that's determined by an organiza-
tion administrator [589].

NOTE

Baselines, source folders, risks, risk analyses, reviews, and test groups aren't items,
so they don’t have an item type and a global or unique ID.

Several places in Jama Connect allow you to see a quick preview of an item without opening it in the
center panel. For example, right-click on an item in the Explorer Tree and select Preview item.

Container items

Select View details next to a container's title to:

+ Display container's detailed information.
» Open container's attachments [84].
+ Edit the name or description of the container itself.
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TIP

To receive email notifications when a container changes, subscribe yourself [197] or
others [197] to the container.

Add an item

Even if you import data from another application or sync data from another tool, you can also add a new
item to your project as needed.

You can an add an item to a project from several places in Jama Connect. The list of displayed items
includes only item types that are valid for the selected location.

NOTE

You can't add items in filters or in lists of mixed item types.

# STREAM PROJECTS REVIEWS RISK Redside Consulting Dave Wilson | Reports » | Help | Log Out
Clear 3 Hearing Ald £~ Project = O Advanced search
Project » | Change project « Learn more ,f& Dashboard: Clear 3 Hearing Aid £y, User Needs and Market .. Needs *
.| Explorer | 57 || [ [ B / User Needs and Marke... | CL4-FLD-8 Email
© Add v 2 @
Bl .- ) .
= (74 Clear 3 Hearing Aid Needs © Add o Traceview [E. ~
] + Validation Protocols Folder = View details
A
=] ;2 User Needs and Market Requirements.

[# | |Needs S+ & O 1litem

= B T 1
3] k . Demographics
S I
Go Ko

test
¥ [f] System Requirements. user needslist (0

+| [f] SubSystems
+| [F] Risk Management
1 W Defects
|4 System Requirements
¥ [F] System Requirements.

o #dd Tag +Cloud | = List | &

2(0) Flagged(1) Items to be changes(0)

new(0) new tag2(1) tag(G)

test(2) user needs list(1)

Page 1 of 1

To add an item to your project:

1. Open the Add item window using one of these methods.
* Right-click the project name — In the Explorer Tree (or wherever in that project you want to
add an item), right-click the project name, select Add > New item, then select an item type from
the list that appears.
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* Add drop-down list — In the project where you want to add the item, select Add at the top of
the left panel, then select the item type from the list that appears.

» Toolbar — From the toolbar above Single Item View, List View, or Reading View, select Add,
then choose the item type from the list that appears.
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In List View, if the list contains items of a single item type and no items are selected, you can add
an item of the same type, a text item, or a set to the bottom of the list.
If an item is selected, use one of these options.
* Insert new to insert a new item below the selected item or add a child item.
+ Add Item Type as child to add an item as a child item of the selected item.
+ Add related to add a related item to the selected item. If a relationship rule [259] was applied
to that project, only item types that meet the rules are available for that selection.
* Quick add add items in a set of the same item type.
2. Select the location where you want to add the new item in the window that opens (invalid locations
are disabled), then click Select & Close.
3. Inthe Add Item window:
a. Fillin the fields for the selected item type.

b. (Optional) Select Notify to add a notification comment and select users or groups to notify
about the creation of this item.
Comments are included in the version notes for the item and are displayed in the stream [209].
4. Select Save or Save and Close.
5. Select Commit.

Quick-add an item
The Quick-add option lets you add multiple items at a time to a set of the same item type.

You can add up to 50 items at once.
Important considerations

» The Name field is required.
» The Description field is required or read-only based on how the item type is configured.
» To add required fields, edit the item after you create it.

To quick-add an item:

1. Inyour project, select Add > Quick add.

If you don’t see the Quick add option, then the item you're adding doesn’t match the item type in
that set.
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2. Enter the required name for the item (255 characters maximum) and an optional description (500
characters maximum).

3. Click Add Row to include additional rows as needed, for a maximum of 50 rows (items). Include a
name and optional description for each added item.

Use the tab key to move across the table.

4. Click Save.
The new items appear in the Explorer Tree.
5. To add required fields to a new item, select the item to open and edit it.

Add a child item

Create a child item when you need an item that falls hierarchically below a parent item of the same item
type.

Important considerations

+ If a parent item includes a child item, the parent item can't be converted to a text item.
* A parent item can include a child item that is a text item.
» Relationships and attribute values of a parent item aren't inherited by child items.

To add a child item:

1. Right-click on an item and select Add > New item > Sub Component.
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2. In the Add item window, fill in the fields for the selected item type.

3. (Optional) Select Notify to add a notification comment and select users or groups to notify about
the creation of this item.

Comments are included in the version notes for the item and are displayed in the stream.
4. Select Save or Save and Close.
5. Select Commit.

Edit an item
You can edit a saved item any time you need to add or change its information.

Single Item View automatically displays items in a read-only format.
Important considerations

* You must have create/edit permissions to edit an item.

A field must be enabled for read/write permissions.

+ If afield is disabled for editing, it might have been configured to be read-only [598] by an organization
admin, locked by another user, or locked through a workflow.

To edit an item:

1. Select the field you want to edit, using one of these methods:
» Double-click on the field
» Hover over the field and select the pencil icon to make it editable.

70



Jama Connect User Guide

« Select Edit from the toolbar.

2. Edit the item field, as needed.
3. When you're done editing, select an option:

+ Save & done.
» To save and add another item of the same type, select the arrow on the middle button, then
select Save & add another.
+ To save and notify other Jama Connect users, select the arrow on the middle button, then select
Save & notify.
4. Select Save Changes to complete the edit and create a new version of the item.

A confirmation message confirms that the item was successfully changed.

Edit an item in List View

You can edit an item to make needed changes, for example to picklists, fields, and tags. In List View
you can update multiple items of the same type. You can make changes in one item, then press Enter
to move to the next row.

TIP
@ If you need to make the same changes across multiple items, use batch update [72].

1. Double-click the field you want to edit in projects List View.
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2. To undo any unsaved changes, press Escape or select Cancel below the selected item.
3. Select Save or press Enter to save the change and move to the next item in the list.

Batch-update multiple items
You can update picklists, fields, and tags for multiple items at one time.

Important considerations

* You can't batch-update rich text fields. Instead, use a Jama Connect to Excel round trip [117].

* You can't batch update test runs using this method. Instead, use the Test runs window to batch
update test runs [350].

To batch-update items:

1. Select items that you want to edit using one of these methods:

 In List View, select the items that you want to edit, then select Batch edit to open the Batch
update window.

» (Review moderator only) Select items for batch update in the item progress [190] tab of review
statistics.
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2. In the Batch edit window, make your changes, then select Next.

Batch adit
Select fields to update:

Assigned
Release
Add Tags

Locked Status

Remove Tags

Back

3. (Optional) Select users or groups and send a notification about this batch update.

4. Select Commit.

Add, edit, or delete links

You can add a link to an item using two methods.

73

Mext

Cancel



Jama Connect User Guide

» Associate a link with an item.
 Embed a link in a rich text field in an item.

If the Links widget was enabled by an organization administrator [593], you can store a link or URL in
Jama Connect, then assign the link to individual items across projects.

Important considerations

URLs that are prefixed with "http://" are treated as unique links. URLs without the prefix are added to
the end of the Jama Connect URL, which might be helpful if you placed files on the server and you want
to link them without uploading them as attachments.

For example:

* http://www.creativecommons.org — Opens a new browser window with the URL https://creative-
commons.org/

» screenshots/login.html — Opens a new browser window with the URL http://localhost:8080/con-
tour/screenshots/login.html

To add, edit, or delete a link:
1. To add a link, in Single Item View, select Add link, then fill in the fields and select Save.

LINKS:
www.jamasoftware.com wew @l

O Add link...

2. To edit or delete a link, select Edit or Delete from the link's row.

Locking an item

A lock makes an item read-only, so that it can't be edited or deleted. An item can be manually
locked [74] or automatically locked [202] by the system.

What can you do with a locked item?

* Reuse [279] and create relationships from a locked item.
* View and unlock locked items [41].
» Find out who locked an item.

What can’t you do with a locked item?
+ Edit, delete, or synchronize locked items.
Who can unlock a Jama Connect item?

An organization admin or project admin can unlock system-locked items [549], but only an organization
admin can unlock items manually locked by another user [547].

Locked items Who can unlock?
Manually locked by other users Organization admin
Locked by system or workflow * Project admin

« Organization admin
« Creator user with workflow transition permissions (only for projects the user administers)

Manually lock and unlock items from the toolbar

To prevent others from making changes while you're working on an item, you can manually lock that
item.
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When you configure List View to show locked items, a gold lock appears next to items that are manually
locked.

TIP
@ If you need to access an item locked by another user, contact that user or your
organization administrator to unlock it.

1. To lock an item manually — In Single ltem View, select Lock item from the toolbar.

2. To unlock an item — (Organization or project admins only) In Single Item View, select unlock
item [41] from the toolbar.

Converting items to another item type

In Jama Connect you can change an existing item or items from one type to another. When you
convert an item to another type, these attributes remain intact: short name, description, relationships,
versions, activities, comments, and tags.

To convert an item, folder, set, or component, you can use:

* Drag and drop [76]
+ Context actions menu [77]

Important considerations

» Afield is converted only if its name or data type is identical in the current and new item types.

» A lookup field is converted only if it refers to the same pick list (and has has the same name and data
type) in the current and new item types.

» Converting an item breaks the sync if you reused that item.

+ If converting an item puts the item out of compliance with the relationship rules, the issue is reflec-
ted in the relationship diagram.

* When you convert a set, all items in that set are converted to a different item type.

* You can't "undo" an item conversion [79] but you can convert the item back to the original item type.
Use the same procedure you used to convert items.
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You can convert from...

Component

Set

Folder

ltem

Text item

To...

set

text item

component
set
folder

text item
item
folder
item

text item*

folder**

component
set

item

Notes

Sets within the original component convert to folders in the newly created set.

For components, the original set must be empty and at the top level of the hierar-
chy.

Original set must be empty.

* An item that include child items can't be converted to a text item.

** A child item can't be converted to a folder unless the parent is converted first. When converting to a

folder, items lose widget functionality and custom field values.

Convert items using drag and drop
When you need to change the item type for all items in a set, use the drag and drop method.

Important considerations

» Before converting items, read about how conversions work in Jama Connect [75].

* When you drag and drop a text item into a folder of your required type, the text item is moved to that

location, but it isn’t converted.
* You can’t use bulk conversion for text items. You must convert them one at a time.

* When converting an item to a folder, select Recursively convert all items with Children to Folders
in the Review Item Conversion window. Parent items at every level beneath the item being converted

are converted to a folder.

To convert an item or set to another item type with drag and drop:

1. From List View or the Explorer Tree, select the items and drag them into the set where you want to

move them.

2. Review the information in the Review Item Conversion window.
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w

Click Next to view each page of the Review Item Conversion window.
4. If converting an item to a folder, select Recursively convert all items with Children to Folders.
Parent items at every level beneath the item being converted are converted to a folder.

NOTE

This option appears only when you select a folder to be converted.

5. Select Convert.
If the item can belong in its current location (such as a text item), it remains there. However, sets
can't contain mixed item types, so the item might need to be moved.

6. If prompted to move an item, select the new location for that item, then click Select and Close.

7. To see changes, select Versions in the side toolbar [56] of Single Item View [55] to open the item's
version tab.

Convert items in List View or Explorer Tree
You can use the drop-down menu in List View or the Explorer Tree to convert items or sets.

Before converting items, read about how conversions work in Jama Connect [75].

1. In List View or the Explorer Tree, select the items you want to convert, select Convert to, then
select an item type from the list that appears.
» List View — Select the checkbox for the item or set.

* Explorer Tree — Right-click on an item or set.
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The Review Item Conversion window highlights in white the fields that are copied into the new
item type.

Click Next to view each page of the Review ltem Conversion window.

If converting an item to a folder, select Recursively convert all items with Children to Folders.
Parent items at every level beneath the item being converted are converted to a folder.

This option appears only when you select a folder to be converted.

Select Convert.
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If the item can belong in its current location (such as a text item), it remains there. However, sets
can't contain mixed item types, so the item might need to be moved.
5. If prompted to move an item, select the new location for that item, then click Select & Close.

@ NOTE
If you select multiple items in List View, you must also specify a location, even
if it's the items' original location. Doing this ensures that the items end up in the
correct place.

6. To see the changes, select Versions in the side toolbar [56] of Single Item View [55] to open the
item's version tab.

Convert items back to original type

You can't undo an item conversion, but you can convert your items back to their original type. When
changing back, the item receives new identifiers.

+ Use the same procedure you used to convert your items to convert the same items back to the
original type.

» Any fields that don't convert in the new conversion direction are lost. To determine if fields were
lost, select Versions in the side toolbar of Single Item View to open the bottom panel and select
Compare.

» Any fields that were lost must be manually replaced by an organization administrator [598].

Moving items
Within a project, you can move items using the Explorer Tree [79] or List View [80]. Once items are
moved, you can undo the move or find the items in the stream [146].

Rules for moving items

Item type Rule
Component Can have child components and can be moved to the root of the Explorer Tree.
Set Can be moved inside a component or to the root of the Explorer Tree. Sets can't have child sets.
Folder Can be moved to a set that's the same item type as the set where the folder was created, or to another folder.
ltem Can have child items of the same item type and be moved to a set of the same item type or to a folder.
Text item Can be moved anywhere in the Explorer Tree.
General You must have write-access to both an item and its new location. When components, sets, or folders are moved,
all items within them are also moved.

Move items in Explorer Tree
Iltems must meet valid item location rules [79] before then can be moved.

You can also move items between projects [80].
Visual indicators tell you if a move is allowed or provides guidance for moving an item.

* Green indicator — Moves that are allowed.
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* Red indicator —Moves that aren't allowed.
» Dotted blue line — Guide for moving an item between other items.

To move items in the Explorer Tree:

1. Select the item you want to move in the Explorer Tree.
2. Drag and drop the item to the new location.

Move items in List View
Iltems must meet valid item location rules [79] before they can be moved.

Quick tips

* If you select the tab at the top of the Explorer Tree and drag items from List View to the release, you
can change the release on one item or multiple items.
* You can move items between projects [80].

To move items in List View:

1. InList View, select the items you want to move.
2. Drag and drop the items to the chosen location.

Move items between projects

You can move an item or set of items, along with all associated conversations, versions, and attach-
ments to a different project. This is useful when a project has grown too large and performance has
started to degrade.

Important considerations — Review this list before you move items between projects

* A move can't be undone. Users can move items back to the original project but IDs are changed.

* You can only move components and sets between projects. If you're trying to move a folder of items
or individual items from a component or set, you must first create a new component/set, then move
those items to the new component/set.

* Document key IDs are changed when an item is moved. The new ID is based on rules set up in the
destination project.

* When an item is moved, all associated stream collaboration, activities, and versions are moved to the
new project. Attachments, tags, and releases are copied to the new project.
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+ If you delete the source project, images inserted in a rich text field that are copied in other projects
are also deleted because they are referenced and aren’t copied from the original project. To keep
images intact in the duplicated project, we recommend archiving the source project.

+ Original attachments, tags, and releases still exist in the source project, including links, images, and
diagrams within rich text fields.

» Test runs can't be moved. Test cases can be moved without impacting test runs.

+ Items contained in a review aren't shown in future versions of a review after they are moved.

» The document ID in old baselines reflect the new ID.

+ If any moved item is associated with an integration sync, integrations such as the JIH can't be
running while a move is being performed.

» Performance might be impacted at the time of the move if other resource-intensive processes are
being done at the same time.

TIP

@ If you delete the source project, images inserted in a rich text field that are copied in
other projects are also deleted because they are referenced and aren’t copied from
the original project. To keep images intact in the duplicated project, we recommend
archiving the source project.

To move items between projects:

1. Make sure that:
* You have write permissions in the source and destination project.
* The items to be moved must be unlocked.
+ All other move operations are completed. You can't make two moves at the same time.

2. In the source project, right-click on the set or component of items you want to move, then select
Move item.

3. In the Move items to... window, select the destination project and select Move.
4. Review details and select Confirm.

During the move you can go to the destination project by selecting Go to project or stay in the
same project by selecting Done.

A pop-up window shows progress of the move. If any item fails to move, the entire move fails.

Once the move is complete, you can find recently moved items [146] from the Activity Stream.

Duplicate an item
You might want to copy an item to use it as a template for a new project or a new requirement.

You can duplicate items in Jama Connect using these methods.

* Duplicate items — Create a copy of the item's name, description, test steps (if applicable), and the
ability to choose to include tags, attachments, and links. You can duplicate items that are locked.

* Reuse items — Creates a copy of an item, but with more options. With this method you can reuse
multiple items, reuse items with children, duplicate more of the item's content, or duplicate an item
from another project. For more information, see Reuse items [279].
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NOTE

You must have read/write permissions to duplicate an item.

To duplicate an item:

1. Right-click on the item you want to copy and select Duplicate item from the menu.
2. In the Duplicate item window, indicate whether you want to duplicate tags, attachments, or links.
3. Press Enter or select Duplicate.

@ NOTE
According to the item type, selected preferences are saved across sessions. How-
ever, clearing your browser data restores default options. When specific attributes
(as in links) aren't enabled for an item type, the option doesn't appear in the
pop-up window.

The item you duplicated opens in Single ltem View of the duplicated item.

Delete an item

When you delete items, they aren't physically deleted. They are marked as inactive and are no longer
visible to users or reports. If needed, they can be re-activated through the database.

Anyone with read/write permissions for an item can delete it, unless an organization administrator has
made the option unavailable [618].

Important considerations

* You can delete an item only if it is unlocked.

» Deleted items show up in the activity stream. The activity entry is also the only method of restoring a
deleted item [82] for those with delete permissions.

* In most cases, nothing is deleted from the Jama Connect database. Even if you delete another user,
item, or something else in the system, a record is maintained and the deleted object is merely de-ac-
tivated on the front end. However, you can permanently delete the selected project and everything
under it from the database.

To delete an item:

1. To delete in Single Item View [55], choose an item and select Delete.
2. To delete in List View [51] or Reading View [52], choose one or more items and select Delete.
3. To delete in the Explorer Tree, right-click on an item and select Delete.

Restore a deleted item

If you have permission to delete an item, you can also restore it. When you restore a deleted item, it
retains all comments, versions, and relationships associated with the item.

1. Select the project name at the top of the left panel to open the dashboard, then open the Activity
Stream widget [353] to view recent activities.

2. In the search field at the top of the Activity Stream widget, type delete to display all recently
deleted items.
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3. Find the item you want to restore and select Restore.

If the set for the restored item was removed, a component with a temporary set is created. The item can
then be moved to any set of the same item type.

Tags

Tags are labels that you can attach to items. They can help you find items with something in common.

NOTE

These tags are different than hashtags [211] that you apply to comments in the stream.

Tags are displayed in the bottom of the left panel in a section that can be hidden.

» Search for tags [133] using the "tag:" prefix.
* You can edit tags in List View.

» Tags can be displayed in a Cloud view:
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In either view, select the tag to view its associated items.

Add and delete tags
Add and delete tags as your project evolves, if you created a tag by accident, or to keep items
organized.

The tags widget must be enabled by an organization administrator [589]. Otherwise, the option to add a
tag isn't available in the Ul.

1. To add a tag to an item:
a. In Single ltem View, select Add tag.

b. Enter the tag name in the available field.
2. To delete a tag from an item, select the X in the tag.

Attachments
Attachments are external files such as images, documents, and spreadsheets that can be attached to
an item.

A project administrator can manage attachments [641] for a project.
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Important considerations

* You must have create/edit permissions to access attachments.

» These default filetypes are allowed: APK, AVI, BMP, CSV, DOC, DOCM, DOCX, DOT, DOTX, DWG,
GIF, GZ, JAMA, JPEG, LOG, MD, MOV, MP3, MP4, MPEG, ODG, ODP, ODS, ODT, PAGES, PDF,
PGP, PNG, PPT, PPTM, PPTX, RAR, RTF, TGZ, TIF, TIFF, TRA, TXT, VCS, VSD, VSDX, VSS, WAR,
WAV, WMA, WMV, WPS, XCF, XLS, XLSB, XLSM, XLSX, XLT, XPS, ZIP, ZIPX.

» Hosted environment — To add filetypes or ask about the number or size limits for attachments, ask
your Named Support Contact to request this from support.

+ Self-hosted environment — The system admin can update this list directly [498].

Add, edit, and delete attachments

An attachment is an external file such as an image, document, or spreadsheet that can be added to an
item. You can add, edit, or delete attachments as needed.

NOTE

You must have create/edit permissions to access attachments.

1. To add an attachment:
a. In Single ltem View, select Add attachment.

» To upload new items, select the Upload tab in the Add File Attachment window, then select
Choose file to select the file you want to attach and upload.
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+ To attach files that are already uploaded to Jama Connect, select the Existing tab in the
Add File Attachment window, then select the file you want to attach. Select Show all to see
all the files that are already attached to an item.

b. Select Attach to Item.
The file is now shown in Single Item View as an attachment.
c. To download the attachment, select the attachment name or the down arrow icon.
2. To delete an attachment, select Remove from item (trash icon).
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Remove from [tam

N O]

3. To edit what is attached to an item, select Edit (three dots icon) to open the Edit File Attachment
window.
V]

You can then:

* Reload the attachment.
» Update the name and description.
» Upload a different attachment, which overwrites the existing one. To add a new attachment, start
from step 1.
4. Select Save and Close.

Using the rich text editor

When the rich text editor is enabled [598] by your organization admin, you can format text in individual
fields and embed other data like images and tables.

With rich text fields you can use text formatting, hyperlinks [89], images [88], tables [89], spellcheck-
er (English), templates [92], diagrams, graphs [90], and equations [91].

NOTE

The equation editor requires additional licensing. Contact your Jama Software account
manager for more information.

If a field is enabled with rich text, you see the rich text menu, which provides rich text controls.
These controls are like text editing options in many software applications. You can also use keyboard
shortcuts [662] with the rich text editor.

Important considerations

» Many third-party reporting tools can't display rich text (HTML) properly.

* Integrations with third-party applications might not be able to accept rich text (HTML) data.

» Each rich text section can have its own style, making it difficult to control the overall look and feel of
your report.

* As needed, you can disable the rich text editor [598].

* Whenever a rich text item is saved, Jama Connect deletes certain text (usually code like JavaScript)
that might be a security risk. This doesn't affect most data.

Rich text toolbar and buttons
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9.

10.
11.
12.

Text style and size

Cut, copy, and paste — Paste action inserts selected text as plain text.

Field view — Insert document templates [92] (must be configured [608] by organization admin),
view source code, and fullscreen mode.

Format text

Subscript, superscript

Text alignment

List formatting

Edit text

Insert links [89]

Special tools — Add diagrams [90], images [88], tables [89], special characters.
Accessibility checker

Equations editor — Math Editor, Chemistry Editor.

The spellchecker automatically underlines misspelled words in red. Cmd+right-click on the word to
view spelling suggestions.

Insert image to rich text fields

The rich text editor lets you add an image to an item field. The editor provides multiple methods for
adding an image.

1.

NOTE

A system admin can manage file types [498] for self-hosted customers. Cloud custom-
ers need to contact support before they can use this option.

Add an image using one of these rich text methods:
* Toolbar option: Add image

TIP

@ Provide the full path to the image file to comply with third-party converters for
PDF and Word. If you move Jama Connect to a new server or modify the server
name, edit your image files to match the path or name change.

+ Copy and paste (not available with Internet Explorer 10)
* Drag and drop
* Browse the server (select Add image from the server)
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2. (Optional) Resize or move the image as needed.
A system admin or organization admin can define a maximum height and width setting for an
inserted image.

3. [Ifaninserted image is too large to be displayed, select Expand to view the image in full size.

Insert a link in rich text fields
Direct links to attachment files can be helpful to reviewers. You can link from a rich text field directly to
other sets, items, and attachments in Jama Connect, or to an external link.

1. Select the Link icon in the Rich Text toolbar.

2. In the Enter URL or Choose Item window, do one of the following:
» Enter the URL for an external link.
+ Select tabs to choose your link from recently viewed locations, the Explorer Tree, releases,
search results, or attachments, then under the Attachments tab, upload a file directly from your
desktop.

3. Click Select to place your link in the rich text field. The link doesn't work until you save changes to
your item.
4. To break a link, select the Break link icon in the toolbar.

Add and edit tables with rich text editor
You can add a table to an individual field using the tools section of the rich text editor [87]. You can also
edit the table.
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TIP

@ Although you can import tables from other documents, they can be difficult to work with
once imported, and they don’t export cleanly. Instead, create tables manually in Jama
Connect.

1. To add a table, select the Table icon in the Tools section of the rich text editor.

2. To format a table, right-click any table cell, then select the preferred action.

3. To resize a table, select its borders.

4. To add space above or below a table, hover your mouse near the space, then select the blue
button that appears on the right.

Insert rich text diagrams

Diagrams can be anything from basic shapes to more complex modeling and business process flows.
Once saved, a diagram is an editable image within the rich-text field.

Important considerations

* You can't copy and paste between the diagram editor and other applications.
* You can’t import images from other diagramming tools.

1. Select Diagram in the Rich Text toolbar to open the Graph Editor window. If you highlight an
existing diagram before selecting the button, it appears in the window for editing.

2. In the Graph Editor window, create new shapes by dragging from the menu on the left and
dropping to the canvas.
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3. To add shapes, icons, tables, or text, or to use the search function, use options in the left pane. For
more information, see MXGraph Editor.

4. To format style text and arrangement, use the options on the right.

5. When finished, select Save and Close to insert your image into the field.

Insert equations in rich text fields

With this editor, you can create complex equations and edit them in Jama Connect. These are con-
verted into images for safe storage and export, but are always editable when you have a MathType
license.

Important considerations

Your organization determines the total number of floating licenses, which are available on a first-come/

first-served basis. If a license is available, you can use it by opening the Equation Editor. To release the
license, close the Equation Editor. If a license isn’t available, try again in a few minutes or contact your

admin for help.

@ NOTE
The MathType Equations Editor requires a separate license. Contact your Jama Con-
nect administrator or sales representative to inquire about purchasing this license.

For self-hosted customers with a license, the system administrator can enable the
equations editor [489].

1. To add a new equation or formula, open the appropriate editor by clicking its icon (Math Editor or
Chemistry Editor), then select the equation or formula you need.
2. To edit an existing equation or formula in your item, use one of these methods:
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+ Highlight the equation/formula, then select the appropriate icon for the editor you need.
* Double-click on the equation/formula to open the appropriate editor.

For more information about how to create mathematical equations or chemistry formulas, see the
MathType User Guide.

Insert templates to rich text editor

Templates are pre-written text or documents that can be inserted into the rich text editor to help
uniformly format items like test cases or use cases.

0 IMPORTANT
This feature must be configured by an organization admin [608] before you can use it.

1. To open the Content Templates window, select the Templates icon in the Rich Text toolbar.

2. Select a template from the list (for example, Basic Use Case, Document Style Use Case, Basic
Test Case, and Agile Story Card) and continue editing the item.
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3. Select Replace actual contents to delete content currently in the field.
4. Click Save & done.

Run Accessibility Checker

The Accessibility Checker is a plugin that analyzes content created in the rich text editor. It lets you
know if the content meets standards for people with impaired visual, cognitive, or motor skills.

1. Select the Accessibility Checker icon from the Rich Text toolbar.

The plugin inspects output HTML code to identify common accessibility problems and offers a
"quick fix" solution.
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2. Use the arrows at the top of the pop-up window to scroll through issues found by the Accessibility
Checker.

3. For each identified issue, do one of the following:
» Enter the suggested changes and select Quick fix to apply the changes.
+ Select Ignore.

4. If the Accessibility Checker finds no issues, you see a confirmation message. Select OK to close
the message.

Importing content into Jama Connect

Content in Jama Connect is structured using an item-based approach. Items in Jama Connect can be
containers (components, sets, folders) or instances of a particular type of item, such as a requirement
or test case.

One way to populate Jama Connect with content is to import existing items (such as requirements or
test cases) from other applications.

The most common applications for importing items into Jama Connect are:

Microsoft « Determine hierarchy of imported items with Word heading styles (Heading 1, Heading 2...).
Word < Retain formatting like bulleted lists, numbered lists, and text formatting.
« Import Word tables as rich text field content or use tables to identify and import discrete items into Jama
Connect.
Excel « Map columns directly to fields.

< Determine hierarchy of imported items with cell coloring or indentation.
« Import via one-way import or round-trip import/export [117].

IBM Doors « Import objects found within Modules.
* Map object attributes directly to fields within Jama Connect.
Maintain relationships during import with active IBM DOORS data.

The Data Import Wizard guides you through the process of importing items into Jama Connect. It
recognizes file types like .doc, .docx, .xls, .xIsx, and .csv and displays options accordingly.

You might need to prepare your source file for a successful import. For example, if your Word file has

requirements in tables, you might need to ensure that all tables use consistent headings in the first row
so that the wizard can identify each table for import.
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TIP

@ Before populating Jama Connect with your data, discuss with others on your team to
make sure all needed information has a “home” (field) in Jama Connect. Involving team
members in this process can avoid rework of having to import again for data that was
not initially taken into account.

Importing items from a Word file

You can add items to Jama Connect from a Word file. You might, for example, have a Word document
with various types of requirements (customer, system, or software requirements) or with test cases.

TIP

If you are familiar with how to prepare a Word file for import, go to Import a Word
file [100].

When using a Word document to import items into Jama Connect, you can use these features to control
how things are imported.

Headings and styles — From the document’s Styles list, you can use default heading styles to
determine hierarchy (nesting) of imported items in Jama Connect.Headings are always imported as
items, not as folders. However, the hierarchy can be converted to folders once imported to Jama
Connect. Apply the Normal style to item descriptions.

Tables — Tables in a Word document can be imported directly into Jama Connect rich text fields as
tables. Word tables can also be used to create discrete items in Jama Connect. If a table has a first
row header and one row per requirement, the content is read as one item per row. If a table has two
columns where the first column contains headings (for example, “Requirement Text”) and the second
column contains data (for example, “The system shall...”), the content is read as individual items for
each table that conforms to a repeated structure.

Import/lgnore Sections — Use designated keywords in your Word document to define which sec-
tions to import and which to ignore. This is useful for large documents when not all content is relevant
to import.

Field mapping — Define how Word elements map to Jama Connect item fields. This process varies
slightly, depending on whether you use headers or tables to identify items.
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@ NOTE
Many Word styles are imported, but not all are converted exactly. The import wizard
can’t import a table of contents. Images are included as part of the import. OLE
components, such as embedded Visio diagrams, are imported as PNG images.

Setting hierarchy with heading styles

When importing items from a Word document, you must prepare the document so that the import is
successful. An important step in this preparation is to set the hierarchy, how items are nested in Jama
Connect.

To set the hierarchy, use Word heading styles. Each heading represents a new item in Jama Connect.
The heading text is imported into the item’s Name field and any paragraph text, tables, or images are
imported into the Description field.

S NOTE
In your Word document, all headings are imported as items, never as folders. How-
ever, the item hierarchy can be converted to folders after import using the Convert

function.

The hierarchy of imported items is determined by which heading level you apply to the item name. A
nested heading in Word is treated as a child item in Jama Connect, with a maximum of seven levels.

For example, in this diagram, Item A uses Heading 1 and is imported as a parent item. Item B uses
Heading 2 and is imported as a child of Iltem A, and Item C uses Heading 3 and is imported as a child
of ltem B.

When you open the imported item in Single Item View, the Name field is populated with the text of the
Word heading, and the Description field is populated with the text of the Normal style paragraph.
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S NOTE

For the Description and rich text fields, formatting for bullets, bold, italic, and underlin-
ing are retained when imported. Numbered lists are imported as bullets. When a list
contains multiple levels, Jama Connect continues to use bullets. However, each set is
indented to indicate the original level.

How tables are imported from Word
When importing items from a Word document, the Data Import Wizard lets you choose how tables are
imported.

Each table is an individual item

Select this option when your Word document includes a separate table for each item you want to
import. The wizard prompts you to complete field mappings with this option.

In this example, the document heading (System Requirements) is imported to Jama Connect as a
parent item and each table is imported as a separate child item.

The table for each item must have at least two columns: column 1 is the field name (for example,
Name) and column 2 is the field value (for example, Three digit display).
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TIP

@ If your Word file includes multiple tables, make sure that all tables use the same
wording for the field name in the header (first) row. For example, if one table uses ID
for the field name, all tables must use ID, as in this example.

Each table row is an individual item

Select this option when your Word document includes tables where the first row is the heading row and
each subsequent row constitutes a discrete item. The wizard prompts you to complete field mappings
with this option.

The cells with field names must be the top row of the table. Each subsequent row represents a separate
item, and a row’s cells define the field values. If you have multiple tables in your document, each table
must have the same heading values to be recognized by the import tool.

This is an example document after importing into the set called System Requirements.
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Descriptions might include tables

Select this default option when the document you're importing has no tables or the content of a table
applies only to the item description.

You don't need to map fields when you select this option.

Here is an example document and the results after you import.

Prepare your Word file for import

Before you import a Word file, make sure it is formatted for a successful import. For example, confirm
that you use default headings and that your tables are formatted properly.

You might also need to define the document scope by tagging sections of content to include and
exclude. Requirement documents are often large and might contain sections or items that need to be
imported to different sets, different folders, or not at all.

1.
2.
3.

Open the Word file you intend to import to Jama Connect.

Set hierarchy with heading styles [96] (how items are nested in Jama Connect).

If your file includes tables, make sure they are formatted according to how tables are imported from
Word [97].

(Optional) If you don’t want to import the entire file, add keywords to sections you want to import
and ignore.

Use start/stop keywords that are simple, one-word, and all caps with no formatting. Keywords must
not be actual words that might appear in the content. Commonly used start/stop keywords are
IMPORTSECTION and IGNORESECTION.

a. Insert the keyword IMPORTSECTION before and after each section you want to import.

b. Insert the keyword IGNORESECTION before and after each section you want to exclude from
the import.
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5. Save and close the Word file.

Import a Word file

Once you have exported data from DOORS, you can import it to Jama Connect using the Data Import
Wizard in Jama Connect.

1.  Open the Data Import Wizard: In the Explorer Tree, right-click an item where you want to import
new items, then select Import. Your file will be imported below the selected item.
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The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.

a. Click Browse and select the Word file you want to import.
If the file type isn’t recognized, the import doesn't continue.

b. (Optional) If you previously saved your field mappings for importing a Word file, click the
Select a saved field mapping field and choose that file.
This is useful if you are importing multiple documents with the same field mapping.

c. (Optional) In the Encoding section, select the character set encoding to use during the import.
For most imports you can use the default, UTF-8, which is used by the Jama Connect data-
base.

3. Complete the Choose Field Mappings for Import page, then click Next.
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a. Document Scope Options — If you tagged your Word file to import and ignore some sec-
tions, select the checkboxes and enter the name of each keyword (for example, INCLUDE-
SECTION and IMPORTSECTION).

b. Field Mapping
* Max length of Name field — Select this and enter a maximum number of characters for the

name. Default is 255 but this option lets you further limit the name length.

» Default Value — Use this option (when available) if you want a field value to be used
by default. Then, all items created during import include the default value you enter. For
example, you can set the status to Draft for all imported items.

4. Complete the How to Handle Tables page, then click Next.
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a. Choose a Table Import Style — Select this option if your item description includes tables:

» Descriptions may include tables — Select this option if your file uses headings for hierar-
chy, but the content includes some tables.

» Each table is an individual item — Select this option if your file uses tables and includes a
separate table for each item. Must complete Table Field Mapping.

» Each table row is an individual item — Select this option if your file uses tables and the
tables use a separate row for each item. Must complete Table Field Mapping.

b. Table Field Mapping — Complete this section if importing table content as individual items
(option 2 or 3 above). From your Word tables, copy the heading values into the Identifier field
for each Jama Field mapping. For some Jama Fields, you can set a default value (for example,
setting status to Draft), which populates the field if the mapping has no value.

5. Verify First Item in Import File — Review the mapping of the first item found in the document
you're importing. If the mapping is correct, select Submit to import the target document.
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a. (Optional) Select Import another file to restart the wizard.
b. (Optional) To reuse the field mapping settings, select Save this as new document mapping.

NOTE

Field mappings are project-specific and can be used by any user in the
project where the mappings are saved.

c. Click Submit.
6. Click Close.

A message appears in the Data Import Wizard to confirm that the import was successful.

Importing from Excel

You can use the Excel Import Wizard to import data into Jama Connect from a Microsoft Excel docu-
ment. This process is called a one-way Excel import. You can also export existing data from Jama
Connect to an Excel template, then update the data in Excel as needed, and import it back into Jama
Connect. This called an Excel round-trip.

To ensure a successful import, your Excel worksheet must be created and formatted for the specific
type of data (items, test cases, item relationships) that you want to import.

For items and test cases, your worksheet indicates item hierarchy — how items are nested — as
folders, parent items, or child items. You can use color or indentation to define hierarchy.

When importing items, your worksheet can include only one item type. If you need to import more than
one item type, you must create a separate worksheet for each item type and import each worksheet
separately.

104



Jama Connect User Guide

TIP

@ If you are familiar with how to prepare an Excel file for import, go to the tasks Import
items [113], Export/import via Jama Connect-to-Excel round trip [117], and Import
relationships [120].

Recognized file types

Jama Connect imports data from Excel files with these extensions: .xIsx, .xls, and .csv.

NOTE

An import from a file with a .csv extension doesn't create folders or hierarchy. On-
ly .xIsx and .xIs files create folders and hierarchy.

Preparing a worksheet to import items

Before importing items from your Excel worksheet, make sure it contains all the necessary elements for
a successful import.

» One item type per worksheet. If you have more than one item type to import, create a separate
worksheet for each type.
» Header row [106] with field names

+ Valid pick list options [106]
If importing into a Jama Connect pick list field, make sure the values in your Excel worksheet exactly
match the available values in the Jama Connect field.

+ Date format
When including dates in text-formatted cells, always format dates like this:

mm/dd/yyyy hh:mm:ss Z (example: -0800, +1000, +0700) where Z is the time zone difference from
GMT.

* Roundtrip
If importing to update existing items in Jama Connect, you must use a spreadsheet generated from
Jama Connect when you select the Excel Export for Roundtrip option.

Create a baseline [239] before a round-trip export/import process, in case you need to restore old
data.

TIP

To import test cases or requirements, see Preparing a worksheet to import test ca-
ses [110] or Preparing a worksheet to import relationships [112].
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Defining header row in Excel

Including a header row in your worksheet helps to easily map columns in the worksheet to fields in
Jama Connect. Typically, the Header row is the first row in your worksheet, but it doesn’t have to be.

The header row includes fields listed horizontally, with values for those fields defined in subsequent
rows.

Your worksheet can contain only one header row. If you don't use column headers, the import automati-
cally numbers the columns sequentially from left to right, starting with 1.

We recommend that you always include Name and Description fields. You can add optional fields like
Status or Priority.

If you don’t include a Name field, the worksheet must still contain a column to be mapped to the Jama
Connect Name field. Every item and folder in Jama Connect must have a value in the Name field. If
your requirements were previously managed in an Excel worksheet without this field, you can create a
new column for Name values or designate an existing column, such as a legacy ID value, for the Name.

If other fields for the imported item type are required (based on Admin configurations), you can add
them to your worksheet or plan to set a default value during the import.

o IMPORTANT
An organization administrator can add or delete fields [598] for an item type in Jama
Connect. However, the Name field is a system field and can't be disabled.

Defining pick lists in Excel

When your worksheet includes a column for a pick list in Jama Connect, for example Priority or Status,
the values you define must match the list of available values in Jama Connect. Otherwise, the imported
item shows a blank entry for that field value.

In this example worksheet, Requirement 1 lists Fun as a Priority value, which doesn’t match the values

in Jama Connect (High, Medium, Low). After importing this item, the List Iltem View shows a blank
entry for Priority.
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TIP

@ Before importing your worksheet, identify the columns in Excel that will be mapped to
pick list fields in Jama Connect. Use the Excel Filter functionality to identify the values
found in that column in Excel. If the values found in Excel do not have an exact match
in the Jama Connect pick list, you must correct errors before importing. Otherwise, the
value will be blank.

Setting hierarchy with color in Excel
When you import items from an Excel worksheet, you can use cell color to determine hierarchy of
imported items. This method allows only one tier of hierarchy and doesn't differentiate between colors.

In your Excel worksheet, you can select the cell you want to use as a parent container and use a color
to indicate hierarchy.

When you import the document, the Data Import Wizard prompts you to select the column that will
determine hierarchy. In this example, Name column is selected.
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The resulting import shows the colored cells as parent containers.

Setting hierarchy with indentation in Excel

When you import from an Excel worksheet, you can use indentation to determine hierarchy of imported
items.

In your Excel worksheet, you decide which cells you want to be parent items, then indent the cells
below the parent items.

Using indentation for hierarchy allows multiple levels of hierarchy (for example, folders containing sub-
folders and subfolders containing items). This is an advantage over using highlighted cells for hierarchy.
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When you import the document, the Data Import Wizard prompts you to select the column that will
determine hierarchy. In this example, Description column is selected.

The resulting import shows the indented cells as child items:
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Preparing a worksheet to import test cases

To import test cases and their steps, you use the Excel import to Jama Connect option. You can use
a one-way import to import a test case from an Excel worksheet or, if you need to update existing test
cases, you can use a round-trip process.

Required header fields

To successfully import test cases and their test steps, your Excel worksheet must contain one header
row with these four columns (field names): Test Case Name, Action, Expected Results, and Notes.

A, B C ]
Test Case Hame Action Expected Results Notes

One-way import for test cases

Quickly bring legacy test cases into Jama Connect. This example worksheet imports two test cases:
"Test Wheel" and "Test Brakes." Each row with the repeated test case name is imported as a new test
step.
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Test Case Hame Action Expected Results Notes

Test Wheel Fotate rrove in circular motion with no obstruction tester notes
Test Wheel Let air out self inflatar starts tester notes
Test Wheel Foke Hole self inflator starts tester notes
Test Wheel bend spoke wheel breaks tester notes
Test Brakes apply brakes downhill slows to a stop in 201t at 80% downgrade at S0MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 30ft at 85% downgrade at S0MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 40ft at 90% downgrade at S0MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 15ft at B0% downgrade at 4A0MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 201t at 85% downgrade at 40MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 25ft at 90% downgrade at A0MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 10ft at B0% downgrade at 30MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 15ft at 85% downgrade at 30MPH tester notes
Test Brakes apply brakes downhill slows to a stop in 20ft at 90% downgrade at 30MPH tester notes

When importing the Excel file, follow the instructions for any one-way import [117]. The Data Import
Wizard prompts you to select the worksheet, plus the number of the header row.

NOTE

To import items or requirements, see Preparing a worksheet to import items [105] or
Preparing a worksheet to import relationships [112].

Round-trip for test cases

When you need to update a test case already in Jama Connect, you can use a round-trip [117] process.
First you export a test case from Jama Connect, which generates an Excel file populated with the
required fields. Next you update any fields that need changes, then re-import the data back to Jama
Connect.

Because of the relationship between test cases and test runs, you can't update the test case sta-
tus [320] in a round-trip import/export. The test case status field is calculated from all test runs derived
from that test case.Test case status.

Add and delete a test step in Excel
You might need to add a new step to your test case or delete an existing step.

1. Add a test step — Copy an existing row (step), then right-click on the row where you want to insert
the copy and select Insert Copied Cells. Edit the fields in the copied row to reflect the information
needed for the new step.
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i8 L Ml I F o] R I
Tests included whe Medium Mot Sched 05/17 Sam Test 0517720 1 Mot Sched
open a web browse Unassigne Mot Sched Sarn Test 05/17/2C 1 Mat Sched
open a web browse Unassigne Mot Sched Sam Test 05/17/2C 2 Mat Sched
open a web browse Unassigne Not Sched Sam Test 05117720 3 Mot Sched
open a web browse Unassigne Mot Sched Sarn Test 05/17/2C 4 Mat Sched
open @ web browse __ Unassigne Mot Sched SamTest 051720 EBMNetSched
wopen a web browse Unassigne Mot Sched Sarn Test 051720 7 Mot Sched
open aweh browse Unassigne Not Sched Sam Test 054720 7 Mot Sched
open a web browse Unassigne Mot Sched Sam Test 05/17/2C & Mat Sched
open a web browse Unassigne Not Sched Sam Test 05117720 9 Mot Sched
open a web browse Unassigne Mot Sched Sarn Test 05/17/2C 10 Mot Sched
open a web browse Unassigne Mot Sched Sam Test 05417720 11 Mot Sched

IMPORTANT

Always use Insert Copied Cells instead of Paste. The Paste command replaces
the row instead of adding a new row, and subsequent steps are removed on
import.

2. Remove a step — Right-click on the row (step) you want to remove, then select Delete.
Re-numbering of steps takes effect on import.
3. Save thefile.

Preparing a worksheet to import relationships
Relationships are imported to Jama Connect from an CSV file, using a relationship import plugin [551].
You can’t import relationships with the Excel Import Wizard.

A properly formatted CSV file, when opened in Excel, consists of two columns:

* Column A — Parent or upstream item references
* Column B — Child or downstream item references

As needed, you can import multiple relationships to a single item or many relationships to many items.
To accomplish this, you create duplicate cell combinations for those items. In this example, CP-REQ-10
has three relationships, each in its own row.

NOTE

To import items or test cases, see Preparing a worksheet to import items [105] or
Preparing a worksheet to import test cases [110].
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Import items or test cases from an Excel worksheet
Importing items or test cases from Excel to Jama Connect is called a one-way import. The process is
handled by the Data Import Wizard, which guides you through the steps. The wizard recognizes .xls

and .xIsx file types.

o IMPORTANT
You can’t create new items with a one-way import. If you need to add new items, use
an Excel round trip [117].

1. Open the Data Import Wizard: In the Explorer Tree, right-click the set or folder where you want to
import new items, then select Import. Your file will be imported below the selected item.

The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.
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a. Click Browse and select the Excel file you want to import. If the file type isn’t recognized, the
import doesn't continue.
b. (Optional) Encoding — Select UTFS8.
3. Complete the Choose Field Mappings for Import page, then click Next.
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Excel Options — If your file has more than one worksheet, select the one you want to import, then
enter the number for the header row. If a header row doesn't exist, select row 0, which populates
the Mapping section with the Excel default column names.

* Round trip/Update Options — For one-way import, leave these options unselected.

» Field Mapping — Select the appropriate column from the worksheet for each field in Jama
Connect where you want to import data. Select a mapping for Name and any required fields, as
determined by the Admin configuration for the item type. Fields not required for the import don’t
need to be mapped.

On the Additional options page, indicate whether your worksheet uses cell color or indentation for

hierarchy, then click Next.
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5. If the fields were mapped successfully, you see a preview of your import. Click Submit to import all
items.
The Final Import Summary page confirms the total number of items imported.
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6. (Optional) Import another worksheet or save the current mappings to use for future uploads.

NOTE

Field mappings are project-specific and can be used by any user in the project
where the mappings are saved.

7. Click Close.

Export/import via Jama Connect-to-Excel round-trip

With a round trip, you can batch edit multiple items or test cases in Jama Connect, as well as create
new items or test steps to be imported.

The round-trip process involves these steps:

1. Export the items you want to edit from Jama Connect to an Excel worksheet.
2. Make your changes in the worksheet (add items or steps, delete steps, change field values).
3. Import the edited worksheet back into Jama Connect.

Round trip requires you to re-import Excel documents created by Jama Connect using an Excel
template. When the system identifies items that originated in Jama Connect, it updates your items
according to the conflict rule set at the time of the import.

Excel has a cell character limitation and, during the export, truncates rich text fields that exceed the
limit. A truncated rich text field can impact the data that’s imported to Jama Connect using round-trip.

1. Export a folder, filter, or set of items to Excel:
a. InList View, select the columns that you want to export to Excel.
Only the columns shown in List View are exported, so be sure to display all columns you need
to include.
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b. Select Export > View all export options.

In the window that opens, select Excel Export for Roundtrip from the menu on the left, then
select Run.

C.

@ NOTE
Excel limits the number of characters that a cell can contain. If a Jama Connect
field (rich text field) exceeds the limit, Excel truncates the text when it's exported.
As a result, the Jama Connect is updated with the truncated data if imported via

round-trip.
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Open the newly downloaded Excel report and save it to a place where it can be edited.

Columns A—E are hidden. They contain fields that Jama Connect requires to update existing items.
Edit the exported Excel document with required changes, then save it.
a. Edit the fields you need to update. In this example, the names of three test cases are changed.

If a field is based on a pick list in Jama Connect (for example, Priority), the pick list values are

exported as well. This ensures that valid data is entered before re-importing to Jama Connect.
b. As needed, create new items or test steps that you want added to Jama Connect. After import,

added items appear at the bottom of the set or folder where you import to.

* You can add only one item type for the selected set or folder.

» Leave the ID and Global ID fields blank. These values are assigned to new items during

import
» Leave Assigned field blank.
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4.

Import the edited Excel file. The process is the same as for the one-way import except for the
Choose Field Mappings for Import page:

Excel Options — If your file has more than one worksheet, select the one you want to import.
Select the number of the row in your worksheet that contains the headers. By default, the
Excel for Roundtrip export uses row 2 as the header row.

If a header row doesn't exist, select row 0, which populates the Mapping section with the Excel
default column names.

Round trip/Update Options — Select the checkbox for Update Items to update Jama Con-
nect items that were modified in the round-trip Excel worksheet.

Select an option for Conflict Resolution: Excel wins or Do Not Update. Conflicts might
occur when a field in Jama Connect has changed values since the round-trip export was
generated.

Field Mapping — Select the appropriate column from the worksheet for each field in Jama
Connect where you want to import data. Select a mapping for Name and any required fields,
as determined by the Admin configuration for the item type. Fields not required for the import
don’t need to be mapped.

Import relationships from Excel
Relationships are imported to Jama Connect from a CSV file. The file consists of two columns.

Important considerations
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+ A relationship import plugin must be configured [551] and enabled.

A CSV file must include correct parent and child field values and must have the .csv extension.

» Import relationships in small batches no larger than 250 at a time.

» Check that your parameters are written correctly and reference the right API ID or field. For more
information, see Configure import relationships plugin [551].

To import relationships:

1. From the Jama Connect header, select Project > Import > Custom Import.
2. In the window that opens, configure these settings:
+ Select a destination — Select the location in your project for the Import Relationships Plugin.
Destination is required, but it doesn't affect the import.
+ Select custom importer — Select the Import Relationships Plugin created by your organiza-
tion admin.
+ Field delimiter — Select Comma.
» Optional Encoding — Select UTFS8.
+ Select file to import — Click Choose File, then navigate to the CSV file with the required
relationships.

3. Select your Excel file and click Import.

Give Jama Connect time to process the relationships. If you're importing more than 100 relationships,
the update isn't instantaneous.

When the import is complete, you see a notification at the top of your screen: "Success: X items
imported."

Importing from IBM DOORS

You can import active IBM DOORS data, such as requirements, test cases, and project information to
Jama Connect. You can also maintain relationships during the import process.

Here are the steps for a successful import:

1.  Ensure you meet Jama Connect [122] and DOORS [122] prerequisites.
2. Export HTML zip file from DOORS [124].
3. Import to Jama Connect [125].
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DOORS export prerequisites

Before exporting data from IBM DOORS, verify these prerequisites for a successful export.
Mapping

» The Object Identifier column in IBM DOORS is typically mapped to the Name field in Jama Connect.
+ If you're importing hierarchy, the DOORS standard Object Heading and Text (or Main) column must
be mapped to the Description field in Jama Connect. This is the only column that exports hierarchy

information to HTML for Jama Connect imports.

Links
If you're importing links (trace relationships) across multiple modules in DOORS:

* The modules must be open when you export. A DOORS export includes only the modules that are
shown in your view, so make sure no filters are selected because they limit the number of items
exported.

» Each module must have a unique prefix so that the Object Identifier is unique. DOORS doesn't
enforce this requirement, so make sure you confirm that each module has a unique prefix before you
export.

» The Object Identifier column must be visible in the DOORS module view (not Object Number or
Absolute Number). The Object Identifier is a combination of the Module Prefix and the Absolute
Number (as in SYS32). If the Object Identifier has only integer values, the Module Prefix is most
likely empty.

Jama Connect prerequisites for DOORS import
Before importing data from DOORS to Jama Connect, verify these prerequisites for a successful import.

Links
Relationships between items aren't created until both items are imported.

» To import relationships (or trace links), you must create a custom field in Jama Connect [598] for each
item type you're importing.

» Each custom field must contain a unique identifier, which aids in importing relationships from DOORS
to Jama Connect.

Create custom fields in Jama Connect

To import relationships (or trace links), you must first create a new custom field in Jama Connect for
each item type you're importing. Each field must contain a unique identifier.

TIP

@ When importing many custom fields from DOORS, create a common custom item type
that contains all the custom fields. Use this item type only for the initial import, then
later convert sets to a standardized set of item types. That way, every imported item
includes legacy DOORS information in its version history. To view this information,
compare versions [231].

1. In Jama Connect, select Admin > Organization > Item types.
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2. Find the item type you're using for the DOORS import, then select Fields.

3. Inthe panel that opens, select Add Field.

4. In the Add Field window that opens, complete these options, then click Save.

123



Jama Connect User Guide

+ Select a Field Type — Select Custom Fields, then select Text Field from the drop-down menu.

* Field label — Enter a name for the field (for example, "DOORS ID").

* Unique Field Name — Enter "SYS_DOORS_ID." This is case-sensitive and must exactly match
the above image.

» Select Read Only.

This item type can now accept relationships (trace links) imported from DOORS.

o IMPORTANT
The SYS_DOOR_ID field must be created for all the item types you are relating.

Export data from DOORS
Before you can import data from IBM DOORS to Jama Connect, you must export it to an HTML .zip file.
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NGO RON =

On your local system, create the export target folder in the local drive/directory.

Open a DOORS module that you want to export and make sure there are no active filters.
Select File > Export > HTML.
Select Layout > Table.

Select Export > Current.
Select Links to import links as relationships and create the necessary field in Jama Connect [122].
Select a folder or location where you want to store your DOORS files.
Browse to the target folder and select Export.

File Edit View

Insert Link Analysis

Table Tools

Discussions

User

Change Management Help

H&EE (meo | FEF@FtEd | e felag

ViewlStandard view v| All levels - Hh = |:_§-| f—‘ ' '}l

=- BysinessRequirernents'l 0 | BusinessRequirements1 H
+- 1 Business Reguirements - = =

BR-1 ' 1 Business Requirements

BR-2 || 1.1 Problem Statement

BR-3 « The problem of Dental software being clunky and focused heavily on administrative tasks.
This results in dentists
programs that expect t ) Export HTML - DOORS [E=N ECR =5cY
mouse and keyboard.

BR-4 » The impact of which v | il
needs and must go bell  Expor: ithin
a cubicle.

BR-5 » A successful solution | IMelude: n
clinical needs. The syg Links lcons Change meter Empty attibutes dure
being performed. The nd
quick touch screen con| — - ;

\_medikiosk_BusinessRequirements 1.htm

BR-6 » Back office requiremg  ~ - a dard
scheduling and record P T i
with insurance comparn

BR-7 | 1.2 Position State) [TEpot |[ Hep | [Cose ]

BR-16 1.3 Manage patie
RR-17 The cvstem neads tn maintain a rnhost natient nrnfile This inclides contact infrrmatinn

9. Without making changes, create a .zip file to the target folder that contains the exported HTML

content.

IMPORTANT

Changing or moving the exported files before compressing them can create unreli-

able results.

m

Images in the item description are imported. Comments, attachments, and item history aren't imported.

Import DOORS files to Jama Connect

Once you have exported data from DOORS, you can import it to Jama Connect using the Data Import

Wizard in Jama Connect.

The import process creates:

» Sets or folders in an existing set. DOORS Attributes map to fields in Jama Connect.
* Relationships between items only after both items are imported.

The Data Import Wizard guides you through the import steps.

1.

Open the Data Import Wizard: In the Explorer Tree, right-click an item where you want to import
new items, then select Import. Your file will be imported below the selected item.
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The first page of the wizard opens with the Destination field pre-populated.
2. Complete the Select Import File and Destination page, then click Next.
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+ Click Browse and select the DOORS file you want to import.
If the file type isn’t recognized, the import doesn't continue.

+ (Optional) Select a saved field mapping — Select previously created import configurations that
were saved in the project for the same file type. This is helpful if you need to import multiple
documents with the same field-mapping layout.

+ Optional Encoding — Select UTF8.

3. Complete the Choose Field Mappings for Import page, then click Next.
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Data Import Wizard

L_@ Choase Field Mappings for Import s EI|1'|.‘%::'..Fi:|e3: :é:' -: mE -: 4 zip

2R L UE File Type: ZIP File
Field Mapping

L* ]
Jama Item Field Default Value Mapping
Business Owner R None .l
Name D b4
Description Rich text fields cannot have default values. BusinessRequirementsl i
Priority w7 None —
Status Cannot map workflow field
New Text Field None N
Back Next Cancel

* Field Mapping — Select a mapping for the Name field (this is usually the DOORS Object
Identifier attribute). You can assign a default value for other Jama Connect fields and select
which DOORS attributes you want to map to each.

o IMPORTANT

The Description field is usually mapped to the Main attribute in DOORS. Bullets
and other symbols are exported from DOORS as images, not as formatting. If
you're mapping a field that contains images or formatting, the corresponding im-
port field must be configured as a rich text field, otherwise these images don't
appear.

You can't select a mapping for Step action, Step expected results or Step notes.

Select the options you want for hierarchy and relationships, then click Next.
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Data Import Wizard

=

Preserve Hierarchy

[7] Use item-subitem structure (instead of folder-item structure) when creating hierarchy of imported items

Relationships

=
[7] Create relationships fram DOORS links: -
Relationship Type: »
DOORS Id column; v
"From’ (QUT) link direction in DOORS v
maps to:
Back Next Cancel

* Preserve hierarchy — Select to keep the DOORS hierarchy when importing. If left unselected,
the resulting items are at the same level.

» Use item/sub-item structure — Select if you want all parent items to keep the item type of their
children. If left unselected, all parent items become folders.

o IMPORTANT

All items converted to folders lose their relationships (links). If you're importing
relationships, use the item or child-item structure.

+ Create relationships from DOORS links — Select to migrate Trace Links from DOORS to
relationships in Jama Connect.

If you see the following error, check that you successfully completed all Jama Connect prerequi-
sites [122] before import.

Relationships

-
It appears the Scope Definition you are attempting to import into is missing a necessary field for the DOORS id. This field is required. See
your administrator or check the help documentation.

Relationship Type: b

DOORS Id column: W

From® (OUT) link direction in DOORS b
maps to:

* Relationship type — Select the type of relationship you want to create. If left unselected, this
value is set to your organization's default value.

+ DOORS ID column — Select the name of the column from your export that contains the
DOORS Obiject Identifier, which is used as the identifier when creating relationships. It must
match between item types.
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* 'From' (OUT) link direction in DOORS maps to — Set OUT=upstream or OUT=downstream.
DOORS and Jama Connect use different terminology for relationship direction. The selection
depends on how relationships are used in DOORS. Check the HTML file or run a test import to
verify that this works as expected.

o IMPORTANT

Because relationships are created based on the DOORS Object Identifier, import-
ing items twice creates multiple relationships.

If the fields were mapped successfully, you see a preview of your import. Verify that it looks correct,
then click Submit to import all items.

Data Import Wizard

| Verify First ltem in Import File

Matt Mickle
BR-1

1 Business Requirements
Unassigned

Draft

BR-1

Back Submit Cancel

The Final Import Summary page confirms the total number of items imported.
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Data Import Wizard 88

— . Destination: DOORS: MediKiosk exportimport ...

I |

= Final Import Summary Import File: Doorsimpart.zip
Step 4 of 4 File Type: ZIP File

Import successfull

“fou have imported 22 tems.
“fou have created 1 relationships.

Import another file

Save Mapping Options

Save or Update this document mapping

Save This As New Document Mapping

Close

* (Optional) Import another DOORS Module.
+ (Optional) If you plan on importing the same item type (objects) with the same mappings multiple
times, you can save your mapping changes as a new document mapping here.
6. Click Close.
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The content you want to find might be anywhere in your project. For example, you might want to look at
the requirements or test plans.

Jama Connect gives you many ways to directly access the items you need:

» Search [132] — Look through an index of your item type fields, as well as text within a Word
document, a PDF document, or text attachments, to bring up a list of items.
Use the search bar in the header to help you find the topic you're looking for.

 Filter [134] — Limit the results of a search to a group of items by content such as author, keyword,
date, or coverage. You can also filter stream comments, review comments, reviews, review items,
Trace View items, and project items.

Select Filter items at the top of the center panel in List View or Reading View to open the filter panel
and filter out the items you want to see.

» Advanced filters [135] — Save a set of rules or conditions for later use and share that filter with other
users.

» Quick find [140] — If you don't remember where to find something in the application, use the quick
find [140] topic in this guide.

You can also find moved items [146] or find an item in the Explorer Tree [147].

Full text search

Jama Connect uses an index of the database fields for its search function. It also searches in text, Word
files, and PDF files to find the items you're looking for.

You can search item IDs, descriptions, attachments, and field values. Search for a specific unique item
ID (not global ID) and it opens.

Important considerations

» The application doesn't support searches for null values. This includes checkboxes that haven't been
checked.

» Files over 25 MB aren't indexed so their content isn't searchable.
» The following file types are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF.
» The following file types are not indexable: XLSX, XLS, XML, HTML, HTM.

Ways you can search

You can search for a word or a phrase for a simple search, and you can use advanced methods like
wildcards, Boolean operators, and more to find the items you need.

+ Single term — Use a single word to find items with that exact term or items that contain that term.
For example, Test returns items with the terms test, pretest, tests, tested, and tester.

» Phrase — Use a group of words surrounded by double quotes. For example, “primary test"
returns only items that contain the words primary test.

+ Single character wildcard — Use a single character wildcard (?) with a single term (not a phrase).
For example, te?t returns items that contain test, tent, and text.

» Multi-character wildcard — Use a multi-character wildcard (*) with a single term (not a phrase). For
example, syn*ize returns items containing the terms synchronize and synthesize.
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NOTE

You can't begin a search with a wildcard (such as ?!*) or you will receive a syntax
error.

Boolean operators — Boolean operators in ALL CAPS to combine phrases or terms.

OR (||) is the default Boolean operator when you enter two terms or phrases. For example,
primary test or sample returns items that contain either primary test OR sample.

AND returns items where both terms and phrases exist. For example, primary test AND
sampl e returns documents that contain both primary test and sample.

+ returns items that must contain the term or phrase immediately following the +. For example,
+primary test returns items that must contain primary and might contain test.

NOT (-) excludes items that contain the word or phrase after NOT. The application doesn't allow
null searches, so you must enter something before the word NOT to get any results. For example,
primary test NOT sample returns items that contain primary test but not sample.

Parentheses — Use parentheses to group clauses and form sub queries. For example, (tests OR
samples) AND maps return results that contain tests, maps, samples and maps or all three
terms.

Prefix — Use the prefix tag: to indicate the tag field in your query. For example, tag: require-
ment management AND tag:security.

Field name — Use field names followed by a colon to search for information in specific fields. For
field names that contain spaces use an underscore. For example, user_status:new returns items
with a User status field that contains new.

Search for content

Need to search across all projects or within a current project? Enter a query in the search field to find
what you need.

For more complex searches, use advanced filters [135].

You must have read permissions for projects or sets to be included in your search results.

1.

From the drop-down menu in the upper right header, select where you want to search:
* Project — Within the current project.

» All — Across all projects in your organization.

Enter your query in the search field and press Enter.

(Optional) Select Filter items to refine your search. For details, see Filter items for targeted re-
sults [134].
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The results appear in List View.

Filter items for targeted results
Using a filter is an easy way to refine your search results. To limit and focus your text search, you can
filter content by author, date, or coverage.

Filters can't be saved. If you want to reuse a specific filter, use the advanced filters.

1. In Projects, select Filter items to open the Filter by panel.

2. Define how you want to filter your results. Filters are cumulative and the options you select are
displayed at the top of the screen.
» Keyword — Enter a term in the Keyword field.
+ Item Type — Templates for sets used within each project. For example, you can filter by System

Requirement, Set, Folder, or more.

» Author — The person who created or last modified the item.
» Direct Coverage — Parameters for upstream, downstream, missing, and suspect relationships.
» Last Modified — Time stamp of when the item was last modified.
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The search results appear in List View.

3. When you're done, select Hide Filters to close the panel.

Any applied filters are preserved and visible at the top of the page.

Advanced filters

With advanced filters you can save a set of rules or conditions for later use and share that filter with
other users.

Add or edit advanced filters [136], bookmark them, or use them to filter the Explorer Tree [139] or send
items for review [153].

Rules and conditions

Each rule is matched to a specific item type or all item types having specified conditions.

A condition describes specific attributes of an item (fields of an item type, tags, relationships, location,
keyword, or if the item has children).

Each rule can contain any number of these conditions.

The rule can be set to return items that follow any one of the conditions, all of the conditions, or none
of the conditions (which acts as the inverse of "any").

Finding advanced filters

In the left panel next to the Explorer Tree tab, select Filters.

Tip: Hover of the filter name to see the author's name.
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A CAUTION
You can delete a filter when you no longer need it. Before you do, make sure the filter
isn’'t shared. If you delete a shared filter, even if you're not the creator, it's deleted for
everyone.

Add or edit advanced filters

Running a filter against all your Jama Connect projects can return large data sets and degrade perform-
ance. For best results and quality performance, make filters more specific to return only the results you
need.

S NOTE
Only organization administrators can edit filters that they didn't create. Depending on
your permission, you might not be able to edit filters that were created by other users.
To view their details, right-click on the filter name under the Filters tab and select View
criteria.

1. Inthe Explorer Tree, select the Filters tab.
2. Select Add filter to open the New filter window.
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Name the filter and indicate the project scope by selecting one of these options:

* This project only — Use this filter to query data from the project the user is viewing at the time.
The filter appears only when using this project.

» Current project — Use this filter to query data from the project the user is viewing at the time.
But the filter is also available for use in other projects.

+ All projects — The filter pulls data from every project in the organization that the user has
permissions to view. Using this option, you can see items from other projects that match the filter
criteria.

(Optional) Select Make public to make the filter public. This filter is available to anyone with

access to the project.

Define your filter. Condition options change depending on which item type is selected.

+ Select Add rule to create a new rule. A filter can contain any number of rules.

* Add a condition (+)

* Remove a condition (=)

+ Select the blue Add condition group button to add a condition group. Condition options change
depending on which item type is selected.

« If your relationship condition requires a sub-filter, select this filter... to open the Embedded
Filter window.
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Example: A filter to identify all change requests with downstream relationships to requirements.
Create a filter to identify change requests with downstream relationships and another sub-filter to
limit downstream items to the relationship item type.

+ To limit the filter to items updated within a certain amount of time, use the drop-down menu next
to Limit to items updated within.

+ To define the how the results are sorted on output, use the drop-down menus next to Sort order

for results by.
6. Preview your results by selecting Preview in the bottom left corner of the New filter window.
Results appear in the same window.

7. Choose from one of these options:
+ Select Save.
» Select Back to Filter to make changes to the filter.
» Select View in List to see the filtered items in List View. Your filter isn't saved.

Duplicate advanced filters
Advanced filters allow you to use complex criteria. To save time, copy a filter so you can reuse it in
future searches.

1. Under the Filters tab of the Explorer Tree, right-click on the filter you want to copy and select
Duplicate.
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2. Enter a name and edit the filter settings [136].

3. Select Save.

Filter the Explorer Tree

The Explorer Tree can contain a lot of items, making it time consuming to find what you need. Apply an
existing filter to quickly locate multiple items.

1. To view saved filters, select the Filters tab in the Explorer Tree.
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2. Right-click on the filter you want to use and select Apply filter to Explorer.

The filter results are shown in the Explorer Tree. ltems in the hierarchy that don't apply are shown
in lighter text.

Export from advanced filters
Select the data you want to export using advanced filters and export directly to Word, Excel, or PDF.

If you view your filter results in Reading View, the hierarchy container items are visible. These items
offer visual context and are included in your export. However, they can't be selected or changed from
this view.

1. Create the advanced filter [135] that gathers the items you want to export.
2. Select Export and choose the output type.

Quick find

Do you know what you're looking for, but just forgot where it is in the application? Use this handy table
to quickly find what you need.

Note: Small screens display icons as image-only, without the text.
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To find...
Baselines

Dashboard

Homepage

Impact Analysis

Where
Explorer Tree

« Upper left corner of the
screen

* Explorer Tree

Top header from anywhere in
Jama Connect

Single Item View

Select...

Baselines tab

Project name

House icon

Single Item View > Impact analysis
% Impact analysis

Image-only version:

Strengthen cons

S ersion 2
Impact analysis

~u
L=

£
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To find...

Item versions

Relationships

Relationship

Status Indicator

Relationship

rules

Where Select...
Single Item View (side toolbar) Versions widget
Single Item View (side toolbar) Relationships widget
+ Side toolbar Relationships widget

¢ Inacolumnin List View
(when configured)

* Top number -- Represents the number of upstream items related
to this item.

* Bottom number -- Represents the number of downstream items.

If an item isn't in compliance with the relationship rules, it appears in
red. Otherwise, it's gray.

Single Item View Relationships widget > Relate items in the bottom panel > Show
relationship diagram at the top of the right panel

For more information, see Relationship rules quick find [144].

142




Jama Connect User Guide

To find...
Releases

Review status

Risk analyses

Suspect links

Test cases

Test plans

Trace View

Where
Top of the left panel

Header

Header

« List View

Single Item View
» Advanced filters
Explorer Tree

« Explorer Tree
Projects > List View
* Projects > Trace View

Explorer Tree

Projects

Select...

Releases

Reviews

« Grid -- Displays review status at the bottom of each card.

« Table -- Displays review status in Review status column.

Risk

You can find suspect links from several places in Jama Connect. For
more information about finding suspect links, see Suspect links quick
find [145].

You can find test cases from several places in Jama Connect. For
more information about finding test cases, see Test cases quick
find [1486].

Test Plans tab > <plan>

Trace View button

%" Trace view
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To find... Where Select...

Traceability Ma- Projects > Project > Traceability Trace Matrix
trix

Relationship rules quick find
Relationship rules are set up by an organization administrator [614], but can be viewed by all users in
two places.

* In Single Item View, select the Relationships widget, select Relate items in the bottom panel, then
select Show relationship diagram at the top of the right panel. The relationship diagram for this
project appears in a pop-up window.

 Display the diagram for a project on the dashboard [355].
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Suspect links quick find

You can find suspect links [270] using one of these methods.

» To view (or clear [270]) all suspect links for a project, select Project > Suspect links.

» To view all suspect links for an item, open an item in Single ltem View [55] and select Relationships
in the side toolbar to open the bottom panel.

In the Suspect column, you can see if an item is suspect because of upstream changes. You can
also clear suspect links [270].

* In List View or Single Item View, view suspect links in the Relationship Status Indicator [269].
» Find suspect links using advanced filters [135].
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Test cases quick find
You can find test cases using one of these methods.

» Look for test cases in the Explorer Tree [47].

* Projects > Trace View [52] where they appear in relationship to items they test, along with associ-
ated test runs.

* Projects > List View [51] where you can filter by item type name to find test cases.

» Test Plans where you can see them in the test cases section of the plan by selecting Test Cases.

Find moved items

If you don't know where to look for items that were moved, you can use the Activity Stream to find and
access recently moved items. This is also an easy way to move all items back to the previous location
(or to another location) after a move is made.

1. Open the Activity stream and use the search box to search for moved items.
2. Hover your mouse over the location to see a file path.
3. Select View moved items to see the files that were moved.
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4. (Optional) In List View, you can move items.

Find an item in the Explorer Tree

If you've navigated to an item from search results, filter results, or tags, you can quickly locate an item
in the Explorer Tree.

NOTE

When viewing the Explorer Tree, some items aren't visible if a component, set, or
folder contains over 250 items.

» From the Single Item View toolbar, use interactive links (formerly called "Find me") to find a location
in your project hierarchy.

» From the Explorer Tree, view the highlighted item you want to find.
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Reviews in Jama Connect

Reviews play a key role in successful product development. They help ensure that a new project meets
stakeholder, market, and compliance requirements.

Jama Connect uses an iterative and collaborative approach for reviewing requirements and other
artifacts in real-time, which improves stakeholder alignment, reduces review cycles, and eases the path
to compliance.

Your organization administrator configures review center settings [622] to meet the needs of your
organization.

Review features include a wizard that streamlines review setup and electronic signatures for coordina-
ted approval and signoff.

Roles for review workflow
Your role determines which tasks you perform in a review.

Moderator — Create, manage, finalize, and close a review. Only moderators can comment on a closed
review.

Approver — Provide feedback and approve or reject the item during the review.
Reviewer — Provide feedback.

Review Administrator — See and manage all reviews.

Role Responsibilities and actions

Moderator * Initiate a review.

» Add and manage review participants.
* Modify a review.

» Edit an item to incorporate feedback.
» Close and reopen a review.

» Publish a revised review.

* Finalize a review.

» Archive a review.

» Delete a review.

* Recover an archived review.

+ Transition items based on item workflow.
* Remove items.

Reviewer* + Contribute feedback.
» Finish a review as a reviewer.

Approver + Contribute feedback.

» Approve or reject review items.

» Delegate approval.

* Finish the review as an approver.

» Add electronic signatures to a review.

Review administrator * View a list of all reviews.

+ Perform administration tasks for all reviews, whether or not they were invited to participate.
» Archive and unarchive a review.

» Recover a deleted review.

» Configure review comments.

All » Find and view review items.

» Compare versions.

Monitor progress.

» Vote on items.

Subscribe to items on the page.

* Moderators and approvers can also perform all reviewer actions.
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Review lifecycle — Who does what during a review

Action

Moderator

Reviewer

Approver

Review Ad-
min

Initiate a review [153]

Invite participants [158]

Add and manage review participants [160]

Modify a review [161]

X | X | X | X

Delegate approval [175]

Participate as a reviewer [170]

Find and view review items [180]

Contribute feedback [170]

X | X | X | X

Finish the review as a reviewer [172]

X | X | X | X

X | X | X | X

Finish the review as an approver [173]

x

Electronically sign the review [174]

Incorporate review feedback [162]

Close a review [163]

Mark a review as completed and update workflow status [169]

Compare versions [187]

Monitor progress [189]

Vote on items [194]

Subscribe to items on the page [193]

XX | X | X| X | X|X

X | X | X | X

X | X | X | X

View list of all reviews [151]

Perform administration tasks for all reviews [177]

Archive a review [165]

x

Recover an archived review [165]

Recover a deleted review [177]

Configure review comments [178]

XX X[ XX X|X| X|X|X

Remove or recover items in a review [166]

Workflow status for reviews

The review status field shows the current workflow stage (status) of a review. This field changes as a
result of other operations, like closing and archiving a review.

Review status is visible in Grid View and Table View [150].

Status Definition

In progress Default status when moderator initiates a review. [153] Status can be changed to “In progress” when the
moderator restores a deleted review or marks the review status as "In progress [150]."

Closed for feed- Automatic status when the review deadline is reached or when the moderator closes a review [163].

back

Completed Status displayed when a moderator selects Close for feedback or a deadline date is met.

Review finalized Status when a moderator marks a review as finalized.

Archived Status when a moderator archives a review [165], or when a review administrator recovers a deleted
review or sets the status to "Archived."

Deleted Status when a moderator or review administrator deletes a review [165].

Review status quick find

Quickly find a review status using one of these methods.
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Location Option
Reviews (header) Select Grid to see the review status at the bottom of each card.
Table Select Table. Review status appears in the Review status column.

Review Center dashboard views
Access reviews from the top navigation by selecting Reviews in the header.

From the header, you have two options:

My reviews All reviews where you are assigned as a reviewer [170], approver [172], or moderator [152].

All reviews Reviews that haven't yet been archived.

What you see in the dashboard

What is displayed in the dashboard depends on your role, whether you’ve been invited to a review, and
the options you select.
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Review administrators — See all reviews.

Users — See only public reviews until they are invited to a review (depends on how your organization
administrator and moderator have set public review permissions).

Filter by — Filter reviews by review status or by your role in the review.

Include/Hide archived reviews — See reviews that have been archived or remove them from your
results.

The indicator for a pubic review depends on your view:

Grid View Table View

v

Moderator tasks

Certain tasks can only be performed by a moderator. Moderators can also be reviewers or approvers, in
which case they can perform all tasks for those roles as well as moderator tasks.

+ Initiate a review [153]

* Add and manage participants [160]

* Modify a review [161]

* Incorporate feedback for review items [162]

* Close an "in progress" review for feedback [163]
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* Finalize a review [164]

» Publish a revised review [164]

» Archive a review [165]

* Delete a review [165]

* Recover an archived review [165]

» Remove or recover items in a review [166]

» Transition a Peer review to an Approval review [168]
* Close and finalize Approval review [169]

Initiate a review
You can create reviews for any item or group of items that you can access. By default, you are the
moderator for any reviews you create.

You can start a review from several places in the interface. Whichever method you use, a wizard opens
and guides you through the process.

Method/location Action
Reviews Select Reviews in the top navigation, then select Start a review.
Test plan Select Test runs > Cycle > Send for review to send a cycle of test runs to review.

Note: To send an entire test plan for review, select Test Plans, right-click on the test plan, and select
Send for review.

Projects > Single Select the item you want to review, then select Send for review.
Item View

Projects > List View Select the items you want to review, then select Send for review.
Explorer Tree Right-click on an item and select Send for review.

Filters tab — Right-click on the filter that points to the items you want to review, then select Send for
review.

Releases tab — Right-click on the filter that points to the release you want to review, then select Send
for review.

Baselines tab — Right-click on the source that includes the baselined items you want to review, then
select Send for review (reviews the items in their current state, not their baselined state). If all items
from an existing source were deleted, you can't select Send for review from the baseline tree.

TIP

@ When you initiate a review, a baseline of the selected reviews is automatically gener-
ated [248]. You can find this baseline [248] under the Baselines tab or you can find a
link under the Versions tab of any item in this review.

To start a review:

1. Select the items you want to review using one of the methods described in the previous table.
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2. Definition [154] — Define your review.

3. Settings [156] — Configure the settings for your review.

4. Participants [158] — Configure who you want to review your items.
5. Invitation [159] — Complete the invitation email.

Definition

When you initiate a review [153], the first step is to define the review.

1.

2.

If you selected items before initiating the review, the system suggests a name, or select a name for
the review.
Set a deadline for the review, or the deadline defaults to one week from today.

NOTE

If you're using Windows, be sure that "Adjust for daylight saving time automatical-
ly" is enabled in "Date and time" settings in Windows, so that the time zone is
displayed correctly when initiating a review.

If you selected items before initiating the review, the Project field shows the name of the source
project. Otherwise, select the Project that contains the items for this review.

If you selected items before initiating the review, this field isn't editable. Otherwise, select the items
that you want to review.

You can select whole containers or expand the containers to select individual items. You can also
use the Releases or Filters tab to select a release or filter to send to review. You can't select items
from multiple tabs. Use the Select button to indicate your choice is complete.
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5. Select Include item attachments to add item attachments to the review.
[tems

Project: Semiconductor Project 2.0 Q

» Include item attachments {Reviewers must have proper project permissions to view attachments.)

Include related items

When the review is created, you see attachments for the item in each section of the review (if they
exist). Select the attachment link to open the latest version of the attachment.

6. Select Include related items to see options for making upstream and downstream items visible in
the review (as long as such items exist).
You see each item type that's related either upstream or downstream, along with a count of the
number of related items.
Select Show filters to filter those relationships by relationship type.
Select the related items you want to include in the review.
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7. Select Next.

Settings

When you initiate a review [153], the second step is to choose the review settings. This image shows
the default settings. Additional settings are available only if they are configured by an organization or
process administrator.
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You see the Review template option if it's enabled in Review center by an organization admin. For more
information about review templates, see Iltem workflow for Approval Reviews.

1. Select electronic signature settings.
If you select Require electronic signatures from approvers, all approvers must sign the review
in order to approve it. Select Enable signature group for approvers if you want your review signa-
tures to have a particular signer role. Find out more about how electronic signatures work [225].

2. Select permission settings.
Allow for review comments to also appear in the single item view within a project:
Administrators must first enable this option in the Review Center Settings for this option to appear.
Make public: This option makes the review visible beyond those invited to participate. An organiza-
tion administrator determines whether public reviews [622] can be seen by anyone with access to
reviews, or only by those with permission to ALL items in a review.
Let approvers add reviewers and approvers: Select to allow approvers to add others to the
review.
Let approvers delegate their review to others: Select to allow delegation of the approver role. If
an approver is assigned a signer role, and they delegate their approver role, the signer role is also
delegated.

3. Select optional settings.
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4.

Enable time tracking: Check this box to track the amount of time each reviewer spends within the
review. The clock that tracks the time is visible to all participants in review statistics [189].

Notify me when a participant finishes a review: Check this box to send notification emails [196]
to the moderator when a reviewer marks a review complete or when a participant requests a new
version.

Enable voting: Check this box so participants can provide input on priority or other issues the
moderator needs to resolve. Read more about voting [194]. If you select this box, you are asked to
designate the number of votes per user and a label for what the vote means.

Select Next.

Participants
When you initiate a review [153], the third step is to choose review participants.

1.

o IMPORTANT
Inviting anyone to a review gives them read access to the entire content of the review,
even if they don't have permission to the underlying items.

Using the left column, select participants for this review.

Use the tabs at the top of the column to select from users on the project team, or from outside the
project team.

You can select individuals or groups. Search by name or email using the field at the top of the list. If
you select a group, you can add all users or select individual users from the group.

Select the Invite user by email tab to invite users from outside of Jama Connect. Those users
receive an email invitation with a link to the review. When they select the link, they are given a
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reviewer license (as long as there are floating reviewer licenses available) and are asked to set up
an account. They can only access the review you invite them to.

o IMPORTANT
An organization administrator can disable this function or can restrict the domains
for which outside review invitations are allowed. [622]

2. Selected participants appear in the right panel. Select a review role for each participant (approv-
er [172] or reviewer [170]).
If you enabled signer roles [156], you can also assign a signer role to each approver.
Signer roles are based on groups. If you select a group name, then select All users, the signer role
for those users defaults to the group name.
3. Select Next.

Invitation
When you initiate a review [153], the final step is to complete the invitation.

1. You see a draft of the email that's sent to participants. At the top, it shows the total number of
participants who receive the email and their roles.
Fields for the email subject and message are the only two fields you can modify in this panel.
The email also shows the review role and signer role as determined in the participants pan-
el [158]. For reviews that have participants with different reviewer roles, light gray text shows
information that might vary for each participant.
The signature meaning is the same for all reviews and defaults to "l approve this review" and can't
be modified.
The email includes a link to the review and the deadline.

2. Select Initiate review to receive a confirmation that your email was sent.
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Add and manage review participants
As a moderator, you can add or remove moderators from your review.

1. In areview, select Add moderators.

If you are viewing multiple reviews in the Table view, select Update moderators for this review.

The Update Moderators window opens.

2. Add moderators from your team (Project Team tab) or from outside your team/Jama Connect
(Outside Project Team tab).

3. Toremove a moderator, select the X next to the name in the Review Moderators panel.
4. (Optional) Add a comment about the changes you made.
5. To finish, select Update Moderators.

Important considerations

+ If you remove yourself from a review, you no longer have access to that review. All added and
existing moderators receive email notifications for changes to the list of moderators during the review.
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» Moderators can be added to a review regardless of their access rights to the items in the review.
However, when a new revision for the review is published, it includes only items that moderators
have write access to. This can have unexpected consequences for reviews sent from filters, such as
missing or extra items in the new revision.

Modifying an "In progress™ review
You might want to change the content that's included in a review, the due date, or the participants. You
can also close a review so that feedback is no longer allowed.

Only a moderator [152] or a review administrator [177] can change a review.
You can change a review from different locations and views in Jama Connect:

* In a review, use the Manage review drop-down menu.
= Manage review -

Edit
Close for feedback

Mark review as finalized

* In Reviews > Table View, use the Actions column.

The icons in the Actions column are:

Edit — Open the wizard where you change the deadline, invite new reviewers, or change an approv-
er’s status (role).

Reopen — Open a review that was closed.

Delete — Remove a review permanently (only a review administrator can recover a deleted review).
Update moderators — Add to or remove moderators from your review.

Archive — Remove the review from the list that appears to users.

Modifying a "Closed" review
A review closes automatically on the end date and time or it can be closed manually by the modera-
tor. When a review is closed, reviewers can no longer add comments.

Important considerations

+ As the moderator, you might want to reopen a closed review to allow more feedback, archive the
review, or publish a new version.

* Only a moderator or a review administrator can edit a review.

* When viewing a closed review, you see a blue status bar at the top of the review, which notifies
participants if a review is closed.

Use these buttons to do the following with a closed review:
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» Archive — Remove a review from the primary list of reviews.
* Recover — Recover a review that was archived or deleted. No item updates are published.

* Publish new revision — Publish a new version of the review that includes any changes made to the
original items, and change any options for the review itself.

Incorporate review feedback
A moderator can incorporate feedback by editing an item directly from the review.

1. From the header, select Reviews, then open the item using one of these menus:
Triangle drop-down menu Menu next to item's name

Edit item

View edits

Subscribe

y
m
@ Remove
|-
B Gotoitem

You can also select the name of the item you want to edit to open it, then select Edit item from the
menu on the right.

2. In the window that opens, make the changes you need.

3. (Optional) Select Notify to designate people or groups you want to inform about this change, then
choose the people to be informed.
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Your changes are saved in the project, but not in the review.

Any time an update is made to an item that's in review, a blue status bar appears at the top of the
review. The review remains unchanged until the moderator publishes a new version.
4. Select Commit.
To update change in the review click Publish new revision.
6. Inthe window that opens, select one:
* Publish — Update the review for all participants.
* Modify review — Make further changes to the review itself in the wizard.

o

Participants receive an email notifying them about the new revision.

Close an "In progress" review

A review closes automatically when its deadline is reached. A moderator might want to close a review
manually before the deadline if, for example, all reviewers already provided feedback.

Once a review is closed, a moderator can recover it by changing the status back to “In progress.”

1. To close a review manually that you are currently viewing, select Manage review > Close for
feedback.
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2.

The closed review now displays the message “This review is closed” in the blue status bar.
To reopen a closed review, select Recover.

The blue status bar no longer appears when the review is reopened.

Publish a revised review

When changes are made to the original review items, you can publish a new version of the review that
includes the changes.

1.

Open a review that includes changes. The text in highlighted in blue indicates the number of
pending updates.

Select Publish new revision to include these changes in the review.
Select an option:

» Publish — Publish the revision immediately (available only when a new version of an item is
created).

* Modify review — Change more options for the review in the wizard.

Finalize a review

When you're satisfied that your review is complete — that all items have been reviewed and approved
and that all comments have been resolved — the next step is to finalize the review.

Important considerations

When you finalize the review, the review workflow tool automatically updates the status of the review
items. For example, at the end of a review, a moderator can trigger the status of reviewed items to
change from "In review" to "Approved."

If workflow is assigned to an item type in your Approval review [623], the item will transition. If you
don't use a template, the review is marked as finalized.

When you reopen a finalized review, items are transitioned to their previous review status.

In the review, select Manage review > Mark review as finalized.

In the window that opens, select Finalize review.
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This action automatically triggers Review Status Workflow, which updates the status of the review.

Delete a review

You can delete a review, but not if it includes electronic signatures. However, if an entire project is
deleted, all reviews in that project are also deleted, even if they include electronic signatures.

Once a review is deleted, only a review administrator can recover it.

1.  From the header in the review, select Delete review (trash icon).

2.  When prompted to confirm, select Yes.

Now, when a user selects Reviews, the review that you just deleted is no longer listed with other
reviews.

Archive a review
When a review is archived, it's no longer visible in the list that's displayed when users select Reviews in
the header.

Reviews can only be archived by moderators and review administrator, and only if their status is
“Closed.”

As the moderator, you can control which reviews are visible to your participants:

+ Select Filter by > Include archived reviews.
» Select Filter by > Hide archived reviews.

1. From the header, select Reviews > Table.
2. In the Actions column of the review you want to archive, select the folder icon to archive the
review, then confirm when prompted.

Actions
Alalddd
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Recover an archived review
A moderator or review administrator can recover a review that was archived [165].
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When an archived review is recovered, the participant roles and contributions are unchanged. For
example, if an approver signed and approved a review before it was archived or deleted, it remains the
same after the review is recovered.

If items were edited after a review was archived or deleted, they don't appear in the recovered review
until the moderator publishes a revised review.

You can recover an archived review from the review’s Actions column or from its blue status bar.

1. To recover an archived review from the Actions column:
1. From the header, select Reviews > Table.

2. In the row with the review you want to recover, select the Reopen icon from the Actions
column.

3. Inthe window that opens under Select review status, use the drop-down menu to select "In
progress," select a new end date and time, then select Save.

2. Torecover an archived review from the review’s blue status bar:
1. Open a review that was archived.
2. From the header, select Recover.

Remove or recover items in a review

A moderator can remove or recover items in a review, and can perform either of these actions without
altering the source in the project.
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Important considerations

* When you pair these actions with the Approval workflow, those items remain in their original state and
aren’t updated when the review is finalized.

To remove items from a review:

1. In the review with the item you want to remove, select the triangle drop-down menu, then select
Remove next to the item.

The "Tagged for removal" label appears.
2. Click Publish new revision to remove the item from the review.

3. In the Publish new revision window, click Publish.
A label appears with the version the item was removed in.
Anyone who has access to the review can see items that were removed.

+ M Removed in V1

To recover items in a review:

1. From the triangle drop-down menu, select Recover to recover the item you removed.

167



Jama Connect User Guide

The "Tagged for recovery" label appears.
2. Click Publish new revision to recover the item in the review.

Transition a Peer review to an Approval review

When reviewers are done looking over a Peer review, the moderator can transition a review to an
Approval review.

Important considerations
» Both templates must be enabled [623] by an organization administrator.
* When an item is tagged for removal or recovery, and you want to transition to an Approval review,

those items are automatically updated.

1. In the review, select Manage review > Transition to Approval.

The Transition to approval review wizard opens.
2. On the Definition page, make your changes, then click Next.

3. On the Settings page, confirm you’re using the approval template, then click Next.
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4. On the Participants page, make your changes, then click Next.
5. On the Invitation page, update the subject and message as needed, then click Transition review.

A revision is created and an email notification is sent to reviewers.

Close and finalize Approval review

After the review is approved, the moderator closes and transitions items to their approved state. You
don’t need a Peer review to finalize an Approval review.

Workflow must be enabled [32] in Admin > Organization for the items in the review, or the option to
Close and transition items won't appear when you finalize a review.

Example with workflow disabled

1. In the review, select Manage review > Finalize approval review.
Wizard opens. You can change the name, deadline, and participants.
2. View the review overview and workflow transitions, then click Finalize review.

169



Jama Connect User Guide

The review is now closed.

Reviewer tasks

» Contribute feedback [170]
* Finish a review as a reviewer [172]

Reviewers can also perform tasks that are available to all review roles.
For example:

» Find and view review items [180]

* Compare versions [187]

* Vote on items [194]

» Subscribe to items on the page [193]

For details, see Tasks for all review roles [180].

Contribute feedback
Once a review is created, all participants can read through the items, make comments, and ask
questions.

By default, you see only comments made in a specific version. For example, comments made in version
2 only appear in that version.
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1. From the review, open the Comment window using one of these methods:
+ Select the Comments icon next to the item.
+ Select the text you want to comment on.

2. Type your comment.
3. (Optional) Apply a category to your comment to help participants understand and track key feed-
back.
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Category Outline color Meaning

Comment / Speech bubble Yellow Open

Green Acknowledged by Moderator
Question mark Yellow Open

Green Answered by Moderator
Pencil / Proposed change Yellow Open

Green Accepted by Moderator

Red Rejected by Moderator
Exclamation / Issue Yellow Open

Green Resolved by Moderator

4. Select Submit feedback to save the comment.
Additional ways to collaborate with your team

» Use the like icon when you agree with a comment and want to track how team members vote on a
decision.

Finish a review as a reviewer

When you complete your work as a reviewer, the next step is to “finish” the review. This action lets the
moderator know you're done with your work (if notifications were set up) and updates the overall review
progress in review statistics [190].

If the review is closed before you finish the review, the blue status bar includes a message: “This review
is closed.”

1. From the review, select Complete review on the toolbar.

2. In the review summary window, add any final comments, select Finish.
3. If you need to make more comments after finishing the review, select Reopen review from the
toolbar, as long as the moderator hasn’t yet closed the review.

Approver tasks

* Approve or reject review items [173]

» Finish a review as an approver [173]

* Add electronic signature to a review [174]
* Add reviewers [176]

* Delegate approval [175]
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o IMPORTANT
After delegating approval, you are no longer an approver, but you remain a reviewer
for the current review. If you delegate approval, all new approvers receive an email
notification.

Approve or reject review items

During a review, you can view items and their comments, approve or reject individual items, and
approve or reject an entire review.

If you don't see a checkmark or X, you don't have Approver status. Contact your Moderator if you need
Approver status.

1. To mark an individual item, select an icon next to its name:
+ Checkmark = Item is approved
+ X = ltem is rejected

2. To mark all items on the page, use the Batch item actions pull-down menu:
» Mark entire page approved
* Mark entire page rejected
3. If your review contains more than one page of items, repeat this action for each page.

When you're done, the blue status bar includes the message “You've marked all items in the review.”
You can then finish the review as an approver and electronically sign the review.

Finish a review as an approver

1. When you're finished with a review, select Complete review from the toolbar.

2. Inthe Review finished window, you can mark any remaining items "Approved" and add a final
comment. These comments are visible under Reviews > Feedback in the top-right menu, or in an
email sent to the moderator if email notifications are enabled for this review. If this review requires
an electronic signature [174], you can also add that here.
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3. Select Request new revision or Approve (or Approve and sign if you're using an electronic
signature).

S NOTE
If you change your mind and want to reopen your review after finishing a review as
an approver, you can select Reopen review to re-open it, as long as the moderator
hasn't closed the review. If you're using an electronic signature [225], opening a review
revokes it.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.
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A STREAM PROJECTS REVIEWS RISK Redside Consulting Dave Wilson | Help | Log Out
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Participants

Page 10f3| b Wl | & |Show: 50 v Displaying 1 - 50 of 119

1. Inthe Review finished window, enter your username and password as your electronic signature.
If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.

Delegate approval
Assign approval to another team member if you're away when a review needs to be approved or
someone else is a better fit.

1. In the review, select Delegate approval from the toolbar.

2. Inthe Request reviewer delegation window, select a delegate.
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3. Click Delegate approval.
A confirmation message appears.

4. Click Yes to confirm.

An email is sent to the new approver notifying them of the request.

Add reviewers
You can add reviewers to a review at any time.

1. In the review, select Add participants.

2. In the window, select the review participants you want to add.
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3. Click Add participants.

An email is sent to the reviewers notifying them of the request.

Review administrator tasks

* Recover a deleted review [177]

» Configure review comments to appear in projects [178]
» Recover an archived review [165]

* Modify a review [161]

* Make a review public [156]

Important considerations

* Permissions for a review administrator must be assigned by an organization administrator.
* As a review administrator, you can access a review's content when the review is public; when you are
also a reviewer, approver, or moderator in the review; or when you add yourself to the review.

Recover a deleted review
Only a review administrator can recover a review that was deleted.

When a deleted review is recovered, the participant roles and contributions are unchanged. For exam-
ple, if an approver signed and approved a review before it was deleted, it remains the same after the
review is recovered.

If items were edited after a review was deleted, they don't appear in the recovered review until the

moderator publishes a revised review.
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1. From the header, select Reviews > Table.
2. In the row with the review you want to recover, select the Reopen icon in the Actions column.

3. In the Recover review window, select the new end date for the review.

4. Click Save.

The table is refreshed and the review is now open.

Configure review comments to appear in projects

Comments made during reviews can provide valuable context, whether you're reviewing a requirement,
lower-level feature, or test item. A record of those comments offers enhanced traceability, so you can
make informed decisions over the course of the item's lifecycle.

The review moderator can allow comments from a review to appear in the project view for that item.

When enabled, the Review comments widget appears in Single ltem View. Select it to see the review
comments for that item.
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This option needs to be enabled in two places for it to take effect. The organization administrator must
enable it in the Review Center Settings and the moderator must enable it when creating a review.

For the administrator

1. Select Admin > Organization > Review center.

2. Under Permission settings, select Allow for review comments to also appear..., then click Save
settings.

This option is now available and visible to review moderators when they create reviews.

For the review moderator

* When creating a review, select Allow for review comments to also appear in the single item view
within a project.
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Once enabled, comments are grouped by review and sorted with the latest comments at the top.
Tips and more

* Why aren't comments appearing? For review comments to be visible within a project, this setting
must be enabled for each review.

* How do | see comments from older reviews? For reviews created without this setting, you can go
back and change this setting to include review comments.

» View More — Appears if there are more comments from that review that haven't loaded.
* Load More — Provides comments from older reviews that haven't loaded, including comments that
might have occurred since the page loaded.

Tasks for all participant roles

» Find and filter items in a review [180]
* Highlighting review comments [182]
* Compare versions [187]

* Show related items in a review [188]
* View participant progress [189]

* View item progress [190]

* View review activity [191]

* Filter review comments [192]

» Subscribe to a review [193]

* Export reviews [193]

+ Voting [194]

Find and filter items in a review
All user roles can search for and filter specific items in a review.
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You can navigate to different areas of the review workspace without losing your filter or search selec-
tion. For example, if you make a filter selection and go to another view, your filter selection is saved
when you navigate back to the review.

Find items in a review

» Enter text in the Search field, then expand the Choose item types drop-down menu to filter your
search.

Find item

= Search o
= Choose item type(s)

" Sets
" Texs
+ \alidations

» Select the item type, then enter text in the Search field.

Find item

» | user needs| fo

Folders

CL4-FLD-8: Needs

Sets

CL4-SET-22: User Needs and
Market Requirements.

System Requirements

CL4-5R-5: Haptic Feedback

When you select an item from the search results or table of contents, the item is selected and outlined
in blue. In the Find item panel, you can refine your search based on the filtered results.

Filter items in a review

Use filtering to view items and comments that need your attention.
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All review participants can filter items to find comments by status, version, author, or activity.

All review participants can filter items to find comments by status, version, author, and activity.

All review participants can filter review items by Activity, Comments by status, Comments by ver-
sion, and Comments by author. Selecting and applying filters in a specific category is additive and

applies ADD statements to each selection. If you apply filters that span multiple filter categories, it
becomes an OR statement.

Highlighting review comments

You can organize and find comments based on their status: Open, Resolved, or Rejected. Comments of
each status type are highlighted by a different color (highlighting is turned on by default).

For example, a comment highlighted in yellow lets review participants know that it's open, while a
comment highlighted in red indicates that a proposed change was rejected.

By default, the review version that you’re looking at shows only highlighted comments that are open,
resolved, or rejected.

182



Jama Connect User Guide

When two highlighted comments overlap, that text is highlighted in light blue.

You can only reject comments that propose a change.
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Moderators resolve an open comment: select it, (optional) type a response and click Reply, then click
Resolve.

The comment box and highlighted text changes to a resolved status (green).
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Apply @mention to review comments

Use the @mention feature to direct comments to a subject matter expert. This is useful when you have
several reviewers and need to direct a question to a specific reviewer.

Important considerations

« Comments that include @mention are highlighted by color, based on whether you or another review
is tagged. Light yellow = comment for you. Light blue = comment for another reviewer.

» Only users participating in the review appear in the list of possible reviewers who can be tagged with
@mention. You can modify the review [161] to add participants.

» Anyone who is participating in the review can @mention other participants.

To use the @mention feature:

1. In areview, select the comment icon and type @ followed by the name of the reviewer.
Repeat for each reviewer you want to mention.

Only the names of the people you included when you created the review [153] appear in the list.
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2. Type your message, then click Comment.

3. (Optional) To display only items where you are mentioned, select Filter > My mentions.
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E . W T Q o 1litem

Filtering items by: My mentions X

Filter items by

Activity

Meeds review (216)

v My mentions (1)

An email notifies the tagged review participant with the review name, items, and comment.

Compare versions
Whenever a published review has more than one version, you can compare two versions.

Good to know

+ If you want to make other fields visible in the review, an organization administrator can configure item
type views [609] for Reading View or Single Item View to show those fields.

» Typically, item fields contain fewer than 10,000 characters (2,000 words). When you compare review
versions, the applications might skip fields with lengthy content.

» The date and version a comment was added appears in the comment.

1. From the review with the versions you want to compare, click Compare.

2. Select the versions drop-down menu near the review title to select the version you want to compare
to the current review.
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Changes are displayed inline. Deleted text is red and highlighted. Added text is green and under-
lined.

The "compare view" displays inline changes for most field types. If the field can't be compared, you
see the message: Not available for reviews.

Show related items in a review

Including related items in a review gives reviewers context and helps them understand the coverage of
items in a review. Related items are visible only if the moderator selected the option Include related
items when the review was created.

If you don't have permissions to view a related item, you see an item type icon and the text This item is
outside the scope of this review.

To view items directly related to a review item:

1. In the review, select Show related items.
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Initially, up to five upstream and downstream items are displayed.
2. To view additional related items, select Load More Downstream Items.

3. Select a related item to see more details.

View participant progress
As a review progresses, you can view statistics about the participants' progress. This information is
unique to the current version of the review.

In separate tabs, you can see item progress [190] for this version, or review activity [191] across
versions.

1. From the review with stats you want to view, select Stats.
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2. Under the Participant progress tab, you can see a panel with participant details and links to email
participants.
Next to that, bar charts show overall progress for the review for approvers and reviewers who
have finished the review. For approvers the chart shows how many items they marked approved or
rejected. For other reviewers it shows how many items are marked read. Reviewers' time spent.
Below that, each participant is listed with their review role, signer role, signature information,
comment count, time spent shown in hours:minutes, and a progress bar showing their completion
level.

NOTE

Time is logged if a tab with the review is left open by a reviewer.

View item progress

As a review progresses, you can view statistics about the progress of the items in review. This informa-
tion is unique to the current version of the review.

In separate tabs, you can see participant progress [189] for this version and review activity [191] across
versions.

* From the review with the items you want to view, select Stats.
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Under the Item progress tab, you see an overview with the total number of items in the review, their
item types, the start and end dates for this version of the review, the current approval status for all
items (if this review uses approvers), and a summary of open comments in the review.

Below that, is a table showing item fields along with the number of votes, as well as the number of
participants who marked the item approved, rejected, or reviewed.

For reviews with multiple approvers, the item approval status count increases when all approvers
approve the item. However, it only takes one approver to reject an item for the rejected count to
increase. Iltems that aren't marked as approved or rejected are considered not reviewed. Items that
aren't marked as approved or rejected are considered not reviewed.

If you're a moderator, you see the preset filters to filter the list by item type, folder, or set. You can
use Views to configure which fields are visible in the table. You can use Actions to batch update
items [72].

View review activity

You can see all activities for a review across versions, including when reviews were opened, closed,
when new versions were published or when signatures were added. This can be useful for collecting
electronic signature [225] information for FDA 21 CFR Part 11 compliance.

You can also see item progress [190] and participant progress [189] for each version of the review.

From the review with activities you want to view, select Stats.
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2. Inthe page that opens, select the Review activity tab.
The table shows activity for all versions since the review was created.

Filter review comments
You can view and filter comments for all the items in a review to find only the comments you want to

see.

1.  From the review, select Feedback to see all the comments for the review, with a filter panel on the

left.
You can read and reply to comments here.
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2. (Optional) You can also use the filters in the filter panel to search for comments by category or
keyword. Available categories are:

All Every comment from the review.

Open Comments the moderator hasn't acknowledged or responded to
Mine Your comments

Review Comments sent to participants about the review by email
Important Comments flagged as important by a moderator

Questions Comments that are questions to be answered

Proposed changes Comments that suggest changes

Issues Comments that raise issues

Subscribe to a review
If you're a review participant, you can stay up-to-date on review comments with email notifications in
reviews where you're a participant.

To receive notifications, you must first configure your review subscriptions [40] in your profile. You can
also configure your profile so that you automatically follow an item when you comment on it.

1. Open the review with the items you want to subscribe.
2. Select Actions > Subscribe to the items on this page.

o IMPORTANT

Some reviews contain multiple pages of items. To subscribe to all the items in a
large review, you must subscribe to items on multiple pages.

Export reviews
You can export reviews as a Word document or a PDF by selecting Export anywhere in Reviews.

Review exports can't be customized, the export uses the default Word template.
You have two export options:

» Export activity review — Includes all review activities [191] across versions (for example, when the
review was created, versioned, closed, marked as finalized) along with the date, name, and role of
the person responsible.

» Export version review — Includes an overview of the review, a list of participants with their review
role, signer role, signature meaning and status, as well as the content of the review and the com-
ments.

To download an export to your desktop:

1. In the review you want to export, select Export in the top right toolbar.
2. Select the type of export and format.
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3. In the window that opens, choose how you'd like to open the file, then click OK.

The file opens in a new tab.

Voting

With voting, your team can prioritize items or rank them based on a topic proposed by the moderator.
Each participant has a certain number of votes. Participants can give multiple votes to a single item.

Moderators can enable voting in the settings [156] when they initiate a review.

You can apply votes as a participant using one of these methods:
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» Select the up arrow to add a vote or the down arrow to subtract votes. The box on the left displays
the number of votes you used on that item. You also see how many votes you have left to use.

» Participants can also apply votes while viewing an item's detail.
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Collaborating with your team

For companies to turn today’s research into tomorrow’s products, teams must stay connected and
synchronized. Jama Connect equips teams to track decisions and ensure quality of the product they set
out to build.

Jama Connect links globally distributed team members and facilitates collaboration in the product
development lifecycle. It allows you to provide and capture feedback, decision making, and approval for
requirements and all product aspects under review.

Jama Connect enables efficient sharing of data, documents, files, information, and knowledge within
and across teams in your organization.

Use these features to work with your team, document conversations, and track decisions.

* Reviews [149] — A method to help teams, stakeholders, and customers discuss, evaluate, revise,
and approve items in the development process. For details, see Reviews in Jama Connect [149].

+ Workflows [198] — An automated set of transitions, from one status to another, over the course of
an item's lifespan.

* Notifications [196] — Optional emails sent to groups or individuals to alert you when changes to
items are made.

» Stream [203] — A collection of the most recent comments and activities in the project.

» Electronic signatures [225] — A method for getting approval on electronic documents or forms.

Email notifications and subscriptions

Users can configure email and notification settings in their profile [37] to stay up to date with activity in
their projects.

0 IMPORTANT

To receive notifications in Jama Connect, your SMTP must be enabled by your system
administrator.

You can sign up for notifications to be sent to you automatically from several places in Jama Connect.

Notifications from... Sent to you...

Review [153] When you're invited to participate

When someone replies to your comments in a review

Workflow [643] When status of an item changes
Stream [214] When you're mentioned in the stream
System Health Report [550] With updates on license usage

Your Jama Connect administrators control what you can do with subscriptions. For example:

» Organization administrators — Can allow users to subscribe others and to mute subscriptions.
* Project organization administrators — Can unsubscribe groups or individuals from any of their
subscriptions.

As a user, you can:
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» Set up notifications for a single item in a project or for an entire project.
» Configure email notifications and subscriptions.

Subscribe to emails for yourself
You can subscribe to a single item, to multiple items, or to an entire project.

1. To subscribe to a single item, select the item in Single Item View, then select Subscribe.

2. To subscribe to multiple items:
1. Open the items in Project > List View.
2. Select each item you want to subscribe to.
3. Select Subscribe.

A confirmation message appears below the toolbar.

Subscribe other users to email notifications

You must be a system, organization, or project administrator to subscribe others to all items at a project
level.

1. To subscribe others to a single item, select the item in Single Item View, then select Subscribe >
Subscribe others.

2. To subscribe others to multiple items:
1. Open the items in Projects > List View.
2. Select each item you want to subscribe to.
3. Select Subscribe > Subscribe others.
4

In the Subscribe others to all items window, select the groups or users that you want to
subscribe to this item.
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5. Click OK.
Workflow
A workflow is a set of transitions from one status to another, over the course of an item's lifespan.
All workflows must be set up by an organization or process administrator before they can be used.
Workflow can be used in these scenarios:

* Project items [198] — Creates a common pathway for items to follow.
» Review items [623] — Allows organizations to configure items to transition to a specific workflow state
following the review process.

Using workflow in Projects

You can set up a workflow for Project items, so that users at your organization can move items in your
project along a similar path as they progress.

Workflow in Projects allows you to:

» Update status for an item or group of items. Items must be the same type and in the same workflow
state.

+ Transition items from one status to the next, either for a single item or as a batch transition for a
group of items.

If workflow is configured by an organization [643] or process admin, use the drop-down menu in Single
Item View to move the status of an item along the workflow and activate any related actions or
notifications.
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Use workflow to batch transition items

With batch transitions, you can select multiple items of the same item type and transition them to a
different workflow status.

Important considerations

+ All items that you transition must be in the same state. For example, you might batch transition all "In
Progress" items to a "Complete" status, but you can't select both "In Progress" and "Proposed" items
for batch transition.

1. Select the project, folder, or set that contains the items you want to transition and view them in List
View. Select the items you want to transition, then select Actions > Batch transition.

2. In the Batch Transition Workflow window, confirm your item selection, choose the status, add a
comment, then click Commit.
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Your comment appears in the version history of the item and as an activity in the stream.
Note: A batch transition is the only way to add a version or notification comment.

3. The status change is shown for each item you transitioned.

Use workflow to batch transition items in Reviews
With batch transitions, you can select multiple items of the same item type and transition them to a
different workflow status.

Important considerations
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» The items you select for transition must be the same item type and workflow state.

1. When you're in a review, select Stats.

2. Scroll to the bottom of the page and select items of the same item type and workflow state that
are to be transitioned. You can select multiple items by using Shift or Ctrl keys. Select Actions >
Batch transition workflow.

NOTE

You can also batch update non-workflow fields, but you can't batch delete from
here.

3. In the Batch transition workflow window, select the set of items you want to update and the
intended workflow transition, then click Commit.
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If the workflow doesn't have another transition state to select, you don't have permission or the item
is locked. A pop-up window displays a warning that you can't proceed.

Lock items in a workflow
Locking items in a workflow can help avoid unwanted changes. For example, a project administrator
might want to leave items unlocked while in "draft" status, but lock them when they reach "approved"

status.

NOTE

You must have organization or project administrator permissions to configure workflow.

Iltems can also be automatically locked by the workflow [198]. These items show a gray lock after their
name and a blue lock in List View.

System-locked items unlock when transitioned through the workflow or by an organization or project
administrator.
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To add an automatic lock to the workflow:

1. Select Admin > Project > Workflow.
2. For the item you want to lock, select Override.
3. Inthe Lock? column, select the lock icon to include (or remove) an automatic lock in the workflow.

4. Click Save settings.

Stream — Staying connected

The stream is where you can see the most recent comments and activities of your Jama Connect
project.

The stream is built on three basic activities:
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A STREAM PROJECTS REVIEWS RISK ADMIN Redside Consulting ~ AdminTest | Help | Log Out

Stream
| A
k
@ #t m Actions ¥ Cancel
n- T~

Dave Wilson Decision needed - afew seconds ago

% Admin Test Please publish the latest review!decisionneeded
L * Mute

Admin Test + afew seconds ago
Done

(A Admin Test - « afew seconds ago
Done

) * Delete

Working with the stream

With everyone having the most up-to-date information through the stream, stakeholders stay informed
and aligned.

You can:

* Include stakeholders in a conversation [212] by name or email.
» Keep up to date on the latest activities [209] for a project or item.
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+ Clarify conversations by using actions [216] like questions, decisions, or issues.

* Include whiteboards, prototypes, or other images [215].

+ Filter the stream [218] to include only comments or activities that refer to a specific project, item, or
person.

* View the stream across projects [223], at an item level [220], or at a project level [222].

Types of streams
Jama Connect includes streams for specific types of collaboration and activity.

Global Stream [205] — At this level, you see a collection of the most recent comments and activities.

Project and Item Activity Stream [205] — At this level, you see comments and activities for the entire
project.

Item Collaboration Stream [206] — At this level, you can see comments and connected users related
to a specific item.

Baseline Activity Stream [207] — At this level, you can monitor activity, quickly find a baseline ID, or
see if a signature is revoked.

Review Activity (Stats) [208] — At this level, you can see all activities for a review across versions,
including when reviews were opened, closed, when new versions were published, or when signatures
were added.

Admin Activity Stream [544]— At this level, you see an audit trail of updates made by organization
and project administrators.

Global stream
At this level, you see a collection of the most recent comments and activities.

How to access From the header, select Stream.

What you can do See the most recent comments related to an item.

Project activity stream
At this level, you see comments and activities for the entire project.
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How to access Select the project name to open the Activity Stream.

Note: If you don’t see the Activity Stream, select the green Add button. In the window, select
Activity stream, then click Add. You must have Project Admin permissions to do this.

What you can do » See comments and activities for the entire project.
» See changes to items — Adding, editing, or deleting content from item fields, commenting on
an item; using features like releases, baselines, or reviews that impact the item.

» Find out when a review is opened, revised, closed, reopened; when signatures are added or
revoked.

« View items that are reused and synchronized and reuse details that appear in the activity
stream. Users with read permission can view details about reused items and can select a link
to view newly copied and synchronized items.

» From a project, select the Collaboration Stream View icon to see information only for that
project.

Item collaboration stream
At this level, you can see comments and connected users related to a specific item.

Here's an example of what the stream looks like in List View and Reading View:

206



Jama Connect User Guide

How to access There are several ways to view the stream at the item level.

In Project > List View, select the speech bubble icon.

In Project > Reading View, select the speech bubble icon.

In Project > Single Item View, select the speech bubble icon.

What you can do » See comments and connected users related to a specific item.
« See changes to items — Adding, editing, or deleting content from item fields, commenting on
an item; using features like releases, baselines, or reviews that impact the item.
» View items that are reused and synchronized and reuse details that appear in the activity
stream. Users with read permission can view details about reused items and can select a link
to view newly copied and synchronized items.

Baseline activity stream
At this level, you can monitor activity, quickly find a baseline ID, or see if a signature is revoked.
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How to access Select the Baselines tab, baseline name, and View details (which changes to View items) to
open the Activity stream.

What you can do » Monitor activity, quickly find a baseline ID, or see if a signature is revoked.
» View changes to baselines — Adding (manually or automatically with a review), editing, or
deleting* baselines or sources. Visible to users with read-only permission. Baseline activity
streams.

*Deleting requires admin permissions. Baselines with e-signatures can’t be deleted.

Review activity (stats)
At this level, you can see all activities for a review across versions, including when reviews were
opened, closed, when new versions were published, or when signatures were added.
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How to access In the review, select Stats to open the activity page.

What you can do « See all activities for a review across versions, including when reviews are opened, closed,
when new versions were published, or when signatures were added.
» Find out when a review is opened, revised, closed, reopened; when signatures are added or
revoked.

» See when items are sent for review.
« See all activity for a single review across revisions in the Review activity tab.

Activity stream

Activities are the recorded changes made to an item, including editing, commenting on, relating to other
items, deleting, and restoring.

You can view activities at an item level [220] or a project level [222]. You can also view activities specific
to different parts of Jama Connect, such as reviews [191] and baselines [248].

These are the types of activities that appear in the stream.
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Activity type

Definition

Visible in...

Changes to items

Adding, editing, or deleting content from item fields; comment-
ing on an item; using features like releases, baselines, or re-
views that impact the item.

Project activity stream

Item activity stream

Changes to baselines

Adding (manually [245] or automatically with a review [244]),

Baseline activity stream

editing, or deleting* baselines or sources. Visible to users with
read-only permission. Baseline activity stream [248] shows all
activity for a baseline.

Reused and synchronized When items are reused and synchronized [276], details of re-
items use appear in the activity stream. Users with read permission
can view details about reused items and can select a link

to view newly copied and synchronized items.

Project activity stream

Item activity stream

Comments Comments related to an item or project. Review comments Collaboration stream
aren't included in activity stream.
Reviews When review is opened, revised, closed, reopened; when sig- Project activity stream

natures are added or revoked.
Review activity (stats)

When items are sent for review, see all activity for a single
review across revisions in the review activity [191] tab.

Review activity (stats)

* Deleting requires admin permission. Baselines with e-signatures can’t be deleted.

Comments
Comments are user-created messages that you can see in the stream or in reviews.

Comments are visible:

* Atanitem level [220]
* At a project level [222]
* Inreviews [170]

* Across projects [223]

You can add and delete a comment as well as restore comments that you deleted. You can also add a
hashtag (#) to a comment for filtering or add a reference to a specific person, project, or group.

Add, delete, or restore a comment

All comments made in Jama Connect are displayed in the stream. You can see any comment you have
permissions to view.

You can add comments, delete comments that you made, and restore comments that you deleted.

You can also restore comment threads or replies that you deleted, but only if they were associated with
an item. You can't restore deleted comments that aren't associated with an item.

1. To add a comment to the stream, an item, or a project:
1. Open the stream at an item level [220], project level [222], or across projects [223].
2. Enter your comment:
* New comment — In the Stream comment box.
* Replying to a comment — In the reply box below the comment.

Stream

n~ T~

3. (Optional) As needed, you can refer to a particular person, group, project or item [212], request
or resolve an action [216], upload an image [215], or add a hashtag [211].
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4. Select Comment.
2. To delete a comment:
1. Select Delete below the comment.
2. When prompted, click Yes.
3. To restore a deleted comment:
1. In Single Item View, select the Activities widget to open the bottom panel.

=3
16

2. Inthe deleted comment, select Restore.

3. When prompted, click Yes.
The comment is restored and appears in the My Settings section.

Tips and more

When the discussion gets long, Jama Connect shows only the most recent comments. Select View all
replies to expand the thread and show all comments. Select Hide replies to collapse the thread.

Add a comment hashtag
By adding a hashtag to your comments, you can quickly filter the stream by selecting the hashtag itself.

Tags begin with the # character and are lowercase letters with no spaces.

To add a comment hashtag:

1. In the Stream comment box, type # followed by the tag.
For example, #alert or #review.

2. Click Comment.
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Admin Test Comment - afew seconds ago

#review

) * Mute + Delete

The comment appears in the stream thread.

@ NOTE
Comment tags are different from item tags. Comment tags are added to comments and
can be used to filter the stream, but item tags are added to an individual item and can
be used to search or group items.

Use @mention to add a reference
To increase the efficiency and usability of your comments, you can refer to specific items, projects,
people, or groups with @mention.

Anyone you include in a comment receives an email notification [214].

1. Open a list of names (items, projects, people, groups) using one of these methods:
* In the comment field of the Stream window, type @ followed by the first few letters of the name.

» Below the comment field of the Stream window, select @.

2. Scroll through the list to select the name you want to include in your comment.

The name that you included appears as a bold link in your comment.

Add someone from outside Jama Connect

You can add a commenter who is not part of Jama Connect. They get a temporary license [578] that
allows them to view the comment threads to which they were invited. They can also see descriptions of
referenced items in the thread.

Once you send the invitation, the person can optionally set up a user login and password, which is then
available in the @mention drop-down list. The license expires after 30 days —and the user is locked
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out of Jama Connect — unless it is changed to a permanent one. They can still be @mentioned in
stream if the license has expired, but they can no longer access the conversation or items.

NOTE

An administrator can grant invited users permission [653] to view additional project
data.

To give stream access to someone outside of Jama Connect:

1. In the comment field of the Stream window, type @ followed by the user's email address to trigger
an invitation, then select the blue Invite bar that appears.

2. In the Invite User window that opens, enter the full email address and click Invite.

3. Type your note and click Comment.

The person you invited now automatically receives stream emails [214].

View referenced projects and items
When a project or item is referenced with @mention, you can view it in its activity stream.

1. To view a reference to a:
* Project — Open the project's activity stream.
* Item — Open the item's activity stream in Single ltem View.

2. (Optional) In the activity stream, select Description to see details about the referenced project or
item.
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3. (Optional) Select View additional references to see more than the first displayed reference.

Email notifications for the stream

Jama Connect includes several types of email notifications, including ones initiated in the stream. This
information applies only to stream email notifications.

Adding participants

When you comment on an item or project in the activity stream, you can add people to a comment by
using @mention. This includes people who aren't current Jama Connect users.

When you receive stream notifications

Initial email — When your name is added to a comment in the stream.

Update email — When anyone replies to a comment thread where your name was added.
New comments — If you subscribed to the item.

Tips and more

* If you are in multiple groups that are mentioned in a comment, they receive only one email for each
comment or reply.

* When participants receive an email because they're mentioned in the stream, they can comment di-
rectly to the thread by replying to that email. A copy of the comment is emailed to everyone on the
thread.

» Email updates contain links to see the entire comment thread in Jama Connect.
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NOTE
Replying to a thread by email works for comment threads in the stream, but not for
comments in reviews.

 To stop receiving email notifications for a comment thread where you’re mentioned, go to that thread
in the stream and select Mute. Do this for each thread that mentions you.

s NOTE

Once you mute notifications for a thread, you only receive future emails if you're
specifically mentioned in a comment or if you're a member of a group that's also
referenced.

Upload images to the stream
You can include useful photos (meeting notes, white board drawings, or prototypes) in the stream by
uploading images.

Here's how:

1. In the Stream window, select the Image button.

2. Select the image file you want to upload, then select Open.
The image appears in the stream comment field.

3. (Optional) To resize the image, hover over the bottom right-hand corner of the image, grab the
handle and drag the corner to the required size.

4. (Optional) To move the image in the comment, hover over the top left-hand corner of the image and
grab the handle. Drag the image to the correct location in the comment.
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5. Select Comment.

The image you uploaded now appears in the stream.

Request or resolve an action

Actions can highlight important conversations in the stream by identifying a comment as one of three
types: decision, question, or issue.

Actions also help clarify your request to someone you include in your comment. You can also filter by
actions [218] to see what questions, issues, or decisions need attention.

1. To initiate a request, choose from the Actions menu or type a ! in the comment box and choose an
action from the menu that appears.

When a comment contains a request action, the left edge of the comment is outlined in yellow and
a blue button invites other users to resolve the action (Answer question, Make decision, Resolve
issue).

216



Jama Connect User Guide

2. Torespond to a request, choose from the Actions menu: Decision, Answer, or Resolution.

OPEN ACTIONS

Decision needed
Cluestion

Issue

RESOLVED ACTIONS

Decision
Answer

Resolution

Tips and more

* Resolved actions are displayed in green.

» Open actions are displayed with a yellow border.

217



Jama Connect User Guide

* Use the like icon when you agree with a comment and want to track how team members vote on a
decision.

» Select the number next to the like icon to see who agreed.

Filter the stream

Filters let you see only comments that matter to you. When you create a filter, it remains active only if
the session is active.

If you want to reuse a filter, you can save it. You can also bookmark a filter in your browser to view later.

NOTE

You can create custom filters [220] at an item level to filter comments or activities in the
stream.

1.  Open a Stream window and select the Filter comments field.
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w

Stream

- | l

Enter one of the following and select from the displayed menu to create a filter:

# Displays a menu of hashtags.

@ Displays a menu of users.

! Displays a menu of actions.

Keyword Displays a menu of frequently used names for people, groups, projects, or other content types.
Select an option from one of the menus or press Enter if you entered a new keyword.

(Optional) To filter by actions, select the Quick filters menu. These filters are additive so you can
filter on multiple actions.

T~
OPEN ACTIONS
Decisions needed
Questions

Issues

RESOLVED ACTIONS

Decisions
Answers

Resolutions

The filters you choose appear below the comment field. The stream is refreshed with each filter you
add or delete.

(Optional) To save a filter, select the bookmark button and enter a name for the filter, then select
Save.

To set a quick filter from a comment, select people, projects, items, or other boldfaced references in
the comment. These filters aren't additive.

(Optional) To share a filter with another Jama Connect user, copy the URL of your filtered results
and send it through email.
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View collaboration stream at an item level

You can view the stream [203] comments and activity for an item, for example, to see all "Open"
(unresolved) questions about that item. A speech bubble icon includes a number that indicates how
many comments were recorded for that item.

NOTE

The side toolbar is only visible if it is configured by the organization administrator [593].

To view comment stream

1. Select an item’s speech bubble icon using one of these methods:
Projects > Reading View

Projects > List View

220



Jama Connect User Guide

Single Item View > Side toolbar

== ”
(1]

2. Inthe window that opens, select the silhouette icon to view comments, add comments, or view
connected users.

To view comment and activity stream

1. In Single Item View, select the Activities button on the side toolbar to see the history of an item.
The number on the button indicates the item's activity.

A
[ 20

2. The bottom panel displays the stream and all activities (such as edits, reviews, relationships) and
comments for this item. From here you can add a comment, search the stream with a keyword,
refresh the display, or hide the panel.
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3. Use the three buttons in the top left corner of the stream to:
+ Display active comments
+ Display all activities
+ Apply a custom filter to activities
4. Select the settings (gear) icon in the top right corner to open the Activity Filter Settings window.
5. Keep the default settings or customize keywords, activity type, date range, or item type, then select
Apply. Your custom filters are saved across items.

View collaboration stream at a project level

You can view the stream [203] at a project level, you see comments [210] and activities [209] for the
entire project in the project dashboard.

Important considerations

* Any comments you enter at this level automatically refer to the selected project.

222



Jama Connect User Guide

+ If the stream doesn't already appear on your project dashboard, a project or organization administra-
tor can add it.

Open the project dashboard using one of these methods:

» Explorer Tree — Select the main project level in the Explorer Tree or select the name of the project
just above the Explorer Tree.

+ Comment bubble — Select the comment bubble in the upper right navigation, then select Stream
View.

View global stream across projects

View the stream across projects when you want to do a search or filter projects. For example, if you
want to see open questions that are assigned to you for all projects.

To view the stream across projects, use one of these methods:

» Select Stream from the top navigation. This displays all comments from all projects, starting with the
most recent.

» Select View All Stream Activity from the home page to see all comments across projects.
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View connected users

A connected user is a creator, editor, or someone who has commented, subscribed, or been @men-
tioned on an item.

View connected users to see who is connected to items. For example, if you're changing a requirement
and want to see who might be impacted by a change.

To view connected users:

1.  Open the Connected users window using one of these methods:
+ Single Iltem View — Select the connected users icon.

u
2

« List View — Select the user icon.

2. Select Show indirectly connected users to view users who are interested in items related to this
one.
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3. (Optional) To toggle the related users on or off, select the circle icons at the top of the list.

You can now view the list of connected users and make comments in the stream.

Electronic signatures

An electronic signature is a way for project participants to virtually approve reviews, baselines, and
electronic documents like test plans and requirements.

Review moderators can require a signature for a review and add a signer role. All review signatures
carry the Signature meaning: "l approve the content of this review."

Electronic signatures consist of a username and password. They are captured with a time and date
stamp and an audit trail. Each signature is tied to the individual user, as well as to a baseline or review
where the signature was added.

Electronic signatures, time stamps, signer roles, and signature meaning are all visible in review activi-
ty [191].

Things to know

» For easy identification, a baseline with an electronic signature includes a blue dot and white exclama-
tion mark in the baseline tree.

» As the moderator, you can add a signer role or a reason for signing to a review signature [174], but
not to a baseline signature.
 Signatures are enabled by default, but can be disabled by a system administrator.
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 Electronic signatures depend on the authentication system your organization is using. Authentication
properties can be configured by a system administrator.

* You can't delete a review with an electronic signature, or a baseline created from a review with an
electronic signature.

* You can revoke your signature if it was signed in error or something needed to change. Select
Revoke to cancel your signature. Only the user who signed the baseline can remove their signature.
When revoking a signature, you can leave a reason for revoking, which appears in the activity stream
as a comment.

* As an approver, you can reopen a review that you signed, but this revokes your signature.
» To see a review that was signed, look in the participant progress [189] or review activity [191] tab.
» Self-hosted customers can't edit a baseline that is signed.

S NOTE
You can't delete a review with an electronic signature, or a baseline created from a
review with an electronic signature.

Electronic signatures depend on the authentication system your organization is using.
Authentication properties can be configured by a system administrator.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.
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1. In the Review finished window, enter your username and password as your electronic signature.

If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.

Add signer role

As a moderator, you can enable the signer role for other approvers. This allows them to associate their
role with their signature. Signer roles are created from user group names.

If your moderator is inviting a user from outside of Jama Connect, they must log in and register before
you can assign them to a group. After your organization or project admin adds them to a group, the
moderator can edit the review to give them a signer role.

1. Initiate a review [153].
2. Make sure electronic signatures and signer roles are enabled in settings [156].
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3. To invite participants [160], select the user, then use the Signer role drop-down menu to assign a
signer role.

+ If the user belongs to multiple groups, you can choose their role as signer from multiple options.

+ If they don't belong to any groups, their role is "Not assigned."

» To add a signer role, create a user group [569] with a name that indicates the role you want to
represent (for example, QA, Business Analysts, Security). Be sure the person you want to assign
the role to belongs to that group.

* If you select a group in the participants panel, select Add all users. The signer role defaults to
the name of that group.

4. Click Initiate review.

Approvers assigned a signer role are notified of their role in their email invitation [159].

TIP
@ After a review is signed, anyone with permission to a review can view signer roles that
were used for a signature under review activity [191].

Sign a baseline electronically
Adding an electronic signature lets users see items that are approved or revoked. For example, if you
want to sign and approve a review.

1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then select
View details.
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2.

3.

Select Add signature.

In the Electronic signature window, enter your username, password, and any optional comments,
then select Save. Username and password must match that of the logged in user.

If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.

Electronic signature
Your full name: Signature date and time:
Baxter Flogeets 12/04/2019 09:52 pm

To complete your electronic signature, please enter your username and password.

Username:

Password:

Comments:

Cancel
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Manage content

Use these features to plan, organize, track progress and impact.

* Compare versions [231]

+ Change requests [232]

* Releases [236]

+ Baselines [239]

» Coverage and Traceability [253]
* Reuse and synchronization [276]
» Exports [298]

» Categories [311]

Item versions

A new version is created each time you make changes to an item. In the bottom panel you can compare
versions [231] or make a past version current [231].

When viewing item versions, you can see Baselines that were created when that version was active,
any automatically generated Change details, any user comments applied by the person who made the
changes, as well as the date and name of the person who made the changes.

Item versions quick find
In Single Item View, select Versions in the side toolbar to open a list of item versions in the bottom
panel.
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The current version number appears below the item name and in the small blue circle on the Versions
button.

Make a past item version current

When you make a past item current, the system creates a new version that's identical to the version
you chose. By doing this, you don't lose access to past versions.

All pick list values that existed at the time the previous version of the item was active are restored, even
if that value was removed as an option for new items.

1. Select Versions to open the bottom panel in Single ltem View.

2. Find the row that contains the item version that you want to make current and select Make
Current.

NOTE

You can't make past versions of test cycles or test runs current. For converted items,
you can't revert back to the previous item type using this method.

Compare versions
1. Select Versions to open the bottom panel in Single ltem View.

2. Select the two versions you want to compare using the buttons in the From and To columns, then
select Compare.

231



Jama Connect User Guide

3. Inthe Version compare window, the From version is on the left and the To version on the
right. Changes are displayed inline. Deleted text is red and highlighted. Added text is green and
underlined.

Change requests
Change requests are items that call for a change to product or system.

Change requests don't entail any sort of automated process; they are simply a way to track requested
changes. When an item type is activated as a change request [589], you can add new change requests
and associate them with other items [232].

With change requests you can:

» Use Impact Analysis [235] to determine if and how your change requests affect other items, and
create direct relationships between affected items and the change request.

+ Send a change request to review [153] to gather feedback from stakeholders and determine if the
change request is approved or rejected.

Add a change request and associate items

1. Create a new set in your project called "Change requests" to make them easy to find.

2. Add a new item [66] to that set.

3. Open the item and select Items to be changed. This button doesn't appear unless configured by
an organization administrator [593].
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4. In the bottom panel that opens, select Associate Items. From the list that appears on the right
panel, select which items you want to associate with this change request, then select Associate.
You can also double-click on the item to associate it.

5. The items that you associated appear in the bottom panel with links to those items. Each item is
listed with the Starting version when the change request was introduced and the Ending version
of the item that fulfills the change request.
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o IMPORTANT

If an item has the change request tab enabled, it's a change request. ltems
that are change requests can't be associated with other items that are change
requests.

6. You can edit the association [234] to indicate the starting version when the change request was
introduced, the ending version of the item that fulfills the change request, and additional notes. You
can also run an Impact Analysis [235], delete an association [235], or close a change request [236].

7. When you view other items that were associated with this change request, you see the same
button in the right toolbar of their Single Item View, as well as any change requests they're
associated with in the bottom panel.

TIP

@ When the change request author locks the change request, it can't be edited. This
way the author can moderate the progress of requested items to be changed, can
update associations, or close the change request as edits are made.

Edit change request associations

Edit change request associations to indicate which version is the starting or ending version of a change
request.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.
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2.

3.

4.

Double-click in the row with the item you want to update. You can also select the row, then select
Edit > Update association.
In the window that opens, modify the Starting Version, Ending Version, or Note.

Select Save.

Create change request Impact Analysis

1.

In Single ltem View, select Change Request to open the bottom panel with a list of associated
change requests.
Select the item you want to know more about and select Actions > Impact Analysis.

The Impact Analysis is populated by the items in the change request.

Delete change request associations

1.

In Single ltem View, select Change Request to open the bottom panel with a list of associated
change requests.

Double-click in the row with the item you want to update. You can also select the row, then select
Edit > Update association.

Select Edit > Remove Association.
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Close a change request

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Select the change request you want to close, then select Actions > Close Change Request.

Releases
A release is a group of items that are developed together and mapped to a specific completion date.

Select Releases at the top of the left panel to see all of the releases listed for this project. Select any
release to see the items assigned to it.

If you include items in a release, you are assigning them to that release. If the release field [236] is
visible, you can use Reading or List View to see the name of the release to which an item has been
assigned.

Assign an item to a release

When you assign an item to a release, the item will appear under the Releases tab, and the action will
be noted in the version history.

You can only use the system predefined Release field to show items in the Releases tab. If you use a
custom Release field to designate an item to a release, that item won't appear in the Releases tab.

Before you can assign items to a release, a project or organization administrator must first create the
release. Once the release is created, there are several ways you can assign an item to a particular
release:

» Locate the release field [236] (if it is visible [609]) in Single Item or List View and select the desired
release name from the drop-down menu.

+ In the List or Reading View of your project, select the items you want to add to the release. Select the
Releases tab at the top of the left panel and drag the items into the release.

» Use batch update [72].

» Use round-trip import and export [117].

Release field

The release field is a predefined field [601] with a picklist that contains all the releases created in a
particular project.
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o IMPORTANT

You can only use the system predefined Release field to show items in the Releases
tab. If you use a custom Release field to designate an item to a release, that item will
not appear in the Releases tab.

If you don't see a release field in the item type you are using, an organization administrator can edit the
fields for that item type [598], and make it visible [609].

An organization administrator must also configure pick list values [606] for each release.

Release settings
You can determine what you'd like to see under the Releases tab for your project whether it is the
default settings or your personal settings.

1. Select the Releases tab in the left panel.
2. Select the Release settings (gear) icon.

3. Inthe Release settings window, select Use my own settings or Use my default settings to
determine what you want to see under the Releases tab. You can choose to see only certain
item types, IDs, archived releases or relationships that you want to see. Scroll down to see all the
options for release settings.
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4. Select Apply to apply these settings.
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NOTE

If you are an organization or project administrator, you can configure default settings
under the Default settings tab and select Apply.

Baselines

A baseline in Jama Connect is a snapshot of your project at a point in time. The current version of
selected items — and their relationships — are forever associated with that baseline. A baseline also
captures the state of the selected items, like Draft, Reviewed, and Approved.

Important considerations

* When you add a relationship to a baseline, the version doesn't change.

» Relationships do not change if you replace it with a baseline.
For example, if you have two relationships at the time of baseline version one, make a change to
version two, add a relationship to version three and replace it with a baseline, you still have three
relationships.

+ If you click Revert to Baseline, all content is switched back to the content that was versioned at the
time it was baselined.

What you need to create a baseline

Versioning must first be enabled to create a baseline. Once versioning is enabled [648], a baseline is
created:

» Automatically [248] when someone initiates or revises a review
* Manually [245] by anyone with read/write permissions

Why are baselines important?

By creating a baseline at each project milestone, you can view the status of your project at those key
points in the lifecycle. You can also see which items are related in the baseline list and reading views.

What can | do with a baseline?

* Locate an existing baseline [244]

* Create a baseline manually [245]

+ Compare baselines [247]

* View baseline activity [248]

* Replace current items with baseline [252]

What is a baseline source?
A source is a container that holds all the baselines for a specific group of items.

When you add a baseline for a new group of items, the source is created automatically. Whenever you
add the baseline — from a project, set, folder, filter, release, or individual items — the source is created
in the tree and contains the new baseline. A source can't exist without a baseline.

If a source already exists when a new baseline is created for the same set of items, the baseline is
added to that source. Otherwise, a new source is created and added to the top of the tree.

Key to the baseline tree
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* Green database icon — Source
* White box wrapped in gray — Baseline

+ Individual Items — Default source name when multiple items are selected at the time the baseline is
created.

+ B1-04/27/2020 — Example of default baseline name (baseline number and date it was created).
Baseline name is editable as needed.

Tips and more

+ If you create a baseline from a container, filter, release, or review, the source and its initial baseline
are created. If you use the same source the next time you create a baseline, that second baseline
added to the source under the first baseline.

+ If you create a new baseline from a set and add another single item to it from another set, a source
labeled "Individual ltems" is created.
» Deleting a baseline source deletes all the baselines it contains.

Benefits of organizing your baseline tree
Organize your baseline tree to reflect how your organization works.

Project and organization administrators can reorganize the baseline tree by dragging and dropping
sources and folders.

Organizing baseline sources and folders

» Use drag and drop to move baseline sources from one location to another, from the root level to a
folder, and between folders.

+ Editing a source name creates an event in the project activity stream. In the activity stream, select the
baseline source ID to open the baseline tree and view the highlight.

» Baseline folders can be created at the root level or added to a folder. Use drag and drop to reorder
baseline folders.

* If you hover over an icon or name in the baseline tree, hover text appears describing the contents of
the item.
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Searching baselines, baseline folders, and baseline sources

* When you type a name in the search field, the results are highlighted so you can find them easily.

* When you clear the search field, the results from the previous search are expanded and highlighted
in the baseline tree.

* When you create a folder or baseline, it is highlighted in the baseline tree.

+ If you accessed the baseline from a link or the Explorer Tree hierarchy is collapsed, select Find me
to locate the baseline in the baseline tree.

* When you toggle Show IDs to On, the baseline IDs are displayed in the baseline tree. When the IDs
are visible, you can search for them using the baseline search box.
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* When you select the baseline ID in the activity stream, the source is expanded and the baseline is

highlighted. Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a
signature is revoked.

« Alink is added in the baseline header when a baseline is created from a review or a new revision of a
review. Use the link to navigate to a specific review quickly.

Create baseline folders

Once a baseline is created, the item content can't be changed. You can, however, change the baseline
name and description.

Users with a creator license and permissions for project or organization administrator can create, edit,
and delete an empty baseline folder.
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Anyone with read/write permissions can edit, delete, or restore a baseline that they created. However,
you must have project or organization administrator permissions to edit, delete, or restore baselines
created by others.

» Create a baseline folder using one of these methods:
* From the Add drop-down menu, select Folder.
* Right-click on the folder, then select Add Folder.

Edit a baseline

Once a baseline is created, the item content can't be changed. You can, however, change the baseline
name and description.

Important considerations

* Anyone with read/write permissions can edit, delete, or restore a baseline that they created.

* You must have project or organization administrator permissions to edit, delete, or restore baselines
created by others.

* You must be an organization or project administrator to edit a signed baseline.

1. Select the Baselines [244] tab in the Explorer Tree, then select the baseline you want to edit.
2. You can edit a baseline in two ways:

* Right-click on the baseline and select Edit.

 In the upper right corner of the main panel, click Edit.

3. In the Edit baseline window, enter your changes and select Save.

Your changes appear in the Explorer Tree.
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Locate an existing baseline

When anyone creates or revises a review, a baseline is automatically generated. Knowing where to look
for an existing baseline can be helpful when you want to compare changes in a review that has multiple
versions.

You can find a baseline for a specific project from the Explorer Tree or Single Item View.
Explorer Tree
Use the Explorer Tree to find a baseline if you need to quickly find a baseline.

1. Select the Baselines tab of the project you want to look at.
2. Type the baseline name in the search field. The results are highlighted so you can find them easily.

3. Expand the source to see all the baselines from the same source, then select the one you want. If a
baseline was created from a review, it is preceded by the word "review" in the name.
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4. Select the baseline to view its contents.

Single Item View

Use this method if you know which items were included in the baseline or the review that created it.

1. Open the item in Single ltem View [55].
2. Select the Versions button on the side toolbar [56].

The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.

3. Select the link to open the review or the corresponding baseline. If the review link is disabled, you
weren't invited to the review or the review isn't public.

Create a baseline manually
Create a baseline when you want to capture a snapshot of where items are at in that moment.

NOTE

You must have a creator license and read/write permissions to manually create a
baseline.

1. Inthe Explorer Tree, select the Baselines tab in the project where you want to create the baseline.
2. Add a baseline using one of these methods:

+ If the item already has a source, right-click on the source and select Add baseline.
+ If you need to choose items, select Add > Baseline from the top.
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NOTE

If the items from an existing source were deleted, you can't add a new baseline
from that source.

3. In the window that opens, click a tab (Item selection, Releases, Filters) and select containers or
individual items in that tab. You can select containers or individual items, but you can select from
only one tab.

4. Click Create.
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5. (Optional) Change the default name for the baseline and add a description.
Add baseline

MName: B11 - 01/05/2022

Description:

218 item(s) Save Cancel

6. Select Save to create the baseline.

The new baseline is added to the tree, either under and existing source or to the top of the tree.
Baselines are always listed in the order they were created.

Tips and more

» Baselines are created automatically [248] whenever anyone creates a review.

* Project versioning must be enabled [648] to be able to create a baseline.

* All upstream and downstream relationship information from items included in the baseline scope are
also included in the baseline snapshot, even if those upstream or downstream items aren't part of the
baseline scope. This functionality is limited to relationship direction, item name, and item ID.

Comparing baselines

You can compare baselines to see if an item changed since the last baseline, and what those changes
were.

Two default reports analyze baselines to show changes over time:

» Baseline Comparison [361] compares two baselines.

» Baseline Compared to Current [359] compares the items and relationships from a baselined version
to the current version.

There are several ways to compare baselines:

» Select the Baselines tab in the Explorer Tree, then select the baseline you want to view.
(Optional) In List View, select the gear icon (Show/Hide) to open the drop-down menu, then select
Current version and Version to display those columns.

» To view the version of an item that was baselined, select the row, then select Preview item.

» To compare a baselined item with the current version side-by-side, select the row for that item, then
select Compare with current in the top right.
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Tips and more

+ To see the current state of the item, select any Global ID [278] or Unique ID [637] in List View.

View baseline activity

Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a signature is
revoked.

1. Select the Baselines tab, then select the name of the baseline that you want to view.
2. Select View details.

The baseline activity stream is visible at the bottom of the center panel.

Locate review baselines

When anyone creates or revises a review, a baseline is automatically generated so that you can
compare changes between reviews.

You can find automatically generated review baselines in two ways:

» Select Baselines in the Explorer Tree of your project.
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Baselines that were automatically generated for reviews are displayed with the word "Review" pre-
ceding the name of the review.

* If you know the items that were included in the baseline (or the review that created it):
1. Open the item in Single Item View [55].
2. Select Versions in the side toolbar [56].
The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.
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3. Select the link for the review or its corresponding baseline. The link is enabled only if you were
invited to the review.

Sign a baseline electronically
Adding an electronic signature lets users see items that are approved or revoked. For example, if you

want to sign and approve a review.

1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then select
View details.

2. Select Add signature.

3. Inthe Electronic signature window, enter your username, password, and any optional comments,
then select Save. Username and password must match that of the logged in user.
If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.
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Electronic signature
Your full name: Signature date and time:
Baxter Flogeets 12/04/2019 09:52 pm

To complete your electronic signature, please enter your username and password.

Username:

Password:

Comments:

Cancel

Deleting sources and baselines
Delete a source or baseline if it was created by mistake or you no longer need it.

Things to know

* Deleting a source deletes all the baselines it contains.

» The option to delete a baseline or source that contains a baseline is only enabled for baselines
that are not yet electronically signed. However, deleting a project [630] deletes all project content,
including baselines and signatures.

NOTE

You must have project or organization administrator permissions to delete sources and
baselines.

Delete a source

* Right-click on the source you want to delete.
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Delete a baseline
Delete a baseline from the project using one of these methods:

» Select the baseline, then select Delete (trash icon) in the top right.
* Right-click on the baseline name, then select Delete.

Tips and more

* Undo — If you change your mind after deleting a source or baseline, you can select Undo in the
success notice.

* Restore — You can restore a deleted baseline or source by finding the deletion activity [209] in
the projects activity stream and selecting Restore. If you deleted a source that contains multiple
baselines, you can restore individual baselines or the source and all its baselines. When you restore
a baseline or source, this event appears in the baseline activity stream.

» Limitations — You can't edit or delete a baseline that is electronically signed. You also can't delete a
source if it contains an electronically signed baseline.

Replace current items with baseline

When you replace current items with a baselined version, a new version of the item is created and
content is replaced with the baseline content. No versions are lost.

Important considerations
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+ Items that were deleted are restored to the version at time of the baseline.
* Relationships that were deleted aren't restored.
* You can update an individual item from the versions tab in Single ltem View [230].

NOTE

You must have project or organization administrator permissions to do this.

1. Select the baseline you want to revert in the Baselines tab of the Explorer Tree [244].
2. Select Replace with baseline.

3. In the confirmation message, click Yes.

A pop-up message displays the number of items that were updated.

Coverage and traceability

Traceability shows the relationship between items that depend upon and define each other. You can
always travel upstream or downstream to get more context and trace product definition from high level
requirements all the way through final tests.

Coverage is the extent to which items are validated by another item.
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By relating items [260] according to a set of relationship rules [614], you can assess the impact that
changes can have on other items. View items in Trace View [52], or use the following options to analyze
item relationships and be sure you have the coverage you need.:

* Relationship Status Indicator [269]
» Trace Matrix [272]

* Impact Analysis [273]

* Coverage Explorer [274]

Trace View
Trace view shows related upstream and downstream items, missing relationships, and item details in
context of their relationship.

When you select Trace View, the items you selected in List View are displayed in the Source column.
Related items downstream from the source are displayed to the right. ltems upstream from the source
are displayed to the left. Use the blue arrow buttons on either side of the screen to travel up or
downstream.

The top of each level column shows a count of the item types found on the entire level.

S NOTE
The item count is a unique count. If the same item is downstream of multiple items
in the source column, it appears multiple times in the "1 level down" column, but it's
counted only once.
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Select an item in the source column to highlight its specific upstream and downstream relationships.
You can select multiple items using the checkboxes. Selections remain highlighted as you navigate.
Select X to clear your selections.

Select Set columns at the top of each trace level to turn fields on or off [54] for items in that level.

Use Trace View to find missing coverage and use the Add menu in the toolbar to add items directly from
this view.

You can also filter Trace View [258] or use Trace View to save a view [256] or export the content [257].
You can also use the Trace View to see validation and verification testing results. If a test case is visible

in Trace View, you also see the related test runs. No manual creation of relationships is required; Trace
View infers the relationship between test cases and runs and once a test cycle is created.
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If your organization has a risk management license, you can also configure this view [54] to see risks in
Trace View. [423]

Save a Trace View
After you save a Trace View, you can change the name and save it as something else. You can also
bookmark it.

1. Select the Trace View [52] that you want to save, then click Save.

The name text box becomes an editable field.
2. Edit the name as needed, then select Save (checkmark icon).

3. (Optional) Select the arrow next to the name to see a pull-down list of saved Trace Views. Book-
marked views appear at the top of the list.
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Bookmarked Trace Views are visible from your homepage; use the URL to share this Trace View
with other users.

Export a Trace View

When you export from Trace View, the result contains all data that traces from the columns currently
visible on your screen to the Source column.

0 IMPORTANT
When you export a Trace View, it can be no more than 6 levels. If you try to export a
Trace View that exceeds 6 levels, the Export button is grayed out.

1. From the Explorer Tree or an advanced filter, select the items you want to export, then click Trace
view.

2. Navigate to the furthest level upstream or downstream that you want to export, then click Export.
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3.

Click OK to open the CSV file.
Select the down arrow in your browser to view the available downloads.

Filter Trace View
You can filter items in Trace View by item type.

1.
2.

3.

Open the items you want to filter in Trace View [52].

If more than one item type exists in a column, you can select Filter items at the top of the column
you want to filter.

In the window that opens, select the items you want to see.

A number next to each item type displays the total count of unique items to filter for that item type
in that column.

After the filter runs, a message at the top of the page lets you know how many levels and how
many total item types were filtered. Select X to remove all filters.
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5. You can save the Trace View [256] or export the Trace View [257] with filters in place.

Relationships

Relationships link items together and can help assess the impact an item or group of items can have on
other items.

Traceability is defined by relationships. When one item changes, you know to check related items to
make sure they are still correct.

Relationships can be upstream or downstream from an item. With the appropriate permissions [269],
you can relate items within the same project or between projects. Find and view relationships [259] in
Single ltem View.

You can also add relationships from:

+ Single ltem View [260]
 List, Reading or Trace View [263] (by adding a new related item)
* The trace matrix [263]

Relationships quick find

In Single Item View, select Relationships to open the bottom panel where you can view and filter [267]
related items.
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Select Visual Layout to see a different perspective with links to more rapid actions.

Add a relationship from Single Iltem View

Creating a relationship establishes a directional link between two items. The related items can exist in
the same set or project, or in completely different projects.

1. Select Relationships in the side toolbar, then select Relate Items in the bottom panel.
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This opens the side panel where you can select the items that you want to relate. Recently viewed
items is the default view, but you can also choose the Explorer Tree, Releases , or Search tab to
find the items you want to relate. Double-click on the item, or select the item you want to relate and

select Relate.

@ NOTE
If you don't have rights to a linked related item, you can still see the related item’s
name, project, and relationship attributes. However, you can't preview, open, or
edit the item if you don't have permission.
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o IMPORTANT
If relationship rules [614] were applied to the project, only items that meet the
rule's criteria appear in the right panel. You can only create a relationship with item
types that meet the applied relationship rules. Select Show relationship diagram
at the top of the right panel to display the rules that are associated to this project.

3. Arelationship is added to the selected item in the direction defined by the rules and is immediately
visible in the bottom panel. If the new relationship isn't defined in the rules, you are prompted to
define the relationship direction and type.
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TIP

@ If you have multiple relationships to define between the same item types, you can
select Don't ask again. During your session, all relationships between these item
types are automatically set up the same way.

Add a relationship from the Trace Matrix

1.

2.

3.
4.

Select Projects in the header, then select Project > Traceability > Trace Matrix.

In the Trace Matrix window header, select the two item types you want to compare, and limit the
number of items you want to see, then select View Matrix.

Double-click in any cell where you want to add or edit a relationship.
In the Add/Edit Relationship window, make changes and select Update.

Add a new related item
You can add a new item and, at the same time, relate it to one or more items.

1.
2.

View the items to be related in List View [51], Trace View [52], or Reading View [52].

Select the items to which you want to add related items. To use the Add related option, all selected
items must be the same item type.

Select Add> Add related in the top right toolbar. From the drop-down menu, select the item type
for the missing upstream or downstream items you want to add. The drop-down menu lists only
item types allowed by relationship rules.
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4. In the Relationship settings window, select the direction and relationship type for the item you
want to relate, then select Create relationships.
+ Direction — Upstream or downstream.
* Relationship Type — Configured by an organization administrator [611]. Common examples
include: related to, dependent on, derived from, validated by, verified by, or mitigated by.
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5. In the Add Item window, enter details including name and description, then select Save.

6. Inthe Select Location window, you must select a location for this new item. Locations that aren't
permitted appear in light gray. You might need to expand folders, sets, or components to find the
location you want. Select a location, then Select and close.
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7. If you checked the Notify option in the Add Item window, you can notify other groups or users of
this new related item.
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Relate two locked items
As part of your workflow, you can relate two existing locked items.

NOTE

You must have organization admin permissions to complete this task.

1. Configure relationships [611] for your item types.
2. Select Admin > Organization, then select Relationships.

3. Inthe Relationship Options section, click Edit.
4. Select Allow relationship changes between two locked items.
5. Click Save.

You can now relate two locked items.

Filter relationships

You can filter items related to a single item. For example, you might want to view only the test cases or
use cases related to a requirement. The filter is stored until the end of your session, so as you move
from item to item, the filter remains in effect.

1. In Single ltem View, select Relationships in the side toolbar to open the bottom panel.
2. Select Filter in the bottom panel toolbar.

3. In the Relationships filter settings window, choose your own settings or the default settings,
scroll down to see all the options, then select Apply.
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4. You see the results filtered out in the bottom panel, select Filter Applied-Click To Restore
Defaults to release the filter and see all related items again.

Relate to an existing item
You can relate two existing items of the same item type.

1. View the items to be related in List View [51], Trace View [52], or Reading View [52].
2. Select the items to relate. All selected items must be the same item type.
3. Select Relate to existing.

4. In the side panel that opens, select the items that you want to relate, then click Relate.

Recently viewed items is the default view, but you can also use the Explorer Tree, Releases,
or Search tab to find the items you want to relate.
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A relationship is added to the selected item in the direction defined by the rules and is immediately
visible in the bottom panel of the relationships [259] view. If the new relationship isn't defined in the
rules, you are prompted to define the relationship direction and type.

Tip: If you have multiple relationships to define between the same item types, you can select Don't
ask again. During your session, all relationships between these item types are automatically set up the
same way.

Access permissions and relationships

How you interact with relationships depends on the access permissions you have for each of the related
items. Read more about permissions [578].

If you have and these ac- you can....
these access per- cess permis-
missions for the sions for the re-
current item... lated item...
Read/Write Read only ... view trace relationships as well as the ID and name of the related item. You

can modify relationships and create new ones. You can also navigate to the related
item and clear suspect links.

Read only or No permission ... view trace relationships, but not modify or create new relationships. You can see

Read/Write the ID and name, but can't navigate to the related item.

Read only Read/Write ... view trace relationships. You can modify relationships and create new ones. You
can also navigate to the related item and clear suspect links.

Read/Write Read/Write ... create, modify, or delete relationships as well as navigate to related items.

Read only Read only ... view trace relationships and navigate to related items. You can't create or modify

relationships between the two items.

Relationship Status Indicator

The Relationship Status Indicator shows how many relationships an item has, as well as whether those
relationships meet the project's relationship rules.

The Relationship Status Indicator is visible in the Relationship button of the side toolbar [56], as well
as in a column in List View (when configu