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Welcome to Jama Connect

Jama Connect is a centralized web application that helps you manage the development of new technol-
ogy products. It manages all aspects of product requirements. Jama Connect also records test results
and manages risk while maintaining regulatory compliance.

As a new user or trial user, read through this section to learn how Jama Connect can change the way
you work and can enhance your product development process. We want to answer all your "What do I
need to get started?" questions.

This information isn’t linear — feel free to scan through and jump to the different areas that are most
interesting to you.

The right tool at the right time

 

This guide contains information about a self-hosted release of Jama Connect. If you're a system admin-
istrator new to Jama Software you can skip straight to the system administrator section [468].
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Get started

To start using Jama Connect, you need your user account credentials.

• Trial account
Sign up for a free trial at https://www.jamasoftware.com/platform/jama-connect/trial/

• New user account
Your administrator has your account username and password.

As a new user of Jama Connect, this is the place to start: log in and get familiar with the different areas
of the workspace.

To log in to Jama Connect:

1. In a supported web browser, enter the URL provided by your administrator.
2. Type your username and password, then select Log in.

Header — Includes the main sections of the Jama Connect interface.
Homepage — Shows links to your most relevant content like bookmarks, recent views, open views,
stream comments, and actions.

Tips and more

• You're allowed 10 login attempts within five minutes before you're locked out for 30 minutes. To un-
lock your account before then, follow the forgotten password procedure.

• To manage your account, select your name in the top right navigation to open the My Profile window.
• To log out of the application, select Log Out in the top right header. If you don't log out, the default

timeout is two hours.
• Bookmark projects, containers, sets, and folders so they appear under Bookmarks and Recently

viewed sections. Having it appear in both places allows you to keep track of recently viewed items
even if you remove the bookmark.
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Exploring the Jama Connect workspace
The Jama Connect workspace is where you set up and manage your projects, create test plans, com-
municate with your team, track relationships, and more.

You can also view these short videos to learn the Jama Connect basics: how to navigate the system,
add and edit information, build in traceability, send information for review, and collaborate with your
project team.

The workspace is divided into five panes that you can expand, collapse, and resize.

1. Explore and manage projects — Select the tabs at the top of the left panel to expand these views:
Explorer, Filters, Releases, Baselines, and Test Plans.

2. View item details — View the details for specific items. Content from Components, Sets, Folders,
Filters, and individual items are located in this pane.

3. Create trace relationships — Add relationships for traceability or items within a change request.
Open this section from the Relationships tab and close when it's not needed.

4. Manage item information — Manage information associated with comments, relationships, attach-
ments, versions, and activities.

5. Use keywords to navigate the workspace — Use the tags cloud to navigate to items grouped by
keywords.

Jama Connect is highly configurable, so you can customize the workflow that works best for you. For
example, focus on creating requirements from the Explorer Tree, view details about a test case, or ex-
plore relationships. Depending on the task or goal, you might interact with one area or all areas of the
workspace.

Navigation

These links can help you find your way around Jama Connect:
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• Explorer Tree [46]
• Toolbar [49]
• Side toolbar [57]

Views

You can choose how you view your selected items in the center panel. Each view is suited to different
types of work.

• Single Item View [56] — Displays the information about one item in the center panel.
• List View [52] — Shows data from multiple items in a table with a different field in each column so

you can sort, select, and compare items at a glance.
• Reading View [53] — Shows both text and images for a particular group of items so you can read

through selected items like a document.
• Trace View [53] — Shows related upstream and downstream items, missing relationships, and item

details in context of their relationship.
• Compare View [58] — Shows side by side content so you can compare differences between differ-

ent item versions.

Project approach and tree structure
Jama Connect is made up of projects and uses a tree approach, which allows users to easily organize
content and view the content of each project.

What is a project?

Think of a project as a virtual container or “workspace” of information. Each project relates to a product
you are creating or a software application you are developing.

Why have a project?

Projects allow you to organize content and apply permission schemas. For example, a user might be
able to create and edit requirements in Project A, but might not be able to see content in Project B.

Projects are created by the Jama Connect admins at your organization, who also control corresponding
permissions for each project.

At a high-level, each Jama Connect environment can contain multiple projects. Typically, a single
project in Jama Connect relates to a single product or a single version of a system that you are building.

Monitoring your project

Within a Jama Connect project, you can track releases/phases, baselines, test plans, and results. You
can also create a project dashboard to track the data your team wants to monitor for quality and pro-
gress.
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How do I access my project?

To open a single project, click Projects in the header. If you’re already in a project, select Change
project to switch to a different project.

Advantages of projects and tree structure

Jama Connect projects and the Explorer Tree are highly configurable, which allows your organization to
adapt the solution to fit your own unique hierarchy and development process.

We also have several templates to get your team started. This allows your organization to:

• Standardize methodology across different teams
• Decrease context switching when working across multiple projects
• Enable reuse of shared requirements

Organizing your content

Each project has its own Explorer Tree, which displays project items in a hierarchical structure. Think of
the tree like your filing cabinet.
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Within the Explorer Tree you have access to several tools to organize your content:

• Component — A structural container used to organize a project into more manageable pieces.
For example, if our project represented an automobile, typical components in our Jama Connect
project might be: “Vehicle Airbag System” or “Emergency Braking System.” Underneath these compo-
nents are all the requirements and test sets that make up these subsystems for a car.

• Set — A container that defines groups of items of a single item type. Sets can exist at the top of
projects or beneath the components.
For example, in our “Emergency Braking System” component we might have a set of “System Re-
quirements” and a separate set of “Verification Tests.”  Typically documents such as a Product Re-
quirement document or Functional Requirement specification translates in Jama Connect as a set.

• Folder — A way to organize items within a set.
• Items — The granular types of content in Jama Connect.

For example, a single Requirement is an item. A single Test Case is an item. You can configure multi-
ple item types in Jama Connect.

Learn more about projects and Explorer Tree

• Projects at a high level [616]
• Configure Explorer Tree settings [47]

Item-based product development
Jama Connect is a database-driven, item-based product development platform.

Why do we use items instead of documents? Several reasons:

• Version control — Track changes and feedback at an individual item level, whether the item is a re-
quirement, a risk, a test, or even project documentation.

• Data integrity — Quickly search, filter, and create dashboards to view progress based on item attrib-
utes. Documents don’t allow for this and often have data integrity issues.

• Time savings — Save time by not having to manually maintain IDs and trace links in a document. In
Jama Connect, traceability is a by-product of the way you work.

• Review efficiency — Focus on smaller, more iterative item reviews. Users no longer have to wait for
entire documents to be submitted before they can provide feedback. Get to market quicker!

• Auditing quality — With a few clicks, identify items that are missing coverage throughout the prod-
uct development process.

The shift from a document-based approach to an item-based approach is key to enabling the value of
Jama Connect. Your team's methodology directly influences how you set up and configure your Jama
Connect environment with different item types.

The diagram below illustrates how to shift from a document-based approach to an item-based approach
using Jama Connect.  

• Identify the documents and content that need to live in Jama Connect.
• Determine the item types that exist in those documents. For example, item types could be System

Requirements, Use Cases, or Test Cases. Item types must have defined relationships in Jama Con-
nect, which you can specify using a relationship rule.

• Configure a project structure, then import your existing documentation or start authoring in Jama
Connect.

With an item-based and data driven workflow, you can configure a project structure, then begin author-
ing in Jama Connect. You can either import existing content or author directly in the application. You
only need to export documents as needed.

Jama Connect User Guide

13



The following diagram* is a typical relationship model in Jama Connect that adheres to a Systems Engi-
neering Methodology (SEM).

* Box = single item type. Lines = relationships

Your team's development methodology comes into play here, for example classic vs. agile methodolo-
gy. While some teams use only one method, many teams use a combination.

Each method might use different terms. For example:

Classical Systems Engineering System Requirement

System Architecture

High-Level Requirement

Low-Level Requirement

Agile Strategic Themes

Epics

User Stories

Traceability from Requirements to Test
Traceability shows the relationship between items that depend upon and define each other. You can al-
ways travel upstream or downstream to get more context and trace product definition from high level
requirements all the way through final tests.

Relationships in Jama Connect are established between discrete items. For example, Stakeholder Re-
quirement A is related to System Requirement X.
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Benefits of establishing relationships

Why are relationships important in Jama Connect?

• Allocation — Understand which systems and subsystems implement the requirements.
• Traceability — Break down high-level requirements into more detailed specifications.
• Verification — Prove implementation and quality by linking requirements to tests and their results.
• Impact analysis — When requirements change, identify and understand the ripple effect to lower-

level requirements and testing.

Relationship rules are applied to projects to drive compliance to your organization’s model and method-
ology. Setting up relationship rules for your item types is critical because it enforces the methodology
your organization wants to use in Jama Connect.

Jama Connect uses the terms “upstream” and “downstream” to describe relationship direction. When
upstream items change, their downstream items are flagged as “suspect” so that you can review any
impact the change might have.

How to establish a relationship:
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1. Navigate to a single item in your project such as a user need or a requirement.
2. Click Add related and select the item type you want to add.

Jama Connect opens a new window where you configure the item relationship.
3. Click Save and Close.

The original item (Requirement) and the new item (Verification) are now linked with a trace relationship.

View and add relationships
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• To view relationships, click the “Relationships widget in right corner of the item.
• To add more relationships, click Relate items.

To learn more about adding relationships, see: Relationships [256]

What's next

Once you have established relationships, the Trace view in Jama Connect is a great way to view a live
trace matrix [268]. You can also filter and extract views of your traceability.

Trace view:
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Tracking changes in your project
Being able to track changes is critical throughout product development, including details and context
that led to the change, specific version differences, and stakeholders involved with the changes. Jama
Connect gives you the ability to capture all of these details.

Jama Connect has two effective ways to track changes:

• Versions — Capture change at an “item” level. For example, a single requirement might have multi-
ple versions as well as associated change comments.

• Baselines — Capture a point-in-time snapshot of a group of items. For example, if you want to pre-
serve a version of an entire Jama Connect project or “set” of approved items, you can create a base-
line.

Version changes

A new version is created each time you make changes to an item. In the bottom panel, you can com-
pare versions or make a past version current.

Changes to a single item

In the following screenshot, you can see how Jama Connect compares differences between multiple
versions of an item. This engineering requirement has two versions. In the bottom panel, you can also
see who made the change, any change details, and, if added, any change comments. Get the complete
context of change from just this one screen!
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Version Compare view

This next screenshot shows the differences between two versions of a requirement. Individual field dif-
ferences are shown and highlighted* in red and green, making it easy to see what might have changed.
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* Red = content that was removed. Green = new content added.

Changes to several items in a baseline

This next screenshot shows a baseline in Jama Connect, which is a snapshot of several items.

Baselines can also change over time as new requirements are added, removed, or updated. Jama Con-
nect provides users with the ability to track these changes between different baselines through out-of-
the-box reports.

How reviews work
Ever feel like work is harder than it should be? Multiple revisions of a document get emailed around;
conflicting or out-of-sequence feedback on shared documents; expensive time-consuming review meet-
ings: sound familiar?
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Jama Connect alleviates these pain points with its review features.

• Everyone is automatically placed in the latest revision.
• Reviewers can simultaneously log their feedback and approvals.
• All feedback is in sequence with document revisions.
• It’s easy to filter and view only the items that need additional review or feedback.

Reviews are critical to improving requirements and test quality and in increasing the shared understand-
ing among the teams who are engineering and implementing the requirements. Most item types in Ja-
ma Connect can be sent to a review.

Review roles: who does what?

• Moderator — Content Owner. Starts the review and facilitates the discussion.
• Reviewer — Contributes to the discussion.
• Approver — Signs off and approves items that are in review.

Who can start a review?

Users with Creator license and permissions to author and edit in the project can start and moderate a
review.

What's involved in a review?

Here’s what a typical workflow looks like.
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1 Define what gets reviewed Before starting a review, determine which set or folder of items you want to send for re-
view. A review doesn’t need to be for an entire document. It can be for particular sections
only, which allows for a more agile and iterative review. In addition to location, a review
can be started from a filter, release, baseline, or test plan.

2 Start the review If leveraging Jama Connect workflow functionality, make sure the status of items is set to
“Review:” right-click on the location in the Explorer Tree and click Send for review. If
you’re starting from a filter, release, baseline or test plan, right-click the Filter/Release/
Baseline/Test Plan name and click Send for review. Jama Connect loads the review setup
wizard, where you can configure the review deadline and invite Reviewers and Approvers.

3 Monitor progress the review is initialized, Reviewers and Approvers receive an email invitation to participate.
They work concurrently, adding comments and marking items as “Approved” or “Rejected.”
As a moderator, you can track participant progress and respond to comments.

4 Incorporate changes As the moderator, you incorporate edits based on feedback from the participants.After in-
corporating changes, you are prompted to publish a new revision of the review.

5 Close the review Reviews close when the review deadline is reached or when the Moderator closes the re-
view manually (Action > Close Review).

Reviews can always be reopened to publish new revisions and review what has changed.

Best practices

• Facilitate a review before Requirement is moved to “Approved” or “Rejected” status.
• Focus on small, iterative reviews with fewer than 200 requirements per review. A large requirements

doc can be hard to consume.
• It’s OK to have lots of review revisions; approvers are always placed into the “latest” revision.
• Offer guidance on the type of feedback you need.

Create a review

You can create a review for any group of items in a project. And you can start a review from several
places in the Jama Connect interface.

Regardless of where you begin, the process is the same through an easy-to-follow wizard.
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Let’s start from Reviews in the top navigation.

1. Select Reviews, then select Start a review.

The wizard opens to the Definitions page.
2. Follow the prompts in the wizard to define your review:

3. Click Initiate review.

Learn more about reviews

For details about how to create and use reviews, explore these topics in the User Guide:

• Review moderator [156]
• Compare versions [185]
• Filter or search the review workspace [182]
• Organize and find review comments [180]
• Review Education Resources from Community site
• Review Center FAQ from Community site

Exporting documents from Jama Connect
While Jama Connect alleviates many of the pain points around managing documents, you might still
need to create documents to share with your customers, quality teams, or auditors.

The basics

With Jama Connect, you can easily create documents using our standard export to Word and Excel or
by creating your own custom office templates.

The items that appear in your Jama Connect view are exported:
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Beyond the basics with Office templates

If you need more than what the default Office templates provide, you can customize a template to suit
your project. For details about how to create a custom Office template:

• Exports [294] (User Guide)
• Word Template Guide (Community)

Advanced reporting

If you require more control over the report output than Word templates provide, you can use an ad-
vanced reporting tool like BIRT or Velocity.

Here are some common scenarios for using an advanced reporting tool:

• Ordering of documents — Word templates always arrange your included items in the same order
that they appeared in Jama Connect when you generated the export. If you need like items to stay
together or certain item types to always be displayed before other types, you need to use a custom
export.

• Style formatting — Although Word templates support basic text formatting like bullets and text deco-
ration, they don’t support control for page formatting options like section breaks or custom page num-
bering. BIRT and Velocity exports provide a broader level of control than Word.

• Multiple levels of relationships — Default Word templates can export relationships one level up-
stream or one level downstream. BIRT and Velocity both allow more access to follow relationships
and tree structure through multiple levels.

• Conditional logic — BIRT and Velocity both allow more control over when and where to display in-
formation. If you want to display an item’s status, but only if it were created more than 30 days ago
and has an upstream relationship to a Feature, you need to use an advanced reporting engine.

For more detailed information about advanced reporting:

• Introduction to Advanced Reporting (Community)

Dashboards

You can configure your projects to show key metrics to quickly see what needs attention.  Typically,
dashboards are used to:

• Monitor progress (for example, status of Requirements or Execution Results of a Test Cycle)
• Audit progress (for example, show the count of items that are missing a critical data point or process

step)

To access the dashboard, select the project name in the Explorer Tree.
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As an administrator with organization or project permissions, you can customize dashboards per project
(not per user).

Customizations include:

Filter results Displays the results of an existing filter.

Assigned to me Displays a list of items "assigned to" the current user.

Bar chart Displays the results of an existing filter as a bar chart.

Recent activity Displays a line graph of recent activity over a period of time.

Pie chart Displays a pie chart for a filter and field that the user selects.

Activity stream Displays the current activity stream of the project. View all current activity including comments, edits
made, new items created, and assignment changes.

Project summary Displays a summary of the entire project, including total number of items in the project, number of days
until next release, and number of days until project completion.

Rich text Displays user defined text, images, diagrams, and equations.

Recently viewed Displays the last 15 items viewed by the current user.

Relationship diagram Displays the relationship rules applied to the project.

Testing
Do you need to validate and verify your product? Or maybe you need to create a report that shows the
connection between regulations, requirements, and tests?

Then look no further: use Jama Connect test capabilities to guide your teams through the testing proc-
ess, so you can validate and verify your products and systems.

Let's define our terms

Test cases Items that contain the tests needed to validate or verify product features or systems. They contain the
essential information about your tests, and can be organized by project, library, or ad hoc.

Test plans Document that describe the strategy and objective of the test.

Test groups Allows teams to organize test cases within a test plan.

Test runs Item used to record results for a test case you ran against your product.

Test cycles A series of test runs consisting of groups of test cases, that are ready for execution. In a test plan, you
can add a test cycle to help manage and execute test runs.

Defects Testing errors that are logged from test runs and traced to upstream test cases and requirements
through the relationship configuration.

What's involved in testing?

Here's a typical workflow:
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1 Create test cases for your
project

Create test cases that meet the needs of a particular project or multiple projects
across your organization.Test cases describe the specific tests you plan to use and
their steps. Relate test cases to the requirement you’re testing.

2 Create a test plan to test
requirements

Create a test plan that gives an overview of how you want to test requirements.

3 Organize test cases in
groups

Associate the cases you want to use into that plan using groups to organize them.

4 Move groups into cycles Get ready for testing, by moving those groups into cycles where you can see a list
of all the tests you want to run.

5 Execute test runs and log
defects

Execute the test runs and log defects as needed.

6 Get overall test case sta-
tus

Resulting test run statuses roll up to calculate the overall test case status.

7 Generate report showing
results

You can then generate a report showing results, such as the Test Plan Summary
Reporter or the Test Plan Detail Report.

Learn more about testing

• Test cases [307]
• Test plans [317]
• Test groups [320]
• Test cycles [328]
• Test runs [331]
• Defect item type [585]

All about baselines
A baseline in Jama Connect is a snapshot of your project at a point in time. The current version of each
selected item — and their relationships — are forever associated with that baseline.

Why are baselines important?
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A baseline captures the relationship of your selected project components to each other, as well as their
state — for example: draft, reviewed, approved.

A project in Jama Connect can have many baselines. Use baselines as the basis for an export or as a
reference for a historical milestone. By creating a baseline at each project milestone, you can view the
status of your project at those key points in the lifecycle. For example:

• At gate reviews
• Before a reorganization
• Before an import of requirements

Where to create the baseline

In the Jama Connect Project, navigate to the Baselines tab and click Add > Baseline.

Create a baseline (snapshot)

Are you ready to send an item for review? Or maybe you need to capture the current set of require-
ments. Perhaps your project has reached a milestone like testing or approval.

Create a baseline to secure a snapshot of one or several items in your project.

1. Select the Baseline tab from the left panel tabs of your project.
2. From the Add drop-down menu, select Baseline.
3. Select the criteria that you want to include in your baseline, using the three tabs in the pop-up win-

dow:
• Item selection — A copy of the project where you are working. Select your entire project, a sin-

gle set, multiple sets, a single item, or multiples items.
• Releases — If you created a release, baseline one or multiple items.
• Filters — Baseline any advanced filters you created.

4. Click Create. The Add Baseline window appears with a pre-populated name.
5. (Optional) Rename the baseline or add a description.
6. Click Save.

Your baseline is now created and is highlighted under the source where you created it.

Jama Connect User Guide

27



Organize your baseline tree: the basics

Working with baselines is dynamic and intuitive: reorganize, rename, and restructure your tree however
you want. Let’s create a folder or two, then we can arrange them.

Note: You must be a project admin or organization admin to do this.

1. From the Add drop-down menu, select Folder.
2. In the window that opens, type the name of the folder.
3. Click Save.

The new folder is saved at the top of your baseline tree.

Quick tips

• To add a folder to an existing folder, right-click on a folder and select Add Folder.
• To move a folder or a source, drag it to a location in your baseline tree.

Learn more about baselines

For detailed information about baselines, explore more topics in the User Guide:

• Baseline sources [236]
• Baseline organization [237]
• Baseline activity [245]
• Add electronic signatures to a baseline [225]

Reuse and synchronization
Reuse in Jama Connect is much more than a copy/paste mechanism. It’s a full suite of features that
allows for complex capabilities like:

• Maintaining a library of common requirements
• Branching a project to create a variant product
• Comparing differences between a local version of a requirement and its source library version

Reuse and Sync methods are useful for detecting variance and putting a spotlight on the impact analy-
sis across releases and projects. And these methods are useful whether your product keeps the same
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requirements as a previous version; if it integrates and improves on original requirements; or if you in-
clude custom requirements for each product.

To save time and effort for your teams:

• Reuse common product requirements between projects.
• Sync across those reused items to help determine and track variance across projects.

When you use Reuse and Sync within your requirements management configuration infrastructure, you
maximize your requirements resource management. You can modify and evolve existing work quickly
while maintaining your requirement lineage.

Library approach

• A library project houses a collection of requirements maintained by a “librarian” or “curator” (permis-
sions-based).

• The curator of a library can pull differences back into the library when needed.
• Project members can pull and push updates between the project and the library.

Branching approach
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• Projects are branched by project duplication.
• Synchronization is enabled during project duplication and differences are monitored between contain-

ers/items.
• Jama Connect project baselines are created just after duplication. This captures the state of the

project at the time of duplication and is used for baseline comparisons.

Administration
Administration in Jama Connect is primarily used to control the product development process and
users’ access to the data.

Product development process

There is no “one size fits all” process for developing products or applications. Each industry starts with a
template modeled after best practices, but every company can tailor the process to fit their needs.

Here is an example process* used to develop a medical device.

* Boxes = an artifact/document (generically defined as item types in Jama Connect).  

Lines = relationships that enforce traceability between the items.  

Item types = items with configurable fields to record specific details about each requirement,   including
details like ID, Name, and Description. Also include values for capturing data like workflow   status and
validation method, similar to columns in spreadsheet.

User management
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A primary role for administration in any enterprise system is the assignment of licenses and managing
access to data. Jama Connect includes several options to give administrators the ability to fine-tune
read/write/review access to fit their company’s needs.

Learn more about user management

• Licensing [569]
• Managing users [559]

Manage item types
By default, a trial user account is set up with permissions of an organization administrator, which gives
you access to the ADMIN module in the top-level navigation. If you don’t see this, ask your administra-
tor to update your permissions.

Edit an existing item type

1. Select Admin > Organization, then select Item Types.
2. Find the item type you want and select Edit in that row.
3. Adjust the details that your project users can see when working with items.

• Display, Display plural — The name used to identify the item type, for example, System Re-
quirement.

• Type key —The part of the ID that helps users quickly determine the item type of an item. For
example, the default type key for System Requirement is SREQ, so when a user sees an item
with the ID of QR-SREQ-34, they can know at-a-glance that the item is a System Requirement for
that project.

• Use as — Specific functions or permissions for item types configured as a test case or defect.
• Image — An icon to help users quickly differentiate items.
• Widgets — A graphic that shows additional data for the item. The most common widgets are Ver-

sions, Links, Attachments, Relationships, Activities, and Tags.
4. Click Save.

Add a field

Chances are that the fields available in your selected item type are just what you need for your process.
But if you want to add details specific to your organization, you can do that too.

1. Select Admin > Organization, then select Item types.
2. Select Fields from the row of the item type.
3. Select Add Field from the fields’ header for the item type.
4. Select Custom Fields, then select the type of field you want to add.
5. Enter the name you want users to see in Field Label.

The Unique Field Name is pre-populated with a suggestion. This name is used for reporting or ac-
cessing from REST API.

6. Depending on the field type you select, additional options might be required. If prompted, configure
them now.

7. Click Save.
8. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Configure pick lists

Jama Connect User Guide

31



A common field to configure on an item type is a pick list. Pick lists can be reused, and the list you want,
like Priority, might already exist. You can adjust the language or values to fit your needs.

If you need a new list, you can create it before you add the new field to an item type.

1. Select Admin > Organization, then select Pick lists.
2. Find the pick list you want and select Values in that row.
3. Add a new value or edit an existing value:

• New — Select the + icon and enter the value.
• Existing — Select the row and click the pencil icon.

4. Click Save.
5. (Optional) Use the arrow keys in the header to move the field into the order you want on the form.

Managing relationship rules
Relationships are an important part of ensuring compliance and quality. Many industries base their pro-
cesses around the V-Model and need relationships to enforce the traceability through the stages.

Creating the correct relationships can be challenging for users, so Jama Connect gives administrators
the ability to configure rules that help guide users in making the correct connections.

In the previous process example for a medical device, the item type User Need can have two down-
stream relationships: System Requirement and Validation.

To configure these relationships, you use the Relationships option from the left panel.

Upstream refers to the higher-level item type that is affected by the lower level (downstream) item, often
through an activity like testing or decomposition.

Add a new relationship rule

Creating a relationship establishes a directional link between two items.
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1. Select Admin > Organization, then select Relationships.
2. Find the relationship ruleset you want.
3. Scroll to the bottom of the list of rules and select Add relationship.
4. Configure the relationships:

a. Select the Upstream Type.
b. Select the Downstream Type.

Relationship types describe why the relationship between the two items exists. View the pick list
above the rulesets on the Relationships page.

c. Select Yes or No to configure if the relationship is used for coverage.
Note: If you select For Coverage, Jama Connect notifies users if this relationship doesn’t exist.

d. Click Save.

Managing workflow
Similar to relationships, workflow is an important part of ensuring compliance and quality.

Workflow in Jama Connect is highly configurable. In general, workflow is set up on an item type with a
pick list of available statuses. This process guides a user though specific steps, making sure that only
users with correct permissions can make the transitions (by utilizing the Transition Permissions fea-
tures), then locking items from further updates when needed.

For example, when an item is moved from Draft to Approved, it is locked so no changes can be made
while it is in the Approved state.

Add a new transition to a workflow

The best way to understand workflows is to start with a workflow that's included in your collection of
data.

1. Select Admin > Organization, then select Workflow.

2. Find the item type you want and select Config in that row.
3. In the Workflow Configuration section, use the item type and picklist field options to set up and

manage the transitions between statuses.
The Current Status column shows all values for the selected picklist field; the New Status column is
the option you want for the transition from that state. For example, a requirement that is a Draft can
be Approved or Rejected.
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4. (Optional) To add a transition state, select + and configure:
• If users are notified of the change
• If the item is locked when it transitions to the new state
• Any restrictions on who can make the update

5. (Optional) Select - to remove a transition state.
6. Click Save.

REST API and extensibility
Jama Connect offers a powerful REST API that allows your team to integrate and extend the out-of-box
capabilities of Jama Connect.

Typical use cases include:

• Integrating test results from automated test scripts
• Extracting specific data for analysis in Business Intelligence tools
• Automating batch manual tasks

You can see REST API swagger documentation at <your Jama URL>/api-docs/
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Interested in learning how to work with the Jama Connect REST API? The following resources can help
you get started.

• API Cookbook provides recipes for users and partners creating integrations using the Jama Connect
REST API: https://dev.jamasoftware.com/cookbook/

• Jama Connect REST API documentation provides information about the specifics of our API: https://
rest.jamasoftware.com/

ID Description

Project ID Project IDs are unique to Jama Connect. Your administrator sets the default project and set keys.

Example: <project key> - <set key> # <SBX-REQ-1 or SBX-TEST-3>

Global ID Global IDs are used to reference where a requirement or test was reused globally across Jama
Connect projects. The Global ID isn’t unique because several copies of items might be connected
that share the same Global ID.

Example: GID-1234

API ID API IDs are the database identifier for an item and is used by developers when interacting with
Jama Connect from the REST API.

In List View, you can locate the API ID as a column or in the browser URL for the item you’re
viewing in Jama Connect.

Example: 21374

Find Project API ID in URL:

Find Filter API ID, navigate to the filter in Jama Connect and look at URL:

Find Item API IDs:
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Find API IDs in List View:

Jama Connect top tasks
Want to learn more about the Jama Connect tasks that are of highest interest to our users? Based on
research and feedback, we created a table with links to the top areas our users want to know about.
A top task is a common feature that’s frequently leveraged by our users.
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Top task Helpful links

Create detailed requirements Add an item [110]

Create new items

Trace requirements to verifications and tests Traceability from requirements to test [14]

Jama Connect for modern requirements management

Extract information into Jama Connect from documents Import items [60]

Import from Microsoft Word [60]

Import from Microsoft Excel [71]

Import from IBM DOORS [86]

Audit for quality and completeness Item-based product development [13]

Export test cases to Microsoft Excel [315]

Test [307]

Advanced filters [139]

Dashboard [344]

Collaborate with your colleagues Collaborating with your team [194]

Reviews in Jama Connect [153]

Staying connected with the Stream [201]

Electronic signatures [222]

Roles for review workflow [153]

Videos and top resources
Use these videos to get acquainted with Jama Connect and to access additional information and re-
sources.

• Get started with Jama Connect
• Jama Connect Basics
• Jama Community Top Resources
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Setting up your work environment

You can change the settings for your profile and workspace to suit your needs and your project work.

My Profile page

• Add a photo
• Add contact information
• Change your password
• Control subscriptions (email notifications)
• Manage settings for reviews

Workspace

• Customize the Explorer Tree
• View a group of content
• Configure fields

Editing and managing your profile
Your profile is where you change your password, view locked items, and manage subscriptions.

To manage your profile, select your name in the top right navigation to open the My Profile window.

To do this... Select...

Edit your user details Edit settings

Replace your default user picture Edit avatar

Reset your password [38] and you're not using SSO Change password

Set API credentials [39] Set API credentials

Configure your item subscriptions [40] My subscriptions

View your locked items [42] My locked items

View and unlock system-locked items [546] System locked items

Configure your review subscriptions [41] Review Center

Reset your password
You can change your password from your My Profile window or reset it from the login screen.

An organization or system administrator can also reset user passwords [569].

NOTE
If your organization is using LDAP or Crowd authentication, this feature is disabled.

1. Select your name in the header to open the My Profile window.
2. Select Change Password from the options at the top of the window.
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3. Enter and confirm your new password.
Passwords must meet the strength requirements set by the system administrator [498]. To display
tips about which characters are required for password strength, hover over the center of the win-
dow.

4. Select Close.

Set API credentials
To integrate applications and scripts through the Jama Connect REST API [468], you must first gener-
ate API credentials. We currently use OAuth 2.0 authentication to generate pairs of client IDs and se-
crets. This method is often preferred by users and IT security groups over more basic methods that di-
rectly take usernames and passwords.

Important considerations

• To use the API in a self-hosted environment, you need basic authentication for scripts and integra-
tions.

• API credentials like these are only used for safe authentication. User access and privileges set by
your Jama Connect administrator are still enforced.

• For full instructions on how to use API credentials after you generate them, see the developer notes
on authentication.

• You can make a maximum of 20 API credentials; remove the ones you don't need. To do this, select
Set API credentials from the My Profile window.

To set your API credentials:

1. Select your name in the header to open the My Profile window.
2. Select Set API Credentials at the top right of the window.
3. Add a name (required) to help remember why you made these credentials and a short description

(optional) that's easy to understand, like Test Automation Integration.
4. Select Create API Credentials. Jama Connect generates a new Client ID and Client Secret pair

for you to use.
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5. Copy the Client ID and Client Secret right away.

IMPORTANT
The Client Secret is displayed only once, right after you create it. Copy the Client
ID and Client Secret into your application before you continue. If you don't copy
them now, you must create a new Client ID and Client ID.

Configure email notifications and subscriptions
You can subscribe to email notifications [194] to stay up to date on item changes. To receive email noti-
fications, you must configure your profile to receive them.

You can only unsubscribe to notifications that you created for yourself. If you have notifications that oth-
ers subscribed you to, you can’t unsubscribe, but you can mute them.

NOTE
Muting notifications can be disabled by an organization administrator [609].
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1. Select your name in the header to open the My Profile window.
2. Select My Subscriptions, then select the tab with the subscriptions you want to see:

• Me — Subscriptions you created
• Others — Subscriptions that others created for you

3. Define how often you want to receive notifications: use the drop-down menu at the bottom of the
window.
Default is to check for new notifications every 5 minutes.
• Daily — Receive a batch of notifications in a single daily email.
• Weekly — Receive a batch of notifications in a single weekly email.
• Mute All Notifications — Silence all item subscription emails.

NOTE
Muting notifications only affects email subscriptions for items and not other types
of email notifications [194]. 

Configure my review settings
You can follow a review [191] to keep up to date with comments on items in the review.

1. Select your name in the header to open the My Profile window, then click Review Center. 
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2. Configure your settings:
• Enable email updates from Reviews.
• Automatically follow items you commented on.

3. Select Close.

View and unlock locked items
You don't need administrator permissions to unlock items that you locked.

Organization admins can... Unlock other users' items [544]

 View and unlock system-locked items [546] across projects in Jama Connect

Project admins can... Unlock other users' items [544]

View and unlock system-locked items in projects where they are admins

TIP
In Single Item View, you can see who locked an item when you hover over the Edit
button.

Organization and project admins can't unlock system-locked items using the batch up-
date workflow.

To view locked items across projects:

1. Select your name in the header to open the My Profile window.
2. Click My Locked Items to view a list of locked items. 

3. Select the item you want to unlock, then select Unlock in the top right corner of the window.
Note: Organization admins can select Show All Locked Items.
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4. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,
Locked By, and Last Locked.

To unlock your items across projects:

1. Select your name in the header to open the My Profile window.
2. Click My Locked Items to view a list of locked items. 

3. Select the item you want to unlock, then select Unlock in the top right corner of the window.
4. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,

Locked By, and Last Locked.

To lock or unlock items in List View:

1. In List View, select the items you want to unlock.
2. Select Batch edit.

3. In the Batch update window, enable Locked Status, then select one of the following:
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• Unlock all items
• Lock all items

4. Click Next, comment and notify users as needed, then select Commit.
5. (Optional) In List View, select the gear icon, configure which fields are visible, then select Locked,

Locked By, and Last Locked.

The new columns and results appear in the table.

Adding and deleting bookmarks
Bookmarks are links to content you view frequently and are displayed at the top of your homepage.

NOTE
You can use your browser's bookmarks or favorites feature to bookmark any view in
Jama Connect.

Bookmarks remain at the top of the homepage, sorted by most recently viewed. Projects, components,
folders, sets, filters, risk analyses, and Trace Views can be bookmarked for future reference.

You can add bookmarks in two different ways:
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• Bookmark recently viewed content on the homepage — When you view a particular folder, set,
component, or project it will appear in the Recently viewed list on your homepage. Select the empty
bookmark icon for the content you want to bookmark. The bookmark icon changes to a solid icon and
the content appears under the Bookmarks and Recently viewed sections.

• Bookmark Trace Views — When viewing a Trace View that you want to bookmark, you first save the
Trace View [253], then select the bookmark icon at the top of the page. Trace View is now book-
marked on your homepage.
To remove a bookmark, select the solid bookmark icon in the bookmarks list on the homepage. The
content you remove appears at the top of the section.

NOTE
You can also bookmark risk analyses [410]. These are visible for organizations with
risk management licensing, and appear when you select Risk in the header.

Learn more
Here are some ways to learn more about the application:

• Select Projects > Learn more to see a list of in-depth resources about Jama Connect.

• You can see which version of Jama Connect you're using at the bottom of the page or from the login
page if you're using the default authentication.

• View a glossary [659] of Jama Connect specific terms.
• Look for Learn more or the question mark icon throughout the application. You can also select Help

in the top right corner to open the Jama Connect User Guide in a new tab.
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Getting familiar with the Jama Connect interface
The Jama Connect interface is where you work with and manage your projects. It is made up of several
distinct areas, each with its own purpose.

The information in Get started introduces you to the interface. This chapter takes a more detailed look
with descriptions of toolbars and panes in the interface. It also includes instructions for customizing the
Explorer Tree and configuring how you view your projects.

Explorer Tree
The Explorer Tree organizes the sets, components, folders, and items in your project.

How it works

You can drag and drop items between the Explorer Tree and List View [52] to move items [127] and
organize your project. You can also configure settings [47] so that the Explorer Tree displays informa-
tion that's most useful to you.

Jama Connect arranges content by component, set, and folder. Select one to view its content.
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For more information about how to use the Explorer Tree:

• Find an item in the Explorer Tree [151]
• Filter the Explorer Tree [143]
• Move items in the Explorer Tree [127]

Tips and more

• When working with a large number of items — more than 250 items per folder — work with them in
List View instead of the Explorer Tree.

• To move multiple items, you can multi-select in the List View and drag them to their new location in
the Explorer Tree.

Customize the Explorer Tree
The Explorer Tree organizes the sets, components, folders and items in your project hierarchy. You can
configure the Explorer Tree settings so that it displays only information that's useful to you.

1. Select the gear icon at the top of the Explorer Tree to open the Explorer Settings window.
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2. In the My Settings tab, select the changes you want:

• Use my own settings — Overrides the default Explorer Tree settings with your personal set-
tings.

• Use default settings — Returns the Explorer Tree to the default settings. An organization or
project administrator can configure default Explorer Tree settings [627].

• Show item IDs — Displays the unique ID [628] (as in PROJ-REQ-25) before each item.
• Display global ID — Displays the global ID (as in GID-8845) before each item. This can be help-

ful if the item is copied and synchronized.
• Show only folders / hide items — Hides items from view in the Explorer Tree. Components,

set, and folders are still displayed. This can improve performance when your project has a large
number of items.

• Show outline numbering — Displays a number scheme of order and depth in the Explorer
Tree. Root level items have numbers like 1, 2 or 3. Child items contain the parent item number
as well as its own number, like  1.1, 1.2  or 1.1.5.

• Show relationships in Explorer Tree — Displays downstream relationships of items in the Ex-
plorer Tree. Select the green downstream arrow to open the related items in List View.
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CAUTION
Be careful not to relate an item back to itself. You can create an infinite loop that
causes the Explorer Tree to expand. To avoid this, don't relate items in a way
that creates an infinite loop.

3. Select Apply. When you're satisfied with changes, select Close.

Tools for viewing and controlling content
With Jama Connect, you can look at and control your content according to the type of work you need to
do.

• Toolbar [49] — Provides different methods to control and view your content.
• List View [52] — Shows data from multiple items in a table with a different field in each column.
• Reading View [53] — Shows text and images for a group of items so you can read through selected

items like a document.
• Trace View [53] — Shows related upstream and downstream items, missing relationships, and item

details in context of their relationship.

You can also customize fields [55] that control how you view your projects.

Toolbar
The toolbar is located in the center of the workspace. The tools allow you ways to control and view your
content.
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Toolbar options vary slightly depending on your location in the application.

Select... To...

View details See the details of a component, set, folder, or a project overview.

List View Show data from multiple items in a table with a different field in each column.

You can sort, select, and compare items at a glance.

For more information, see List View [52].

Reading View Show text and images for a group of items, which allows you to read through selected items like a
document.

For more information, see Reading View [53].

Filter items Open the filter panel and filter the items you want to see.

A filter limits the group of items or comments by content, like author, keyword, date, or coverage.

Row height In List View, manually adjust the height of the rows.

If you select Extended, rows are formatted to wrap text.

Gear icon (show/hide
fields)

Configure which fields appear for each item in Reading View, List View, or Trace View.

For more information, see Configure fields [55].

Refresh Refresh the list of results and recent changes from other users.
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Select... To...

Add Add items, folders, sets, and components.

Trace View Show related upstream and downstream items, missing relationships, and item details in context of
their relationship.

For more information, see Trace View [53].

Export Export your data to Word, Excel, PDF, or use one of the Office Templates.

Batch edit Update picklist fields and tags for multiple items at a time.

Reuse Reuse [275] when your projects contain items that are the same or similar.

Convert to Change an existing item or items from one type to another.

Batch transition Select multiple items of the same item type and transition them to a different workflow status.

Send for review Send specific items for review.

Note: The maximum number of items you can Send for review is 500.

Relate to existing Relate two existing items of the same item type.
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List View
In List View, you can configure which fields appear as table columns. The table is dynamic — you can
sort, select, drag and drop, and reorder columns.

Tips and more

• If your organization has a risk management license, you can also configure this view [55] to see
risks in List View [417].

• To reorganize columns, select the column header and drag it to the new location.
• To choose which fields you see in the table, you can configure fields [55].
• Use the interactive links (breadcrumb navigation) to find your way around and view the location of

your project hierarchy.

• To sort items, select the column header.

View information about an item.

Move [127] items in a project.

View locked items [42].

View how many relationships an item has, as well as whether those relationships meet the project's relationship rules.
For more information, see Relationship Status Indicator [265].

View and add comments [207].

View and add connected users [221].
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View related items (the relationship between two items). For more information, see Add a relationship from Single Item
View [256].

Reading View
Reading View shows text and images for a group of items so you can read through selected items like a
document.

You can use Reading View in both Projects and Reviews. Click Reading View on the toolbar at the top
of the center panel.

From Projects > Reading View you can:

• View images
• Select individual or multiple items
• Open items
• View hierarchy with numbering
• Drag items to the Explorer Tree to reorder (as long as item type allows it)
• Add comments and view connected users
• Configure fields [55]
• View related items
• Export hierarchical content from an advanced filter [144]
• If your organization has a risk management license, you can also configure this view [55] to see

risks in Reading View [417].

Trace View
Trace view shows related upstream and downstream items, missing relationships, and item details in
context of their relationship.
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When you select Trace View, the items you selected in List View are displayed in the Source column.
Related items downstream from the source are displayed to the right. Items upstream from the source
are displayed to the left. Use the blue arrow buttons on either side of the screen to travel up or down-
stream.

The top of each level column shows a count of the item types found on the entire level. 

NOTE
The item count is a unique count. If the same item is downstream of multiple items in
the source column, it appears multiple times in the "1 level down" column, but it's coun-
ted only once.
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Select an item in the source column to highlight its specific upstream and downstream relationships.
You can select multiple items using the checkboxes. Selections remain highlighted as you navigate. Se-
lect X to clear your selections. 

Select Set columns at the top of each trace level to turn fields on or off [55] for items in that level.

Use Trace View to find missing coverage and use the Add menu in the toolbar to add items directly from
this view.

You can also filter Trace View [255] or use Trace View to save a view [253] or export the content [254].

You can also use the Trace View to see validation and verification testing results. If a test case is visible
in Trace View, you also see the related test runs. No manual creation of relationships is required; Trace
View infers the relationship between test cases and runs and once a test cycle is created.

If your organization has a risk management license, you can also configure this view [55] to see risks
in Trace View. [417]

Configure fields
Choose which fields you see for each item in Projects Reading View, List View, or Trace View.

Tips and more

• All users see the Risk field as an option. However, risk analyses function only if you purchased addi-
tional licensing.

• You can also configure your Compare View for synchronized items [292] or your List View for base-
lines [244].

1. Select the gear icon (show/hide fields) in the toolbar [49].
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In Trace View you can configure fields for each level independently.

2. In the drop-down list, select the fields you want to see. Reading View remembers user selections
for a particular location so they appear across sessions.

3. Close the window.

The table displays your changes.

Single Item View
In Single Item View, you can view specific details about an item. For example, an item's ID, Name, De-
scription, and Status. This view always shows all the fields the item type is configured to include by your
admin.
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You can also edit the item [114] and use widgets [57] to access different areas of Jama Connect.

Here's a high-level overview of some of the features Single Item View offers:

1. Top right toolbar [49]
2. Projects workflow [196]
3. Side toolbar [57]
4. Global ID [274]
5. Breadcrumb navigation (formerly called "Find me") helps you find your way around and indicates

the location in your project hierarchy.

Side toolbar
The Side toolbar appears on the right side in Single Item View. The widgets are buttons that give you
access to different features of Jama Connect. Widgets can be configured by an organization administra-
tor configured by an organization administrator [584].

Select... To...

Relationship Status Indi-
cator

Open the bottom panel where you can see the required relationships for this item and whether the
item follows the project's relationship rules. Suspect relationships [266] are also flagged.

Connected users Opens a window that displays the users directly associated with the item as well as indirectly asso-
ciated with related or traced items. The number displayed is the number of connected users.

Review comments Opens and closes the bottom panel of review comments [180] related to this item. The number
displayed is the total number of comments for this item.
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Select... To...

Comments Opens and closes the bottom panel of comments [207] related to this item. The number displayed
is the total number of comments for this item.

Activities Opens and closes the bottom panel display of activities [207] related to this item.

Versions Opens and closes the bottom panel of item versions [227]. The number displayed is the total num-
ber of versions for this item.

Synchronized items Opens and closes the bottom panel of synchronized items [284].

Child items Opens and closes the bottom panel with a list view of child items [113]. Appears only if the selec-
ted items has child items.

Items to be changed Opens and closes the bottom panel with a list of change requests [229] that might affect this item.

Compare View
Compare View shows side-by-side content so you can compare differences between different item ver-
sions.

To open compare view, select the Version widget in the side toolbar.
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Compare View is used in these areas of Jama Connect:

• Compare versions of reviews [185]
• Compare synchronized items [289]
• Compare item versions [228]
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Create content

Before populating the Jama Connect application with your data, you might want to discuss with others
in your organization which elements of the application you want to use and how you want to use them. 

Typically, organizations create items as requirements, features, use cases, test cases, defects, or other
basic information types that are needed to define the scope of the project or product.

When you're ready, you can:

• Import items [60]
• Create new items [110]
• Add tags [132], links [118], and attachments [133]
• Add images, graphs, and equations with the rich text editor [95]
• Organize with components [105] and folders [108]

Learn more about how to manage content [227] and collaborate [194] once your content is available.

Import items
You can import items into Jama Connect from various platforms including Microsoft Word [60], Excel
[71], and IBM Doors [86]. 

For Excel documents, you can make a round-trip import and export [82] to efficiently add items and
update fields in a spreadsheet format. 

You can also batch create relationships between existing items using the Import Relationships Plugin
[548].

Import from Microsoft Word
You can import items into Jama Connect from a Microsoft Word document. You can use headings, bul-
leted lists, numbered lists, and text formatting to affect how items are imported.

After you prepare your Word document for import [60], follow these instructions to import items with a
Word document [71].

Prepare Microsoft Word document for import
Whether or not you are creating the Microsoft Word document for importing items into Jama Connect,
consider these things to make sure the import goes smoothly.

• Headings and styles [61]
Use Headings and Styles within your Word document to determine hierarchy.

• Tables [62]
When importing, you can use tables in Word documents in three distinct ways.

• Field mapping [69]
The field mapping process is slightly different depending whether you're using headers [61] or tables
[62] to determine hierarchy.

NOTE
Many Word styles are imported, but not all styles are converted exactly. The Data Im-
port Wizard is unable to import a table of contents. Images are included as part of the
import. OLE components, such as embedded Visio diagrams, are imported as PNG im-
ages.
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Set hierarchy with headings and style
When importing items with a Microsoft Word document you can create hierarchies using styles.

• Headings determine the name of the items and place them as parent and child items.
• Normal describes a heading. Jama Connect moves this text to the description field of the associated

item.

For Headings to determine hierarchy, you must use the default Word styles like Heading 1, Heading 2,
Heading 3. You can use up to six levels of hierarchy in Word.

Bullets, bold, italic, and underline keep the same formatting. Numbered lists are imported as bullets.
When the list contains multiple levels, Jama Connect continues to use bullets. However, each set is in-
dented to indicate where the original levels existed.

For example, this Word document includes three levels of headings.

Once imported, they appear as three items on three levels because sub-sections in Word are treated as
child items in Jama Connect.

The Headings serve as the item Summary field, and the normal text style translates to the Description
field. 
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How to handle tables
In the Data Import Wizard, you're asked how to handle tables in Word.

Jama Connect can interpret imported Word tables in three ways:

1. Descriptions might include tables (default option) (example [65])
2. Each table is an individual item (example [62])
3. Each table row is an individual item (example [64])

If you select the default option, select Next. However, the other options prompt you to map fields and
preview the results. Tables in Word can be mapped using only one style. If you're using multiple tables,
they must be of the same Import Style.

If your document includes a heading, the import uses it to create a container for the subsequent items.

Example: Each table is an individual item
Select this option when the document you're importing contains a table for each individual item to be
imported. The table might have more than two columns, but the name of the field must be in the cell to
the left of the field's value.

NOTE
If your document includes a heading, the import uses it to create a container for the
subsequent items.

Here is an example document:
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In the import results, the heading in the document becomes a container in Jama Connect: 
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Each table becomes an individual item:

Example: Each table row is an individual item
Select this option when the document contains a table that contains multiple items to be imported. The
table might have more than two columns, but the cells containing the field names must be in the top row
of the table.

This is an example document:
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These are the results after you import:

Example: Descriptions might include tables
Select this default option when the document you're importing has no tables or the tables hold content
for the description only. You don't need to map fields when using this option.

NOTE
The rich text editor in Jama Connect is most compatible when using a Table Style in
Word and Excel.

Here is an example document:
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Here are the results after import:

Field mapping for tables
If you're not using the default option for tables, you are asked to map fields for tables. 
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1. Copy the exact field names from the tables and paste them into the appropriate Identifier cell.
2. Select default values that are used for all new items that don't have a value in the document you're

importing. Rich text fields can't have a default value. Also, you can't map a workflow field (for ex-
ample: Status).

3. Select Next and review the mapping of the first item found in the document you're importing.
4. If the mapping is correct, select Submit to import the target document. If the mapping is incorrect,

select Back and make the necessary adjustments.

Document scope
Sometimes requirement documents are large and contain sections or items that need to be imported
into different sets, folders, or not at all. With the Document Scope Options, you can mark sections of a
document to be imported or excluded.

If the application detects the file as DOC or DOCX, you're asked to determine the document scope and
to choose field mapping [69] options for the import.
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To set the document scope:

1. Before importing your Word document, decide which sections of text you want to import or ignore.
Open the document and indicate which section or sections of the document to import by inserting
textual tags around the areas. In the following example, only the part of the document located be-
tween the text IMPORTSECTION is included.

2. Select the file for import.
3. In the window that opens, under Choose Field Mappings for Import , select the box next to Im-

port sections surrounded by start/stop text  and enter corresponding start/stop text to indicate
sections to be imported. Select the box next to Ignore sections surrounded by start/stop text
and enter corresponding start/stop text to indicate sections to be ignored. Both options can be used
together. 
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TIP
The examples use the default start/stop text IMPORTSECTION and IGNORESEC-
TION. Jama Connect doesn't restrict the start/stop text to just these two entries. How-
ever, due to Word styles and formatting, we recommend using text that's simple, one-
word, and all caps.

Any words used as start/stop text must not be words that can be included in the docu-
ment's text as content. For example, the word "exclude."

Field mapping
If Jama Connect detects the file to be a DOC or DOCX, it asks you to determine the document scope
[67] and to choose field mapping options for the import. If you're using tables, see field mapping for ta-
bles [66].

Enter the following information in the Field Mapping section:

• Use Name field as description if no description is found
Check this box if your target document has several heading sections with no text included. This op-
tion populates the name and description field with the text found in the heading. This is best used
when the names for the imported items are likely to be updated with shorter names.

• Max length of Name field
Check this box and enter a number of characters to limit the name length. Jama Connect automati-
cally truncates names to 255 characters, so that the names don't overwhelm the explorer and results
list. This option allows the user to further control the name length.

• Default values
The list at the bottom displays Jama Connect item fields, their default value, and an explanation of
how they're being mapped. You can enter a Default value for some fields. However, rich text fields
can't have default values.

Select files for import
The process for importing files includes selecting the files you want to import. Optionally, select the des-
tination and choose the field-mapping layout.
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1. Select the files you want to import:
Right-click on any item in the Explorer Tree and select Import. Your files are imported into the same
level as the selected item. 

2. In the window that opens, select a file to import. Jama Connect evaluates the file type and guides
you through the import. Import doesn't continue if the file isn't recognized.

3. (Optional) Select the following options:
• Destination

If you initiated the import by right-clicking in the Explorer Tree, this field is pre-populated. Make
sure the field correctly indicates where the import places the newly created items. Select the
magnifier to change the destination.

• Select a saved field mapping
Here you can select previously created import configurations that were saved in the project for
the same file type. This is helpful to set up if you need to import multiple documents with the
same field-mapping layout. At the end of a successful import you can save the field mapping for
reuse in the project. Select Delete an existing field mapping to remove any field mapping
saved in the project.

• Optional Encoding
This value determines the character set encoding used during the import. The default setting is
UTF-8, the character encoding used by the Jama Connect database. For most imports you can
use the default.

4. Select Next.
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Word to Jama Connect one-way import

1. Select the file [69] you want to import. If the system doesn't recognize the file extension (DOC or
DOCX) the import doesn't continue.

2. In the window that opens, enter the document scope [67] and field mapping [69] options.
3. If your Word document includes tables, select a table import style. [62]
4. A text-only preview is displayed. Verify that the first item to be imported is correct and select Sub-

mit if you're satisfied with the preview. If not, select Back to make necessary changes.
5. Review the Final Import Summary. You can select Import another file to start again. You can

also re-use the field mapping settings that you used in this import by selecting Save this as new
document mapping. Saved import field mappings can be used by any user in the project where
the mappings are saved. However, the mappings are project-specific so you can't use them from
project to project.

Import from Microsoft Excel
You can import items to Jama Connect from a Microsoft Excel document.

You can use cell coloring and indentation to determine a hierarchy for items imported to Jama Connect.

After you prepare your Excel document for import, you can import items one-way from Excel to Jama
Connect, or you can execute a round-trip import between Jama Connect and Excel to efficiently update
items.

Prepare Excel document for import
Before importing your Excel document, keep these points in mind to avoid common errors.

• Include a header row [71] in your Excel document (required).
• Only use valid options from pick list fields [72] (required).
• When using round-trip [82] for multiple projects, always be sure you're clear which project you're

making changes to, because imported data overwrites previous data.
• For complex imports like round-trip data, consider creating a baseline [236] first, in case you need to

restore old data.
• To use the Update items option, the spreadsheet must be created by Jama Connect using a properly

configured Excel template. Excel documents missing the required Jama Connect data triggers a "fail-
ure previewing file" error.

• If you're importing dates in text-formatted cells in Excel, they must be in exactly this format to import
accurately: mm/dd/yyyy hh:mm:ss Z, where Z is the time zone difference from GMT (for example:
-0800, +1000, +0700).

TIP
Add the "Imported" status to a pick list in the targeted set's item type, so you can filter
for newly imported items. Just filter for the pick list value "Imported."

Header row in Excel imports
Required fields must be listed horizontally at the top of the spreadsheet, with qualifying information be-
low them.
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IMPORTANT
Although an organization administrator can add or delete fields [589] from an item
type, the name field is a system field and can't be disabled.

To include custom fields in your import, list them the same way. The worksheet must contain only one
row of column headers and the corresponding data presented here. If you don't want to use column
headers, the import automatically numbers the columns from left to right, starting with the number one.

NOTE
Header rows work differently when importing test cases [308].

Jama Connect can only import one Excel worksheet at a time. You can select which worksheet you're
importing during import. If your Excel document has several worksheets, you must import them sepa-
rately.

You must also select the Excel row number that corresponds to the field names in Jama Connect. The
corresponding columns in this row map to field values in Jama Connect. If a heading row doesn't exist,
users can select row "0" which populates the Mapping section with the Excel default column names.

Pick lists in Excel imports
When entering information into a field that's a pick list (such as Priority), be sure to exclusively use op-
tions from that pick list. Values in the spreadsheet that you want to map to pick lists in Jama Connect
must exactly match the valued displayed in that pick list. Use the Excel filter to filter pick list columns
and make sure that the values in the spreadsheet match the targeted pick list in Jama Connect. This is
a quick way to identify any pick list options that are misspelled or items that are missing a value.
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Entering options that aren't in the pick list results in blank entries upon import, as shown in this example
with the value of "Fun."

Field mapping for Excel
The field mapping area shows three columns that indicate the value that specific fields of an item will
get for the import. If you don't specify a mapping for a Jama Item Field, the import skips the field (for
updating existing items) or uses the specified default value (for importing new items).

1. Jama Item Field
This section indicates each of the fields available to the type of item in Jama Connect you're creat-
ing or updating.
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2. Default Value
The values specified here for the coinciding Jama Item Field are used if no value is specified in an
Excel field that's being mapped. Required fields in Jama Connect force users to provide a default
value to prevent null or empty values.

3. Mapping
The mapping section contains a select list for each coinciding Jama Item Field. The select list is a
list of column values in Excel from the "Excel Header Row" specified earlier. Select the Excel col-
umn value in the select list that's intended for each Jama Item Field.

Import relationships

Overview
Relationships are imported to Jama Connect from a CSV file. The file consists of two columns.

1. Column A: Parent or upstream item references.
2. Column B: Child or downstream item references.

Tip: It's possible to import multiple relationships to a single item or many relationships to many items by
creating duplicate cell combinations for those items. In this example, CP-REQ-10 has three relation-
ships created to it.

Prerequisites

1. A relationship import plugin must be configured [548] and enabled.
2. A CSV must be generated with the correct parent and child field values.

Process
In Jama Connect, select Project > Import > Custom Import.

This opens a pop-up window with settings to configure.

Select a destination: Select the location in your project for the Import Relationships Plugin. While des-
tination is a required setting, it doesn't affect the import.

Select custom importer: Select the Import Relationships Plugin created by an organization admin.

Field delimiter: Select Comma.

Optional encoding: Select UTF8.

Select file to import: Upload the CSV file containing the required relationships.
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Attach your CSV file and select Import. You see a notification at the top of your screen after the import
is complete that says, "Success: X items imported."

Note: You might see the Success pop-up message even if relationships weren't successfully imported.
Try the following if this happens:

1. Double-check that you're importing a file with the extension .csv.
2. Give Jama Connect time to process the relationships. If you're importing more than 100 relation-

ships, the update isn't instantaneous. We recommend importing relationships are imported in small
batches no larger than 250 at a time.

3. Check that your parameters are written correctly and reference the right API ID or Field.

Import test cases with Excel
You can import multiple test cases and their corresponding test steps with a single spreadsheet. You
have two options for using Excel to bring test cases into Jama Connect:

• One-way imports quickly bring legacy test cases into Jama Connect.
• Round-trip imports let you work with content outside of Jama Connect and bring changes back in

safely.

One-way import for test cases
Follow the same instructions as a one-way import [81].

When importing test cases and their test steps your Excel spreadsheet MUST contain at least the fol-
lowing four column headers:

1. Test Case Name
2. Action
3. Expected Results
4. Notes

The following example shows a document that imports two test cases: "Test Wheel" and "Test Brakes."
Each row where the test case name is repeated is imported as a new test step.
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For Jama Connect to read the test steps, you must select the Header Row as Row 2, so that the map-
pings begin with the first test step rather than the field names.

Round-trip for test cases
A round-trip import for test cases works just like a regular round-trip [82]. Because of the relationship
between test cases and test runs, some caveats must be considered when editing test cases from
round-trip.

While you can update, add, remove, or re-assign a test case in a round-trip, you can't update the test
case status [311] this way. The test case status field is calculated from all of the test runs derived from
that test case.

Add a test step

1. Copy a pre-existing row.
2. Insert the copied cells where appropriate. You must insert the copied cells rather than pasting di-

rectly over the cells. Otherwise, you will replace the row instead of adding a new row and subse-
quent steps are removed on import.

3. Make needed changes to the copied fields.
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Note: The numbering of the steps appears off but is re-numbered on import.

Remove a step
Remove a step anywhere in the sequence of steps. Re-numbering takes effect on import.

Select files for import
The process for importing files includes selecting the files you want to import. Optionally, select the des-
tination and choose the field-mapping layout.

1. Select the files you want to import:
Right-click on any item in the Explorer Tree and select Import. Your files are imported into the same
level as the selected item. 

2. In the window that opens, select a file to import. Jama Connect evaluates the file type and guides
you through the import. Import doesn't continue if the file isn't recognized.

3. (Optional) Select the following options:
• Destination

If you initiated the import by right-clicking in the Explorer Tree, this field is pre-populated. Make
sure the field correctly indicates where the import places the newly created items. Select the
magnifier to change the destination.

• Select a saved field mapping
Here you can select previously created import configurations that were saved in the project for
the same file type. This is helpful to set up if you need to import multiple documents with the
same field-mapping layout. At the end of a successful import you can save the field mapping for
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reuse in the project. Select Delete an existing field mapping to remove any field mapping
saved in the project.

• Optional Encoding
This value determines the character set encoding used during the import. The default setting is
UTF-8, the character encoding used by the Jama Connect database. For most imports you can
use the default.

4. Select Next.

Additional options for Excel imports
The Data Import Wizard asks how you want to handle hierarchy for your import. 

• Set the hierarchy within your import by colored or indented cells.
On import, rows with the colored [79] or indented [80] cells appear as parent folders with the rows
below them as child items.

• Import items not folders.
 Jama Connect imports parent rows as folders by default. You can disable this by selecting Use item-
subitem structure.

Whether you're importing parent items or folders, the names of the parent items and folders must be in
the same Excel column that you mapped to the name field in the prior window.

For round-trip imports [82], you likely don't need to set the hierarchy. If you do set a hierarchy with
round-trip imports, hierarchy changes are applied only to new items.
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Set Excel import hierarchy with color
The cell coloring hierarchy method allows only one tier of hierarchy and doesn't differentiate between
colors.

1. Select the cell you want to use as a parent container and change the color of that cell.

2. Import the document as usual. [81] You must indicate which column you're using to determine the
hierarchy in the Additional Options [78] step in the Data Import Wizard.

3. The resulting import shows the colored cells as parent containers.
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Set Excel import hierarchy with indentation
Import from Excel with indentation

1. Decide which cells you want to be parent topics, then select the cells below the parent topics and
indent them.

2. Import the document as usual. [81] Be sure to indicate which column you're using to determine
the hierarchy in the Additional options step [78].
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The resulting import shows the indented cells as child items:

Excel to Jama Connect one-way import
Prepare your spreadsheet before importing files from Excel.

1. Select files for import [69]. 
2. Complete the field mappings step for Excel documents.

• Select the Excel worksheet and header row. For basic one-way import, this is likely row 1, the
row that contains field names. For round-trips [82] this is likely row 2.

• Indicate whether this is a round trip import and how to resolve conflicts.
• Map fields for your import [73].

3. To open the Additional options [78] window, select Next. If you're using indentation or cell color to
designate hierarchy, indicate that here.

4. If the fields were mapped successfully, you see a preview of your import. If it's correct, select Sub-
mit. You can also select Back to make changes.

5. The last window confirms how many total items you imported. From this page, you can import an-
other file, if needed. You can also save the current mappings to use for future uploads.
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Jama Connect to Excel round trip 
With a round trip, you can batch edit multiple items in Jama Connect. Export the Jama Connect items
you want to edit to Excel, then make your changes in the spreadsheet. Finally, import the edited docu-
ment back into Jama Connect, where you see the updated changes to the items.

Round trip requires you to re-import Excel documents created by Jama Connect using an Excel tem-
plate. When the system identifies items that originated in Jama Connect, it updates your items accord-
ing to the conflict rule set at the time of the import.

1. In List View, select the folder, filter, or set to be exported to Excel. You can also select multiple
items individually. Only the columns shown in List View are exported, so be sure to display all col-
umns that need to be included.

NOTE
Excel has a cell character limitation. When exporting Rich Text fields, a field that
exceeds the limit is truncated on export, which impacts the data that’s imported to
Jama Connect using Round Trip.

2. Select Export > Office Templates in the top right corner.

3. This opens a pop-up window. Select Excel Export for Roundtrip from the menu on the left, then
select Run.

NOTE
Rich text fields can often create difficulties in Excel and must not be used for
round trip.
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4. Open the newly downloaded Excel report and save it to a place where it can be edited.

NOTE
Columns A-E are hidden. These columns contain the fields that Jama Connect re-
quires to update existing items.

5. Make updates to the exported Excel document. In this example, we are changing the names of
three test cases. Clearing a field's value in the spreadsheet also clears the field's value once the
data is imported back into Jama Connect.

NOTE
If a field is based on a pick list in Jama Connect, the pick list is exported as well.
This helps ensure that valid data is entered before re-importing to Jama Connect.
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6. You can also add new items to the Excel document that are added as new items in Jama Connect
when you import it again. If you add an item to your round-trip document, it appears at the bottom
of the set or folder you decide to import to. You can add only one item type for the chosen set or
folder. Item IDs and Global IDs are assigned to any new items when you import, so be sure to
leave those columns blank. Assigned and Priority field values can be left blank.

7. Save the document and import [81] the document into Jama Connect, keeping in mind the following
tips:
• Make sure all updated fields are mapped correctly, otherwise the import fails.
• Under Excel Options, set Header Rows to 2 because the Jama Connect Excel Export Report

defaults to mapping a Header Row in row 2.

• Select the appropriate conflict setting on import. Conflicts might occur when a field in Jama Con-
nect has changed values since the round-trip export was generated. Choose the conflict rule that
you prefer to keep your data correct. Select Update items to update Jama Connect items modi-
fied since the last round-trip export.

• Columns aren't resizable by default because the document is protected to preserve the hidden
columns Jama Connect needs to match up items on import. If you need to resize columns, select
Review and unprotect the document.

• Import the document to the location where you want to place new items added to Jama Connect.
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• Copying or filling complete rows copies the hidden text that Jama Connect uses to match up col-
umns on import. Copy only cells, not complete rows, to be sure you don't copy information you
don't want. If extra information like this isn't removed, the import might update existing items with
the new rows. For new items created from copied rows, you must unprotect the document, ex-
pand columns A–E and delete the text contained in the cells.

• Rich text fields in Jama Connect will include HTML in Excel, so the formatting is preserved when
the items are re-imported. This depends on the field's configuration [589], which can be set as a
text box or as rich text. Fields set as text box are displayed as plain text.

• You can't manually update IDs or add new IDs. These are ignored on import.
• You can't update a pre-existing Jama Connect item hierarchy by applying cell indenting, cell col-

oring, or changing values in the default hidden columns. Also, items added to the spreadsheet
that aren't in Jama Connect can't use the hierarchy options.

IMPORTANT
You can only create new items with Excel round-trip import by copying or adding
individual cells.

CSV imports
Jama Connect imports spreadsheet data saved as comma-separated values (CSV format). Commas
are the most common delimitation character used to save spreadsheet data, but tabs, semicolons, and
colons are also supported.
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A CSV import doesn't create folders or hierarchy. To import a large number of documents this way, you
can create a temporary set in Jama Connect with the same item type as the targeted set. This allows
easy identification of imported items.

Import from IBM DOORS
You can import active IBM DOORS data, such as requirements, test cases, and project information to
Jama Connect, and also maintain relationships during migration.

Here are the steps for a successful import:

1. Ensure you meet Jama Connect [86] and DOORS [86] prerequisites.
2. Export HTML zip file from DOORS. [89]
3. Import to Jama Connect [90].

DOORS export prerequisites
Before exporting, verify these prerequisites for a successful export. It's helpful to think through all as-
pects of the import before carrying it out.

The Object Identifier column is typically mapped to the Name field in Jama Connect.

If you're importing hierarchy, the DOORS standard Object Heading and Text (or Main) column must
be mapped to the Jama Connect Description field. This is the only column that exports hierarchy infor-
mation to HTML for Jama Connect imports.

If you're importing links (trace relationships) across multiple modules in DOORS:

• The modules must be open when you export. DOORS exports include the modules that are shown in
your view. For this reason, you must not have filters selected or it limits the number of items exported.

• Each module must have a unique prefix so that the Object Identifier is unique. DOORS doesn't en-
force this, but if you add a unique prefix to each module, the Object Identifiers are unique.

• The Object Identifier column must be visible in the DOORS module view (not Object Number or
Absolute Number). The Object Identifier is a combination of the Module Prefix and the Absolute
Number (as in SYS32).  If the Object Identifier has only integer values, the Module Prefix is most
likely empty.

Jama Connect prerequisites (DOORS)
When importing to Jama Connect, DOORS Modules create sets or folders in an existing set. DOORS
Attributes map to fields in Jama Connect.

Relationships aren't created until both items you want to relate are imported.

To import relationships (or trace links), you must first create a new custom field in Jama Connect for
each item type you're importing. This field is used to contain a unique identifier that facilitates the migra-
tion of relationships from DOORS to Jama Connect.

1. In Jama Connect, select Admin > Organization > Item types.
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2. Find the item type you're using for the DOORS import, select Fields.

TIP
It might be helpful to create a new item type [580]only to be used for the migration,
then convert the items to the correct item type after the import is complete.

This way every item imported has a record of legacy DOORS information in its
version history. You can view this information by comparing versions [228].

3. In the panel that opens, select Add Field.

4. In the window that opens, select Custom Fields and Text Field from the drop-down menu.
1. Next to Field Label, enter a name for the field (such as "DOORS ID").
2. Next to Unique Field Name, enter "SYS_DOORS_ID." This is case sensitive and must exactly

match the following image.
3. Select Read Only and Save.
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5. Now this item type can accept relationships (trace links) imported from DOORS.
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IMPORTANT
This field must be created for all the item types you're relating.

6. When you import, DOORS Modules are added as sets, or folders within sets. If you're using the tip,
you might want to add a set of the new item type you created before you import. You must also
configure the project for this item type [626]. That way you can right-click on the new set and import
directly to that location.

Export from DOORS
You must only use an HTML .zip file when importing to Jama Connect.

IMPORTANT
Follow these steps carefully to ensure the export is successful.

1. Create the export target folder in the local drive/directory.
Tip: The folder can have the same name as the module being exported, but it's not required.

2. Open a module to export. Make sure there aren't active filters.
3. Select File > Export > HTML...
4. Select Layout > Table.
5. Select Export > Current.
6. Select Links to import them as relationships and create the necessary field in Jama Connect [86].
7. Select a folder or location to store your DOORS files.
8. Browse to the target folder and select Export.

9. Without making changes, compress (.zip) the target folder that contains the exported HTML con-
tent.
Note: Changing or moving the exported files before compressing them can create unreliable re-
sults.

Images in the item description are imported. Comments, attachments, and item history aren't imported.
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Import to Jama Connect
Once you complete the export from DOORS, Jama Connect guides you through the following steps of
the import.

1. Select files and destination [69]
2. Select field mapping (DOORS) [91]
3. Hierarchy and relationships (DOORS) [92]
4. Verify and submit [93]

Select files for import
The process for importing files includes selecting the files you want to import. Optionally, select the des-
tination and choose the field-mapping layout.

1. Select the files you want to import:
Right-click on any item in the Explorer Tree and select Import. Your files are imported into the same
level as the selected item. 

2. In the window that opens, select a file to import. Jama Connect evaluates the file type and guides
you through the import. Import doesn't continue if the file isn't recognized.

3. (Optional) Select the following options:
• Destination

If you initiated the import by right-clicking in the Explorer Tree, this field is pre-populated. Make
sure the field correctly indicates where the import places the newly created items. Select the
magnifier to change the destination.
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• Select a saved field mapping
Here you can select previously created import configurations that were saved in the project for
the same file type. This is helpful to set up if you need to import multiple documents with the
same field-mapping layout. At the end of a successful import you can save the field mapping for
reuse in the project. Select Delete an existing field mapping to remove any field mapping
saved in the project.

• Optional Encoding
This value determines the character set encoding used during the import. The default setting is
UTF-8, the character encoding used by the Jama Connect database. For most imports you can
use the default.

4. Select Next.

Select field mappings (DOORS)
In this window, Jama Connect field names are listed on the left. You can assign a default value and se-
lect which DOORS attributes you want to map to each Jama Connect field.

TIP
It might be helpful to open the DOORS HTML zip file in a separate tab when selecting
field mappings to ensure you're mapping fields they way you had planned.
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IMPORTANT
You must select a mapping for the Name field. This is usually the DOORS Object
Identifier attribute.

The Description field is usually mapped to the Main attribute in DOORS. Bullets and
other symbols are exported from DOORS as images, not as formatting. If you're map-
ping a field that contains images or formatting, the corresponding import field must be
configured as a rich text field, otherwise these images don't appear.

You can't select a mapping for Step action, Step expected results or Step notes.

Hierarchy and relationships (DOORS)

IMPORTANT
For hierarchy and relationships to migrate successfully, be sure you follow the DOORS
[86] and Jama Connect [86] prerequisites carefully prior to importing.

In this window, you can select the options you want for hierarchy and relationships:

1. Select Preserve hierarchy if you want to keep the DOORS hierarchy when importing. If left unse-
lected, the resulting items are at the same level.
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2. Select Use item/sub-item structure (instead of folder/item structure) when creating hierarchy
of imported items if you want all parent items to keep the item type of their children. If left unselec-
ted, all parent items become folders.

IMPORTANT
All items converted to folders lose their relationships (links). If you're importing rela-
tionships, use the item or child-item structure.

3. Select Create relationships from DOORS links if you want to migrate Trace Links from DOORS
to relationships in Jama Connect.
If you see the following error, double-check that you successfully completed all Jama Connect pre-
requisites [86] before import.

4. Next to Relationship type, select the type of relationship you want to create. This value is set to
your organization's default value if left unselected.

5. Next to DOORS ID column , select the name of the column from your export which contains the
DOORS Object Identifier, which is used as the identifier when creating relationships and must
match between item types.

6. Next to 'From' (OUT) link direction in DOORS maps to, set OUT=upstream or OUT=downstream.
DOORS and Jama Connect use different terminology for relationship direction. The selection de-
pends on how relationships are used in DOORS. Double-check the HTML file or run a test import to
verify that this works as expected.

IMPORTANT
Because relationships are created based on the DOORS Object Identifier, importing
items twice creates multiple relationships.

Verify and submit
In this window you can see a preview of the first item that imported and verify that it looks correct.
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If the import looks correct, select Submit and a summary page outlines the number of items imported
as well as the number of relationships created.

You can continue and import another DOORS Module.

If you plan on importing the same item type (objects) with the same mappings multiple times, you can
save your mapping changes as a new document mapping here.
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Use the rich text editor
Use rich text fields to format text and embed other data, like images and tables, in item fields. An organ-
ization administrator can enable the rich text editor for item type fields [589].

With rich text fields you can use text formatting, hyperlinks [99], images [98], tables [100], spellcheck-
er (English), templates [103], diagrams, graphs [101], and equations [102]. 

NOTE
The equation editor requires additional licensing. Contact your Jama Software account
manager for more information.

CAUTION
Many third-party reporting tools can't display rich text (HTML) properly. Also, each rich
text section can have its own style, making it difficult to control the overall look and feel
of your report. 

Integrations with third-party applications also might not be able to accept rich text
(HTML) data.

You can disable the rich text editor [589] in these cases or to tightly control the data
entered in these fields.
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NOTE
Whenever a rich text item is saved, the Jama Connect application deletes certain text
(usually code such as javascript) that might be a security risk. This doesn't affect the
vast majority of data.

If a field is enabled with rich text, you see the rich text menu. Use the menu for rich text controls. Press
Enter to start a new paragraph.

Rich text controls are similar to text editing options found in many software applications. You can also
use keyboard shortcuts [653] with the rich text editor.

1. Text style and size. These styles can be correlated to Word styles for stylized exports. 
2. Cut, copy, and paste

• Cut: Remove the selected text to your clipboard.
• Copy: Copy the selected text to your clipboard.
• Paste as plain text: Pastes the selected text without rich text formatting.
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NOTE
You can also right-click or control + click inside the text field to pull up the editor
context menu to complete these actions.

3. Field view
• Insert document templates: [103] Organization administrators can configure these templates

[600].
• View source code: You can add HTML elements to create custom styling, but be aware that not

all styling might be supported in other areas of Jama Connect, like reports. 
• Fullscreen mode: Select to maximize the field.

4. Format text
• Bold
• Italic
• Underline
• Strikethrough
• Text color
• Highlight color
• Clear formatting

You can convert any text to the default style and size. This can be helpful for copying and pasting
text from external sources.

5. Script
• Subscript: Any text highlighted when this button is selected becomes a subscript.
• Superscript: Any text highlighted when this button is selected becomes a superscript.

6. Text alignment
7. List formatting

• Numbered list
• Bulleted list
• Offset left
• Offset right

8. Edit text
• Undo
• Redo
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• Find
• Replace

9. Insert links [99]
Highlight any text and use this control to add a hyperlink to that text.

10. Special tools
• Add/edit diagram: Create or edit a diagram [101] that was created.
• Add image: Insert images [98].
• Add image from server: Display an image [98] that was uploaded to the Jama Connect appli-

cation server.
• Table: Insert a table [100].
• Special character: Insert special characters.

11. Equations editor [102]
• Math editor
• Chemistry editor

12. The spell-checker automatically underlines misspelled words in red. Cmd+right-click on the word
to view browser and operating system spelling suggestions.

Insert rich text images
You can add images with the rich text editor using one of these methods. 

1. Upload an image into the editor
Click Add image in the toolbar to open a window. Browse for a file, then select Open.

NOTE
Provide the full path to the image file to comply with third-party converters for PDF
and Word. If you move Jama Connect to a new server location or modify the server
name, edit your image files to match the path or name changes.

2. Upload an image using copy and paste
Copy an image. Place your cursor in the rich text field and use Ctrl+V.

NOTE
This functionality isn't available with Internet Explorer 10.

3. Drag and drop an image
You can drag an image from your desktop and drop it into the rich text editor.

4. Browse the server for images.
Select Add image from the server to open a new browser tab and see the list of images previous-
ly loaded onto the Jama Connect application server. Choose an image from the list and click Se-
lect to insert the image.

Once the image is inserted into the editor, it can be resized by grabbing and dragging the bottom right
corner. The image can be moved by hovering over the top left corner, grabbing the handle, and drag-
ging the image to its new location. A maximum height and width setting can be applied by a system or
organization administrator in organization detail [609].

If the image is too large to be displayed, users see an Expand button. Select Expand to view the image
in full size.
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NOTE
A system administrator can manage file types [495] for self-hosted customers.

Insert rich text links
You can link from a rich text field directly to other sets, items, and attachments in Jama Connect or to
external links. Direct links to attachment files can be helpful to reviewers.

1. Select the Link icon in the rich text toolbar. Highlight the text you want to use as a hyperlink or
place your cursor on an existing link to include that information in the next step.

2. In the Enter URL window, enter a URL for external links. You can also select tabs to choose your
link from recently viewed locations, the Explorer Tree, releases, search results, or attachments. Un-
der the Attachments tab, upload a file directly from your desktop.
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3. To place your link in the rich text field, use Select. The link doesn't work until you save changes to
your item. 

4. To break a link, select the Break link icon next to the Link icon in the toolbar.

Insert rich text tables
Use the rich text editor button [95] to insert a table.

Format tables by right-clicking any cell, then selecting Table Edit:
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Resize tables by selecting the borders.

Create a space above or below a table or text that's near the top or bottom of the editor by hovering
your mouse near the space, then select the blue button that appears on the right.

NOTE
Creating tables manually in Jama Connect is more efficient than importing them from
other documents. Once a table is imported, it becomes difficult to work with and
doesn't export cleanly.

Insert rich text diagrams

1. Select Diagram in the rich text toolbar to open the Graph Editor window. If you highlight an exist-
ing diagram before selecting the button, it appears in the window for editing.

2. In the Graph Editor window, create new shapes by dragging from the menu on the left and drop-
ping to the canvas. 
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3. Explore the menus on the left to add different shapes, icons, tables, and text or use the search
function. Format style text and arrangement in the menu on the right. For more information, see
MXGraph Editor.

4. When you're finished, click outside of the diagram or highlighted text, then select Save and Close
to insert your image into the field in Jama Connect.

NOTE
You can't copy and paste between the diagram editor and other applications, or import
images from other diagramming tools. 

Insert rich text equations
With the Mathtype Equations Editor, you can create complex equations and edit them in Jama Connect.
These are converted into images for safe storage and export, but are always editable when you have
a MathType license.

NOTE
The MathType Equations Editor requires a separate license. Contact your Jama Con-
nect administrator or sales representative to inquire about purchasing this license.

For self-hosted customers with a license, the system administrator can enable the
equations editor [486].

Your organization determines the total number of floating licenses, which are available on a first-come/
first-served basis. If a license is available, you can use it by opening the Equation Editor. To release the
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license, close the Equation Editor. If a license isn’t available, try again in a few minutes or contact your
admin for help.

1. To open the editor, select the Math Editor icon or the Chemistry Editor icon. To edit an existing
equation in your item, you can either:
• Select the equation to highlight it, then select the Math Editor icon (for math equations) or

Chemistry Editor icon (for chemistry formulas).
• Double-click on the equation to open the correct equations editor.

2. For more information about how to create mathematical equations or chemistry formulas, see the
MathType User Guide.

Insert rich text templates
Templates are pre-written text or documents that can be inserted into the rich text editor to help uniform-
ly format items, such as test cases or use cases.

IMPORTANT
This feature must be configured by an organization administrator [600] before using. 

1. To use a template, select the Templates button to open the Content templates window.

2. You can use several default templates with the rich text editor, including basic use case, document
style use case, basic test case, and agile story card. If you select Replace actual contents, the
template deletes content currently in the field. Select a template and continue editing the item.
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Enable Accessibility Checker
The Accessibility Checker allows you to inspect content created in the rich text editor for how well it
meets standards for people with impaired visual, cognitive, or motor skills.

1. Select the Accessibility Checker icon from the Rich Text toolbar. The plugin inspects output HTML
code and identifies common accessibility problems that you can fix.

2. If the Accessibility Checker finds an issue, it offers a Quick Fix solution for common problems. Enter
the changes requested and select Quick Fix to apply the changes or choose Ignore. Use the arrows at
the top of the pop-up window to scroll through issues found by the Accessibility Checker.
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3. If the Accessibility Checker finds no issues, you see a confirmation message. Select OK to close the
message and exit Accessibility Checker.

Containers
Containers help with organization in Jama Connect. For example, components [105], sets [106], folders
[108], and source folders [236] are all containers. All are items, except source folders.

Components
A component is a structural container item used to organize a project into more manageable pieces. 

For example, you might define each of the individual pieces that comprise your product with a different
component.

• Components can only be located or moved to the root of the Explorer Tree or inside another compo-
nent.

• Components might contain sets of various item types, text items, and sub-components. Each compo-
nent can have different access rights.

NOTE
Text items can appear anywhere in this structure.

Add components
A component is a structural container used to organize a project into more manageable pieces. 

To add a component:

1. Right-click on the project name in the Explorer Tree wherever you want to add a component or
sub-component.
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You can also select Add > Component at the top of the left panel in the project where you want to
add the component.  

2. In the Add item window, select a name and description for the component.
(Optional) Select Notify to select users or groups you want to notify about the creation of this com-
ponent.

3. Select Save, Save and close, or Add another if you want to add more components.
4. If you used the Add button, use the Select location window to select the location for the new com-

ponent. Invalid locations are disabled.
5. Click Select and close.

Sets
A set is a structural container item with configurable access rights, used to group items of the same
type. It can also contain folders, text items, child text items, and child items of the same type.

A set contains items of the same type. You can move or copy between sets of the same item type.

Item types for a set are configured by an organization administrator [580]. For example, you might have
a set of Business Requirements and a set of Non-Functional Requirements that share the Require-
ments item type.

Add sets
A set is a structural container item with configurable access rights, used to group items of the same
type. It can also contain folders, text items, child text items, and child items of the same type.

To add a set:

1. Right-click on the project name in the Explorer Tree wherever you want to add a folder. Select Add
> New item > Set of... > [item type].
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You can also select Add > Set of... > [item type] at the top of the left panel. 
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2. In the window that open, edit the set key [628], name, and description of the set.
(Optional) Select Notify to select users or groups you want to notify about the creation of this set.

3. Select Save, Save and close, or Add another to add more sets.
4. If you clicked Add, use the Select location window to select the location for the new set. Invalid

locations are disabled.
5. Click Select and close.

Folders
A folder is a container item you can use to organize items and manage hierarchy in the Explorer Tree.

Folders are a structural item type that contain other items, not an array of different item types. Folders
can contain only text items and the same item type as the folder itself. Folders can be located or moved
inside a set of the same item type, or inside another folder. You can't place a folder inside a component
of mixed item types.

An item can be moved between folders and sets of the same item type using drag and drop within the
Explorer Tree or from List View. Folders can be dragged to other sets of the same item type or into oth-
er folders also in the same item type.

Add folders
A folder is a container item you can use to organize items and manage hierarchy in the Explorer Tree.

To add a folder:

1. Right-click on the set name in the Explorer Tree wherever you want to add a folder. Select Add >
New item > Folder.
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You can also select Add > Folder at the top of the left panel in the project where you want to add
the folder. 

2. In the Add item window, select a name and description for the folder.
(Optional) Select Notify to select users or groups you want to notify about the creation of this fold-
er.

3. Select Save, Save and close, or Add another if you want to add more folders.
4. If you selected Add, use the Select location window to select the location for the new folder. Inva-

lid locations are disabled.
5. Click Select and close.
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TIP
If you want a parent item to contain certain widgets or custom fields that a folder can't,
you can use an item, rather than a folder, to contain other items of the same item type.
A group of items can be flagged using a field or all attachments can be inserted into
the parent item for easier tracking.

Items
Items are the building blocks of Jama Connect. Projects are made up of items. Items are made up of
fields. Items can be containers [105] (sets, folders, components or parent items) or documents (fea-
tures, requirements, test cases, tasks, defects). 

All items have an item type that's determined by an organization administrator [580], a global ID [274],
and a unique ID [628]. Baselines, source folders, risks, risk analyses, reviews, and test groups aren't
items.

For container [105] items, you can select View details next to the container title that displays details of
that container.

Select View to:

• Open container attachments [133].
• Edit the name or description of the container itself.

TIP
Subscribe yourself [195] or others [195] to this container item to receive email notifica-
tions when this container changes.

Several places in Jama Connect allow you to see a quick preview of an item without
opening it in the center panel. For example, right-click on an item in the Explorer Tree
and select Preview item.

Add an item
You can an add an item to a project from several places in Jama Connect.

NOTE
You can't add items in filters or in lists of mixed item types.
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To add an item to your project:

1. Open the Add item window using one of these methods.
• Right-click the project name — In the Explorer Tree (or wherever in that project you want to

add an item), right-click the project name, select Add > New item, then select an item type from
the list that appears.
The list includes only item types that are valid for that location.

• Add drop-down list — In the project where you want to add the item, select Add at the top of
the left panel, then choose the item type you want to add.
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• Toolbar — From the toolbar above Single Item View,  List View, or Reading View, select Add,
then choose the item type you want to add.

In List View, if the list contains items of a single item type and no items are selected, you can add
an item of the same type, a text item, or a set to the bottom of the list.
If an item is selected, use one of these options.
• Insert new to insert a new item below the selected item or add a child item.
• Add Item Type as child to add an item as a child item of the selected item.
• Add related to add a related item to the selected item. If a relationship rule [255] was applied

to that project, only item types that meet the rules are available for that selection. 
• Quick add add items in a set of the same item type.

2. In the Add item window, fill in the fields for that item type.
3. Save the new item by selecting Save or Save and close.
4. If you didn't select a location in step 1, the Select Location window opens for you to select the

location where you want to add the new item. Invalid locations are disabled. Click Select & Close. 
5. (Optional) In the Add item window, select Notify to add a notification comment and select users or

groups you want to notify about the creation of this item.  

NOTE
These comments are included in the version notes for the item [227] and are dis-
played in the stream [207].
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6. Select Commit.

Quick-add an item
Use the Quick add option to add multiple items — up to fifty at a time — to a set of the same item type.

Important considerations

• The Name field is required while the Description field is required or read only based on how the item
type is configured.

• To add required fields, edit the item after you create it.

1. In your project, select Actions > Quick add.
If you don’t see the Quick add option, then the item you’re adding doesn’t match the item type in
that set.

2. In the Quick add items window, enter the name (required), optional description, and additional rows
as needed.
You can add up to 50 rows (items), 255 characters per name field, and 500 characters per descrip-
tion field. Use the tab key to move across the table.

3. Click Save.
The new items appear in the Explorer Tree.

4. To add required fields to a new item, select the item to open and edit it.

Child items
A parent item with child items can't be converted to text items. An item can also contain text items as a
child item. Relationships and attribute values aren't inherited to child items.

To create a child item:

• Right-click on an item and select Add > New item > Sub Component.
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Edit items
Single Item View automatically displays items in a read-only format.

1. Double-click on the field you want to edit.
You can also hover over the field and select the pencil icon to make it editable.

You can also select Edit from the toolbar.
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NOTE
If you don't see the pencil icon or the Edit button, you do not have create/edit per-
missions.

2. Make changes to the item fields. 

NOTE
If a field is disabled for editing, an organization administrator might have config-
ured the field to be read-only [589].

3. Select Save to intermittently save the updates but keep the editing view open.
4. Once you're done editing, select Save and done.

• To save and add another item of the same type, select the arrow on the middle button and select
Save and add another.

• To save and notify other Jama Connect users, select the arrow on the middle button and select
Save and notify.

5. If you selected Save and notify, Jama Connect prompts you for comments and provides a list of
groups and users to notify about the update. Users who are subscribed to the item appear in the
Notify window. The X icon removes users from the notification list. Users who are already subscri-
bed can't be unsubscribed from this view.

6. To subscribe the user or group for future updates to this item, select the envelope icon.
7. Select Commit to complete the edit and create a new version.

Edit items in List View
1. Double-click the field you want to edit in projects List View.

2. Select Save or press Enter to save the change and move to the next item in the list, or use Ctrl+S
to save the item.
Press Escape or select Cancel just below the selected item to undo any unsaved changes.

TIP
You can also update multiple items with batch update [116]. 
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Batch update items
You can update picklists, fields, and tags for multiple items at a time.

Rich text fields are not supported in batch update, but this can be done using a Jama Connect to Excel
round trip [82].

1. In List View, select the items that you want to edit, then select Batch edit to open the Batch up-
date window.

If you're a review moderator, you can also select items for batch update in the item progress [188]
tab of review statistics.

2. In the Batch update window, make your changes, then select Next. 
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3. In the next window, select users or groups and send a notification alerting them to this batch up-
date. When you're done, select Commit.
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NOTE
You can't batch update rich text fields or use this method to batch update test runs.
Use the Test runs window to batch update test runs [341].

Add, edit, or delete links
If the Links widget was enabled by an organization administrator [584], you can store a link or URL in
the application that you can assign to individual items across projects.

1. In Single Item View, select Add link. 

2. Fill in the fields and select Save.

TIP
URLs that are prefixed with "http://" are treated as unique links. URLs without the
prefix are put at the end of the Jama Connect URL, which might be helpful if you
placed files on the server and you want to link them without uploading them as at-
tachments. For example:

• http://www.creativecommons.org — Opens a new browser window with the
URL http://www.creativecommons.org

• screenshots/login.html — Opens a new browser window with the URL http://
localhost:8080/contour/screenshots/login.html

3. To edit or delete a link, select the Edit or Delete buttons from the link's row.

Lock items
A lock makes items read-only. Locks can be set automatically or manually.

You can reuse [275] and create relationships from a locked item. You can't edit, delete, or synchronize
locked items.

Items can be manually locked [119] or automatically locked [200] by the system.

You can view and unlock locked items [42]. You can also find out who locked them.
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An organization or project administrator can unlock system locked items [546], but only an organization
administrator can unlock items manually locked by another user [544].

Who can unlock Jama Connect items?

Items Creator User with Workflow Transition Permis-
sions

Project Ad-
min

Organization Ad-
min

Manual locks by other
users

X

System/workflow locks X

Only applies in projects they administer.

X X

Manually lock items
To prevent others from making changes while you're working on an item, you can manually lock that
item.

Important considerations

• If you need to access an item locked by another user, contact that user or your organization adminis-
trator to unlock it.

• Users with organization or project permissions can unlock an item [42] from the toolbar.

• In Single Item View, select Lock item from the toolbar.

When you configure List View to show locked items, a gold lock is displayed next to items that are
manually locked.

Convert an item to another item type
In Jama Connect , you can change an existing item or items from one type to another. When you con-
vert an item to another type, the short name, description, relationships, versions, activities, comments,
and tags remain intact.

Keep in mind:

• If a field has a different name or data type in the new item type, the field doesn't convert.
• For lookup fields, they must refer to the same pick list (and have the same name and data type) in

order to convert.
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• Converting an item breaks the sync if you reused it.
• If converting an item puts the item out of compliance with the relationship rules, the problem is reflec-

ted on the item in the relationship diagram.
• If you convert a set, all the items in that set are converted to a different item type.
• You can't "undo" an item conversion [126] but you can convert the item back to the original item type.

Table 1. Conversion allowances
You can convert from a ... to a ...

component set (sets within the original component convert to folders in the newly cre-
ated set)

text item

set component (as long as the original set is empty and at the top level of hier-
archy)

set (as long as the original set is empty)

folder

text item

folder item

folder

item item

text item*

folder**

text item component

set

item

* You can't convert items with child items to a text item.

** Child items can't be converted to a folder unless the parent is converted first. Also, when converting to a folder, items lose widget
functionality and all custom field values.

Note: In all cases, the target conversion type must correspond with the type of items allowed for its destination. For example, to
convert an item to a defect item type, you must place it in a set or a folder of defects.

To convert an item, folder, set, or component, you can:

• Drag and drop items [120]
• Use the context actions menu [122]

Convert items using drag and drop

IMPORTANT
Before converting items make sure you understand how conversions work in Jama
Connect [119].

To convert an item or set to another item type with drag and drop:

1. From List View or the Explorer Tree, select the items and drag them into the set where you want to
move them.

2. Review the information and select Convert.
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IMPORTANT
Dragging and dropping a text item into a folder of your required type doesn't trig-
ger the conversion functionality. The text item is moved to that location. Text items
must be converted one at a time. Bulk conversion doesn't work with text items.

3. Changes are reflected in the item's version tab. To access this, select Versions in the side toolbar
[57] of Single Item View [56].
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TIP
When converting an item to a folder, use the option at the bottom of the window to re-
cursively convert items with children to folders.

If you select this option, parent items at every level beneath the item being converted
also convert to a folder.

For example, if converting this change request item to a folder of change requests, and
selecting the recursive conversion option, you obtain these results.

Convert items using the context menu
You can convert one or more items or sets using the context menu in List View or in the Explorer Tree.
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IMPORTANT
Before converting items make sure you understand how conversions work in Jama
Connect [119].

1. In List View, select the item or items you want to convert and select Convert to > [name of item
type].

Alternatively, right-click on an item or set in the Explorer Tree and select Convert to > [name of
item type].
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2. The Review item conversion window shows you (in white) which fields are copied into the
new item type. Use the tabs in the lower left corner to move between items if you have selected
multiple. When you 're satisfied with the conversion, select Convert.
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3. When you select Convert, if the item can belong in its current location (such as a text item),
the item remains there. However, sets can't contain mixed item types, so the item might need to be
moved. If so, the Select location window appears and requires you to select the new location for
that item. Click Select and close.

NOTE
If you select multiple items in List View, you must also specify a location, even if
it's the items' original location. Doing this ensures that the items end up in the cor-
rect place.

4. Changes are reflected in the item's version tab. To access this, select Versions in the side toolbar
[57] of Single Item View [56].
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TIP
When converting an item to a folder, use the option at the bottom of the window to re-
cursively convert items with children to folders.

If you select this option, similar parent items at every level beneath the item converted
is also converted in the same way.

For example, if converting this change request item to a folder of change requests, and
selecting the recursive conversion option, you obtain these results.

Undo an item conversion
You can't undo an item conversion, but you can convert your items back to their original type. When
changing back, the item receives new identifiers.  

1. Use the same procedure you used to convert your items to convert the same items back to the
original type.
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2. Any fields that don't convert in the new conversion direction are lost. To determine if fields were
lost, select Versions in the side toolbar of Single Item View to open the bottom panel and select
Compare.

3. Any fields that were lost must be manually replaced by an organization administrator [589].

Move items
To move items within a project you can move them in the Explorer Tree [127] or use List View [127]. 

Once items are moved, you can undo the move or find them in the stream [150]. 

To move items, they must follow these rules for valid item locations:

• Components — Can have child components and be moved to the root of the Explorer Tree.
• Sets — Can be moved inside of a component or to the root of the Explorer Tree. Sets can't have

child sets.
• Folders — Can be moved to a set that's the same item type as the set where the folder was created,

or to another folder.
• Items — Can have child items of the same item type and be moved to a set of the same item type or

to a folder.
• Text items — Can be moved anywhere in the Explorer Tree.
• General — You must have write access to move any items. For example, when moving items be-

tween sets, you must have write access to both sets. When components, sets, and folders are
moved, all the items within them are moved as well.

Move items in Explorer Tree
Items must meet valid item location rules [127] before then can be moved.

You can also move items between projects [128]. 

Tips and more

• A green indicator appears for moves that are allowed.
• A red indicator appears for moves that aren't allowed.
• A dotted blue line guides you when moving an item between other items.

1. Select the item or items you want to move in the Explorer Tree. 
2. Drag and drop the items into the new location.

Move items using List View
Items must meet valid item location rules [127] in order to be moved.

Quick tips

• If you select the tab at the top of the Explorer Tree, drag items from List View to the release, then you
can change the release on single or multiple items.

• You can also move items between projects [128].

1. In List View, select the item or items you want to move. 
2. Drag and drop the items to the chosen location. 
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Move items between projects
You can move an item or set of items, along with all associated conversations, versions, and attach-
ments to a different project. This is useful when a project has grown too large and performance has
started to degrade.

IMPORTANT
Before moving items between projects:

• A move can't be undone. Users can move items back to the original project but IDs
are changed.

• You can only move components and sets between projects. If you're trying to move a
folder of items or individual items from a component or set, you must first create a
new component/set and move those items to the new component/set.

• Document key IDs are changed when moved. The new ID is based on rules set up in
the destination project.

• When an item is moved, all associated stream collaboration, activities, and versions
are moved into the new project. Attachments, tags, and releases are copied to the
new project.
If you delete the source project, images inserted in a rich text field that are copied in
other projects are also deleted because they are referenced and aren’t copied from
the original project. To keep images intact in the duplicated project, we recommend
archiving the source project.

• Original attachments, tags, and releases still exist in the source project, including
links, images, and diagrams within rich text fields.

• Test runs can't be moved. Test cases can be moved without impacting test runs.
• Items contained in a review aren't shown in future versions of a review after they are

moved.
• The document ID in old baselines reflect the new ID.
• If any moved item is associated with an integration sync, integrations such as the

JIH can't be running while a move is being performed.
• Performance might be impacted at the time of the move if other resource-intensive

processes are being done at the same time.

Jama Connect User Guide

128



Before you can move an item:

• You have write permissions in the source and destination project.
• The items to be moved must be unlocked.
• All other move operations must be completed.  You can't make two moves at the same time.

To move items between projects:

1. In the source project, right-click on the set or component of items you want to move. Select Move
item.

2. In the Move items to... window, select the destination project and select Move. 
3. Review details and select Confirm.
4. During the move you can go to the destination project by selecting Go to project or stay in the

same project by selecting Done.
5. A pop-up window shows progress of the move. If any item fails to move, the entire move fails.
6. Once the move is complete, you can find moved items [150].

Duplicate items
You can duplicate items in Jama Connect using these methods.

1. Duplicate items — Create a copy of the item's name, description, test steps (if applicable), and the
ability to choose to include tags, attachments, and links. You can duplicate items that are locked.

2. Reuse items [275] — Creates a copy of an item, but with more options. With this method you can
reuse multiple items, reuse items with children, duplicate more of the item's content, or duplicate an
item from another project.

NOTE
You must have read/write permissions to duplicate an item.

To duplicate an item:

1. Right-click on the item you want to duplicate and select Duplicate item from the menu.
2. In the Duplicate item window, indicate whether you want to duplicate tags, attachments, or links.
3. Press Enter or select Duplicate.

NOTE
According to the item type, preferences you select in the pop-up window are
saved across sessions. However, clearing your browser data restores default op-
tions. When specific attributes (as in links) aren't enabled for an item type, the op-
tion doesn't appear in the pop-up window.

You're directed to the Single Item View of the duplicated item.

Delete an item
When you delete items, they aren't physically deleted but are marked as inactive and aren't visible to
users or reports. If absolutely required, they can be re-activated through the database.

Anyone with read/write permissions for an item can delete it, unless an organization administrator has
made the option unavailable [609].
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To delete an item:

• Select Delete in Single Item View [56].
• Select one or more items from List View [52] or Reading View [53], then select Delete.
• Right-click on the item in the Explorer Tree and select Delete.

IMPORTANT
Only unlocked items can be deleted.

Deleted items show up in the activity stream. The activity entry is also the only method
of restoring a deleted item [130] for those with delete permissions.

In most cases, nothing is deleted from the Jama Connect database. Even if you delete
another user, item, or something else in the system, a record is maintained and the de-
leted object is merely de-activated on the front end.

However, deleting a project [621] permanently deletes the selected project and ev-
erything under it from the database.

Restore a deleted item
If you have permission to delete an item, you can also restore a deleted item. Restoring a deleted item
also retains all comments, versions, and relationships associated with the item.

1. Select the project name at the top of the left panel to open the dashboard, then open the Activity
Stream widget [344] to view recent activities. 

2. Search for "delete" in the search field at the top of the Activity Stream widget. This brings up all
recently deleted items.

3. Find the item you want to restore and select Restore.

If the set for the restored item was removed, a component with a temporary set is created. The item can
then be moved to any set of the same item type.

Links
There are two methods for adding links to items.

• Associate a link with an item [118].
• Embed a link in a rich text field [99] in an item.

Add, edit, or delete links
If the Links widget was enabled by an organization administrator [584], you can store a link or URL in
the application that you can assign to individual items across projects.
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1. In Single Item View, select Add link. 

2. Fill in the fields and select Save.

TIP
URLs that are prefixed with "http://" are treated as unique links. URLs without the
prefix are put at the end of the Jama Connect URL, which might be helpful if you
placed files on the server and you want to link them without uploading them as at-
tachments. For example:

• http://www.creativecommons.org — Opens a new browser window with the
URL http://www.creativecommons.org

• screenshots/login.html — Opens a new browser window with the URL http://
localhost:8080/contour/screenshots/login.html

3. To edit or delete a link, select the Edit or Delete buttons from the link's row.

Tags
Tags are labels you can attach to items that can help you find items that have something in common.

Tips and more

• Tags are displayed in the bottom of the left panel in a section that can be hidden.
• Select Add tag to add a tag [132].
• Search for tags [137] using the "tag:" prefix.
• You can edit tags in List View.
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Tags can be displayed in a Cloud view:

List View:

In either view, select the tag to view the associated items.

NOTE
These tags are different than hashtags [208] that you can apply to comments in the
stream.

Add and delete tags

1. In Single Item View, select Add tag. If the field isn't available, the tags widget must be enabled by
an organization administrator [580].
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2. Enter the tag name in the available field. You can select from a pull-down menu that appears when
you begin typing or, if you're making a new tag, press enter when you're done typing. 

3. To delete a tag from an item, select the X in the tag.

Attachments
Attachments are external files such as images, documents, and spreadsheets that can be attached to
an item.

A project administrator can manage attachments [632] for a project. 

Add, edit, and delete attachments

NOTE
You must have create/edit permissions to access attachments.

1. In Single Item View, select Add attachment.
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2. In the Add file attachment window, you can choose to attach files that are already uploaded to
Jama Connect or to upload new items. To upload, select the Upload tab, then select Choose file
to choose the file you want to attach and upload.

To choose from existing files, select the Existing tab, then select the file you want to attach. Select
Show all to see all the files that are already attached to an item. 
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NOTE
These default filetypes are allowed: APK, AVI, BMP, CSV, DOC, DOCM, DOCX,
DOT, DOTX, DWG, GIF, GZ, JAMA, JPEG, LOG, MD, MOV, MP3, MP4, MPEG,
ODG, ODP, ODS, ODT, PAGES, PDF, PGP, PNG, PPT, PPTM, PPTX, RAR, RTF,
TGZ, TIF, TIFF, TRA, TXT, VCS, VSD, VSDX, VSS, WAR, WAV, WMA, WMV,
WPS, XCF, XLS, XLSB, XLSM, XLSX, XLT, XPS, ZIP, ZIPX.

For cloud customers who want to add filetypes, or ask about the number or size
limits for attachments, your Named Support Contact can request this from support.

For self-hosted customers, the system administrator can update this list directly
[495].

3. Select Attach to item. 
4. The file is now shown in Single Item View as an attachment.

Select the attachment name or the down arrow icon to download the attachment.
Select the trash icon to delete the attachment.
Select the three dots icon to open the Edit file attachment window. From here, you can reload
the attachment or update the name and description. If you upload a different attachment from this
window, it overwrites the existing one. To add a new attachment, start from step 1. 
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Find content

The content you want to find might be anywhere in your project. For example, you might want to look at
the requirements or test plans.

Jama Connect gives you many ways to directly access the items you need:

• Search [136] — Look through an index of your item type fields, as well as text within a Word docu-
ment, a PDF document, or text attachments, to bring up a list of items.
Use the search bar in the header to help you find the topic you're looking for.

• Filter [138] — Limit the results of a search to a group of items by content such as author, keyword,
date, or coverage. You can also filter stream comments, review comments, reviews, review items,
Trace View items, and project items.
Select Filter items at the top of the center panel in List View or Reading View to open the filter panel
and filter out the items you want to see.

• Advanced filters [139] — Save a set of rules or conditions for later use and share that filter with other
users.

• Quick find [144] — If you don't remember where to find something in the application, use the quick
find [144] topic in this guide.

You can also find moved items [150] or find an item in the Explorer Tree [151].

Full text search
Jama Connect uses an index of the database fields for its search function. It also searches in text, Word
files, and PDF files to find the items you're looking for.

You can search item IDs, descriptions, attachments, and field values. Search for a specific unique item
ID (not global ID) and it opens.

Important considerations

• The application doesn't support searches for null values. This includes checkboxes that haven't been
checked.

• Files over 25 MB aren't indexed so their content isn't searchable.
• The following file types are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF.
• The following file types are not indexable: XLSX, XLS, XML, HTML, HTM.

Ways you can search

You can search for a word or a phrase for a simple search, and you can use advanced methods like
wildcards, Boolean operators, and more to find the items you need.

• Single term — Use a single word to find items with that exact term or items that contain that term.
For example, Test returns items with the terms test, pretest, tests, tested, and tester.

• Phrase — Use a group of words surrounded by double quotes. For example, “primary test" re-
turns only items that contain the words primary test.

• Single character wildcard — Use a single character wildcard (?) with a single term (not a phrase).
For example, te?t returns items that contain test, tent, and text.

• Multi-character wildcard — Use a multi-character wildcard (*) with a single term (not a phrase). For
example, syn*ize returns items containing the terms synchronize and synthesize.
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NOTE
You can't begin a search with a wildcard (such as ?!*) or you will receive a syntax
error.

• Boolean operators — Boolean operators in ALL CAPS to combine phrases or terms.
• OR (||) is the default Boolean operator when you enter two terms or phrases. For example, pri-
mary test or sample returns items that contain either primary test OR sample.

• AND returns items where both terms and phrases exist. For example, primary test and sam-
ple returns documents that contain both primary test and sample.

• + returns items that must contain the term or phrase immediately following the +. For example,
+primary test returns items that must contain primary and might contain test.

• NOT (-) excludes items that contain the word or phrase after NOT. The application doesn't allow
null searches, so you must enter something before the word NOT to get any results. For example,
primary test NOT sample returns items that contain primary test but not sample.

• Parentheses — Use parentheses to group clauses and form sub queries. For example, (tests OR
samples) AND maps return results that contain tests, maps, samples and maps or all three
terms.

• Prefix — Use the prefix tag: to indicate the tag field in your query. For example, tag: require-
ment management AND tag:security.

• Field name — Use field names followed by a colon to search for information in specific fields. For
field names that contain spaces use an underscore. For example, user_status:new returns items
with a User status field that contains new.

Search for content
Need to search across all projects or within a current project? Enter a query in the search field to find
what you need.

For more complex searches, use advanced filters [139].

You must have read permissions for projects or sets to be included in your search results.

1. From the drop-down menu in the upper right header, select where you want to search:
• Project — Within the current project.
• All — Across all projects in your organization.

2. Enter your query in the search field and press Enter.

3. (Optional) Select Filter items to refine your search. For details, see Filter items for targeted results
[138].
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The results appear in List View.

Filter items for targeted results
Using a filter is an easy way to refine your search results. To limit and focus your text search, you can
filter content by author, date, or coverage.

Filters can't be saved. If you want to reuse a specific filter, use the advanced filters.

1. In Projects, select Filter items to open the Filter by panel.

2. Define how you want to filter your results. Filters are cumulative and the options you select are dis-
played at the top of the screen.
• Keyword — Enter a term in the Keyword field.
• Item Type — Templates for sets used within each project. For example, you can filter by System

Requirement, Set, Folder, or more.
• Author — The person who created or last modified the item.
• Direct Coverage — Parameters for upstream, downstream, missing, and suspect relationships.
• Last Modified — Time stamp of when the item was last modified.

Jama Connect User Guide

138



The search results appear in List View.
3. When you're done, select Hide Filters to close the panel.

Any applied filters are preserved and visible at the top of the page.

Advanced filters
With advanced filters you can save a set of rules or conditions for later use and share that filter with
other users.

Add or edit advanced filters [140], bookmark them, or use them to filter the Explorer Tree [143] or send
items for review [157].

Rules and conditions

• Each rule is matched to a specific item type or all item types having specified conditions.
• A condition describes specific attributes of an item (fields of an item type, tags, relationships, location,

keyword, or if the item has children).
• Each rule can contain any number of these conditions.
• The rule can be set to return items that follow any one of the conditions, all of the conditions, or none

of the conditions (which acts as the inverse of "any").

Finding advanced filters

In the left panel next to the Explorer Tree tab, select Filters.

Tip: Hover of the filter name to see the author's name.
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CAUTION
You can delete a filter when you no longer need it. Before you do, make sure the filter
isn’t shared. If you delete a shared filter, even if you're not the creator, it's deleted for
everyone.

Add or edit advanced filters
Running a filter against all your Jama Connect projects can return large data sets and degrade perform-
ance. For best results and quality performance, make filters more specific to return only the results you
need.

NOTE
Only organization administrators can edit filters that they didn't create. Depending on
your permission, you might not be able to edit filters that were created by other users.
To view their details, right-click on the filter name under the Filters tab and select View
criteria.

1. In the Explorer Tree, select the Filters tab.
2. Select Add filter to open the New filter window.
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3. Name the filter and indicate the project scope by selecting one of these options:
• This project only — Use this filter to query data from the project the user is viewing at the time.

The filter appears only when using this project.
• Current project — Use this filter to query data from the project the user is viewing at the time.

But the filter is also available for use in other projects.
• All projects — The filter pulls data from every project in the organization that the user has per-

missions to view. Using this option, you can see items from other projects that match the filter
criteria.

4. (Optional) Select Make public to make the filter public. This filter is available to anyone with ac-
cess to the project.

5. Define your filter. Condition options change depending on which item type is selected.
• Select Add rule to create a new rule. A filter can contain any number of rules. 
• Add a condition (+)
• Remove a condition (–)
• Select the blue Add condition group button to add a condition group. Condition options change

depending on which item type is selected.

• If your relationship condition requires a sub-filter, select this filter... to open the Embedded Fil-
ter window.
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Example: A filter to identify all change requests with downstream relationships to requirements.
Create a filter to identify change requests with downstream relationships and another sub-filter to
limit downstream items to the relationship item type.

• To limit the filter to items updated within a certain amount of time, use the drop-down menu next
to Limit to items updated within.

• To define the how the results are sorted on output, use the drop-down menus next to Sort order
for results by. 

6. Preview your results by selecting Preview in the bottom left corner of the New filter window. Re-
sults appear in the same window.

7. Choose from one of these options:
• Select Save.
• Select Back to Filter to make changes to the filter.
• Select View in List to see the filtered items in List View. Your filter isn't saved.

Duplicate advanced filters
Advanced filters allow you to use complex criteria. To save time, copy a filter so you can reuse it in fu-
ture searches.

1. Under the Filters tab of the Explorer Tree, right-click on the filter you want to copy and select Du-
plicate.
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2. Enter a name and edit the filter settings [140].

3. Select Save.

Filter the Explorer Tree
The Explorer Tree can contain a lot of items, making it time consuming to find what you need. Apply an
existing filter to quickly locate multiple items.

1. To view saved filters, select the Filters tab in the Explorer Tree. 
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2. Right-click on the filter you want to use and select Apply filter to Explorer.

The filter results are shown in the Explorer Tree. Items in the hierarchy that don't apply are shown
in lighter text.

Export from advanced filters
Select the data you want to export using advanced filters and export directly to Word, Excel, or PDF. 

If you view your filter results in Reading View, the hierarchy container items are visible. These items
offer visual context and are included in your export. However, they can't be selected or changed from
this view.

1. Create the advanced filter [139] that gathers the items you want to export. 
2. Select Export and choose the output type.

Quick find
Do you know what you're looking for, but just forgot where it is in the application? Use this handy table
to quickly find what you need.

Note: Small screens display icons as image-only, without the text.
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To find... Where Select...

Baselines Explorer Tree Baselines tab

Dashboard • Upper left corner of the
screen

• Explorer Tree

Project name

Homepage Top header from anywhere in
Jama Connect

House icon

Impact Analysis Single Item View Single Item View > Impact analysis

Image-only version:
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To find... Where Select...

Item versions Single Item View (side toolbar) Versions widget

Relationships Single Item View (side toolbar) Relationships widget

Relationship
Status Indicator

• Side toolbar
• In a column in List View

(when configured)

Relationships widget

• Top number -- Represents the number of upstream items related
to this item.

• Bottom number -- Represents the number of downstream items.

If an item isn't in compliance with the relationship rules, it appears in
red. Otherwise, it's gray.

Relationship
rules

Single Item View Relationships widget > Relate items in the bottom panel > Show
relationship diagram at the top of the right panel

For more information, see Relationship rules quick find [148].
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To find... Where Select...

Releases Top of the left panel Releases

Review status Header Reviews

• Grid -- Displays review status at the bottom of each card.

• Table -- Displays review status in Review status column.

Risk analyses Header Risk

Suspect links • List View
• Single Item View
• Advanced filters
• Explorer Tree

You can find suspect links from several places in Jama Connect. For
more information about finding suspect links, see Suspect links quick
find [148].

Test cases • Explorer Tree
• Projects > List View
• Projects > Trace View

You can find test cases from several places in Jama Connect. For
more information about finding test cases, see Test cases quick find
[150].

Test plans Explorer Tree Test Plans tab > <plan>

Trace View Projects Trace View button
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To find... Where Select...

Traceability Ma-
trix

Projects > Project > Traceability Trace Matrix

Relationship rules quick find
Relationship rules are set up by an organization administrator [605], but can be viewed by all users in
two places.

• In Single Item View, select the Relationships widget, select Relate items in the bottom panel, then
select Show relationship diagram at the top of the right panel. The relationship diagram for this
project appears in a pop-up window.

• Display the diagram for a project on the dashboard [351].

Suspect links quick find
You can find suspect links [266] using one of these methods.
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• To view (or clear [266]) all suspect links for a project, select Project > Suspect links.

• To view all suspect links for an item, open an item in Single Item View [56] and select Relationships
in the side toolbar to open the bottom panel.

In the Suspect column, you can see if an item is suspect because of upstream changes. You can
also clear suspect links [266].

• In List View or Single Item View, view suspect links in the Relationship Status Indicator [265].
• Find suspect links using advanced filters [139].
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Test cases quick find
You can find test cases using one of these methods.

• Look for test cases in the Explorer Tree [47].
• Projects > Trace View [53] where they appear in relationship to items they test, along with associ-

ated test runs.
• Projects > List View [52] where you can filter by item type name to find test cases.
• Test Plans where you can see them in the test cases section of the plan by selecting Test Cases.

Find moved items
If you don't know where to look for items that were moved, you can use the Activity Stream to find and
access recently moved items. This is also an easy way to move all items back to the previous location
(or to another location) after a move is made.

1. Open the Activity stream and use the search box to search for moved items.
2. Hover your mouse over the location to see a file path.
3. Select View moved items to see the files that were moved.
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4. (Optional) In List View, you can move items.

Find an item in the Explorer Tree
If you've navigated to an item from search results, filter results, or tags, you can quickly locate an item
in the Explorer Tree.

NOTE
When viewing the Explorer Tree, some items aren't visible if a component, set, or fold-
er contains over 250 items.

• From the Single Item View toolbar, use interactive links (formerly called "Find me") to find a location
in your project hierarchy.

• From the Explorer Tree, view the highlighted item you want to find.
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Reviews in Jama Connect

Reviews play a key role in successful product development. They help ensure that a new project meets
stakeholder, market, and compliance requirements.

Jama Connect uses an iterative and collaborative approach for reviewing requirements and other arti-
facts in real-time, which improves stakeholder alignment, reduces review cycles, and eases the path to
compliance.

Your organization administrator configures review center settings [613] to meet the needs of your or-
ganization.

Review features include a wizard that streamlines review setup and electronic signatures for coordina-
ted approval and signoff.

Roles for review workflow
Your role determines which tasks you perform in a review.

Moderator — Create, manage, finalize, and close a review.

Approver — Provide feedback and approve or reject the item during the review.

Reviewer — Provide feedback.

Review Administrator — See and manage all reviews.

Role Responsibilities and actions

Moderator • Initiate a review.
• Add and manage review participants.
• Modify a review.
• Edit an item to incorporate feedback.
• Close and reopen a review.
• Publish a revised review.
• Finalize a review.
• Archive a review.
• Delete a review.
• Recover an archived review.
• Transition items based on item workflow.

Reviewer* • Contribute feedback.
• Finish a review as a reviewer.

Approver • Contribute feedback.
• Approve or reject review items.
• Delegate approval.
• Finish the review as an approver.
• Add electronic signatures to a review.

Review administrator • View a list of all reviews.
• Perform administration tasks for all reviews, whether or not they were invited to participate.
• Archive and unarchive a review.
• Recover a deleted review.
• Configure review comments.

All • Find and view review items.
• Compare versions.
• Monitor progress.
• Vote on items.
• Subscribe to items on the page.

* Moderators and approvers can also perform all reviewer actions.
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Review lifecycle — Who does what during a review
Action Moderator Reviewer Approver Review Ad-

min

Initiate a review [157] X

Invite participants [162] X X

Add and manage review participants [164] X

Modify a review [164] X

Delegate approval [177] X

Participate as a reviewer [172] X X X

Find and view review items [182] X X X X

Contribute feedback [173] X X X

Finish the review as a reviewer [174] X X

Finish the review as an approver [176] X

Electronically sign the review [177] X

Edit items in a review [165] X

Close a review [167] X

Mark a review as completed and update workflow status [171] X

Compare versions [185] X X X X

Monitor progress [187] X X X X

Vote on items [192] X X X X

Subscribe to items on the page [191] X X X X

View list of all reviews [155] X

Perform administration tasks for all reviews [178] X

Archive a review [169] X X

Recover an archived review [169] X X

Recover a deleted review [179] X

Configure review comments [180] X

Workflow status for reviews
The review status field shows the current workflow stage (status) of a review. This field changes as a
result of other operations, like closing and archiving a review.

Review status is visible in Grid View and Table View [154].

Status Definition

In progress Default status when moderator initiates a review. [157] Status can be changed to “In progress” when the
moderator restores a deleted review or marks the review status as "In progress [154]."

Closed for feed-
back

Automatic status when the review deadline is reached or when the moderator closes a review [167].

Completed Status displayed when a moderator selects Close for feedback or a deadline date is met.

Review finalized Status when a moderator marks a review as finalized.

Archived Status when a moderator archives a review [169], or when a review administrator recovers a deleted re-
view or sets the status to "Archived."

Deleted Status when a moderator or review administrator deletes a review [168].

Review status quick find
Quickly find a review status using one of these methods.
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Location Option

Reviews (header) Select Grid to see the review status at the bottom of each card.

Table Select Table. Review status appears in the Review status column.

Review Center dashboard views
Access reviews from the top navigation by selecting Reviews in the header.

From the header, you have two options:

My reviews All reviews where you are assigned as a reviewer [172], approver [175], or moderator [156].

All reviews Reviews that haven't yet been archived.

What you see in the dashboard

What is displayed in the dashboard depends on your role, whether you’ve been invited to a review, and
the options you select.
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Review administrators — See all reviews.

Users — See only public reviews until they are invited to a review (depends on how your organization
administrator and moderator have set public review permissions).

Filter by — Filter reviews by review status or by your role in the review.

Include/Hide archived reviews — See reviews that have been archived or remove them from your re-
sults.

The indicator for a pubic review depends on your view:

Grid View Table View

Moderator tasks
Certain tasks can only be performed by a moderator. Moderators can also be reviewers or approvers, in
which case they can perform all tasks for those roles as well as moderator tasks.

• Initiate a review [157]
• Add and manage participants [164]
• Modify a review [164]
• Incorporate feedback for review items [165]
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• Close an "in progress" review for feedback [167]
• Finalize a review [168]
• Publish a revised workflow [168]
• Archive a review [169]
• Delete a review [168]
• Recover an archived review [169]
• Transition a Peer review to an Approval review [170]
• Close and finalize Approval review [171]

Initiate a review
You can create reviews for any item or group of items that you can access. By default, you are the mod-
erator for any reviews you create.

You can start a review from several places in the interface. Whichever method you use, a wizard opens
and guides you through the process.

Method/location Action

Reviews Select Reviews in the top navigation, then select Start a review.

Test plan Select Test runs > Cycle > Send for review to send a cycle of test runs to review.

Note: To send an entire test plan for review, select Test Plans, right-click on the test plan, and select
Send for review.

Projects > Single
Item View

Select the item you want to review, then from the Actions drop-down menu, select Send for review.

Projects > List View Select the items you want to review, them from the Actions drop-down menu, select Send for review.

Explorer Tree Right-click on an item and select Send for review.

Filters tab — Right-click on the filter that points to the items you want to review, then select Send for
review.

Releases tab — Right-click on the filter that points to the release you want to review, then select Send
for review.

Baselines tab — Right-click on the source that includes the baselined items you want to review, then
select Send for review (reviews the items in their current state, not their baselined state). If all items
from an existing source were deleted, you can't select Send for review from the baseline tree.

TIP
When you initiate a review, a baseline of the selected reviews is automatically gener-
ated [245]. You can find this baseline [245] under the Baselines tab or you can find a
link under the Versions tab of any item in this review.

To start a review:

1. Select the items you want to review using one of the methods described in the previous table.
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2. Definition [158] — Define your review.
3. Settings [160] — Configure the settings for your review.
4. Participants [162] — Configure who you want to review your items.
5. Invitation [163] — Complete the invitation email.

Definition
When you initiate a review [157], the first step is to define the review.

1. If you selected items before initiating the review, the system suggests a name, or select a name for
the review.

2. Set a deadline for the review, or the deadline defaults to one week from today.

NOTE
If you're using Windows, be sure that "Adjust for daylight saving time automatically"
is enabled in "Date and time" settings in Windows, so that the time zone is dis-
played correctly when initiating a review.

3. If you selected items before initiating the review, the Project field shows the name of the source
project. Otherwise, select the Project that contains the items for this review.

4. If you selected items before initiating the review, this field isn't editable. Otherwise, select the items
that you want to review.
You can select whole containers or expand the containers to select individual items. You can also
use the Releases or Filters tab to select a release or filter to send to review. You can't select items
from multiple tabs. Use the Select button to indicate your choice is complete.
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5. Select Include item attachments to add item attachments to the review.

When the review is created, you see attachments for the item in each section of the review (if they
exist). Select the attachment link to open the latest version of the attachment.

6. Select Include related items to see options for making upstream and downstream items visible in
the review (as long as such items exist).
You see each item type that's related either upstream or downstream, along with a count of the
number of related items.
Select Show filters to filter those relationships by relationship type.
Select the related items you want to include in the review.
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7. Select Next.

Settings
When you initiate a review [157], the second step is to choose the review settings. This image shows
the default settings. Additional settings are available only if they are configured by an organization or
process administrator.
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You see the Review template option if it's enabled in Review center by an organization admin. For more
information about review templates, see Item workflow for Approval Reviews [614].

1. Select electronic signature settings.
If you select Require electronic signatures from approvers, all approvers must sign the review in
order to approve it. Select Enable signature group for approvers if you want your review signa-
tures to have a particular signer role. Find out more about how electronic signatures work [222].

2. Select permission settings.
Allow for review comments to also appear in the single item view within a project:
Administrators must first enable this option in the Review Center Settings for this option to appear.
Make public: This option makes the review visible beyond those invited to participate. An organiza-
tion administrator determines whether public reviews [613] can be seen by anyone with access to
reviews, or only by those with permission to ALL items in a review.
Let approvers add reviewers and approvers: Select to allow approvers to add others to the re-
view.
Let approvers delegate their review to others: Select to allow delegation of the approver role. If
an approver is assigned a signer role, and they delegate their approver role, the signer role is also
delegated.
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3. Select optional settings.
Enable time tracking: Check this box to track the amount of time each reviewer spends within the
review. The clock that tracks the time is visible to all participants in review statistics [187].
Notify me when a participant finishes a review: Check this box to send notification emails [194]
to the moderator when a reviewer marks a review complete or when a participant requests a new
version.
Enable voting: Check this box so participants can provide input on priority or other issues the mod-
erator needs to resolve. Read more about voting [192]. If you select this box, you are asked to des-
ignate the number of votes per user and a label for what the vote means.

4. Select Next.

Participants
When you initiate a review [157], the third step is to choose review participants.

IMPORTANT
Inviting anyone to a review gives them read access to the entire content of the review,
even if they don't have permission to the underlying items. 

1. Using the left column, select participants for this review.
Use the tabs at the top of the column to select from users on the project team, or from outside the
project team.
You can select individuals or groups. Search by name or email using the field at the top of the list. If
you select a group, you can add all users or select individual users from the group.
Select the Invite user by email tab to invite users from outside of Jama Connect. Those users re-
ceive an email invitation with a link to the review. When they select the link, they are given a review-
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er license (as long as there are floating reviewer licenses available) and are asked to set up an ac-
count. They can only access the review you invite them to.

IMPORTANT
An organization administrator can disable this function or can restrict the domains
for which outside review invitations are allowed. [613]

2. Selected participants appear in the right panel. Select a review role for each participant (approver
[175] or reviewer [172]).
If you enabled signer roles [160], you can also assign a signer role to each approver.
Signer roles are based on groups. If you select a group name, then select All users, the signer role
for those users defaults to the group name.

3. Select Next.

Invitation
When you initiate a review [157], the final step is to complete the invitation.

1. You see a draft of the email that's sent to participants. At the top, it shows the total number of par-
ticipants who receive the email and their roles.
Fields for the email subject and message are the only two fields you can modify in this panel.
The email also shows the review role and signer role as determined in the participants panel
[162]. For reviews that have participants with different reviewer roles, light gray text shows informa-
tion that might vary for each participant.
The signature meaning is the same for all reviews and defaults to "I approve this review" and can't
be modified.
The email includes a link to the review and the deadline.

2. Select Initiate review to receive a confirmation that your email was sent.
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Add and manage review participants
As a moderator, you can add or remove moderators from your review.

1. In a review, select Update moderators from the Actions drop-down menu or from the Actions col-
umn in the table view when you select Reviews in the header.
The Update Moderators window opens.

2. Add moderators from your team (Project Team tab) or from outside your team/Jama Connect (Out-
side Project Team tab).

3. To remove a moderator, select the X next to the name in the Review Moderators panel.
4. (Optional) Add a comment about the changes you made.
5. To finish, select Update Moderators.

Important considerations

• If you remove yourself from a review, you no longer have access to that review. All added and exist-
ing moderators receive email notifications for changes to the list of moderators during the review.

• Moderators can be added to a review regardless of their access rights to the items in the review.
However, when a new revision for the review is published, it includes only items that moderators have
write access to. This can have unexpected consequences for reviews sent from filters, such as miss-
ing or extra items in the new revision.

Modifying an "In progress" review
You might want to change the content that's included in a review, the due date, or the participants. You
can also close a review so that feedback is no longer allowed.

Only a moderator [156] or a review administrator [178] can change a review.

You can change a review from different locations and views in Jama Connect:
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• In a review, use the Finish drop-down menu.

• In Reviews > Table View, use the Actions column.

The icons in the Actions column are:
Edit — Open the wizard where you change the deadline, invite new reviewers, or change an approv-
er’s status (role).
Reopen — Open a review that was closed.
Delete — Remove a review permanently (only a review administrator can recover a deleted review).
Update moderators  — Add to or remove moderators from your review.
Archive  — Remove the review from the list that appears to users.

Modifying a "Closed" review
A review closes automatically on the end date and time or it can be closed manually by the modera-
tor. When a review is closed, reviewers can no longer add comments.

As the moderator, you might want to reopen a closed review to allow more feedback, archive the re-
view, or publish a new version.

Only a moderator or a review administrator can edit a review.

When viewing a closed review, you see a blue status bar at the top of the review, which notifies partici-
pants if a review is closed.

Use the buttons on the blue status bar, the Actions menu, or Reviews > List View to do the following
with a closed review:

• Archive — Remove a review from the primary list of reviews.
• Recover — Recover a review that was archived or deleted. No item updates are published.
• Publish new revision — Publish a new version of the review that includes any changes made to the

original items, and change any options for the review itself.

Incorporate review feedback
A moderator can incorporate feedback by editing an item directly from the review.

1. From the header, select Reviews, then open the item using one of these menus:

Triangle drop-down menu Menu next to item's name
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You can also select the name of the item you want to edit to open it, then select Edit item from the
menu on the right. 

2. In the window that opens, make the changes you need.

3. (Optional) Select Notify to designate people or groups you want to inform about this change,
choose the people to be informed, then select Save and close.
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Your changes are saved in the project, but not in the review.

Any time an update is made to an item that's in review, a blue status bar appears at the top of the
review. The review remains unchanged until the moderator publishes a new version.

4. Select Commit.
5. To update change in the review click Publish new revision.
6. In the window that opens, select one:

• Publish — Update the review for all participants.
• Modify review — Make further changes to the review itself in the wizard.

Participants receive an email notifying them about the new revision.

Close an "In progress" review
A review closes automatically when its deadline is reached. A moderator might want to close a review
manually before the deadline if, for example, all reviewers already provided feedback.

Once a review is closed, a moderator can recover it by changing the status back to “In progress.”

1. To close a review manually that you are currently viewing, select Finish > Close for feedback.

The closed review now displays the message “This review is closed” in the blue status bar.
2. To reopen a closed review, select Recover in the blue status bar of the review.
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The blue status bar no longer appears when the review is reopened.

Publish a revised review
When changes are made to the original review items, you can publish a new version of the review that
includes the changes.

1. Open a review that includes changes. The blue status bar indicates that you can publish a revision.

2. Select Publish updated revision to include these changes in the review.
3. Select an option:

• Publish — Publish the revision immediately (available only when a new version of an item is cre-
ated).

• Modify review — Change more options for the review in the wizard.

Finalize a review
When you’re satisfied that your review is complete — that all items have been reviewed and approved
and that all comments have been resolved — the next step is to finalize the review. 

Important considerations

• When you finalize the review, the review workflow tool automatically updates the status of the review
items. For example, at the end of a review, a moderator can trigger the status of reviewed items to
change from "In review" to "Approved." 

• If workflow is assigned to an item type in your Approval review [614], the item will transition. If you
don't use a template, the review is marked as finalized.

1. In the review, select Finish > Mark review as finalized.

2. In the window that opens, select Finalize review.

This action automatically triggers Review Status Workflow, which updates the status of the review.

Delete a review
You can delete a review, but not if it includes electronic signatures. However, if an entire project is de-
leted, all reviews in that project are also deleted, even if they include electronic signatures.

Once a review is deleted, only a review administrator can recover it.

1. From the header, select the trash icon.

Jama Connect User Guide

168



2. When prompted to confirm, select Yes.

Now, when a user selects Reviews, the review that you just deleted is no longer listed with other re-
views.

Archive a review
When a review is archived, it's no longer visible in the list that’s displayed when users select Reviews in
the header.

Reviews can only be archived by moderators and review administrator, and only if their status is
“Closed.”

As the moderator, you can control which reviews are visible to your participants:

• Select Filter by > Include archived reviews.
• Select Filter by > Hide archived reviews.

1. From the header, select Reviews > Table. 
2. In the Actions column of the review you want to archive, select the folder icon to archive the re-

view, then confirm when prompted.

Recover an archived review
A moderator or review administrator can recover a review that was archived [169].

When an archived review is recovered, the participant roles and contributions are unchanged. For ex-
ample, if an approver signed and approved a review before it was archived or deleted, it remains the
same after the review is recovered.

If items were edited after a review was archived or deleted, they don't appear in the recovered review
until the moderator publishes a revised review.

You can recover an archived review from the review’s Actions column or from its blue status bar.
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1. To recover an archived review from the Actions column:
1. From the header, select Reviews > Table.
2. In the row with the review you want to recover, select the Reopen icon from the Actions col-

umn.

3. In the window that opens under Select review status, use the drop-down menu to select "In
progress,"  select a new end date and time, then select Save.

2. To recover an archived review from the review’s blue status bar:
1. Open a review that was archived.
2. From the blue status bar across the top, select Recover.

Transition a Peer review to an Approval review
When reviewers are done looking over a Peer review, the moderator can transition a review to an Ap-
proval review.

Both templates must be enabled [614] by an organization administrator.

1. In the review, select Actions > Transition to Approval.
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The Transition to approval review wizard opens.
2. On the Definition page, make your changes, then click Next.

3. On the Settings page, confirm you’re using the approval template, then click Next.

4. On the Participants page, make your changes, then click Next.
5. On the Invitation page, update the subject and message as needed, then click Transition review.

A revision is created and an email notification is sent to reviewers.

Close and finalize Approval review
After the review is approved, the moderator closes and transitions items to their approved state. You
don’t need a Peer review to finalize an Approval review.

Workflow must be enabled [33] in Admin > Organization for the items in the review, or the option to
Close and transition items won't appear when you finalize a review.

Example with workflow disabled
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1. In the review, select Actions > Finalize approval review.
Wizard opens. can change the name and deadline. Can change participants.

2. View the review overview and workflow transitions, then click Finalize review.

The review is now closed.

Reviewer tasks
• Contribute feedback [173]
• Finish a review as a reviewer [174]

Reviewers can also perform tasks that are available to all review roles.

For example:
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• Find and view review items [182]
• Compare versions [185]
• Vote on items [192]
• Subscribe to items on the page [191]

For details, see Tasks for all review roles [181].

Contribute feedback
Once a review is created, all participants can read through the items, make comments, and ask ques-
tions.

By default, you see only comments made in a specific version. For example, comments made in version
2 only appear in that version.

1. From the review, open the Comment window using one of these methods:
• Select the Comments icon next to the item.
• Select the text you want to comment on.

2. Type your comment.
3. (Optional) Apply a category to your comment to help participants understand and track key feed-

back.
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Category Outline color Meaning

Comment / Speech bubble Yellow Open

Green Acknowledged by Moderator

Question mark Yellow Open

Green Answered by Moderator

Pencil / Proposed change Yellow Open

Green Accepted by Moderator

Red Rejected by Moderator

Exclamation / Issue Yellow Open

Green Resolved by Moderator

4. Select Submit feedback to save the comment.

Additional ways to collaborate with your team

• Use the like icon when you agree with a comment and want to track how team members vote on a
decision.

Finish a review as a reviewer
When you complete your work as a reviewer, the next step is to “finish” the review. This action lets the
moderator know you're done with your work (if notifications were set up) and updates the overall review
progress in review statistics [188].

If the review is closed before you finish the review, the blue status bar includes a message: “This review
is closed.”
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1. From the review, select Finish on the toolbar. 

2. In the review summary window, add any final comments, select Finish.
3. If you need to make more comments after finishing the review, select Actions > Reopen review,

as long as the moderator hasn’t yet closed the review.

Approver tasks
• Approve or reject review items [175]
• Finish a review as an approver [176]
• Add electronic signature to a review [177]
• Add reviewers [178]
• Delegate approval [177]

IMPORTANT
After delegating approval, you are no longer an approver, but you remain a reviewer
for the current review. If you delegate approval, all new approvers receive an email no-
tification.

Approve or reject review items
During a review, you can view items and their comments, approve or reject individual items, and ap-
prove or reject an entire review.

If you don't see a checkmark or X, you don't have Approver status. Contact your Moderator if you need
Approver status.

1. To mark an individual item, select an icon next to its name:
• Checkmark = Item is approved
• X = Item is rejected
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2. To mark all items on the page, use the Actions pull-down menu:
• Mark entire page approved
• Mark entire page rejected

3. If your review contains more than one page of items, repeat this action for each page.

When you're done, the blue status bar includes the message “You’ve marked all items in the review.”
You can then finish the review as an approver and electronically sign the review.

Finish a review as an approver

1. When you're finished with a review, select one of the following:
• Select Finish from the toolbar.

• Select Finish review in the blue banner that appears when you mark all items approved.

2. In the Review finished window, you can mark any remaining items "Approved" and add a final
comment. These comments are visible under Reviews > Feedback in the top-right menu, or in an
email sent to the moderator if email notifications are enabled for this review. If this review requires
an electronic signature [177], you can also add that here.

3. Select Request new revision or Approve (or Approve and sign if you're using an electronic sig-
nature).
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NOTE
If you change your mind and want to reopen your review after finishing a review as an
approver, you can select  Actions > Reopen review to re-open it, as long as the mod-
erator hasn't closed the review. If you're using an electronic signature [222], opening a
review revokes it.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.

1. In the Review finished window, enter your username and password as your electronic signature.
If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.

Delegate approval
Assign approval to another team member if you're away when a review needs to be approved or some-
one else is a better fit.

1. In the review, select Actions > Delegate my approval.
2. In the Request Reviewer Delegation window, select a delegate.
3. Click Delegate Approval.
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An email is sent to the new approver notifying them of the request.

Add reviewers
You can add reviewers to a review at any time.

1. In the review, select Add participants.

2. In the window, select the review participants you want to add.

3. Click Add participants.

An email is sent to the reviewers notifying them of the request.

Review administrator tasks
• Recover a deleted review [179]
• Configure review comments to appear in projects [180]
• Recover an archived review [169]
• Modify a review [164]
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• Make a review public [160]

Important considerations

• Permissions for a review administrator must be assigned by an organization administrator.
• As a review administrator, you can access a review's content when the review is public; when you are

also a reviewer, approver, or moderator in the review; or when you add yourself to the review.

Recover a deleted review
Only a review administrator can recover a review that was deleted.

When a deleted review is recovered, the participant roles and contributions are unchanged. For exam-
ple, if an approver signed and approved a review before it was deleted, it remains the same after the
review is recovered.

If items were edited after a review was deleted, they don't appear in the recovered review until the mod-
erator publishes a revised review.

1. From the header, select Reviews > Table. 
2. In the row with the review you want to recover, select the Reopen icon in the Actions column.

3. In the Recover review window, select the new end date for the review.

4. Click Save.

The table is refreshed and the review is now open.
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Configure review comments to appear in projects
Comments made during reviews can provide valuable context, whether you're reviewing a requirement,
lower-level feature, or test item. A record of those comments offers enhanced traceability, so you can
make informed decisions over the course of the item's lifecycle.

The review moderator can allow comments from a review to appear in the project view for that item.

When enabled, the Review comments widget appears in Single Item View. Select it to see the review
comments for that item.

This option needs to be enabled in two places for it to take effect. The organization administrator must
enable it in the Review Center Settings and the moderator must enable it when creating a review.

For the administrator

1. Select Admin > Organization > Review center.
2. Under Permission settings, select Allow for review comments to also appear..., then click Save

settings.
This option is now available and visible to review moderators when they create reviews.
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For the review moderator

• When creating a review, select Allow for review comments to also appear in the single item view
within a project.

Once enabled, comments are grouped by review and sorted with the latest comments at the top.

Tips and more

• Why aren't comments appearing? For review comments to be visible within a project, this setting
must be enabled for each review.

• How do I see comments from older reviews? For reviews created without this setting, you can go
back and change this setting to include review comments.

• View More — Appears if there are more comments from that review that haven't loaded.
• Load More — Provides comments from older reviews that haven't loaded, including comments that

might have occurred since the page loaded.

Tasks for all participant roles
• Find and filter items in a review [182]
• Highlighting review comments [183]
• Compare versions [185]
• Show related items in a review [186]
• View participant progress [187]
• View item progress [188]
• View review activity [189]
• Filter review comments [190]
• Subscribe to a review [191]
• Export reviews [191]
• Voting [192]
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Find and filter items in a review
All user roles can search for and filter specific items in a review.

You can navigate to different areas of the review workspace without losing your filter or search selec-
tion. For example, if you make a filter selection and go to another view, your filter selection is saved
when you navigate back to the review.

Find items in a review

• Enter text in the Search field, then expand the Choose item types drop-down menu to filter your
search.

• Select the item type, then enter text in the Search field.

When you select an item from the search results or table of contents, the item is selected and outlined
in blue. In the Find item panel, you can refine your search based on the filtered results.

Filter items in a review

Use filtering to view items and comments that need your attention.
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All review participants can filter items to find comments by status, version, author, or activity.

All review participants can filter items to find comments by status, version, author, and activity.

All review participants can filter review items by Activity, Comments by status, Comments by ver-
sion, and Comments by author. Selecting and applying filters in a specific category is additive and
applies ADD statements to each selection. If you apply filters that span multiple filter categories, it be-
comes an OR statement.

Highlighting review comments
You can organize and find comments based on their status: Open, Resolved, or Rejected. Comments of
each status type are highlighted by a different color (highlighting is turned on by default).

For example, a comment highlighted in yellow lets review participants know that it’s open, while a com-
ment highlighted in red indicates that a proposed change was rejected.

By default, the review version that you’re looking at shows only highlighted comments that are open,
resolved, or rejected.
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When two highlighted comments overlap, that text is highlighted in light blue.

Moderators resolve an open comment: select it, (optional) type a response and click Reply, then click
Resolve.

The comment box and highlighted text changes to a resolved status (green).
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Compare versions
Whenever a published review has more than one version, you can compare two versions.

Good to know

• If you want to make other fields visible in the review, an organization administrator can configure item
type views [600] for Reading View or Single Item View to show those fields.

• Typically, item fields contain fewer than 10,000 characters (2,000 words). When you compare review
versions, the applications might skip fields with lengthy content.

• The date and version a comment was added appears in the comment.

1. From the review with the versions you want to compare, click Compare.

2. Select the versions drop-down menu near the review title to select the version you want to compare
to the current review.
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Changes are displayed inline. Deleted text is red and highlighted. Added text is green and under-
lined.

The "compare view" displays inline changes for most field types. If the field can't be compared, you
see the message: Not available for reviews.

Show related items in a review
Including related items in a review gives reviewers context and helps them understand the coverage of
items in a review. Related items are visible only if the moderator selected the option Include related
items when the review was created.  
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If you don't have permissions to view a related item, you see an item type icon and the text This item is
outside the scope of this review.

To view items directly related to a review item:

1. In the review, select Show related items.

Initially, up to five upstream and downstream items are displayed.
2. To view additional related items, select Load More Downstream Items.

3. Select a related item to see more details.

View participant progress
As a review progresses, you can view statistics about the participants' progress. This information is
unique to the current version of the review.
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In separate tabs, you can see item progress [188] for this version, or review activity [189] across ver-
sions.

1. From the review with stats you want to view, select Stats.

2. Under the Participant progress tab, you can see a panel with participant details and links to email
participants.
Next to that, bar charts show overall progress for the review for approvers and reviewers who have
finished the review. For approvers the chart shows how many items they marked approved or re-
jected. For other reviewers it shows how many items are marked read. Reviewers' time spent.
Below that, each participant is listed with their review role, signer role, signature information, com-
ment count, time spent shown in hours:minutes, and a progress bar showing their completion level.

NOTE
Time is logged if a tab with the review is left open by a reviewer.

View item progress
As a review progresses, you can view statistics about the progress of the items in review. This informa-
tion is unique to the current version of the review.

In separate tabs, you can see participant progress [187] for this version and review activity [189] across
versions.

• From the review with the items you want to view, select Stats.
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Under the Item progress tab, you see an overview with the total number of items in the review, their
item types, the start and end dates for this version of the review, the current approval status for all
items (if this review uses approvers), and a summary of open comments in the review.
Below that, is a table showing item fields along with the number of votes, as well as the number of
participants who marked the item approved, rejected, or reviewed.

For reviews with multiple approvers, the item approval status count increases when all approvers ap-
prove the item. However, it only takes one approver to reject an item for the rejected count to in-
crease. Items that aren't marked as approved or rejected are considered not reviewed. Items that
aren't marked as approved or rejected are considered not reviewed.
If you're a moderator, you see the preset filters to filter the list by item type, folder, or set. You can use
Views to configure which fields are visible in the table. You can use Actions to batch update items
[116].

View review activity
You can see all activities for a review across versions, including when reviews were opened, closed,
when new versions were published or when signatures were added. This can be useful for collecting
electronic signature [222] information for FDA 21 CFR Part 11 compliance.

You can also see item progress [188] and participant progress [187] for each version of the review.

1. From the review with activities you want to view, select Stats.
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2. In the page that opens, select the Review activity tab.
The table shows activity for all versions since the review was created.

Filter review comments
You can view and filter comments for all the items in a review to find only the comments you want to
see. 

1. From the review, select Feedback to see all the comments for the review, with a filter panel on the
left. 
You can read and reply to comments here.

2. (Optional) You can also use the filters in the filter panel to search for comments by category or key-
word. Available categories are:

Jama Connect User Guide

190



All Every comment from the review.

Open Comments the moderator hasn't acknowledged or responded to

Mine Your comments

Review Comments sent to participants about the review by email

Important Comments flagged as important by a moderator

Questions Comments that are questions to be answered

Proposed changes Comments that suggest changes

Issues Comments that raise issues

Subscribe to a review
If you're a review participant, you can stay up-to-date on review comments with email notifications in
reviews where you're a participant.

To receive notifications, you must first configure your review subscriptions [41] in your profile. You can
also configure your profile so that you automatically follow an item when you comment on it.

1. Open the review with the items you want to subscribe.
2. Select Actions > Subscribe to the items on this page.

IMPORTANT
Some reviews contain multiple pages of items. To subscribe to all the items in a
large review, you must subscribe to items on multiple pages.

Export reviews
You can export reviews as a Word document or a PDF by selecting Export anywhere in Reviews.

Review exports can't be customized, the export uses the default Word template.

You have two export options:

• Export activity review — Includes all review activities [189] across versions (for example, when the
review was created, versioned, closed, marked as finalized) along with the date, name, and role of
the person responsible.

• Export version review — Includes an overview of the review, a list of participants with their review
role, signer role, signature meaning and status, as well as the content of the review and the com-
ments.

To download an export to your desktop:

1. In the review you want to export, select Export in the top right toolbar.
2. Select the type of export and format.
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3. In the window that opens, choose how you'd like to open the file, then click OK.

The file opens in a new tab.

Voting
With voting, your team can prioritize items or rank them based on a topic proposed by the moderator.
Each participant has a certain number of votes. Participants can give multiple votes to a single item.

Moderators can enable voting in the settings [160] when they initiate a review.
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You can apply votes as a participant using one of these methods:

• Select the up arrow to add a vote or the down arrow to subtract votes. The box on the left displays
the number of votes you used on that item. You also see how many votes you have left to use.

• Participants can also apply votes while viewing an item's detail.
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Collaborating with your team

For companies to turn today’s research into tomorrow’s products, teams must stay connected and
synchronized. Jama Connect equips teams to track decisions and ensure quality of the product they set
out to build.

Jama Connect links globally distributed team members and facilitates collaboration in the product devel-
opment lifecycle. It allows you to provide and capture feedback, decision making, and approval for re-
quirements and all product aspects under review.

Jama Connect enables efficient sharing of data, documents, files, information, and knowledge within
and across teams in your organization.

Use these features to work with your team, document conversations, and track decisions.

• Reviews [153] — A method to help teams, stakeholders, and customers discuss, evaluate, revise,
and approve items in the development process. For details, see Reviews in Jama Connect [153].

• Workflows [196] — An automated set of transitions, from one status to another, over the course of
an item's lifespan.

• Notifications [194] — Optional emails sent to groups or individuals to alert you when changes to
items are made.

• Stream [201] — A collection of the most recent comments and activities in the project.
• Electronic signatures [222] — A method for getting approval on electronic documents or forms.

Email notifications and subscriptions
Users can configure email and notification settings in their profile [38] to stay up to date with activity in
their projects.

IMPORTANT
To receive notifications in Jama Connect, your SMTP must be enabled by your system
administrator.

You can sign up for notifications to be sent to you automatically from several places in Jama Connect.

Notifications from... Sent to you...

Review [157] When you're invited to participate

When someone replies to your comments in a review

Workflow [634] When status of an item changes

Stream [211] When you're mentioned in the stream

System Health Report [547] With updates on license usage

Your Jama Connect administrators control what you can do with subscriptions. For example:

• Organization administrators — Can allow users to subscribe others and to mute subscriptions.
• Project organization administrators — Can unsubscribe groups or individuals from any of their

subscriptions.

As a user, you can:
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• Set up notifications for a single item in a project or for an entire project.
• Configure email notifications and subscriptions.

Subscribe to emails for yourself
You can subscribe to a single item, to multiple items, or to an entire project.

1. To subscribe to a single item, select the item in Single Item View, then select Subscribe.

2. To subscribe to multiple items:
1. Open the items in Project > List View.
2. Select each item you want to subscribe to.
3. Select Subscribe.

A confirmation message appears below the toolbar.

Subscribe other users to email notifications
You must be a system, organization, or project administrator to subscribe others to all items at a project
level.

1. To subscribe others to a single item, select the item in Single Item View, then select Subscribe >
Subscribe others.

2. To subscribe others to multiple items:
1. Open the items in Projects > List View.
2. Select each item you want to subscribe to.
3. Select Subscribe > Subscribe others.
4. In the Subscribe Others window, select the groups or users that you want to subscribe to this

item.
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5. Click OK.

Workflow
A workflow is a set of transitions from one status to another, over the course of an item's lifespan. 

All workflows must be set up by an organization or process administrator before they can be used.

Workflow can be used in these scenarios:

• Project items [196] — Creates a common pathway for items to follow.
• Review items [614] — Allows organizations to configure items to transition to a specific workflow state

following the review process.

Using workflow in Projects
You can set up a workflow for Project items, so that users at your organization can move items in your
project along a similar path as they progress. 

Workflow in Projects allows you to:

• Update status for an item or group of items. Items must be the same type and in the same workflow
state.

• Transition items from one status to the next, either for a single item or as a batch transition for a
group of items.

If workflow is configured by an organization [634] or process admin, use the drop-down menu in Single
Item View to move the status of an item along the workflow and activate any related actions or notifica-
tions.
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Use workflow to batch transition items
With batch transitions, you can select multiple items of the same item type and transition them to a dif-
ferent workflow status.

Important considerations

• All items that you transition must be in the same state. For example, you might batch transition all "In
Progress" items to a "Complete" status, but you can't select both "In Progress" and "Proposed" items
for batch transition.

1. Select the project, folder, or set that contains the items you want to transition and view them in List
View. Select the items you want to transition, then select Actions > Batch transition. 

2. In the Batch Transition Workflow window, confirm your item selection, choose the status, add a
comment, then click Commit.
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Your comment appears in the version history of the item and as an activity in the stream.
Note: A batch transition is the only way to add a version or notification comment.

3. The status change is shown for each item you transitioned. 

Use workflow to batch transition items in Reviews
With batch transitions, you can select multiple items of the same item type and transition them to a dif-
ferent workflow status.

Important considerations
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• The items you select for transition must be the same item type and workflow state.

1. When you're in a review, select Stats.

2. Scroll to the bottom of the page and select items of the same item type and workflow state that are
to be transitioned. You can select multiple items by using Shift or Ctrl keys. Select Actions >
Batch transition workflow.

NOTE
You can also batch update non-workflow fields, but you can't batch delete from
here.

3. In the Batch transition workflow window, select the set of items you want to update and the inten-
ded workflow transition, then click Commit. 
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If the workflow doesn't have another transition state to select, you don't have permission or the item
is locked. A pop-up window displays a warning that you can't proceed.

Lock items in a workflow
Locking items in a workflow can help avoid unwanted changes. For example, a project administrator
might want to leave items unlocked while in "draft" status, but lock them when they reach "approved"
status.

NOTE
You must have organization or project administrator permissions to configure workflow.

Items can also be automatically locked by the workflow [196]. These items show a gray lock after their
name and a blue lock in List View. 

System-locked items unlock when transitioned through the workflow or by an organization or project ad-
ministrator.
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To add an automatic lock to the workflow:

1. Select Admin > Project > Workflow.
2. For the item you want to lock, select Override.
3. In the Lock? column, select the lock icon to include (or remove) an automatic lock in the workflow.

4. Click Save.

Stream — Staying connected
The stream is where you can see the most recent comments and activities of your Jama Connect
project.

The stream is built on three basic activities:
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Working with the stream

With everyone having the most up-to-date information through the stream, stakeholders stay informed
and aligned.

You can:

• Include stakeholders in a conversation [209] by name or email.
• Keep up to date on the latest activities [207] for a project or item.
• Clarify conversations by using actions [213] like questions, decisions, or issues.
• Include whiteboards, prototypes, or other images [212].
• Filter the stream [215] to include only comments or activities that refer to a specific project, item, or

person.
• View the stream across projects [220], at an item level [217], or at a project level [219].

Types of streams
Jama Connect includes streams for specific types of collaboration and activity.

Global Stream [203] — At this level, you see a collection of the most recent comments and activities.

Project and Item Activity Stream [203] — At this level, you see comments and activities for the entire
project.

Item Collaboration Stream [203] — At this level, you can see comments and connected users related
to a specific item.

Baseline Activity Stream [205] — At this level, you can monitor activity, quickly find a baseline ID, or
see if a signature is revoked.

Review Activity (Stats) [206] — At this level, you can see all activities for a review across versions,
including when reviews were opened, closed, when new versions were published, or when signatures
were added.

Admin Activity Stream  [541]— At this level, you see an audit trail of updates made by organization
and project administrators.
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Global stream
At this level, you see a collection of the most recent comments and activities.

How to access From the header, select Stream.

What you can do See the most recent comments related to an item.

Project activity stream
At this level, you see comments and activities for the entire project.

How to access Select the project name to open the Activity Stream.

Note: If you don’t see the Activity Stream, select the green Add button. In the window, select Ac-
tivity stream, then click Add. You must have Project Admin permissions to do this.

What you can do • See comments and activities for the entire project.
• See changes to items — Adding, editing, or deleting content from item fields, commenting on

an item; using features like releases, baselines, or reviews that impact the item.
• Find out when a review is opened, revised, closed, reopened; when signatures are added or

revoked.
• View items that are reused and synchronized and reuse details that appear in the activity

stream. Users with read permission can view details about reused items and can select a link
to view newly copied and synchronized items.

• From a project, select the Collaboration Stream View icon to see information only for that
project.

Item collaboration stream
At this level, you can see comments and connected users related to a specific item.

Here's an example of what the stream looks like in List View and Reading View:
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How to access There are several ways to view the stream at the item level.

In Project > List View, select the speech bubble icon.

In Project > Reading View, select the speech bubble icon.
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In Project > Single Item View, select the speech bubble icon.

What you can do • See comments and connected users related to a specific item.
• See changes to items — Adding, editing, or deleting content from item fields, commenting on

an item; using features like releases, baselines, or reviews that impact the item.
• View items that are reused and synchronized and reuse details that appear in the activity

stream. Users with read permission can view details about reused items and can select a link
to view newly copied and synchronized items.

Baseline activity stream
At this level, you can monitor activity, quickly find a baseline ID, or see if a signature is revoked.

How to access Select the Baselines tab, baseline name, and View details (which changes to View items) to
open the Activity stream.
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What you can do • Monitor activity, quickly find a baseline ID, or see if a signature is revoked.
• View changes to baselines — Adding (manually or automatically with a review), editing, or de-

leting* baselines or sources. Visible to users with read-only permission. Baseline activity
streams.

*Deleting requires admin permissions. Baselines with e-signatures can’t be deleted.

Review activity (stats)
At this level, you can see all activities for a review across versions, including when reviews were
opened, closed, when new versions were published, or when signatures were added.

How to access In the review, select Stats to open the activity page.

What you can do • See all activities for a review across versions, including when reviews are opened, closed,
when new versions were published, or when signatures were added.

• Find out when a review is opened, revised, closed, reopened; when signatures are added or
revoked.

• See when items are sent for review.
• See all activity for a single review across revisions in the Review activity tab.
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Activity stream
Activities are the recorded changes made to an item, including editing, commenting on, relating to other
items, deleting, and restoring.

You can view activities at an item level [217] or a project level [219]. You can also view activities specific
to different parts of Jama Connect, such as reviews [189] and baselines [245].

These are the types of activities that appear in the stream.

Activity type Definition Visible in...

Changes to items Adding, editing, or deleting content from item fields; comment-
ing on an item; using features like releases, baselines, or re-
views that impact the item.

Project activity stream

Item activity stream

Changes to baselines Adding (manually [242] or automatically with a review [241]),
editing, or deleting* baselines or sources. Visible to users with
read-only permission. Baseline activity stream [245] shows all
activity for a baseline.

Baseline activity stream

Reused and synchronized
items

When items are reused and synchronized [272], details of re-
use appear in the activity stream. Users with read permission
can view details about reused items and can select a link to 
view newly copied and synchronized items. 

Project activity stream

Item activity stream

Comments Comments related to an item or project. Review comments
aren't included in activity stream.

Collaboration stream

Reviews When review is opened, revised, closed, reopened; when sig-
natures are added or revoked.

Project activity stream

Review activity (stats)

When items are sent for review, see all activity for a single re-
view across revisions in the review activity [189] tab.

Review activity (stats)

* Deleting requires admin permission. Baselines with e-signatures can’t be deleted.

Comments
Comments are user-created messages that you can see in the stream or in reviews.

Comments are visible:

• At an item level [217]
• At a project level [219]
• In reviews [173]
• Across projects [220]

You can add and delete a comment as well as restore comments that you deleted. You can also add a
hashtag (#) to a comment for filtering or add a reference to a specific person, project, or group. 

Add, delete, or restore a comment
All comments made in Jama Connect are displayed in the stream. You can see any comment you have
permissions to view.

You can add comments, delete comments that you made, and restore comments that you deleted.

You can also restore comment threads or replies that you deleted, but only if they were associated with
an item. You can't restore deleted comments that aren't associated with an item. 

1. To add a comment to the stream, an item, or a project:
1. Open the stream at an item level [217], project level [219], or across projects [220].
2. Enter your comment:

• New comment — In the Stream comment box.
• Replying to a comment — In the reply box below the comment.
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3. (Optional) As needed, you can refer to a particular person, group, project or item [209], request
or resolve an action [213], upload an image [212], or add a hashtag [208].

4. Select Comment.
2. To delete a comment:

1. Select Delete below the comment.
2. When prompted, click Yes.

3. To restore a deleted comment:
1. In Single Item View, select the Activities widget to open the bottom panel.

2. In the deleted comment, select Restore.

3. When prompted, click Yes.
The comment is restored and appears in the My Settings section.

Tips and more

When the discussion gets long, Jama Connect shows only the most recent comments. Select View all
replies to expand the thread and show all comments. Select Hide replies to collapse the thread.

Add a comment hashtag
By adding a hashtag to your comments, you can quickly filter the stream by selecting the hashtag itself.

Tags begin with the # character and are lowercase letters with no spaces. 

To add a comment hashtag:

1. In the Stream comment box, type # followed by the tag.
For example, #alert or #review.
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2. Click Comment.

The comment appears in the stream thread.

NOTE
Comment tags are different from item tags. Comment tags are added to comments and
can be used to filter the stream, but item tags are added to an individual item and can
be used to search or group items. 

Use @mention to add a reference
To increase the efficiency and usability of your comments, you can refer to specific items, projects, peo-
ple, or groups with @mention.

Anyone you include in a comment receives an email notification [211].

1. Open a list of names (items, projects, people, groups) using one of these methods: 
• In the comment field of the Stream window, type @ followed by the first few letters of the name.

• Below the comment field of the Stream window, select @.
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2. Scroll through the list to select the name you want to include in your comment.

The name that you included appears as a bold link in your comment. 

Add someone from outside Jama Connect
You can add a commenter who is not part of Jama Connect. They get a temporary license [569] that
allows them to view the comment threads to which they were invited. They can also see descriptions of
referenced items in the thread. 

Once you send the invitation, the person can optionally set up a user login and password, which is then
available in the @mention drop-down list. The license expires after 30 days —and the user is locked
out of Jama Connect — unless it is changed to a permanent one. They can still be @mentioned in
stream if the license has expired, but they can no longer access the conversation or items.

NOTE
An administrator can grant invited users permission [644] to view additional project da-
ta.

To give stream access to someone outside of Jama Connect:

1. In the comment field of the Stream window, type @ followed by the user's email address to trigger
an invitation, then select the blue Invite bar that appears.

2. In the Invite User window that opens, enter the full email address and click Invite.

3. Type your note and click Comment. 
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The person you invited now automatically receives stream emails [211].

View referenced projects and items
When a project or item is referenced with @mention, you can view it in its activity stream.

1. To view a reference to a:
• Project — Open the project's activity stream.
• Item — Open the item's activity stream in Single Item View.

2. (Optional) In the activity stream, select Description to see details about the referenced project or
item.

3. (Optional) Select View additional references to see more than the first displayed reference.

Email notifications for the stream
Jama Connect includes several types of email notifications, including ones initiated in the stream. This
information applies only to stream email notifications.

Adding participants

When you comment on an item or project in the activity stream, you can add people to a comment by
using @mention. This includes people who aren't current Jama Connect users.

When you receive stream notifications

Initial email — When your name is added to a comment in the stream.

Update email — When anyone replies to a comment thread where your name was added.

New comments — If you subscribed to the item.

Tips and more

Jama Connect User Guide

211



• If you are in multiple groups that are mentioned in a comment, they receive only one email for each
comment or reply.

• When participants receive an email because they're mentioned in the stream, they can comment di-
rectly to the thread by replying to that email.  A copy of the comment is emailed to everyone on the
thread.

• Email updates contain links to see the entire comment thread in Jama Connect.

NOTE
Replying to a thread by email works for comment threads in the stream, but not for
comments in reviews.

• To stop receiving email notifications for a comment thread where you’re mentioned, go to that thread
in the stream and select Mute.  Do this for each thread that mentions you.

NOTE
Once you mute notifications for a thread, you only receive future emails if you're spe-
cifically mentioned in a comment or if you're a member of a group that's also refer-
enced.

Upload images to the stream
You can include useful photos (meeting notes, white board drawings, or prototypes) in the stream by
uploading images.

Here's how:

1. In the Stream window, select the Image button.

2. Select the image file you want to upload, then select Open.
The image appears in the stream comment field.

3. (Optional) To resize the image, hover over the bottom right-hand corner of the image, grab the han-
dle and drag the corner to the required size.

4. (Optional) To move the image in the comment, hover over the top left-hand corner of the image and
grab the handle. Drag the image to the correct location in the comment.
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5. Select Comment.

The image you uploaded now appears in the stream.

Request or resolve an action
Actions can highlight important conversations in the stream by identifying a comment as one of three
types: decision, question, or issue.

Actions also help clarify your request to someone you include in your comment. You can also filter by
actions [215] to see what questions, issues, or decisions need attention.

1. To initiate a request, choose from the Actions menu or type a ! in the comment box and choose an
action from the menu that appears.

When a comment contains a request action, the left edge of the comment is outlined in yellow and a
blue button invites other users to resolve the action (Answer question, Make decision, Resolve is-
sue).
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2. To respond to a request, choose from the Actions menu: Decision, Answer, or Resolution.

Tips and more

• Resolved actions are displayed in green.

• Open actions are displayed with a yellow border.
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• Use the like icon when you agree with a comment and want to track how team members vote on a
decision.

• Select the number next to the like icon to see who agreed.

Filter the stream
Filters let you see only comments that matter to you. When you create a filter, it remains active only if
the session is active.

If you want to reuse a filter, you can save it. You can also bookmark a filter in your browser to view later.

NOTE
You can create custom filters [217] at an item level to filter comments or activities in the
stream.

1. Open a Stream window and select the Filter comments field.
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2. Enter one of the following and select from the displayed menu to create a filter:

# Displays a menu of hashtags.

@ Displays a menu of users.

! Displays a menu of actions.

Keyword Displays a menu of frequently used names for people, groups, projects, or other content types.

3. Select an option from one of the menus or press Enter if you entered a new keyword.
4. (Optional) To filter by actions, select the Quick filters menu. These filters are additive so you can

filter on multiple actions.

The filters you choose appear below the comment field. The stream is refreshed with each filter you
add or delete.

5. (Optional) To save a filter, select the bookmark button and enter a name for the filter, then select
Save.

6. To set a quick filter from a comment, select people, projects, items, or other boldfaced references in
the comment. These filters aren't additive.

7. (Optional) To share a filter with another Jama Connect user, copy the URL of your filtered results
and send it through email.
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View collaboration stream at an item level
You can view the stream [201] comments and activity for an item, for example, to see all "Open" (unre-
solved) questions about that item. A speech bubble icon includes a number that indicates how many
comments were recorded for that item.

NOTE
The side toolbar is only visible if it is configured by the organization administrator [584].

To view comment stream

1. Select an item’s speech bubble icon using one of these methods:
Projects > Reading View

Projects > List View
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Single Item View > Side toolbar

2. In the window that opens, select the silhouette icon to view comments, add comments, or view con-
nected users.

To view comment and activity stream

1. In Single Item View, select the Activities button on the side toolbar to see the history of an item.
The number on the button indicates the item's activity.

2. The bottom panel displays the stream and all activities (such as edits, reviews, relationships) and
comments for this item. From here you can add a comment, search the stream with a keyword, re-
fresh the display, or hide the panel.
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3. Use the three buttons in the top left corner of the stream to:
• Display active comments
• Display all activities
• Apply a custom filter to activities

4. Select the settings (gear) icon in the top right corner to open the Activity Filter Settings window.
5. Keep the default settings or customize keywords, activity type, date range, or item type, then select

Apply. Your custom filters are saved across items.

View collaboration stream at a project level
You can view the stream [201] at a project level, you see comments [207] and activities [207] for the
entire project in the project dashboard.

Important considerations

• Any comments you enter at this level automatically refer to the selected project.
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• If the stream doesn't already appear on your project dashboard, a project or organization administra-
tor can add it.

Open the project dashboard using one of these methods:

• Explorer Tree — Select the main project level in the Explorer Tree or select the name of the project
just above the Explorer Tree.

• Comment bubble — Select the comment bubble in the upper right navigation, then select Stream
View.

View global stream across projects
View the stream across projects when you want to do a search or filter projects. For example, if you
want to see open questions that are assigned to you for all projects.

To view the stream across projects, use one of these methods:

• Select Stream from the top navigation. This displays all comments from all projects, starting with the
most recent.

• Select View All Stream Activity from the home page to see all comments across projects.
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View connected users

A connected user is a creator, editor, or someone who has commented, subscribed, or been @men-
tioned on an item.

View connected users to see who is connected to items. For example, if you're changing a requirement
and want to see who might be impacted by a change.

To view connected users:

1. Open the Connected users window using one of these methods:
• Single Item View — Select the connected users icon.

• List View — Select the user icon.

2. Select Show indirectly connected users to view users who are interested in items related to this
one.
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3. (Optional) To toggle the related users on or off, select the circle icons at the top of the list.

You can now view the list of connected users and make comments in the stream.

Electronic signatures
An electronic signature is a way for project participants to virtually approve reviews, baselines, and
electronic documents like test plans and requirements.

Review moderators can require a signature for a review and add a signer role. All review signatures
carry the Signature meaning: "I approve the content of this review."

Electronic signatures consist of a username and password. They are captured with a time and date
stamp and an audit trail. Each signature is tied to the individual user, as well as to a baseline or review
where the signature was added.

Electronic signatures, time stamps, signer roles, and signature meaning are all visible in review activity
[189].

Things to know

• For easy identification, a baseline with an electronic signature includes a blue dot and white exclama-
tion mark in the baseline tree.

• As the moderator, you can add a signer role or a reason for signing to a review signature [177], but
not to a baseline signature.
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• Signatures are enabled by default, but can be disabled by a system administrator.
• Electronic signatures depend on the authentication system your organization is using. Authentication

properties can be configured by a system administrator.
• You can't delete a review with an electronic signature, or a baseline created from a review with an

electronic signature.
• You can revoke your signature if it was signed in error or something needed to change. Select Re-

voke to cancel your signature. Only the user who signed the baseline can remove their signature.
When revoking a signature, you can leave a reason for revoking, which appears in the activity stream
as a comment.

• As an approver, you can reopen a review that you signed, but this revokes your signature.
• To see a review that was signed, look in the participant progress [187] or review activity [189] tab.
• Self-hosted customers can't edit a baseline that is signed.

NOTE
You can't delete a review with an electronic signature, or a baseline created from a re-
view with an electronic signature.

Electronic signatures depend on the authentication system your organization is using.
Authentication properties can be configured by a system administrator.

Sign a review electronically
If a review requires an electronic signature, you are asked to add a signature when you finish a review
as an approver.
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1. In the Review finished window, enter your username and password as your electronic signature.
If your organization uses SAML, the SAML authentication window opens, where you enter your
username and password.

2. Select Approve and sign to complete the review.

Add signer role
As a moderator, you can enable the signer role for other approvers. This allows them to associate their
role with their signature. Signer roles are created from user group names.

If your moderator is inviting a user from outside of Jama Connect, they must log in and register before
you can assign them to a group. After your organization or project admin adds them to a group, the
moderator can edit the review to give them a signer role.

1. Initiate a review [157].
2. Make sure electronic signatures and signer roles are enabled in settings [160].
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3. To invite participants [164], select the user, then use the Signer role drop-down menu to assign a
signer role.

• If the user belongs to multiple groups, you can choose their role as signer from multiple options.
• If they don't belong to any groups, their role is "Not assigned."
• To add a signer role, create a user group [560] with a name that indicates the role you want to

represent (for example, QA, Business Analysts, Security). Be sure the person you want to assign
the role to belongs to that group.

• If you select a group in the participants panel, select Add all users. The signer role defaults to
the name of that group.

4. Click Initiate review.

Approvers assigned a signer role are notified of their role in their email invitation [163].

TIP
After a review is signed, anyone with permission to a review can view signer roles that
were used for a signature under review activity [189].

Sign a baseline electronically
Adding an electronic signature lets users see items that are approved or revoked. For example, if you
want to sign and approve a review.
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1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then select
View details.

2. Select Add signature.

3. In the Electronic signature window, enter your username, password, and any optional comments,
then select Save. Username and password must match that of the logged in user.
If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.
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Manage content

Use these features to plan, organize, track progress and impact.

• Compare versions [228]
• Change requests [229]
• Releases [233]
• Baselines [236]
• Coverage and Traceability [250]
• Reuse and synchronization [272]
• Exports [294]

Item versions
A new version is created each time you make changes to an item. In the bottom panel you can compare
versions [228] or make a past version current [228].

When viewing item versions, you can see Baselines that were created when that version was active,
any automatically generated Change details, any user comments applied by the person who made the
changes, as well as the date and name of the person who made the changes.

Item versions quick find
In Single Item View, select Versions in the side toolbar to open a list of item versions in the bottom
panel. 

The current version number appears below the item name and in the small blue circle on the Versions
button.
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Make a past item version current
When you make a past item current, the system creates a new version that's identical to the version
you chose. By doing this, you don't lose access to past versions.

All pick list values that existed at the time the previous version of the item was active are restored, even
if that value was removed as an option for new items.

1. Select Versions to open the bottom panel in Single Item View [227].
2. Find the row that contains the item version that you want to make current and select Make Cur-

rent.

NOTE
You can't make past versions of test cycles or test runs current. For converted items,
you can't revert back to the previous item type using this method.

Compare versions

1. Select Versions to open the bottom panel in Single Item View [227].
2. Select the two versions you want to compare using the buttons in the From and To columns, then

select Compare.

3. In the Version compare window, the From version is on the left and the To version on the
right. Changes are displayed inline. Deleted text is red and highlighted. Added text is green and
underlined. 
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Change requests
Change requests are items that call for a change to product or system. 

Change requests don't entail any sort of automated process; they are simply a way to track requested
changes. When an item type is activated as a change request [580], you can add new change requests
and associate them with other items [229]. 

With change requests you can:

• Use Impact Analysis [232] to determine if and how your change requests affect other items, and cre-
ate direct relationships between affected items and the change request.

• Send a change request to review [157] to gather feedback from stakeholders and determine if the
change request is approved or rejected.

Add a change request and associate items

1. Create a new set in your project called "Change requests" to make them easy to find.
2. Add a new item [110] to that set.
3. Open the item and select Items to be changed. This button doesn't appear unless configured by

an organization administrator [584].
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4. In the bottom panel that opens, select Associate Items. From the list that appears on the right
panel, select which items you want to associate with this change request, then select Associate.
You can also double-click on the item to associate it.

5. The items that you associated appear in the bottom panel with links to those items. Each item is
listed with the Starting version when the change request was introduced and the Ending version
of the item that fulfills the change request.
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IMPORTANT
If an item has the change request tab enabled, it's a change request. Items that
are change requests can't be associated with other items that are change re-
quests.

6. You can edit the association [231] to indicate the starting version when the change request was in-
troduced, the ending version of the item that fulfills the change request, and additional notes. You
can also run an Impact Analysis [232], delete an association [232], or close a change request [233].

7. When you view other items that were associated with this change request, you see the same but-
ton in the right toolbar of their Single Item View, as well as any change requests they're associated
with in the bottom panel.

TIP
When the change request author locks the change request, it can't be edited. This
way the author can moderate the progress of requested items to be changed, can
update associations, or close the change request as edits are made.

Edit change request associations
Edit change request associations to indicate which version is the starting or ending version of a change
request.

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.
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2. Double-click in the row with the item you want to update. You can also select the row, then select
Edit > Update association.

3. In the window that opens, modify the Starting Version, Ending Version, or Note.

4. Select Save.

Create change request Impact Analysis
1. In Single Item View, select Change Request to open the bottom panel with a list of associated

change requests.
2. Select the item you want to know more about and select Actions > Impact Analysis.

The Impact Analysis is populated by the items in the change request.

Delete change request associations
1. In Single Item View, select Change Request to open the bottom panel with a list of associated

change requests.
2. Double-click in the row with the item you want to update. You can also select the row, then select

Edit > Update association.
3. Select Edit > Remove Association.

Jama Connect User Guide

232



Close a change request

1. In Single Item View, select Change Request to open the bottom panel with a list of associated
change requests.

2. Select the change request you want to close, then select Actions > Close Change Request.

Releases
 A release is a group of items that are developed together and mapped to a specific completion date. 

Select Releases at the top of the left panel to see all of the releases listed for this project. Select any
release to see the items assigned to it.

If you include items in a release, you are assigning them to that release. If the release field [233] is visi-
ble, you can use Reading or List View to see the name of the release to which an item has been as-
signed.

Assign an item to a release
When you assign an item to a release, the item will appear under the Releases tab, and the action will
be noted in the version history.

You can only use the system predefined Release field to show items in the Releases tab. If you use a
custom Release field to designate an item to a release, that item won't appear in the Releases tab.

Before you can assign items to a release, a project or organization administrator must first create the
release. Once the release is created, there are several ways you can assign an item to a particular re-
lease:

• Locate the release field [233] (if it is visible [600]) in Single Item or List View and select the desired
release name from the drop-down menu.

• In the List or Reading View of your project, select the items you want to add to the release. Select the
Releases tab at the top of the left panel and drag the items into the release.

• Use batch update [116].
• Use round-trip import and export [82].

Release field
The release field is a predefined field [593] with a picklist that contains all the releases created in a par-
ticular project.
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IMPORTANT
You can only use the system predefined Release field to show items in the Releases
tab. If you use a custom Release field to designate an item to a release, that item will
not appear in the Releases tab. 

If you don't see a release field in the item type you are using, an organization administrator can edit the
fields for that item type [589], and make it visible [600].

An organization administrator must also configure pick list values [598] for each release. 

Release settings
You can determine what you'd like to see under the Releases tab for your project whether it is the de-
fault settings or your personal settings.

1. Select the Releases tab in the left panel. 
2. Select the Release settings (gear) icon.

3. In the Release settings window, select Use my own settings or Use my default settings to de-
termine what you want to see under the Releases tab. You can choose to see only certain item
types, IDs, archived releases or relationships that you want to see. Scroll down to see all the op-
tions for release settings.
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4. Select Apply to apply these settings.
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NOTE
If you are an organization or project administrator, you can configure default settings
under the Default settings tab and select Apply.

Baselines
A baseline in Jama Connect is a snapshot of your project at a point in time. The current version of se-
lected items — and their relationships — are forever associated with that baseline. A baseline also cap-
tures the state of the selected items, like Draft, Reviewed, and Approved.

Important considerations

• When you add a relationship to a baseline, the version doesn't change.
• Relationships do not change if you replace it with a baseline.

For example, if you have two relationships at the time of baseline version one, make a change to ver-
sion two, add a relationship to version three and replace it with a baseline, you still have three rela-
tionships.

• If you click Revert to Baseline, all content is switched back to the content that was versioned at the
time it was baselined.

What you need to create a baseline

Versioning must first be enabled to create a baseline. Once versioning is enabled [639], a baseline is
created:

• Automatically [245] when someone initiates or revises a review
• Manually [242] by anyone with read/write permissions

Why are baselines important?

By creating a baseline at each project milestone, you can view the status of your project at those key
points in the lifecycle. You can also see which items are related in the baseline list and reading views.

What can I do with a baseline?

• Locate an existing baseline [241]
• Create a baseline manually [242]
• Compare baselines [244]
• View baseline activity [245]
• Replace current items with baseline [249]

What is a baseline source?
A source is a container that holds all the baselines for a specific group of items.

When you add a baseline for a new group of items, the source is created automatically. Whenever you
add the baseline — from a project, set, folder, filter, release, or individual items — the source is created
in the tree and contains the new baseline. A source can't exist without a baseline.

If a source already exists when a new baseline is created for the same set of items, the baseline is add-
ed to that source. Otherwise, a new source is created and added to the top of the tree.

Key to the baseline tree
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• Green database icon — Source
• White box wrapped in gray — Baseline
• Individual Items — Default source name when multiple items are selected at the time the baseline is

created.
• B1-04/27/2020 — Example of default baseline name (baseline number and date it was created).

Baseline name is editable as needed.

Tips and more

• If you create a baseline from a container, filter, release, or review, the source and its initial baseline
are created. If you use the same source the next time you create a baseline, that second baseline
added to the source under the first baseline.

• If you create a new baseline from a set and add another single item to it from another set, a source
labeled "Individual Items" is created.

• Deleting a baseline source deletes all the baselines it contains.

Benefits of organizing your baseline tree
Organize your baseline tree to reflect how your organization works.

Project and organization administrators can reorganize the baseline tree by dragging and dropping
sources and folders.

Organizing baseline sources and folders

• Use drag and drop to move baseline sources from one location to another, from the root level to a
folder, and between folders.

• Editing a source name creates an event in the project activity stream. In the activity stream, select the
baseline source ID to open the baseline tree and view the highlight.

• Baseline folders can be created at the root level or added to a folder. Use drag and drop to reorder
baseline folders.

• If you hover over an icon or name in the baseline tree, hover text appears describing the contents of
the item.
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Searching baselines, baseline folders, and baseline sources

• When you type a name in the search field, the results are highlighted so you can find them easily.

• When you clear the search field, the results from the previous search are expanded and highlighted
in the baseline tree.

• When you create a folder or baseline, it is highlighted in the baseline tree.
• If you accessed the baseline from a link or the Explorer Tree hierarchy is collapsed, select Find me

to locate the baseline in the baseline tree.
• When you toggle Show IDs to On, the baseline IDs are displayed in the baseline tree. When the IDs

are visible, you can search for them using the baseline search box.
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• When you select the baseline ID in the activity stream, the source is expanded and the baseline is
highlighted. Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a
signature is revoked.

• A link is added in the baseline header when a baseline is created from a review or a new revision of a
review. Use the link to navigate to a specific review quickly.

Create baseline folders

Once a baseline is created, the item content can't be changed. You can, however, change the baseline
name and description.

Users with a creator license and permissions for project or organization administrator can create, edit,
and delete an empty baseline folder.
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Anyone with read/write permissions can edit, delete, or restore a baseline that they created. However,
you must have project or organization administrator permissions to edit, delete, or restore baselines
created by others.

• Create a baseline folder using one of these methods:
• From the Add drop-down menu, select Folder.
• Right-click on the folder, then select Add Folder.

Edit a baseline
Once a baseline is created, the item content can't be changed. You can, however, change the baseline
name and description.

Important considerations

• Anyone with read/write permissions can edit, delete, or restore a baseline that they created.
• You must have project or organization administrator permissions to edit, delete, or restore baselines

created by others.
• You must be an organization or project administrator to edit a signed baseline.

1. Select the Baselines [241] tab in the Explorer Tree, then select the baseline you want to edit.
2. You can edit a baseline in two ways:

• Right-click on the baseline and select Edit.
• In the upper right corner of the main panel, click Edit.

3. In the Edit baseline window, enter your changes and select Save.

Your changes appear in the Explorer Tree.
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Locate an existing baseline
When anyone creates or revises a review, a baseline is automatically generated. Knowing where to look
for an existing baseline can be helpful when you want to compare changes in a review that has multiple
versions.

You can find a baseline for a specific project from the Explorer Tree or Single Item View.

Explorer Tree

Use the Explorer Tree to find a baseline if you need to quickly find a baseline.

1. Select the Baselines tab of the project you want to look at.
2. Type the baseline name in the search field. The results are highlighted so you can find them easily.

3. Expand the source to see all the baselines from the same source, then select the one you want. If a
baseline was created from a review, it is preceded by the word "review" in the name.
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4. Select the baseline to view its contents.

Single Item View

Use this method if you know which items were included in the baseline or the review that created it.

1. Open the item in Single Item View [56].
2. Select the Versions button on the side toolbar [57].

The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews col-
umn.

3. Select the link to open the review or the corresponding baseline. If the review link is disabled, you
weren't invited to the review or the review isn't public.

Create a baseline manually
Create a baseline when you want to capture a snapshot of where items are at in that moment.

NOTE
You must have a creator license and read/write permissions to manually create a base-
line.

1. In the Explorer Tree, select the Baselines tab in the project where you want to create the baseline.
2. Add a baseline using one of these methods:

• If the item already has a source, right-click on the source and select Add baseline.
• If you need to choose items, select Add > Baseline from the top.
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NOTE
If the items from an existing source were deleted, you can't add a new baseline
from that source.

3. In the window that opens, click a tab (Item selection, Releases, Filters) and select containers or
individual items in that tab. You can select containers or individual items, but you can select from
only one tab.

4. Click Create.
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5. (Optional) Change the default name for the baseline and add a description.

6. Select Save to create the baseline.

The new baseline is added to the tree, either under and existing source or to the top of the tree. Base-
lines are always listed in the order they were created.

Tips and more

• Baselines are created automatically [245] whenever anyone creates a review.
• Project versioning must be enabled [639] to be able to create a baseline.
• All upstream and downstream relationship information from items included in the baseline scope are

also included in the baseline snapshot, even if those upstream or downstream items aren't part of the
baseline scope. This functionality is limited to relationship direction, item name, and item ID.

Comparing baselines
You can compare baselines to see if an item changed since the last baseline, and what those changes
were.

Two default reports analyze baselines to show changes over time:

• Baseline Comparison [356] compares two baselines.
• Baseline Compared to Current [354] compares the items and relationships from a baselined version

to the current version.

There are several ways to compare baselines:

• Select the Baselines tab in the Explorer Tree, then select the baseline you want to view.
(Optional) In List View, select the gear icon (Show/Hide) to open the drop-down menu, then select
Current version and Version to display those columns.

• To view the version of an item that was baselined, select the row, then select Preview item.
• To compare a baselined item with the current version side-by-side, select the row for that item, then

select Compare with current in the top right.
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Tips and more

• To see the current state of the item, select any Global ID [274] or Unique ID [628] in List View.

View baseline activity
Use the baseline activity stream to monitor activity, quickly find a baseline ID, or see if a signature is
revoked.

1. Select the Baselines tab, then select the name of the baseline that you want to view.
2. Select View details.

The baseline activity stream is visible at the bottom of the center panel.

Locate review baselines
When anyone creates or revises a review, a baseline is automatically generated so that you can com-
pare changes between reviews.

You can find automatically generated review baselines in two ways:

• Select Baselines in the Explorer Tree of your project.
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Baselines that were automatically generated for reviews are displayed with the word "Review" pre-
ceding the name of the review.

• If you know the items that were included in the baseline (or the review that created it):
1. Open the item in Single Item View [56].
2. Select Versions in the side toolbar [57].

The list of reviews and baselines is displayed in the bottom panel under the Baselines/Reviews
column.
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3. Select the link for the review or its corresponding baseline. The link is enabled only if you were
invited to the review.

Sign a baseline electronically
Adding an electronic signature lets users see items that are approved or revoked. For example, if you
want to sign and approve a review.

1. In the Explorer Tree under the Baselines tab, select the baseline you want to sign, then select
View details.

2. Select Add signature.

3. In the Electronic signature window, enter your username, password, and any optional comments,
then select Save. Username and password must match that of the logged in user.
If your organization is using SAML for authentication, you are asked to select Sign baseline, then
enter your username and password to authenticate your signature.
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Deleting sources and baselines
Delete a source or baseline if it was created by mistake or you no longer need it.

Things to know

• Deleting a source deletes all the baselines it contains.
• The option to delete a baseline or source that contains a baseline is only enabled for baselines that

are not yet electronically signed. However, deleting a project [621] deletes all project content, includ-
ing baselines and signatures.

NOTE
You must have project or organization administrator permissions to delete sources and
baselines.

Delete a source

• Right-click on the source you want to delete.
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Delete a baseline

Delete a baseline from the project using one of these methods:

• Select the baseline, then select Delete (trash icon) in the top right.
• Right-click on the baseline name, then select Delete.

Tips and more

• Undo — If you change your mind after deleting a source or baseline, you can select Undo in the suc-
cess notice.

• Restore — You can restore a deleted baseline or source by finding the deletion activity [207] in the
projects activity stream and selecting Restore. If you deleted a source that contains multiple base-
lines, you can restore individual baselines or the source and all its baselines. When you restore a
baseline or source, this event appears in the baseline activity stream.

• Limitations — You can't edit or delete a baseline that is electronically signed. You also can't delete a
source if it contains an electronically signed baseline.

Replace current items with baseline
When you replace current items with a baselined version, a new version of the item is created and con-
tent is replaced with the baseline content. No versions are lost.

Important considerations
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• Items that were deleted are restored to the version at time of the baseline.
• Relationships that were deleted aren't restored.
• You can update an individual item from the versions tab in Single Item View [227].

NOTE
You must have project or organization administrator permissions to do this. 

1. Select the baseline you want to revert in the Baselines tab of the Explorer Tree [241].
2. Select Replace with baseline.

3. In the confirmation message, click Yes.

A pop-up message displays the number of items that were updated.

Coverage and traceability
Traceability shows the relationship between items that depend upon and define each other. You can al-
ways travel upstream or downstream to get more context and trace product definition from high level
requirements all the way through final tests.

Coverage is the extent to which items are validated by another item. 
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By relating items [256] according to a set of relationship rules [605], you can assess the impact that
changes can have on other items. View items in Trace View [53], or use the following options to analyze
item relationships and be sure you have the coverage you need.:

• Relationship Status Indicator [265]
• Trace Matrix [268]
• Impact Analysis [269]
• Coverage Explorer [270]

Trace View
Trace view shows related upstream and downstream items, missing relationships, and item details in
context of their relationship.

When you select Trace View, the items you selected in List View are displayed in the Source column.
Related items downstream from the source are displayed to the right. Items upstream from the source
are displayed to the left. Use the blue arrow buttons on either side of the screen to travel up or down-
stream.

The top of each level column shows a count of the item types found on the entire level. 

NOTE
The item count is a unique count. If the same item is downstream of multiple items in
the source column, it appears multiple times in the "1 level down" column, but it's coun-
ted only once.
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Select an item in the source column to highlight its specific upstream and downstream relationships.
You can select multiple items using the checkboxes. Selections remain highlighted as you navigate. Se-
lect X to clear your selections. 

Select Set columns at the top of each trace level to turn fields on or off [55] for items in that level.
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Use Trace View to find missing coverage and use the Add menu in the toolbar to add items directly from
this view.

You can also filter Trace View [255] or use Trace View to save a view [253] or export the content [254].

You can also use the Trace View to see validation and verification testing results. If a test case is visible
in Trace View, you also see the related test runs. No manual creation of relationships is required; Trace
View infers the relationship between test cases and runs and once a test cycle is created.

If your organization has a risk management license, you can also configure this view [55] to see risks in
Trace View. [417]

Save a Trace View
After you save a Trace View, you can change the name and save it as something else. You can also
bookmark it.

1. Select the Trace View [53] that you want to save, then click Save.

The name text box becomes an editable field.
2. Edit the name as needed, then select Save (checkmark icon).
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3. (Optional) Select the arrow next to the name to see a pull-down list of saved Trace Views. Book-
marked views appear at the top of the list.

Bookmarked Trace Views are visible from your homepage; use the URL to share this Trace View
with other users.

Export a Trace View
When you export from Trace View, the result contains all data that traces from the columns currently
visible on your screen to the Source column.

Note: When you export a Trace View, it can be no more than 6 levels. If you try to export a Trace View
that exceeds 6 levels, the Export button is grayed out.

1. From the Explorer Tree or an advanced filter, select the items you want to export, then click Trace
view.
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2. Navigate to the furthest level upstream or downstream that you want to export, then click Export.
3. Click OK to open the CSV file.

Select the down arrow in your browser to view the available downloads.

Filter Trace View
You can filter items in Trace View by item type.

1. Open the items you want to filter in Trace View [53].
2. If more than one item type exists in a column, you can select Filter items at the top of the column

you want to filter.

3. In the window that opens, select the items you want to see.
A number next to each item type displays the total count of unique items to filter for that item type
in that column. 

4. After the filter runs, a message at the top of the page lets you know how many levels and how
many total item types were filtered. Select X to remove all filters. 

5. You can save the Trace View [253] or export the Trace View [254] with filters in place.

Relationships
Relationships link items together and can help assess the impact an item or group of items can have on
other items.

Traceability is defined by relationships. When one item changes, you know to check related items to
make sure they are still correct.
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Relationships can be upstream or downstream from an item. With the appropriate permissions [265],
you can relate items within the same project or between projects. Find and view relationships [256] in
Single Item View.

You can also add relationships from:

• Single Item View [256]
• List, Reading or Trace View [259] (by adding a new related item)
• The trace matrix [259]

Relationships quick find
In Single Item View, select Relationships to open the bottom panel where you can view and filter [263]
related items. 

Select Visual Layout to see a different perspective with links to more rapid actions.

Add a relationship from Single Item View
Creating a relationship establishes a directional link between two items. The related items can exist in
the same set or project, or in completely different projects.
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1. Select Relationships in the side toolbar, then select Relate Items in the bottom panel.

2. This opens the side panel where you can select the items that you want to relate. Recently viewed
items is the default view, but you can also choose the Explorer Tree, Releases , or Search tab to
find the items you want to relate. Double-click on the item, or select the item you want to relate and
select Relate.

NOTE
If you don't have rights to a linked related item, you can still see the related item’s
name, project, and relationship attributes. However, you can't preview, open, or
edit the item if you don't have permission.
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IMPORTANT
If relationship rules [605] were applied to the project, only items that meet the
rule's criteria appear in the right panel. You can only create a relationship with item
types that meet the applied relationship rules. Select Show relationship diagram
at the top of the right panel to display the rules that are associated to this project.

3. A relationship is added to the selected item in the direction defined by the rules and is immediately
visible in the bottom panel. If the new relationship isn't defined in the rules, you are prompted to
define the relationship direction and type.  
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TIP
If you have multiple relationships to define between the same item types, you can
select Don't ask again. During your session, all relationships between these item
types are automatically set up the same way.

Add a relationship from the Trace Matrix

1. Select Projects in the header, then select Project > Traceability > Trace Matrix.

2. In the Trace Matrix window header, select the two item types you want to compare, and limit the
number of items you want to see, then select View Matrix.

3. Double-click in any cell where you want to add or edit a relationship. 
4. In the Add/Edit Relationship window, make changes and select Update.

Add a new related item
You can add a new item and, at the same time, relate it to one or more items.  

1. View the items to be related in List View [52], Trace View [53], or Reading View [53].
2. Select the items to which you want to add related items. To use the Add related option, all selected

items must be the same item type.
3.  Select Add> Add related in the top right toolbar.  From the drop-down menu, select the item type

for the missing upstream or downstream items you want to add. The drop-down menu lists only
item types allowed by relationship rules.
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4. In the Relationship settings window, select the direction and relationship type for the item you
want to relate, then select Create relationships.
• Direction — Upstream or downstream.
• Relationship Type — Configured by an organization administrator [602]. Common examples in-

clude: related to, dependent on, derived from, validated by, verified by, or mitigated by.
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5. In the Add Item window, enter details including name and description, then select Save. 

6. In the Select Location window, you must select a location for this new item. Locations that aren't
permitted appear in light gray. You might need to expand folders, sets, or components to find the
location you want. Select a location, then Select and close.
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7. If you checked the Notify option in the Add Item window, you can notify other groups or users of
this new related item.
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Relate two locked items
As part of your workflow, you can relate two existing locked items.

NOTE
You must have organization admin permissions to complete this task.

1. Configure relationships [602] for your item types.
2. Select Admin > Organization, then select Relationships.

3. In the Relationship Options section, click Edit.
4. Select Allow relationship changes between two locked items.
5. Click Save.

You can now relate two locked items.

Filter relationships
You can filter items related to a single item. For example, you might want to view only the test cases or
use cases related to a requirement. The filter is stored until the end of your session, so as you move
from item to item, the filter remains in effect.

1. In Single Item View, select Relationships in the side toolbar to open the bottom panel. 
2. Select Filter in the bottom panel toolbar.
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3. In the Relationships filter settings window, choose your own settings or the default settings,
scroll down to see all the options, then select Apply.

4. You see the results filtered out in the bottom panel, select Filter Applied-Click To Restore De-
faults to release the filter and see all related items again.

Relate to an existing item
You can relate two existing items of the same item type.

1. View the items to be related in List View [52], Trace View [53], or Reading View [53].
2. Select the items to relate. All selected items must be the same item type.
3. Select Relate to existing.

4. In the side panel that opens, select the items that you want to relate, then click Relate. 

Recently viewed items is the default view, but you can also use the Explorer Tree, Releases,
or Search tab to find the items you want to relate.

A relationship is added to the selected item in the direction defined by the rules and is immediately visi-
ble in the bottom panel of the relationships [256] view. If the new relationship isn't defined in the rules,
you are prompted to define the relationship direction and type.
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Tip: If you have multiple relationships to define between the same item types, you can select Don't ask
again. During your session, all relationships between these item types are automatically set up the
same way.

Access permissions and relationships
How you interact with relationships depends on the access permissions you have for each of the related
items. Read more about permissions [569]. 

If you have these
access permis-

sions for the cur-
rent item...

and these ac-
cess permis-

sions for the re-
lated item...

you can....

Read/Write Read only ... view trace relationships as well as the ID and name of the related item. You can
modify relationships and create new ones. You can also navigate to the related
item and clear suspect links. 

Read only or
Read/Write

No permission ... view trace relationships, but not modify or create new relationships. You can see
the ID and name, but can't navigate to the related item.

Read only Read/Write ... view trace relationships. You can modify relationships and create new ones. You
can also navigate to the related item and clear suspect links. 

Read/Write Read/Write ... create, modify, or delete relationships as well as navigate to related items.

Read only Read only ... view trace relationships and navigate to related items. You can't create or modify
relationships between the two items. 

Relationship Status Indicator
The Relationship Status Indicator shows how many relationships an item has, as well as whether those
relationships meet the project's relationship rules.

The Relationship Status Indicator is visible in the Relationship button of the side toolbar [57], as well
as in a column in List View (when configured [55]). 

• On the Relationships button, the number at the top represents how many upstream items are rela-
ted to this item. The number at the bottom of the button shows the number of downstream items. If an
item isn't in compliance with the relationship rules, it appears in red. Otherwise it is gray. 

• In List View, you can hover over the red exclamation point to see how the item violates relationship
rules.

An item might violate relationship rules in one of these situations: 

• Orphan item — Item is missing a required upstream item. Adding a related upstream item resolves
the error.

• Missing coverage — Item is missing a required downstream item. Adding a related downstream
item resolves this error.

• Suspect — An upstream item has changed. After you're satisfied that the item isn't affected by that
change, clearing the suspect link resolves this error.
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NOTE
If relationship rules haven't been applied to the project, an error appears only if the link
is suspect.

Clear suspect links
Suspect links on an item indicate it might no longer be correct or complete, because changes were
made to items upstream.

TIP
Links that are suspect also show the relationship status indicator when you view them
in List View or Single Item View, as long as the Relationship Status Indicator field was
added to the item type.

If you view an item that's marked as suspect and determine it has no impact, or make the necessary
changes, you can manually clear the suspect link.

To clear suspect links:

1. Open all suspect links for the project or suspect links for a single item [148].
2. Select Clear to clear an individual link or Clear All to clear all suspect links.

NOTE
The Clear All button applies only to visible items. If you want to clear a large num-
ber of suspect links, you must select Clear All, then wait for the list to be updated
with the remaining items, then select Clear All again until no more suspect links
are displayed.
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NOTE
Only updates to certain fields trigger suspect links. These fields are determined by the
organization administrator who configures item types [589].
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Trace Matrix
The Trace Matrix is a visual representation of relationships within a project.

This is an intuitive way to quickly see relationships for two groups of items. For example, you can select
a set of requirements and see which have related test cases. The matrix also helps determine impact
when a change occurs. 

IMPORTANT
The Trace Matrix doesn't enforce relationship rules.

Traceability Matrix quick find
Select Projects > Project > Traceability > Trace Matrix to access the Trace Matrix.

Add a relationship from the Trace Matrix

1. Select Projects in the header, then select Project > Traceability > Trace Matrix.

2. In the Trace Matrix window header, select the two item types you want to compare, and limit the
number of items you want to see, then select View Matrix.
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3. Double-click in any cell where you want to add or edit a relationship. 
4. In the Add/Edit Relationship window, make changes and select Update.

Impact Analysis
Impact Analysis shows you the entire picture of all upstream and downstream related items that might
be affected by changes.

With traceability, you can see the impact of a change to a selected item before the change is made.

For example, if you're about to change a requirement, you can first see who is assigned to related items
and include them on a comment about the change. 

Impact Analysis quick find
In the top toolbar of Single Item View, select Impact Analysis.

Note: Small screens display icons as image-only, without the text.
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You can also perform an impact analysis on a change request. Select Items to change (bell icon) on
the Change request in the side toolbar to open the bottom panel, then select Actions > Impact Analy-
sis.

Coverage Explorer
The Coverage Explorer is tool to view or export a set of items, including related items that provide nee-
ded coverage.

You can create and save coverage views and export them to an Excel document [271]. 

Coverage Explorer quick find
Select Project > Traceability > Coverage Explorer.
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Create and export views in the Coverage Explorer
A view can only contain up to 500 items per level. You can bookmark a view to highlight and prioritize it.
Only the view's creator can rename or delete it.

1. From Projects, select Project > Traceability > Coverage Explorer.

2. Select Add Coverage View.

3. In the Select items window, select the item or items you want to analyze for coverage. Use the
tabs at the top to change your view from Recently Viewed to the Explorer, Releases , or a Filter
if these are better ways to find the items you want. Select Preview to see details about an item.
Once you choose the items you want to analyze, use Select to close the window and see your
items in the main Coverage Explorer window. 
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4. Use the gear icon at the top of the Coverage Explorer window to hide, show, and reorder fields for
that level.

5. Select the green plus button to add a new level of downstream relationships. You can add only
one item type per level. However, if you add a downstream level and leave the item type blank, it
displays multiple item types.

6. Select Save to save the view. It is added to the saved views in the left column with a favorite star.
You can deselect the star by clicking on it.

7. Select Export to export a view to an Excel document.

Reuse and synchronization
With reuse [275] and synchronization [284] you can duplicate supporting information for any item, con-
tainer of items, or even a project and continuously keep it in sync.

Supporting information can include the entire item, item fields, item widget information (relationships,
tags, attachments), related items, child items, project details, and other information. You can choose
how much of this you want to include when you reuse items [275]. Duplicate [129] is a simple way to
reuse information.
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NOTE
Attachment links are synchronized, not attachment content.

When items are synchronized, they receive a global ID [274] that they share regardless of where they
are located in the system. You can synchronize the items that you reuse, or connect existing items [288]
so that they can be maintained in parallel.

To keep track of synchronized items, use the Sync items window [273] where you can compare items
[289] and decide how to update synchronized items.

NOTE
Reuse and synchronization can require significant memory. This is especially true if
your organization has a large Jama Connect database and has heavy reuse or syn-
chronization use.

Reuse and synchronization quick find
With reuse and synchronization, you can duplicate supporting information for any item, container of
items, or even a project and continuously keep it in sync.

• Organization administrator — Only an organization administrator can configure reuse and syn-
chronize [546].

• Explorer Tree — In the Explorer Tree, a blue dot in the bottom right-hand corner indicates that an
item was synchronized.

• List View — Select an item in list view then select Actions > Reuse to open the Reuse item(s)
window.

• Project drop-down menu — An organization or project administrator can select Project > Sync
items to open the Sync items window, or Project >Manage all projects to duplicate (and optionally
synchronize) projects [618]. 

• Stream — Reuse and synchronization of items adds activity entries to the stream [217] for all items
created or modified during the process.

• Synced items window — Right-click on any item in the Explorer Tree, then select View synched
items.
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This opens the Sync Items window, where you can select any item or container on the left to see
which other items have the same global ID.

• Single Item View synced items bottom panel — Open an item in Single Item View. On the right
toolbar select, select Synchronized items.
This opens the bottom panel to display all items that are currently synchronized with this item. From
here, you can connect items [288], synchronize items [284], break sync [286], or compare details for
items that are out of sync [289].

Global ID
Global IDs are identifiers of items that are connected through synchronization. While every item has its
own unique ID [628] (which is also the project ID), two items that are synchronized can share a Global
ID.

Items that share this ID are considered cloned artifacts, despite being located in different areas of Jama
Connect, and possibly representing different versions of each other.

Global IDs have two parts:

• Global ID prefix — The Global ID is the same across the organization. An organization administrator
can change the Global ID prefix [542].

• Global ID counter — The Global ID counter only grows and can't be reset or reduced. An organiza-
tion administrator can change the starting point of the Global ID counter.  If a user tries to set the
counter value below the Last Used Global ID Counter, Jama Connect shows an error message notify-
ing the user to choose a greater value.

When items are connected for synchronization, they are assigned the same Global ID. When an item is
removed from this group (through Break sync [286])  a new Global ID is assigned.

Reuse and synchronization guardrail
Reuse and synchronization of hundreds of items can affect system performance, causing it to feel slow-
er than usual for users and decrease performance for other processes such as exporting.

If you try to reuse and synchronize a very large number of items, a warning appears if it’s likely to im-
pact performance. 

If you still want to do this, consider reusing items in smaller batches or starting a large reuse and syn-
chronize process during off hours when there is less competition for resources.

When to use reuse and synchronize
Typical scenarios for reuse and synchronize include creating a library or catalog, branching, and re-
lease management.

• Duplicate — You can make a copy of an item, container, or project. Synchronization is optional but
can be enabled between items.

• Library/Catalog — Create a library or catalog to establish system-wide standards in your organiza-
tion for all business units to follow. These might include common business practices, rules, glossaries
or even a set of non-functional requirements that teams must reference but not modify.
For example, a business that relies heavily on acronyms and terminology might create a glossary that
can be defined and managed in one place, and used as a reference everywhere else. Another organ-
ization might create and manage business practices in one place, allowing references to those practi-
ces to remain consistent across the organization.
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TIP
If you're using a catalog to push changes to many projects, you can synchronize
items to push changes from your “catalog” project to all other project items that
share the same global ID. You must have write access on all projects in the sync to
do this.

• Shared requirements — Large projects typically adhere to a common set of requirements, but often
each requirement also has information specific to a project and must be managed by that project. For
instance, a requirement name and description can be shared across multiple projects but release val-
ues, priorities, assignments, and relationships can continue to be managed by each project.

• Branching — With branching, you can split a set of information from a single point in time into sever-
al branches such that each branch can be modified in parallel.
This can be useful when you want a snapshot of items at a particular point in time, but to still allow
these items to be modified in parallel. In this case, reuse results in the versioning of an entire docu-
ment made up of multiple items, rather than just a version of a single requirement.

• Release management — Similar to branching, reuse and synchronization lets you use items across
multiple releases or sprints in parallel.

• Project template — You can set up a project to act as a template that you reuse and synchronize to
quickly ramp up new projects or to establish standard practices on content organization. You can also
synchronize the template to push updates to associated projects.

Reuse
If your projects contain items that often are the same or differ slightly, reuse can help you work more
efficiently. You can reuse items over multiple projects and synchronize them, if needed.

You can only duplicate items to sets of the same item type. For example, if you have two requirement
sets in a project created from the same item type then you can duplicate and move items between
these sets. Child items behave much the same as sets: if you reuse items to a parent item, making
them child items, they must be the same item type as the parent item.

TIP
If you have several items that are reused regularly, put them in a central project so fu-
ture changes to items can easily be maintained from one central location.

NOTE
For instance, during reuse, relationships can automatically be created that are incon-
sistent with the relationship rules of a specific project.

Reuse an item

1. Select items for reuse [276].
2. In the Reuse Items window do the following:

• Select source items (if not already selected)
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• Select reuse options [277]
• Select target destination [281]

3. Select Reuse and sync at the bottom of the window. If you're reusing something that has already
been reused, a warning asks you whether you want to overwrite or skip the items. Select one of the
following:
• Overwrite Items — Overwrites the items in the destination and replaces it with the items in the

source project. Overwritten items use the fields you specified for reuse. Any fields not included in
the reuse operation are set to null or their default value. Tags, attachments, and links are re-
placed, if you included tags, attachments, and links.

• Skip Items — Skips any existing items in the destination, so they don't get replaced with source
items.

4. The Reuse Complete window shows a summary of what was reused. Select one of the following:
• View Results — Shows a list of all of the newly reused items.
• Reuse Again — Select to reuse the same source items in a different destination.
• Finished — Closes the windows.

Select items for reuse
Follow these steps to reuse multiple items, the full content of a single item, or to reuse an item from one
project in another project.

You can select items for reuse in two ways.

• In the Explorer Tree, select the item or container that you want to reuse. Right-click to open the con-
text menu and select Reuse items.
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• In List View, select the items you want to reuse, then select Reuse.

TIP
To quickly make a copy of an item in the same project you can use Duplicate items
[129].

Select reuse options
These options are part of the process of reusing items [275].
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Important considerations

Selecting items for reuse can be helpful if you are creating several copies, but want the original “source”
item to have a relationship to its copied items. For example, if you reuse a set of requirements multiple
times from a library project in Jama Connect in several other projects: if you copied to a System 1
project and then System 2 project. When viewing the copied requirements in System 2, users could see
an upstream relationship to the “source” requirements in the library. Adding or not adding this relation-
ship has no impact on how to compare or sync items.

To compare differences between synced items: Compare synchronized items [289]

These basic options cover common ways to reuse items. Use advanced options to customize reuse
rules as needed.

NOTE
Advanced reuse rules must be configured by a reuse administrator [282].

Under basic reuse options, select the following:
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• Sync item(s) and share Global ID (default)
This option is selected by default and gives source and destination items the same Global ID. Any
changes to synced items displays an out-of-sync flag. You can use Compare View to understand
what no longer matches between synced items and choose to sync them again. Deselect this reuse
option if you only want to duplicate items, but not sync them.

• Append a prefix
Adds a prefix to the name of the item. Example: Entering "ABC-" as the prefix for item "Example A"
results in the name "ABC-Example A."

• Add a relationship from the original item
This not only reuses the source item, but also creates a relationship between the source item and the
newly created one.

• Include all tags, attachments and links
Select this if you also want to duplicate all tags, attached files and URL links associated with the
items. If an existing item is overwritten and this is checked, all tags, attachments, and links are upda-
ted to match (any tags, attachments, or links that existed in the destination but not in the source item
are removed). If this isn't selected and you overwrite an existing item, any tags, attachments, and
links are cleared in the destination item.

• Don't include relationships outside of the source selection
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This selection tells the system to only copy the source item. Any relationships within the source item
aren't copied. For example, if the source item has a component that contains Features, Require-
ments, and Test Cases, any relationships between those selected items are copied when the compo-
nent is reused. However, if any of the source items have relationships that are to items outside of the
source component, such as a relationship between a Requirement in the source component and a
Use Case in another component not reused in this action, those relationships aren't copied. 

• Include relationships from the source selection

This tells the system to copy over the source item, as well as any source item relationships. The new
item has relationships to the same items as the source item. For example, if the source item has a
component that contains Features, Requirements, and Test Cases, any relationships between those
selected items are copied when the component is reused. In addition, if any of the source items have
relationships that are to items outside of the source component, such as a relationship between a Re-
quirement in the source component and a Use Case in another component not reused in this ac-
tion, a relationship is created between the newly created Requirement and the same Use Case.

• Include related items and mirror relationships
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This tells the system to copy over the source item and any related items and create a relationship to
those newly created related items. For example, if the source item has a component that contains
Features, Requirements, and Test Cases, any relationships between those selected items are copied
when the component is reused. Also, if any of the source items have relationships that are to items
outside of the source component, such as a relationship between a Requirement in the source com-
ponent and a Use Case in another component not reused in this action, a new Use Case and its con-
tainer appears in this project, as well as a new relationship between the new Requirement and the
new Use Case.

IMPORTANT
If you change the hierarchy of the source component, those changes aren't made in
the destination component.

Select target destination
The target destination is the place where you want to create a reused item. When reusing items you
can create a new item or you can overwrite an existing item with the source item. 

In the Reuse Items window, under Select a target destination, select where you want the item to go:
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• Reuse source project hierarchy in destination project
Select this option if you are choosing a target destination in a different project that has the same hier-
archy as the source project. If a similar set and folder exist, or if they have the same names and lay-
out in the source and destination project, then those sets and folders aren't remade in the destination
project. If a similar set or folder doesn't exist, a new one is created. 
For example, if you reuse a feature in the Features component, but no Features component exists in
the target project, this option creates the Features component and reuses the feature.

• Manually select location(s) for reused items(s)
Select this option if you're copying an item to a different project with a very different structure, or if
you're reusing an item to a different section of the same project.

Reuse administrator
Because of the complexity of reuse and synchronization, it can be helpful to have a person managing
reuse. An organization administrator can assign reuse administrator permissions [574].

Reuse administrators are the only ones who can:

• Edit and delete compare views of synchronized items
• Add, edit, and delete reuse rules under advanced options

Add and edit reuse rules

IMPORTANT
You must be a reuse administrator [282] to perform these tasks.

A reuse rule allows you to reuse not only specific items, but also items related to your primary selection.
You can also select which fields are copied to the new item (fields not selected use default values).

1. After selecting items for reuse, the Reuse window opens. Under Reuse options, select Advanced.

2. Only reuse rules that apply to the item type selected are shown. To view all reuse rules, deselect
Only show applicable. As a reuse administrator, you can add, edit , or delete rules. 
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3. If you add or edit a rule, the Reuse window opens.
4. To add a rule, select Add item type rule, then select an item type from the drop-down menu. 

5. Select the green Related button to define how to handle up and downstream items related to this
item type. You can add multiple rules for each item type and each rule can go 16 levels deep. Se-
lect the red minus delete button to remove any level or rule. 

6. Select the reuse options that you want to apply to these rules:
• Sync items and share global ID

Select this box to give the source item and the destination item the same global ID. With the
same global ID, changes to one item flag the relationship between them as out of sync.

• Append a prefix to the names of the copied items
If the items are only being reused but not synchronized, you can append a prefix to the new item
in order to differentiate between two copies of the same items. Enter the prefix you want to use in
the field.

• Add a relationship from the original item
Select this to create a relationship between the original item and the new item.

7. At the bottom of the window under Fields to copy, you can configure each item type to limit the
fields and widgets to be copied. Select Configure next to the item type you want to configure.

8. The fields tab allows you to define whether you want all fields copied or specific fields copied.
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IMPORTANT
Release fields can't be reused and synced between projects because they are
unique to each project.

9. The Widgets tab allows you to define whether you copy tags, attachments, and links. Once you
have configured your item type, select Done to save your changes and close the window.

Synchronization
Synchronization monitors for differences between reused items and containers. When differences exist,
users have the option to update the data for those items or containers.

Synchronized items are only visible to users with read permissions to both items. You must have write
permissions to make edits, synchronize [284], reuse [275], or duplicate items.

 If you change the hierarchy of a source component, those changes aren't synchronized in the destina-
tion component.

When you convert a synchronized item to different item type, such as converting a Requirement to a
Feature Request, the item loses its synchronization and receives a new global ID.

NOTE
Synchronization changes don't trigger suspect links [266].

Running a synchronization does not remove deleted items. For example, if an item is
deleted from the original component, you can't choose Sync All to delete that item
from the new component.

Synchronize items 
Synchronization updates are allowed only on those projects where you have read/write permissions.
You can pull data from projects where you have read-only permissions, but you can't push data to items
in those projects.

If you add a new item to a container in the source project, then synchronize it to other projects, Jama
Connect checks the destination projects to see whether an item with the new global ID already exists.

You can synchronize items in one of these ways:

• When you connect items from Single Item View [288]
• In the Synced items window (when syncing multiple items) [286]
• When you reuse items [275]
• When an organization or project administrator duplicates projects [618]

NOTE
If multiple items with the same global IDs are allowed in that project [542], a new sync
item is added to the container in the destination project, and other copies of that item
elsewhere in the project are ignored. If multiple items with the same global ID aren't
allowed (default), the destination items sync, even though they aren't in the proper hi-
erarchy.
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Sync options window
If you're viewing the Sync options window when synchronizing items in the Synced items window
[286], you see reuse options and a destination for your item. 

If you're viewing Sync options window from the Compare View, you see a top and bottom half. The top
section displays rules for items in the left column of Compare View. The bottom section displays rules
for items in the right column of Compare View. The functionality is the same for each pane.

Rules you create in the Sync options window override synchronization rules created through adminis-
tration or reuse.

Select Basic in the top right corner to view and select these options:

• Choose how you want to handle relationships:
• Don't synchronize relationships
• Include relationships from the source selection
• Include related items and mirror relationships

• Select the following options as needed:
• Synchronize all tags, attachments, and links

When synchronizing related items that don't exist in the destination project, all fields, tags, attach-
ments, and links are reused. Fields that aren't applicable to the destination project are set to de-
faults.

NOTE
Only links to attachments are synchronized, not the attachments themselves.

• Add a relationship from the original item
• The default destination uses the specified target destination.

Reused items are placed in the destination project based on the hierarchy of the source project. If a
matching location isn't found, the system automatically creates components, sets, and folders in the
destination project as needed.

Jama Connect User Guide

285



Select Advanced to:

• Display and modify existing reuse rules or add new ones.
Reuse rules shown are filtered by item type. Deselect Only show applicable to display all reuse
rules. Select Add rule to add a new rule to the items selected in this view. 

• Select a destination.
Select Manually select location(s) for reused item(s) to select a specific destination for your
synced items. 

Select Synchronize to sync all fields specified in the reuse rules in the Sync options window. This also
removes all attachments, tags, links, and relationships if selected.

When synchronizing related items that don't exist in the destination project, all fields, tags, attachments,
and links follow the sync option that's applied to the view (fields that aren't applicable to the destination
project are set to defaults).

Break synchronization
Breaking the synchronization removes the connection between items and any other relationships built
on this connection. In addition, it gives the removed item a new global Id. Further synchronizations for
that original global ID don't affect the item with the broken connection.

1. Open the Synced items window or open the bottom panel in Single Item View [273] of the item
whose synchronization you want to break.

2. Select the item whose synchronization you want to break and select Break Sync.

In the Sync Items window, select Break Sync in the same row as a specific item to remove the
sync and reassign that item a new global ID. Click the Break Sync button at the top to break the
synchronization between all of the items listed and reassign a new global ID to all of the items.

3. You are asked to confirm the break. Select Yes to continue.

Synchronize items from Synced items window

1. Open the Synced items window [273].
2. Select the component, set, or items that you want to sync from the Explorer Tree. Select Sync All

to open the Sync options [285] window for all of the items shown, or select the up or down arrow
to sync changes to or from the items shown. 
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3. Alternatively, you can select Compare to open the Compare View. Then use the right or left arrow
buttons for each item to sync them in a particular direction. Or, you can select multiple items (high-
lighted in blue) using the Ctrl and Shift keys and use the arrows at the top of the Sync All column
to synchronize all the items in a particular direction.

CAUTION
Synchronizing all items can't be undone. If the wrong groups are chosen to be up-
dated, fixing those updates might be cumbersome and time intensive.

4. The Batch Sync window displays the selected number of items to update. Selected Itemsare au-
tomatically selected, but you can also choose All items.

5. Select Batch Sync to complete the update.
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NOTE
When synchronizing items, only those fields that are enabled as synchronized fields
[584] have their data updated. Child items are added to the destination if they exist in
the source only. 

When syncing a container, the container and all children are always synced unless you
created advanced reuse rules [282] that specify otherwise.

Connect items from Single Item View

1. Open the bottom panel in Single Item View [273].
2. In the bottom panel, select Connect Items.

3. In the right panel that opens, select the item you want to connect to, then select Connect. You can
use the recently viewed, search, explorer, or releases tabs to help you find the item. You can also
select Preview to open a window with details about an item.
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4. The newly connected item now appears in the bottom panel with the same global ID. This change
also appears as an activity in the Stream [201].

Compare synchronized items

1. Open the Synced items window [273], then select an item or container in the Explorer Tree.
2. The selected item or component is displayed with a sync status that lets you know whether that

item is in sync or out of sync.  If it's out of sync, select it to open a Detailed Comparison View of
those differences.
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3. To view the differences at an item level, select Compare.

4. You see a list of all synchronized items in that component. Use the links at the top to filter items
within a component. Use your mouse to scroll left or right so you can compare fields. Click Config-
ure View to configure which fields are displayed [292]. Yellow highlights indicate synchronized
items with content that doesn't match.
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NOTE
If an organization administrator didn't enable a field to be synced [584], it's never
highlighted in yellow, and it can't be synced.

5. (Optional) Select Save compare view.

6. If this view doesn't give you enough information to determine whether or not you want to sync
something, select Detailed compare view for the items you want to compare. This opens a De-
tailed Compare View window.
You see individual changes that were made with the old text highlighted and in red and the new
text underlined and in green. You can synchronize the data by selecting the green arrow, or select
the pencil icon to manually edit the content of the fields. Select Save when you're done.
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7. Select Back to go back to the initial window where you can select synced items.

Configure Compare View for synchronized items
To configure Compare View in the Synced items window:

1. Select Configure View in the upper right corner.

2. Select the item type to configure from the drop-down menu at the top of the Configure view win-
dow.

3. Under the Fields tab, double-click, drag or use the middle arrows to move the fields you want to
see from Hidden fields to Visible fields. 
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4. Under the Relationships tab, indicate whether to view relationships and to view all or some of
them in the Compare View. 

5. Under the Widgets tab, indicate whether you want to see tags, attachments, and URL links in the
Compare View.
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6. Select Apply to save your changes or select Cancel to close the window without saving.

NOTE
The changes you make in this window are only set for the specific Compare View
you're currently viewing in the Sync Items window. Changes don't persist if you close
this window. If you want to keep the same configuration, you can save a Compare
View [289].

Exports
Select the data you want to export using advanced filters [139] or the Explorer Tree and export directly
to Word [295] or Excel [296] from List or Reading View. Use these options to quickly export without a
template.

If you view your filter results in Reading View, you see container items. These items offer a sense of
hierarchy and visual context and are included in your export. However, you can't select or change con-
tainers from Reading View.

Important considerations

Data exported from Jama Connect to Excel can be interpreted as formulas in Excel, leading Excel to
evaluate the cell and return a value. For example, if the name of an in item in Jama Connect is
“=1338-1”, Excel interprets it as a formula and the value is displayed as “1337”. All Excel formulas begin
with the equal symbol (=). When Excel encounters a field value that starts with =, the cell might interpret
it as a formula.

To avoid issues with how Excel might interpret data, don't use field names starting with the equal sym-
bol (=).

You can also:

• Export data using a custom template [298]
• Export data from Trace View [254]
• Export review activity [191]
• Export test cases [315]
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• Make round-trip exports [82]
• Export a risk analysis [421] (if your organization has this feature)

To use specific templates, select Office Templates [298]. From the Office templates window, you can
download and modify some of the more basic templates [301].

Do you have information you want to include or exclude from an export? In List View, select the gear
icon to modify the fields that appear in your in your document.

Export template parameter

By default, extra line breaks are removed to improve the published document, however this might cause
consecutive tables to be combined. If you need to restore a template to previous export results, you can
apply a new parameter to the report parameter field in the template.

Setting Definition Parameter

Default Removes extra line breaks; consecutive tables are combined. cleanEmptyParagraphs=true

Custom Keeps extra line breaks; consecutive tables are separate. cleanEmptyParagraphs=false

TIP
For self-hosted customers, a system or organization administrator can upload custom
Velocity exports [368] that are also displayed in the Export window.

Export to Word
You can export a set of items as a Microsoft Word document. If you want to show your content in con-
text, you can include hierarchy in these exports. The default Word export is a boilerplate that was cre-
ated with Office Templates and can be modified to meet your needs.

To export contextual hierarchy with Reading View:
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1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. Choose Reading View.
3. Select Export > Export to Word.
4. Upon export, your content appears as follows, depending on how you selected your data:

• Selection with the Explorer Tree
The selected container becomes the title page for the export.

• Selection with an advanced filter within a single project
Reading View includes the container hierarchy above the filtered items, up to the top of the
project. Container items that show hierarchy have a grayed-out (disabled) checkbox, while the
rest of the items can be selected. Hierarchical containers are exported with the content items.

• Selection with a cross-project filter
Reading View doesn't display numbering. The export is a listing of items without hierarchical in-
formation.

When you export items from List View, all of the items appear in list form. The export displays a table of
contents, followed by each of the items, their names, and a list of field names and values for each.

To export a list of items from List View:

1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. Choose List View.
3. Select Export > Export to Word.

NOTE
Word for Mac is known to have some issues with exporting certain formats and ta-
bles. If you experience issues, try to eliminate any special formatting or tables
within tables.

Export to Excel using default templates
Export to Microsoft Excel if you need to provide data to external stakeholders who don’t have access to
Jama Connect. You can also use round trip to work offline or share data in a format that can be used to
update existing data.

You can export selected items to an Excel document two ways:

• Using the default boilerplate template
• Using Office Templates, which can be customized

To export data to Excel:

1. From an advanced filter or the Explorer Tree, select the data you want to export.
2. In List View, select the gear icon (Show/Hide) to open the drop-down menu.
3. Select the fields that you want to include in the Excel output.
4. Deselect (hide) the fields that you don't want to include.

NOTE
Excel doesn't support rich text. Jama Connect removes formatting when it exports
to Excel.

5. In the toolbar, select Export.
6. For default template

If you want to export using the default boilerplate, select Export to Excel. Your results appear im-
mediately.
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7. For Office Templates
If you want to customize your template, select Office Templates, select an Excel export option,
then click Run.

• Export to Excel default
Generates an export that includes the fields that appear in List View (one column per field). This
export isn’t meant for importing data updates to existing items in Jama Connect. If you need to
do this, use Excel Export for Roundtrip [82].

• Excel Export for Roundtrip
Includes all available fields. You can edit the resulting spreadsheet and import the changes back
into Jama Connect.

NOTE
All fields that you plan to update using round trip must be included in the export,
including rich text fields like Description. Rich text is output in raw HTML format,
so the content can be preserved if re-imported.

Export to PDF
You can export a set of items as a PDF using the PDF reports included with Jama Connect. If you want
to show your content in context, you can include hierarchy in these exports. The default export is cre-
ated with Office templates and can be modified to meet your needs.

NOTE
For information about creating custom PDF reports and how to make existing reports
PDF compatible, go to the Jama Software Community site and search for Velocity re-
ports or see Upload custom reports or exports [368].

To export contextual hierarchy with Reading View:
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1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. In Reading View, select Export > Export to PDF.

3. Upon export, your content appears as follows, depending on how you selected your data:
• Selection with the Explorer Tree

The selected container becomes the title page for the export.
• Selection with an advanced filter within a single project

Reading View includes the container hierarchy above the filtered items, up to the top of the
project. Container items that show hierarchy have a grayed-out (disabled) checkbox, while the
rest of the items can be selected. Hierarchical containers are exported with the content items.

• Selection with a cross-project filter
Reading View doesn't display numbering. The export is a listing of items without hierarchical in-
formation.

When you export items from List View, all of the items appear in list form. The export displays a table of
contents, followed by each of the items, their names, and a list of field names and values for each. To
export a list of items from List View:

1. Select the items you want to export using the Explorer Tree or an advanced filter.
2. In List View, select Export > Export to PDF.

Office Templates
Microsoft Office Templates are Word documents and Excel spreadsheets that allow you to add format-
ting to your exports.

Office Templates are best for simple exporting with Word and Excel using data that you select in the
Explorer Tree or with an advanced filter [139].

Select Export > Office Templates to open the Office Templates window.
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The Office Templates window shows several default templates that come with Jama Connect. You can
download one of the existing templates [301] and modify it, or create your own template in Word and
upload it [302]. Select the bookmark next to a template to move it to the top of the list.

For self-hosted customers, an administrator can also upload Velocity templates [368] and they are also
displayed here.

TIP
The All Items Details Export [304], and the Coverage Report [305] are made with Ve-
locity and can't be downloaded and modified with Microsoft Word.

Each Office Template has three sections:

• Cover page This section contains general information about the export, and the data it references.
Some fields typically included in this area are:

<<reportName>> - shows the Report Name entered in the Office Templates 
window 
<<reportDescription>> - shows the Report Description entered in the 
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Office Templates window 
<<contextType>> - shows the type of content being used (e.g. release, 
component, filter, folder, item etc) 
<<contextName>> - immediate context for the data being used (e.g. 
container name, like "Requirements") 
<<userName>> - name of the user generating the report 
<<projectName>> - name of the project 
<<projectManager>> - project administrator 
<<organizationName>> - name of the organization 
<<contextPath>> - hierarchical path from the content to the project level

• Table of contents
This is automatically generated using Word's heading hierarchy. You can delete this by editing the
template to remove this section.

• Items and fields
This section contains the items and their respective fields from the selected data set. This section can
be modified.

TIP
For a list of fields available for export in your current project, you can download the
Field Reference Guide [305]. 

If you need to roll up field data or do something more complex than simply export for-
matted data from Jama Connect, read about reports [353] or custom reports [367].

Export data with Office templates

1. In List View or Single Item View, select Export > Office Templates.
2. In the window that opens, select the export you want to run from the list of templates on the left.
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3. Select the format for your export. You might also need to enter additional information about your
export for some of the templates to work correctly.

4. Exports that contain lots of data can take several minutes. You can select Email me the report to
receive a link to the export when it's finished. Links are stored for 7 days before they're automatical-
ly deleted.

5. Click Run.

Download an existing export template
You can download an existing Office Template to modify it or to start a new template.

1. In List View, Reading View, or Single Item View, select Export > Office Templates.
2. In the Office Templates window that opens, right-click on the template you want to download or

open the template and use the top toolbar to select Download Template.
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3. The template is downloaded to your computer. You can modify the template in Word and upload it
as a new template [302].

Upload an export template
Any user with read/write permissions can upload and export a custom template. You must be a project
administrator to upload and save a template to a particular project.

NOTE
For self-hosted customers, an organization or system administrator can upload tem-
plates to be available in multiple projects.

To upload a template:

1. Save the template you want to upload to your desktop computer.
2. Select Export > Office Templates to open the Office Templates window.
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3. In the window that opens, select Upload a Template in the window that opens.

4. Select Choose File and select the template you want to upload.
5. Enter a name and description.

TIP
Include the following field tags in your template to make the template name and
description visible in your export:

Report Name: «reportName»
Report Description: «reportDescription»

For a list of other available field tags you can include in your templates for the cur-
rent project, download the Word Field Reference Guide [305].

6. If you want this export template so it's available to other users only in this project, select Project. If
you want this template so it's available to users in any project, select Organization. Export tem-
plates that are shared with the organization are visible in the left column of the Office Tem-
plateswindow with the label All Projects.
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7. Select Save Report.

All Item Details Export
The All Item Details Export displays all item details for the selected project. It was designed in Velocity
for output in Microsoft Word and HTML. It's a useful export for sharing details of a set of requirements
or other group of artifacts with others outside of Jama Connect.

Once the main panel in Projects shows the correct data set, then select Export > Office Templates. In
the Office Templates window, select All Item Details, select a format, choose the parameters you need
("Include relationships" and/or "Include tags"), and select Run.
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Coverage Report
The Coverage Report displays downstream relationships to the selected set in HTML, Microsoft Word,
or Microsoft Excel. It provides summary and detailed information on the traceability coverage for the se-
lected items.

1. Select the data you want to export using the Explorer Tree or an advanced filter.
2. Select Export > Office Templates.
3. In the Office Templates window, select Coverage Report.
4. Select a format, choose the parameters you need (Missing coverage only, Downstream item lo-

cation), and select Run. Selecting no parameters provides a report like the one shown here. If you
want to see a more specific set of relationships, then select one or both of the parameter options.

Download the Field Reference Guide
The Field Reference Guide is helpful when you're creating or editing templates. It provides a dynamic
reference of all the field tags that you can use to surface information in your export templates.

This guide is unique to each project in Jama Connect. Downloading the guide provides an up-to-date
list of all the field tags available for items in the currently selected Jama Connect project.

You can copy and paste from this reference guide when creating a new template.

To download the guide:

1. In Projects List View or Single Item View select Export > Office Templates.
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2. Select Upload a template, then select Generate Word Template Reference Guide.

3. If any fields change in your project, download a new guide to see how the changes affect export
templates.

Embed custom fonts in exports
You can embed custom fonts into Word or PDF exports.

1. Download the template [301] for the existing export that you want to publish with a custom font.
2. Convert that template to DOCX format by selecting File > Save As > Word Document (.docx) in

Microsoft Word.
3. Select all of the text in the document and change it to use your custom font.

NOTE
The custom font must be in the TrueType Font format (TTF).

4. Enable embedded fonts in the document.
5. Upload the template [302] to an existing or new export in Jama Connect.
6. Export the document [300] in Word or PDF format.
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Test

You can use tests in Jama Connect to validate and verify the quality of your product and provide reports
to show connections between regulations, requirements, and tests.

A typical workflow looks like this:

• Create test cases [307] that meet the needs of a particular project or multiple projects across your
organization. Test cases describe the specific tests you plan to use and their steps [309].

• Create a test plan [317] that gives an overview of how you want to test requirements.
• Associate the cases you want to use into that plan using groups [320] to organize them.
• Get ready for testing, by moving those groups into cycles [328] where you can see a list of all the

tests you want to run. 
• Execute the test runs and log defects [335] as needed.
• Resulting test run statuses roll up to calculate the overall test case status [311]. You can then gener-

ate a report showing results, such as the Test Plan Summary Report [364] or the Test Plan Detail Re-
port [362].

IMPORTANT
You must have at least a test runner license to be able to add and edit defects and
items, create test plans and runs, and manage relationships and attachments. Howev-
er, test runners can only affect items that are used as defects [309]. More extensive
permissions require a different license [569].

Test cases
Test cases are items that contain the tests needed to validate or verify product features or systems.

Test cases contain essential information about your tests. Depending on how you want to use them you
can make standalone tests, or specific tests aligned with your use cases and requirements to assist
with validation and verification.

Creating test cases is the first step in getting tests set up for your organization. Although Jama Connect
comes with a default item type of Test Case, you can use any item type as a test case [585]. You can
add a new test case in the same way you would add any other item [110]. 

Here are three ways you might want to organize test cases:

• By project: Keep all the test cases in the same location as your project so the team goes to the
same place to collaborate, and can see a similar mirrored structure between your tests and require-
ments. This makes it easy to manage permissions for users and contain the test case and test run
status in your reports.

• By library: You can create a single library of tests in a separate project and reuse test cases in differ-
ent projects. This can be useful to standardize the testing setup and to allow the entire organization to
use the same test cases. However, with test cases being reused in multiple plans and projects, re-
ports are more likely to rely on test run status than test case status.

• Adhoc: You can pull test cases from multiple projects into any plan. You can find test cases across
multiple projects by using a filter.

Test cases are where you create test steps [309] that are used every time that case is run.
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Test cases contain an automatically calculated (and uneditable) test case status [311] field.

Test cases quick find
You can find test cases using one of these methods.

• Look for test cases in the Explorer Tree [47].
• Projects > Trace View [53] where they appear in relationship to items they test, along with associ-

ated test runs.
• Projects > List View [52] where you can filter by item type name to find test cases.
• Test Plans where you can see them in the test cases section of the plan by selecting Test Cases.

Import test cases
You can import multiple test cases and their corresponding test steps by importing them from a spread-
sheet. Use one-way import [81] to quickly bring legacy test cases into Jama Connect.

You can also use a round-trip import [82] so you can work with content outside of Jama Connect and
bring changes back in safely. 

TIP
Although you can import test cases using Microsoft Word, you can only map the Name
and Description fields, not the individual steps. Instead, use Excel for test case im-
ports.

When importing test cases:

• Your Excel spreadsheet must contain the following column headers: Test case name, Action, Expec-
ted results, and Notes.

• Add columns to represent additional fields as part of the import, which is consistent with how other
imports to Excel work.

• Each row with the same test case name imports as a new test step for that case.
• You can't use a round-trip [82] to edit the test case status [311] because that field is automatically

calculated from test run statuses.
• To add a test step in Excel, copy a pre-existing row and insert that row where you want it. Change the

content of the cells as needed to create the new step. The numbering of the steps appears off but re-
numbers on import.
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• To remove a step in Excel, delete a row anywhere in the sequence of steps. Re-numbering takes ef-
fect upon import.

Special use of item types for test
Any item type can be set up by an organization administrator [585] to work in the following test-specific
ways.

• Test case — Items used as a test case can have test steps [309] and test case status [311] fields,
as well as work in test plans for those with a creator license.

• Defect — Items you use as defects work in testing for those with a test runner license [570] or a crea-
tor license.

View and edit test case details
Test cases are created in the Explorer Tree for a project and edited like any other item [114]. They can
be opened from the Explorer Tree, Reading View, List View, or found using search or filter.

You can also view and edit test cases in these other ways:

• View test cases in groups. Select the test case ID to open and edit it in Single Item View.

• Access test cases from test runs. When you're viewing a test run in Single Item View, select the test
case button on the side toolbar to open a bottom panel with details about the test case. Then select
the ID to open and edit that test case.

Test steps
Test steps are distinct steps used to run a test. 

When running a test, you can indicate the success or failure of each step. The test steps field is availa-
ble in any item whose item type is used as a test case [585].

Add and edit test steps
Test steps are plain text by default. When an organization administrator enables rich text in test steps
[586], you can edit with rich text by selecting the pencil icon or double-clicking on the Steps field. Se-
lecting Edit in the toolbar only allows plain text or html edits.
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You can't edit test steps when editing a test run.

1. View details of the test case [309] where you want to add steps, or create a new test case [307].
2. Select Edit in the toolbar, the pencil icon next to the field, or double-click in the field to make it edit-

able. In the steps field, select Add step.

3. Enter text in the Action, Expected result, and Notes fields, if you want. You can use the Tab key
to move between fields. Use the rich text editor [310] to format text or to add images in the steps.

4. Use the up and down arrows to re-order the steps. You can also grab the handle by the row num-
ber to drag it to the right position.

5. Use the insert icon to insert a step. Delete a step with the trash can icon.
6. Select Save to include the test steps in the test case.

Add images to test steps
Test steps are plain text by default. An organization administrator can enable rich text for basic format-
ting and embedded images. [586]

To add an image:

1. Edit a test case.
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IMPORTANT
You must save a test case first before adding images to test step fields.

2. Select Edit in the toolbar, the pencil icon next to the field, or double-click in the field to make it edit-
able. Place your cursor in the step where you want to add the image. 

3. Select the add image icon, then select the image from your browser. You can also select the file
folder icon, then select the image from those already saved onto the application server as attach-
ments.

4. Large images are resized automatically to fit the width of the cell. To view the full-sized image, navi-
gate to the image location by right-clicking on the image.

Test case status
Test case status is an automatically calculated status that indicates the state of the last edited test run
associated with that test case.

By default, this status is calculated using all available test runs associated with the test case, including
runs that aren't scheduled. An organization administrator can disable this option [609] so that unexecu-
ted runs aren't included in the calculation.

The status is calculated in one of these methods:

• If the test case is used in only one test plan, the latest status is reported on the test case.
• If the test case is used in multiple test plans, test case status shows the most urgent test run status

based on the following hierarchy, regardless of when it ran: Not Scheduled, Failed, Blocked, Sched-
uled, Passed.

The status is visible in Single Item View of each test case.
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NOTE
Because test case status is automatically calculated, it can't be manually updated
when editing a test case.

TIP
If a test case is used in multiple plans and it's picking up the status of a plan that's no
longer relevant, one option is to archive that plan [327]. Doing so removes that plan's
test run statuses from the test case status calculation.

You can also use archiving to trigger a recalculation of all test cases in a plan. When a
user archives and then un-archives the test plan, this results in a re-calculation of the
status for all test cases in that plan. This can be useful if you change the admin setting
to include unexecuted test runs [609] (which isn't retroactive) and want to recalculate
test case status with the new setting.

View test run results
You can add a Test Run Results column to Test Cases in reviews, List View, Reading View, and Trace
View. The column displays the status of all Test Runs that are downstream.

Add column in List View or Reading View

1. From the gear icon, select Test Run Results.
2. Hover over the color bar to view the status for each test run.
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Add column in Trace View

1. From the gear icon, select Test Run Results.
2. Hover over the color bar to view the status for each test run.

 

 

Add column in reviews

1. Select Admin > Organization, then select Item types.
2. On the Item types page, select Test Case > Edit.
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Note: Your administrator might use a different name for Test Case, like "verification." To confirm the
item type, look at the "Use as" section in the Edit Item Type window.

3. Click Save.
4. Select Test Case > Views and enable the Test Run Results field for Reading View and Single Item

View.
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In a review with Test Case items, the results rollup bar now appears.
5. Hover over the color bar to view the status for each test run.

Export test cases to Microsoft Excel
You might want to export test cases to Excel for manual testing or for audit purposes when the docu-
ments need to be saved in a formal repository.

The content that appears in the final output depends on the items you select. For example, if you select
Name and Modified by, those are the only fields that appear in the output.
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NOTE
You can also export test cases [295] to a Microsoft Word document.

Things to know before selecting Steps

Each step is assigned its own row in Excel output. Also, each step row includes the same non-step data
for that case. The repeated data impacts the item count in the spreadsheet.

Compare the results with and without Steps:

With Steps

TIP
All step fields are included: Step #, Step Action, Step Expected Results, and Step
Notes. These columns can’t be configured in Jama Connect and must be adjusted af-
ter the export.

Without Steps

To export test cases:

1. From the Explorer Tree, select the set or folder for the test cases that you want to export. If the test
cases are in multiple locations, you must use a filter to select the test cases.

2. Select List View.
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3. Select the gear icon to open a drop-down menu and select what you want to include in the Excel
spreadsheet.

4. In the toolbar, select Export > Export to Excel.

Test plans
A test plan is an item that documents the overall strategy for validating or verifying that a product or
system meets its design specifications and requirements. 

Test plans quick find
Although test plans are items, they aren't visible in the Explorer Tree.

To find test plans and their details:

1. Select the Test Plans tab at the top of the Explorer Tree.

2. Select the plan you want to use to view details [322] of that plan.
3. View and comment on test plans in review [324], as needed.

TIP
Although test plans don't appear in the Explorer Tree, you can surface them with an
advanced filter [139].
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Add a test plan

NOTE
You must have read/write permissions for the entire project in order to create a test
plan. 

1. Select the Test Plans tab in the left panel.

2. Select Add test plan.
3. In the Add item window that opens, enter the name and description of your new plan, and add any

tags. An organization administrator can edit the default template [600] included in the test plan de-
scription.
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TIP
If you select Add another, when you save this plan a new Add item window
opens for you to create another plan. 

If you select Notify in the lower left corner of the window, you can leave a com-
ment and notify a particular person or group by email that this plan was created. 

4. Select Save and close.

Add test cases to a plan
Once you have created test cases, you can add them to a plan in groups. For example, you might
group all the cases for a specific aspect of the product, test location, or tester. You can use groups later
to create a similar cycle of runs [329].

You can only add a test case to one group in a test plan.

1. Select the Test Plans tab in the left panel, and the name of the plan where you want to add the
cases. 

2. In the upper right toolbar of the center panel, select Test cases for that plan.
3. The right panel shows an Explorer Tree for your project. In the center panel you can view (or cre-

ate) groups [320] for organizing your test cases.
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4. Select any component, set, or folder of test cases, or an individual test case from the tree on the
right. You can also use the Releases, Filters , or Search tabs to find the test cases you want to
add. Drag it to an existing group to add cases to that group.
Alternatively, grab test cases and drag to the dashed line box at the top of the center pane to cre-
ate a new group. If you drag a component, set or folder that contains test cases, the hierarchy is
preserved. For example, if you drag this set of test cases to the top of the center panel:

... it results in the creation of these three groups:

Test groups
Test groups let you combine and label similar tests in a test plan.

Test cases are added to a plan in groups. Organizing test cases this way makes it easier for others to
understand and run your test plan. For example, you might want to put all the cases for a specific as-
pect of the product, test location, or tester in the same group.

Add, edit, or delete a test group
When adding test cases to a plan [319], they are added in groups. In addition to the default test group,
or automatic groups that are created by dragging test cases, you can also manually create a new
group.
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1. Select Test cases [150] for the plan you want to see.
2. Select the green Add Test Group button.

3. In Add/Edit Group of Test Cases, enter the name of the group.
4. Select the magnifying glass icon to open the Add users window. Select the name of the person

you want to assign to run the tests in this group. Use Select user to complete the action. This also
automatically assigns any runs created from this group to that person.

TIP
Some organizations create a user as a placeholder for a particular team, such as
"Test Team A" and assign groups to that team.

This does require an active license, but it allows members of the team to see all
the runs that are assigned to their team in a cycle.

When you execute a run that was assigned to another user (such as "Test Team
A") you can reassign that run to yourself.

5. Select Save on the Add/Edit groups of test cases window.
6. To edit an existing test group, select the settings icon in the corner of the group to open the Add/

Edit window. You can also use the triangle to collapse or expand groups, or the X to delete
groups.
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View test plan details
Select the name of a plan to open it. In the center panel, you can toggle between these three views:

• Overview
Describes the testing goals and purpose. It's displayed as a Single Item View [56] of the test plan. An
organization administrator can configure which fields are displayed for this item type [589].

• Test cases
Select Test Cases to add groups of test cases to a plan.
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• Test runs
Select Test Runs to add and perform a cycle of test runs. 

Edit a test plan
Once you find the test plan you want to use, decide which way to edit the overview section of a plan.

1. Right-click on the plan you want to edit. 
2. Select Edit to open the Edit item window. 

3. Make changes to the test plan overview and select Save.

Alternatively, you can:

1. Select the plan name to open it in Single Item View. Overview must be selected in the toolbar.
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2. Select the gray pencil icon next to the field you want to edit.
3. Make changes to the test plan overview and select Save.

Send a test plan for review

1. Select the test plan [317] you want to use.
2. Right-click on the test plan you want to review and select Send for review.

3. Initiate a review [157] as usual.
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TIP
You can also create an advanced filter [139] that contains any combination of test
plans, cycles, cases and runs and send that to review.
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TIP
When sending test items to review, not all relevant fields might appear in Reviews Sin-
gle Item View or in Reviews Reading View. An organization administrator can configure
views [600] for an item type to include the necessary fields.

Duplicate a test plan
Right-click on the test plan you want to duplicate (active or archived) and select Duplicate.
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This creates an active copy of the selected test plan. 

IMPORTANT
The copy contains the same details as the original and the same groups of test cases,
but doesn't contain the test runs or test cycles from the original.

Archive a test plan or run

1. Right-click on the test plan that you want to archive and select Archive.

2. Archived test plans move into a group at the bottom of the list of test plans.
3. To unarchive a test plan, right-click an archived test plan and select Unarchive to make it active.

NOTE
The only way to archive a test run is to archive the associated test plan. When you ar-
chive a test plan, the associated test runs no longer appear in the associated test
case, and the test case status reverts to "not scheduled." You can unarchive test runs
and recalculate test case status by unarchiving the associated test plan.
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Delete a test plan

CAUTION
When you delete a test plan, you also delete all associated test cycles and runs. If you
do this, test cases associated with deleted test runs can change status. If a plan has
any associated test runs, consider archiving the test plan [327] rather than deleting it.

1. View details [322] of the plan you want to delete. 
2. In the toolbar, select Delete (trash icon).

Test cycle
Test cycles convert groups of test cases into a series of test runs that are ready for execution. 

Inside of a test plan, you can add a test cycle [329] to help you manage and execute runs [335]. You
can also send a test cycle for review [331].

Test cycles can include tests for a particular team, from a particular test case, tests you want to run on
the same day or at the same location. 

TIP
You can't add a test case directly to a cycle; it must first be included in a group.
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Add a test cycle
Cycles are created from groups of test cases. Add a test cycle to hold the test runs that you want to
execute together. 

1. Inside of a plan, select Test runs from the toolbar. On the left side of the toolbar you see the name
of the cycle. The runs associated with that cycle are displayed here.

2. In the upper left toolbar, select the small arrow next to Cycle to open the drop-down menu. From
this menu you can view cycle details, add, edit or delete a cycle, or send a cycle for review [331].

3. To add a cycle, select Add Cycle. If this is the first cycle you're adding, you see a green Add first
cycle button.
If you want to edit an existing cycle, select the name of the cycle you want to edit from the pull-
down, then select Cycle > Edit cycle.

4. Enter the test cycle details in the Add test cycle window.

5. Click Next.
6. Select the groups you want to include in the cycle. Select Select all if you want to include all test

groups in this cycle. 
You can also filter the status of which test runs you want to include. For example, it's possible to
only add failed or blocked test runs.

Jama Connect User Guide

329



7. Click Save.

Edit a test cycle
Cycles are created from groups of test cases. You can edit the name and description of a test cycle
without impacting the cycle's contents.

1. In a test plan, select Test Runs from the toolbar. On the left side of the toolbar you see the name of
the cycle. The runs associated with that cycle are displayed here.

2. Select Cycle to open the drop-down menu, then make your changes.
• Select Edit cycle to make changes to the contents associated with the test cycle.
• Select Edit details to change the name and description without impacting the cycle's contents.

3. Click Next.

A pop-up message confirms that the changes were successful.
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Send a test cycle for review
When sending test items to review, not all relevant fields might appear in Reviews Single Item View or
in Reviews Reading View. An organization administrator can configure views [600] for an item type to
include the necessary fields.

1. Select the test plan [317] that you want to use.
2. Select Test Runs in the toolbar.

3. Select the name of the cycle you want to send to review.
4. Select the small arrow next to Cycle to open a drop-down menu, then select Send for review.

5. Initiate a review [157].

Test runs
A test run is an item used to record results for a test case you ran against your product.

Find and manage test runs
By selecting Test runs in the toolbar, you can manage all the runs in the cycles for a plan.

• For the plan you're using, select Test runs in the upper right toolbar.
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• Test runs are displayed in a configurable List View in the center panel. Select Views > Configure
view in the upper right toolbar to make the fields you want to see visible.

NOTE
If you select Test Case as one of the visible columns, the Test Case column shows
the ID in front of the name.

• Select the column header to sort columns. Return them to their original order by selecting Restore
order. For older data, a project reindex [640] might be required to properly restore the order.

NOTE
The Test group column order is based on the hierarchy of groups [320]. The names
themselves can't be sorted in List View.

• Use the drop-down menu next to Cycles [328] to display the test runs for a cycle. 
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• To execute a run, select the blue circle at the left of each row, or right-click and select Execute test
run.

• You can also right-click on a test run and select Open test case to see the test case associated with
this run or Assign test run to select an assignee.

• Select Show only assigned to me in the upper left toolbar to filter the List View for test runs as-
signed only to you.

• Select Export to export the test runs shown as a standard Word, Excel, or custom format document
(Office Templates).

TIP
You can see and analyze test runs in Trace View [53] if you view their associated test
cases there. 

View test run details

1. In the test plan, select Test runs from the upper right toolbar to display test runs in List View. 
2. Select the name of a test run to view its details.
3. From the toolbar on the right, you can view and add relationships, comments, and connected users.

You can also check the activity and version history for the test run or open the associated test case.
4. Double-click on any of the fields to edit the test run.

Configure test run view
You can choose which columns are displayed under test runs. These settings only apply to you.

1. Select a test plan, then select Test runs in the top right menu.
2. Under Views, select Configure view.
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3. In the window that opens, double-click on the field name, drag and drop, or use the arrows in the
middle to move the field names between Hidden fields and Visible fields.

4. Select Restore organization defaults if you want to return to the default settings. An organization
administrator can configure the default view settings for test run item types [600].

5. Select Save as default for test runs if you want to use this configuration for all test runs that you
view in Jama Connect. If you uncheck this box, your settings are only applied during this session
and return to default settings when you log in again.

6. Select Apply.

Assign test runs

1. Inside of the plan you're using, select Test Runs in the upper right toolbar. 
2. Select the Runs you want to assign in the List View. You can use Ctrl or Shift to select more than

one.
3. Select Actions > Assign Test Runs in the upper right toolbar, or right-click on the run you want to

assign and select Assign Test Runs.
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4. In the Assign Test Runs window, enter the name of the person you want to assign. You can use
the magnifying glass icon to open the Select a user window, select the name you want, then
use Select user to complete the action.

5. Select OK.

Execute a test run
Important considerations

• Selecting Pause doesn't save results and results (pass/fail) don't automatically save. You must click
Save and Done to save the recorded results or "actual results" values.

1. In the project you want to test, select Test Plans.
2. Select the blue button next to the run you want execute or right-click and select Execute Test

Run.

3. In the Execute Test window, use the three tabs at the top to execute the test, view run details, or
view the associated test case.

NOTE
If you try to execute a test run that isn't assigned to you, you are prompted and
asked to reassign it to yourself. 

4. Under the Test Execution tab, select Start Test Run to start the duration timer. 
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NOTE
Unless the field is configured to read-only, you can double-click on the duration
field and change the timer to reflect the actual testing time.

5. If you discover a defect while running a test, select Log a Defect to open the right panel, fill in the
information and select Save Defect. A project administrator can determine where these defects are
saved [639]. When you add a defect from the Test Execution window it's automatically related to
that test run.

6. Once you start the time and begin the test, you can mark each step as passed (green check) or
failed (red x). You can add results for each step in the results field. If no steps were added to the
original test case, you see a single pass/fail button.
You can also add or upload an attachment by clicking Add attachment. These attachments aren't
accessible from any defect items created during the test run. Attachments or screenshots for a de-
fect must be recorded separately on the defect item.

7. (Optional) Include images in the Results column of the test steps, or provide feedback in the Ac-
tual results section below the test steps table.
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8. The test case status [311] (in progress, passed, failed, blocked) is shown at the bottom of the sta-
tus column. If at least one step failed, you can select Mark as blocked, (when something preven-
ted performing all the steps) or Pass with errors.

9. Select the Test run details tab to view details about the run. Select the arrow in a column header
to use the drop-down menu to sort the column or to select which columns are visible.

You can see the following items in this window:
• The test case that generated this test run

Select the ID to open up a new window that displays the details of the derived item, such as the
goal of the test case, pre-conditions, steps in the case, and the duration of the test run.

• Upstream items related to this test run
Select the item ID to view detailed information about the related items in a separate window.

10. Select the Test case tab to view details about the test case that generated this test run.
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11. Select Save and Close.

Configure custom fields to appear during test execution
Custom fields added to the Test Run item type now appear in the Test Execution window during test-
ing.

Similar to the Actual Results field, these custom fields can be filled in during test execution.

1. Click Admin > Item Types >Test Runs, then select Fields.
2. Select Add field to add field types, then click Save.

On the next test run, the custom fields are displayed and can be edited.

Example: Add a test field to capture the serial number for a product being tested during that test run's
execution.
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Make test runs current
When creating test runs, a copy of the test case is put into the test run. But if a change is made to the
test case after that, the change isn't reflected in the test run.

1. You will know if a test case has changed since the test cycle was created, because a pencil and
paper icon appears in the second column if the test case has changed.

2. Select test runs you want to make current (using the Shift key to select multiple), then select Ac-
tions > Make test runs current.
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3. In the Make test runs current window, select whether you want to make all items current or only
those you selected. 

4. You are asked to confirm. Select Commit to make test runs current. 
5. Only runs associated with test cases that were changed are updated. The previous versions are

deleted and the updated version is added. Any previous progress, results, or statuses are also re-
moved from the updated test runs. Any test runs that didn't change still retains progress, results,
and statuses.

NOTE
If you don't have read/write access to an item or if it's locked by someone else, it isn't
updated.

Test run status
Test run status indicates the current state of a test run, and is used in calculating test case status.

Test run status is visible in the test run execution window and in Single Item View.

You can also use a rollup of test run status for all tests in a cycle. You can see it above the cycles when
you select Test runs in the toolbar.
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Possible states are: 

• Pass
• Fail
• Blocked  
• In progress 
• Not run

NOTE
If you need to reset the test run to a status of Not run, you can batch update test run
status [341] or unmark steps that were marked as pass or fail, and set the test run du-
ration to 0. This automatically resets the status to Not run.

Batch update test run status
As long as test runs aren't locked and you have write permissions, you can batch update the test run
status.

1. Select Test Runs in the upper right toolbar. 
2. Select the test runs you want to update in the center panel. Use the Ctrl or Shift keys to select

multiple.
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3. Select Actions > Batch Update Test Run Status.

4. This opens a window for you to confirm the number of runs selected. Select Next.

5. Select the new status you want for the selected runs. Select Next.

6. In the next window, you can select users or groups and send a notification alerting them to this
batch update. When you're done, select Commit.
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IMPORTANT
You can only batch update test runs in the Test runs window. You can't use advanced
filters to batch update test runs. 
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Analysis

Jama Connect includes a number of tools you can use to get the big picture or gain insights on different
areas of your research:

• Reports [353]
• Dashboard [344]
• Coverage and traceability tools [250]
• Exports [294]

Dashboard
The dashboard can be configured to show key metrics about your project so you can see which areas
of your work need attention.

Dashboards are customized per project, not per user. You must have organization or project administra-
tor permissions to make changes to the dashboard. 

See a list of dashboard options [344] that you can add to the dashboard [351].

To access the dashboard, select the project name in the Explorer Tree.

Dashboard options

CAUTION
You must have organization or project administrator permissions to manage the dash-
board [351]. Changes are made at the project level.

The following options are available on the dashboard:
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• Filter results
Displays the results of an existing filter. Name the window, select a filter and which columns to dis-
play. Select how many items you want to display.
Note: Available filters only include lists that can be applied to totals. For example, text or numbers
aren't included.

You can use the buttons in the top right for any of these windows: Collapse, Configure, Refresh, or
Delete.
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•
• Assigned to me

Displays a list of items "assigned to" the current user. 

Select the gear icon in the top right to edit the settings. Name the window, select a filter and which
columns to display. Select how many items you want to display.

• Bar chart
Displays the results of an existing filter as a bar chart. You can configure the name, filter, field shown
and number of elements with the gear icon in the top right. Select the individual bars in the bar chart
to move directly to a view of those items in a new tab.
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• Recent activity
Displays a line graph of recent activity over a period of time. You can configure the time period and
change the name with the gear icon in the top right.

• Pie chart
Displays a pie chart for a filter and field that the user selects. You can configure the filter and field
with the gear icon button in the top right. Select the individual items in the pie chart to open those
items in a new tab.
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• Activity stream
Displays the current activity stream [201] of the project. View all current activity including comments,
edits made, new items created, and assignment changes. Use the filters at the top right to filter only
comments, activities or search for specific items. 
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• Project summary
Displays a summary of the entire project, including total number of items in the project, number of
days until next release, and number of days until project completion. This window displays informa-
tion that project administrators set in Configure project > Project details and under the Release
tab.

• Rich text
Displays user defined text, images, diagrams and equations. Select the gear icon to insert text, pic-
tures, and tables with the same rich text options [95].
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• Recently viewed
Displays the last 15 items viewed by the current user. You can select a recently viewed item to open it
in a new tab.
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• Relationship diagram
Displays the relationship rules [148] applied to the project.

Manage the dashboard
Use the dashboard to give your team insight into the progress of each project.

CAUTION
Any user with project or organization administrator permissions can modify the dash-
board. Changes are made at a project level and not a user level.

To set up the dashboard:

1. Find the dashboard by selecting the project name in the top left, and customize the board for your
project by selecting Add in the top right toolbar.
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2. In the Add to dashboard window select the icon for the option you want to add, then select Add.
Learn more about dashboard options. [344]

3. Select Change layout in the toolbar to choose how the windows appear on the dashboard.
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4. Select Print to print the contents of your dashboard. For best results, use a landscape page setup
and enable printing of background images in your browser settings. 

Reports
A report is a document that helps you analyze the current status and progress in your work. Reports
can include graphs, tabular data, metrics and other roll-ups.

Reports might refer to a specific set of data or they can be global and refer to entire project, or across
multiple projects. You can access reports by selecting Projects , then Reports in the upper right head-
er. From there you can publish a report [354].

Jama Connect comes with some default reports that were created with BIRT or Velocity.

Self-hosted customers can create custom reports [367] and a system administrator can upload them
[368] so they are visible under Reports.

Select Reports in the Jama Connect header to publish reports that typically roll up data or otherwise
reflect status in your projects. Jama Connect comes with the following reports:

• The Baseline Compared to Current Report displays a side-by-side comparison of items and relation-
ships in a baseline and their current versions.

• The Baseline Comparison Report displays a side-by-side comparison of items and relationships in
two baselines.

• The Bidirectional Traceability Report displays upstream and downstream relationships for a selected
container of items.

• The Items in a Set Report displays a tabular list of items in a set. 
• The Release Status Report displays the current state of the items within a release.
• The Task List with Estimates Report displays all item types and sums their estimates if applicable.
• The Test Plan Detail Report displays the details of a test plan.
• The Test Plan Summary report displays a summary of the test plan with graphs and charts, by cycle

and build. 
• The Trace Relationships Report displays items with their downstream relationships.
• The User List Report displays a list of all the active and inactive users associated with the organiza-

tion.
• The Review Center Stats Report displays the progress of a specific review.
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Publish a report

1. From the Jama Connect header, select Reports > Run report.

2. The reports shown in the following image are reports that come with Jama Connect. If your organi-
zation also has custom reports [367], they are visible here too.

NOTE
Select the bookmark icon next to a report to add this to your bookmarked reports
at the top of the list.

Baseline Compared to Current
The Baseline Compared to Current Report displays a side-by-side comparison of items and relation-
ships in a baseline and their current versions.

1. Navigate to the project containing the baseline you want to compare to the current state of the
project, using Change Project in the Explorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.
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3. Select one of these report options:
• Baseline Compared to Current
• Baseline Compared to Current (PDF)

4. Select the format of the report.
5. Select the baseline you want to compare.
6. Select the options you want to include:

• Include Relationships
• Include Version Comments

7. Select Email me the report if you want to receive it by email.
8. Select Run Report.

Baseline Compared to Current shows a table that compares the baseline items and relationships side
by side.
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Items that were modified since the baseline are highlighted.

Baseline Comparison
The Baseline Comparison Report displays a side-by-side comparison of items and relationships in two
baselines.

This report is like the Baseline Compared to Current [354] report, but instead compares two specific
states of selected items at a certain point in time. For example, you can compare the baseline that's
created when you open a review with a baseline of the completed review to see what changed.

1. Navigate to the project containing the items you want to include, using Change project in the Ex-
plorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.
3. Select one of these report options:

• Baseline Comparison
• Baseline Comparison (PDF)

4. Select the format of the report. 
5. Select the two baselines you want to compare.
6. Select the options you want to include:

• Include Relationships
• Include Version Comments

7. Select Email me the report if you want to receive it by email.
8. Select Run Report.
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Items added or deleted between the compared baselines are noted at the top of the report.
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NOTE
When comparing baselines, the hierarchical order must be the same between the two
baselines. If items are reordered in the Explorer Tree from one baseline to the next, the
report shows incorrect or no results.

Bidirectional Traceability
The Bidirectional Traceability Report displays upstream and downstream relationships for a selected
container of items.

To run this report:

1. Select Reports in the upper right header to open the Run Reports window.

2. In the Run Reports window, select one of the default output formats (HTML, PDF, WORD, or XLS).
3. Choose the Location that contains the items you want to analyze in this report.

NOTE
You must choose a container of items to analyze for upstream and downstream
traceability. The report doesn't work on single items.

4. Select Run Report.

The report displays all the items that have relationships from the selected location. Both downstream
and upstream relationships are displayed for each item. The report also indicates whether any related
artifacts are marked as suspect (T = suspect, F= not suspect).
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Items in a Set

The Items in a Set Report displays a tabular list of items in a set. 

Columns in the table show the Header (hierarchy), ID, Name, and Description columns. To run this re-
port:

1. Navigate to the project containing the items you want to include, using Change project in the Ex-
plorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.

3. Select the Items in a Set report.
4. Select the format of the report. 
5. Select the location of the items you want to include.
6. Select Email me the report if you want to receive it by email.
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7. Select Run Report.

Release Status
The Release Status Report displays the current state of the items within a release.

It shows graphs of item status and priority, as well as a table with priority, status, estimate and amount
remaining.

To run this report:

1. Navigate to the project containing the items you want to include, using Change project in the Ex-
plorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.
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3. Select the Release Status report.
4. Select the format of the report. The default format is PDF.
5. Select the Location of the items you want to include.
6. Select Email me the report if you want to receive it by email.
7. Select Run Report.

NOTE
If you have data in the Estimate and Remaining fields, those numbers aresummed on
the bottom of the report in order to provide totals for the release.

Task List with Estimates
The Task List with Estimates Report displays all item types and sums their estimates if applicable.

To run this report:

1. Navigate to the project containing the items you want to include, using Change project in the Ex-
plorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.
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3. Select the Test Plan Detail report.
4. Select the format of the report.
5. Select the Location of the items you want to include.
6. Select Email me the report if you want to receive it by email.
7. Select Run Report.

Test Plan Detail
The Test Plan Detail Report displays the details of a test plan.

To run this report:

1. Navigate to the project containing the test plan you want to include, using Change project in the
Explorer Tree.
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2. Select Reports in the upper right corner of the header to open the Run Reports window.

3. Select the Test Plan Detail report.
4. Select the format of the report.
5. Select the Test Plan you want to use.
6. Select Email me the report if you want to receive it by email.
7. Select Run Report.
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Test Plan Summary
The Test Plan Summary report displays a summary of the test plan with graphs and charts, by cycle
and build. 

1. Navigate to the project containing the test plan you want to include, using Change project in the
Explorer Tree.

2. Select Reports in the upper right corner of the header to open the Run Reports window.
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3. Select the Test Plan Summary report.
4. Select the format of the report.
5. Select the Test Plan you want to use.
6. Select Email me the report if you want to receive it by email.
7. Select Run Report.
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Trace Relationships
The Trace Relationships Report displays items with their downstream relationships.

Review Center Stats
The Review Center Stats Report displays the progress of a specific review in a table that shows activity
per reviewer and per item under review.

You must be a reviewer, approver, or moderator of a review to run the report or to have the review listed
in the menu. Public reviews aren't listed unless you're specifically assigned to the review.
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User List
The User List Report displays a list of all the active and inactive users associated with the organization.

The report includes:

• Username
• Full name
• Disabled (Inactive) status
• Email
• License type

Table 2. License type key for User List Report
Creator (named) N

Creator (float) C

Test runner TR

Stakeholder S

Temporary ET

Reviewer (named) NV

Reviewer (float) - legacy V

Reserved reviewer - legacy RV

Reserved collaborator - legacy R

Collaborator (float) - legacy FC

Inactive I

Custom reports
Jama Connect's default reports [353], exports [294], or Office Templates [298] can be used to meet the
most common reporting requirements.

However, if your needs go beyond built-in default reports, custom reports might be of benefit to you.

Jama Software Consulting Services can offer help creating:
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• Reports with logic
• Reports with charts and graphs
• Reports with custom formatting

To get help, contact your account manager or Jama Software support at support@jamasoftware.com.

Upload custom reports or exports

NOTE
Self-hosted customers with system or organization administrator permissions can com-
plete this task.

You can upload reports [353] or exports [294] so that other users can access them.

If you're uploading a Velocity or Office Template export that uses pre-selected data in the main panel,
the exports appear under Exports > Office Templates. If you're uploading BIRT or Velocity reports that
pull data at a project or cross-project level, they appear under Reports in the Jama Connect header.
Read more about Jama Connect and Velocity here.

TIP
Before uploading a report or export, check with the person who created it about the
best settings to use because report criteria is unique to each one.

To upload custom reports or exports:

1. Log in as root user [489] and select Reports. If you're an organization administrator for a self-hos-
ted instance, select Admin > Reports. This shows a list of all currently available reports or export
templates.

2. Select Add report in the top right corner to open the Add/Edit Report window.
3. Enter a name for the custom report or export template so that other users can identify it.
4. Select the report or export template type (BIRT, Velocity, or Microsoft Office Template), and the for-

mat you want to use.
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NOTE
For templates with Microsoft Word or HTML formats, the option to export the re-
port to PDF is also available.

For Office Templates, any user with a creator license can add their own custom
export [302] to make it visible under Export > Office Templates.

5. To define availability for reporting, select the Data Access type.
6. To limit access to run custom reports based on user permissions and by user group, select the

Restrict to Group type.

7. Next to Report File Name, select Choose File to open a window where you can select the report
or export template you want to upload. BIRT reports have the file extension .rptdesign. Velocity re-
ports have the file extension .vm.

8. Enter a Description that helps users understand the output.
9. Use Scope, to determine whether the report or export template is available to all users (Organiza-

tion) or only users in a particular project (Project). Default reports that come with Jama Connect
have a scope set to System.

10. Select Visible to Users for it to appear in the application. 
11. If you're uploading a Velocity export that only applies to data referenced on the user's main panel,

select Context Sensitive. This export appears in the window that opens when users select Ex-
ports > Office Templates.

12. (Optional) Class name and path is only used for custom plug-ins for BIRT or Velocity reports and
can be left blank. 

13. For Office Templates, set any parameters [370] you want to use in the report or export template.
14. In the Criteria section, select the plus sign to add criteria for this report or export template.
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• From the drop-down menu, select the type of data for this individual criteria. For example, select
"Release" for it to pass in a release ID, or "Baseline" for it to pass in a baseline ID.

• For Display, enter the label you want users to see. This name is what the user reads when pub-
lishing the report and exporting from Jama Connect and describes the expected input from the
user.

• For Name, enter a case-sensitive name that is passed to the report or export template. Each pa-
rameter in a report or export template must be unique. When users publish a report or export
Jama Connect content, these are displayed in alphabetical order by the name field, not in the
order shown in the report setup screen.

TIP
If you're editing an existing report or export template, and you change the Name
criteria, you must change the reference to the criteria in your report or export tem-
plate or it breaks.

15. Select Save to upload the report or export template and save your changes.

Report parameters
You might need to select one of the following report parameters when uploading custom reports.

NOTE
Only system administrators with access to editing reports can make these changes.
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• Release — Shows all project releases in a pick list. The user can select release parameters as nee-
ded.

• Location — Shows the project hierarchy in a pick list. The user can select a location for each loca-
tion parameter.

• Baseline Parameter — Shows all baselines in the project in a pick list. The user can select one
baseline for each baseline parameter.

• String Parameter — Presents the user with a text field to enter a string.
• Date Parameter — Presents the user with a text field to enter a date.
• Boolean — Presents the user with a checkbox. The value "true" or "false" is sent to the reporting

engine.
• Test Plan — Presents the user with a pick list of test plans in the selected project. Jama Connect

passes the database ID to the report.
• Review — Presents the user with a pick list of reviews in the selected project. Jama Connect passes

the ID to the report.

Reports history
Use the Reports history page to view and download reports. You can also see the status of reports that
are being generated.

Note: Organization admins see all reports. Users see only reports they create.
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• Download reports — In the Actions column, select the down arrow icon.
• Remove reports — In the Actions column, select the trash icon.

Risk
With Risk Management, your organization can use Jama Connect to organize and conduct a risk analy-
sis for your products.

The default starter templates are based on the FMEA and ISO 14971 standards and follow a common
risk management process [372]. However, they can be adjusted to better meet your needs.

Once your organization has purchased the additional licensing, you can find risk analyses by selecting
Risk in the header.

NOTE
Risk Management requires additional licensing for your organization, as well as crea-
tor, stakeholder or test runner licenses for all risk management participants. Contact
your Jama Software account manager for more information.

Risk management process
Risk Management in Jama Connect is intended to help your organization assess and mitigate risk
based on the requirements for your product. In general, the risk analysis process follows this format:

1. A risk administrator [376] creates a risk template [377] to standardize how risks are captured and
evaluated for their organization, or for a certain type of product.

2. Moderators [396] create a risk analysis based on a risk template and invite participants to view or
work on the analysis.

3. Participants assigned to a risk analysis work together to:
• Define risks [372]
• Set rankings [373]
• Mitigate risks [374]
• Adjust rankings [375]
• Perform risk-benefit analysis [376]

Define risks
Once a moderator invites participants to an analysis [399], the risk management process begins with
defining risks. Participants identify risks and potential consequences in the first part of a risk analysis.
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Participants can all view the same risk analysis. Contributors can edit the analysis, entering a single risk
on each row and the values that correspond to that risk. While editing, the analysis locks [406] to avoid
prevent edits by other users.

Each risk corresponds to a separate row and is marked with a unique risk ID [420]. The analysis can be
configured to add multiple harms [381] per hazardous situation. Contributors can also link items [404] to
this risk in any text field. From Single Item View you can see which risks link to a particular item [415].

Set rankings
After defining risks [372], participants can rank them to determine risk levels for the product. 

In a risk analysis, participants often rank:

• Severity of the harm 
• Probability of a hazardous situation occurring (P1)
• Probability of a hazardous situation leading to harm (P2)

To set rankings, participants select values from a drop-down scale.  
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Selecting severity and probability values automatically generates risk levels. Based on what's accepta-
ble risk for the product, participants can use this information to consider how to mitigate risk and make
the product safer.

TIP
A risk administrator sets default values for scales and matrices, as well as the way that
P total and Risk level are calculated [378]. 

Mitigate risks
Once participants set rankings [373] for the defined risks, it becomes apparent which risks exceed an
acceptable level. Participants can suggest ways to make the product safer. Often, these are additional
product requirements that must be defined, tested and added to the risk analysis for traceability.

When mitigating risks, participants document the options, measures, and verification used.
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• Under Options, participants select the best path for reducing a specific risk. Typically, organizations
have a short list of options from which they choose, for example, the ISO 14971 standard uses:
• Inherent safety by design
• Protective measures in the product or manufacturing process
• Information for safety

• Under Measures, participants enter the procedures or requirements implemented to reduce risk.  
• Under Verification, participants confirm that new product requirements are successfully tested.

Contributors can also link items [404] to this risk in any field. From Single Item View, you can see which
risks link to a particular item [415].

Adjust rankings
After mitigating risks [374], participants evaluate again to see if they successfully lowered risk to accept-
able levels.

They may adjust rankings for:

• Probability of a hazardous situation occurring (P1)
• Probability of a hazardous situation leading to harm (P2)
• Severity

NOTE
Some data under Adjust rankings might not be visible or editable, depending on your
process. Risk administrators can control which values are displayed or can be edited
[395]. All others can see which values are visible or editable in Definitions. When a
value isn't editable in Adjust rankings, it's carried over from Set rankings to deter-
mine final risk levels. 

To adjust rankings, participants select values from a drop-down scale.
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These adjustments are shown in the corresponding P total and residual Risk level. Participants can
repeat the cycle of mitigation and adjustment until risk levels are acceptable for the product.

Perform risk-benefit analysis
When rankings are adjusted and final risk levels are set, participants use a a risk-benefit analysis to de-
termine whether the benefits of a product or procedure outweigh the possible risks.

During this process, participants evaluate risks [407] and seek agreement that risks are mitigated as far
as possible, that these risks are acceptable, and that the benefits outweigh the risks.

Risk administrator

NOTE
You must have a creator license to be a risk administrator. 

As a risk administrator, you have full permissions to create and edit risk templates and you can manage
participants for any analysis. By adding yourself as a participant, you can also act as a moderator [396],
contributor [402], or viewer [408] for any analysis.

You also have these unique abilities as a risk administrator:

• View all of the templates and analyses that were created
• Create templates [377]
• Edit templates [378]
• Delete templates [396]
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NOTE
An organization administrator grants risk administrator permissions by assigning risk
administrator permissions to a user group [577]. 

Create a template

NOTE
You must be a risk administrator [376] to create a risk management template.

Risk management comes with two default templates:

• FMEA starter template
• ISO 14971 starter template

You can use these templates (located at the bottom of the list of templates), or modify them to create
additional templates.

When you create a new template, you can adjust language and settings for a risk analysis and save the
result for others to use.

To create a new risk management template do the following:

1. Select Risk in the header.
2. Select Definitions next to FMEA starter or ISO 14971 starter.

3. Select Save As.
4. Enter a name for the new template and select Save.
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5. To build your new template, edit the settings, then save the result as a new template.

Edit template settings

NOTE
You must be a risk administrator [376] to edit template settings.

If you remove all fields from a section in a risk template, the section header and risk analyses don't ap-
pear in the template. Also, the section itself is no longer visible to users when they view definitions in
the risk analysis.

NOTE
The Adjust Rankings section is an exception to this rule. If you enable a ranking field
before mitigation, the section is still displayed.

To edit template settings:

1. Select Risk in the header.
2. In the list of templates, select Settings next to the template you want to edit. 
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3. Here you can:
• Enter a template description [381]

Add a description to help moderators choose the right template.

• Edit display text [381]
Add or remove a text column, change column headers and descriptions for text columns, allow
users to add multiple harms, allow users to add links.

• Edit scales [384]
Add or remove a scale, change column headers, descriptions and drop-downs for scale columns.
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• Edit matrices [389]
Add or remove a matrix, change column headers, descriptions and field values for matrix col-
umns.
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• Hide data or make it read-only [395]
Show or hide certain columns of the analysis, or make them read only.

4. Scroll to the bottom of the Settings page and select Save.

NOTE
The starter templates' settings can't be modified: you can only use them to create a
new template. You can select Definitions to see how a starter template is set up.

Edit display text

NOTE
You must have risk administrator [376] permissions to edit display text settings.

You can edit the following aspects of a template to better meet the needs of your risk management
team.

To do this:

1. Select Settings next to the template you want to edit, allowing you to change the following:
• Template description 

Enter text that describes how to use this template. Select Save.
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This text appears below the template name in the list of templates.

• Section names 
You can change five section names in Settings. This text appears at the top of the analysis. By
default, the names are Define risks, Set rankings, Mitigate risks, Adjust rankings, and Evalu-
ate risks. 

To edit this text, replace the corresponding default text under Display name and select Save.

• Column header and description 
For any column, you can edit the header or description, or allow users to add links in that column.
Descriptions of column headers appear as hover tips in analyses made from this template.
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Edit names and descriptions on the Settings page below each column header name. Select Al-
low links if you want to allow users to add links to that column in the analysis.

You can enable two special fields so that participants can add multiple harms per risk. By default,
these are labeled Harm and Cause in the starter templates, although you can rename them.

• Remove columns
Remove text, scale or matrix columns from the template by selecting Remove next to the column
name. You can also restore these columns by selecting Add.
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NOTE
The risk ID column can't be removed or edited.

2. Select Save.

Edit scales

NOTE
You must have risk administrator [376] permissions to edit matrix settings.

On the settings page, you can adjust the values for scales (such as P1, P2 and  Severity). The values
from these scales appear in drop-down menus the corresponding columns of the analysis.
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You can edit scales in the following ways:

• Edit scale name and description
In template Settings, enter a name and description for each scale, then select Save.

The scale name appears as the column header and the description as a hover tip in any analyses
made from this template. 

• Remove scales
Select Remove next to the name of the scale you want to remove from the template. Then select
Save. This removes the corresponding column from this template.
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NOTE
A note appears below the scale description to alert you if another scale or matrix de-
pends on the one you're editing. If you try to remove a scale with dependencies, you
are prompted to confirm deletion.

If you remove a scale with dependencies, dependent matrices are also removed. 

• Edit scale values
Each scale has a Value, Label and Description that you can edit. Select Add value to add a value.
You can change the values to any number from 1–99. Values control the display order from lowest to
highest. Use the trash can icon to delete a value. Select Save when you're finished editing.
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NOTE
If you edit a scale that has a dependent matrix, you see a message with a request to
update the dependent matrix. You can't save changes until you reconcile this. 

To correct the error, edit the affected matrix.

Select Reset all values to clear and reset all values in the matrix, or select Update
the headers only. You only need to set values for the affected area. 

You must enter a value for each matrix field before saving. You can use the tab and
arrow keys to select values.
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When you're finished, select Save.

• Restore a scale
The default starter template comes with three scales. If you remove a scale and want to add it back,
select Add. Edit the scale as needed, then select Save. 

Edit matrices
You can edit the existing matrices in a template or add a new matrix.

NOTE
You must have risk administrator [376] permissions to edit matrix settings.

Matrices are based on input from scales. Each field in the matrix is determined by the product of the two
corresponding inputs.

The resulting calculated fields from this matrix display in the corresponding column in the analysis.
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To save a matrix, you must assign text values (like low, medium, high) to each of the matrix fields. How-
ever, you can choose whether to display that text, or the actual numerical product for that field in the
analysis.

To edit matrix settings, select Settings next to the template you want to edit, and choose any of the
following aspects to edit:

• Edit matrix name and description
Enter a name and description for each matrix, then select Save.

The matrix name appears as the column header and the description as a hover tip in any analyses
made from this template. 
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• Edit matrix values
To add new values, select Add value. To edit existing values, use the drop-down arrow to edit the
name and color of these default values, then select Set value. Select Delete in the drop-down menu
to remove a value. Select the checkbox to display text values in any analyses made from this tem-
plate, or leave it unchecked to display numerical products. Select Save at the bottom of the Settings
page to save these changes.

To edit the values within the matrix, select the value you want to edit and use the drop-down to
choose a new value.

Jama Connect User Guide

391



• Edit matrix inputs
You can adjust the risk level matrix to use different scales. For example, you might only want a matrix
that balances probability and severity. To edit matrix inputs, select Change input at the top left corner
of the matrix.

In the window that opens, select the scales or matrices that you want to use as inputs from the drop-
down menus. Select Save.

NOTE
You can't use the same matrix or scale as an input for more than one matrix in the
same template.
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NOTE
If you edit a matrix that has a dependent matrix or scale, you will see an error mes-
sage with a request to update the dependent matrix or scale. You can't save
changes until you reconcile this error. 

To correct the error, select Reset all values to clear and reset all values in the matrix
or, select Update the headers only. You only need to set values for the affected
area. 

You can also use the tab and arrow keys to navigate and select values you want to
set.

• Remove a matrix
Select Remove next to the name of the matrix to remove it from the template. Then select Save. This
also removes the corresponding column from this template.
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NOTE
A note appears below the matrix description to alert you if another matrix depends
on the one you're editing. If you try to remove a matrix with dependencies, you are
prompted to confirm deletion.

If you remove a matrix that has dependencies, you will also remove those dependent
scales and matrices.

• Restore a matrix
To restore a matrix that was removed, scroll to the last existing matrix and select Add in the gray ma-
trix bar. Edit the matrix as needed, then select Save.
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NOTE
You must enter a value for all fields in the matrix before you can save it.

Show, hide, or lock data

NOTE
You must have risk administrator [376] permissions to show, hide, or lock data.

For certain data under Adjust Rankings, you can decide whether to make it visible or editable. To find
these options, scroll to the bottom of the Settings page and select the checkboxes you prefer:

Scales marked Make visible are shown as columns in the analysis. If you mark Allow edits, the analy-
sis shows a small arrow that opens a drop-down menu for editing. 
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Delete a template

NOTE
You must have risk administrator permissions to delete a template.

To delete a risk management template:

1. Select Risk in the header.
2. Next to the template you want to delete, select Settings.

3. On the Settings page, select Actions at top of the page.
4. In the Actions window, select Delete template.
5. Selecting Delete to confirm that you want to delete the template.

NOTE
You can't delete the ISO 14971 default starter template. 

Moderator

NOTE
You must have a creator license to be a moderator.

A risk moderator initiates and manages a risk analysis.

If you initiate a risk analysis, you become the risk moderator by default.
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A moderator can do everything that contributors [402] and viewers [408] can do.

A moderator can:

• Initiate an analysis [397] (this is how they become a moderator)
• Add participants [399]
• Edit an analysis name [399]
• Delete an analysis [402]

TIP
A risk analysis can have more than one moderator. Moderators or risk administrators
can add other participants as moderators, if needed.

Initiate a risk analysis

NOTE
You must have a creator license to initiate an analysis. By default, you become the
moderator for any analysis you create.

To initiate a risk analysis:

1. Select Risk in the header.
2. Decide which template you want to use and select it.
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3. Type the analysis name and click Save.
4. This opens the new analysis. Select the title at the top of the page to edit the analysis name [399]. 

5. Select Participants to add participants [399].
6. The analysis is only be visible to any users you added as participants. Participants see the analysis

when they select Risk in the header.
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Edit analysis name

NOTE
You must be a moderator [396] to edit an analysis name.

To edit a risk analysis name:

1. Select Risk in the header.
2. Find and select the analysis you want to rename.
3. When the analysis opens, select the name at the top of the page and the field becomes editable.

4. Changes to the name are shown in the header at the top of the analysis, as well as in the list of
analyses when you select Risk in the header.

Add participants

NOTE
You must be a moderator or risk administrator to add or update risk analysis partici-
pants.

To add participants to an analysis:

1. Open the analysis [409].
2. Select Participants.
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3. In the panel that opens, enter the name of the person you want to invite and select their name from
the drop-down menu. 

IMPORTANT
You can only select Jama Connect users with a creator, stakeholder, or test runner
license. To invite participants who don't appear here, contact your organization ad-
ministrator to add users [561] or update license types [567]. 

NOTE
You can't add users who are currently participants. If you want to change a user
from one role to another, you must first remove them from their current role, then
invite them to the new role.

4. Once you select a name, use the drop-down menu to select a role for the new participant:
• Moderator [396]
• Contributor [402]
• Viewer [408]
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NOTE
Risk analyses can have multiple moderators, contributors, and viewers.

5. Add a message to the participant, if you like, and select Invite. An email is sent to this user to invite
them to the analysis. When they select Risk in the header, the analysis is available for them to use.
After you invite new participants, you see them listed in the Participants panel. You can remove
participants from this panel, too.

6. To delete a participant, select Remove.
7. Select the X at the top of the panel or Close participants to close this panel.

TIP
In the event that an analysis has a single moderator who isn't available to manage an
analysis, a risk administrator can assign a new moderator.
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Delete an analysis

NOTE
You must be a moderator or a risk administrator to delete a risk analysis.

To delete a risk analysis:

1. Select Risk in the header.
2. Select the name of the analysis you want to delete.
3. Select Actions > Delete analysis in the top right menu.

4. Select Delete to confirm that you want to delete the analysis. You can't restore an analysis or its
data once you delete it.

Contributor

NOTE
You must have a creator license to be a contributor.

A contributor changes content and values in an existing analysis. A moderator adds contributors to a
risk analysis.

As a contributor, you can do everything a viewer can do [408], plus the following:

• Add, edit and delete risks [402]
• Lock and unlock an analysis [406]
• Link items to an analysis [404]

Add, edit, and delete risks

NOTE
You must have contributor or moderator permissions to complete this task. Viewers
can't add, edit, or delete risks.

To add a risk to an analysis:

Jama Connect User Guide

402



1. Add a row for the new risk.
Select Add row at the bottom of the analysis or in the top right toolbar, to add a new row to the
analysis.

TIP
You can also use the Tab key to add rows to the bottom of the analysis. Tabbing
through the last row land your cursor on the Add row button, and you can use
Enter to add a new row.

To specify where to add a new row, select the row above it. Then use the Add row drop-down
menu in the top right toolbar and select Insert after selected.

The new row appears with an automatically generated risk ID [420].

2. The analysis locks [406] when you're editing to prevent others from overwriting your work. Your data
is autosaved as soon as you move from one cell to the next. Select Unlock when you're done edit-
ing so others can edit.

3. To delete a risk from an analysis, select the box at the beginning of the row you want to delete, then
use the drop-down arrow next to Add row to select Delete.
To delete the last row, select Delete last row at the bottom of the page.
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Link items to an analysis

NOTE
You must be a moderator [396] or contributor [402] to link items to an analysis.

NOTE
For you to add a link to a particular field in an analysis, a risk administrator must con-
figure the template [381] to allow this.

You can link from any text column of an analysis to Jama Connect.

1. Select the field where you want to add a link to open the Add link option.

2. Select Add link to open a drop-down menu. Begin typing any part of the unique ID [628] of the
item, container, or attachment you want to link.

3. Select the link from the drop-down menu.
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TIP
If you can't find the item you want to link in the drop-down menu, you can copy the
link to that item from your browser and paste it in the drop-down field. You can add
up to five item links per field.

4. Once a link to an item is added, anyone with permission to that item can view the linked analyses
and risks [415].
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Lock and unlock an analysis
Select Risk in the header to see a list of all analyses that you can access. If an analysis has a lock icon
next to it, it's locked and you can view it, but not edit it.

An analysis is locked whenever a moderator or contributor does any of the following:

• Enters text into any field 
• Selects a value from a scale
• Adds or removes a link
• Adds or removes a row
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To unlock an analysis, select Unlock when you have finished editing. This allows other participants to
edit the analysis. 

While you're editing an analysis, other participants see a LOCKED notification next to the analysis
name, along with information about who is editing the analysis and when it was last edited. They can
select Refresh to update that information.

WARNING
The only person who can unlock an analysis before it times out, is the person who
locked it.

Otherwise, the lock times out 60 minutes after the last edit and the analysis becomes
available for others to edit. This happens even if the user is still working in other areas
of Jama Connect.

If another user edits the analysis after the lock times out, any unsaved data the first
user entered is lost. Data is automatically saved when a user moves from one cell to
another.

If the same user returns to edit the analysis before other users, any changes are saved
when they make another edit.

Evaluate risks
During a risk-benefit analysis, you might want to add comments about how the final risk level was deter-
mined and its acceptance. You can also add a link to a Jama Connect item in this field.

Analyses created with the ISO 14971 starter template, or any template that was customized by a risk
administrator [381] can include a column to the right of the final risk level where participants can add
comments about that risk and its acceptance.
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Viewer

NOTE
You must have a stakeholder, test runner, or creator license to be invited to an analysis
as a viewer.

A viewer can read, but not edit, a risk analysis. 

A moderator or contributor can also do everything that a viewer can do.

For example, all participants (viewers, moderators, and contributors) can:

• View an analysis [409]
• Bookmark an analysis [410]
• View risk definitions [411]
• Filter risk analyses [412]
• Filter and sort risks [413]
• View risks and analyses for an item [415]
• View and sort risk IDs [420]
• Export a risk analysis [421]
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View a risk analysis

NOTE
To view a risk analysis, you must be invited [399] to that analysis, be the moderator
[396] of that analysis, or have risk administrator permissions [376].

To view a risk analysis:

1. Select Risk in the header.
2. In the list of analyses, find the analysis you want to open and select it. Analyses are listed in the

order they were created. Any bookmarked analyses are at the top of the list. Any locked analyses
[406] show a lock icon. To see more analyses, select Load more.

TIP
You can filter [412] and bookmark [410] analyses to find them more easily.
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3. If you're invited to an analysis, you receive an email with a link to view it. Any participant can use
that same link to view the analysis.

NOTE
You only see the analyses for which you're a participant. Risk administrators [376] are
the only ones who can see all the analyses.

Bookmark an analysis
You can bookmark a risk analysis to keep it near the top of your list and make it easy for you to find.

1. Select Risk in the header.
2. In the list of recently viewed analyses, select the bookmark icon next to the analysis you want to

bookmark.

3. The analysis that you bookmarked moves to the list of bookmarks at the top of the page.

TIP
You can also bookmark projects, components, folders, sets, filters, and Trace Views to
your homepage [44].
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View risk definitions
The risk administrator creates templates for the analysis and makes decisions about how the analyses
are set up. This includes setting rankings in the scales, configuring matrices and making certain fields
visible or editable.

Select Actions > View definitions to understand how an analysis works. This page gives context
about how this analysis was set up. Anyone with access to an analysis can view definitions.

In addition to specific descriptions for scale rankings and matrix values, the definitions page also shows
which fields allow links and which fields are editable.
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TIP
You can also hover your mouse over the column headers to see the definition for each
one.

Filter risk analyses
When you select Risk in the header, you see a list of all active risk analyses. You can filter the list of
analyses by your role to find the analysis you're looking for more easily.

1. Select Filter next to the Analyses header.

2. In the drop-down menu select a role. The filter is applied to bookmarked and recently viewed analy-
ses.
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3. The Analyses header now includes the number of results returned. Text below the header shows
which filters are being applied.

4. To clear the filter, select Clear filter.

TIP
You can also bookmark analyses [410] to keep them at the top of the list.

Filter and sort risks
You can filter and sort the risks in an analysis by scale and matrix values to find what you need.

To filter risks:
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1. Select Filter.

2. The filter panel shows all the values you can use, grouped by scale, or matrix. Select the boxes for
the values you want to see in your filtered results. 

3. Selected filters are displayed as tags at the top of the risk analysis. Active filters are shown at the
top of the page. Select X to remove a filter or Clear all to remove all filters.
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IMPORTANT
Filters can only block or show entire rows. If you have multiple harms per risk, the
filter displays all of the harm values if any one of them meets the criteria.

4. Select Close filter to hide the filter panel. Filters remain active until you release them.

NOTE
You can't add rows while an analysis is being filtered.

5. You can also sort values for scale or matrix columns. Select the header to toggle between ascend-
ing, descending or unsorted order (indicated by small black arrows next to the header name). 

TIP
To resize columns, hover between two column headers, click and drag to the right
width.

IMPORTANT
For risks with multiple harms, sorting on values uses the harm with the highest val-
ue for the entire row. 

View risks in Single Item View
Contributors can add links to items in text fields in an analysis as a way of linking requirements, mitiga-
tions, or verifications to a particular risk.

Jama Connect User Guide

415



You can see which risks or analyses link to a particular item when viewing that item in Single Item View
[56].

IMPORTANT
An organization administrator must enable the risk widget [584] for the item type before
risk is visible in single item view.

Your organization must have active risk licensing and you must be an invited partici-
pant in order to view a risk analysis.

When the widget is enabled, you see a flame icon next to the number of risks that correspond to that
item.

Select the small arrow next to the number to view details about the analyses and risks that refer to this
item.
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The names of analyses are listed in bold, followed by the number of risks in that analysis that refer to
this item. The risks IDs [420] are listed below each analysis name.

As long as you are invited to the analysis, you can select the analysis or the risk ID to view the item in
context. When you select the risk ID you see the risk that links to the item outlined in blue.

TIP
You can also see risks in other areas of the application [417], even when the risk widg-
et hasn't been enabled for that item type.

View risks across the application

NOTE
Your organization must have active risk licensing and you must be an invited partici-
pant in order to view a risk analysis.
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You can tell when an item is linked to a particular risk in a risk analysis when viewing the item in Single
Item View [415], or when viewing multiple items. For example, in Reading, List, or Trace View.

1. Select Configure fields and select Risk as a field you want to display [55].

2. You see a risk icon with a count of risks associated with that item in each of the following views:
• Reading View

• List View
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• Trace View

3. Select the risk icon to open a side panel with detailed information about the risks that are linked to
that item. Select the risk ID or the analysis name in the side panel to go directly to the risk or analy-
sis.
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TIP
You can configure fields to show risk in the following areas of the application: Reading
View [53], List View [52], Trace View, [53] Test cycles [328], Dashboard [344], Relea-
ses [233], Coverage Explorer [270].

Risks aren't visible in Reviews [153], baselines [236], sync items compare view [292],
or compare item versions [228].

View and sort risk IDs
Risk IDs are unique IDs assigned to each row in an analysis. Risk IDs are automatically generated
across all analyses and numbered sequentially in the order they were created.

Risk IDs are visible in the left column of every analysis. This column can't be moved or edited. Howev-
er, you can select the column header to sort risk IDs in ascending or descending order.
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Export a risk analysis
You can export a risk analysis to Excel at any point during the analysis process. To do this, select Ex-
port at the top right corner of the risk analysis.

The export downloads directly to your computer, based on your browser settings.

Open the exported Excel file, and you see two worksheets labeled:

• Analysis
This worksheet contains the content of the risk analysis.

• Definitions
This worksheet contains information about the text fields, scales, and matrices used in the analysis.
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Installing Jama Connect

Jama Connect is a Linux-based application that runs on Docker containers and uses Replicated soft-
ware to "orchestrate" deploying applications. The process of installing Jama Connect includes installing
and configuring Docker and Replicated. These tasks deliver the components necessary to run Jama
Connect.

Components and what they do

Docker containers — A standalone executable package of software that includes code, runtime, sys-
tem tools, system libraries, and settings. See https://www.docker.com/resources/what-container for de-
tails.

Replicated — A container-based platform for easily deploying cloud native applications inside custom-
ers' environments to provide greater security and control. The Admin Console is the interface for instal-
ling and administering the Jama Connect application. See https://www.replicated.com/ for details.

Jama Connect license — The license included in your Welcome email. You upload the license to your
application server, then begin installing Jama Connect.

• Jama Connect users access Jama Connect by browsing to the instance URL (https://jamainstan-
ceurl.customer.com/).

• Replicated administrators browse to the Admin Console by browsing to the same instance URL, but
on port 8800 (https://jamainstanceurl.customer.com:8800/).

• Replicated updates Jama Connect and the license via API calls for internet-enabled environments.
Our airgap option removes the need for remote API calls.

• Any content added to your Jama Connect instance is stored in the database. Uploaded artifacts, such
as attachments and report templates, are stored in the file system in the /data directory.

Which type of installation do you need?
Decide which type of installation you need to perform, then follow the instructions for that type.
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Planning your installation
Before you install the Admin Console and Jama Connect, make sure you have the following.

All installations

• The license file sent from Jama Software, a small file with the .rli file extension (included in the Wel-
come email)

• An application server with the necessary preparation [427] and requirements [425]
• A database server with the necessary preparation [429]
• Supported 64-bit Linux distribution with a kernel of:

• 4.x or greater (recommended)
• 3.10 (minimum)

• Supported version of Docker

Airgap installations

If you are using the airgap method to install Jama Connect, you must have the following items.

• URL to the airgap-safe portal (included in the Welcome email) for downloading the Jama Connect ap-
plication file

• A unique password (included in the Welcome email) to access the airgap-safe portal
• PDF of this installation guide for the version of Jama Connect you are installing

IMPORTANT
If you lose the URL and password, contact support to generate new ones.

Optional

• TLS certificate and private key to secure the Admin Console and Jama Connect application

System requirements
Make sure that your environment conforms to all requirements and recommendations before installing
Jama Connect software.

For a list of current requirements, see supported software and system requirements and follow the link
for your version of Jama Connect.

For the supported authentication types, see Authentication methods [466].

Application server requirements
To install and run Jama Connect successfully, your application server must meet these requirements.

Requirement Notes

Be a dedicated applica-
tion server

Aside from Jama Connect, make sure that no other applications are running on the application
server. Any external services affect the stability of the application. For example, diminishing mem-
ory resources.

Have sufficient storage,
CPU, and memory

Usage patterns and data size can be varied and complex, and application performance depends
on the amount of CPU and memory provided. Use the tables in Resource sizing for your applica-
tion server [426] to estimate the appropriate size and resources for your application server.

Have administrative rights
to that server

An administrator must be able to maintain the application, perform upgrades, and access the
server for regular maintenance.
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Requirement Notes

Use compatible software
and environments

Verify that you're using compatible and supported software and environments with our most re-
cent self-hosted release.

Resource sizing for servers
For optimal performance, we recommend that you estimate the needs of your environment's servers
before installing Jama Connect.

Use the following tables to determine resources for your application server and database server. Moni-
tor usage [522] and adjust your settings [482] as necessary.

If you're approaching the Enterprise threshold, contact support for customized recommendations and
advanced, multi-server setup.

Application server

Small Medium Large Enterprise

Active items in system Up to 600,000 Up to 2 million 2–4 million 4 million+

Active projects Up to 100 Up to 500 Up to 1,000 1,000+

Concurrent users 50 or fewer Up to 500 Up to 1,000 1,000+

CPU cores 4 8 16 Contact Support

Total system RAM 16 GB 24 GB 32 GB Contact Support

Database server

Small Medium Large Enterprise

Active items in system Up to 600,000 Up to 2 million 2–4 million 4 million+

Active projects Up to 100 Up to 500 Up to 1,000 1,000+

Concurrent users 50 or fewer Up to 500 Up to 1,000 1,000+

CPU cores 4 8 16 Contact Support

Total system RAM 16 GB 32 GB 64 GB Contact Support

Total system RAM can vary if you're using memory intensive workflows such as reuse [275], exporting
[294], move items [127], integrations [622], and batch updates [116].Database sizing is based on your
usage patterns and platform. You must have a minimum of 4–8 cores and 16–24 GB of memory. Con-
sult with your database administrator when determining database size.

The memory allocation allows for minimum headroom. If you need to run additional software for moni-
toring and analysis, consider the additional system requirements for that software. Configure dynamic
memory settings [482] as needed in the Admin Console. 

We recommend setting up dedicated volumes for the data your application is going to write. For infor-
mation about setting up these volumes, see Preparing your application server, Example: Setting up
dedicated volumes [427].

The storage calculator can help you determine your particular needs for the application server.

Item Default lo-
cation

Recommen-
ded file sys-

tem type

Explanation Small ex-
ample

Enter-
prise ex-

ample

Calculate
your own

Operating
system

N/A N/A Not included in this cal-
culation

N/A N/A ______ GB

Docker im-
ages

/var/lib/
docker

XFS with
ftype=1, or
EXT4

Variable 30 GB 50 GB ______ GB
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Item Default lo-
cation

Recommen-
ded file sys-

tem type

Explanation Small ex-
ample

Enter-
prise ex-

ample

Calculate
your own

User data /data NFS Filesystem can vary,
but consider size of at-
tachments you're stor-
ing

40-100 GB 100 GB ______ GB

Replicated /var/lib/repli-
cated/

EXT4 Tip: Configure snap-
shots to be stored in /
data/replicated/snap-
shots/ to ensure back-
up

20 GB 30 GB ______ GB

Log files /logs EXT4 10 GB (fixed) 10 GB 10 GB 10 GB

Total: 100 + GB 160+ GB ______ GB

Important considerations

• To avoid performance issues, use XFS with the dtype option of ftype=1 or use EXT4. For Docker's
default data root directory, /var/lib/docker, if an XFS filesystem doesn’t have the dtype attribute set to
ftype=1, performance can degrade for container creation at startup.

• Jama Software supports internally hosted network storage mounts (NFS). EBS is suggested in cloud-
based environments. Cloud NFS (like EFS) isn't supported because Docker doesn't work with EFS.

Database server requirements
The database must be hosted on a server separate from the Jama Connect application. This server can
host other databases, but we don’t support other applications running on the same server as the data-
base.

• MySQL 5.7 and 8 (recommended)
• Microsoft SQL 2016, 2017, and 2019

What is NOT supported

• Azure database
• MariaDB
• Custom configurations of Jama Connect databases. Customizations such as query optimization and

additional indexes that aren’t shipped with Jama Connect aren’t supported.

Things to do before installation
Whether your environment is internet-enabled or airgap, make sure that your application server and da-
tabase server are ready before installing Jama Connect.

• Prepare your application server [427]
• Prepare your database server [429]
• Install and configure your database (MySQL [430] or SQL Server [432])
• Configure custom memory settings for Elasticsearch [434]

Preparing your application server
Make sure your application server meets all requirements. See Supported software and system require-
ments.

For users and administrators to properly access Jama Connect, the following ports must be accessible
to inbound traffic. Work with your network administrator to ensure your network is configured properly.

• Port 22 — The SSH port. This allows administrators to make remote connections to the application
server using SSH.

• Port 8800 — The Admin Console port. This is needed for administrators to access the Admin Con-
sole used to configure, install, and upgrade Jama Connect.
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• Port 80 — The Jama Connect port for clear text communication (HTTP). This port can be used to
access Jama Connect. It can be disabled, or the port number can be reconfigured.

• Port 443 — The Jama Connect port for SSL/TLS communication (HTTPS). This port can be used to
access Jama Connect. It can be disabled, or the port number can be reconfigured.

For Jama Connect to successfully run its processes, the following User IDs must be available and un-
used on the application host.

• User ID 91 — UID 91 is used by Tomcat to read and write to directories under /data.
• User IDs 480 – 499 — These ports are used by the various services.

To ensure accurate time on the application server, sync the time on a routine schedule (for example, set
a cron job to sync time every day or hour). To set up the cron job, use the command: 

ntpdate pool.ntp.org

Important considerations

• To improve resolution time of any issues, keep ports open. Closing access to ports for communication
within the server isn't supported and risks application accessibility.

• Docker pre-routes traffic so be sure to set rules in the DOCKER-USER table, not the INPUT table.
• To avoid blocking issues when installing on RHEL or CentOS Linux distributions, disable firewall or

add the docker0 interface to the "trusted" zone.
• We recommend setting up dedicated volumes for the data your application is going to write.

Example: Setting up dedicated volumes

Use this example to partition the logical volumes on your application server.

Start with a 100 GB disk.

1. Create a mountpoint:

mkdir /data /logs /var/lib/docker /var/lib/replicated

2. Create a physical volume:

pvcreate /dev/<your-disk-name>

3. Create a volume group:

vgcreate vg_jama /dev/<disk-name>

4. Create logical volumes:

lvcreate -L 30G -n lv_docker vg_jama
lvcreate -L 20G -n lv_replicated vg_jama
lvcreate -L 10G -n lv_logs vg_jama
lvcreate -l 100%FREE -n lv_data vg_jama

5. Write file systems:

mkfs.xfs -L docker -n ftype=1 /dev/vg_jama/lv_docker
mkfs.ext4 -L replicated /dev/vg_jama/lv_replicated
mkfs.ext4 -L data /dev/vg_jama/lv_data (ext4 or NFS)
mkfs.ext4 -L logs /dev/vg_jama/lv_log

6. Edit the file /etc/fstab to include the following lines:

LABEL=docker /var/lib/docker xfs defaults 0 0
LABEL=replicated /var/lib/replicated ext4 defaults 0 0
LABEL=data /data ext4 defaults 0 0
LABEL=logs /logs ext4 defaults 0 0
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7. Mount all volumes:

mount -a

8. Confirm that all volumes were mounted properly:

df -h

Preparing your database server
The following information is needed when connecting the application server to the database server.

Information Requirements

Type/vendor Database must be one of the following:

• MySQL (recommended) — Install and configure MySQL [430]
• Microsoft SQL Server — Install and configure Microsoft SQL Server [432]

Database hostname Example: jama.companydb.com

Listening ports The application server must be allowed to communicate, remotely, with the database server over the
listening ports. Default ports are:

• MySQL = 3306
• Microsoft SQL Server = 1433

Database schema
name

The database owner must be able to either:

• Create a new database schema.
• Create tables inside an existing database schema of the given name.

The database name must follow these rules:

• Start with a letter (a–z).
• Contain any number of characters: a–z, 0–9 or an underscore ("_").
• Letters must be lowercase.

Username jamauser

Password

Connections The database must be able to accept a minimum of 300 concurrent connections.

SAML schema user-
name

samluser

OAuth database user-
name

oauthuser

The username and password for SAML and OAuth must match what's entered in the Microsoft SQL
Server upgrade preparation script. See Upgrade and configure Microsoft SQL Server [454] for more de-
tails.
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Install and configure MySQL
MySQL is the recommended database server. Follow these steps to install and configure it.

If you want to upgrade MySQL, see Upgrade and Configure MySQL [453].

1. Make sure that the InnoDB engine is enabled.
2. Download and install a supported version of MySQL. To find out which version of MySQL you need,

see Supported software, environments, and system requirements and click the link for your version
of Jama Connect.

3. Create an empty Jama Connect schema / database that uses UTF8.

create database jama character set utf8;

4. Use the following commands to create a user called "jamauser" with the ability to access, create,
and update tables within the database.
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IMPORTANT
Before installing Jama Connect 8.62.x, you must create two additional database
schemas for the installation/upgrade to succeed. To create the database schemas,
run these SQL commands on the MySQL database server:

CREATE DATABASE jama character set utf8;
CREATE DATABASE saml;
CREATE DATABASE oauth;
CREATE USER 'jamauser'@'%' IDENTIFIED BY 'password';
CREATE USER 'oauthuser'@'%' IDENTIFIED BY 'password';
CREATE USER 'samluser'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON jama.* TO 'jamauser'@'%';
GRANT ALL PRIVILEGES ON oauth.* TO ‘oauthuser’@‘%’;
GRANT ALL PRIVILEGES ON saml.* TO ‘samluser’@‘%’;

5. Restart the database server.

The following recommended settings require 8 GB of memory allocated to MySQL Server for a typical
installation and 16 GB for an enterprise installation.

Depending on your database server's operating system, this can be added to your my.cnf file (Linux) or
my.ini file (Windows). You can also make these changes directly to the database.

Property Typical Installation Enterprise Installation

max_allowed_packet 1 GB 1 GB

query_cache_type 1 1

query_cache_size 256 MB 256 MB

tmp_table_size 2 GB 2 GB

max_heap_table_size 2 GB 2 GB

table_open_cache 512 512

innodb_buffer_pool_size 2 GB 12 GB

innodb_log_file_size 256 MB 256 MB

innodb_log_buffer_size 12 MB 12 MB

innodb_thread_concurrency 16 16

max_connections 151 351

wait_timeout 259200 259200

Here is a sample text config file at an enterprise level. You must add the following values for your envi-
ronment:

ignore_builtin_innodb
bind-address=0.0.0.0
key_buffer_size=16M
max_allowed_packet=1G
thread_stack=192K
thread_cache_size=8
myisam-recover-options=BACKUP
query_cache_type=1
query_cache_size=256M
tmp_table_size=2G
max_heap_table_size=2G
table_open_cache=512
innodb_buffer_pool_size=12G
innodb_log_file_size=256M
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innodb_log_buffer_size=12M
innodb_thread_concurrency=16
max_connections=351
wait_timeout=259200

Install and configure Microsoft SQL Server
If you are using Microsoft SQL Server for your database, follow these steps to install and configure it.

You must have full database admin permissions to the SQL Server.

If you want to upgrade the Microsoft SQL Server, see Upgrade and configure Microsoft SQL Server
[454].

IMPORTANT
Before installing or upgrading to Jama Connect 8.62.x, you must:

• Install Microsoft SQL 2016–2019 for the database server.
• Create an empty Jama Connect database and two additional database schemas for

the installation/upgrade to succeed.

For the upgrade to complete, organizations using Microsoft SQL Server must enter da-
tabase users in Replicated. Without these entries, the installation or upgrade will fail.

Organizations that do not create the new schema will successfully install/upgrade;
however, the system will continue to attempt to connect to the databases and produce
log failures. After you create the database schemas, you must restart Jama Connect.

For more information, go to Supported software, environments, and system require-
ments and select your version of Jama Connect.

Follow these steps for a first-time installation of Jama Connect.

1. Use a SQL management application (such as SQL Server Management Studio) to connect to the
SQL Server.

2. Replace the following values in the installation script: <JAMA_LOGIN_Psswd>, <SAML_LOG-
IN_Psswd> & <OAUTH_LOGIN_Psswd>.

NOTE
Copy and store the passwords you create here. You will need them later to config-
ure the Admin Console settings.

3. In a new query window, run the following SQL query code:

-- Fresh Install Preparation SCRIPT
/*
Jama Connect Preparation Commands for a fresh install. It is required to 
run
 these command / script on the Microsoft SQL Server BEFORE running the 
Jama 
Connect 8.62.x install
for ON-PREM installation using Microsoft SQL Server 2016 - 2019
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DATE: 05/10/2021
NOTES:
This script assumes this is a new Installation of JAMA Connect. DO NOT 
RUN 
THIS SCRIPT ON AN EXISTING JAMA INSTALLATION.
The script will create a new empty JAMA database, add 2 new schemas 
(empty) to 
the Jama Database, 2 new DB Logins and Database users to support the 
Multi-
Auth functionality released in Jama Connect 8.62.0.

INSTRUCTIONS:
This script must be run prior to Jama installation or installation may 
fail to 
complete.
Modify the <JamaUser_LOGIN_Psswd>, <SAML_LOGIN_Psswd> & 
<OAUTH_LOGIN_Psswd> 
values in the script below before Execution. 
Passwords must be enclosed in single quotes.
*/

USE master;
CREATE LOGIN jamauser with password = 'password';
CREATE LOGIN samluser with password = 'password';
CREATE LOGIN oauthuser with password = 'password';
GO

USE master;
CREATE DATABASE jama;
GO
ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK IMMEDIAT
E
GO

USE jama;
EXEC ('CREATE SCHEMA oauth');
EXEC ('CREATE SCHEMA saml');
GO

USE jama;
CREATE USER jamauser for LOGIN jamauser;
CREATE USER samluser for LOGIN samluser with DEFAULT_SCHEMA=saml;
CREATE USER oauthuser for LOGIN oauthuser with DEFAULT_SCHEMA=oauth;
GO

EXEC sp_addrolemember N'db_owner', jamauser;
EXEC sp_addrolemember N'db_owner', samluser;
EXEC sp_addrolemember N'db_owner', oauthuser;
GO

4. Confirm that these actions were successful:
1. Script completed — Check the Query Execution results for errors.
2. Users created — Run the following SQL script in a new query window.
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USE jama
SELECT * from master.sys.sql_logins
SELECT * from Jama.sys.sysusers

The results include jamauser, samluser, and oauthuser in the "Name" column of the result
panes.

3. Users granted the DB_owner role — Run the following SQL script in a new query window.

USE jama
SELECT DP1.name AS DatabaseRoleName,
isnull (DP2.name, 'No members') AS DatabaseUserName
FROM sys.database_role_members AS DRM
RIGHT OUTER JOIN sys.database_principals AS DP1
ON DRM.role_principal_id = DP1.principal_id
LEFT OUTER JOIN sys.database_principals AS DP2
ON DRM.member_principal_id = DP2.principal_id
WHERE DP1.type = 'R'
ORDER BY DP1.name;

The results will show that db_owner role is granted to jamauser, samluser, and oauthuser.
5. Run the following query to keep the database from locking users' accounts while they are logging

in or working in Jama Connect. You must have db_owner permissions.

ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH 
ROLLBACK IMMEDIATE;

6. Run this question to make sure the flag was successfully enabled:

SELECT is_read_committed_snapshot_on FROM sys.databases WHERE
name='jama';

If the returned value is 1, the flag is on.

Configure custom memory settings for Elasticsearch
To prepare for installing Jama Connect, you must first update the system that hosts Docker. The update
consists of configuring memory settings for Elasticsearch.

1. Open the /etc/sysctl.conf file, add the following line to the file, then save the file.

vm.max_map_count=262144

2. Reload the sysctl.conf file:

sysctl -p

3. To confirm, type this command:

sudo sysctl -a | grep max_map_count

The system responds with:

vm.max_map_count=262144

Installing software for the first time (internet)
If your organization is internet-enabled, follow these instructions to download, install, and configure the
software you need for your Jama Connect instance. The software includes Admin Console (Replica-
ted), Docker, and Jama Connect.

Jama Software sends a Welcome email that includes your Jama Connect license (.rli) file.

The installation process consists of these tasks:
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Prepare • Prepare application server and database server
• Install database
• Download Replicated and Docker
• Configure memory settings for Elasticsearch

Install • Install Admin Console (Replicated)
• Install Jama Connect

Set up • Add organization admin account
• Configure email/collaboration settings
• Configure authentication
• Configure backups

Downloading Replicated and Docker (internet)
You can download the Admin Console (Replicated) and Docker files to your desktop system, then move
and extract them to the /data/install directory on your application server.

Replicated

https://community.jamasoftware.com/blogs/kristina-king/2016/11/11/standard-channel-on-premises-re-
lease-notes

Click Notes for Administrators for your version of Jama Connect to get the correct cURL command to
install Replicated.

Docker

https://help.replicated.com/community/t/installing-docker-enterprise-edition-ee/58

If you are using Docker Enterprise Edition, you must:

• Follow the installation instructions in the Mirantis Container Runtime (MCR) Deployment Guide:
https://docs.mirantis.com/mcr/20.10/install.html

• Use a supported version of Docker: 1.10.3 – 19.03.8-ce

Install the Admin Console (internet)
The Admin Console (Replicated) is the interface used to install the Jama Connect application and Dock-
er. You can use the Replicated installation script to install the latest supported version of Docker and
Replicated. 

Important considerations

• During installation, the application server must have access to the internet, including the Replicated
listed domains.

• The Admin Console isn't compatible with Internet Explorer.
• If you receive a warning that Docker is using the devicemapper storage driver, cancel the installation

and configure Docker to use the overlay2 storage driver.
• The Release Notes might include the unique cURL command for your version of Jama Connect.
• The supported software page in the Community specifies which versions were used during regres-

sion testing of the version of Jama Connect you want to install.

To install the Admin Console:

1. Connect to the command shell of the application server using SSH.
2. As root user or a user with sudo bash privileges, download and install the Admin Console using

one of these methods:
• Use the cURL command from the Release Notes.
• Download and install a specific version of the Admin Console with this command:
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curl -sSL "https://get.jamasoftware.com/docker?
replicated_tag=<REPLICATED_VERSION>"| sudo bash -s no-auto

3. Replace <REPLICATED_VERSION> with the Replicated versions recommended in the Release
Notes for your version of Jama Connect. For example:

curl -sSL "https://get.jamasoftware.com/docker?replicated_tag=2.38.1" | 
sudo bash -s no-auto

If the cURL command displays the following message, the Admin Console must be installed man-
ually.

Either your platform is not easily detectable, is not 
supported by this installer script, or does not yet have 
a package for Replicated.Please visit the following URL 
for more detailed installation instructions:

https://www.replicated.com/docs/distributing-an-application/installing/

NOTE
The no-auto option is only used to make sure that questions during the installation
don't time out (default timeout setting is 20 seconds).

4. Follow the installation prompts, then you can leave the installation unattended.

IMPORTANT
The prompts are displayed for 20 seconds unless you chose the no-auto option. If
you skip the step to choose an IP address, the URL that you see at the end of this
step doesn’t work. You must run the cURL command again and select an IP ad-
dress.

Please choose one of the following network interfaces:

[0] eth0 10.0.2.15
[1] eth1 172.28.128.3
[2] docker0 172.17.0.1
Enter desired number (0-2):

• Enter the number (0–2) of the network used to access Jama Connect (your DNS entry also
routes to this network). The same network is used to access the Admin Console and the Jama
Connect application.

 Does this machine require a proxy to access the Internet?
 (y/N)

• If using a proxy, enter Y and input the proxy information. If your server is set up to use a proxy,
the user environment auto-detects that configuration and asks if you want the installer to config-
ure the proxy for you.

• When prompted for a service IP address, leave it blank and press Enter.
When the installation is complete, you see the following message:

==> default: To continue the installation,
visit the following URL in your browser:
https://<your_ip_address>:8800

5. Take note of the URL of the Admin Console; you will need it when you configure Replicated set-
tings.
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6. In the /data directory, create a custom Replicated snapshots folder and change the ownership to
the replicated user with the following command. Later you can configure the Admin Console to
store snapshots there. 

7. Change the ownership of the folder to the Replicated user with this command:

mkdir -p /data/replicated/{snapshots,statsd,support-bundle}
chown -R replicated /data/replicated

After changing ownership to Replicated with the command, the permissions look something like
this:

# ll /data/replicated/
total 20
drwxr-xr-x 5 replicated root 4096 Oct 21 21:27 ./
drwxrwxrwx 10 root root 4096 Nov 7 18:48 ../
drwxr-xr-x 5 replicated root 4096 Oct 21 21:29 snapshots/
drwxr-xr-x 6 replicated docker 4096 Oct 21 22:11 statsd/
drwxr-xr-x 2 replicated root 4096 Oct 21 21:27 support-bundle/

Later you can configure the Admin Console to store snapshots in the Replicated snapshots folder.

Install Jama Connect (internet)
The installation script walks you through the process of uploading the license file, installing Jama Con-
nect, and configuring the Admin Console. To start the process, you use the URL that was generated
when you installed Replicated.

The license file is attached to the Welcome email you received from Jama Software.

1. Open the Welcome email and download the attached license file to you local system.
2. In a supported browser, enter the URL for the Admin Console, which was generated when you in-

stalled Replicated.
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3. Enter your hostname.
4. Do one of the following, depending on whether you have a private key and certificate:

• Have key/certificate — Select Choose file under Private key and Certificate, navigate to the
files, then click Upload & Continue.

• No key/certificate — Click Self-Signed Cert.
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5. Click Choose license to upload your license file.

6. Enter and confirm a password for access to the Admin Console, then click Continue.
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The system performs the preflight checks.
7. When the preflight checks are complete, click Continue.

The Settings page for the Admin Console opens.
8. Configure the settings for each group, as needed. Scroll down to see each group of settings.

Database Settings — Use the information from Preparing your database server [429].
• MySQL

• Microsoft SQL Server
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TLS Key & Cert — (Optional) If you have the key and certificate, click Choose file to select them.
9. Scroll to the bottom of the page and click Save. You see a confirmation that your settings were

saved.
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10. Select Restart now.
The system restarts and opens the Admin Console.

11. Log in to Jama Connect as root [489].
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Your installation of Jama Connect is complete.

Installing software for the first time (airgap)
If your organization needs the extra security of an airgap installation, Jama Software provides access to
an airgap-safe portal.

Jama Software sends a Welcome email that includes:

• Special URL to the airgap-safe portal
• Password
• Your Jama Connect license (.rli) file

You must also download the software for Admin Console (Replicated) and Docker.

Once you have access to the airgap-safe portal, you can download the Jama Connect images, move
them to your server, and run the installation script to install the software.

An airgap installation consists of these tasks:

Prepare • Prepare application server and database server
• Install database
• Download Replicated and Docker
• Configure memory settings for Elasticsearch
• Retrieve Jama Connect images

Install • Install Admin Console (Replicated)
• Install Jama Connect

Set up • Add organization admin account
• Configure email/collaboration settings
• Configure authentication
• Configure backups

Retrieve Jama Connect images (airgap installation)
Before you can install the software in an airgap environment, the Jama Connect images must be down-
loaded to a desktop system, then transferred to the /data/install directory on your airgap application
server.
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TIP
Because the download might take a long time, we recommend doing this on a different
day than when you install the software.

To retrieve the images, you need the airgap-safe portal URL and password provided in the Welcome
email sent from Jama Software.

1. Open the Welcome email to access the airgap-safe portal URL and password.
2. In a supported browser, enter the URL and the password.
3. You see a list of available releases since your license was issued, along with a download link and a

checksum for each.
4. Find the version you want to install and select Get Download Link to generate a new temporary

download link.

5. Select Download to download the files directly to your desktop system.

6. Move the downloaded airgap files to your application server host in the following directory:

/data/install

Downloading Replicated and Docker (airgap)
You can download the Admin Console (Replicated) and Docker files to your desktop system, then move
and extract them to the /data/install directory on your application server.

Replicated

https://s3.amazonaws.com/replicated-airgap-work/stable/replicated-2.48.0%2B2.48.0%2B2.48.0.tar.gz

Docker
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https://help.replicated.com/community/t/installing-docker-in-airgapped-environments/81

If you are using Docker Enterprise Edition, you must:

• Follow the installation instructions in the Mirantis Container Runtime (MCR) Deployment
Guide: https://docs.mirantis.com/mcr/20.10/install.html

• Use a supported version of Docker: 1.10.3 – 19.03.8-ce

Install the Admin Console and Docker (airgap)
Once you have retrieved the Jama Connect images [443] and transferred them to the data/install direc-
tory of your airgap application server, install the Admin Console (Replicated) and Docker in the same
directory.

1. Make sure the Admin Console (Replicated) and Docker files have been transferred to the /data/
install directory on your application server and extracted there.

2. At the server’s command line, enter the following command:

tar -xzvf replicated.tar.gz

You see this output:

install.sh
operator_install.sh
replicated-operator.tar
replicated-ui.tar
replicated.tar

3. In the same directory, use this command to execute the application installation script, which identi-
fies the airgap installation file.

cat ./install.sh | sudo bash -s airgap

4. Complete these questions as the script runs:
• Network interface — Enter the number (0–2) of the network used to access Jama Connect. The

same network is used to access the Admin Console and the Jama Connect application.
• Proxy (Y/N) — Enter N (not needed for an airgap system).

5. Copy the URL to use when you install Jama Connect (airgap).

Install Jama Connect (airgap)
An installation wizard walks you through the process of uploading the license file, installing Jama Con-
nect, and configuring the Admin Console. To start the wizard, you use the URL that was generated
when you installed the Admin Console [445].

The license file is attached to the Welcome email you received from Jama Software.

1. Open the Welcome email and save the license file to the /data/install directory on your application
server.

2. In a supported browser, enter the URL for the Admin Console, which was generated when you in-
stalled Replicated.
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3. Enter your hostname.
4. Do one of the following, depending on whether you have a private key and certificate:

• Have key/certificate — Select Choose file under Private key and Certificate, navigate to the
files, then click Upload & Continue.

• No key/certificate — Click Use Self-Signed Cert.
5. Click Choose license to upload your license file.
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6. Select Airgapped for your installation type, then click Continue.

IMPORTANT
If you select Online as your installation type, an internet installation begins. The
only way to correct this is to uninstall Replicated, reinstall it, and start this task
again from the beginning.
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7. Upload your license using one of these methods:
• Enter /data/install (the path of directory where you saved the license file on your application

server), then click Continue.
• Click Upload Airgap Bundle.
The system installs the airgap package, then performs the preflight checks.
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8. When the preflight checks are complete, click Continue.
The Settings page for the Admin Console opens.
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9. Configure the settings for each group, as needed. Scroll down to see each group of settings.
• Database Settings — Use the information from Preparing your database server [429].
• TLS Key & Cert — (Optional) If you have the key and certificate, click Choose file to select

them.
• Airgapped Settings — (Optional) Enter a new path for airgap update packages and for the li-

cense file.
10. Scroll to the bottom of the page and click Save.

You see a confirmation that your settings were saved.

11. Select Restart now.
The system restarts and opens the Admin Console.
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12. Log in to Jama Connect as root [489].

Your installation of Jama Connect is complete.

After installing Jama Connect
Whether your environment is internet-enabled or airgap, after you install Jama Connect you can contin-
ue to set up your Jama Connect environment.

Follow any post installation instructions that apply to your organization.

The setup tasks to configure your environment include:
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• Add Organization Admin account [491]
• Modify organization details [493]
• Configure proxy settings (optional) [463]
• Configure email/collaboration settings [495]
• Configure user authentication [466]
• Create XML backups (optional) [518]

If you have further questions about Jama Connect installation and setup, visit the Jama Support Com-
munity or contact support.

Upgrading your software
Whether your organization is internet-enabled or airgap, follow these instructions to download and in-
stall the upgrade software you need for your Jama Connect instance.

If your organization needs the extra security of an airgap installation, Jama Software provides access to
an airgap-safe portal to retrieve your Jama Connect images.

You might need to upgrade only the Jama Connect application. Or you might need to upgrade Jama
Connect and the Admin Console (Replicated) at the same time.

Before upgrading, be aware of the supported software for your current installation and the produc-
tion system requirements [425].

IMPORTANT
Before installing or upgrading to Jama Connect 8.62.x, you must:

• Create two additional database schemas [454] for the installation/upgrade to suc-
ceed.

• Be running a version of Jama Connect (8.62.x or earlier) that uses Microsoft SQL
2016-2019 for the database server.

For more information, go to Supported software, environments, and system require-
ments and select your version of Jama Connect.

Important considerations

• Always perform the upgrade in a test environment before upgrading your production environment.
• Jama Connect versions 8.0 and later don’t work in a Windows Server environment or with an Oracle

database. For details, see Application server requirements [425].
• If you're on a version of Jama Connect earlier than 8.36.0, you must perform a step upgrade. First

upgrade to version 8.36.0, then upgrade to version 8.49.0. You can’t skip the step upgrades.
See Incremental Step Upgrade for Jama 8.x and Beyond for details.

Things to do before upgrading

• Upgrade and configure Microsoft SQL Server [454].
• Create a backup of Jama Connect [518].
• Create a Replicated snapshot [471].
• Make sure you have enough disk space for the upgrade:

• Remove old Docker images [529].
• Remove or move old Replicated snapshots.
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• Determine your version of Replicated.
• Airgap only: Retrieve the Jama Connect images.

Upgrade and Configure MySQL
MySQL is the recommended database server. Follow these steps to upgrade and configure it.

If you want to install MySQL for the first time, see Install and configure MySQL [430].

IMPORTANT
Before upgrading Jama Connect 8.62.x, you must create two additional database
schemas for the installation/upgrade to succeed. To create the database schemas, run
these SQL commands on the MySQL database server:

CREATE DATABASE saml;
CREATE DATABASE oauth;
CREATE USER 'oauthuser'@'%' IDENTIFIED BY 'password';
CREATE USER 'samluser'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON oauth.* TO ‘oauthuser’@‘%’;
GRANT ALL PRIVILEGES ON saml.* TO ‘samluser’@‘%’;

1. Make sure that the InnoDB engine is enabled.
2. Download and install a supported version of MySQL. To find out which version of MySQL you need,

see Supported software, environments, and system requirements and click the link for your version
of Jama Connect.

3. Create an empty Jama Connect schema / database that uses UTF8.

create database jama character set utf8;

4. Use the following commands to create a user called "jamauser" with the ability to access, create,
and update tables within the database.

CREATE USER 'jamauser'@'%' IDENTIFIED BY 'password'; 
GRANT ALL PRIVILEGES ON jama.* TO 'jamauser'@'%'.

5. Restart the database server.
The following recommended settings require 8 GB of memory allocated to MySQL Server for a typi-
cal installation and 16 GB for an enterprise installation.
Depending on your database server's operating system, this can be added to your my.cnf file (Li-
nux) or my.ini file (Windows). You can also make these changes directly to the database.

Property Typical Installation Enterprise Installaton

max_allowed_packet 1 GB 1 GB

query_cache_type 1 1

query_cache_size 256 MB 256 MB

tmp_table_size 2 GB 2 GB

max_heap_table_size 2 GB 2 GB

table_open_cache 512 512

innodb_buffer_pool_size 2 GB 12 GB

innodb_log_file_size 256 MB 256 MB

innodb_log_buffer_size 12 MB 12 MB

innodb_thread_concurrency 16 16

max_connections 151 351
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Property Typical Installation Enterprise Installaton

wait_timeout 259200 259200

Here is a sample text config file at an enterprise level. You must add the following values for your
environment:

ignore_builtin_innodb
bind-address=0.0.0.0
key_buffer_size=16M
max_allowed_packet=1G
thread_stack=192K
thread_cache_size=8
myisam-recover-options=BACKUP
query_cache_type=1
query_cache_size=256M
tmp_table_size=2G
max_heap_table_size=2G
table_open_cache=512
innodb_buffer_pool_size=12G
innodb_log_file_size=256M
innodb_log_buffer_size=12M
innodb_thread_concurrency=16
max_connections=351wait_timeout=259200

Upgrade and configure Microsoft SQL Server
If you are using Microsoft SQL Server for your database, follow these steps to upgrade and configure it.

You must have full database admin permissions to the SQL Server.

If you want to install the Microsoft SQL server for the first time, see Install and configure Microsoft SQL
Server [432].

IMPORTANT
Before installing or upgrading to Jama Connect 8.62.x, you must:

• Be running a version of Jama Connect that's earlier than 8.62.x and using Microsoft
SQL 2016-2019 for the database server.

• Create two additional database schemas for the installation/upgrade to succeed.

For the upgrade to complete, organizations using Microsoft SQL Server must enter da-
tabase users in Replicated. Without these entries, the installation or upgrade will fail.

Organizations that do not create the new schema will successfully install/upgrade;
however, the system will continue to attempt to connect to the databases and produce
log failures. After you create the database schemas, you must restart Jama Connect.

For more information, go to Supported software, environments, and system require-
ments and select your version of Jama Connect.

1. Use a SQL management application (such as SQL Server Management Studio) to connect to the
SQL Server.
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2. Replace the following values in the installation script: <SAML_LOGIN_Psswd> & <OAUTH_LOG-
IN_Psswd>.

NOTE
Copy and store the passwords you create here. You will need them later to config-
ure the Admin Console settings.

3. In a new query window, run the following SQL query code:

-- UPGRADE SCRIPT
/*
Jama Connect Upgrade Commands. Required to run these on the 
Microsoft SQL Server BEFORE running the Jama Connect 8.62.x Upgrade 
for ON-PREM installation using Microsoft SQL Server
DATE: 05/10/2021
NOTES: This script assumes it is running against a pre-existing 
installation 
with the JAMA Database already present on the Server.
The Script will add 2 new schemas (empty) to the Jama Database, 2 
new DB Logins and Database users to support the Multi-Auth 
functionality released in Jama Connect 8.6.2.
This script must be run prior to actual Jama Upgrade or the upgrade
installation may fail to complete.
INSTRUCTIONS: Ensure a Full backup of the Jama database is made before 
execution.
Modify the <SAML_LOGIN_Password> & <OAUTH_LOGIN_Password> values in the 
script below before Execution. Passwords must be enclosed in single 
quotes.

USE master;
CREATE LOGIN samluser with password = 'password';
CREATE LOGIN oauthuser with password = 'password';
GO

USE jama;
EXEC ('CREATE SCHEMA oauth');
EXEC ('CREATE SCHEMA saml');
GO

USE jama;
CREATE USER samluser for LOGIN samluser with DEFAULT_SCHEMA=saml;
CREATE USER oauthuser for LOGIN oauthuser with DEFAULT_SCHEMA=oauth;
GO

EXEC sp_addrolemember N'db_owner', samluser;
EXEC sp_addrolemember N'db_owner', oauthuser;
GO

4. Confirm that these actions were successful:
a. Script completed — Check the Query Execution results for errors.
b. Users created — Run the following SQL script in a new query window.

USE jama
SELECT * from master.sys.sql_logins
SELECT * from Jama.sys.sysusers
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The results include samluser and oauthuser in the "Name" column of the result panes.
c. Users granted the DB_owner role — Run the following SQL script in a new query window.

SELECT DP1.name AS DatabaseRoleName,
isnull (DP2.name, 'No members') AS DatabaseUserName
FROM sys.database_role_members AS DRM
RIGHT OUTER JOIN sys.database_principals AS DP1
ON DRM.role_principal_id = DP1.principal_id
LEFT OUTER JOIN sys.database_principals AS DP2
ON DRM.member_principal_id = DP2.principal_id
WHERE DP1.type = 'R'
ORDER BY DP1.name; 

The results will show that db_owner is granted to oauthuser and samluser.
5. Run the following query to keep the database from locking users' accounts while they are logging in

or working in Jama Connect. You must have db_owner permissions.

ALTER DATABASE jama SET READ_COMMITTED_SNAPSHOT ON WITH ROLLBACK 
IMMEDIATE;

6. Run this question to make sure the flag was successfully enabled:

SELECT is_read_committed_snapshot_on FROM sys.databases WHERE 
name='jama';

If the returned value is 1, the flag is on.

Determine your version of Replicated
To be able to upgrade the Admin Console to the latest version, you must be running Replicated 2.x.

1. In the Admin Console, click the Cluster link.

The first entry on the Cluster page lists your version of the Admin Console (Replicated).
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2. To upgrade your version of the Admin Console (Replicated):
• Version 2.x

• Upgrade the Admin Console (internet) [457]
• Upgrade the Admin Console (airgap) [457]

Upgrade the Admin Console (internet)
The Admin Console (Replicated) can be updated whenever a new version is available. When upgrading
both Replicated and Jama Connect, upgrade Replicated first.

These steps upgrade Replicated in an internet-enabled environment. If Docker is out of date, it is also
updated.

1. In the Admin Console, select Dashboard to view whether a new version is available.
2. Check the supported software page to find the correct version of Replicated to use for your installa-

tion of Jama Connect.
3. As root user or a user with sudo bash privileges, download and install the Admin Console using

one of these methods:
• Use the cURL command from the Release Notes.
• Download and install a specific version of the Admin Console with this command:

curl -sSL "https://get.jamasoftware.com/docker?
replicated_tag=<REPLICATED_VERSION>" | sudo bash -s no-auto

Replace <REPLICATED_VERSION> with the Replicated versions recommended in the Release
Notes for your version of Jama Connect. For example:

curl -sSL "https://get.jamasoftware.com/docker?replicated_tag=2.38.1" 
| sudo bash -s no-auto |

4. Follow the installation prompts, then you can leave the installation unattended.
5. Once the process is finished, go to the Admin Console and confirm that Replicated was upgraded

to the correct version.

Upgrade the Admin Console (airgap)
The Admin Console (Replicated) can be updated whenever a new version is available. To do so for an
airgap installation, you first download the files to an internet-enabled system, then move and extract
them to the /data/install directory on your airgap application server.

When upgrading both Replicated and Jama Connect, upgrade Replicated first.

These steps upgrade Replicated in an airgap environment. If Docker is out of date, it is also updated.

1. Use this URL to download the Replicated files to an internet-enabled system.
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https://s3.amazonaws.com/replicated-airgap-work/stable/replica-
ted-2.48.0%2B2.48.0%2B2.48.0.tar.gz

2. Transfer the Replicated files to the same location on your airgap application server as your original
airgap installation files.

3. Execute the following command in the same directory where the airgap installation files were origi-
nally installed.

tar -xzvf replicated-A.BC.D+A.BC.D+A.BC.D.tar.gz --overwrite

To find the original file, look in the Admin Console:
Gear icon > Console settings > Airgap settings
Note the update path.  The filename looks like this, where A.BC.D is the version ID:
"replicated-A.BC.D+A.BC.D+A.BC.D.tar.gz"

4. Run the installation script in the same directory where the files were extracted. You must have sys-
tem administration permissions to do this. 

cat ./install.sh | sudo bash -s airgap

5. Follow the installation prompts, then you can leave the installation unattended.
6. Once the process is finished, go to the Admin Console and confirm that Replicated was upgraded

to the correct version.

Retrieve Jama Connect images (airgap upgrade)
Before you can upgrade the software in an airgap environment, the Jama Connect images must be
downloaded to a desktop system, then transferred to the /data/install directory on your airgap applica-
tion server.

TIP
Because the download might take a long time, we recommend doing this on a different
day than when you upgrade the software.

To retrieve the images, you need the airgap-safe portal URL and password provided in the original Wel-
come email sent from Jama Software.

1. In a supported browser, enter the URL and the password for the airgap-safe portal.
You see a list of available releases since your license was issued, along with a download link and a
checksum for each.

2. Find the version you want to install and select Get Download Link to generate a new temporary
download link.

3. Select Download to copy the files directly to your desktop system.
4. Log in to the application host via SSH and move the downloaded files to the /data/install directory.
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Upgrade Jama Connect
Whether your environment is internet-enabled or airgap, you can upgrade an existing installation of Ja-
ma Connect to a newer version using the Admin Console.

An installation script walks you through the process of upgrading Jama Connect. To start the wizard,
you use the URL that was generated when you installed or upgraded the Admin Console (Replicated).

Important considerations

• If you are upgrading both the Admin Console (Replicated) and Jama Connect, upgrade the Admin
Console first.

• If you're on a version of Jama Connect earlier than 8.36.0, you must perform a step upgrade. First
upgrade to version 8.36.0, then upgrade to version 8.49.0. You can’t skip the step upgrades. See
Incremental Step Upgrade for Jama 8.x and Beyond for details.

• Airgap only: Before you can upgrade the application in an airgap environment, you must first retrieve
Jama Connect images [458] and transfer them to your application server.

To upgrade Jama Connect:

1. Use a browser to navigate to Admin Console > Dashboard and make sure that the Admin Con-
sole is up to date.

2. Depending on whether an update is available, select the following:
• If an update was already discovered, the dashboard reads "There is an update available." Select

View update.
• If no update was already discovered, the dashboard reads: "Jama is up to date." Select

Check now.

If an update is then discovered, the dashboard reads "Update Available." Select View update.
3. Review the proposed update or updates and select Install Update.
4. Go to the dashboard, which displays the progress of the upgrade.

• Updating — The Jama Connect components are downloaded from our private and secure regis-
try on the Internet.

• Starting... Queued — The components are started and initialized, as well as the database is up-
dated.

5. When the dashboard reads “Started,” the update is complete. Select the Open link under Started to
open Jama Connect in a new browser window.
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6. Log in to Jama Connect [489].
7. Rebuild the search index [531].

Upgrade from a version prior to 8.0
If you are upgrading from a version of Jama Connect prior to 8.0 (for example, 2015.5), the upgrade
process is different from previous upgrades because the deployment model has changed.

CAUTION
Perform the upgrade in a test environment before upgrading your production environ-
ment.

Prerequisites

1. Configure a supported environment with proper application server preparation [427].
2. Choose your upgrade channel.
3. Locate your production and staging environment licenses.
4. Make sure that your current version of Jama Connect doesn't have a build date older than

2015/11/20. If you are running an older version of Jama Connect, the upgrade won't be able suc-
cessful.
Note: Our recommended upgrade path is 3.x > 4.x > 4.2.x > 2014.x > 2015.x > 2015.5 > 8.66

Upgrade
Depending on your current environment setup, the steps in the upgrade process to 8.66 vary. Before
upgrading, review the Supported Software for your channel and the Production System Requirements
[425]. Jama Connect 8.0 and earlier won't work in a Windows Server environment or with an Oracle
database.
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Migrating from Oracle
If you are upgrading from a version of Jama Connect using Oracle, you must migrate to a supported
database before upgrading to 8.66. See Migrating Databases [535] for more information on the process.

Migrating from Windows
If you are upgrading a version of Jama Connect running on Windows, you must migrate to a supported
Linux operating system [425]. Once the Linux environment is properly configured, move on to Migrat-
ing to 8.66.

Migrating to 8.66
Since this is your first time upgrading to Jama Connect version 8.66, this process will consist of a migra-
tion.

Migrating on the same server
If Jama Connect is running a supported OS, you can stage the new installation on the same server.
However, your environment must meet these requirements:

1. Your previous version of Jama Connect must not be running at the time of installation.
2. No other applications can run on the server.
3. Once you have completed the migration, you must remove your previous Jama Connect installa-

tion.

Migration process

1. Migrate existing data [534] from [contour_home] on your current Jama Connect server to /data/
contour/ on the Jama 8.66 server.

2. If you are migrating your database, see Migrating database server [535].
3. Follow the installation instructions [423].

Follow the installation instructions for airgap [443].
4. Verify that the installation was successful.
5. Remove any previous installations of Jama Connect from the server.

Once Jama Connect is successfully installed, upgrading [452] to future releases is done from the Admin
Console.

Appendix
• Troubleshooting your installation [461]
• Sample airgap installation script [462] 
• Configure proxy settings [463]
• Uninstall Jama Connect [463]

Troubleshooting your installation
If any errors occurred during installation, use this table to fix the issues.

Error message Solution

This webpage is not
available

Verify that the "Host Name" section of the settings was correctly entered to point to the application
server.

Not private or Not se-
cure

This might happen if you chose a self-signed certificate or uploaded an invalid certificate. Verify that
you correctly entered the Custom TLS configuration in the Host Name window.

If this happens only for other users and not the system administrator, and the Admin Console is using
a self-signed certificate, you might have already told your web browser to "Proceed ... (unsafe)" or
"Add exception," while other users haven't. Verify that you selected the setting you want for Reuse
admin console TLS configuration in the Host Name window.
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Error message Solution

Problem: Cannot create
database jama: Con-
nections could not be
acquired from the un-
derlying database!

Most likely, something is wrong with your Admin Console database settings (for example, bind-ad-
dress, DBO credentials), or the connection between the application server and the database server.
Double-check your database settings in the Admin Console.

Sample airgap installation script
A full airgap installation script looks like this example script.

tar -xzvf replicated.tar.gz$ cat ./install.sh | sudo bash -s airgapThe 
installer was unable to automatically detect the private IP address of this 
machine.Please choose one of the following network interfaces:[0] eth0 
10.0.2.15[1] eth1 172.28.128.3[2] docker0 172.17.0.1Enter desired number 
(0-2): 1The installer will use network interface 'eth1' (with IP address 
'172.28.128.3').Does this machine require a proxy to access the Internet? 
(y/N) nWARNING: No swap limit supportLoading replicated and replicated-ui 
images from package2314ad3eeb90: Loading layer 
[==================================================>] 5.037 MB/5.037 
MB20cf0ca78550: Loading layer 
[==================================================>] 1.395 MB/1.395 
MB79da1e49a9ec: Loading layer 
[==================================================>] 39.57 MB/39.57 
MB10127b12860b: Loading layer 
[==================================================>] 2.56 kB/
2.56kB54c848181027: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBf8559cfb1d7e: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBd07f68c6454a: Loading layer 
[==================================================>] 3.072 kB/3.072 
kBe7ebe443cebe: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBe26ab0a00993: Loading layer 
[==================================================>] 1.024 kB/1.024 
kB2314ad3eeb90: Loading layer 
[==================================================>] 5.037 MB/5.037 
MB20cf0ca78550: Loading layer 
[==================================================>] 1.395 MB/1.395 
MB90dd48adb644: Loading layer 
[==================================================>] 2.56 kB/
2.56kBbcfb6537f172: Loading layer 
[==================================================>] 40 .86 MB/40.86 
MB9f84694e322f: Loading layer 
[==================================================>] 11.78 kB/11.78 
kBd88f3b6fbcb2: Loading layer 
[==================================================>] 11.73 MB/11.73 
MBab1f2e0fdc51: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBe0dd0d7697b0: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBc58a11ad5860: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBStopping replicated and replicated-ui serviceInstalling replicated and 
replicated-ui serviceStarting replicated and replicated-ui 
servicereplicated start/running, process 21870replicated-ui start/running, 
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process 21879Installing replicated command aliasInstalling local 
operatorLoading replicated-operator image from package2314ad3eeb90: Loading 
layer [==================================================>] 5.037 MB/5.0
37 MB20cf0ca78550: Loading layer 
[==================================================>] 1.395 MB/1.395 
MB94be066a32a4: Loading layer 
[==================================================>] 12.04 MB/12.04 
MB10f95420dba3: Loading layer 
[==================================================>] 1.024 kB/1.024 
kBStopping replicated-operator serviceInstalling replicated-operator 
serviceStarting replicated-operator servicereplicated-operator start/
running, process 22155Operator installation successfulTo continue the 
installation, visit the following URL in your browser:https://
<this_server_address>:8800To create an alias for the replicated cli command 
run the following in your current shell or log out and log back 
in:source /etc/replicated.alias

Configure proxy settings
If using a proxy server, you must add the Jama Connect application server's IP to the no_proxy Docker
variable to prevent traffic from the application server from being proxied. Work with your Linux system
administrator to set this value.

The steps to do this depend on your operating system.

NOTE
The steps related to Replicated are only necessary if you have already installed the
Admin Console.

1. Stop Replicated with the following commands:
• For Red Hat-derived systems version 7 and later:

sudo systemctl stop replicated replicated-ui replicated-operator

• For all other distributions:

sudo service replicated-operator stop
sudo service replicated-ui stop
sudo service replicated stop

2. Follow the instructions from Docker on configuring the no_proxy settings, setting the appropriate
IPs and hostnames that identify the Jama Connect server.

3. Restart Replicated with the following commands:
• For Red Hat-derived systems version 7 and greater

sudo systemctl start replicated replicated-ui replicated-operator

• For all other distributions

sudo service replicated start
sudo service replicated-ui start
sudo service replicated-operator start

Uninstall Jama Connect
If for any reason you need to uninstall your instance of Jama Connect, follow this procedure.
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IMPORTANT
Uninstalling removes the Admin Console, the installed components that make up Jama
Connect, the default snapshot directory, /var/lib/replicated/snapshots, snapshots (if
they were left in the default directory), and your license. It doesn’t remove user data or
log files.

1. Stop the Jama Connect application [521].
2. Connect to the shell of the application server using SSH.
3. Make sure any snapshots that you need are in a safe location.
4. Execute the following commands for your flavor of Linux.

• Debian and Ubuntu

service replicated stop
service replicated-ui stop
service replicated-operator stop
docker stop replicated-premkit
docker stop replicated-statsd
docker rm -f replicated replicated-ui replicated-operator replicated-
premkit replicated-statsd
docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs 
sudo docker rmi -f
apt-get remove -y replicated replicated-ui replicated-operator
apt-get purge -y replicated replicated-ui replicated-operator
rm -rf /var/lib/replicated* /etc/replicated* /etc/init/
replicated* /etc/init.d/replicated* /etc/default/replicated* /var/log/
upstart/replicated* /etc/systemd/system/replicated*

NOTE
You might see an error while running the apt-get commands regarding pack-
ages not being located. These errors won't cause issues with the commands.

While running the apt-get commands, if you see an error about packages not lo-
cated, you can ignore it.

• RHEL, CentOS and Fedora

systemctl stop replicated replicated-ui replicated-operator
service replicated stop
service replicated-ui stop
service replicated-operator stop
docker stop replicated-premkit
docker stop replicated-statsd
docker rm -f replicated replicated-ui replicated-operator replicated-
premkit replicated-statsd
docker images | grep "quay\.io/replicated" | awk '{print $3}' | xargs 
sudo docker rmi -f
yum remove -y replicated replicated-ui replicated-operator
rm -rf /var/lib/replicated* /etc/replicated* /etc/init/
replicated* /etc/default/replicated* /etc/systemd/system/
replicated* /etc/sysconfig/replicated* /etc/systemd/system/multi-
user.target.wants/replicated* /run/replicated*
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When the final command completes, Jama Connect is uninstalled.

IMPORTANT
Uninstalling removes the Admin Console, the installed components that make up Jama
Connect, snapshots (if they were left in the default /var/lib/replicated/snapshots directo-
ry), and your license. It doesn't remove user data or log files [531].
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Administration

Jama Connect administrators have special roles in working with your organization's content.

A role is a set of permissions granted to a user so that they can perform particular functions.

• System administrators [468] set up and install Jama Connect. They are able to access the server set-
tings and log in as the root user. Jama Connect manages system administration for hosted custom-
ers. For self-hosted customers, this role holds the initial license and can't be assigned.

• Organization administrators [541] have the highest level of permissions in Jama Connect and can
configure settings for the organization. All Jama Software customers have at least one organization
administrator, and there might be multiple within a single organization. They must have a creator li-
cense.

• Project administrators [624] have the necessary permissions to manage many aspects of a project
that those with create/edit permissions can't. They must have a creator license.

• Review administrators [178] have the necessary permissions to manage reviews. They must have a
creator or reviewer license.

• Reuse administrators [282] have the necessary permissions to create advanced reuse and synchroni-
zation rules. They must have a creator license.

• Process administrators [580] have the necessary permissions to configure content and connections in
Jama Connect. They must have a creator license.

• User administrators [559] have the necessary permissions to manage licenses, users, and groups.
They must have a creator license.

• Risk administrators [376] have full permissions to create and edit risk templates and can manage par-
ticipants for any analysis.

Authentication methods
Jama Connect supports a wide range of authentication methods to keep your data safe and secure by
authenticating users. The default method, Basic authentication, verifies users with the login data that is
stored in the Jama Connect database. However, different integrations are available for cloud or self-
hosted environments.
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Supported combinations for self-hosted and cloud

• SAML for SSO and OAuth for REST
• Multi-mode for user authentication and OAuth for REST

For information about using the Jama Connect REST API with OAuth, see Set API credentials [39].

Supported third-party authentication methods

• SAML [499] — Cloud and self-hosted option. Open standard for transferring identity data between
two parties: an identity provider (IdP) and a service provider (SP).
Electronic signatures are enabled by default, but can be disabled by a system administrator.
To set up SAML, your company must meet these requirements:
• Have a SAML 2.0-compliant Identity Provider (IdP).
• Identify a technical person, often an IT administrator, who can provide the URL of the Identity Pro-

vider. Name this person before engaging with Jama Software and, for testing purposes, provide
them access to Jama Connect.

• Cloud customers — You must contact support to schedule enablement.
• Self-hosted customers — If you're on a version of Jama Connect earlier than 8.62, you must follow

instructions for that release instead of the instructions here. Contact support for help accessing the
correct instructions and with the process.

• LDAP [504] — Self-hosted option. Centralizes the management of user accounts. Jama Connect in-
cludes a built-in integration of LDAP and Microsoft Active Directory.

• Crowd [509] — Self-hosted option from Atlassian. Manages users and groups within a single a sys-
tem. Jama Connect accepts user details from Crowd, then syncs them with authentication data in the
application.

Internal authentication methods

• Basic [498] — The default authentication for Jama Connect. Basic authentication uses a username
and password that’s stored in the Jama Connect application database.

• Basic + IdP [501] — The combination of Basic and SAML creates multi-mode authentication, so
you can separate your internal users from your external partners, vendors, and contractors. Multi-
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mode authentication provides access for external users so they can be part of the requirement, ap-
proval, and tracking process in Jama Connect.

NOTE
To use multi-mode authentication [501], you must be running Jama Connect 8.62 or
later.

As a self-hosted user, you can update or change the authentication type for an organization. To do this,
log in as root user and select System Properties > Authentication Properties.

REST API
Jama Software REST API is an application program interface to assist developers in a clean, straight-
forward integration with the application.

A system administrator can enable REST API in system properties [495].

Get more information about REST API, features and documentation.

Supported image extensions and attachment types
Jama Connect only allows attaching file types that exist in the Allow List, which provides improved se-
curity and prevents uploading harmful file types that aren’t blocked.

To prevent uploading file types that might be harmful, Jama Connect filters the file types that you can
upload as an attachment.

Uses this method to filter attachment types... Supported version

Allow List Cloud, Jama Connect 2015.2 and later

Block List Jama Connect 2015.1 and earlier

Jama Connect allows these attachment types. We collected this list based on the usage pattern of our
current customers. Each type has been screened for potential security risks.

APK, AVI, BMP, CSV, DOC, DOCM, DOCX, DOT, DOTX, DWG, GIF, GZ, JAMA, JPEG, JPG, MD,
MOV, MP3, MP4, MPEG, ODG, ODP, ODS, ODT, PAGES, PDF, PGP, PNG, PPT, PTM, PPTX, RAR,
RTF, TGZ, TIF, TIFF, TRA, TXT, VCS, VSD, VSDX, VSS, WAR, WAV, WMA, WMV, WPS, XCF, XLS,
XLSB, XLSM, XLSX, XLT, XPS, ZIP, ZIPX

System administrator (self-hosted only)

NOTE
This information applies to self-hosted environments only.

System administrators are in charge of the following tasks. 

• Logging in to the application server operating system and Jama Connect as root user
• Installing, updating, and maintaining the Jama Connect platform
• Setting up the database and application servers
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• Installing the admin console and Jama Connect
• Configure settings such as authentication and mail servers
• Regular maintenance such as updates and uploading custom reports

Ideally a system administrator has expertise in these areas of administration:

• Database
System administrators set up and administer the database including database sizing, resource alloca-
tion, recommended backups, and availability of the database engine.

• Linux
Jama Connect must be installed on a Linux based system. System administrators need to use Com-
mand Line Interface (CLI) for basic navigation, file manipulation, permissions, and network configura-
tion when they are installing, upgrading, allocating resources, and maintaining availability and securi-
ty of the server. 

• Directory server
If you're not using Jama Connect native authentication, system administrators must perform setup
and administration or your organization's supported directory server [498].

• Mail server
If you're using these functions in Jama Connect, system administrators perform setup and administra-
tion of your organization's mail server.

System administration are necessary for customers who are self-hosting Jama Connect. For cloud cus-
tomers, Jama Software manages system administration. If you're interested in an implementation that
doesn't require system administration at your organization, contact your sales representative regarding
our cloud solution.

Configuring the Admin Console settings

NOTE
This information applies to self-hosted environments only.

Jama Connect uses Replicated technology to deliver all microservices to self-hosted customers. Repli-
cated software is a container orchestration tool that provides the interface, Admin Console, for Jama
Connect.

Replicated and Jama Connect are hosted on the same application server, running on different ports.

The Admin Console stores settings, such as SSL certificates and database connection information, that
Jama Connect uses to start and run correctly. Some of its functions include:

• Manage the run state of Jama Connect
• Perform upgrades
• Synchronize license renewals

Many of the settings for the Admin Console are configured during installation. However, you can make
changes to the settings whenever you need.

Application server overview

Your application server hosts the Jama Connect application, Docker containers, and the Admin Console
(Replicated software). It also stores data such as attachments, images, reports, and a micro-service
cache.
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Docker containers — A standalone executable package of software that includes code, runtime, sys-
tem tools, system libraries, and settings. See https://www.docker.com/resources/what-container for de-
tails.

Replicated — A container-based platform for easily deploying cloud native applications inside custom-
ers' environments to provide greater security and control. The Admin Console is the user interface for
installing the Jama Connect application. See https://www.replicated.com/ for details.

• Jama Connect users access Jama Connect by browsing to the instance URL (https://jamainstan-
ceurl.customer.com/).

• System administrators access the Admin Console by browsing to the same instance URL, but on port
8800 (https://jamainstanceurl.customer.com:8800/).

• Replicated updates Jama Connect and the license via API calls for internet-enabled environments.
Our airgap option removes the need for remote API calls.

• Any content added to your Jama Connect instance is stored in the database. Uploaded artifacts are
stored in the file system in the /data directory.

Restart the Admin Console
Occasionally, you might need to restart the Admin Console. For example, when you need to sync a new
license.

The commands to restart the Admin Console depend on the flavor of Linux you're using.

1. To restart the Admin Console on Debian or Ubuntu systems, execute these commands:

sudo service replicated restart
sudo service replicated-ui restart
sudo service replicated-operator restart

2. To restart the Admin Console on CentOS, RHEL, or Fedora systems, execute these commands:

sudo systemctl restart replicated replicated-ui replicated-operator

Once restarted, the Admin Console displays the login page.
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Create a Replicated snapshot
A Replicated snapshot is a backup of the Admin Console environment. It includes the Replicated data-
base, registry images, and container volumes (when specified).

A Replicated snapshot can be taken while Jama Connect is running without interruption.

IMPORTANT
Replicated snapshots don't include the contents of the Jama Connect database, the
contents of the /data directory, or the log files. To back up those items, see Back up
to .jama or XML file [518].

When to create a snapshot

• When migrating Jama Connect to new hardware [534]. When you replace one server with another
(create a clone), you can perform a fresh installation of Docker and Replicated, then restore from the
snapshot.

• During disaster recovery.
• Before upgrading your software (Jama Connect or Replicated).

Snapshot location

By default, Replicated snapshots are stored in this location:

/var/lib/replicated/snapshots

To include the Replicated snapshots in your regular backups of Jama Connect, you can change the lo-
cation for the snapshots, like this:
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/data/replicated/snapshots

To create a Replicated snapshot:

1. (Optional) Identify and configure a custom directory for your snapshots: Select Admin Console >
Settings (gear icon) > Console Settings > Snapshots.

2. Create a snapshot: Open the Admin Console and select Start Snapshot.

Snapshots Enabled changes to Snapshotting and a progress spinner appears while it backs up
the registry data and container volumes. When the snapshot is ready, you see a timestamp for the
last snapshot.
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If the Replicated snapshot fails, the dashboard displays an error message with technical detail of the
failure, including the file or folder involved. This error message is generated from the underlying file sys-
tem (for example, readdirent: errno 523), which means the problem is likely with the underlying file sys-
tem and not the Jama Connect installation.

Restore all settings from a Replicated snapshot
When you set up a new application server for Jama Connect, you can restore the Admin Console set-
tings that you saved in a Replicated snapshot.

Snapshots include the Replicated database, registry images, and container volumes (when specified).

1. Install Jama Connect on the new server.
2. When the page Upload your license is displayed, select Restore from a snapshot.
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3. When the Restore from snapshot page is displayed, enter the path to your snapshot and click Re-
store.
Use the same path on the new server as you did on the old server. For example, /var/lib/replica-
ted/snapshots or /data/snapshots.

4. On the Restore Cluster page, click Restore.
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The system displays a progress page as it restores your data from the snapshot.
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Configure database settings
Database settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Database Settings section of the page.

3. Select the type of database you're using, MySQL [430] or Microsoft SQL [432], then complete or
change the database settings as needed.

4. (Optional) If you need to connect to your database through an SSL-encrypted connection, provide
additional connection string parameters. These parameters specify key/value pairs in the format
appropriate to your database.
• MySQL

useSSL=true&requireSSL=tru

• SQL Server

ssl=require;appName=jama;bufferMinPackets

More options are available for MySQL and SQL Server
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5. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
6. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Configure web server settings
Web server settings can be configured as part of your initial installation of Jama Connect or any time
you need to make changes.

The web server configuration allows the use of SSL (TLS) or plain text connections.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Web Server section of the page.
3. Enter the context path for Jama Connect, for example, https://<hostname>. Don't use this configura-

tion unless you need to specify a sub-path or sub-directory.
4. (Optional) Select Check context path syntax.
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5. (Optional) Set the TLS and plain text port as needed.
6. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
7. To apply settings, you must restart the application:

• Immediately — select Restart now.
• Later — Select Cancel and Restart later.

Configure host name
Your Host Name settings can be configured as part of your initial installation of Jama Connect or any
time you need to make changes.
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If possible, choose a host name that's meaningful to users. Be sure the domain name matches your
TLS certificate. 

If you need to change this host name, you must also change the base URL. [527] 

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Host Name section of the page.

3. Enter or change the host name.
4. (Recommended) Select Reuse admin console TLS configuration to use the same certificate con-

figured in the Admin Console.
5. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
6. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Bypass browser TLS warning
A Transport Layer Security (TLS) or Secure Sockets Layer (SSL) certificate is required to establish a
link between the Admin Console (Replicated) and your browser.

When configuring the Admin Console for the first time, you see a TLS warning with an option to bypass
it with a self-signed certificate. If you have a trusted certificate, you can configure the certificate at any
time [481]. If you continue with the self-signed certificate, you see a warning every time you access the
Admin Console.

You can upload a TLS certificate and provide a private key if you have one. Private keys can't be pass-
word-protected. The key and primary certificate must be in PEM format, that's a base64 encoded x509
certificate.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Bypass Browser TLS Warning section of the page.
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3. Click Continue to Setup to upload a TLS certificate.

4. Click Choose file to select the key and certificate, then click Upload & Continue.
5. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
6. To apply settings, you must restart the application:

• Immediately — Select Restart now.
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• Later — Select Cancel and Restart later.

Configure TLS certificate
The settings for the TLS certificate can be configured as part of your initial installation of Jama Connect
or any time you need to make changes.

You can provide custom private key and TLS certificates to secure the application, or you can reuse the
Admin Console certificate. You can also update your certificate [526] if it expires. 

The certificate ensures that Jama Connect trusts the issuer.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the TLS Configuration section of the page.

3. To link Jama Connect to a service protected by a certificate (self-signed or issued by a local author-
ity):
• Private Key — Click Choose file and select your private key.
• Certificate — Click Choose file and select your self-signed certificate.

4. Select Use trusted certificate file to upload a PEM-formatted public certificate or multiples that
are concatenated into a single file. These certificates are added to the default Java trust store. You
might need this functionality to connect to your MySQL, SQL Server, LDAP, Crowd, IMAP, SMTP, or
other internal servers from Jama Connect.

5. Scroll down to the bottom of the page and click Save. A message confirms that your settings were
saved.

6. To apply settings, you must restart the application:
• Immediately — Select Restart now.
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• Later — Select Cancel and Restart later.

Configure memory settings
Memory settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

Use the advanced memory settings to change the memory allocation of containers that are running
Java processes.

jamacore service Uses 6.5 GB plus a portion of the remaining total memory.

Recommended: 6.5 GB + ($total-15 GB)*50%

Search service Uses 1 GB plus a portion of the remaining total memory.

Recommended: 1 GB + ($total-15 GB)*5%

Diff service Default recommendation is 128 MB.

Elasticsearch Uses 3.5 GB plus a portion of the remaining total memory.

Recommended: 3.5 GB + ($total-15 GB)*20%

SAML service Uses 1 GB plus a portion of the remaining total memory.

OAuth service Uses 512 MB plus a portion of the remaining total memory.

Memory settings can be expressed as a simple formula, using:

Operators + - / *

Brackets ( ) to specify order of operations

Variable $total to reference the total memory of the application server

Numbers with units KB, MB, or GB

Numbers with percentages %

NOTE
When changing memory settings, make sure you don't over-allocate the total memory
of the application server [426]. Monitor usage [522] and make sure to leave enough
memory for system processes to run smoothly. For information, see Resource sizing
for your application server [426].

To configure memory settings:

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Advanced Memory Settings section of the page.
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3. Use the default values. If you have performance issues, contact Support for help configuring these
values.

4. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
5. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Configure advanced startup settings
Startup settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

Enable Java Management Extensions (JMX) and set additional Java Virtual Machine JVM options
(JAVA_OPTS) for the following containers that are running Java processes:

• The jamacore application
• Search service
• Elasticsearch

IMPORTANT
Each of these containers already adds a number of their own JVM options that might
clash with additional JVM options configured here.

Use JMX support in a secure environment, because JMX ports have no authentication on the JMX ports
when JMX is enabled. A formula can also be used [482] to set an exact memory amount.

To configure advanced startup settings:

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Advanced Startup Settings section of the page.
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3. Select Enable JMX remote for core Jama application.
4. Enter the JMX remote port number for the core Jama application.

Don't overlap JMX ports between containers and don't overlap other ports that are already in use
on the application server.

5. (Optional) Enter additional Java JVM options for Jama core, search service, and Elasticsearch.

6. Enter a Java RMI server hostname.
A single Java RMI server hostname can be given that works across all containers that have JMX
enabled. The host IP address is used by default. However, if the host IP address isn't accessible by
the JMX client for the configured JMX ports, the public hostname or the public host IP is set here. If
an SSH tunnel is used, set the hostname to "localhost."

7. (Optional) In the Add services configuration field, add services configuration specific to Jama
Connect, such as throttling.

8. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
9. To apply settings, you must restart the application:

• Immediately — Select Restart now.
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• Later — Select Cancel and Restart later.

TIP
Garbage collection logging (GC logging) is automatically enabled for containers that
are running Java processes. GC log files are available alongside other log files for the
respective container [531]. When you restart Jama Connect [521], previous GC log
files are packaged as a ZIP file. Typically, the default GC logging configuration is suffi-
cient, but it's possible to override GC logging parameters through the Additional JVM
options for Jama core field in admin console advanced startup settings [483].

Configure Advanced Search Settings
Advanced Search settings can be configured as part of your initial installation of Jama Connect or any
time you need to make changes.

Configure index settings for Elasticsearch. Making changes to these settings requires re-indexing.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the Advanced Search Service Settings section of the page.

3. Accept the default values.
4. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
5. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Configure New Relic settings
New Relic settings can be configured as part of your initial installation of Jama Connect or any time you
need to make changes.

1. In the header of the Admin Console, select Settings to open the Settings page.
2. Scroll down to the New Relic Settings section of the page.

The "Application name" and "License key" are required to connect jamacore to New Relic.
3. For the Application name, enter Jama. If unsure where to find your license key, see the New Relic

instructions.
4. (Optional) Select Use proxy for New Relic to expand the proxy settings. If you're using High Se-

curity Mode, make that selection to expand the settings.
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5. Click Save. A message confirms that your settings were saved.
6. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Set a custom location for the MathType Equations Editor
Settings for the MathType Equations Editor can be configured as part of your initial installation of Jama
Connect or any time you need to make changes.

NOTE
The MathType Equations Editor requires a separate license. After your organization
has purchased the license, and the system administrator sets up a location for the edi-
tor, users can access the editor in the Rich Text Editor [102] in Jama Connect.

Airgap or self-hosted instances of Jama Connect can add math and chemical equation options to the
rich text editor without making calls to an external server.

Before enabling the MathType Equations Editor, you must:

• Designate a server inside your environment that can listen for MathType calls and responses. Check
for the latest supported version on the Community.

• Acquire a MathType license from Jama Software.

To configure settings for MathType Editor:

1. Log in to the Admin Console.
2. In the side panel, select WIRIS Connection Settings.
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3. Select Use custom WIRIS connection to override default settings for communication with the WI-
RIS cloud servers.

4. Enter the following information for your designated MathType server:
• WIRIS host (Required) — Enter the hostname of your MathType server. This must be accessible

from both the Jama Connect application server and the user's browser. Don't include the port or
protocol.

• WIRIS path — Enter the context path followed by "render." Depending on how your server is set
up, it might look like this:

/editor/render

• WIRIS port — The defaults are 80 for http and 443 for https. You can override these values by
entering a different port number.
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• WIRIS protocol — This is https or http. If you use https to link to Jama Connect, you must also
use https for WIRIS.

NOTE
Additional settings for proxy are available but haven't been fully tested. You can
use these settings if your Jama Connect instance needs to use a proxy to con-
nect to the MathType server. However, these settings don't change how your
browser connects to the MathType server.

5. Scroll to the bottom of the page and click Save. A message confirms that your settings were saved.
6. To apply settings, you must restart the application:

• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Setting up Jama Connect

NOTE
This information applies to self-hosted environments only.

Once you finish installing Jama Connect, continue with a few tasks for the initial setup of the applica-
tion.

When logged in as root, you can access the System Administration page. From there you can complete
the tasks for setting up and maintaining Jama Connect.

Administrator tasks
System administrators complete basic setup and maintenance tasks in the System Administration
page. Some of these tasks can also be completed by an organization administrator.

Task System admin Org admin

Modify organization details [493] X

Configure general properties [495] X

Configure authentication properties [523] X

Manage users [559] X X

Manage permissions [648] X X

Manage reports [353] X

Monitor license usage [571] X X

Create editor templates [600] X X

Create a backup [513] X

Reindex search [531] X

Access system information [491] X
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Task System admin Org admin

View log and profile [538] X

Clear cache [530] X

View scheduled jobs [530] X

View applied patches [530] X

Log in as root for the first time
As a system administrator, you are the root user with a unique set of permissions [569] that allow you to
access the System Administration page in Jama Connect.

The first time you log in as root, change the default password for the root user and edit any details in
the My Profile page, such as email address, phone number, or location.

1. At the Jama Connect login page, enter the default credentials for root, then select Sign In.
• Username = root
• Password = password

2. In the top right header, select root.

3. On the root user's My Profile page, select Change Password.
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4. Enter the existing password, enter and confirm a new secure password, then select Save.
5. (Optional) Select Edit Settings to configure the root user email and any other details as needed.
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6. Select Save, then select Close

Assign a new user as organization admin
Only system and organization administrators can assign roles or grant permissions to other users. If
you configure an organization admin right after you install Jama Connect, you can share the
tasks of setting up user accounts and permissions.

You must be have system administrator permissions to complete this task.

1. Log in to Jama Connect as the root user [489] or as an organization admin.
2. Select Users > Add user.

3. Select a user if LDAP is enabled [504]:
1. From the LDAP column that is added, select Add user from LDAP, enter the name of an exist-

ing LDAP user in the search box, then press Enter.

TIP
You can add wildcards to a search but don’t add them at the beginning of a
search term. Wildcards at the beginning can result in slow performance. For
large directories, expect several minutes.

2. From the search results, choose a user, then select Add.
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4. Select a user if LDAP isn’t enabled — Select Add user.
5. In the Create User page that opens, complete the information for a single user.

6. For License Type, select Creator.
7. Under Groups, select Organization Admin from the list.
8. Select Save.

Grant permissions to users
Permissions allow users access to create, read, and edit items. They are granted at different levels in
your environment.

Types of permissions Level Notes

Roles [577] and access permissions Organization level Org-level permissions are passed on to lower levels.

Project admin permissions Project level

Access permissions Container level and above

TIP
Organization admin permissions can’t be overridden. In releases prior to Jama Con-
nect 8.62, there was the appearance that you could control an organization admin’s ac-
cess. However, that user could still see all projects and content, and if they wanted
they could give themselves access. The addition of User, Process, and Add project
roles decreases the need for a large group of organization admins. No updates or
overrides that you created in the past have been removed, so we recommend that you
remove them as your organization adopts these new admin roles.

You can create new permissions for a user or group as well as modify existing permissions.
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1. Log in to Jama Connect as the root user [489] or as an organization admin.
2. Select Admin > Permissions.

3. In the Project Selector on the left, choose the level where you want to access permissions. 
• Organization (System)
• Individual project
• Container
The main page displays current permissions.

4. To change existing permissions for a user or group:
1. Select Modify in the row of the user or group you want to change, select the permissions you

want to include, and deselect what you don't want to include.
2. Select Remove in the row of the user or group where you want to delete permissions.

5. To add permissions for a user or group:
1. Select Add permissions in the top right.
2. In the Add permissions page that opens, select the Groups or Users tab.

• Existing user or group — Select a user or group from the list on the left, then under Per-
missions, select the role (access permissions) for that user or group.

• New user or group — Select New user or New group in the top right corner of the page.
Then under Permissions, select the role or access permissions for that user or group.

3. Select Save.

Edit organization details
As a system administrator, you can change your organization’s information such as the name, descrip-
tion, or return email address.

1. Log in to Jama Connect as the root user [489].
2. Select Organizations > Edit.
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3. Enter or change any of the following information:
• Organization name — Typically the name of your company or team. This name appears in the

application as well as in reports.
• Description — Additional information about your company.
• Return email — Email notifications automatically sent by the application. Typically, the organiza-

tion administrator's email address is used or noreply@example.com.
• Base URL — The base URL is used to create URLs sent in email notifications and embed im-

ages in exports.
• Rich text image max width (px) — Maximum pixel width setting that shrinks all images embed-

ded into rich text fields. Default 0 means no max width is applied.
• Rich text image max height (px) — Maximum pixel height setting that shrinks all images em-

bedded into rich text fields. Default 0 means no max height is applied.

NOTE
Images retain their aspect ratio when adjusted to fit the maximum setting of
height or width. The adjustment only happens during an upload or document im-
port. Images that already exist on the server are not adjusted. Compres-
sion is based on the width and height setting applied.

• Allow project admins to subscribe to others — Allows project administrators to subscribe oth-
er users to items.

• Allow users to mute subscriptions — Allows users to turn off a subscription that was subscri-
bed to by another user.

• Allow non-administrators to delete items/containers — Allows a user to delete items even if
they don't have organization admin permissions. Default is On.

• Include unexecuted test run in status calculations (Not retroactive) — Jama Connect uses
all associated test runs to automatically calculate test case status.
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NOTE
For test cases associated with a single plan, test case status reflects the status
of the test run with the most recent activity, which includes unexecuted tests (if
enabled). When the case is associated with multiple plans, the most urgent sta-
tus is chosen in this priority order: unexecuted, failed, blocked, scheduled,
passed.

Select this box to include unexecuted test runs in the calculation of test case status (default). Un-
check this box to remove unexecuted test runs from the status priority order.
If you don't include unexecuted test runs and there are no executed test runs, the system defers
to including unexecuted test runs.

• Allow multiple items with the same Global ID in a single project — Allows items to be reused
multiple times within one project. Default is off.

Configure general properties
The general properties need to be configured for all Jama Connect installations. Properties include con-
figuring email, the session timeout value, and any messages you want to display on the login page.

1. Log in to Jama Connect as the root user [489].
2. Select the System properties tab in the Jama System Administration panel, then select Edit in the

top, right corner.
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3. Change any of the following settings.
• Session timeout — Automatically disconnects idle users after a set time (default is 120 mi-

nutes). When a session times out, the user is prompted to log in and their license is re-
leased. Recommended when using floating licenses.

• Enable HTML tag security cleaning — Prevents suspicious HTML tags from being added to
new and modified rich text fields and test steps. Doesn’t clean up data retroactively. Enabled by
default.

• SMTP settings — Settings that affect notifications and subscriptions.

SMTP Enabled Select Yes to use SMTP.

SMTP Host The domain address of your SMTP server.

SMTP Port The port for SMTP access.

SMTP User User account to access SMTP.

SMTP Password Password for the user account.

Authorization Required Select Yes if authorization is required for the SMTP server.

Use TLS Select Yes if your mail server uses TLS. Jama Connect supports only Explicit (Opportunistic)
SSL/TLS connections for SMTP.
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• Collaboration from Address/IMAP — IMAP must be supported to enable reply-to e-mails in the
stream [211].

System "From" ad-
dress

Enter an address for the system to use when it sends notifications or other system messag-
es (for example, info@mycompany.com).

Collaboration "From"
address

Must match the email address used for IMAP, so replies to stream emails are sent to the
same account that processes incoming mail (for example, replyto@mycompany.com).

IMAP enabled Select Yes to use IMAP and stream emails.

IMAP server Enter the domain address of your email server (for example, imap.gmail.com).

IMAP port The port for IMAP access, typically different from SMTP. Standard ports are Non-SSL:143,
SSL:993.

IMAP use SSL Select Yes to use SSL.

IMAP user account Enter a user account for someone with access to the folder where IMAP emails are saved.

IMAP user password Enter the password for the user account.

IMAP folder Folder where collaboration emails are sent or saved (for example, Inbox). Must be accessi-
ble to the person with the IMAP user account.

IMAP error Folder where IMAP collects parsing issues or errors.

• Time and date formatting — Set the time to meet the needs of your users.
Set the time to meet the needs of your users.
Java and JavaScript do not use the same date-time syntax. Review the difference before setting
the values. Some typical formats for JavaScript are m/d/Y h:I a and m/d/Y. Some typical formats
for Java are MM/dd/yyyy hh:mm:ss a z and MM/dd/yyyy.
If you use Windows, enable Adjust for daylight saving time automatically is in Windows Date
and time settings so that the time zone is displayed correctly in reviews.
The Trace View date format is inherited from a different format than other items in the applica-
tion. To match formats, you must have the Javascript Day/Month/Year format and Java-
script Date/Time format in the same order. This is most notable when using a European date for-
mat.

• Allow project administrators to add groups — Select Yes for project administrators to add
groups [642]. Otherwise, only system and organization administrators can add groups.

• Allow project administrators to set project permissions — Select Yes for project administra-
tors to grant project permissions [644]. Otherwise, only system and organization administrators
can grant permissions.

• Allow access to REST API — Enables users to perform actions in Jama Connect from outside
the user interface.

• Attachment file extensions — List of file types (lowercase, separated by commas, periods,
spaces, or newline characters) that can be uploaded as an attachment.

NOTE
Files are rejected if the content of the file doesn’t match the file extension, or if
the MIME type is not understood by the system, even if the file type is listed
here. To allow files of an unknown type, set the option to a blank string.

File extensions must be lowercase even if the actual extension on the file is up-
percase. Learn more.

• Notice on login page — Displays a notice to users below the login page and in a yellow bar at
the base of the application page.
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NOTE
This login page might not be visible if you are using SSO or SAML logins.

• Maintenance mode — Logs out and locks out all users except the root user until this option
is disabled.

• Set header color — Helps to differentiate test or staging instances from the production instance
of Jama Connect.

4. Select Save.

Configure Basic authentication
The default authentication method is Jama Connect Basic, which authenticates users by their username
and password that are stored in the Jama Connect database. Passwords are encrypted before they are
stored in the database.

NOTE
You must be a system administrator to complete this task.

To configure the Basic authentication properties:

1. Log in to Jama Connect as the root user [489].
2. Select System Properties > Authentication Properties > Basic.
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3. Configure the authentication properties for the method you are using.
• Enable basic authentication — Enabled by default. You must deselect this option to use LDAP

or Crowd.
• Enable "Forgot Password" functionality — Users who forget their password can request a

new password without notifying the system admin.
• Allow users to change their username — Users can change their username when they man-

age their profile [38].
• Password requirements — Set the required password strength for all future passwords. New

user passwords must meet the required password strength to be saved. Changes to these set-
tings do not affect passwords already in the system.

4. Click Save.

Configure SAML authentication
To configure SAML authentication, you must first update the authentication properties.

Important considerations

• Cloud customers — Contact support to schedule enablement.
• Self-hosted customers — Follow these steps to configure multi-mode authentication.
• To connect multiple instances of Jama Connect to the SAML service, you must create unique meta-

data or applications for each instance through the identity provider. This is true for any combination of
production, sandboxes, or self-hosted instances. The entity ID is a unique value that allows the serv-
ice and identity provider to locate each other and send users to the correct Jama Connect instance.

• We recommend testing an integration instance before using SAML on a production instance. For ex-
ample, disable a sandbox instance from SAML before connecting on a production instance.

• Starting with Jama Connect 8.48, organizations that use SAML can use electronic signatures [222],
which are enabled by default. If your identity provider (IdP) can't process the re-authentication, you
can disable signatures.

• You can enable a different authentication method at any time. If you do, SAML is disabled.
• You can control the auto-provisioning of new SAML users in both single SAML and multi-mode. If

your users are set up in SAML but not yet added to your Jama user table, this option allows you to
control whether users can auto-provision in Jama Connect.
When this option is selected and properties are saved, your SAML users (SAML and multi-mode)
can’t sign in to Jama Connect until you add them to the Jama user table. A message tells them to
finish the authentication process with their administrator.
This option is selected by default after you upgrade to 8.62.
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To configure SAML authentication:

1. Log in to Jama Connect as the root user [489].
2. Select System Properties > Authentication Properties > SAML.
3. Before you enter data, select Enable SAML, then click Save.

4. Contact your identity provider for the metadata URL or XML, then paste it in the appropriate field.
If a connection is established, the last three read-only fields are auto-populated with a URL.
• SP metadata URL — https://saml-or.jamacloud.com/saml/metadata/alias/defaultAlias
• ACS / single-sign-on URL — https://saml-or.jamacloud.com/saml/SSO/alias/defaultAlias
• SP entity ID / Audience restriction — https://saml-or.jamacloud.com/saml/metadata/alias/

defaultAlias
If the connection doesn't work, you might need to adjust the information in the ACS binding, First
name attribute mapping, and Last name attribute mapping fields or contact support.

TIP
The mapping fields serve as the key that connects user identity between Jama
Connect and your identity provider. If name attribute mapping fields aren't speci-
fied, then a new user's full name defaults to their email address.

5. Click Save.
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Once SAML is enabled, Jama Connect redirects all users to the identity provider's login page. The Ja-
ma Connect login page is only accessible for system administrators if they log in as the root user with
this URL:

https://your-jama-url/casper/login.req

Configure multi-mode authentication
The combination of Jama Connect Basic and SAML authentication (Basic + IdP) provides extra securi-
ty by separating your internal users from external partners.

Important considerations

• Cloud customers — Contact support to schedule enablement. 
• Self-hosted customers — Follow the steps in this task to configure multi-mode authentication.
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To configure multi-mode authentication:

1. If you haven't entered the SAML metadata in the root menu, go to the SAML tab and enter it there.
• Contact your identity provider for the metadata URL or XML, then paste it in the appropriate field.

If a connection is established, the last three read-only fields are auto-populated with a URL.
• SP metadata URL — https://saml-or.jamacloud.com/saml/metadata/alias/defaultAlias
• ACS / single-sign-on URL — https://saml-or.jamacloud.com/saml/SSO/alias/defaultAlias
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• SP entity ID / Audience restriction — https://saml-or.jamacloud.com/saml/metadata/alias/
defaultAlias
If the connection doesn't work, you might need to adjust the information in the ACS binding,
First name attribute mapping, and Last name attribute mapping fields or contact support.

TIP
The mapping fields are the key that connects user identity between Jama
Connect and your identity provider. If name attribute mapping fields aren't
specified, a new user's full name defaults to their email address.

2. Log in to Jama Connect as the root user [489].
3. Select System Properties > Authentication Properties > Basic + IdP.

4. Select Enable BOTH Basic authentication and SAML, then click Save.
The Basic + IdP tab transitions can now accept input. While the Basic and SAML tabs are now
read-only This type of input is the same on both tabs: Basic and SAML.

5. Complete the Basic and SAML sections in the Basic + IdP tab:
Basic — Fill out the the Basic Authentication section.
SAML — If you haven't entered the SAML metadata in the root menu, complete the following steps
in the SAML section of the Basic + IdP tab.

6. Click Save.
7. Confirm the configuration was successful.

• Select the Users tab, then verify that the Authentication Type column appears in the table.
If you see the Authentication Type column, Basic + IdP authentication is now enabled.
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Configure LDAP authentication
LDAP (Lightweight Directory Access Protocol) is a tool for organizations to centralize the management
of user accounts. Jama Connect includes a built-in integration for LDAP and Microsoft Active Directory.

LDAP must be configured before it can be used in Jama Connect to authenticate users against your
LDAP server. 

To configure LDAP authentication:

1. Log in to Jama Connect as the root user [489].
2. Select System Properties > Authentication Properties > LDAP.

3. Configure the authentication properties for the method you are using.
• Enable LDAP — Select this to enable LDAP and disable the default Jama Connect authentica-

tion. Save the settings for changes to take effect.
• Enable Self Registration — Users can register themselves by logging in to Jama Connect using

their LDAP credentials. If successfully authenticated, they get a prompt to register for Jama Con-
nect. Without self-registration, users must be added manually by an organization administrator.
Once registered, users will be assigned a license type based the rules below. An organization or
project administrator must then assign permissions for that user.
• If there are available creator licenses, they are assigned a creator license.
• If there are no named creator licenses, users are assigned floating creator licenses (shared

among others).
• If there are no creator or floating creator licenses available, you can still create users, but they

are set to inactive. An organization administrator must manually assign the user an active li-
cense when one becomes available.

• Default organization for self-registered user — Select the organization that self-registered
users are assigned by default. There should only be one option.

• Default user group for self-registered user — Select the default group to which a self-regis-
tered user should be assigned. Organization administrators will need to assign permissions to
self-registered users. 

4. You can configure multiple directories with LDAP authentication. To add a new provider, select Add
AD Provider or Add LDAP Provider, depending on the LDAP tool you use.  
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5. In the window that opens, provide the following server information used to connect to the Active
Directory or LDAP server, then click Next.

• Name — Name of the connection that will appear in the Jama Connect interface.
• Description — Description of the connection that will appear in the Jama Connect interface.
• URL — The URL to the Active Directory or LDAP server.
• Bind DN — The reference to the account that Jama Connect will use to perform all actions

against the Active Directory or LDAP server. This field accepts the Distinguished Name of the
account ("cn=John Doe,ou=Users,dc=jamasoftware,dc=com").  
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Some Active Directory servers support the use of Full Name ("John Doe") or Email ("jdoe@do-
main.com").

• Bind Password — The password of the Bind DN account.
• Test Configuration — Select Test configuration to test for a successful connection to the

specified server and bind account information. If successful, a "Configuration Successful" mes-
sage will display in the window and the Base DN selection screen will expand.

• Select the Base DN — The Base DN is the directory where users in Active Directory or LDAP
exist that need to be added to Jama. Successfully tested configurations will load a radio button
selection list of all available Base DNs.

6. Specify the attributes in Active Directory and LDAP that automatically populates the Jama Connect
user attributes.

• Username — Enter the username of a sample user that exists in the specified Base DN.
• Username Attribute — Enter the attribute where the username value is stored (for example, Ac-

tive Directory commonly uses "samaccountname"). 
7. Select Next to validate that the provided username and username attribute exist. If successful, the

window expands to show a selection list of all available attributes for each of the Jama Connect
user attributes.
• Jama User Attributes — First Name, Last Name, Full Name, Email, Location, Phone, Title. 
• LDAP attribute — The selection drop-down shows all available directory attributes that are con-

nected to the provided username. Select the correct value in the selection list that matches the
Jama Connect user attribute.

8. Select Advanced setup if you know all the details of the connection and user attribute values. If
you choose this option, you must add the Full Name Attribute or errors will result.
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9. After saving the connection, select Synchronize Now to manually sync all existing users in Jama
Connect to LDAP. This updates user information with attributes from LDAP. 

Any Jama Connect users who are not registered in LDAP are deactivated. Users in LDAP that do not
already exist in Jama Connect aren't synchronized. New users must be added manually [491] with ex-
isting LDAP credentials.

Troubleshooting LDAP errors
If any errors occurred during installation, use this table to troubleshoot the issues.
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Error message Reason

Unable to communicate with LDAP server; nested exception
is javax.naming.CommunicationException: localhost:389
[Root exception is java.net.ConnectException: Connection
refused: connect]

Can't connect to the server. Check the URL and make sure port
389 is open.

Operation failed; nested exception is javax.naming.Authenti-
cationException: [LDAP: error code 49 - Invalid Credentials]

The BindDn or password is incorrect.

Can't find user Indicates that the Base Dn, Bind Dn, and Bind Password can be
connected to accurately (a good connection to LDAP). Either the
Login Name Attribute was not filled in correctly or the Sample
User does not exist in the Base Dn indicated.

Can't authenticate user The sample user password is incorrect. However, this message
indicates a successful connection to LDAP and that the sample
user was found in the Base Dn.

Operation failed; nested exception is javax.naming.Partial-
ResultException: Unprocessed Continuation Reference(s);
remaining name

The cause is usually the base URL is incomplete (too broad).

Operation failed; nested exception is javax.naming.Service-
UnavailableException: adunit:636; socket closed. Port 636 is
for SSL.

Either SSL isn't supported by Spring LDAP or the certificate is in-
correct.

Solution: Try using ldap protocol. For example: ldaps://myserv-
er.example.com:636.

 

Make sure you entered the correct information for the type of LDAP you are configuring:

• Active Directory
URL: 'ldap://localhost:389'
Base Dn: 'ou=Users,dc=<domainname>,dc=com'
Bind Dn: 'cn=Admin,ou=Admin Users,dc=<domainname>,dc=com'
Bind Password: 'password'
Login Name Attribute: 'sAmAccountName'
Email Attribute: 'email'
User Name Attribute: 'displayName'
Sample User: 'admin'
Sample User Password: 'password'

• LDAP
URL: 'ldap://localhost:389'
Base Dn: 'ou=Users,dc=<domainname>,dc=com'
Bind Dn: 'cn=Admin,ou=Admin Users,dc=<domainname>,dc=com'
Bind Password: 'password'
Login Name Attribute: 'uid'
Email Attribute: 'mail'
User Name Attribute: 'cn'
Sample User: 'admin'
Sample User Password: 'password'

IMPORTANT
If you are using SSL, you must use the ldaps protocol. For example, ldaps://myserv-
er.example.com:636

The Base Dn and Bind Dn values won't accept a domain-only value. At least one additional level is re-
quired, such as the 'ou=Users' shown in the example above.
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Take note of the "Can't find/authenticate user" errors. Errors often indicate a successful connection, but
the Sample User/Password are incorrect. 

IMPORTANT
The Sample User and Password fields are deleted every time the configuration window
is closed.

Configure Crowd authentication
Use Crowd to manage users and groups within a single system. Jama Connect can accept user details
from Crowd and sync them with authentication data in Jama Connect.

To configure Crowd authentication:

1. Log in to Crowd as an administrator.
2. Select Applications > Add Application, fill in the fields for a new application and select Next.

• Application type — Generic Application.
• Name — "jama" or any other unique name that identifies Jama Connect as the application.

NOTE
The name must match. For example, lower case "jama" in the above example.

• Description — (Optional) Provide a short description of the application.
• Password — Create a new password that Jama Connect uses to access Crowd.

3. Enter the URL and IP address for Jama Connect, then select Next.
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4. Select the directories that control access to Jama Connect, then select Next.

NOTE
These directories must exist prior to inclusion.

5. Select the particular groups in the Crowd Directory you want to have access to Jama Connect, or
choose "all users in the directory" if you want all users to have access, then select Next.

6. Review your configuration, then select Save.
7. Log in to Jama Connect as the root user [489].
8. Select System Properties > Authentication Properties and complete the following fields.
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• Enable Crowd — Select to enable or disable Crowd Connector. When disabled, the Jama Con-
nect database is used for users and passwords. 

• Crowd location — Enter the URL for the Crowd server.
• Crowd application name — Name of the application created in step 2 above.
• Crowd application password — Enter the password for Jama Connect that was created in

Crowd.
• Validation interval — The amount of times a user can access the application prior to re-authen-

ticating. The larger the number, the less communication with Crowd.
• Sync Crowd users and groups — Select this option to push Crowd Groups and Users into Ja-

ma Connect at regular intervals. Make sure you understand how users and groups in Crowd in-
teract with Jama Connect [512] before you do this.
When syncing with Crowd, Jama Connect assigns licenses as follows:
• If there are available named creator licenses, users are assigned a named creator license.
• If there are no available creator licenses, users are assigned a float license.
• If there are no available creator or float licenses, the user is skipped and it appears in the log.
When Crowd is synced, Jama Connect runs through its list of users, adds new users, and modi-
fies existing users in the Jama Connect userbase. When that's complete, Jama Connect runs
through the list again to see if there are any existing users in the Jama Connect userbase that
need to be deactivated.
Since Jama Connect makes two passes at adding and deactivating users, you might need to
sync twice consecutively for it to work. For example, if you reach your license threshold, don't
use float licenses, try adding a new user and deactivating an existing user, or must sync twice
consecutively before the new user is given a named license.

IMPORTANT
You can also select Manual Sync at the bottom of the window to manually syn-
chronize all users and groups. Manual sync removes all Jama Connect config-
ured Users and Groups and insert Crowd users and groups.
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• Sync interval — Enter the timing interval you would like for Crowd to synchronize groups and
users with Jama Connect. This defaults to 30 minutes.

• Default Organization for User — Only required when multiple organizations are setup with Ja-
ma Connect.

9. Select Save.
10. Select Test Connection to test if the configuration values are valid.

Users who are registered in Jama Connect, but not in Crowd, can't access Jama Connect. Other users
won't be able to add disabled users to reviews or notifications.

How users and groups work in Crowd
How users and groups function is impacted when you synchronize users and groups in Crowd connec-
tor [509].

The following actions change:

• All groups and users in Crowd that aren't in Jama Connect are added to Jama Connect. New users
are assigned the most licenses available. When no licenses are available, users are created and In-
active.

• All groups in Jama Connect that aren't in Crowd are removed.
• All users that are in Jama Connect, but not in Crowd, are deactivated.
• Going forward, all user and organizational group management activities are performed in Crowd.
• Organization administrators no longer create or edit users and organizational groups in Jama Con-

nect because they are automatically created from Crowd.

The following actions stay the same:

• Organization administrators retain the ability to assign a license type [567] to users.
• Users can continue to upload avatar icons [38].
• Organization administrators and project administrators continue to manage project groups [642]

within individual projects.

IMPORTANT
Project level project groups are only managed in Jama Connect and aren't visible in
Crowd.

• An organization or project administrator continues to manage user and group permissions [574] in
Jama Connect.

Action in Crowd Result in Jama Connect

Group(s) added to “Jama” Application in
Crowd

Group created.

The name of the group is reused if it already exists.

Users added to the "Jama" group in Crowd Users added.

Attributes in Jama Connect are overwritten by values from Crowd if a user already
exists.

Group attributes modified Group attributes are modified.

User attributes modified User attributes are modified.

User added to group User is added to group.

User removed from group User is removed from group.

Group deleted Group is deleted.

User is deactivated User is deactivated.
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Action in Crowd Result in Jama Connect

User activated User is activated.

If the user doesn't exist, a new user is created. The new user is assigned the
highest available license. If a license isn't available, the user is inactive.

Backing up and restoring your data
Backing up your data is an essential part of maintaining and securing your self-hosted environment.
With regular backups, you can easily restore settings and content when you update your application
server hardware or if you lose data.

NOTE
This information applies to self-hosted environments only.

You can back up and restore your data using several methods:

• Replicated snapshot — A function of Replicated software that creates a backup of the Admin Con-
sole environment. It includes all Admin Console settings, the Replicated database, Docker images,
and Docker container volumes.

• .jama or XML file — A method with built-in automation, recommended for migrations and refreshes.
A .jama file includes the database and /data directory. An XML file includes only the database.

• Native database backup — The proprietary backup/restore system for MySQL and SQL Server da-
tabases. Recommended only if your database is extremely large.

• Backup of user data directories [531] — Where all physical artifacts [531] are stored.

IMPORTANT
Create a backup regularly: daily, weekly, or monthly. Include in your regular backup a
Replicated snapshot (Admin Console environment) and a .jama or XML file back-
up (database and /data directory).

Create a Replicated snapshot
A Replicated snapshot is a backup of the Admin Console environment. It includes the Replicated data-
base, registry images, and container volumes (when specified).

A Replicated snapshot can be taken while Jama Connect is running without interruption.

IMPORTANT
Replicated snapshots don't include the contents of the Jama Connect database, the
contents of the /data directory, or the log files. To back up those items, see Back up
to .jama or XML file [518].

When to create a snapshot
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• When migrating Jama Connect to new hardware [534]. When you replace one server with another
(create a clone), you can perform a fresh installation of Docker and Replicated, then restore from the
snapshot.

• During disaster recovery.
• Before upgrading your software (Jama Connect or Replicated).

Snapshot location

By default, Replicated snapshots are stored in this location:

/var/lib/replicated/snapshots

To include the Replicated snapshots in your regular backups of Jama Connect, you can change the lo-
cation for the snapshots, like this:

/data/replicated/snapshots

To create a Replicated snapshot:

1. (Optional) Identify and configure a custom directory for your snapshots: Select Admin Console >
Settings (gear icon) > Console Settings > Snapshots.

2. Create a snapshot: Open the Admin Console and select Start Snapshot.

Snapshots Enabled changes to Snapshotting and a progress spinner appears while it backs up
the registry data and container volumes. When the snapshot is ready, you see a timestamp for the
last snapshot.
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If the Replicated snapshot fails, the dashboard displays an error message with technical detail of the
failure, including the file or folder involved. This error message is generated from the underlying file sys-
tem (for example, readdirent: errno 523), which means the problem is likely with the underlying file sys-
tem and not the Jama Connect installation.

Restore all settings from a Replicated snapshot
When you set up a new application server for Jama Connect, you can restore the Admin Console set-
tings that you saved in a Replicated snapshot.

Snapshots include the Replicated database, registry images, and container volumes (when specified).

1. Install Jama Connect on the new server.
2. When the page Upload your license is displayed, select Restore from a snapshot.
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3. When the Restore from snapshot page is displayed, enter the path to your snapshot and click Re-
store.
Use the same path on the new server as you did on the old server. For example, /var/lib/replica-
ted/snapshots or /data/snapshots.

4. On the Restore Cluster page, click Restore.
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The system displays a progress page as it restores your data from the snapshot.
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Back up to .jama or XML
We recommend backing up to a .jama or XML file for migrations and refreshes because this method
has built-in automation. You can avoid manual changes which can impact the integrity of the data.

A .jama file backup includes the database and /data directory. An XML file backup includes only the da-
tabase.

Important considerations

• If SAML is enabled, disable it before backing up your data. After you restore your instance of Jama
Connect, you must re-enable SAML.

• Backups must be done manually; they can't be scheduled automatically.
• Make sure you have enough available disk space [522].
• Make sure Jama Connect is in maintenance mode [495] before you create a backup.
• If you are using a version of Jama Connect prior to version 8, generate backups during a mainte-

nance window and inform users, including API users, not to use the application.
• Regardless of what version you are using, all integrations must be disabled.

To back up to a .jama or XML file:

1. Log in to Jama Connect as the root user [489].
2. Select the Backup tab to see the backup options.

3. Choose a backup method (listed here in recommended order).

Method Scenario Select...

Save .jama file to the application server. Migrating between versions later than 8.0. Save .jama File to
server

Save XML file to the application server. • Migrating between different types of databases
[535]

• Migrating version earlier than 8.0

Save XML File to
Server

Download XML database backup to your
workstation.

• If you can't access the application server
• For smaller databases

Download XML

Download document type definition (DTD)
to your workstation.

If all other methods fail Download DTD

The backup process is complete.

Restore to a new server from .jama or XML
When you set up a new server, you can install Jama Connect and restore data using the .jama or XML
file backup you created. See Back up to .jama or XML file [518].
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IMPORTANT
If you use SAML in your environment, it was disabled before you created the .jama or
XML backup. When you install Jama Connect on a new server, it will be running Basic
authentication. You must re-enable SAML to use that authentication method.

1. Log in to Jama Connect as the root user [489] on the new server.
2. Install Jama Connect [437]:

• On the Settings page under Database settings, select the database you are using: MySQL or
SQL Server.

• Under Restore Jama Backup, enter the file path for the backup you created, (for example, /
data/restore/your_backup.xml). Select Check conditions to make sure the path to your backup
file meets the conditions listed onscreen.
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IMPORTANT
You must have an empty database for the restore process to complete.

3. For non-.jama file backups: Move existing data folders to the new application server.
4. Save and restart Jama Connect [521]. 
5. Log in to Jama Connect as the root user [489].
6. If your new application server has a different URL than the old one, update the base URL to reflect

the change.
7. To sync your indexes with the database, index all items.

Backing up MySQL or SQL Server database
If your MySQL or SQL Server database is extremely large, use the native backup method that comes
with your database. Doing so avoids possible data corruption.

Follow instructions for whichever system you are using, MySQL or SQL Server.

IMPORTANT
If you are migrating from one type of SQL server to another, for example SQL Server to
MySQL, use the .jama or XML file backup [518].

Maintaining your Jama Connect environment
A system administrator is responsible for keeping the system up and running and at peak performance.

Maintaining your environment consists of ongoing tasks that are done regularly and important tasks that
are done infrequently.

Jama Connect User Guide

520

https://dev.mysql.com/doc/refman/5.7/en/mysqldump.html
https://technet.microsoft.com/en-us/library/ms189621(v=sql.105).aspx


Ongoing/regular tasks Infrequent but important tasks

• Monitor memory usage [522]
• Back up your data [513]
• View scheduled jobs [530]
• Clear cache [530]
• Remove old Docker images [529]
• View applied patches [530]
• Stop and restart Jama Connect services [521]
• Reset Admin Console password [523]
• Deactivate and reactivate users [523]

• Update the license (internet [524] or airgap [525])
• Update the certificate [526]
• Update the application's IP address [526]
• Change [527] or fix URL [528]
• Delete an organization [529]
• Reindex all items [531]
• Upgrade the Admin Console [457]
• Upgrade Jama Connect [452]

Stop and restart Jama Connect services
Some tasks require that you stop and restart the Jama Connect services. For example, when you
make changes to the application, they don’t take effect until you restart Jama Connect.

1. In the Admin Console, select Stop Now.

2. Wait until the screen shows "Stopped", then complete your tasks.
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3. Select Start Now to restart Jama Connect services.
4. Wait for the components that make up Jama Connect to be started and initialized.

The dashboard displays the status in this order: Starting, Queued, then Started.

Monitoring memory usage
Make sure you have allocated an appropriate amount of memory for your organization's usage. Check
and adjust usage regularly to keep your environment running for best performance.

Several factors affect the amount of memory that Jama Connect requires, including:

• Size of your dataset
• Number of concurrent users
• Users' common workflows

If any of the containers’ memory consumption is close to the maximum available memory, you can ad-
just those values. These containers in order require the most memory:

• jamacore
• elasticsearch
• searchservice

Make sure that you don't over-allocate the total memory of the application server. Also, leave approxi-
mately 5 GB of available memory (headroom) for system processes. For help in estimating your appli-
cation server size, use the tables in Resource sizing for your application server [426].

Use one of these methods to monitor usage, then adjust your memory settings [482] as needed.

• Log in to Jama Connect as the root user.
• Select the License management tab to view usage by license type.
• Use the Admin Console monitoring graphs.
• Use any Java application monitoring tool that supports JMS.
• Use JavaMelody, which comes preconfigured with the Jama Connect application. To access Java-

Melody, log in to Jama Connect as the root user [489] and navigate to [your.jama.url]/javamelody.
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Deactivate and reactivate users
Users can’t be deleted from Jama Connect, but you can deactivate users if they are no longer active
members of the team. When you deactivate a user, their account becomes inactive and their named
license is freed up for another user. You can also reactivate the user as needed.

IMPORTANT
You must have organization or system administrator permissions to deactivate and re-
activate a user.

1. Log in to Jama Connect as the root user [489].
2. Select the Users tab.
3. To deactivate a user, select Deactivate in the Action column next to the user you want to deacti-

vate.
Deactivated users disappear from the list.

4. To reactivate a deactivated user:
1. Select View inactive users to view all users, then select Activate in the Action column next to

the user you want to reactivate.

2. In the User license type window, select a license type and select Save.

Reset Admin Console password
You can reset the password for the Admin Console if, for example, the administrator forgot it.

1. To remove the current password, run this command on the application server:

replicated auth reset

2. To create a new password, enter this URL in a browser:
https://[your.admin.console.ip]:8800/create-password
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3. Select Password, then type a new, secure password for access to the Admin Console.

The new password takes effect immediately.

Update the license (internet)
When you renew your license or change the number of available seats, you must update your license.
You receive a single key for your organization, called a license key, which specifies the type and num-
ber of licenses you have.

Your application server must be able to access the internet (except for airgap [525]customers).

TIP
Schedule a license update during a maintenance window because the process in-
volves an interruption to the Jama Connect application.

To sync your license:

1. In the header of the Admin Console, select the gear icon > View License.
2. Select Sync License.
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3. Stop and restart Jama Connect [521] for changes to take effect. 

Update the license (airgap)
When you renew your license or change the number of available seats, you must update your license.
You can ask your account manager for a new .rli license file, which Jama Software sends you via email.

TIP
Schedule a license update during a maintenance window because the process in-
volves an interruption to the Jama Connect application.

To sync your license:

1. Open the email from Jama Software with the new .rli license file.
2. In the header of the Admin Console, select the gear icon > Console Settings and verify the loca-

tion of the current license (for example, /data/install). Place your new license in that same location.

3. If the name of the new .rli file differs from the original, update the name in the License File field.
Don't use spaces in the filename.

4. In the header of the Admin Console, select the gear icon > View License, then select Sync Li-
cense at the bottom of the page.

5. Scroll to the bottom of the page and select Save. 
6. Stop and restart Jama Connect [521] for changes to take effect.
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TIP
You can also sync a new license with this command:

curl -o jama_8-#-#.airgap -O

Update the certificate
If a certificate expires, it becomes invalid and must be replaced.

1. In the header of the Admin Console, select the gear icon > Console Settings.
2. Under TLS Key & Cert, select the location of the SSL private key and certificate.

• If the SSL key and certificate are on the application server, select Server path, then enter the file
locations.

• If the SSL key and certificate are on the computer you use to access the Admin Console, select
Upload files to upload the key and certificate files, then select Choose file for SSL Private Key
and SSL Certificate.

3. Scroll to the bottom of the page and select Save. A message confirms that your settings were
saved.

4. To apply settings, you must restart the application:
• Immediately — Select Restart now.
• Later — Select Cancel and Restart later.

Update the IP address for the application server
If you need to update the IP address or hostname of your application server, you must also edit the Re-
plicated configuration files to reflect this change.

If you previously used an IP address, continue using an IP address. If you previously used a hostname,
continue using a hostname.
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NOTE
If you are using DNS and the hostname for this server isn't changing (just the underly-
ing IP), you don't need to edit any files.

1. Make the IP/hostname changes in your network and on the server.
2. Stop the Jama Connect services [521].
3. Stop Replicated (Admin Console):

• CentOS, RHEL 7+, and Fedora

sudo systemctl stop replicated replicated-ui replicated-operator

• Debian, Ubuntu, and thers

sudo service replicated stop
sudo service replicated-ui stop
sudo service replicated-operator stop

4. Edit the Replicated configuration files to replace all occurrences of the old IP address or hostname
with the new IP address or hostname.
• Fedora/CentOS/RHEL

/etc/sysconfig/replicated and /etc/sysconfig/replicated-operator
• Debian/Ubuntu

/etc/default/replicated and /etc/default/replicated-operator
• Others

Contact support at support@jamasoftware.com if you can't locate the Replicated configuration
files.

5. If you have a firewall in place or use a proxy and configured no_proxy settings in Docker, update
these settings with the new IP address [463].

6. Restart Docker.
• Fedora/CentOS/RHEL 7+

sudo systemctl restart docker

• Debian/Ubuntu and Others

sudo service docker restart

7. Start the Replicated service (Admin Console).
• Fedora/CentOS/RHEL 7+

sudo systemctl start replicated replicated-ui replicated-operator

• Debian/Ubuntu and Others

sudo service replicated start
sudo service replicated-ui start
sudo service replicated-operator start

8. Once the Replicated containers are up, navigate to https://{new_ip_address}:8800, then enter the
new IP address or hostname under Settings > Hostname.

9. Log in to Jama Connect as the root user [489].
10. Change the URL [527] to reflect the new IP address.
11. Run Fix URL references [528] to change any existing references in the text of items that were al-

ready created.

Change URL
The Base URL is the first part of all web addresses that Jama Connect installations use, beginning
with http and ending with a slash (/).
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You might want to change your Base URL if a company changes its name or if you need to create a test
instance.

To change your Base URL:

1. Log in to Jama Connect as the root user [489].
2. Select the Organizations tab.
3. Select Change URL from the Action column.

4. Enter the new URL in the New Base URL text box.
5. Select Change URL.
6. Update all URL references [528] in the application to the new value. 

If this step isn't completed, the application still contains old URL references, which can result in un-
predictable behavior such as images not being displayed in exports.

7. If you're using SAML authentication, disable and re-enable SAML settings to update the base URL
in our SAML services.

The new URL is updated and active.

Update URL references after changing URL
The option Fix URL References updates all URL references in the application to reflect a new URL.
After you change a URL [527], always run this function.

IMPORTANT
The Fix URL References option doesn’t modify items in archived projects. It also
doesn’t change the URL used to connect the application server to your database serv-
er; that URL is stored in your database.properties file. The Base URL (baseurl field) is
only updated in the database organization table by the Change URL [527] option.

Use the Fix URL References option if:

• You notice images are not being displayed in exports.
• A login prompt appears after URL redirection.
• An error message is displayed when you run exports.

To update all URL references in the application:

1. Log in to Jama Connect as the root user [489].
2. Select Organizations > Fix URL References.
3. Select Fix URL References from the Action column.

4. Enter the new URL in the text box, To this URL.
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5. Select Fix URL References.
6. When prompted, select Yes to finish.

Delete an organization
Deleting an organization is an activity that is done only when more than one organization exists.

NOTE
Before version 4.3, users had the option to add multiple organizations. However, this
option was removed in the spring of 2014. As of release 8.10, if you have multiple or-
ganizations, delete all but your production organization.

Overall system performance might be affected during the delete process depending on the size of the
organization to be deleted. Schedule the deletion during off-peak hours.

Deleting an organization completely removes all data about the organization including projects, set-
tings, and users. Deleted organizations can’t be recovered. If you need to preserve the non-production
organizations, contact your account representative.

1. Back up your data [518].
2. Log in to Jama Connect as the root user [489].
3. Enable maintenance mode [495] under the System properties tab. If maintenance mode isn't ena-

bled, the option to delete organizations isn't available.
4. Under the Organizations tab, select the Delete action in the row of the organization to be deleted.
5. When prompted, select Yes to confirm you are deleting the organization.

Remove old Docker images
Old Docker images from previous versions of Jama Connect use up storage space and might cause
indexing to fail. To avoid this, periodically remove old Docker images from your system to keep it run-
ning smoothly.

You also want to remove dangling volumes, which are volumes associated with a container that no lon-
ger exists. Jama Connect creates new containers and volumes when you restart the application. These
volumes can fill up your disk space.

IMPORTANT
Make sure Jama Connect is running so that only images not in use are deleted. These
commands clean only images and volumes loaded with the Docker storage driver in
use. Files that were written with other storage drivers remain on the volume until sepa-
rate commands are run for that storage driver.

Use these commands to clean up your volumes:

1. Identify how much space is being used on your server:

sudo docker system df

2. List out all Docker images on your server:
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sudo docker images

Images are displayed on the screen, listed by their ID in the IMAGE ID column.

3. Remove an image by its ID:

sudo docker rmi IMAGE_ID

4. Remove any dangling volumes from the Docker data root directory:

docker volume rm $(docker volume ls -qf dangling=true)

5. Identify the volumes being removed:

docker volume ls -qf dangling=true

NOTE
When you run the commands above to remove an image that is currently in use, you
will get an error. For self-hosted customers with internet access, any missing images
download again when you restart Jama Connect. For airgap customers, you'll need to
manually load the images.

View scheduled jobs
Some jobs can impact performance. When you view scheduled jobs, you can identify which jobs are
currently running, when jobs are scheduled to run, and how much memory they require. Knowing this
information helps you prepare for any performance hit.

1. Log in to Jama Connect as the root user [489].
2. In the Jama System Administration panel, select Scheduled jobs to view jobs, their group, class,

and firing time.

View applied patches
You might need to check which patches have been installed on your application server. For exam-
ple, you can see if any patches were missed, or you might need to let support know about your cur-
rent environment.

1. Log in to Jama Connect as the root user [489].
2. In the Jama System Administration panel, select Applied Patches to view the unique ID, run date,

and status.

Clear cache
If you notice latency or slow performance of Jama Connect, you can free up disk space and memory by
clearing the cache.

1. Log in to Jama Connect as the root user [489].
2. In the Jama System Administration panel, select Cache statistics.
3. Clear items from the cache:

• All items — Select Clear all cache to clear all cache items from the cache.
• Specific item — Select Clear Cache on a specific cache item to clear it from the cache.
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Reindex all search items
Search indexes get out of sync with the database due to large batch updates, API updates, or database
updates. During a full index, all search indexes are rewritten to the current values in the database.

NOTE
You must have system administrator permissions to complete this task while logged in
as root. While organization admins and project admins can index project items [640],
they can't index all search items.

Important considerations

• Files over 25 MB aren't indexed, so their content isn't searchable.
• Filetypes that can be indexed: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF.
• Filetypes that can't be indexed: XLSX, XLS, XML, HTML, HTM.
• During the index process, the application automatically enters  maintenance mode [495]. Users can’t

log in during this time and users who are already logged in receive a message about the mainte-
nance.

To sync your search indexes:

1. Notify users before initiating an index.
2. Disable all integrations including legacy connectors and the Jama/Tasktop Integration Hub.

DWR, SOAP, and REST API calls are automatically blocked during the reindex.

NOTE
The system administrator doesn't have access to disable integrations. Work with
an organization admin or integrations admin [622] to disable those services.

3. Log in to Jama Connect as the root user [489].
4. Select the Index/Search tab and select Index items.

The system displays a count of items in the application and the estimated time to complete the in-
dex.

5. Select Yes to continue.

You see an alert when indexing is complete and maintenance mode is automatically disabled.

Folder locations
You can use an exported filesystem, such as NFS, for mounting the following directories, provided the
path remains the same. Mounting these directories in the cloud is not supported.

The following two directories are on the application server:

• /data
Stores physical artifacts, like attachments, reports, avatars, diagrams, and metrics. Exported file sys-
tems, like NFS, are supported for use with the /data directory.

• /logs
Contains all log files of the Jama Connect components such as the following:
• /logs/tomcat

Apache Tomcat log files, logs all activities [207] in the application
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• /logs/tomcat/contour
Core Jama Connect log files

• /logs/elasticsearch
Elasticsearch log files

• /logs/search
Search service log files

• /logs/nginx
Nginx log files (note that currently only error logging is provided for Nginx)

NOTE
You cannot change the location where log files are written to, however, you can
change the appenders and logging levels for different components of the Jama Con-
nect application. The core Jama Connect application log configuration can be updated
in:

/data/log4jconfig/log4j.properties

The log configuration for Elasticsearch and search service can also be found in 

/data/config

Changes to these configuration files persist when you restart Jama Connect and are
applied in a few seconds.

IMPORTANT
Replicated snapshots are stored in the following location by default: 

/var/lib/replicated/snapshots

However, if you change the path to include /data it will be easier to include these snap-
shots in your regular backups of Jama Connect data at /data/directory, as such:

/var/lib/replicated/data/snapshots

Note that /snapshots should have three times the space allocated as the rest of /data.

Migrating your data
To use Jama Connect 8.x, your application server must be running on a Linux platform; Windows server
is no longer supported. Also, because Oracle database is no longer supported, you must migrate to ei-
ther Microsoft SQL Server or MySQL before upgrading to version 8.x.

You must also migrate your existing data when you upgrade the platform (physical or virtual)
for your database server or application server.
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NOTE
This information applies to self-hosted environments only.

Migrate Jama Connect data when you:

• Upgrade Jama Connect from pre-8.0 version [460]
• Upgrade from Oracle database on pre-8.0 Jama Connect
• Migrate the application to a new server [534]
• Migrate the database to a new server [535]
• Set up or update a test server [535]

Migrating... Details

From Oracle database Jama Connect 8.x no longer supports Oracle database. You must migrate to a supported database be-
fore upgrading to 8.x.

From Windows server Jama Connect 8.x no longer supports Windows platform. You must migrate to a supported Linux oper-
ating system, then migrate your application and data.

IMPORTANT
If you restore data from an XML or .jama file, your image file automatically referen-
ces the new server's name or location. But if you use any other method to restore da-
ta (such as proprietary tools for MySQL or Microsoft SQL Server), you must run the Fix
URL option to update references manually [528]. 

Migration overview
The basic process for migrating your application and data involves creating a backup of your /data di-
rectory, then creating a snapshot of your Replicated Admin Console settings. Once that is done, you
install Jama Connect on a new server and migrate the /data directory backup to the new server. When
the new server is online and functioning, you then remove Jama Connect from the original system.

Depending on your current environment, you might also need to:

• Upgrade to Jama Connect 8.x if you’re running a pre-8.x version.
• Migrate to a supported Linux system if you’re running on a Windows server.
• Migrate to a supported database (MySQL or SQL Server) if you’re running an Oracle database.

Migration process

1. Make a backup of your current Jama Connect installation using one of these methods:
• Jama Connect backup (.jama file or XML file)
• Proprietary database backup for SQL Server or MySQL

2. Make sure you are running:
• Jama Connect 8.x or later on a supported Linux system
• A supported database, SQL Server or MySQL

3. Migrate existing data, using .jama file, XML file, or proprietary SQL database file.
4. Remove previous installation of Jama Connect.
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Migrate existing directories
If you created your backup with a Jama Connect XML file or with SQL proprietary database software,
you must manually migrate certain directories (folders).

A .jama backup file includes the database plus all necessary directories. However, an XML backup
file or a proprietary database backup includes only the database.

1. In the /data directory, delete these directories:
• tenant
• ActiveMQData
• elasticsearch
These directories are restored when you restart Jama Connect on the new server.

2. Migrate these directories accordingly:

Directories Details

/attachments/** Move to the new application server at /data/contour/attachments/**

/avatars/** Move to the new application server at /data/contour/avatars/**

/diagrams/** Move to the new application server at /data/contour/diagrams/**

/metrics/** Move to the new application server at /data/contour/metrics/**

/reports/** Move to the new application server at /data/contour/reports/**

** All directories and files below the given folder
3. On the new application server, set permissions and ownership for all directories with these com-

mands:

chown -R 91:91 /data/contour
chmod -R u+rwX /data/contour

Migrate the application to a new server
If you have a new server (physical or virtual) for your existing Jama Connect 8.x installation, you
must first create a backup and snapshot on the original server, then migrate data and restore the snap-
shot on the new server.

IMPORTANT
The snapshot contains the license from the original server. Only use a production serv-
er snapshot on a new production server, and a test server snapshot on a new test
server.

1. Log in to Jama Connect as the root user [489].
2. Enable maintenance mode [495]:

1. Select the System properties tab in the Jama System Administration panel, then select Edit in
the top right corner.

2. Scroll to the bottom of the page and select Yes for maintenance mode.
3. On the original server:

1. Create a Replicated snapshot [471] from the Admin Console.
2. Create a backup (.jama file, XML file, or proprietary SQL backup) and download it from the root

menu. Move to the new server under /data/restore.
4. On the new server:

1. Migrate the existing data [534], including the /data directory and its contents from the old server
to the new server, preserving the structure and permissions of the contents.

Jama Connect User Guide

534



2. Move the snapshot from the original server to the same directory on the new server.
3. Restore the snapshot [473]. When prompted for the license, select Restore from a snapshot.
4. If the IP address of the two servers are different, update the IP address of your application

server [526].

Migrate existing database to a new server
If you have a new server (physical or virtual) for your existing database, you must create a backup of
the original database, then migrate and restore it on the new database server.

Important considerations

• If migrating from the same database type, such as MySQL to MySQL, perform a proprietary backup
and restore [520], to avoid converting the data.

• If migrating between different database types, such as MySQL to SQL Server, generate a backup
[518] of your database using your current installation of Jama Connect.

• If migrating from a pre-8.0 version of Jama Connect, generate a backup [518] of your database using
your current installation of Jama Connect. You must use an XML file for the backup.

• If migrating from an 8.x version of Jama Connect, use a .jama file for the backup.

To migrate your database to a new server:

1. Generate a backup on your application server, using a .jama file (recommended), XML file, or a
proprietary database backup.

2. If using a .jama file or XML file:
a. Wait for the backup file to be written to the /data/contour/backup directory on the application

server.
b. Move the backup file to the /data/restore directory on the destination application server.

3. Create a new database following the instructions appropriate for MySQL or SQL Server.
4. Delete filesystem assets on the destination server:

rm -rf /data/{activeMQData,| config, contour, elasticsearch, tenant}

5. On the respective destination servers, configure the Admin Console, and when prompted, select
Restore from backup file.

6. Save the settings and restart Jama Connect.

Setting up a test server
If configuring a test server, you must disable the following features before you create the backup on the
original server. Disabling these features prevents duplicate information from being sent out from both
your test and production environments.
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Make sure to disable these features:

• Legacy connectors such as the JIRA, TFS, and Rally connectors
• SMTP or IMAP

Troubleshooting

NOTE
This information applies to self-hosted environments only.

You can avoid troubleshooting by following regular maintenance practices [520], but if you run into prob-
lems here are some resources that might help:

• For issues with installation, log in to the Jama Connect as root user [489] and select the System Info
tab to see a quick overview of your installation.

• View log and profile [538] 
• Clear cache [530]
• View scheduled jobs [530]
• Index all items [531]
• Remove old Docker images [529]
• Reconnect to the Wiris server [540]
• Generate a support bundle [536] and contact support@jamasoftware.com

Generate a support bundle
A Support Bundle contains information about the application server and the Jama Connect installation.
The bundle, which includes support troubleshoot issues in your environment, includes thread dumps
[537], log files from the Admin Console, and the components that make up Jama Connect.

1. Generate a Support Bundle from the UI or command line of the application server.
• From the UI — In the header of the Admin Console, select Support, then select Down-

load Support Bundle.
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• From the command line:

replicated apps
replicated support-bundle <app_id>

<app id> is the ID of your application taken from the output of the first command.
2. Upload the Support Bundle to Jama Support: support@jamasoftware.com

For more information, see the community article: Jama Support Bundle: How do I get it, what's in it, and
which logs should I care about?

Thread dump
A thread dump is a snapshot of the state of your Jama Connect processes at a point in time.

Jama Support might request a thread dump for troubleshooting performance issues.

Any time you generate a Support Bundle [536], the bundle includes three thread dumps taken at 5-sec-
ond intervals.

TIP
Take multiple thread dumps over an interval of time. A single thread dump on its own
doesn’t provide complete information about an issue.

You can create a thread dump from the command line or the from the Logging Configuration window.

Manually (command line) Logging configuration window [538]

jamacli jamacore-thread-dump Select Logging > Configuration
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NOTE
You can create thread dumps only for containers that are the core Jama Connect appli-
cation.

View and configure logging
Log files record information from the application and can help with troubleshooting. Information is cap-
tured in the contour.log file.

Entries in the log file are noted by the [jama.AccessLog] package and include this information:

• Date of request
• Server processing time to handle the request
• The user who submitted the request
• The organization ID of the user who submitted the request
• The user session ID of the user who made the request
• The server address that the request was made to

Enabling the profiler logging enhances logging in Jama Connect. However, profiler logging might re-
quire additional resources to generate this content. For best performance, use the profiler for trouble-
shooting purposes.

The profiler prints out the following information:

• The user who submitted the call
• The organization the user belongs to
• The java thread ID of the call
• A stack trace of the call that includes processing time and memory usage of each trace

To view the log and configure logging:

1. Log in to Jama Connect as the root user.
2. Select Logging > Log Viewer to view the log. As needed, select Refresh at the top right to refresh

the log.
3. Select Logging > Configuration.
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TIP
By default all logging levels are set to info and will reset to that default when the
application is restarted [521]. 

To permanently change the logging level and appenders, edit the file:

/data/config/log4j.properties

The log configuration for Elasticsearch and search service can also be found in:

 /data/config

You cannot change the location to where log files are written. Changes to these
configuration files are applied within a few seconds and are persisted across re-
starts the application.

4. To change the logging level from the default setting of Info, select Edit.

5. To log additional content for every log entry in the contour.log file, scroll to the bottom of the page
and select Enable profiler under Profiling.
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Profiling is indicated in the log file as the [jama.Profiler] package.
Here is a sample log entry:

2011-04-28 09:37:19,865 INFO [org.directwebremoting.impl.DefaultRemoter] 
- Exec: projectSvc.getExtTreeNodeForProject()
2011-04-28 09:37:19,869 INFO [jama.Profiler] - user:admin org:2 
thread:96 start:2011-04-28 09:37:19,866
[3ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.Jama.dwr.impl.DwrProjectServiceImpl.getExtTreeNodeForPro
ject
[3ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.contour.service.impl.ProjectServiceImpl.getExtTreeNodeFo
rProject
[2ms] [+88K/-88K 837755K/254041K]- 
com.jamasoftware.contour.service.impl.DocumentTypeServiceImpl.getAvailabl
eDocumentTypesForProject

6. To capture information for all user requests and all locked-out users in Jama Connect, select Ac-
cess log, then select Enable access logging.
Information is captured in the contour.log file. Here is a sample log entry:

2014-08-29 16:24:59,370 INFO http-bio-8080-exec-17 [jama.AccessLog] - [3 
ms] PRBDIJN9 1 - 083BBE5B1E8C481033DA7AFBBEF023A5 160 http://
localhost:8080/contour/

7. To capture a one-time dump of the current running java threads being executed, select Dump
threads information under Thread dump.
Information is captured in contour-threaddump.log.
This information is useful for identifying long running processes. If Jama Connect seems to hang,
run a thread dump and send the log file to support@jamasoftware.com.

Reconnect to the Wiris server (self-hosted only)
If your connection to the Wiris server is interrupted, you can fix the issue by modifying the Wiris set-
tings, restarting your system, then returning the settings to their original values.

1. Modify the Wiris settings:
a. In the Admin Console, select Settings > WIRIS Connection Settings.
b. Select Use custom Wiris connection.
c. Make the following changes:
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• Wiris Host — Add “xx” to the end of the string
• Wiris Path — Add “xx” to the end of the string
• Wiris Port – Change to 44311

d. Select Save and restart your system.
2. Test the connection. Use Jama Connect in a field that calls the Wiris MathType Editor:

a. In Jama Connect, select Projects, and select the item you want to modify.
b. From the Add drop-down menu, select New item > Text.
c. In the Add item window, select the Math Editor icon.
d. Add an equation using the equation editor. As expected, this action fails.

3. In the Admin Console, reset the modified Wiris setting to the original values.
4. Select Save and restart your system.
5. Test the connection. Use Jama Connect in a field that calls the Wiris MathType Editor:

a. In Jama Connect, select the item you want to modify.
b. From the Add drop-down menu, select New item > Text.
c. In the Add item window, select the Math Editor icon.
d. Add an equation using the equation editor. This action now succeeds

Organization administrator
An organization administrator controls all aspects around the configuration of Jama Connect and the
user and groups. This is a role that can be assigned to an individual or a group.

An organization administrator can manage users [559], content [542], collaborations [609], and inte-
grations [622]. 

Most of the organization administrator tasks can be found under Admin in the top-level navigation. If
you don't see this, you don't have organization administrator permissions.

Many changes made in the organization administration pages require signing out before they take ef-
fect. By default, Jama Connect creates a group called Organization Admin and assigns it Administrator
and Manage project rights to the organization.

Monitoring changes with the Admin Activity stream
The Admin Activity stream provides an audit trail of updates made by organization and project adminis-
trators.

To open the Activity stream panel, select Admin, then select the Activity stream button on the right
side of the panel.
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Need to find something quickly? Search for activities by entering the search term, like the name of a
pick list or the user who performed the action.

Manage content
There are many areas of the application that require organization administrator permissions to set up
and maintain content for the broader group of users.

Change Global ID
Global IDs are unique identifiers of items that are connected through synchronization. While every item
has its own unique ID [628], two items that are synchronized can share a global ID.
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NOTE
You must have organization administrator permissions to complete this task.

You can change or add a prefix, as well as an optional item type key, in front of the Global ID assigned
to items.

1. Select Admin > Details, then select Edit.  

2. Confirm if you want to allow multiple items with the same Global ID in a single project.
• Yes — One item can be synchronized with one or more items in the same project.
• No — Items can only be synchronized to items in other projects. The default setting is No.

3. To change the Global ID Prefix Value and Item Type Key, select Edit.
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• Change only future prefixes: Change the Global ID Prefix and select Update. No current IDs
are affected. Future IDs include the new prefix.

• Change ALL prefixes (past and future): Select Apply prefix to existing items. All existing
prefixes are changed if they match the old prefix, and new IDs will contain the new prefix. If the
past Global IDs didn't have a prefix, the new one is appended to those IDs.

• Include item type in the global ID: Select Include Item Type Key. To change the item type key,
you must configure the item type [580].

4. To change the Global ID next counter value, select Edit.
5. Set the counter that assigns Global IDs, then select Update. If you set the counter to a value that's

being used, the counter uses the next available ID as its starting point when the next item is as-
signed.

Your changes appear in the Organization Details page.

Unlock items locked by another user
You must have organization and project administrator permissions to unlock items that are locked by
another user.

NOTE
Project admins can only batch unlock items from List View and Single Item View.

To unlock items that others have locked as an organization admin:
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1. Select the link with your name in the header to open the My profile window. This button is disabled
if you have the Admin button selected in the header.

2. Select the My locked items tab and check the box next to Show all locked items.

3. Locate the item in the list you want to unlock and select it. Select the Unlock button.

To unlock items that others have locked as a project or organization admin:

From List View

1. Select the item you want to unlock, then click Batch edit.

2. In the Batch update window, select Locked Status > Unlock all items, then click Next.
3. (Optional) Add a comment and notify users.
4. Click Commit.

From Single Item View
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• Select the item you want to unlock, then select Unlock item.

TIP
If you are an organization or project administrator, you can also access the system-
locked items tab to unlock system locked items [546].

Unlock system-locked items
Anyone can view the list of system-locked items regardless of permissions.

IMPORTANT
Organization admins can unlock system-locked items.

System-locked items can be unlocked by a project admin with admin permissions for
those items.

1. Select your name in the header to open the My Profile window.
2. Select System Locked Items to see all items that were automatically locked [200] (blue lock).

3. Select the items you want to unlock, then select the Unlock button in the top right corner of the
window.

Configure reuse and synchronization
You must have write permissions [574] to modify items through synchronization. Items with a user lock
[544] or system lock [546] can't be modified through synchronization.
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NOTE
You must have organization administrator [541] permissions to complete this task.

As an organization administrator you can:

• Grant permissions to a reuse administrator [574]
• Configure global ID [542]
• Sync or remove Compare Views [289]
• Enable synchronization of widgets [584]
• Prevent users from synchronizing items [284]

System health report
The system health report is an optional feature that notifies you of areas of the application that can af-
fect performance and user experience.

Projects that are too large, reports that contain too many items, and syncing too many items at a time
are just a few of the things that can slow Jama down and cause problems. This report can be emailed
to designated users weekly.

NOTE
You must have organization administrator permissions to view the system health re-
port.

1. To view the report, select Admin > Organization, then select System health report.
2. Select Add or change recipients to add or modify who receives the report.

3. You can set a threshold for each of the areas (Projects, Reviews, Reports and Test Plans) by se-
lecting Edit the threshold.
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Plugins

IMPORTANT
You must be an organization administrator to complete this task.

There are two plugins you can install:

1. User import plugin [552]
2. Import relationship plugin [548]

Configure Import Relationships Plugin
The Import Relationships Plugin helps you batch create relationships between existing items in the ap-
plication.

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Plugins > Add plugin entry.
2. In the Add plugin entry window, enter the following information and select Save.

• Name: Import Relationships (or whatever name you want visible to users)
• Enabled: Check this box to make the plugin available to users.
• Class (case sensitive):  Enter the name of the object defined in the source code. For a single

project enter: 

com.jamasoftware.contour.plugin.jama.ImportRelationships

For cross-project imports enter:
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com.jamasoftware.contour.plugin.jama.ImportRelationshipsCrossProject

• Type: Import
• Parameters:  Set relationship parameters [549]
• Plugin notes: Add any notes you have here. This will not be visible to end users.

3. When the information is correct, select Save. 

TIP
For a sample entry of a cross-project import, see Set relationship parameters
[549].

Set relationship parameters
Depending on whether you want to import relationships in a single project or multiple projects, there will
be four or six parameters to complete.

NOTE
You must have organization administrator permissions to complete this task.

Cross-project import sample entry
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These parameters are used when configuring the Import Relationships Plugin [548]:

• parentType: Defines which item type to use for the parent (upstream) relationship.
• childType: Defines which item type to use for the child (downstream) relationship.
• parentField: Defines which field to use to find the the parent (upstream) item.
• childField: Defines which field to use to find the child (downstream) item.
• parentProjectId: Defines the project that contains the parent (upstream) item. Only for the cross

project plugin.
• childProjectId: Defines the project that contains the child (downstream) item. Only for the cross

project plugin.

Parameters can be written in any order, as long as they follow correct formatting. Each parameter is
case sensitive and requires a semicolon at the end.

Gathering parentType and childType values

To specify the item Types, you need the API IDs of the item Types to be related. You can find the API ID
under Admin > Item Types.
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For example, if you wanted to create relationships for upstream Requirements to downstream Use Ca-
ses, you join the item Type with the corresponding API-ID:

parentType=24;

childType=25;

Gathering parentField and childField values

The CSV file used for import needs to contain an identifying field for each item, such as the Name or
Global ID. To specify which field in the parent and child item will be used for this identification, use the
system Field value. You can see which fields are available to use under Admin > Item Types > [High-
light the item type to be used] > Config.

For example, if you wanted to use the ID (also known as the Unique ID) for your parentField and child-
Field, your parameters need to join the field type with the field value:

parentField=documentKey;

childField=documentKey;

Gathering parentProjectId and childProjectId values

To specify which projects the parent and child items are associated with, you need the API-IDs of both
projects. You can get the project API-ID under Admin > Manage all project > [select the project to
be used] > API-ID.
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For example, if you wanted to import relationships between a parent project with API-ID 20258 and a
child project with API-ID 31548, your parameters need to join the item with the corresponding project
API-ID:

parentProjectId=20258;

childProjectId=31548;

Configure User Import Plugin
With the User Import Plugin, organization administrators can add multiple users at once by importing a
spreadsheet. Imports don't delete users from Jama Connect.

NOTE
You must have organization administrator permissions to complete this task.

With the User Import Plugin, organization administrators can add multiple users at once by importing a
spreadsheet. 

1. Select Admin > Organization, then select Plugins > Add plugin entry.
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2. In the Add plugin entry window, enter the following information and select Save.

• Name: User Import
• Enabled: Make the plugin available to users
• Class (case sensitive):  Enter the name of the object defined in the source code: 

com.jamasoftware.contour.plugin.jama.UserImportPlugin

• Type: Event or Import
• Parameters: Leave this field blank
• Plugin Notes: Add any notes you have here. This isn't visible to the end user.

3. Create a CSV document with no header row that contains the following values in columns A
through K:
• Username

If LDAP or CROWD is enabled, the username must match what is listed in the directory.
• First name
• Last name
• Email
• Password
• Title
• Location
• Phone number
• License type

Values must be one of the following:
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• Add/Update
Values must be one of the following:

• Company
• Groups

If a user belongs to multiple groups you can add them in columns L and up.
For example:

4. Select Project > Import > Custom import to open the Custom Import window.

5. Enter the following information in the Custom import window:
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• Select a destination: This is a required field. Your selection doesn't affect the outcome.
• Select Custom Importer: User Import
• Field Delimiter: Comma
• Optional Encoding: UTF8
• Select file to import: Choose the CSV file you created in step 3, that contains the list of users to

be imported.
6. Select Import. Each user that's added with the user import plugin receives a welcome email with

the Jama Connect URL.

IMPORTANT
If the import fails it might be because:

• A user that already exists was set to add (rather than update).
• A user that does not exist was set to update (rather than add).
• One or more of the records is incorrect.
• A required field was missing.

Upload custom reports or exports

NOTE
Self-hosted customers with system or organization administrator permissions can com-
plete this task.
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You can upload reports [353] or exports [294] so that other users can access them.

If you're uploading a Velocity or Office Template export that uses pre-selected data in the main panel,
the exports appear under Exports > Office Templates. If you're uploading BIRT or Velocity reports that
pull data at a project or cross-project level, they appear under Reports in the Jama Connect header.
Read more about Jama Connect and Velocity here.

TIP
Before uploading a report or export, check with the person who created it about the
best settings to use because report criteria is unique to each one.

To upload custom reports or exports:

1. Log in as root user [489] and select Reports. If you're an organization administrator for a self-hos-
ted instance, select Admin > Reports. This shows a list of all currently available reports or export
templates.

2. Select Add report in the top right corner to open the Add/Edit Report window.
3. Enter a name for the custom report or export template so that other users can identify it.
4. Select the report or export template type (BIRT, Velocity, or Microsoft Office Template), and the for-

mat you want to use.

NOTE
For templates with Microsoft Word or HTML formats, the option to export the re-
port to PDF is also available.

For Office Templates, any user with a creator license can add their own custom
export [302] to make it visible under Export > Office Templates.

5. To define availability for reporting, select the Data Access type.
6. To limit access to run custom reports based on user permissions and by user group, select the

Restrict to Group type.
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7. Next to Report File Name, select Choose File to open a window where you can select the report
or export template you want to upload. BIRT reports have the file extension .rptdesign. Velocity re-
ports have the file extension .vm.

8. Enter a Description that helps users understand the output.
9. Use Scope, to determine whether the report or export template is available to all users (Organiza-

tion) or only users in a particular project (Project). Default reports that come with Jama Connect
have a scope set to System.

10. Select Visible to Users for it to appear in the application. 
11. If you're uploading a Velocity export that only applies to data referenced on the user's main panel,

select Context Sensitive. This export appears in the window that opens when users select Ex-
ports > Office Templates.

12. (Optional) Class name and path is only used for custom plug-ins for BIRT or Velocity reports and
can be left blank. 

13. For Office Templates, set any parameters [370] you want to use in the report or export template.
14. In the Criteria section, select the plus sign to add criteria for this report or export template.

• From the drop-down menu, select the type of data for this individual criteria. For example, select
"Release" for it to pass in a release ID, or "Baseline" for it to pass in a baseline ID.
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• For Display, enter the label you want users to see. This name is what the user reads when pub-
lishing the report and exporting from Jama Connect and describes the expected input from the
user.

• For Name, enter a case-sensitive name that is passed to the report or export template. Each pa-
rameter in a report or export template must be unique. When users publish a report or export
Jama Connect content, these are displayed in alphabetical order by the name field, not in the
order shown in the report setup screen.

TIP
If you're editing an existing report or export template, and you change the Name
criteria, you must change the reference to the criteria in your report or export tem-
plate or it breaks.

15. Select Save to upload the report or export template and save your changes.

Report parameters
You might need to select one of the following report parameters when uploading custom reports.

NOTE
Only system administrators with access to editing reports can make these changes.
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• Release — Shows all project releases in a pick list. The user can select release parameters as nee-
ded.

• Location — Shows the project hierarchy in a pick list. The user can select a location for each loca-
tion parameter.

• Baseline Parameter — Shows all baselines in the project in a pick list. The user can select one
baseline for each baseline parameter.

• String Parameter — Presents the user with a text field to enter a string.
• Date Parameter — Presents the user with a text field to enter a date.
• Boolean — Presents the user with a checkbox. The value "true" or "false" is sent to the reporting

engine.
• Test Plan — Presents the user with a pick list of test plans in the selected project. Jama Connect

passes the database ID to the report.
• Review — Presents the user with a pick list of reviews in the selected project. Jama Connect passes

the ID to the report.

Manage users
As an organization or user admin, you can set up user access for your organization.

• Add user groups [560]
• Add users [561] and assign them to one or more groups
• Open projects and assign users and groups access rights [644]

You can also assign this task to a project administrator.
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User groups
User groups are an efficient way to manage notifications, permissions, access, and actions for multiple
users at a time.

You can create groups based on the users' roles, permissions or position so you can efficiently:

• Grant access permissions [574]
• Grant role permissions [577]
• Initiate a review [157]
• Subscribe users to items [195]
• Notify users of changes [194]
• Send workflow notifications [634]
• Grant access to projects workflow [599]
• Add signer roles to reviews [224]

TIP
Users can be assigned to multiple groups.

Jama Connect includes two types of groups:

• Organization group — These groups have no project context and are available to all projects in the
organization when adding permissions.

• Project group — These groups are created in the context of a project and are available to that spe-
cific project when adding permissions.

Name groups in a way that works well for your organization. You might use your internal structure (such
as job title or work group), or name groups by access permission (read only, read/write), or roles (reuse
admin, review admin, project admin). If you're using signer roles [224] for electronic signatures [222],
the group name is used as the signer role.

By default, Jama Connect comes with a number of pre-defined organization and project user groups.
For example, the group Organization Admin is a default group that has organization and project rights.

Add, edit, or delete user group
Organization administrators can delete a group or make changes to an existing group's members, de-
tails, or subscriptions.

NOTE
You must have organization administrator permissions to add or delete user groups
available to all projects. A system administrator can also add groups by following the
steps below. A project administrator can also add groups at a project level [642].

1. Select Admin > Organization > User groups, then select Add group.
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Note: Project groups that a member of the project is in determine which groups are available for
the signer roles.

2. In the Create Group window, enter a name and description for the group, and select members by
their username. Large lists are searchable.

3. Select Save.
The new group appears in the table.

The review moderator now has the ability to edit a review and give a user a signer role [224].

Add new user
If this is a new installation, it's better to add user groups [560] before you add individual users, so you
can manage users, permissions, and security more efficiently.
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NOTE
You must have organization administrator permissions to complete this task. A system
administrator can also add new users [491].

To add multiple new users, configure the user import plugin [552].

To add users individually:

1. Select Admin > Organization, then select Users to display a list of active users.
If you don't see the user you're looking for, select View inactive users.

2. If LDAP is enabled [504], you can select Add user from LDAP and search for an existing LDAP
user in the search box.  Jama Connect searches LDAP against the configured "Login Name Attrib-
ute" and the "User Name Attribute." You can add wildcards to a search, but if you add them at the
beginning of a search term, they can result in slow performance. For large directories, expect sev-
eral minutes.

3. From the toolbar, select Add user.
4. In the Add user window, fill in the required fields, then select Save.

• Username
The username must be unique so using an email address is recommended.

• License type
Keep in mind the number of licenses purchased [569] and the expected usage [571] by the
user when assigning license types. 

• User groups
Consider how you use groups to manage users, permissions, and security [560], then select the
appropriate groups for this user.

• Send email to new user
Send an email to the user with their username, password, and URL to log into the system.

Configure User Import Plugin
With the User Import Plugin, organization administrators can add multiple users at once by importing a
spreadsheet. Imports don't delete users from Jama Connect.
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NOTE
You must have organization administrator permissions to complete this task.

With the User Import Plugin, organization administrators can add multiple users at once by importing a
spreadsheet. 

1. Select Admin > Organization, then select Plugins > Add plugin entry.

2. In the Add plugin entry window, enter the following information and select Save.

• Name: User Import
• Enabled: Make the plugin available to users
• Class (case sensitive):  Enter the name of the object defined in the source code: 

com.jamasoftware.contour.plugin.jama.UserImportPlugin

• Type: Event or Import
• Parameters: Leave this field blank
• Plugin Notes: Add any notes you have here. This isn't visible to the end user.

3. Create a CSV document with no header row that contains the following values in columns A
through K:
• Username

If LDAP or CROWD is enabled, the username must match what is listed in the directory.
• First name
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• Last name
• Email
• Password
• Title
• Location
• Phone number
• License type

Values must be one of the following:

• Add/Update
Values must be one of the following:

• Company
• Groups

If a user belongs to multiple groups you can add them in columns L and up.
For example:

4. Select Project > Import > Custom import to open the Custom Import window.

5. Enter the following information in the Custom import window:
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• Select a destination: This is a required field. Your selection doesn't affect the outcome.
• Select Custom Importer: User Import
• Field Delimiter: Comma
• Optional Encoding: UTF8
• Select file to import: Choose the CSV file you created in step 3, that contains the list of users to

be imported.
6. Select Import. Each user that's added with the user import plugin receives a welcome email with

the Jama Connect URL.

IMPORTANT
If the import fails it might be because:

• A user that already exists was set to add (rather than update).
• A user that does not exist was set to update (rather than add).
• One or more of the records is incorrect.
• A required field was missing.

Add users to multi-mode authentication
Multi-mode authentication allows you to add a new Basic user, so you can differentiate between IdP
and Basic users.

Important considerations

• Authentication methods must match to use electronic signatures in baselines and reviews. An organi-
zation admin can change authentication methods.

• Users can't use the same email between the two different authentication types.
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NOTE
You must have organization admin permissions to complete this task.

1. Select Admin > Organization, then select Users to display a list of active users.
2. Select Add user.

3. In the Add user window, select the authentication type you want for this user:
• Basic authentication — Select Use basic authentication for this user.
• IdP authentication — Deselect Use basic authentication for this user.

4. Click Save.

Jama Connect runs a check to see which authentication method was used. Initially, the Authentication
Type for the user you added is blank. When they log in for the first time, the column is populated with
Basic or IdP.

You can also verify the Authentication Type from Admin > Organization > Users.
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Edit user details

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Users to display a list of active users. If you can't find
them, select View Inactive Users.

2. Select Edit in the Action column of the user you want to edit. This opens the Edit User window.
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3. Select Save.

Edit user or group subscriptions
Users can subscribe to email notifications. Administrators don't have control over a user's own subscrip-
tions, only to subscriptions added by others. Only the user can control their subscriptions.

NOTE
You must have organization or project administrator permissions to complete this task. 

1. Select Admin > Organization, then select Users.
2. Select Edit subscriptions in a user row to open the Edit subscriptions window.

3. Select the user you want to edit from the left column. On the right you see a list of their current
subscriptions. 

4. If you're an organization administrator, select Unsubscribe in the Action column or to remove mul-
tiple subscriptions, select the subscriptions you want to remove, then select Unsubscribe selec-
ted. If you're a project administrator, select the items you want to mute and select Mute subscrip-
tions.
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TIP
Organization administrators can also edit group subscriptions by selecting Admin >
Organization > User groups > Subscriptions.

Reset user password

NOTE
You must have system or organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Users to view a list of users.
2. Select Password in the Action column for the user whose password you want to change.
3. In the Edit password window, enter and confirm a password that meets the default authentication

requirements.

License types and permissions
The license type limits the possible permissions and roles that can be granted to a user. For example,
creator, stakeholder, test runner, and reviewer.

Each user, regardless of license type, has a unique login (username and password). Organization ad-
ministrators can view the current license [573] or assign users license types [567].

Creator and reviewer licenses can be named or float licenses, whereas test runner and stakeholder are
named only.

These are the available user license types:

• Creator
A creator license is a named or floating license that gives full read and edit rights, and full access to
reviews, for those who are active users managing items and projects on a daily basis.

• Test runner
A test runner license is a named license that focuses on users whose primary goal is execution and
recording test results. This includes basic permissions to read and review, as well as the additional
ability to create test plans and defects, and execute test runs. They can also add attachments to test
runs during execution.

• Collaborator
A collaborator license is a legacy license that can be a named or floating license that gives read-only
privileges to those who need visibility into a project, but don’t need editing rights. These users can
view items, provide comments, participate in (but not create) reviews, execute test runs, and log de-
fects. The stakeholder license is recommended for users who only need read access, and the test
runner is recommended for users who need full access to test center and defect recording capabili-
ties.

• Stakeholder
A stakeholder license is a named license that gives read-only privileges to those who need visibility
into a project, but don’t need editing rights. Stakeholders can view items, provide comments and act
as reviewers.

• Reviewer

Jama Connect User Guide

569



A reviewer license is a named or floating license that grants permission to participate in reviews, act
as approvers, moderators, or review administrators, and respond to comments in the stream. A re-
viewer license doesn't allow users to initiate reviews or access items in the core project.

• Temporary
A temporary license is a 30-day full creator license, automatically granted to a non-licensed individual
whose email address is used to invite them to a review or to comment in the stream. It has no default
permissions except for the discussion thread or review to which they were invited, although an organ-
ization administrator can add permissions.

Permissions by license type
Your license type defines your permissions, which determine your ability to create and edit items or ac-
cess them as read-only.

If you have a Creator license and read-only permissions to a project, you can:

• Execute test runs
• Log defects from the test run execution window

** Permissions that are included with each license type.

Configure Jama Connect for test runner license
Users with a test runner license can only manage attachments and relationships, and edit certain items
for tests. For example, test plans, cycles, groups, runs, as well as item types used as defects [309].
They don't have permissions to manage attachments and relationships, or to edit items in the rest of the
project.
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IMPORTANT
You must have organization administrator permissions to configure Jama Connect for
the test runner license type.

If your organization has purchased a test runner license type, you must make the following changes in
Jama Connect:

• Configure item types to be used as a defect [585]
• Assign access permissions [574]

Batch update license types
Occasionally, you might want to update many users at once. For example, several users might be as-
signed a temporary license that's about to expire and you need to assign creator licenses.

If you select more users than the number available of your selected license type, that license type isn't
available when batch updating.

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Users.
2. Sort the users by license type by selecting the field name header at the top of the user grid.
3. Highlight the users to be updated. Use Shift or Cmd-click to select multiple.
4. Right-click or Ctrl-click and select Batch Update User(s).

5. In the window that opens, select the license type, then select Commit.

Monitor license usage

NOTE
You must have system or organization administrator permissions to complete this task.

1. Select Admin > Organization, then select License.
2. In the center panel you can see a display of daily usage by floating license type for a particular time

period, as well as detail of current usage.
You can view stats from the last 7, 30, or 90 days, including the number of float licenses being
used on a daily basis, the number of days where you reached your maximum threshold, and if
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any users were denied access due to a lack of float license availability. Use the menus in the head-
er to select the type of license and the time period you want displayed.
Each gray bar represents the highest number of floating licenses that were concurrently in use on a
given day. By clicking on one of the gray bars, you are able to see an hourly breakdown of license
usage throughout that day.

NOTE
This chart isn't a a live look at license usage. It provides an hourly snapshot of the
licenses that are in use at that time. The data is also stored in UTC time, so when
viewing the hourly breakdown you must adjust for your current time zone.

Scroll down to see all of your license information such as license type, expiration date, how many
licenses are owned, as well as any integrations the organization has purchased. For more informa-
tion, see View license [573].

3. Select the gear icon in the upper right to open the Configure License Usage View window. Se-
lect Notify me when this threshold is met and enter an email address to send notifications when
usage surpasses a specified threshold. 
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View license
View details about your license, such as the type and expiration date.

NOTE
You must have system or organization administrator permissions to view the licenses. 

• To view your current license information, select Admin > Organization, then select License.
For organizations with floating licenses, information about float license usage is available above the
table (more information is available here [571]).
The table provides details about the license, such as the type and expiration date. Counts are also
provided by specific user license type, as shown in this example:
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Grant permissions
Permissions allow users to do things such as access, modify, and delete items or perform other specific
tasks. Permissions control how users experience Jama Connect by restricting actions they can perform
or content they can see.

NOTE
To grant most permissions, you must be an organization or user administrator. A sys-
tem administrator [492] grants limited permissions and a project administrator [644]
grants only project-level permissions. Project administrators can access users outside
of their project to give access when the Organization detail configuration Allow project
administrators access to all users and organization groups is enabled.

IMPORTANT
 Risk administrator permissions are managed separately [577].

Risk Management [372] requires additional licensing for your organization, as well as
creator, stakeholder or test runner licenses for all risk management participants. Con-
tact your Jama Software account manager for more information.

1. Select Admin > Organization, then select Permissions.
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2. In Project Selector on the left, select the organization, an individual project, or container, depending
on the level you want to grant permissions. 

TIP
Permissions set at the organizational level are passed on to lower levels, but
might be overridden for individual projects, components or sets. For simplicity, we
recommend setting permissions at the highest acceptable level.

Organization administrators can also grant project permissions in the configure
project window [644].

3. The main panel displays current permissions that were granted. Select Modify or Override to edit
current user or group permissions. To add a new user or group, select Add permissions in the top
right.

NOTE
Permissions are inherited from higher levels in the organization structure. For ex-
ample, if you assign a group access at the organization level, all projects, compo-
nents, and sets within the organization inherit the permissions.

When a group or user's Inherited column contains the value "true" and is highligh-
ted in green, that user or group has received its permissions from a higher level.
Select Override to change their permissions.

Also, certain permissions are allowed with each license type [569]. You might
need to assign the correct license type [567] to change permissions. Also, be
aware of how permissions work with related items [265].

4. If you select Add permissions, the Assign permissions window opens, and you can select the
groups or users you want to add.

TIP
Before assigning permissions, consider setting up groups [560] to make this task
more efficient.
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You can also add a new group or user by selecting New user or New group in the top right corner
of the window. Then select the role or access permissions [646] you want to add at the bottom of
the window and select Save.

NOTE
Roles [577] and access permissions can be granted at an organizational level.
Project administrator permissions can be granted at a project level. Access per-
missions can be granted at a container level and greater. 

5. Alternatively, select Remove at the level that access was granted to remove access to a project,
component, or set completely by unselecting all permissions.

IMPORTANT
Remove functions differently at lower levels in the hierarchy. If the user or group's
permissions were previously overridden at that level, the Inherited column shows
"false," and selecting Remove reverts the permissions back to the original inheri-
ted permissions. If the user or group's permissions haven't been previously over-
ridden, the Inherited column shows "false," and selecting Remove completely re-
moves the group or user from a project or set. If the group or user's permissions
are inherited, the Inherited column reads "true" and permissions can only be re-
moved at the higher level where they were assigned.

NOTE
If a user is part of multiple user groups with conflicting permissions, the user's given
the highest permissions that are set. 
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IMPORTANT
While items within sets fall under the permission rules of the set, attachments to those
items don't. Attachments can still be accessed by outside users who have access per-
mission to the project while adding attachments [133] or inserting rich text links [99].

Assign risk administrators
A risk administrator has full permissions to create and edit risk templates, analyses, and manage partic-
ipants.

NOTE
You must be an organization administrator to assign a group of users to be risk admin-
istrators.

A risk administrator [376]:

• Must have a creator license.
• Has full permissions to create and edit risk templates and analyses and manage participants.
• Can view and manage all risk analyses created in the system.

To assign risk administrators:

1. Choose an existing group (or first create a new group [560]) for risk administrators. 
2. Select Admin > Organization, then select Risk management.

3. Select a group from the drop-down menu. You can grant risk administrator permissions to multiple
groups.
The groups appear below the drop-down menu on the Risk management page.

Roles
A role is a set of permissions granted to a user so that they can perform particular functions.
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NOTE
Permission roles are different than review roles [153], risk roles [399], and signer roles
[224].

The permissions included with each role [649] can be granted by an administrator [646] to an individ-
ual or a group.

These are the roles and the type of license they require:

• System administrator [468] 
The system administrator handles the overall installation, setup, and configuration of Jama Connect,
and doesn't have access to projects. The system administrator is a special user and not a role that
can be provided to other users. This user doesn't require a license and logs in to the system with the
username "root."

• Organization administrator [541] 
An organization administrator controls all aspects around the configuration of Jama Connect and the
user and groups. This is a role that can be assigned to an individual or a group.

• User administrator [559]
The user administrator provides the ability to manage licenses, users, and groups. This is a role that
can be assigned to an individual or a group. This user can see all users and organization groups in
the system.
The user administrator can only set permissions for groups/users on projects where they are a project
administrator. They are also limited to managing organization group membership for only groups
where they are a member, which prevents a user admin from giving access to projects where they
don't have access.
User administrators can't make changes or additions to users or groups that have been assigned to
organization and process administrators with the exception of activation/deactivation and license
management.

• Process administrator [580]
The process administrator role focuses on the configuration of content and connections within Jama
Connect.
• Item types
• Pick lists
• Relationship rules
• Review Center
• Risk management
• Workflow

• Project administrator [624] 
A project administrator is a role that can be provided for all projects or on a specific project with a
focus on permissions, project groups, and workflow customization.

• Add Project
The Add Project is a very specific role that is meant to exist between the organization administrator
and the project administrator. With this role, a user can create a new project or duplicate an existing
project where that user is a project administrator.

• Review administrator [178] 
A review administrator is a role with the permissions needed to manage reviews.
Review administrators can view all reviews and perform administration tasks for those reviews, re-
gardless of whether they were invited to the review. A review administrator is the only one who can
delete a review

• Reuse administrator [282] 
A reuse administrator is a role with the permissions needed to manage reuse.
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In addition to reuse permissions, a reuse administrator needs read access for visibility of any
synchronized items they are working with, and write permissions for making edits, synchronizing, re-
using, or duplicating.

• Risk administrator [376]
A risk administrator can create and edit risk templates, as well as manage analyses and participants.
An organization administrator can grant risk administrator permissions [577].
Risk Management [372] requires additional licensing for your organization, as well as creator, stake-
holder or test runner licenses for all risk management participants. Contact your Jama Software ac-
count manager for more information.

IMPORTANT
Users must have the license type [569] that allows for the permissions granted with
each role.

Deactivate and reactivate users
You must have organization administrator permissions to deactivate a user. When you deactivate a
user, the user becomes inactive and frees up named assigned licenses associated with that user.

IMPORTANT
Users can't be deleted from Jama Connect.

1. Select Admin > Organization, then select Users. 

2. In the Action column for the user you want to deactivate, select Deactivate.
3. Deactivated users disappear from the list until you select View inactive users to view all users.
4. Alternatively, to reactivate a deactivated user, select Activate.
5. In the User license type window, select a license type and select Save.
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Manage process
Best practices are a great starting place, but every organization has unique needs and Jama Connect
can be configured to align your processes and artifacts. To address these needs, Jama Connect pro-
vides the ability to control fields, picklists, relationships, templates, and workflow.

These settings tend to evolve over time as teams mature and new groups are brought into Jama Con-
nect. An admin role is available to delegate these responsibilities to the appropriate users and groups.

• Item types [580]
• Fields [588]
• Set up editor templates [600]
• Configure views [600]
• Manage relationships [601]
• Manage tests [609]

Item types
Item types are the templates for sets used within each project.

While sets are unique to each project, item types can be used in projects [626] across the entire or-
ganization. Item types cannot be customized for individual projects.

Each item type can be configured [580] to best fit your organization and methodology. The fewer item
types that your organization creates the easier it will be to manage items.

Additionally, every item type is automatically assigned an API ID for reporting purposes. That API ID
cannot be specified or changed.

Add and edit item types
Changes to item types affect all projects in your instance of Jama Connect. You can define an item type
once, and all projects have access to that type. Item types can't be customized for individual projects.

NOTE
You must have organization administrator permissions to add and edit item types.

You can create a new item type, add or delete fields [589] in an existing item type, or change the item
type details. 
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TIP
The fewer item types that your organization creates, the easier it is to manage items
and report on the sets based on those item types.

Jama Connect comes with a set of core item types that cannot be deleted. You can tell
which item types these are by selecting Admin > Organization > Item types and
viewing which item types don't have a delete option.

You can see a list of core item type fields in Admin > Organization > Item Types >
Core > Views > Projects List View -Mixed Item Types. Custom fields can't be selec-
ted for visibility in mixed item type views.
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1. Select Admin > Organization, then select Item types.
2. To add a new item type, select Add item type, or to edit an existing item type select Edit for the

item type you want to modify. 

3. This opens the Add item type window where you can select or modify the following options:
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• Display
Display name for a single item of this item type (Required).

• Display plural
Display name for multiple items of this item type (Required).

• Description
For others who may at a later point want to know internally how this item type is used or how it is
distinguished from other item types.

• Type key
This is the default ID Prefix that will be shown when creating a set using the item type. It can be
overwritten. (Required).

• Use as
Select an option only if you are using this item type for special use for test [309]. (If you are using
the REST API to create an item type, it refers to this as a Category)

• Widgets
Read more about item type widgets [584] or how to enable or disable them [584].

• Image
Display icon to use for this item type (this is required). Icons are used as the set icon, the list
view icon and the icon at the upper-left of the item view.

• API ID A new item type will automatically be assigned a reference ID for API reporting purposes.
You can see this ID by selecting Admin > Item types, but it cannot be specified or changed.

4. Select Save.
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NOTE
In order to use item types in a particular project, a project or organization administrator
must add the item type to the project [626].

IMPORTANT
You can delete an item type, however you will be asked to delete any existing items of
that type prior to deletion. To delete, select the item type you want to delete and select
Delete.

Item type widgets
Widgets are small embedded applications that add functionality to item types. Available widgets include:

• Activities [207]
• Attachments [133]
• Change request  [229]
• Links [130]
• Relationships [255]
• Risk [415]
• Synchronized items [284]
• Tags [131]
• Versions [227]

Enable or disable item widgets

NOTE
You must have organization administrator permissions to complete this task.

To enable or disable widgets:

1. Follow instructions to edit an item type [580].
2. Enable widgets by selecting the widget's name [584] in the Inactive widgets column. It will move

over to the Active widgets column.

NOTE
The change request item type should only be used for change requests [229].
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NOTE
Adding the relationship widget will automatically add the the Relationship Status
Indicator [265] as well. They can not be used separately.

3. In the Active widgets column, the links, tags, attachments and relationships widgets have a gray
synchronize toggle button next to their name. To indicate whether or not each widget can be
synchronized, use the synchronize toggle button for each item. When the button is darker, it indi-
cates that the widget can be synchronized.

NOTE
If you disable synchronization for a specific widget, when an item of that type is
synchronized, that widget will not be included in synchronization, nor will that
widget be taken into account when sync status is calculated.

4. To disable a widget select the X next to the widget's name in the Active widgets column.

Use a different item type as a test case or defect
You can use any item type as a defect or a test case. By selecting test case, this adds test steps and
test case status to that item type.
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NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization > Item types.
2. In the same row as the item type you want to change to a test case, select Edit.
3. In the Add/Edit item type window that pops up, select the pull-down menu next to the Use as field

and select one of the options. Select Test case or Defect.

4. Select Save. 

Enable rich text in test steps

NOTE
You must have organization administrator permissions to complete this task.
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1. Select Admin > Organization > Item types.
2. Find the item type you want to use. You can use any item type that is a Test Case type (this may be

an item that's used as a Test Case [309]). Select Fields in that row.
3. In the right panel, select the Steps field, then select the Edit pencil icon.

4. In the Edit field window, select Allow Rich Text and click Save.

IMPORTANT
To disable rich text in test steps, follow the same steps, unchecking the Allow rich text
box.

If you do so, no data will be lost, but images and rich text will be replaced with HTML
tags.

Users will not see any existing steps break and the content will still render. It is up to
the users to decided what formatting tags to remove. The application does not auto-
matically strip tags, and renders correct HTML tags in steps with or without the rich text
mode enabled.

Change a set key
You can edit a set ID or renumber items in a set at any time.
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NOTE
You must have organization or project administrator permissions to complete this task.

1. Select Projects, right-click on the set you want to modify, then select Change set key.

2. In the Confirm Set Key Change window that opens, enter the new set key, which must be 1–16
characters long, consisting of only letters, numbers, or underscores.

3. Select Regenerate Item IDs to reset the counter and apply new numbering to all existing items.
Item counters start over at 1.

CAUTION
Don't select Regenerate Item IDs if you want to restart numbering on newly cre-
ated items. Leave existing items as they are.

Fields
A field holds a basic unit of data in an item type.

Fields contain values. In List View, each column represents a different field. Individual users can config-
ure which fields they see. For more information, see Configure Compare View for synchronized items
[292] and Configure fields [55].

An organization administrator can add new fields to an item type [589] and configure the behavior for
those fields.

There are three types of fields in Jama Connect:

• Predefined fields
An organization administrator can add predefined fields [593]. They are indexed and can
be searched without using the database field name.

• Custom fields
An organization administrator can add custom fields [594]. They can be similar to predefined fields,
or can be multi-select fields, URL fields, rollup, and item of type fields. 

• System fields
System fields (like, name,  test steps [309], test case status [311] and review status [154]) are auto-
matically created to provide system functionality and cannot be disabled or deleted.
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TIP
Predefined fields can be very similar to custom fields. If you plan on doing a lot of re-
porting with your data, predefined fields will simplify the document type's underlying
schema and make it simpler to use those fields in reporting.

Add, edit, and delete fields
When editing an item type [580], you can add, edit, and delete fields.

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization > Item types. 
2. Select Fields for the item type you’d like to change to open an Item type fields panel on the right.
3. You see a list of existing fields with information about each one. Here you can select a row to high-

light it in blue, then select one of the icons in the top toolbar:

• Edit a field
Select the pencil icon to open the Edit field window.

• Reorder fields
Use the green up and down arrow buttons.

• Delete a field
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CAUTION
Please consider the following before deleting a field:

• Once a field is deleted, all values related to that field will be deleted from the
database and cannot be recovered.

• If the field was used to relate synced items (JIRA KEY, proxy, etc.), a dupli-
cate item will be created if you try to create the sync again.

• If the field is mapped in an integration, that field will no longer update and
could cause errors in your integration tool.

• If filters used the field, filter results will become inaccurate. The filter should
be updated before removing the field.

• If the deleted field raised suspect links, relationships will be affected. Because
the field no longer exists, users will not be able to see the changes that cre-
ated the suspect link.

• If you attempt to restore a previous version of an item that still contains the
deleted field, the field's contents will not be restored. Even if you recreate
the field prior to the version rollback, data will not be restored.

• If you still want to delete a custom field, consider exporting a copy of
those field values via a report or the API.

To delete a field select the field then select the red x icon.
• Add a field

Select the green Add field icon to open the Add field window. 
4. If you selected Add or Edit, a window will open where you can select the following options:
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• Select a field type
If you are adding a new field, you must first indicate what type of field. Select either a predefined
field or custom field. Both field types can be used in the same item type. (This section does not
appear when editing fields). 

IMPORTANT
You can only use the system predefined Release field to show items in the Re-
leases tab. If you use a custom Release field to designate an item to a release,
that item will not appear in the Releases tab. 

• Field label
This is the field name that users will see.

Jama Connect User Guide

591



CAUTION
When creating a new field, the application automatically uses the field label that
you enter to name the unique field name in the database. Once it has been
saved, even though you can change the field label, you can't change the
unique field name in the database.

Avoid leading with an underscore when naming fields. There are some unique
field names that may conflict with Elasticsearch fields (like "_source" and "_ID")
and prevent proper functioning.

• Unique field name
This is the name of the field in the database.

• Read only
Select this box to prevent users from editing the field. 

• Allow API overwrite
Fields that are configured to be read-only have the option to be editable via the REST API. Sys-
tem fields like modifiedDate or rollup do not allow the option to overwrite.

• Is required
Required fields are string, text or date fields that are configured so that the user must enter data
into the field before saving an item.

• Use to trigger suspect
Suspect links [266] is triggered when specific fields update in an item. This option lets you deter-
mine which field changes will flag an item as suspect.

• Synchronize
When items are synchronized to other items, a change in a field with this checkbox will flag this
item as out of sync in the synced items window and in Single Item View [273].

• Text components
If you chose to add a text box field, you will need to choose if you want it to have rich-text capa-
bilities.
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• Pick list
If you choose to add a field that controls user input with a lookup or pick list, you must select the
pick list from the drop-down menu. If you have not already created a pick list, close the window
and add a pick list [598]before making the field.

5. Select Save. By default, new fields are added to the bottom of the item type fields list, but you can
reorder using the green arrows.

Predefined fields
An organization administrator can add predefined fields [588]. They are indexed and can
be searched without using the database field name. 

When you are adding fields [589], you must select the database location where the lookup value will be
stored from predefined fields; this selection will not affect the users. However, custom report writers will
need to know the mapping of the fields to the database.

There are several predefined fields you can choose from including:

• Text
Optionally, you can enable rich text in these fields.

• Dates
Each field (date1 through date5) will limit the user entry to a valid date and will provide a pop-up cal-
endar picker.

• Integer
The fields originalEstimate, remainingEstimate and timeSpent all only allow the entry of whole num-
ber positive integers.
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• Flag
Flag fields will be displayed as check boxes to the users working with the item type. By default all
flags are marked as No (False).

• String
Includes the Predefined Fields: Short Name, ID, string1 through string15.

• Pick list
Fields such as status, priority and lookup 1-10 will prompt you for a pick list in the Add field window.
If that option is not available, then you have selected a non-pick list type from the predefined fields
drop-down. Once a predefined field has been used for a pick list it will no longer be available in the
list. If additional fields are needed, use custom fields.

• Release
Each pick list is populated by the list of releases created within each individual project. Some item
types are configured with a release field [233] by default. If the release field is removed from the item
type, it will become available in the predefined field list.

• User
Item types that include a user field will present the user with a pop-up list of users to select from. The
user will only be allowed to select one user from the list.

Custom fields
An organization administrator can add custom fields that are unique to their organization. Custom fields
can be similar to predefined, multi-select, URL, rollup, and item of type fields.

To find a field, search using the field name because they aren't indexed.

When adding a custom field [589], these are the types you can choose:

• Item of type
Use this to create a new pick list field that is populated by a list of existing items in the current project
that are of the specified item type. Users can reference items of another type in this manner. Only
one item can be selected in an item of type pick list.

• Flag
Flag fields are displayed as checkboxes to those working with the item type. By default, all flags are
labeled No (False).

• Integer
Allows only the entry of whole number positive integers.

• Release
Each pick list is populated by the list of releases created within each individual project. Some item
types are configured with a release field by default. If the release field is removed from the item type,
it's available in the predefined field list.

• Pick List
Pick lists are a set of specific values that can be entered in a field.

• Float
Use float fields to accurately capture numeric values. The float field follows IEEE 754. These fields
can be positive or negative.

• Multi-select pick list
Use the multi-select pick list field to allow the user to select multiple values in a pick list.

• URL
A URL field is similar to a regular text box. It performs some minor validation of text entered in the
field to check that it is a URL and will display the text as a link when submitted.

• Text
A text field is designed to hold plain text strings with no line breaks. If line breaks are required, use
the text box field.

• Text box
A text box field is designed to hold more data than a typical text field. It can store plain text or rich text
and can also have a template applied to it.
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• Rollup
A rollup field shows progress being made on downstream items without having to open each down-
stream item individually. You can select the progress bar to open a filter with any downstream items
that are included in the rollup calculation.

Progress on the downstream item is tracked by a pick list (often a Status pick list).
You will need to indicate the downstream item type, the pick list field on that downstream item
type, and the pick list value that indicates progress is complete.

• Calculated
A calculated field allows the user to add, multiply or automatically average several integer or pick list
fields. You can also create Weighted Shortest Job First (WSJF) fields to help prioritize items in Jama.
You can add calculated field results to the List View and use them for sorting and filtering.
You must select the following options:
• Calculation type

Average, Multiply, Sum or Weighted Shortest Job First
• Calculation source

This item or Related item(s)
• Related item type
• Relationship direction

Upstream or Downstream
• Fields upon which to base the calculation

This will display pick list, multi-select, integer, number of upstream or downstream relationships,
and the number of comments fields. If a pick list field is chosen, the value field will be used in the
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calculation. If a multi-select field is chosen, the value used will be the sum of the value of each se-
lected item

• Number of decimals to display (up to 4)
• Whether to require all values to be present before the calculation is performed

If you do not select this option, the calculation will be performed each time a value is entered into
one of the selected fields.

NOTE
American or British-style decimals must be used in the fields from which the calcula-
tions are derived. Errors will occur if non-American or British style decimals are en-
tered.

If a calculation is based on a related item, the calculated field will not update until the
item containing the calculated field is edited.

Enable rich text in test steps

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization > Item types.
2. Find the item type you want to use. You can use any item type that is a Test Case type (this may be

an item that's used as a Test Case [309]). Select Fields in that row.
3. In the right panel, select the Steps field, then select the Edit pencil icon.

4. In the Edit field window, select Allow Rich Text and click Save.
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IMPORTANT
To disable rich text in test steps, follow the same steps, unchecking the Allow rich text
box.

If you do so, no data will be lost, but images and rich text will be replaced with HTML
tags.

Users will not see any existing steps break and the content will still render. It is up to
the users to decided what formatting tags to remove. The application does not auto-
matically strip tags, and renders correct HTML tags in steps with or without the rich text
mode enabled.

Pick lists
Pick lists are a set of specific values that can be entered into a field.

This can be particularly useful when you want to be sure field content is entered exactly between users,
or when you are creating calculated fields. 

Each pick list can be assigned a name and a description. Descriptions can be useful to define how you
are using that pick list. 

Each option in a pick list can be assigned the following:

• Order
This designates what order the option will appear in a field pull down.

• Display
This determines what words users see when selecting pick list options.

• Description
Useful to define what each option means internally or to other admins. For example a display of "
High" could have a description of "over 5000 items", "625-750 degrees" or "at least 72 miles".

• Value
This can put a numerical value or weight on each option and is useful in creating calculated fields. 

• Color
Color can be used to visually distinguish pick list options at a glance and can be seen in different
views across the application. For example the test case status [311] field is set to have a passing col-
or of green, a failing status of red and a blocked status of orange.

• Default status
This determines which value appears by default. A pick list can only have one default status. 
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Manage pick list values
A pick list can have multiple values that can be organized, color coded, and set as a default.

Important considerations

• Changing pick list values — Other fields might be affected if the value is included in a calculated
field.

• Archiving a pick list value — Removes the option from a selectable option, but preserves the his-
torical selection of the value. Archived pick lists can't be unarchived.

• Deleting a pick list value — Removes the selected value from all items in the system. Each item is
versioned and updated with the replacement value. Previous versions retain the deleted value. The
deleted value isn't available for filtering. Each pick list must retain at least one value and that value
can't be deleted.

NOTE
You must have organization administrator permissions to change pick list values.

1. Select Admin > Organization > Pick lists.
2. In the Action column of the pick list you want to edit, select Values.

3. In the Pick List Items table, select the item row you want to modify, then select one of the following
options:

• Add item (pencil icon) — Enter the name and an optional description, value, and color.
• Edit item (plus icon) — Make your changes.
• Archive item (box icon) — Add a character or word to the beginning of the name (for example,

*Information) to show that a file has been archived.
• Remove item (X icon) — Select a replacement value, then click Delete.

The value is saved to items in the system where the deleted value is selected.
4. Click Save.

The table is updated to reflect your changes.
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Configure workflow
Workflows are not project-specific. When the organization administrator configures a workflow it applies
to the item type across projects.

NOTE
You must have organization or process administrator permissions to complete this
task.

Important considerations

• If the organization administrator selects Allow project managers to override workflows on a
project, the project administrator for each project can set up the workflows.

• If you disable a workflow, Jama Connect stores your settings for later use.
• An organization administrator can disable a workflow from the Workflow Administration section.

1. Select Admin > Organization, then select Workflow. If you disable a workflow, Jama Connect
stores your settings for later use.
• Select Enable workflow for this organization.
• (Optional) Select Allow project managers to override workflows on a project.

IMPORTANT
If you select or deselect either option, it could trigger a long transaction that
might impact system performance.

This enables workflow for all projects using this item type. It can't be disabled at a project level.
2. In the Workflow Administration section, select Add/Edit to start a new workflow, or select an exist-

ing workflow and then Config in the Action column to edit it.
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3. A project or organization administrator can continue setting up the workflow [634] from here. 

Set up editor templates
Editor templates can be applied to any rich text field and must be configured before use.

NOTE
You must have system or organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Editor templates.
• To open the new template with a rich text editor, select Add editor template.
• To edit templates, select an existing template, then select Edit.

2. Give the template a name and description.
3. Create the template as you want it to appear in other items.
4. Select Save.

The template is now available for other users [103]. 

Configure views
You can configure the default fields in Projects List View, Projects Reading View, Reviews Single Item
View, and Reviews Reading View.

You can also configure views in Projects that contain mixed item types, such as views created from a
tag, filter, or component, by selecting Projects List View with mixed item types.

NOTE
You must have organization administrator permissions in order to configure default
views.

Configuring fields for a view [55] overrides the default and becomes the standard order of visible fields
for that user, in all similar views, for that item type.

1. Select Admin > Organization, then select Item types > Views.
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2. In the Project List View window, select the view you want to configure.

3. Double-click a field name or use the arrows to move fields between the Hidden and Visible col-
umns. Select and drag field names up or down to reorder them.

4. Click Save.

NOTE
You can only select core item type fields when you configure List View for mixed item
types. For a list of core item type fields see Admin > Item types > Core > Views.

Manage relationships
As an organization administrator you can do the following to manage relationships:

• Edit relationship widget [584] in an item type
• Set the relationship types [602]
• Configure the Import Relationships Plugin [548]
• Set up relationship rules [605] at an organizational level
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Configure relationships

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Relationships > Edit.

2. To change the relationship options from No to Yes, select the checkbox next to each option:
• Show Status in Relationship Grid?
• Show Note in Relationship Grid?
• Allow relationship changes between two locked items?
Note and Status columns are added to the table in the bottom panel.

3. Configure Relationship types:
The Note and Status fields are only editable when the Relationship type is set to Show
Note and Show Status. In the Relationships widget of an item, double-click on a relationship to
edit its type, direction, status, and note.
• Use the toolbar at the top of this panel to edit, add, or delete types.
• Include a description to specify how and when this type is to be used.

4. Set up relationship rules [605].

Set relationship types

NOTE
You must have organization administrator permissions to set relationship types.

1. Select Admin > Organization, then select Relationships.
2. Under Relationship Types use the buttons to add, edit, delete or reorder relationship types.
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3. When adding a new relationship type you can enter a display name, description. The description is
only visible in this edit window.

If you select Show note and Show status users who create a new relationship using this relation-
ship type will be given the option to enter a note and a status for that relationship.
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TIP
Status and notes are visible any time you reopen the Add/edit relationship win-
dow.

Also, when notes and status are enabled under Relationship options in Admin >
Relationships...

... you will see them in the bottom panel of Single Item View when Relationships
is selected.

You can also filter by status or note in an impact analysis [269].
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4. If you delete a relationship type, you will be asked to choose a replacement type for affected rela-
tionships.

Set up relationship rules

NOTE
You must have organization administrator permissions to complete this task.

Relationship rules help maintain the project structure by preventing problems with relationships [255].
The rules help users know when relationships are required and in which directions.

When these rules are set up, the Relationship Status Indicator [265] alerts users to easily see when
their relationships do not match the relationship rules. 

Rule sets are created at the organization level, and can then be applied to one or more projects.

1. Decide with your team what relationships will be included, the relationship types, as well as wheth-
er the rules should be exclusive and included in coverage calculations for the project.

2. Select Admin > Organization > Relationships and scroll down to the section labeled Relation-
ship rule configuration to see any previously created rule sets.
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3. Scroll to the bottom and select Add rule set.

4. Select New Rule Set and edit the name to describe your set.

5. Add a rule by selecting the Upstream item type, Downstream item type, Relationship type from
the drop-down menus. Select the box under For coverage if this relationship should be inclu-
ded for coverage. 

NOTE
Configure the same rule set across projects that share relationships. If you relate
items across projects with different rule sets, the source project's rule set is ap-
plied.

6. Select Save to save the rule. As the rule is saved, it is added to the diagram to show the relation-
ship visually. Select Add another relationship if you want another for this rule set.

7. As rules are created, the diagram is updated to show the relationships. Solid lines between items
indicate a coverage (required) relationship. Dashed lines indicate relationships that are not for cov-
erage. 
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TIP
Once you have set relationship rules for a project, you can also view the relation-
ship rules diagram in Single Item View or on the dashboard [148].

8. To delete a rule, select the X at the end of the rule's row. To delete an entire rule set, select the X at
the top right of the rule set. After editing or deleting a rule, the rule set diagram will update with any
changes made.

9. Select Add project to apply the rule set to one or more projects. If a rule set is applied to a project
with existing items, nothing will change in that project, even if the existing relationships break the
new rules. Only future relationships will be required to conform with the rule set. 

IMPORTANT
A project can only have one rule set. If a rule set has already been applied to a
project and you attempt to apply a second rule set, the application will remove the
first rule set from the project and apply the second one instead.

10. If you select the box next to Allow any item type not mentioned in this rule set to be related to
any item type including those in the rule set, users can create relationships outside of the rule
set you applied to the project.
Rules are between item types. If you do not define a rule for a particular item type, that item type
can have a relationship with anything, or nothing if the user chooses, even if the rule set is exclu-
sive.

Configure Import Relationships Plugin
The Import Relationships Plugin helps you batch create relationships between existing items in the ap-
plication.

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Plugins > Add plugin entry.
2. In the Add plugin entry window, enter the following information and select Save.
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• Name: Import Relationships (or whatever name you want visible to users)
• Enabled: Check this box to make the plugin available to users.
• Class (case sensitive):  Enter the name of the object defined in the source code. For a single

project enter: 

com.jamasoftware.contour.plugin.jama.ImportRelationships

For cross-project imports enter:

com.jamasoftware.contour.plugin.jama.ImportRelationshipsCrossProject

• Type: Import
• Parameters:  Set relationship parameters [549]
• Plugin notes: Add any notes you have here. This will not be visible to end users.

3. When the information is correct, select Save. 

TIP
For a sample entry of a cross-project import, see Set relationship parameters
[549].
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Manage tests
As an organization administrator you can do the following to manage tests:

• Include unexecuted test runs in status calculations [609]
• Enable rich text in test steps [586]
• Use an item type as a test case or defect [585]

Manage collaboration
Collaboration includes emails [194], electronic signatures [222], the stream [201], reviews [153], and
workflows [196].

Configure organization detail

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Details.
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2. Make selections for the following details:
• Organization name

The name of your company or team. Each instance of Jama Connect can have only one organi-
zation. Organization name is also used for reports.

• Description
Additional information about your company.

• Return email
Used as a return address for email notifications. Typically the organization administrator's email
address is used or a noreply@example.com.

• Base URL
Email notifications usually include links to items. The base URL is used to create the URL's sent
in the email notifications. Enter the base URL for your Jama Connect installation. Example -
http://localhost:8080/contour. Note that attachments (images etc) are dependent on this setting
being accurate.

• Rich text image max width (px)
Maximum pixel width setting that will shrink all images embedded into rich text fields. Default of 0
means no max width will be applied.

• Rich text image max height (px)
Maximum pixel height setting that will shrink all images embedded into rich text fields. Default of
0 means no max height will be applied.

IMPORTANT
Images will retain their ratio when adjusted to fit the maximum setting for height
or width. The adjustment only happens during an upload or document import.
Images that already exist on the server aren't adjusted. Compression occurs
based on the width and height settings.

• Allow users to subscribe others
Allows users to subscribe other users to items.

• Allow users to mute subscriptions
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This feature allows users to mute (turn off) a subscription that has been subscribed to them by
another user.

• Allow non-administrators to delete items/containers
When enabled, this setting grants users with create/edit permissions the ability to delete items.
When disabled, only organization administrators can delete items.

• Include unexecuted test runs in status calculations (not retroactive)
Jama Connect uses all associated test runs to automatically calculate test case status.
Select this box to include unexecuted test runs in the calculation of test case status (default).
If you don't include unexecuted test runs, and there are no executed test runs, the system defers
to including unexecuted test runs.

NOTE
For test cases associated with a single plan, test case status will reflect the sta-
tus of the test run with the most recent activity, which would include unexecuted
tests if this is enabled.

When the case is associated with multiple plans, the most urgent status is chos-
en, in this priority order: unexecuted, failed, blocked, scheduled, passed.

Uncheck this box to remove unexecuted test runs from that priority order.

• Allow multiple items with the same global ID in a single project
• Math and Chemical symbols use SVG format
• Java Date Time Format

The default setting is month/day/year, but can be changed to year/month/day or day/month/year.
• Change global ID [542] 

Edit user or group subscriptions
Users can subscribe to email notifications. Administrators don't have control over a user's own subscrip-
tions, only to subscriptions added by others. Only the user can control their subscriptions.

NOTE
You must have organization or project administrator permissions to complete this task. 

1. Select Admin > Organization, then select Users.
2. Select Edit subscriptions in a user row to open the Edit subscriptions window.

3. Select the user you want to edit from the left column. On the right you see a list of their current
subscriptions. 

4. If you're an organization administrator, select Unsubscribe in the Action column or to remove mul-
tiple subscriptions, select the subscriptions you want to remove, then select Unsubscribe selec-
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ted. If you're a project administrator, select the items you want to mute and select Mute subscrip-
tions.

TIP
Organization administrators can also edit group subscriptions by selecting Admin >
Organization > User groups > Subscriptions.

Manage stream comments

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Organization, then select Stream.

NOTE
You must separate domains with a comma and avoid adding a space between the
comma and next domain.

2. Configure settings as needed:
• Select Disable Stream and project comments to turn off the stream.
• Select Enable new comments in global Stream for new comments from the global Stream

page to appear when you access the stream from the header.
• Select Allow users to invite new users to Jama Connect by email if you want users to be

able to @mention and invite others who are not registered Jama Software users to their discus-
sion.
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Those who accept invitations automatically receive a temporary license [569] but only have rights
to view the discussion threads to which they have been invited. Organization administrators can
give them more rights, but will need to change the license type to a permanent one before their
30 day license expires. An organization has unlimited temporary licenses, which have full crea-
tor permissions.

• Enter a domain in the field below this to restrict invitations to email addresses within a specific
domain. Enter the domain(s) separated by commas (for example, jamasoftware.com, yourcom-
pany.com).

• Enter a number of seconds in the Comment update frequency to control how often the stream
is updated with new comments.

3. Select Save settings.

Manage reviews
As an organization administrator, you can do the following to manage reviews:

• Grant permissions to a review administrator [574] to view any review and perform certain administra-
tive tasks whether or not they were invited to the review.

• Assign reviewer licenses [567]

IMPORTANT
Users with reviewer, test runner, collaborator and stakeholder licenses can partici-
pate in reviews, but cannot create reviews. If a user is invited to participate in a re-
view they automatically get a reviewer license. Reviewer licenses do not automati-
cally grant read or write access to project data. 

• Configure access to reviews [613]
• Configure item workflow for Approval Reviews [614]
• Determine which default fields are visible in reviews [600]
• Manage permissions by license type [569]

Configure review access
You must be an organization administrators to configure review settings.

For information about license types and reviewer roles, see Permission by license types [569].

1. Select Admin > Organization, then select Review center.
2. Select the options you want and select Save settings. 

• Disable reviews 
Check this box to disable access to reviews.

• Reviews can be public 

IMPORTANT
• Reviews created before Jama Connect 8.61.x with the setting Reviews can

be public disabled and later enabled, those reviews become public.
• Reviews created after Jama Connect 8.61.x with the setting Reviews can be

public disabled and later enabled, those reviews will remain private.
To change the visibility of one review, see Settings [160].
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Check this box to allow users with review access to have read-only access to any review marked
public. This is the default. If enabled, you must select who can see public reviews.
• Anyone with access to reviews

Anyone, regardless of project permissions, can see all items in the review.
• Only those with permission to ALL items in the review

This option only lets users see a public review if they have access to all items in the review.
• Enable review moderators to invite users outside their project

Review moderators can give users who don't have permission to particular items in a project ac-
cess, so they can review of those items.

• Allow approvers to add other reviewers and approvers
Check this box so that moderators can allow approvers to add more approvers or reviewers. This
is the default option.

• Allow approvers to delegate their approval
Check this box so that moderators can allow approvers to delegate their approval role to another
reviewer. This is the default option.

• Allow review moderators to invite new users to Jama by email
Check this box so that moderators can invite people without Jama Connect accounts to partici-
pate in reviews. If they accept, they are automatically granted a reviewer license.
• Only allow email addresses with these email domains

This limits who can be invited to those with email addresses you enter here. Leave it blank to
allow any domain to be emailed.

Item workflow for Approval Reviews
Integrating Approval Reviews with your item workflow provides a streamlined approach, ensuring re-
views are consistent and up to date. When enabled by an organization admin, moderators can use tem-
plates for Approval and Peer reviews.

How does the process for using item workflow with review templates work? Review this high-level over-
view to learn more.
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Note: You must be an organization administrator to configure the item workflow for Approval Reviews.

1. From Admin > Organization > Review center:
a. Select Enable Approval review template. Approval reviews are required to integrate the work-

flow for your review process
b. (Optional) Select Enable Peer review template. Peer reviews can be transition to Approval re-

views.
c. Click Save settings.

2. From Admin > Organization > Workflow:
a. Select Enable a workflow transition to be enabled by a finalized Approval review.
b. Configure the workflow transition status, notifications, lock state, and permissions that apply to

the new approval review transition.
3. Moderator creates a review, then selects the Peer review template in the review wizard.
4. Moderator views a Peer review and transitions it to an Approval review.
5. When the Approval review is done, the moderator selects Finalize Approval review.
6. After viewing the review overview and workflow transitions, the moderator selects Finalize re-

view to confirm the transition.

Review template types
The review templates are optional. You can use none, one, or both types. You don’t need a Peer review
template to finalize an Approval review.

NOTE
By default, the review templates are disabled. You must enable the Approval and Peer
review templates to use them.
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• Approval review template — Use when you want to collect signatures and need a review signed off.
If workflow is enabled, you can batch update items [116] to an approved state.

• Peer review template — Use when you have a review with ongoing itera-
tions and when changes to items are always in the “ready for approval” state.

Organize projects
A project is a way of organizing your data in Jama Connect and is made up of items, filters, base-
lines, releases, reports and tests.

As an organization administrator you can grant project administrator permissions to someone [624]
who will manage a particular project and its users. Alternatively, an organization administrator can also
complete the project-level tasks of a project administrator.

However, there are some tasks related to projects, that must be done by an organization administrator,
such as:

• Add a project [616] (available for project admins with Add Project role)
• Duplicate a project [618] (available for project admins with Add Project role)
• Archive a project [620]
• Grant project permissions [644] (if disabled for project administrators)
• Add or delete groups [560] (if disabled for project administrators)
• Set up projects workflow [634]
• Set up relationship rules [605]

Add a project
If your organization has a lot of projects or products, create a folder called "Product Line" with projects
for major releases. You can also create a project to hold a library of common requirements or docu-
ments that you can reuse [274].

NOTE
You must be an organization admin or project admin with the Add Project role to com-
plete this task.
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1. Select Admin > Project, then select Add project.

2. (Optional) Add a folder to organize your projects.
3. Set up relationship rules for the project. [605] Only one rule set can be applied to each project.
4. Set up project's workflow [634] as needed.

Edit project details

NOTE
You must have project or organization administrator permissions to edit project details.

1. Select Admin > Project, then select Details > Edit.

2. Make your changes, then click Save.

NOTE
The Project Summary widget on the project dashboard uses the End date in the
Project Details window to calculate the number of days until the project is complete.

Change a project key
Updating a project key regenerates the ID for all items in the project.
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NOTE
You must have project or organization administrator permissions to change a project
key.

1. Select Admin > Project, navigate to the project with key you want to change, then select Details >
Change project key.

2. Enter the new project key. Keys must be 1–16 characters long, consisting of letters, numbers, and
underscores.

3. Select Submit.  Unique ID [628] of all items within that project are updated to contain the new key.

Once the project key is updated, the Unique ID [628] of all items within that project are updated to con-
tain the new key.

Duplicate a project
You can duplicate a project to reuse requirements, permission settings, tags and attachments, or start a
new project from a template.

NOTE
You must be an organization admin or a project admin with the Add Project role to du-
plicate projects.

1. Select Admin > Project, then select the project you want to duplicate.
2. Select Actions > Duplicate Project.
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3. Select the items you want to copy and choose to synchronize these items.

• Project Settings — Settings in the Admin > Project area. For example, visible item types, rela-
tionship rule, and Explorer Tree maximum count.

• Project Permissions — Project-level permissions that were applied are carried over to the cop-
ied project.

• Existing Relationships — Relationships between items in the project are copied to the new
project.

• Public Filters — Public filters created by users or project admins are copied to the new project.
• Tags — Tags created by users are copied to the new project.
• Releases — Release values in the Releases tab are copied to the new project, which also main-

tains the release values in the standard “Release” field on items.
• Project Groups — Project-level groups are copied to the new project.
• Workflow — Workflow customizations (notifications, lock settings, transition permissions) are

copied to the new project.
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• URL Links and Attachments — Hyperlinks and attachments to items, using the links/attach-
ments widget, are copied to the new project.

• Synchronize Duplicated Project — All copied items receive a new project ID but maintain the
same Global ID as the original project. This allows teams to compare differences between the
source project and copied project. Common use cases are for parallel development of variant
products or branches of a products release.

• Create Relationships — All copied items include a trace relationship to the original item. You
can set the direction and relationship type.

4. Click Duplicate Project.

A message appears confirming the project was successfully duplicated.

Archive a project
Archiving a project hides it from immediate view from most users, but organization administrators still
see the archived project in the project tree with "(ARCHIVED)" in the title. Archiving a project doesn't
remove it from the database.

NOTE
You must have organization administrator permissions to complete this task.

1. Select Admin > Project, then select the project you want to archive.

2. Select Actions > Archive project.
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3. Select Yes.

Tips and more

• Archived projects and their content don't appear in filters or search results. When a project is ar-
chived, all releases associated with the project are archived. 

• Project groups aren't deleted when a project is archived. If no longer needed, delete project before a
project is archived.

• Select Actions > Unarchive to unarchive a project.

Delete a project
Once a project is deleted, there's no way to restore the project. When a project is deleted, all the data in
that project is deleted. However, this doesn't automatically free up space in the database. A database
administrator must manually compact the database.

NOTE
You must have organization administrator permissions to delete a project.

Quick tips

• Archive a project to clean up your workspace or remove a project from view.
• Delete a project to completely remove the project and all its data.
• Projects can be stored in empty folders.
• Project folders must be empty before they can be deleted.

1. Select Admin > Project, then select the project you want to delete.

2. Select Actions > Delete Project.
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3. Review the list of items, confirm the deletion, then select Delete Project.

The project slowly deletes in the background, so you can continue working. You receive an email when
the deletion is finished.

NOTE
The project isn’t removed immediately. A daily task runs at midnight UTC to perma-
nently remove data from the database. Once the project is permanently removed from
the database, you can remove item types associated with that project.

Integrations
In an effort to best support product development teams, we offer a number of integration platforms for
customers to connect to other application lifecycle management (ALM) software. Jama Software cur-
rently offers OpsHub Integration Manager (OIM) and Tasktop Integration Hub (TIH) which are able to
provide the necessary platform to create configuration that will manage the integration. These integra-
tions hubs will manage information between Jama Connect and the third-party applications of your
choice in a bi-directional manner.  

For more information on integrations visit the Community.

These solutions can be managed on-premises or, in the case of the OIM, hosted by OpsHub in their
cloud. If you have questions or are interested in purchasing either of these solutions please con-
tact <sales@jamasoftware.com>
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Integrate OSLC Model Connector with Jama Connect
Open Services for Lifecycle Collaboration (OSLC) is an open-source set of specifications that enables
and simplifies tool integration in software development.

The integration of OSLC provides traceability between Jama Connect and OSLC domains, applications,
and organizations. The partnership between the Smartfacts Model-Based Systems Engineering (MBSE)
platform and Jama Connect helps product development teams increase their level of collaboration and
communication.

The result of this collaboration is the OSLC Model Connector, which provides:

• Complete traceability for requirements throughout the product development lifecycle
• Clear visibility into MBSE design artifacts in real-time
• Ability to link requirements to various modeling tools

For more information, see Jama Connect OSLC Model Connector Datasheet.

IMPORTANT
You must contact your Jama Software account manager to set up access to the OSLC
Model Connector and to MID Smartfacts.

You must have organization admin permissions to enable the OSLC Model Connector
and give access to users in your organization.

To set up and use the OSLC Model Connector:

To... Do this...

Enable OSLC
Model Connector

1. Log in to Jama Connect, then select Admin > Organization > OSLC.
2. Select Enable OSLC > Save settings.

A pop-up message confirms that OSLC was successfully enabled.

Grant OSLC
Model Connector
permissions

1. Select Admin > Organization > Permissions.
2. In the row for the user or group you want to provide access, select Modify.
3. In the Edit permissions window, select OSLC, then click Save.

A checkmark is displayed in the OSLC column for that user or group. The OSLC permission automatically
inherits the permissions that are set for those users or groups.

Configure specif-
ic item types for
OSLC Model
Connector

1. Select Admin > Organization > Item types.
2. In the row for the item type you want to configure, select Edit.
3. In the Inactive widgets column of Widgets table, select OSLC Artifacts.

OSLC Artifacts move to the Active widgets column.
4. Click Save.

That item type now includes the OSLC Artifacts widget.

Use OSLC Model
Connector with
Jama Connect

1. After the organization admin configures your OSLC permissions, open your project and right-click on
the item where you want to add a new item.

2. Click Add > New item > <item type>.
3. In the Add item window, enter a name for the item, then click Save and Close.

The OSLC Artifacts widget appears in Single Item View.
4. In the OSLC Artifacts widget, select + to add links to OSLC Artifacts that you configured in Smartfacts.

You now see links in the OSLC Artifacts widget.
5. Select a link.

A panel slides out to display the artifact.
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Example of the OSLC Artifacts Widget in Jama Connect

Project administrator
A project administrator is a role that can be provided for all projects or on a specific project with a focus
on permissions, project groups, and workflow customization.

Select Admin > Project to configure your projects.

As administrator, all your projects are available from the Project tab. The last project you viewed is se-
lected by default.

As a project administrator you can:

• Manage project releases [630]
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• Configure project item types [626]
• Manage project users [641]
• Manage project groups [642]
• Manage project permissions [644]
• Manage project attachments [632]
• Manage project tags [632]
• Perform a project cleanup [640]
• Index project data [640]

Monitoring changes with the Admin Activity stream (project admin)
The Admin Activity stream provides an audit trail of updates made by project administrators.

To open the Activity stream panel:

1. Select Admin > Project, then select the project you want to view.
2. Select the Activity stream button on the right side of the panel.

The Activity stream opens. You can search for activities by entering a search term.

The Project admin Activity stream includes the following actions:

Tab Available information

Settings Changes in version items; maximum number of items displayed in the Explorer Tree; where to
save test run defects.

Item Types Item types that transition from visible to hidden and from hidden to visible.

Release List What was added, edited, deleted, archived, and unarchived in a project release.

Project Permissions Modifications to inherited permissions; added and removed permissions at the project level.

Workflow Overriden items and who overrode them; removed and configured workflows per item type in a
project.

Attachments Attachments added from the Attachments tab of the Project admin panel.

Tag Management What was added, deleted, and edited to a tag in a project.

Index When a project level index was initiated.

Clean up When project cleanup and project baselines cleanup are initiated.
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Manage projects
As project administrator you have permissions to modify, set up, and organize various aspects of the
project and content. You can also manage users [641] that participate in the project.

You can also choose to manage the project dashboard [351], although that doesn't require project ad-
ministrator permissions.

Edit project details

NOTE
You must have project or organization administrator permissions to edit project details.

1. Select Admin > Project, then select Details > Edit.

2. Make your changes, then click Save.

NOTE
The Project Summary widget on the project dashboard uses the End date in the
Project Details window to calculate the number of days until the project is complete.

Configure project item types
A hidden item type prevents users from creating new items or sets of that type. Sets or items that are
created under a visible item type, and are then hidden, are still functional in Jama Connect.

Quick tips

• By default, a moved item type places itself at the end of the list. Drag and drop item types to reorder
them.

• An organization administrator can also configure views [600] for all projects, and an individual user
can configure fields [55] for their personal settings.

IMPORTANT
You must have organization or project administrator permissions to configure project
item types.
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You can hide item types from a particular project with the following steps:

1. Select Admin > Project, then select Item Types. 

2. Double-click on any item type to move it between the Hidden item types and Visible item types
columns.

3. Click Apply to save your changes.

Configure default Explorer Tree settings

IMPORTANT
You must have organization or project administrator permissions to configure default
Explorer Tree settings.

1. Select the gear icon at the top of the Explorer Tree.

2. Select the Default settings tab, then select the default settings.
• Show item IDs

This displays the unique ID [628] (as in PROJ-REQ-25) before each item.
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• Display global ID
This displays the global ID (as in GID-8845) before each item. This can be helpful if the item is
copied and synchronized.

• Show only folders / hide items
This hides items from view in the Explorer Tree. Components, sets, and folders are still dis-
played. This can improve performance when your project has a large number of items.

• Show outline numbering
This displays a number scheme of order and depth in the Explorer Tree. Root level items have
numbers like 1, 2, or 3. Child items contain the parent item number as well as its own number,
like 1.1, 1.2,  or 1.1.5.

• Show relationships in Explorer Tree
This displays downstream relationships of items in the Explorer Tree. Select the green down-
stream arrow to open the related items in List View.

CAUTION
If you relate items back to themselves, you might create an infinite loop that
causes the Explorer Tree to expand. To avoid this, don't relate items in a way
that creates an infinite loop.

3. Select Apply and Close to give other users the option to select these default settings. 

Project key
The project key is a unique identifier, automatically created with each project, that makes up the first
part of each item's Unique ID. 

Project or organization administrators can change a project key. [617]

Unique ID
Unique IDs, or item IDs, identify an item with a project key, set key and a set counter. Unique IDs re-
main the same even if item name or content is changed. They can't be edited or duplicated.

• Project key
A project key identifies which project an item belongs to. Project keys must be unique to each project,
and must be 1–16 characters long, consisting of letters, numbers, or underscores. A project or organ-
ization administrator can change the project key [617], but that doesn't reset the numbering of items. 
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• Set key
A set key identifies item sets for each project. You can use the same set key across sets or projects.
Project or organization administrators can change a set key [587] to better meet your organization's
needs.

• Set counter
The set counter is a number automatically added to the item. Unlike the Global ID counter, you can
reset the set counter when you change the set key. 

NOTE
It's possible to use the set key across multiple sets of the same item type. However,
keep in mind that the set counter is shared across all items using the same set key.

Change a project key
Updating a project key regenerates the ID for all items in the project.

NOTE
You must have project or organization administrator permissions to change a project
key.

1. Select Admin > Project, navigate to the project with key you want to change, then select Details >
Change project key.

2. Enter the new project key. Keys must be 1–16 characters long, consisting of letters, numbers, and
underscores.

3. Select Submit.  Unique ID [628] of all items within that project are updated to contain the new key.

Once the project key is updated, the Unique ID [628] of all items within that project are updated to con-
tain the new key.

Change a set key
You can edit a set ID or renumber items in a set at any time.
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NOTE
You must have organization or project administrator permissions to complete this task.

1. Select Projects, right-click on the set you want to modify, then select Change set key.

2. In the Confirm Set Key Change window that opens, enter the new set key, which must be 1–16
characters long, consisting of only letters, numbers, or underscores.

3. Select Regenerate Item IDs to reset the counter and apply new numbering to all existing items.
Item counters start over at 1.

CAUTION
Don't select Regenerate Item IDs if you want to restart numbering on newly cre-
ated items. Leave existing items as they are.

Manage releases
A release is a group of items that are developed together and mapped to a specific completion date.
Users can view releases and use them to assign items to a release.

NOTE
You must have project or organization administrator permissions to manage releases.

Project and organization administrators can set up and manage releases that others use. The releases
in the release list are used to populate the pick list for the Release field on an item. Releases are auto-
matically sorted by release date in the release list and in pick lists.

1. Select Admin > Project, then select Release List.
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2. Select the option you need:
• Add a release

Select the green Add release button in the toolbar to open the Add/edit release window. Add
the name, description, release date, then select Save. 

TIP
You can also add a release from the Releases tab at the top of the left panel.

• Edit a release
Select Edit in the Action column for the release you want to edit. This opens the Add/edit re-
lease window where you can edit the name, description and release date and select Save. 

• Delete a release
Select Delete in the Action column for the release you want to delete. Select Yes to confirm.
Releases can't be deleted if any items are assigned to them. To remove all assigned items, se-
lect the Releases tab and move all assigned items from that release to another release.

• Archive a release
Select Archive in the Action column for the release you want to archive. Select Yes to confirm.
You can view archived releases by selecting View archived releases in the toolbar where you
can select Unarchive.
Archived releases don't appear in filters or search results, but items assigned to any archived re-
lease do. The Release field for these items is populated and has "(Archived)" appended to the
release's version field.

NOTE
Administrators can also configure default release settings [234] that show how re-
leases are displayed.
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Manage attachments

NOTE
You must have project or organization administrator permissions to manage attach-
ments.

1. Select Admin > Project, then select Attachments.

2. From the toolbar, you can add, edit, or delete attachments.

3. In the Add/Edit File Attachment window, add or edit information about that attachment. Select the
History bar at the bottom of the window to pull up a version history for that attachment to compare
versions.

4. Select Upload and Save.

From Single Item View, any user can now add that attachment [133].

Manage tags
From the Tag Management tab, you can view, edit, and create tags.

NOTE
You must have project or organization administrator permissions to manage tags.

• Select Admin > Project, then select Tag Management to add, edit, or delete tags.
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From Single Item View, any user can add that tag [132].

Manage workflows

NOTE
You must have project or organization administrator permissions to manage workflows.

1. To manage workflows as a project administrator, select Admin > Project.

2. Select the Workflow tab, then select Override for the workflow you want to edit.
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3. In the Workflow Configuration section, set up a project workflow [634], then click Save.

Set up projects workflow

NOTE
You must have project or organization administrator permissions to set up projects
workflow. 

1. To manage workflows as a project administrator, select Admin > Project.

2. Select the Workflow tab, then select Override for the workflow you want to edit.
If the organization administrator has configured it [599], select Override to make changes to any
workflow.

You are prompted to confirm the changes.
3. In the Workflow Configuration section, select the following options for the workflow you're creating.

• Enable workflow for this organization
• Allow project managers to override workflows on a project

Important: If you don't enable this option, performance might be impacted and it could trigger a
long transaction if the organization has over 10 workflows.

• Workflow for Item Type
• What picklist field should workflow apply to
• Version items on workflow status change
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NOTE
You can only associate one pick list field per item type. The field you associate
must be a pick list field; multi-select lists don't work.

4. In the first row of the Current Status table, specify an initial state for the item when it's created. This
is the default status of the item, and it overwrites the default field status if one is set.

5. In the following rows, specify the workflow, who is allowed to make those transitions, and the ac-
tions that occur when an item changes status. For example, like locking the item or sending an
email.

TIP
Use the pull-down to move the current status to a new status and trigger related
actions or notifications.
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6. Edit the Action text to make messaging more useful or clear.
7. Use the green plus button or the red minus button to add or remove transitions in your workflow.
8. Select the lock icon to lock or unlock the item when it reaches a certain status (like "draft," "ap-

proved" or "complete"). 

NOTE
This lock is a "system lock" that's slightly different from a user lock. A user lock
can still be edited by the user who locked it and easily unlocked by the same user
or an admin. If an item is in a system lock, no one can edit the item. Admins can
still unlock the item, but we recommend using transitions to move an item to a
state where it can edited again.

9. Select the link in the Transition permissions column to choose who can make these transitions. 
10. Select the link in the notifications column to send an email notification when a user transitions

the status of an item. 

If you send a notification, a message appears where you can document the transition and reason
for changing the status.

11. Click Save.

Configure workflow
Workflows are not project-specific. When the organization administrator configures a workflow it applies
to the item type across projects.

NOTE
You must have organization or process administrator permissions to complete this
task.

Important considerations

• If the organization administrator selects Allow project managers to override workflows on a
project, the project administrator for each project can set up the workflows.
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• If you disable a workflow, Jama Connect stores your settings for later use.
• An organization administrator can disable a workflow from the Workflow Administration section.

1. Select Admin > Organization, then select Workflow. If you disable a workflow, Jama Connect
stores your settings for later use.
• Select Enable workflow for this organization.
• (Optional) Select Allow project managers to override workflows on a project.

IMPORTANT
If you select or deselect either option, it could trigger a long transaction that
might impact system performance.

This enables workflow for all projects using this item type. It can't be disabled at a project level.
2. In the Workflow Administration section, select Add/Edit to start a new workflow, or select an exist-

ing workflow and then Config in the Action column to edit it.

3. A project or organization administrator can continue setting up the workflow [634] from here. 

Lock items in a workflow
Locking items in a workflow can help avoid unwanted changes. For example, a project administrator
might want to leave items unlocked while in "draft" status, but lock them when they reach "approved"
status.

NOTE
You must have organization or project administrator permissions to configure workflow.

Items can also be automatically locked by the workflow [196]. These items show a gray lock after their
name and a blue lock in List View. 
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System-locked items unlock when transitioned through the workflow or by an organization or project ad-
ministrator.

To add an automatic lock to the workflow:

1. Select Admin > Project > Workflow.
2. For the item you want to lock, select Override.
3. In the Lock? column, select the lock icon to include (or remove) an automatic lock in the workflow.

4. Click Save.

Unlock system-locked items
Anyone can view the list of system-locked items regardless of permissions.
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IMPORTANT
Organization admins can unlock system-locked items.

System-locked items can be unlocked by a project admin with admin permissions for
those items.

1. Select your name in the header to open the My Profile window.
2. Select System Locked Items to see all items that were automatically locked [200] (blue lock).

3. Select the items you want to unlock, then select the Unlock button in the top right corner of the
window.

Configure project settings

IMPORTANT
You must be a project or organization administrator to complete this task.

1. Select Admin > Project > Settings, then select Edit.

2. On the Settings page, you can make the following changes:
• Version items

Turns automatic versioning on and off when using the Save and close option. You might want to
turn versioning off while initially creating and organizing the project.

• Max items displayed in Explorer Tree
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Sets the maximum number of items that are displayed per container (project, component, set, or
folders) when using the Explorer Tree. After an import there might be thousands of items so this
can be configured to improve performance when working with large data sets.

• Save test run defects here
Defects that are recorded in the Test execution window are automatically sent to this location in
the project. The Defect item types must be a Visible item type for them to appear. For more infor-
mation, see Configure project item types [626].

Project and baseline cleanup
Project cleanup can be used to remedy issues that occur from inconsistent references or inactive items.

For example, users might experience inconsistencies between the Explorer Tree, List View, filter re-
sults, or see these messages:

• "This item was deleted."
• "You don't have permission to perform this action."

Project cleanup recalculates sort orders and compares them with the database to solve these problems.
It doesn't require re-indexing or downtime.

TIP
Perform a cleanup at a time of low usage.

• Select Admin > Project > Clean Up, then select Clean up project or Clean up project baselines.

A confirmation message appears when the process is finished.
Self-hosted customers can ask a system administrator to verify the results in the log.

Index project items
Sometimes project indexes get out of sync due to field configuration changes, large batch updates, API
updates, and various other functions.

Index project data if you see data that's incorrect or doesn't exist. For example, failed batch updates, or
an item that shows a value in a field, but a search for that field value doesn't return the item.
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NOTE
You must have project or organization administration permissions to index project
items. 

• As a project administrator, select Project > Index and click Index items.

If this doesn't resolve the problem, the system administrator can try doing a full index of items [531].

TIP
Large files over 25 MB aren't indexed and therefore, their content isn't searchable. The
following filetypes are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF. The follow-
ing filetypes aren't indexable: XLSX, XLS, XML, HTML, HTM.

View project users
From the Users tab, you can view information about each user, such as email, license type, login infor-
mation, and user status.

NOTE
You must have project or organization administrator permissions to do this.

1. Select Admin > Project, then select Users.

2. (Optional) select Subscriptions to unsubscribe notifications for individuals or groups.
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TIP
Individual users can manage their own subscriptions in their profile [40].

Manage project groups
As a project administrator, you can manage groups of users that already have access to a project.
These groups are valuable when fine tuning permissions or creating email lists.

NOTE
You must have project administrator permissions to manage groups at a project level.
You must have organization administrator permissions to add, delete or edit groups
[560] at an organizational level.

1. Select Admin > Project, then select Groups. 

2. Select Add Group in the top right toolbar.
3. In the window that opens, give the group a name and description, then select users for the group

and select Save.
4. For project level groups, you can edit the group name, description, or members, as well as editing

a group's subscriptions. You can also delete the group. Use the buttons in the Actions column of
the group you want to edit. 
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NOTE
A system administrator can disable or enable the project administrator's ability to add
groups [495].

Edit user or group subscriptions
Users can subscribe to email notifications. Administrators don't have control over a user's own subscrip-
tions, only to subscriptions added by others. Only the user can control their subscriptions.

NOTE
You must have organization or project administrator permissions to complete this task. 

1. Select Admin > Organization, then select Users.
2. Select Edit subscriptions in a user row to open the Edit subscriptions window.

3. Select the user you want to edit from the left column. On the right you see a list of their current
subscriptions. 

4. If you're an organization administrator, select Unsubscribe in the Action column or to remove mul-
tiple subscriptions, select the subscriptions you want to remove, then select Unsubscribe selec-
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ted. If you're a project administrator, select the items you want to mute and select Mute subscrip-
tions.

TIP
Organization administrators can also edit group subscriptions by selecting Admin >
Organization > User groups > Subscriptions.

Grant project permissions

NOTE
You must have at least project administrator permissions to complete this task. An or-
ganization administrator [574] or system administrator [492] can also grant permissions
at an organization or project level. A system administrator can enable or disable the
project administrator's ability to grant project permissions [495].

1. Select Project > Project Permissions.

2. Select the project, component, set or item for which you want grant permissions in the project se-
lector on the left. From here, you can use the toolbar to:  
• Select Add permissions to add a new user or group.
• Select Modify in the row of a user or group you want to edit.
• Select Remove in the row of any user or group for which you want to delete permissions.
• Select Override to override the inherited permissions for this user or group.

TIP
When a row contains the value True in the Inherited column and is highlighted
in green, this means the group or individual has received its permissions from a
higher level. Select Override in the Actions column to change these inherited
permissions.
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3. In the Add/Edit access window, you can grant the set of permissions that come with the role of
project administrator, or you can grant access permissions for the selected item, set, component.
Select Save.

4. Alternatively, select Remove to take away all permissions from the user or group for that project,
set, or folder.
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Reference

Use these tools to help find quick answers whether you're a new or experienced user:

• Glossary of terms [659]
• Quick find [144]
• Best practices and guardrails [652]
• Application performance testing [654]
• Keyboard shortcuts [653]
• Permissions by license type [569]
• Get help [657]

Permissions
Permissions allow users to do things such as access, modify, and delete items or perform other specific
tasks.

The permissions that a user has depends on:

• The license type [569] they are assigned
• The roles [649] (permission sets) they're granted
• The access permissions [652] (read/write or read only) to specific projects or containers they're

granted

You can grant permissions if you are:

• System administrator [492]
• Organization administrator [574]
• Project administrator [644]

License types and permissions
The license type limits the possible permissions and roles that can be granted to a user. For example,
creator, stakeholder, test runner, and reviewer.

Each user, regardless of license type, has a unique login (username and password). Organization ad-
ministrators can view the current license [573] or assign users license types [567].

Creator and reviewer licenses can be named or float licenses, whereas test runner and stakeholder are
named only.

These are the available user license types:

• Creator
A creator license is a named or floating license that gives full read and edit rights, and full access to
reviews, for those who are active users managing items and projects on a daily basis.

• Test runner
A test runner license is a named license that focuses on users whose primary goal is execution and
recording test results. This includes basic permissions to read and review, as well as the additional
ability to create test plans and defects, and execute test runs. They can also add attachments to test
runs during execution.

• Collaborator
A collaborator license is a legacy license that can be a named or floating license that gives read-only
privileges to those who need visibility into a project, but don’t need editing rights. These users can
view items, provide comments, participate in (but not create) reviews, execute test runs, and log de-
fects. The stakeholder license is recommended for users who only need read access, and the test
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runner is recommended for users who need full access to test center and defect recording capabili-
ties.

• Stakeholder
A stakeholder license is a named license that gives read-only privileges to those who need visibility
into a project, but don’t need editing rights. Stakeholders can view items, provide comments and act
as reviewers.

• Reviewer
A reviewer license is a named or floating license that grants permission to participate in reviews, act
as approvers, moderators, or review administrators, and respond to comments in the stream. A re-
viewer license doesn't allow users to initiate reviews or access items in the core project.

• Temporary
A temporary license is a 30-day full creator license, automatically granted to a non-licensed individual
whose email address is used to invite them to a review or to comment in the stream. It has no default
permissions except for the discussion thread or review to which they were invited, although an organ-
ization administrator can add permissions.

Permissions by license type
Your license type defines your permissions, which determine your ability to create and edit items or ac-
cess them as read-only.

If you have a Creator license and read-only permissions to a project, you can:

• Execute test runs
• Log defects from the test run execution window
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** Permissions that are included with each license type.

Roles
A role is a set of permissions granted to a user so that they can perform particular functions.

NOTE
Permission roles are different than review roles [153], risk roles [399], and signer roles
[224].

The permissions included with each role [649] can be granted by an administrator [646] to an individu-
al or a group.

These are the roles and the type of license they require:

• System administrator [468] 
The system administrator handles the overall installation, setup, and configuration of Jama Connect,
and doesn't have access to projects. The system administrator is a special user and not a role that
can be provided to other users. This user doesn't require a license and logs in to the system with the
username "root."

• Organization administrator [541] 
An organization administrator controls all aspects around the configuration of Jama Connect and the
user and groups. This is a role that can be assigned to an individual or a group.

• User administrator [559]
The user administrator provides the ability to manage licenses, users, and groups. This is a role that
can be assigned to an individual or a group. This user can see all users and organization groups in
the system.
The user administrator can only set permissions for groups/users on projects where they are a project
administrator. They are also limited to managing organization group membership for only groups
where they are a member, which prevents a user admin from giving access to projects where they
don't have access.
User administrators can't make changes or additions to users or groups that have been assigned to
organization and process administrators with the exception of activation/deactivation and license
management.

• Process administrator [580]
The process administrator role focuses on the configuration of content and connections within Jama
Connect.
• Item types
• Pick lists
• Relationship rules
• Review Center
• Risk management
• Workflow

• Project administrator [624] 
A project administrator is a role that can be provided for all projects or on a specific project with a
focus on permissions, project groups, and workflow customization.

• Add Project
The Add Project is a very specific role that is meant to exist between the organization administrator
and the project administrator. With this role, a user can create a new project or duplicate an existing
project where that user is a project administrator.
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• Review administrator [178] 
A review administrator is a role with the permissions needed to manage reviews.
Review administrators can view all reviews and perform administration tasks for those reviews, re-
gardless of whether they were invited to the review. A review administrator is the only one who can
delete a review

• Reuse administrator [282] 
A reuse administrator is a role with the permissions needed to manage reuse.
In addition to reuse permissions, a reuse administrator needs read access for visibility of any
synchronized items they are working with, and write permissions for making edits, synchronizing, re-
using, or duplicating.

• Risk administrator [376]
A risk administrator can create and edit risk templates, as well as manage analyses and participants.
An organization administrator can grant risk administrator permissions [577].
Risk Management [372] requires additional licensing for your organization, as well as creator, stake-
holder or test runner licenses for all risk management participants. Contact your Jama Software ac-
count manager for more information.

IMPORTANT
Users must have the license type [569] that allows for the permissions granted with
each role.

Permissions by roles
Some permissions are included with the user's license type [569]. In addition, users can be as-
signed roles [577] that grant them additional permissions shown in this table. 

Users must have the required license type for role-related permissions to work.
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Roles and permissions
Permissions and roles control how users experience Jama Connect by restricting the actions they per-
form or content they can see.

Roles provide access to administrative features of Jama Connect. They are assigned by administrators
to individual users or to groups.

Permissions control read and write access to your project. You can be granted permission to an entire
project, to a project’s folders, or to a collection of items in a project. Permissions are assigned to individ-
ual users or to groups.

Permissions are inherited from higher levels in the organization structure and can be set at the organi-
zation level, folder level, or project level. Once permissions are set on a project, they can be adjusted
based on the organization of the project Explorer Tree.

Note: You must set the permissions before adjusting a set or component to access the project or the
user won’t be able to access the project.

Best practices

• Set permissions at the highest level possible.
Benefit: Helps you track existing permissions for a user or group when many one-off changes are
made.
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• Use groups instead of individual users.
Benefit: Reduces the volume of entries and ensures consistent setup of users who require similar ac-
cess.

Permission questions and scenarios

Questions and scenarios Answers

I want to provide general user man-
agement to my IT group, but I have
sensitive projects and project
groups. How do I restrict access to
those?

Assign the user admin role. This role is limited to viewing and administering project-level
permissions on only projects where they are a project administrator.

They can still create new users, deactivate existing users, manage their participation in
organization groups, and configure licenses.

Can a user administrator grant
themselves or others the process
role or org admin role? Can they
change their own permissions?

No, only an org admin can set the org and process roles.

A user admin will need to be a project admin to adjust permissions to a project. If they
remove their own project admin role, they will no longer have access to that project’s per-
missions.

Why aren’t there any options to
override permissions on certain
users or groups?

This restriction controls visibility and access across projects that might belong to different
divisions or contains sensitive information that shouldn’t be exposed to all users.

If you want your user admin (user or group) to have access to all projects and project
groups, assign the project admin role at the organization level.

Why can’t my user admin see all
groups where a user is assigned?

By default, user admins can’t access all projects. The user must be a project admin to
access the groups for that project.

Why can't my user admin manage
the membership in an organization
groups?

User admins can only provide access to projects they can access. To access a project,
they must be a member of that project's organization group.

When they aren't a member of the organization group, the project isn't visible to them
and they can't provide access.

Why am I getting a no permissions
error when attempting to add a user
to a group?

The group might have permission to access projects that you do not.

Why can’t my process admin see all
projects when assigning relationship
rules?

Some projects might contain sensitive information, so access is restricted. The list of
projects is filtered to show only projects where the process admin is also a project admin.

If you want your process admin (user or group) to have access to all projects and project
groups, assign the project admin role at the organization level.

Is there a way to limit the item types
that a process admin can see?

Not at this time. This is a future option under consideration.

Why is this user I’ve just made an
org admin still unable to access cer-
tain projects?

The option to override an org admins access is no longer available. Previously this was
an option, however it did not ultimately restrict the org admin from seeing the projects
and giving themselves access directly or through another group.

We did not want to remove or alter any permissions as part of introducing the new roles.
We recommend removing any overrides on org admin users/groups made in the past to
remove confusion.

Does the process admin have ac-
cess to all projects and users?

The process admin only has access to the projects where they are a project admin.

The process admin does have access to users and organization groups for assigned
workflow transitions.

The @mention feature isn’t working
for my users, regardless of project
permissions on the Stream page.

The top-level option to create new comments has a new configuration that disables this
option by default. We’ve determined that context free comments (not made from a project
or item) were creating confusion and exposing users and groups that all users in the sys-
tem should not have access to.

The @mention from the Stream page is now limited to include only users and groups that
align with the commentor’s project permissions. This change tightens security and elimi-
nates accidental exposure of users or groups.

As a project administrator, why can’t
I add users to my project if they are
in the system?

Your organization has configured the settings for Jama Connect to restrict project ad-
mins’ visibility of users and groups to only their project’s permissions.

If you want to your project admins to have access to all users and groups, your organiza-
tion admin can configure the setting on the Organization Detail page.

I’ve given a user with read/write per-
missions access to a set in my
project, but they still can’t see the
project?

Permissions must first be set on the project. Once the user has read or read/write per-
missions on the project, they can access the set. You can provide or remove permissions
to other sets or components in the project to modify access.
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Questions and scenarios Answers

I need my team leads to be able to
create new projects, but I can’t make
them organization admins. What do I
do?

The Add Project role lets users create new projects and duplicate any projects where
they have project admin access.

I’ve removed a user’s access to a
Component, why can they still see
it?

Users receive the highest level of rights assigned to them. If a user is part of a group that
has permissions to a component, you can make one of the following changes:

• Change that group’s permissions to exclude the component.
• Remove the user from the group so the individual entry is now the highest level of

rights assigned.

Access permissions
Access permissions allow a user to create, read, and edit items.

Access permissions have two levels:

• Read/Write
A user with these access permissions can read write edit and delete

• Read-only
A user with these permissions can read, but not create or edit items. 

An organization administrator can grant access permissions at an organizational level [574]. A project
administrator can grant access permissions at a project level [644]. 

Access permissions and relationships
How you interact with relationships depends on the access permissions you have for each of the related
items. Read more about permissions [569]. 

If you have these
access permis-

sions for the cur-
rent item...

and these ac-
cess permis-

sions for the re-
lated item...

you can....

Read/Write Read only ... view trace relationships as well as the ID and name of the related item. You can
modify relationships and create new ones. You can also navigate to the related
item and clear suspect links. 

Read only or
Read/Write

No permission ... view trace relationships, but not modify or create new relationships. You can see
the ID and name, but can't navigate to the related item.

Read only Read/Write ... view trace relationships. You can modify relationships and create new ones. You
can also navigate to the related item and clear suspect links. 

Read/Write Read/Write ... create, modify, or delete relationships as well as navigate to related items.

Read only Read only ... view trace relationships and navigate to related items. You can't create or modify
relationships between the two items. 

Best practices and guardrails
Explorer Tree settings

To improve performance when your project has a large number of items, you can set the Explorer Tree
settings to only show folders and components [47].

Filters

Filters that run against all projects find and display results for all items in your Jama Connect applica-
tion. Filters like these can return large data sets and degrade performance. To assure quality perform-
ance, make filters more specific to return only the results you need.

Items and attachments

When working with large numbers of items (more than 1,000 per folder), hide items in the Explorer Tree
[47] and work with them in List View [52] in the center panel. To move multiple items, rather than multi-
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select in the Explorer Tree, multi-select in the List View and drag them to their new location in the Ex-
plorer Tree. 

Large files over 25 MB aren't indexed and therefore, their content isn't searchable. The following file-
types are indexable: PDF, DOC, DOCX, PPT, PPTX, TXT, RTF. The following filetypes aren't indexable:
XLSX, XLS, XML, HTML, HTM.

Field content

Typically, item fields contain fewer than 10,000 characters (2,000 words). When you compare review
versions, the applications might skip fields with lengthy content.

Reuse and synchronization of hundreds of items can affect system performance, causing it to feel slow-
er than usual for users and decrease performance for other processes such as exporting.

Reuse and synchronization

If you try to reuse and synchronize a very large number of items, a warning appears if it’s likely to im-
pact performance. 

If you still want to do this, consider reusing items in smaller batches or starting a large reuse and syn-
chronize process during off hours when there is less competition for resources.

Keyboard shortcuts
Use the following shortcuts to navigate throughout the Jama Connect application.

NOTE
In general, Mac users can substitute the Cmd key for the Ctrl key and the Option key
for the Alt key. Depending on your keyboard, you might also have to press the Fn key.

Table 3. General navigation
Key command Function

Esc Closes an open window 

Tab Navigates from field to field in List or Single Item View

Enter Selects a highlighted button, or opens a selected item

Arrow keys Scroll through items, tags, releases, baselines or test plans in the left panel

Table 4. Inline editing in List View
Key command Function

Esc Cancels unsaved changes

Tab Moves cursor between editable fields

Enter Saves changes and moves to next item in list

Use the following shortcuts in fields that use the rich text editor [95]:

Table 5. Rich text accessibility
Key command Function

Alt + 0 Opens window with accessibility instructions
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Key command Function

Alt + F10 Enters the toolbar or the tab list of the currently open dialog window

Ctrl +right-click Access native browser spell check menu

Tab Move to the right between groups of toolbar buttons

Shift + tab Move to the left between groups of toolbar buttons

Right arrow Move to the next button to the right

Left arrow Move to the next button to the left

Enter Activates a selected button or menu option

Table 6. Rich text navigation
Key command Function

Home Jumps to the beginning of the line

Ctrl + Home Jumps to the beginning of the document

End Jumps to the end of the line

Ctrl + End Jumps to the end of the document

PgDn Scrolls down the document by the length of the editing area

PgUp Scrolls up the document by the length of the editing area

Ctrl + L Opens the link window

Table 7. Rich text writing and formatting
Key command Function

Shift  + Enter Adds a line break

Ctrl + Z Undo the last change

Ctrl + Y Redo the last change

Ctrl + C Copies a text fragment to the clipboard

Ctrl + V, Shift + Insert Pastes a text fragment from the clipboard

Ctrl + X, Shift +  Del Cuts a text fragment to the clipboard

Ctrl + B Applies or removes bold formatting 

Ctrl + I Applies or removes italic formatting 

Ctrl + U Applies or removes underline

Ctrl + A Selects all field contents

Shift + Arrow Selects text letter by letter

Ctrl + Shift + Arrow Selects text word by word

Shift + End Selects a text fragment from the cursor to the end of the line.

Shift + Home Selects a text fragment from the beginning of the line to the cursor.

Ctrl + Shift + End Selects a text fragment from the cursor to the end of the document

Ctrl + Shift + Home Selects a text fragment from the beginning of the document to the cursor

Shift + PgDn Selects a text fragment of approximately the length of the editing area, starting from the cursor and go-
ing down

Shift + PgUp Selects a text fragment of approximately the length of the editing area, starting from the cursor and go-
ing up

Table 8. Review navigation
Key command Function

Tab Move from one highlighted comment to another

Application performance testing
Jama Software runs daily performance testing of Jama Connect in a self-hosted setup and continuously
monitors performance in our cloud environment.
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Self-hosted performance test results

These performance test results indicate a large self-hosted environment with 1,250 concurrent users.

• All requests were serviced during the testing period of 90 minutes with no un-intentional errors.
• 82% of requests were serviced in under 1 second.
• Longer running operations (like bulk updates and copies) were serviced within tolerances.

• Performance tests consider different user personas commonly found in our customer base, with the
most common and active users being Staff Engineers and Testers (Creators [646]).

• The total of unique, concurrent users spread across the personas was 1,250.
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• This graph shows the distribution of serviced requests during the test with response times expressed
in milliseconds (ms).

• 79% of requests were serviced in under 305ms with 99.5% of requests serviced in the consumer web
target of under 3 seconds.

Cloud performance test results

Jama Software continuously monitors application performance in the cloud. We utilize Real User Moni-
toring (RUM) technology to understand performance at the end-user level.

This performance monitoring includes network latency and transmission of the entire user request
across our global customer base.

• The Jama Connect cloud environment serves an average of over 6 million pages per month with hun-
dreds of millions of total requests.

• The P75 total page load time (from request to full browser paint) averages 3.41 seconds.
• The P75 total page load time (from request to full browser paint) averages 3.41 seconds. The cumu-

lative average of all page loads is under 3 seconds (2.66).
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• We gauge cloud performance on a consumer web scale, which is superior to most enterprise B2B
applications.

• First Input Delay (FID) averages 16.5ms across the cloud environment and is a critical component of
a responsive web experience.

Get help 
Do you have a question that's not covered in the Jama Connect User Guide?

Visit our Support Community where you can find answers, start discussions, share ideas, and access
developer documentation.

As part of your contract, your organization can get additional help from our support staff. Your organiza-
tion's named support contact can submit tickets directly to our support staff.

If you have a large team to train quickly, need to integrate Jama Connect with other tools, or want to go
beyond the basics, Jama Software offers training courses and other professional services to help you
be more successful.

• Education and Tutorials
• How-To Videos and other Resources
• Business Services

Let us know how we can help you.

Widgets
Widget Definition

Activities* Lists all the changes users make to an item: adding, relating, editing, deleting, and restoring.

Activities are listed in chronological order.

Users can search their activity history and filter on activity types.
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Widget Definition

Attachments* Shows external files attached to an item: images, documents, and spreadsheets.

NOTE
If your organization has a document management system, we recommend linking
from a Jama Connect item to the file in your document management system, rather
than duplicating files in Jama Connect.

Change Re-
quest*

Indicates that the item is linked to one or more change requests.

Example: If the icon includes a number, the item is linked to that many change requests and is automatical-
ly added if the item is linked to a change request.

Comments Indicates that a user made comments on the item.

Generally used for day-to-day collaboration with colleagues and tracking questions, decisions, and issues
about items.  These comments are only visible to users with permission to see the Jama Connect project.
Comments from reviews are separate and not included here.

Enabled by default.

Connected Users Shows a creator, editor, or someone who has commented, subscribed, or is @mentioned in an item. Also
shows users on upstream or downstream traced items.

Enabled by default.

Items to be
changed

Indicates when a user links to requirements, tests, and other items that require a change.

Visible only on item types where the Change Request widget is enabled.

Links* Adds links to an item by associating a link with that item or embedding a link in a rich text field within the
item.

NOTE
Hyperlinks can also be added in any rich text field.

Relationships* Shows items that are related for traceability.

Example: A requirement might be linked to upstream customer needs multiple downstream test cases.

Review com-
ments

Shows comments for reviews where this option is enabled.

Risk* Shows the link from requirements, mitigations, or verifications to a particular risk.
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Widget Definition

Sub items Shows the number of items directly under a currently viewed item in the Explorer Tree.

Example: The "System" component has five sub items:

Synchronized
Items*

Monitors differences between re-used items and containers.

Example: If a source item version changes, all re-used items are flagged as "out of sync" allowing users to
compare any differences.

Tags* Labels items so you can find similar items quickly.

Any user with create and edit permissions can add a new tag.

Users with Project Administrator permissions can edit or delete existing tags.

Test Runs Shows the results from a Test Plan and Test Cycle.

Jama Connect allows one Test Case to many Test Run results.

The number indicates the number of active Test Runs.

Visible only on item types where the "Use as" setting is Test Case:

Versions* Shows the number of versions.

A new version is created each time you change an item. You can compare versions or revert to a past item.

* Widget is only visible on item types where an organization admin has enabled [584] it.

Recommended

At minimum, enable these widgets:

• Activities
• Relationships
• Synchronized items
• Versions

Glossary
actions Actions help clarify and surface important conversations in the stream

by identifying a comment as one of three types: decision, question, or
issue.
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approver An approver reviews content against a standard and approves or re-
jects an item for correctness or completeness.

attachment Attachments are external files such as images, documents and spread-
sheets that can be attached to an item.

baseline A baseline captures the state of selected items and their relationships
within a project at a certain point in time.

Baseline Compared to Cur-
rent Report

The Baseline Compared to Current Report displays a side-by-side
comparison of items and relationships in a baseline and their current
versions.

Baseline Comparison Re-
port

The Baseline Comparison Report displays a side-by-side comparison
of items and relationships in two baselines.

baseline ID Baseline IDs are unique IDs assigned to each baseline. Baseline IDs
are automatically generated and numbered sequentially in the order
they were created. They can't be edited or duplicated.

batch transitions With batch transitions, you can select multiple items of the same item
type and transition them to a different workflow status. 

Bidirectional Traceability
Report

The Bidirectional Traceability Report displays upstream and down-
stream relationships for a selected container of items.

bookmarks Bookmarks are links to content you view frequently at the top of your
homepage.

bottom panel This panel slides in from the bottom of the center panel to give more
detail on items such as relationships, the activity stream, version histo-
ry, and merged items.

change request Change requests are items that call for a change to a specific product
or system. 

child item An item that falls hierarchically below a parent item of the same item
type.

collaborator license A collaborator license is a named or floating license that gives read-on-
ly privileges to those who need visibility into a project, but don’t need
editing rights. These users can view items, provide comments, partici-
pate in (but not create) reviews, execute test runs and log defects.

comments Comments are user-created messages found in the stream or in re-
views.

Compare View Compare View shows side by side content so you can compare differ-
ences between different item versions.

component A component is a structural container used to organize a project into
more manageable pieces. 

container Jama Connect uses three container types to help with organization of
document items: components, sets and folders.

contributor A contributor in a risk analysis can open, view, and edit any analysis to
which they are invited. Contributors must have a creator license in Ja-
ma Connect.
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coverage Coverage is the extent to which items are validated by another item. 

Coverage Explorer The Coverage Explorer is tool to view or export a set of items, includ-
ing related items that provide needed coverage.

creator license A creator license is a named or floating license that gives full read and
edit rights, and full access to reviews, for those who are active users
managing items and projects on a daily basis.

dashboard The dashboard can be configured to show key metrics about your
project, so you can see which areas of your work need attention.

dashboard widget Dashboard widgets are small embedded applications that compile and
display data from a single project or filter.

downstream In a relationship, the item that might be impacted by another is down-
stream from that item.

electronic signatures Electronic signatures consist of a username and password. In the case
of a review, a moderator can require electronic signatures to show that
a particular person in a particular role approves of the review. Electron-
ic signatures can also be added to baselines.

Explorer Tree The Explorer Tree organizes the sets, components, folders and items
in your project hierarchy.

export You can export data from Jama Connect as Word or Excel documents.
You can also customize the format of your export with Office Tem-
plates.

field A field holds a basic unit of data in an item type.

filter A filter is a subset of items, users, or reviews from a larger collection.
These are available as simple or advanced filters.

folder A folder is used to organize your work. Jama Connect uses item fold-
ers, baseline folders, and project folders.

global ID Global IDs are unique identifiers of items connected through synchroni-
zation. 

harm Harm is a physical injury or damage to the health of people, or damage
to property or the environment.

hazard A hazard is the potential source of a harm.

hazardous situation A hazardous situation is a circumstance in which people, property, or
the environment are exposed to one or more hazards.

homepage The homepage can show links to your most relevant content, like book-
marks, recent views, open reviews and stream comments or actions.

Impact Analysis Impact Analysis shows you the entire picture of all upstream and down-
stream related items that might be affected by changes.

import You can import data into Jama Connect from Microsoft Word, Excel,
and IBM Doors. 

Import Relationships Plugin The Import Relationships Plugin helps you batch create relationships
between existing items in the application.
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index The index is a list of information about each item that ensures proper
display, sorting, filtering, and searching of data.

item Items are the building blocks of Jama Connect. Projects are made up
of items. Items are made up of fields. Items can be containers (sets,
folders, components or parent items) or documents (features, require-
ments, test cases, tasks, defects). 

item counter The item counter automatically assigns numbers to items as part of
their ID.

item ID Item IDs are unique identifiers for each item that, unlike a Global IDs,
can't be duplicated.

Items in a Set Report The Items in a Set Report displays a tabular list of items in a set. 

item types Item types are the templates for sets used within each project.

item widget Item widgets add functionality to item types (for example, add links, at-
tachments, relationships and tags)

left panel The left panel is where you can find and organize your data. It contains
the Explorer Tree, advanced filters, releases, baselines, tests and
tags.  

license The license gives permission to an organization to install and run the
Jama Connect application.

license type The license type limits the possible permissions and roles that can be
granted to a user (for example, creator, stakeholder, test runner and re-
viewer).

List View List View shows data from multiple items in a table with a different field
in each column so you can sort, select and compare items at a glance. 

lock A lock makes items read-only. Locks can be set automatically or man-
ually.

moderator A review moderator is a user who creates and manages a review. A
risk moderator is a user who creates and manages a risk analysis.
Moderators must have a creator license type.

notifications Notifications are optional emails sent to groups or individuals alert you
when certain changes are made.

Office Templates Microsoft Office Templates are Word documents and Excel spread-
sheets that allow you to add formatting to your exports.

organization An organization represents the entire group of users who have access
to your instance of Jama Connect as well as all the projects, items, and
data. 

organization administrator An organization administrator has administrative control of the Jama
Connect application. An organization might have one or more organi-
zation administrators. 

P1 The probability that a hazardous situation occurs.

P2 The probability that a hazardous situation results in harm.
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permissions Permissions allow users to do things such as access, modify and de-
lete items or perform other specific tasks.

pick lists Pick lists are a set of specific values that can be entered into a field.

project A project is a way of organizing your data in Jama Connect and is
made up of items, filters, baselines, releases, reports and tests.

project administrator A project administrator is a role that has the necessary permissions to
manage a particular project.

project key The project key is a unique identifier, automatically created with each
project, that makes up the first part of each item's Unique ID. 

Projects workflow You can set up a workflow in Projects, so that users at your organiza-
tion can move items in your project along a similar path as they pro-
gress. 

Reading View Reading View shows text and images for a particular group of items so
you can read through selected items like a document.

relationship Relationships link items together and can help assess the impact an
item or group of items can have on other items.

Relationship Status Indica-
tor

The Relationship Status Indicator shows how many relationships an
item has, as well as whether those relationships meet the project's re-
lationship rules.

release  A release is a group of items that are developed together and mapped
to a specific completion date. 

Release Status Report The Release Status Report displays the current state of the items with-
in a particular release.

Replicated snapshots Replicated snapshots are backups of the admin console settings,
Docker containers and the Jama Connect license.

report A report is a document that helps you analyze the current status and
progress in your work. Reports can include graphs, tabular data, met-
rics and other roll-ups.

required fields Required fields are string, text or date fields that are configured so that
the user must enter data into the field before saving an item.

REST API Jama Software REST API is an application program interface to assist
developers in a clean, straightforward integration with the application.

reuse Reuse is the duplication of an item within a project or to a different
project where it can be modified without affecting the original item.

reuse administrator A reuse administrator is a role with the permissions needed to manage
reuse.

review Reviews help teams, stakeholders and customers collaborate in Jama
Connect discuss, review, revise and approve information.

review administrator A review administrator is a role with the permissions needed to man-
age reviews.

Jama Connect User Guide

663



Review Center Stats Report The Review Center Stats Report displays the progress of a specific re-
view.

reviewer A reviewer participates in a review to provide feedback. 

reviewer license A reviewer license is a named or floating license that grants permission
to participate in reviews, act as approvers, moderators, or review ad-
ministrators, and respond to comments in the stream. A reviewer li-
cense doesn't allow users to initiate reviews or access items in the
core project.

Reviews workflow A reviews workflow is a tool for moderators to update the status of re-
viewed items. When configured, the reviews workflow automatically up-
dates field values for review items of the same type and review status. 

right panel The right panel slides out to provide more specific information about
the data you selected.

risk administrator A risk administrator has full permissions to create and edit risk tem-
plates and analyses and manage participants.

risk control measures The procedures or requirements implemented to reduce risk levels.

risk control options The means by which a risk is reduced. 

risk control verification Confirmation that specified requirements were fulfilled.

risk ID Risk IDs are unique IDs assigned to each row in an analysis. Risk IDs
are automatically generated across all analyses and numbered se-
quentially in the order they were created.

risk management Risk management is the systematic application of management poli-
cies, procedures and practices to the tasks of analyzing, evaluating,
controlling and monitoring risk. (ISO 14971)

role A role is a set of permissions granted to a user so that they can per-
form a particular job. 

search You can search an index of all database fields, as well as text within
Word, PDF or text attachments, to bring up a list of resulting items.

sequence of events The events that lead to a hazardous situation.

set A structural container with configurable access rights, used to group
items of the same type. It can also contain folders, text Items, child text
items and child items of the same type.

set key The set key identifies item sets within your project and doesn't have to
be unique across sets or projects.

severity Severity is the measure of the possible consequences of a hazard.

signature meaning Signature meaning is a system setting that states the meaning of the
electronic signature. It's required for FDA 21 CFR Part 11 compliance.
In Jama Connect, it defaults to "I approve this review" and can't be
modified. The signature meaning is visible in review invitations.

signer role A signer role indicates the capacity in which an approver provided their
electronic signature in a review. Signer roles are created from user
group names.
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Single Item View Single Item View displays the information about one item in the center
panel.

stakeholder license A stakeholder license is a named license that gives read-only privileg-
es to those who need visibility into a project, but don’t need editing
rights. Stakeholders can view items, provide comments and act as re-
viewers.

stream The stream is a collection of the most recent comments and activities
(adds, deletes, or edits).

suspect links Suspect links on an item mean it might no longer be correct or com-
plete, because changes were made to items upstream.

synchronization Synchronization monitors for differences between reused items and
containers. When differences exist, users can update the data for
those items or containers.

system administrator The system administrator handles the overall installation, setup, and
configuration of Jama Connect, and doesn't have access to projects.
They don't require a special license and are the only user who can log
in to the system as "root user."

system fields System fields (like, name,  test steps, test case status, and review sta-
tus) are automatically created to provide system functionality and can't
be disabled or deleted.

system health report The system health report is an optional feature that notifies administra-
tors of areas of the application that can affect performance and user
experience.

tags Tags are labels you can attach to items that can help you find items
that have something in common.

Task List with Estimates Re-
port

The Task List with Estimates Report displays all item types and sums
their estimates if applicable.

temporary license A temporary license is a 30-day full creator license, automatically gran-
ted to a non-licensed individual whose email address is used to invite
them to a review or to comment in the stream. It has no default permis-
sions except for the discussion thread or review to which they were in-
vited, although an organization administrator can add permissions.

test case Test cases are items that contain the tests needed to validate or verify
product features or systems.

test case status Test case status is an automatically calculated status that indicates the
state of the last edited test run associated with that test case.

test cycle Test cycles convert groups of test cases into a series of test runs that
are ready for execution. 

test group Test groups let you combine and label similar tests in a test plan.

test plan A test plan is an item that documents the overall strategy for validating
or verifying that a product or system meets its design specifications
and requirements. 

Test Plan Detail Report The Test Plan Detail Report displays the details of a test plan.
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test run A test run is an item used to record results for a test case you ran
against your product.

test runner license A test runner license is a named license that includes basic permis-
sions to read and review, as well as the additional ability to create test
plans and defects, and execute test runs. 

test run status Test run status indicates the current state of a test run, and is used in
calculating test case status.

test steps Test steps are distinct steps used to run a test. 

text item Text items are unique; some rules apply while others do not. They live
outside the boundary of other item types and aren't designed to func-
tion as a full feature. For example, text items can be used as part of a
mixed item set, unlike other types.

thread dumps A thread dump is a snapshot of the state of your application instances'
processes at a point in time.

toolbar The toolbar is located at the top of the center panel.

traceability Traceability shows the relationship between items that depend upon
and define each other. You can always travel upstream or downstream
to get more context and trace product definition from high level require-
ments all the way through final tests.

trace matrix The trace matrix is a visual representation of relationships within a
project.

Trace Relationships Report The Trace Relationships Report displays items with their downstream
relationships.

Trace View Trace View shows related upstream and downstream items, missing
relationships, and item details in context of their relationship.

trial license A trial license is a 30-day license granted to new users who sign up for
a trial of Jama Connect on jamasoftware.com.

unique ID Unique IDs, or item IDs, identify an item with a project key, set key, and
a set counter. Unique IDs remain the same even if item name or con-
tent is changed. They can't be edited or duplicated.

upstream In a relationship, the item that can impact another item is said to be up-
stream from that item.

user A user is a basic role associated with a unique Jama Connect login.
Each user has their own license type, groups, and permissions.

user group User groups are an efficient way to manage notifications, permissions,
access, and actions for multiple users at a time.

User Import Plugin With the User Import Plugin, organization administrators can add multi-
ple users at once by importing a spreadsheet. 

User List Report The User List Report displays a list of all the active and inactive users
associated with the organization.
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version A version is one of a sequence of copies of an item, each incorporating
new modifications. There are versions of reviews and versions of
items.

viewer A viewer can read, but not edit, a risk analysis. 

widgets Widgets are small embedded applications that add functionality to the
dashboard or item types.

workflow A workflow is an automated set of transitions from one status to anoth-
er, over the course of an item's lifespan. 
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